QSK60G, QSV81/91 - CM700/CM2358 K110, QSK78 G CM2358, QSK78 G CM2358, QSK60G, QSV81/91 - CM700/CM2358 K110,

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10/10 LAMP: Amber SRT: | Engine Speed/Position Sensor Circuit - Lost One of Two Signals from the Magnetic Pickup Sensor - Abnormal Rate of Change. No engine speed signal detected from either the main or backup speed sensors. | None on performance.
engine speed sensor

Circuit Description

The engine speed sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the speed sensor and a return circuit. As the teeth on the crankshaft speed ring move past the speed sensor, a signal is generated on the speed sensor signal circuit. The ECM interprets this signal and converts it to an engine speed.

Component Location

The engine speed sensors are located at the rear of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the engine speed sensor 1.

The Engine Control Module (ECM) detected a loss of the engine speed sensor 2.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Open in both engine position sensor circuits to one ECM.
Refer to Troubleshooting Fault Code 121.

Last Modified: 20-Jul-2015
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 135.

Last Modified: 20-Jul-2015


Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 136

Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 136 PID: SPN: 1208 FMI: 3/3 LAMP: Amber SRT: | Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil filter intake pressure circuit. | None on performance.
Pre-oil filter pressure sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the oil filter intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The oil filter intake pressure sensor provides a signal to the ECM on the oil filter intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure before the oil filters. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The oil filter intake pressure sensor is located on the oil filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged sensor
Refer to Troubleshooting Fault Code 136.

Last Modified: 20-Jul-2015


Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 137

Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 137 PID: SPN: 1208 FMI: 4/4 LAMP: Amber SRT: | Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected in the engine oil filter intake pressure circuit. | None on performance.
Pre-oil filter pressure sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the oil filter intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The oil filter intake pressure sensor provides a signal to the ECM on the oil filter intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure before the oil filters. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The oil filter intake pressure sensor is located on the oil filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged sensor
Refer to Troubleshooting Fault Code 137.

Last Modified: 20-Jul-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141.

Last Modified: 20-Jul-2015


Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 142

Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 142 PID: P100 SPN: 100 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine oil pressure (rifle) has exceeded the high warning threshold. | None on performance.
oil pressure sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The engine oil pressure (rifle) has exceeded the high warning threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged sensor
Refer to Troubleshooting Fault Code 142.

Last Modified: 20-Jul-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143.

Last Modified: 23-Jul-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144.

Last Modified: 20-Jul-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145.

Last Modified: 20-Jul-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 108°C [226°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

Refer to Troubleshooting Fault Code 146.

Last Modified: 23-Jul-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 117°C [ 242°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151.

Last Modified: 20-Jul-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153.

Last Modified: 29-Jul-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Possible reduced engine performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154.

Last Modified: 20-Jul-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manfiold air temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 20-Jul-2015


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 PID: SPN: 3464 FMI: 7/7 LAMP: Red SRT: | Electronic Throttle Control Actuator - Mechanical system not responding or out of adjustment. The engine intake air throttle actuator has failed the auto zero span check. | Possible reduced engine performance. The engine will shut down or will not start.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor signal is incorrect.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 177.

Last Modified: 20-Jul-2015


Fault Code Path Selection

FAULT CODE 224-fc187
Fault Code Path Selection

Is the sensor supply 2 circuit fault code generated from ECM source address 00? | Go to 224-fc187sa00
Is the sensor supply 2 circuit fault code generated from ECM source address 39? | Go to 224-fc187sa39

Last Modified: 22-Jul-2015


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | Engine power derate.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 197.

Last Modified: 23-Jul-2015


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 212.

Last Modified: 20-Jul-2015


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine harness
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 213.

Last Modified: 20-Jul-2015


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214.

Last Modified: 20-Jul-2015


Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 219

Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 219 PID: P17 SPN: 1380 FMI: 1/17 LAMP: Maintenance SRT: | Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Least Severe Level. The ECM has diagnosed that the engine oil has become low. | None on performance.
Oil Level Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the oil level switch on the sensor supply circuit. The ECM also provides a ground on the switch return circuit. The oil level switch provides a signal to the ECM on the oil level switch signal circuit. This signal voltage changes based on the engine oil level.

Component Location

The OEM switch is located in the engine oil supply system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine oil has become low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Incorrect oil level
  • A malfunctioning engine oil level switch.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 219.

Last Modified: 20-Jul-2015


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 13-Oct-2015


Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 228

Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 228 PID: P109 SPN: 109 FMI: 1/1 LAMP: Red SRT: | Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Low coolant pressure has been detected. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant pressure was less than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • A malfunctioning radiator cap.
  • A malfunctioning coolant pressure sensor.
  • A malfunctioning water pump.
Refer to Troubleshooting Fault Code 228.

Last Modified: 20-Jul-2015


Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 231

Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: P109 SPN: 109 FMI: 3/3 LAMP: Amber SRT: | Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at coolant pressure circuit. | None on performance.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
  • A malfunctioning coolant pressure sensor.
Refer to Troubleshooting Fault Code 231.

Last Modified: 20-Jul-2015


Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 232

Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: P109 SPN: 109 FMI: 4/4 LAMP: Amber SRT: | Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at coolant pressure circuit. | None on performance.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
  • Supply wire open or shorted to ground.
  • A malfunctioning coolant pressure sensor.
Refer to Troubleshooting Fault Code 232.

Last Modified: 20-Jul-2015


Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 233

Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 233 PID: P109 SPN: 109 FMI: 1/18 LAMP: Amber SRT: | Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The ECM has diagnosed that the HT Coolant pressure has become low. | None on performance.
HT Coolant Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running for more than 20 seconds.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the HT Coolant pressure has become low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Engine coolant level low
  • Cylinder head or gasket damaged (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • A malfunctioning engine coolant level sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 233.

Last Modified: 20-Jul-2015


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Possible reduced engine performance.
Engine Crankshaft Position and Camshaft Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

The camshaft position sensor is located in the gear cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 234.

Last Modified: 20-Jul-2015


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant is severely low. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was greater than 3-VDC for more than 30 seconds, indicating severely low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
Refer to Troubleshooting Fault Code 235.

Last Modified: 20-Jul-2015


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238.

Last Modified: 13-Oct-2015


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 13-Oct-2015


Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 248

Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 248 PID: P173 SPN: 173 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Exhaust gas temperature is above engine protection. | Progressive power derate increasing in severity from time of alert.
Exhaust gas Temperature Sensor

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • An engine speed derate will occur when the fault is registered.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include.

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 248.

Last Modified: 13-Oct-2015


Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 253

Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 253 PID: P98 SPN: 98 FMI: 1/1 LAMP: Red SRT: | Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level. Very low oil level. | Engine will be shut down.
Sump Oil Level Sensor

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil level switch is located on the engine oil dipstick housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the engine is OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low engine oil level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Low engine oil level.
  • Damaged sensor
Refer to Troubleshooting Fault Code 253.

Last Modified: 20-Jul-2015


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at fuel shutoff valve circuit | Engine will be shut down.
Fuel Shut Off Valve

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

Low voltage detected at fuel shutoff valve circuit

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Short circuit to ground in the engine harness, connectors, or fuel shutoff valve.

Refer to Troubleshooting Fault Code 254.

Last Modified: 20-Jul-2015


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine fuel temperature circuit. | None on performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine fuel temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunctioning fuel temperature sensor
Refer to Troubleshooting Fault Code 263.

Last Modified: 20-Jul-2015


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine fuel temperature sensor circuit. | None on performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine fuel temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning fuel temperature sensor
Refer to Troubleshooting Fault Code 265.

Last Modified: 20-Jul-2015


Electronic Fuel Injection Control Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 277

Electronic Fuel Injection Control Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: S18 SPN: 633 FMI: 7/7 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve - Mechanical System Not Responding or Out of Adjustment, the Fuel Control Valve has failed it's spring check. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) has reported to the Engine Control Module (ECM) that it has failed its spring check diagnostic.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged engine harness
  • Damaged FCV.
Refer to Troubleshooting Fault Code 277.

Last Modified: 21-Jul-2015


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343.

Last Modified: 20-Jul-2015


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. Invalid switch configuration adjustable parameter setting have been detected by the Engine Control Module (ECM). | Various optional switch inputs to the ECM may not operate correctly.
Engine Control Module (ECM)

Circuit Description

The Orginal Equipment Manufacturer (OEM) wiring harness connects multiple outputs or switched inputs to the ECM which can be enabled or disabled using INSITE™ electronic service tool, such as such as the accelerator interlock/engine torque limit switch or the clutch/engine protection override switch. Many of the outputs and switched inputs share a common wire on the OEM wiring harness. Refer to the engine wiring diagram to determine which features share common wires in the OEM harness.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected features which share a common input or output to the ECM were simultaneously enabled..

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Many of the outputs and switched inputs share a common wire on the OEM wiring harness. If two features that share a common OEM wire are enabled simultaneously in the ECM, this fault code will be logged. To disable the fault code, disable one of the features on the shared OEM wire. For example, if the accelerator interlock switch and powertrain protection torque limit switch are both enabled in the ECM, either disable one of the features with INSITE™ electronic service tool or configure one of the features to be multiplexed using the SAE J1939 multiplexing feature.

Refer to Troubleshooting Fault Code 346.

Last Modified: 20-Jul-2015


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352.

Last Modified: 13-Oct-2015


Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 354

Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: SPN: 3563 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Temperature Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged wiring harness
  • A damaged intake manifold pressure sensor
Refer to Troubleshooting Fault Code 354.

Last Modified: 20-Jul-2015


Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 355

Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 355 PID: SPN: 3563 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Least Severe Level. Low intake manifold pressure detected. | Possible reduced engine performance.
Intake Manifold Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged wiring harness
  • A damaged intake manifold pressure sensor
Refer to Troubleshooting Fault Code 355.

Last Modified: 20-Jul-2015


Engine Failed Automatic Start - Condition Exists

FAULT CODE 359

Engine Failed Automatic Start - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 359 PID: S124 SPN: 1664 FMI: 11/31 LAMP: Red SRT: | Engine Failed Automatic Start - Condition Exists. The ECM has diagnosed that the engine has failed to start. | Engine may not start. Engine will shut down.
Engine Speed and Position Sensors.

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

Both engine speed/position sensors are located on the back side of the front gear housing above the fuel pump drive.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is attempting to start.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine has failed to start.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The failed to start fault will caue the start cycle to stop and a shutdown fault will occur.

Refer to Troubleshooting Fault Code 359.

Last Modified: 21-Sep-2015


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 386.

Last Modified: 13-Oct-2015


SAE J1587/J1922 Datalink - Data Erratic, Intermittent, or Incorrect

FAULT CODE 412

SAE J1587/J1922 Datalink - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 SPN: 608 FMI: 2/2 LAMP: None SRT: | SAE J1587/J1922 Datalink - Data Erratic, Intermittent, or Incorrect. The ECM has diagnosed that th J1587 communication wires have been either shorted or open circuited. | None on performance.
ECM

Circuit Description

J1587 is the communication network between the ECM and the Ignition module.

Component Location

Located in the Engine Harness

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the J1587 communication wires have been either shorted or open circuited.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

J1587 is a communication network between the ECM and the Ignition module.

Refer to Troubleshooting Fault Code 412.

Last Modified: 20-Jul-2015


SAE J1587/J1922 Datalink - Abnormal Update Rate

FAULT CODE 414

SAE J1587/J1922 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 414 PID: S250 SPN: 608 FMI: 9/9 LAMP: None SRT: | SAE J1587/J1922 Datalink - Abnormal Update Rate. The ECM has diagnosed that the J1587 communications have timed out. | None on performance.
ECM

Circuit Description

J1587 is the communication network between the ECM and the Ignition module.

Component Location

Located in the Engine Harness

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the J1708 communications have timed out.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

J1587 is a communication network between the ECM and the Ignition module.

Refer to Troubleshooting Fault Code 414.

Last Modified: 20-Jul-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure sensor
Refer to Troubleshooting Fault Code 415.

Last Modified: 20-Jul-2015


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 421.

Last Modified: 20-Jul-2015


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | None on performance.
SAE J1939 Datalink 1 Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Shorted or open J1939 data link wiring.
Refer to Troubleshooting Fault Code 426.

Last Modified: 20-Jul-2015


SAE J1939 Datalink - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | J1939 Data Link - Abnormal Update Rate. Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine will only idle.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • The external OEM controlling device has malfunctioned or can no longer transmit on the data link.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 427.

Last Modified: 20-Jul-2015


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441.

Last Modified: 23-Jul-2015


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442.

Last Modified: 23-Jul-2015


Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 453

Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 453 PID: P149 SPN: 1241 FMI: 3/3 LAMP: Amber SRT: | Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. The Gas Mass Flow Sensor has been shorted to a power source. | Possible reduced engine performance.
Gas Mass Flow Sensor

Circuit Description

The Gas Mass Flow Sensor recieves 5 volts from the ECM, and has a sheilded return and signal wire.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the gas mass flow sensor has been shorted to a power source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 453.

Last Modified: 20-Jul-2015


Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 454

Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 454 PID: P149 SPN: 1241 FMI: 4/4 LAMP: Amber SRT: | Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The Gas Mass Flow Sensor has been shorted to ground. | Possible reduced engine performance.
Gas Mass Flow Sensor

Circuit Description

The Gas Mass Flow Sensor recieves 5 volts from the ECM, and has a sheilded return and signal wire.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the gas mass flow sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 454.

Last Modified: 20-Jul-2015


Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 459

Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 459 PID: S67 SPN: 726 FMI: 4/4 LAMP: Red SRT: | Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source. The spark timing control line has been shorted to ground. | Engine will be shut down.
Spark Timing Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark timing control line has been shorted to a power source, shorted to ground, or open circuited.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
Refer to Troubleshooting Fault Code 459.

Last Modified: 20-Jul-2015


Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 462

Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 462 PID: S66 SPN: 725 FMI: 4/4 LAMP: Red SRT: | Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source. The spark refernce control line has been shorted to a power source, shorted to a ground, or open circuit. | Engine will be shut down.
Spark reference control line

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark reference control line has been shorted to a power source, shorted to ground, or open circuited.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
Refer to Troubleshooting Fault Code 462.

Last Modified: 20-Jul-2015


Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P444 SPN: 444 FMI: 1/18 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. The ECM has diagnosed that isolated battery voltage has dropped too low. | Engine will be shut down.
ECM

Circuit Description

OEM supplies 24VDC to the engine through the DC1 and DC2 connectors.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the isolated battery voltage has dropped too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • A weak or damaged battery.
Refer to Troubleshooting Fault Code 477.

Last Modified: 20-Jul-2015


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P444 SPN: 444 FMI: 0/16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. The ECM has diagnosed that the isolated battery voltage is too high. | Engine will be shut down.
ECM

Circuit Description

OEM supplies 24VDC to the engine through the DC1 and DC2 connectors.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the isolated battery voltage is too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is logged when the ECM battery supply voltage exceeds +36-VDC. Causes of this fault code include:

Refer to Troubleshooting Fault Code 478.

Last Modified: 20-Jul-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold temperature sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Maximum engine operating speed will be decreased.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 488.

Last Modified: 20-Jul-2015


Engine Turbocharger Wastegate Actuator 1 Position - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 545

Engine Turbocharger Wastegate Actuator 1 Position - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 545 PID: S32 SPN: 1188 FMI: 7/7 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Mechanical system not responding or out of adjustment. The turbocharger wastegate is unable to meet commanded position. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

The turbocharger wastegate location can vary depending on engine model and application.

The turbocharger wastegate position sensors are internal to the turbocharger wastegate assembly and can not be serviced seperately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The turbocharger wastegate was unable to reach the commanded position for more than 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Intermittent open or short in the wiring harness
  • Malfunctioning turbocharger wastegate
Refer to Troubleshooting Fault Code 545.

Last Modified: 23-Jul-2015


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Most Severe Level. High crankcase pressure detected. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in a right bank hand hole cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Internal engine damage.
  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
Refer to Troubleshooting Fault Code 556.

Last Modified: 23-Jul-2015


Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 561

Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 561 PID: S90 SPN: 1352 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 561.

Last Modified: 20-Jul-2015


Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 562

Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 562 PID: S91 SPN: 1353 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 562.

Last Modified: 20-Jul-2015


Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 563

Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 563 PID: S92 SPN: 1354 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 563.

Last Modified: 20-Jul-2015


Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 564

Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 564 PID: S93 SPN: 1355 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 564.

Last Modified: 20-Jul-2015


Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 565

Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 565 PID: S94 SPN: 1356 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 565.

Last Modified: 20-Jul-2015


Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 566

Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 566 PID: S95 SPN: 1357 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 566.

Last Modified: 20-Jul-2015


Engine Cylinder 7 (A4) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 567

Engine Cylinder 7 (A4) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 567 PID: S96 SPN: 1358 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 7 (A4) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 567.

Last Modified: 20-Jul-2015


Engine Cylinder 8 (B4) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 568

Engine Cylinder 8 (B4) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 568 PID: S97 SPN: 1359 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 8 (B4) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 568.

Last Modified: 20-Jul-2015


Engine Cylinder 9 (A5) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 569

Engine Cylinder 9 (A5) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 569 PID: S98 SPN: 1360 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 9 (A5) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 569.

Last Modified: 20-Jul-2015


Engine Cylinder 1 (A1) Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 571

Engine Cylinder 1 (A1) Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 571 PID: S90 SPN: 1352 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 1 (A1) Knock - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 571.

Last Modified: 20-Jul-2015


Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 572

Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 572 PID: S91 SPN: 1353 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 572.

Last Modified: 20-Jul-2015


Engine Cylinder 3 (A2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 573

Engine Cylinder 3 (A2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 573 PID: S92 SPN: 1354 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 3 (A2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 573.

Last Modified: 20-Jul-2015


Engine Cylinder 4 (B2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 574

Engine Cylinder 4 (B2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 574 PID: S93 SPN: 1355 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 4 (B2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 574.

Last Modified: 20-Jul-2015


Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 575

Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 575 PID: S94 SPN: 1356 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 575.

Last Modified: 20-Jul-2015


Engine Cylinder 6 (B3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 576

Engine Cylinder 6 (B3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 576 PID: S95 SPN: 1357 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 6 (B3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 576.

Last Modified: 20-Jul-2015


Engine Cylinder 7 (A4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 577

Engine Cylinder 7 (A4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 577 PID: S96 SPN: 1358 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 7 (A4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 577.

Last Modified: 20-Jul-2015


Engine Cylinder 8 (B4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 578

Engine Cylinder 8 (B4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 578 PID: S97 SPN: 1359 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 8 (B4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 578.

Last Modified: 20-Jul-2015


Engine Cylinder 9 (A5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 579

Engine Cylinder 9 (A5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 579 PID: S98 SPN: 1360 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 9 (A5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 579.

Last Modified: 20-Jul-2015


Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 584.

Last Modified: 21-Jul-2015


Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 585.

Last Modified: 21-Jul-2015


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 595

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level. High turbocharger speed has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was greater than 150,000 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

To validate the repair, start the engine and use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 595.

Last Modified: 21-Jul-2015


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 641

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 641 PID: S129 SPN: 1137 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 641.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 642

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 642 PID: S131 SPN: 1139 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sesnor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 642.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 643

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 643 PID: S133 SPN: 1141 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 643.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 644

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 644 PID: S135 SPN: 1143 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 644.

Last Modified: 29-Jul-2015


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 645

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 645 PID: S137 SPN: 1145 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 645.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 646

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 646 PID: S139 SPN: 1147 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 646.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 647

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 647 PID: S141 SPN: 1149 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 647.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 648

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 648 PID: S143 SPN: 1151 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 648.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 652

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 652 PID: S130 SPN: 1138 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 652.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 653

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 653 PID: S132 SPN: 1140 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 653.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 654

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 654 PID: S134 SPN: 1142 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 654.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 655

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 655 PID: S136 SPN: 1144 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 655.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 656

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 656 PID: S138 SPN: 1146 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 656.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 657

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 657 PID: S140 SPN: 1148 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 657.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 658

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 658 PID: S142 SPN: 1150 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 658.

Last Modified: 20-Jul-2015


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 686

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 686 PID: P103 SPN: 103 FMI: 2/2 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected by the ECM. | None on performance.
Turbocharger Speed Sensor

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was greater than the speed that is physically achievable by the turbocharger.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Usually this fault code indicates a faulty turbocharger speed sensor or incorrect speed signals from the sensor. This fault can be caused by malfunctions in the following components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM power supply or grounds

If the fault occurs intermittently:

  • Look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).
  • Be sure that the ECM power supply and ground circuits are in good condition and that this power supply is not shared with other vehicle electronics.
Refer to Troubleshooting Fault Code 686.

Last Modified: 21-Jul-2015


Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low turbocharger speed detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 600 rpm for more than 1 second when the engine speed was greater than 1200 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Items that can cause this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.
Refer to Troubleshooting Fault Code 687.

Last Modified: 21-Jul-2015


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged tone wheel
  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code 689.

Last Modified: 21-Jul-2015


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code 691.

Last Modified: 21-Jul-2015


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 692, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code 692.

Last Modified: 21-Jul-2015


Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3/3 LAMP: Amber SRT: | Engine ECU Temperature Sensor Circuit - Voltage Above normal, or Shorted to High source. High signal voltage or open circuit detected at the internal ECM temperature sensor. | None on performance.
ECM

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 697.

Last Modified: 21-Jul-2015


Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4/4 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the internal ECM temperature sensor. | None on performance.
ECM

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 698.

Last Modified: 29-Jul-2015


Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 742

Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 742 PID: S314 SPN: 1176 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the turbocharger compressor intake pressure sensor circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The turbocharger compressor intake pressure sensor is located at the compressor inlet of the turbochager.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
  • Signal circuit shorted to return or ground in the sensor
  • Damaged sensor
Refer to Troubleshooting Fault Code 742.

Last Modified: 21-Jul-2015


Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 751

Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 751 PID: P149 SPN: 1241 FMI: 2/2 LAMP: Amber SRT: | Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect. The Gas Mass Flow sensor has failed in range. | Possible reduced engine performance.
Gas Mass Flow Sensor

Circuit Description

The Gas Mass Flow Sensor recieves 5 volts from the ECM, and has a sheilded return and signal wire.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the gas mass flow sensor has failed in range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 751.

Last Modified: 21-Jul-2015


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 781

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 781 PID: S206 SPN: 1231 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate. No communication or an invalid data transfer rate detected on the J1939 data link between the primary ECM and one or more secondary ECMs. | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 2 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive an one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the engine control modules (ECM) to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted on both banks of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The primary engine control module (ECM 1) lost communication with one or more secondary ECMs via the J1939 data link 2.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A secondary ECM is not receiving power from the battery supply circuit in the harness. This can be caused by an open circuit in the power supply wire, blown ECM fuse, or open return wire.
  • Tripped circuit breaker in the OEM power supply circuit.
  • An open or short circuit in the SAE J1939 datalink circuit
  • Intermittent communication between the ECMs.
Refer to Troubleshooting Fault Code 781.

Last Modified: 21-Jul-2015


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: P105 SPN: 105 FMI: 10/10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change. Possible damage to the intake valves has been detected. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) uses the intake manifold temperature and exhaust gas temperature as inputs for this diagnostic.

Component Location

The intake manifold temperature sensor 1 is located in intake manifold 1.

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the following conditions are met:

  • Engine speed greater than 1300 RPM.
  • Intake manifold 1 temperature is greater than 76C [169F].

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • The difference between the left bank and right bank exhaust gas temperature is greater than a calibrateable threshold.
  • The intake manifold 1 temperature changes by more than a calibrateable amount for a few seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This feature provides protection for the charge-air system, valve train, and power cylinders when a rapid rise in intake manifold charge-air temperature occurs; for example, as a result of a backfire in the intake manifold. The ECM monitors the change in the intake manifold 1 temperature sensor over a period of time. If the intake manifold temperature rate of change is excessive, the ECM logs a fault and requests a shutdown.

The recommended checks are as follows:

• Check for external coolant leaks between each cylinder head and the block. Signs of coolant and/or oil leaks would indicate the cylinder heads have lifted during the intake manifold backfire event.

• Check the air filter elements and air filter housing for damage.

  • Boost leaks in the charge-air cooler plumbing

• Check for free movement of the throttle throughout the full range.

• Check throttle plate alignment.

• Check the charge-air cooler for leaks (coolant and air/fuel mixture). Check the charge-air cooler element for any damage resulting from the intake manifold over-pressure event.

  • Remove the valve covers. Check valve clearances. Check for any abnormalities or mis-aligned rocker gear, valve stems, valve spring assemblies, and displaced valve collets.

- Check the intake valve retainer ring, if any damage detected on the valve retainer ring, further inspect on intake valve collets is required.

  • Bar the engine over by hand. Any tightness when rotating must be investigated. Dropped intake/exhaust valves and coolant leakage internal to the power cylinders must be considered, which can result in further consequential damage to power cylinder components.
  • Inspect the turbocharger compressor wheel blades for signs of damage and contact with the compressor housing. If there are any signs of damage, then the turbocharger must be replaced before starting the generator set.
  • Following start-up of the generator set, carefully monitor individual cylinder exhaust temperatures via the Human Machine Interface. Any cold cylinders must be investigated using appropriate investigation and troubleshooting methods.
  • Check throttle pressure differential sensor.
Refer to Troubleshooting Fault Code 783.

Last Modified: 21-Jul-2015


Engine Turbocharger 1 Boost Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1213

Engine Turbocharger 1 Boost Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1213 PID: S309 SPN: 1127 FMI: 0/16 LAMP: Red SRT: | Engine Turbocharger 1 Boost Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. The ECM has diagnosed that the compressor outlet pressure has become too high. | Engine will be shut down.
ECM

Circuit Description

The engine control module (ECM) provides a 5 volt supply to compressor outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the ECM on the compressor outlet pressure sensor signal circuit.

Component Location

Located between the turbo outlet and charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the compressor outlet pressure has become too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This feature provides protection for the charge-air system, valve train, and power cylinders when a rapid rise in compressor outlet pressure occurs (an intake manifold over-pressure condition). The ECM compares the current compressor outlet pressure reading (p-1) with the immediately preceding compressor outlet pressure reading (p), and if the difference between p-1 and p (Delta p) exceeds 16 psia for more than 0.01 seconds, the ECM logs a fault and requests a shutdown.

Refer to Troubleshooting Fault Code 1213.

Last Modified: 20-Jul-2015


Engine Derate - Condition Exists

FAULT CODE 1243

Engine Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1243 PID: S151 SPN: 3644 FMI: 11/31 LAMP: Amber SRT: | Engine Derate - Condition Exists. The Engine Control Module (ECM) has either issued a derate request or has self derated the engine. | Engine power derate.
ECM

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has either issued a derate request or has self derated the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The regulated derate conditions may vary depending on the OEM and local regulations.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Causes for this fault code include:

  • A malfunctioning turbocharger
  • Fuel system malfunction
  • Malfunctioning turbocharger wastegate
  • Low oil pressure
Refer to Troubleshooting Fault Code 1243.

Last Modified: 21-Jul-2015


Fault Code Path Selection

FAULT CODE 224-fc1257
Fault Code Path Selection

Is the fault code generated from ECM source address 00? | Go to 224-fc1257sa00
Is the fault code generated from ECM source address 01? | Go to 224-fc1257sa01
Is the fault code generated from ECM source address 39? | Go to 224-fc1257sa39

Last Modified: 27-Jul-2015


Engine Cylinder 10 (B5) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1274

Engine Cylinder 10 (B5) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1274 PID: S99 SPN: 1361 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 10 (B5) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1274.

Last Modified: 20-Jul-2015


Engine Cylinder 10 (B5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1275

Engine Cylinder 10 (B5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1275 PID: S99 SPN: 1361 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 10 (B5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1275.

Last Modified: 20-Jul-2015


Engine Cylinder 11 (A6) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1277

Engine Cylinder 11 (A6) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1277 PID: S100 SPN: 1362 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 11 (A6) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1277.

Last Modified: 20-Jul-2015


Engine Cylinder 12 (B6) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1281

Engine Cylinder 12 (B6) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1281 PID: S101 SPN: 1363 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 12 (B6) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1281.

Last Modified: 20-Jul-2015


Engine Cylinder 12 (B6) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1282

Engine Cylinder 12 (B6) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1282 PID: S101 SPN: 1363 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 12 (B6) Knock Sensor Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1282.

Last Modified: 20-Jul-2015


Engine Cylinder 13 (A7) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1285

Engine Cylinder 13 (A7) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1285 PID: S102 SPN: 1364 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 13 (A7) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be severely reduced immediately after the fault code becomes active.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1285.

Last Modified: 20-Jul-2015


Engine Cylinder 13 (A7) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1286

Engine Cylinder 13 (A7) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1286 PID: S102 SPN: 1364 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 13 (A7) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1286.

Last Modified: 20-Jul-2015


Engine Cylinder 13 (A7) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1287

Engine Cylinder 13 (A7) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1287 PID: S102 SPN: 1364 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 13 (A7) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1287.

Last Modified: 20-Jul-2015


Engine Cylinder 14 (B7) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1291

Engine Cylinder 14 (B7) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1291 PID: S103 SPN: 1365 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 14 (B7) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1291.

Last Modified: 20-Jul-2015


Engine Cylinder 14 (B7) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1292

Engine Cylinder 14 (B7) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1292 PID: S103 SPN: 1365 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 14 (B7) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1292.

Last Modified: 20-Jul-2015


Engine Cylinder 15 (A8) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1295

Engine Cylinder 15 (A8) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1295 PID: S104 SPN: 1366 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 15 (A8) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be severely reduced immediately after the fault code becomes active.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1295.

Last Modified: 20-Jul-2015


Engine Cylinder 15 (A8) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1296

Engine Cylinder 15 (A8) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1296 PID: S104 SPN: 1366 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 15 (A8) Knock - Data valid but above normal operational range - Most Severe Level. Knock above the critical level has been detected | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1296.

Last Modified: 20-Jul-2015


Engine Cylinder 15 (A8) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1297

Engine Cylinder 15 (A8) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1297 PID: S104 SPN: 1366 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 15 (A8) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1297.

Last Modified: 20-Jul-2015


Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1362

Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1362 PID: P99 SPN: 99 FMI: 0/16 LAMP: Amber SRT: | Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. High oil filter restriction has been detected. | None on performance.
Engine Oil Filter Inlet Pressure Sensor
Engine Oil Filter Outlet Pressure Sensor

Circuit Description

The engine control module (ECM) uses the oil filter intake pressure sensor and engine oil pressure sensor to determine the oil filter restriction.

Component Location

The oil filter intake pressure sensor is located on the oil filter housing.

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high oil filter restriction.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • High oil filter restriction.
  • Malfunctioning sensor
  • Plugged oil filter housing.
Refer to Troubleshooting Fault Code 1362.

Last Modified: 13-Oct-2015


Operator Interface Mode Transition to Emergency Stop (Due to Remote E-Stop) - Condition Exists

FAULT CODE 1434

Operator Interface Mode Transition to Emergency Stop (Due to Remote E-Stop) - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1434 PID: S151 SPN: 611 FMI: 11/31 LAMP: Red SRT: | Operator Interface Mode Transition to Emergency Stop (Due to Remote E-Stop) - Condition Exists. The remote E-Stop has been activated. | Engine will be shut down.
ECM

Circuit Description

The remote emergency stop switches are used by the operator to intiate an E-Stop.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The fault code will be activated when the operator activates the emergency stop switch.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • Determine the reason for the remote emergency stop switch being activated. When safe to do so, reset the remote emergency stop switch.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The remote emergency stop switches are activated by the operator.

Refer to Troubleshooting Fault Code 1434.

Last Modified: 23-Jul-2015


Software Version Mismatch Between Master Controller and Extended I/O board - Condition Exists

FAULT CODE 1474

Software Version Mismatch Between Master Controller and Extended I/O board - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1474 PID: SPN: 520211 FMI: 11/31 LAMP: Red SRT: | Software Version Mismatch Between Master Controller and Extended I/O board - Condition Exists. The ECM has detected a software version conflict on one or more modules. | The engine will shut down or will not start.
ECM

Circuit Description

N/A

Component Location

The ECM is connected to the battery by a combination of engine harness and OEM harness connected in series. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the parent module has software which is incompatible with the child module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The ECM function and control can change with software versions. The electronic service tool and the ECM perform checks to make certain the Parent and Child module sofware is compatible.

Refer to Troubleshooting Fault Code 1474.

Last Modified: 23-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1521

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1521 PID: S131 SPN: 1139 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1521.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1522

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1522 PID: S133 SPN: 1141 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1522.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1523

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1523 PID: S135 SPN: 1143 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1523.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1524

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1524 PID: S137 SPN: 1145 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1524.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1525

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1525 PID: S139 SPN: 1147 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1525.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1526

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1526 PID: S141 SPN: 1149 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1526.

Last Modified: 21-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1527

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: S143 SPN: 1151 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1527.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1529

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1529 PID: S130 SPN: 1138 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1529.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1531

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1531 PID: S134 SPN: 1142 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1531.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1532

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1532 PID: S136 SPN: 1144 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1532.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1533

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1533 PID: S138 SPN: 1146 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1533.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1534

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1534 PID: S140 SPN: 1148 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1534.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1535

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1535 PID: S142 SPN: 1150 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1535.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1536

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1536 PID: S144 SPN: 1152 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1536.

Last Modified: 20-Jul-2015


Engine Primary Speed Sensor (Engine Crankshaft Speed/Position Sensor) Lost - Condition Exists

FAULT CODE 1546

Engine Primary Speed Sensor (Engine Crankshaft Speed/Position Sensor) Lost - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1546 PID: P190 SPN: 190 FMI: 11/31 LAMP: Amber SRT: | Engine Primary Speed Sensor (Engine Crankshaft Speed/Position Sensor) Lost - Condition Exists. The ECM has detected a loss of signal from the engine speed sensor 2. | None on performance.
Engine Speed and Position Sensors

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

Both engine speed/position sensors are located on the back side of the front gear housing above the fuel pump drive.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault include:

  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.
  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1546.

Last Modified: 13-Oct-2015


Engine Cylinder 12 (B6) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1579

Engine Cylinder 12 (B6) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1579 PID: S101 SPN: 1363 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 12 (B6) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and allow it to run at rated speed, full load for 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Refer to Troubleshooting Fault Code 1579.

Last Modified: 20-Jul-2015


Engine Cylinder 14 (B7) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1581

Engine Cylinder 14 (B7) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1581 PID: S103 SPN: 1365 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 14 (B7) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and allow it to run at rated speed, full load for 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Refer to Troubleshooting Fault Code 1581.

Last Modified: 20-Jul-2015


Engine Cylinder 16 (B8) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1582

Engine Cylinder 16 (B8) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1582 PID: S105 SPN: 1367 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 16 (B8) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and allow it to run at rated speed, full load for 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Refer to Troubleshooting Fault Code 1582.

Last Modified: 20-Jul-2015


Engine Cylinder 16 (B8) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1583

Engine Cylinder 16 (B8) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1583 PID: S105 SPN: 1367 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 16 (B8) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1583.

Last Modified: 20-Jul-2015


Engine Cylinder 16 (B8) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1584

Engine Cylinder 16 (B8) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1584 PID: S105 SPN: 1367 FMI: 4/4 LAMP: Amber SRT: | Engine Cylinder 16 (B8) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the knock sensor circuit. | None on performance.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine knock protection will be unavailable.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause for this fault.

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 1584.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1618

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1618 PID: S129 SPN: 1137 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1618.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1619

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1619 PID: S132 SPN: 1140 FMI: 3/3 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60C [140F].
  • The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 1619.

Last Modified: 20-Jul-2015


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | Possible reduced engine performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various aftertreatment and OEM sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1696.

Last Modified: 13-Oct-2015


Engine Throttle Control Actuator - Bad Intelligent Device or Component

FAULT CODE 1737

Engine Throttle Control Actuator - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1737 PID: SPN: 3464 FMI: 12/12 LAMP: Red SRT: | Engine Throttle Control Actuator - Bad Intelligent Device or Component. The Throttle Control Valve has an internal failure. | Engine will shut down.
Throttle Control Actuator

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Throttle control valve has reported to the Engine Control Module (ECM) that it has an internal failure.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 1737.

Last Modified: 25-Aug-2015


Engine Throttle Control Actuator - Root Cause Not Known

FAULT CODE 1738

Engine Throttle Control Actuator - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1738 PID: SPN: 3464 FMI: 11/11 LAMP: Amber SRT: | Engine Throttle Control Actuator - Root Cause Not Known. The throttle control valve has an internal failure. | Possible reduced engine performance.
Throttle Control Valve

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Throttle control valve has reported to the Engine Control Module (ECM) that it has an internal failure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 1738.

Last Modified: 25-Aug-2015


Engine Throttle Control Actuator - Condition Exists

FAULT CODE 1739

Engine Throttle Control Actuator - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1739 PID: SPN: 3464 FMI: 11/31 LAMP: Amber SRT: | Engine Throttle Control Actuator - Condition Exists. The throttle control valve has an issue with the position demand signal. | Possible reduced engine performance.
Throttle Control Valve

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Throttle control valve has reported to the Engine Control Module (ECM) that it has diagnosed an issue with the position demand signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 1739.

Last Modified: 25-Aug-2015


Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1741

Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1741 PID: SPN: 3464 FMI: 0/15 LAMP: Amber SRT: | Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Least Severe Level.The throttle control valve reported its internal temperature was high. | Possible reduced engine performance.
Throttle Control Valve

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Throttle control valve has reported to the Engine Control Module (ECM) that its internal temperature is too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 1741.

Last Modified: 25-Aug-2015


Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1742

Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1742 PID: SPN: 3464 FMI: 0/16 LAMP: Amber SRT: | Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The throttle control valve has reported it's temperature is limiting it's operation. | Possible reduced engine performance.
Throttle Control Valve

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Throttle control valve has reported to the Engine Control Module (ECM) that its temperature is limiting its operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 1742.

Last Modified: 25-Aug-2015


Engine Fuel Valve 1 Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1761

Engine Fuel Valve 1 Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1761 PID: S18 SPN: 1442 FMI: 2/2 LAMP: Red SRT: | Engine Fuel Valve 1 Position - Data Erratic, Intermittent, or Incorrect. The fuel control valve is no longer moving to the commanded position. | Engine will shut down.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel control valve has failed as is no longer moving to the commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged Fuel Control Valve (FCV)
Refer to Troubleshooting Fault Code 1761.

Last Modified: 13-Oct-2015


Engine Gas Control Valve Outlet Pressure 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1767

Engine Gas Control Valve Outlet Pressure 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1767 PID: SPN: 3469 FMI: 3/3 LAMP: Amber SRT: | Engine Gas Control Valve Outlet Pressure 2 Circuit - Voltage Above Normal or Shorted to High Source, fuel outlet pressure sensor on Bank B has been shorted to a voltage source. | Possible reduced engine performance.
Fuel outlet pressure sensor

Circuit Description

The sensor monitors the gas pressure after the gas valve.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel outlet pressure sensor on Bank B has been shorted to a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel outlet pressure sensor is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • malfunctioning fuel pressure sensor
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 1767.

Last Modified: 20-Jul-2015


Engine Gas Control Valve Outlet Pressure 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1768

Engine Gas Control Valve Outlet Pressure 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1768 PID: SPN: 3469 FMI: 4/4 LAMP: Amber SRT: | Engine Gas Control Valve Outlet Pressure 2 Circuit - Voltage Below Normal or Shorted to Low Source, fuel outlet pressure sensor on Bank B has been shorted to ground. | Possible reduced engine performance.
Fuel outlet pressure sensor

Circuit Description

The sensor monitors the gas pressure after the gas valve.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel outlet pressure sensor on Bank B has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel outlet pressure sensor is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1768.

Last Modified: 20-Jul-2015


Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1774

Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1774 PID: SPN: 3589 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source. A malfunctioning OEM switch circuit has been detected. | None on performance.
Oil Priming Relay

Circuit Description

The OEM switch signal is used by the ECM to determine when adequate pre-lubricating oil pressure has been achieved.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump relay control has been shorted to power.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch ON and the oil priming pump OFF for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Malfunctioning pre-lube pump relay.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1774.

Last Modified: 20-Jul-2015


Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1775

Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1775 PID: SPN: 3589 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected in the oil priming pump control circuit. | None on performance.
Oil Pump Priming Relay

Circuit Description

The OEM switch signal is used by the ECM to determine when adequate pre-lubricating oil pressure has been achieved.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump relay control has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch ON and the oil priming pump OFF for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Malfunctioning pre-lube pump relay.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1775.

Last Modified: 20-Jul-2015


Engine Block/Coolant Pre-heater Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1778

Engine Block/Coolant Pre-heater Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1778 PID: SPN: 3604 FMI: 3/3 LAMP: Amber SRT: | Engine Block/Coolant Pre-heater Control Circuit - Voltage Above Normal or Shorted to High Source. The engine relay has been shorted to a power source. | Possible loss of power, or hard starting.
Engine coolant heater

Circuit Description

Coolant preheater warms coolant to a preset temperature.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine heater relay control has been shorted to a power source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning relay
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1778.

Last Modified: 20-Jul-2015


Engine Block/Coolant Pre-heater Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1779

Engine Block/Coolant Pre-heater Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1779 PID: SPN: 3604 FMI: 4/4 LAMP: Amber SRT: | Engine Block/Coolant Pre-heater Control Circuit - Voltage Below Normal or Shorted to Low Source. The engine heater relay has been shorted to ground. | Possible loss of power, or hard starting.
Engine coolant heater

Circuit Description

Coolant preheater warms coolant to a preset temperature.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine heater relay control has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch ON and engine heater OFF for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning relay
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1779.

Last Modified: 20-Jul-2015


Engine Controlled Shutdown Request Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1781

Engine Controlled Shutdown Request Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1781 PID: SPN: 3606 FMI: 3/3 LAMP: Amber SRT: | Engine Controlled Shutdown Request Circuit - Voltage Above Normal or Shorted to High Source.The shutdown request relay has been shorted to a power source. | None on performance.
ECM

Circuit Description

Some applications use the OEM switch input to drive an engine protection event in the form of an emergency engine shutoff switch, engine compartment cover location switch, or similar.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the shutdown request relay control has been shorted to a power source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and the shutdown request ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • A short to voltage source in the engine harness
Refer to Troubleshooting Fault Code 1781.

Last Modified: 21-Jul-2015


Engine Controlled Shutdown Request Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1782

Engine Controlled Shutdown Request Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1782 PID: SPN: 3606 FMI: 4/4 LAMP: Amber SRT: | Engine Controlled Shutdown Request Circuit - Voltage Below Normal or Shorted to Low Source. The shutdown request relay control has been shorted to ground. | None on performance.
ECM

Circuit Description

Some applications use the OEM switch input to drive an engine protection event in the form of an emergency engine shutoff switch, engine compartment cover location switch, or similar.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the shutdown request relay control has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch ON and the shutdown request OFF for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 1782.

Last Modified: 21-Jul-2015


Engine Oil Priming Pump Manual On Switch - Root Cause Not Known

FAULT CODE 1785

Engine Oil Priming Pump Manual On Switch - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1785 PID: SPN: 3550 FMI: 11/11 LAMP: Amber SRT: | Engine Oil Priming Pump Manual On Switch - Root Cause Not Known.The oil priming pump manual override switch has been shorted to the ON position. | None on performance.
Priming pump

Circuit Description

The pre-lube oil pressure switch is used by the engine control module (ECM) to determine when a successful pre-lube cycle has been achieved. The pre-lube pressure switch is normally closed when the engine and pre-lube pump are not running. The switch will open when pre-lube pressure is reached.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump manual override switch has been shorted to the ON condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged oil pump manual override priming switch.
Refer to Troubleshooting Fault Code 1785.

Last Modified: 20-Jul-2015


Engine Oil Priming Pump Control - Root Cause Not Known

FAULT CODE 1786

Engine Oil Priming Pump Control - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1786 PID: SPN: 3589 FMI: 11/11 LAMP: Amber SRT: | Engine Oil Priming Pump Control - Root Cause Not Known. The oil pump priming switvh has been shorted ON. | None on performance.
Priming pump

Circuit Description

The OEM switch signal is used by the ECM to determine when adequate pre-lubricating oil pressure has been achieved.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump has been shorted ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1786.

Last Modified: 20-Jul-2015


Engine Oil Priming State - Post-Lubrication - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1787

Engine Oil Priming State - Post-Lubrication - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1787 PID: SPN: 3551 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Priming State - Post-Lubrication - Data Valid But Below Normal Operating Range - Moderately Severe Level. The oil priming pump has not performed a post-run lubrication cycle after the engine has shut down. | None on performance.
ECM

Circuit Description

The OEM switch signal is used by the ECM to determine when adequate pre-lubricating oil pressure has been achieved.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump has not performed a post-run lubrication cycle after the engine has shut down.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning pre-lube oil pressure switch.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1787.

Last Modified: 25-Aug-2015


Engine Oil Priming State - Maintenance Lubrication - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 1788

Engine Oil Priming State - Maintenance Lubrication - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1788 PID: SPN: 3551 FMI: 1/17 LAMP: Amber SRT: | Engine Oil Priming State - Maintenance Lubrication - Data Valid But Below Normal Operating Range - Least Severe Level. The oil priming pump has not performed a maintenace lubrication cycle. | None on performance.
ECM

Circuit Description

The OEM switch signal is used by the ECM to determine when adequate pre-lubricating oil pressure has been achieved.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump has not performed a maintenance lubrication cycle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1788.

Last Modified: 25-Aug-2015


Engine Oil Priming State - Pre-Lubrication - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1789

Engine Oil Priming State - Pre-Lubrication - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1789 PID: SPN: 3551 FMI: 1/1 LAMP: Red SRT: | Engine Oil Priming State - Pre-Lubrication - Data Valid But Below Normal Operating Range - Most Severe Level. The priming pump has not performed a pre-start lubrication cycle. | Engine may be shut down.
ECM

Circuit Description

The OEM switch signal is used by the ECM to determine when adequate pre-lubricating oil pressure has been achieved.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump has not performed a pre-start lubrication cycle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • Start and idle the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged wiring harness
  • Malfunctioning pre-lube oil pressure switch.
  • Malfunctioning pre-lube pump relay.
  • Malfunctioning pre-lube pump.
Refer to Troubleshooting Fault Code 1789.

Last Modified: 25-Aug-2015


Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

FAULT CODE 1791

Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1791 PID: SPN: 1204 FMI: 11/31 LAMP: Red SRT: | Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists. The engine was uable to meet the required speed or load demand. | Engine will shut down.
ECM

Circuit Description

N/A

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected the engine could not reach the speed/load requirements.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code will commonly occure with other faults.

Refer to Troubleshooting Fault Code 1791.

Last Modified: 25-Aug-2015


Generator Governing Speed Command: Engine Low Idle/Rated Speed with Genset Breakers Closed - Condition Exists

FAULT CODE 1792

Generator Governing Speed Command: Engine Low Idle/Rated Speed with Genset Breakers Closed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1792 PID: SPN: 4079 FMI: 11/31 LAMP: Amber SRT: | Generator Governing Speed Command: Engine Low Idle/Rated Speed with Genset Breakers Closed - Condition Exists. Engine speed is commanded to idle. The genset mode of operation is utility parallel. | The engine speed will be maintained at rated speed until the genset mode of operation is not utility parallel.
ECM

Circuit Description

On generator sets with PowerCommand® control 3300, the generator set circuit breaker position is a PowerCommand® control baseboard input. Idle/rated mode of operation is controlled by the PowerCommand® control 3300 and can be toggled either via InPower™ electronic service tool or in the generator set human machine interface. The PowerCommand® control 3300 communicates these signals to the ECM via the J1939 communications network.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM monitors generator set contact breaker and utility contact breaker positions. If the ECM receives a command to reduce engine speed from 'rated' to 'idle' and the inputs from both contact breakers show the contact breakers are closed, the fault code will be set.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine will only idle or will shut down.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include.

  • Mechanical faults with either the alternator output contact breaker or the utility parallel contact breaker.
  • Generator and utility contact breakers position feedback wiring faulty.
Refer to Troubleshooting Fault Code 1792.

Last Modified: 25-Aug-2015


Engine Crankshaft Speed/Position Mismatch Between ECMs - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1793

Engine Crankshaft Speed/Position Mismatch Between ECMs - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1793 PID: P190 SPN: 190 FMI: 7/7 LAMP: Amber SRT: | Engine Crankshaft Speed/Position Mismatch Between ECMs - Mechanical System Not Responding or Out of Adjustment. There is an engine speed/position mismatch between the ECMs. | Possible reduced engine performance.
Engine Speed and Position Sensors

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

Both engine speed/position sensors are located on the back side of the front gear housing above the fuel pump drive.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

At least one engine control module (ECM) has lost both the camshaft and crankshaft position sensor signals while another ECM is still detecting both signals.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged sensor
Refer to Troubleshooting Fault Code 1793.

Last Modified: 25-Aug-2015


Undesired Thermal Situation Detected - Condition Exists

FAULT CODE 1794

Undesired Thermal Situation Detected - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1794 PID: SPN: 3584 FMI: 11/31 LAMP: Red SRT: | Undesired Thermal Situation Detected - Condition Exists. The user has depressed the fire stop switch. | Engine will shut down.
ECM

Circuit Description

The remote emergency stop switches are used by the operator to intiate an E-Stop.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The user has depressed the fire stop switch.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Maintaining a running natural gas fueled generator set during a possible fire situation is undesirable; therefore, it is common to have the generator sets linked to site fire alarm systems so that any running generator sets will be brought to an immediate stop.

Once the cause of the fire alarm has been investigated and resolved, by suitably qualified and authorized personnel, the engine room/container fire protection system will need to be reset before Fault Code 1794 can be cleared and the generator set restarted.

NOTE: The fire detection system alarm reset procedure detailed in this procedure refers to the generator plant room or container local system. Any main site system reset procedure is outside of the scope of this document and must only be undertaken by local authorized personnel.

Refer to Troubleshooting Fault Code 1794.

Last Modified: 25-Aug-2015


Engine Turbocharger Compressor Bypass Actuator Control Command - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1799

Engine Turbocharger Compressor Bypass Actuator Control Command - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1799 PID: SPN: 3470 FMI: 7/7 LAMP: Amber SRT: | Engine Turbocharger Compressor Bypass Actuator Control Command - Mechanical System Not Responding or Out of Adjustment. The CBV has failed its spring back check. | Possible reduced engine performance.
Turbocharger Compressor Bypass Valve

Circuit Description

The compressor bypass valve is controlled by the ECM and is used to bleed excessive boost pressure bofore the compressed mix reaches the throttle plate.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Compressor Bypass Valve (CBV) has reported to the Engine Control Module (ECM) that it has failed its spring check diagnostic.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning Turbine Bypass Valve
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1799.

Last Modified: 25-Aug-2015


Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1811

Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1811 PID: SPN: 3601 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Above Normal or Shorted to High Source. The ECM has diagnosed that the Valve Proving System (VPS) control wire has been shorted to a voltage source. | None on performance.
Fuel Shutoff Valve

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the Valve Proving System (VPS) control wire has been shorted to a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • A malfunctioning fuel shutoff valve.
Refer to Troubleshooting Fault Code 1811.

Last Modified: 20-Jul-2015


Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1812

Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1812 PID: SPN: 3601 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Below Normal or Shorted to Low Source. The ECM has diagnosed that the Valve Proving System (VPS) control wire has been shorted to ground. | None on performance.
Fuel Shut Off Valve

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the Valve Proving System (VPS) control wire has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • A malfunctioning fuel shutoff valve.
Refer to Troubleshooting Fault Code 1812.

Last Modified: 20-Jul-2015


Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1813

Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1813 PID: SPN: 3601 FMI: 1/18 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Moderately Severe Level. The ECM has diagnosed that the Valve Proving System (VPS) check for the FUel Shutoff Valve (FSO) has failed. | None on performance.
Fuel Shutoff Valve

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the Valve Proving System (VPS) check for the Fuel Shutoff Valve (FSO) has failed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • A malfunctioning fuel shutoff valve.
Refer to Troubleshooting Fault Code 1813.

Last Modified: 20-Jul-2015


Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1814

Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1814 PID: SPN: 3601 FMI: 1/1 LAMP: Red SRT: | Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Most Severe Level.The ECM has diagnosed that the Valve Proving System (VPS) check for the Fuel Shutoff Valve (FSO) has failed. | Engine will be shut down.
Fuel Shutoff Valve

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the Valve Proving System (VPS) check for the Fuel Shutoff Valve (FSO) has failed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • A malfunctioning fuel shutoff valve.
Refer to Troubleshooting Fault Code 1814.

Last Modified: 20-Jul-2015


Engine Oil Pre-heater Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1815

Engine Oil Pre-heater Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1815 PID: SPN: 3602 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Pre-heater Control Circuit - Voltage Above Normal or Shorted to High Source. The oil pre-heater relay control has been shorted to a power source. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Oil heater

Circuit Description

Oil-preheater heats the oil to a prest temperature.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine oil pre-heater relay control has been shorted to a power source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and engine oil pre-heater ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • A short circuit to voltage source in the wiring harness
  • A malfunctioning relay
Refer to Troubleshooting Fault Code 1815.

Last Modified: 20-Jul-2015


Engine Oil Pre-heater Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1816

Engine Oil Pre-heater Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1816 PID: SPN: 3602 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Pre-heater Control Circuit - Voltage Below Normal or Shorted to Low Source. The engine oil pre-heater relay has been shorted to ground. | Engine may not start or may be difficult to start.
Oil heater

Circuit Description

Oil-preheater heats the oil to a prest temperature.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine oil pre-heater relay control has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch ON and engine oil pre-heater OFF for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning relay
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1816.

Last Modified: 20-Jul-2015


Engine Oil Pre-heater Control Circuit Breaker Tripped - Condition Exists

FAULT CODE 1817

Engine Oil Pre-heater Control Circuit Breaker Tripped - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1817 PID: SPN: 3602 FMI: 11/31 LAMP: Amber SRT: | Engine Oil Pre-heater Control Circuit Breaker Tripped - Condition Exists. The oil-preheater circuit breaker has tripped. | Engine may not start or may be difficult to start.
Oil heater

Circuit Description

Oil-preheater heats the oil to a prest temperature.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the circuit breaker for the engine oil pre-heater has been tripped.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and engine oil pre-heater ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning relay
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1817.

Last Modified: 20-Jul-2015


Engine Oil Pre-heated State - Root Cause Not Known

FAULT CODE 1818

Engine Oil Pre-heated State - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1818 PID: SPN: 3552 FMI: 11/11 LAMP: Amber SRT: | Engine Oil Pre-heated State - Root Cause Not Known. The engine oil pre-heater is not properly warming the engine. | Engine may not start or may be difficult to start.
Oil heater

Circuit Description

Oil-preheater heats the oil to a prest temperature.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine oil pre-heater is not properly warming the engine oil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and the engine oil pre-heater ON for 3 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged wiring harness
  • A malfunctioning relay
Refer to Troubleshooting Fault Code 1818.

Last Modified: 20-Jul-2015


Engine Crankshaft Speed/Position, Very Low Engine Speed Detected When Engine is Supposed to be Running - Root Cause Not Known

FAULT CODE 1821

Engine Crankshaft Speed/Position, Very Low Engine Speed Detected When Engine is Supposed to be Running - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1821 PID: P190 SPN: 190 FMI: 11/11 LAMP: Red SRT: | Engine Crankshaft Speed/Position, Very low Engine Speed Detected When Engine is Supposed to be Running - Root Cause Not Known. ECM detected low or no engine speed is detected, when the ECM knows the engine is supposed to be running. | The engine will shut down or will not start.
Engine Speed Sensor

Circuit Description

The engine speed sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the speed sensor and a return circuit. As the teeth on the crankshaft speed ring move past the speed sensor, a signal is generated on the speed sensor signal circuit. The ECM interprets this signal and converts it to an engine speed.

Component Location

The engine speed sensors are located at the rear of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects low or no speed while the engine is supposed to be running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Engine speed sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1821.

Last Modified: 25-Aug-2015


Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1822

Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1822 PID: SPN: 3676 FMI: 1/1 LAMP: Red SRT: | Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Most Severe Level. The Ecm has detected low coolant in the aftercooler LT cooling circuit. | Engine will be shut down.
LT Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage is between 1.75 VDC and 3 VDC for more than 30 seconds, indicating low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Low coolant level, or air in the cooling system
  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1822.

Last Modified: 20-Jul-2015


Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 1823

Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1823 PID: SPN: 3676 FMI: 1/17 LAMP: Amber SRT: | Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Least Severe Level. The ECM has diagnosed that the LT cooling circuit is low on coolant. | None on performance.
LT Coolant Level Sensor

Circuit Description

The engine control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage is between 1.75 VDC and 3 VDC for more than 30 seconds, indicating low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Low coolant level, or air in the cooling system
  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1823.

Last Modified: 20-Jul-2015


Engine Oil Temperature Sensor 1 Circuit, Too Cold for High Idle - Condition Exists

FAULT CODE 1824

Engine Oil Temperature Sensor 1 Circuit, Too Cold for High Idle - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1824 PID: P175 SPN: 175 FMI: 11/31 LAMP: Amber SRT: | Engine Oil Temperature Sensor 1 Circuit, Too Cold for High Idle - Condition Exists. The oil has not warmed to a preset range. | Engine will only idle.
Oil Temperature Sensor

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detected that the oil temperature was lower than the preset temperature for high idle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine speed may be limited to engine idle speed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning oil temperature sensor.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1824.

Last Modified: 25-Aug-2015


Engine Waste Oil Reservoir Level - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1825

Engine Waste Oil Reservoir Level - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1825 PID: SPN: 3548 FMI: 0/15 LAMP: Amber SRT: | Engine Waste Oil Reservoir Level - Data Valid But Above Normal Operating Range - Least Severe Level. High waste oil level detected. | None on performance.
Dirty Oil Level Switch

Circuit Description

The Dirty Oil Level switch is a 2-wire switch with a signal and return cicuit. It measures the oil level in the blowby reservoir.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine crankcase blowby reservoir has become full.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged sensor
Refer to Troubleshooting Fault Code 1825.

Last Modified: 20-Jul-2015


Incompatible Software Version Determined in Slave Controller - Condition Exists

FAULT CODE 1826

Incompatible Software Version Determined in Slave Controller - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1826 PID: SPN: 520357 FMI: 11/31 LAMP: Red SRT: | Incompatible Software Version Determined in Slave Controller - Condition Exists. The ECM has diagnosed that the software is not compatible inone or more of the modules. | The engine will not start.
ECM

Circuit Description

CAN (Controller Area Network) is the high speed communication line for many of the Vehicle electronic control units (VECU). The CAN communication bus has two 2 lines (CAN H line, CAN L line). These lines are inputted to the Engine Control Module. If the ECM does not receive any messages across the CAN bus for a period of time, this fault will set.

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the parent module has software which is incompatible with the child module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The ECM function and control can change with software versions. The electronic service tool and the ECM perform checks to make certain the Parent and Child module sofware is compatible.

Refer to Troubleshooting Fault Code 1826.

Last Modified: 25-Aug-2015


Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1827

Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1827 PID: SPN: 1390 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. The Fuel Inlet Sensor has been shorted to a voltage source. | None on performance.
Fuel Inlet Pressure Sensor

Circuit Description

The ECM provides 5 volt signal and return to the fuel pressure inlet and outlet sensors.

Component Location

The fuel filter intake pressure sensor is located on the fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel inlet pressure sensor has been shorted to a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning fuel filter intake pressure sensor.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1827.

Last Modified: 20-Jul-2015


Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1828

Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1828 PID: SPN: 1390 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The fuel inlet pressure sensor has been shorted to ground. | None on performance.
Fuel Inlet Pressure Sensor

Circuit Description

The ECM provides 5 volt signal and return to the fuel pressure inlet and outlet sensors.

Component Location

The fuel filter intake pressure sensor is located on the fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel inlet pressure sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes for this fault code include:

  • Damaged wiring harness
  • A malfunctioning fuel filter intake pressure sensor.
Refer to Troubleshooting Fault Code 1828.

Last Modified: 20-Jul-2015


Engine Block/Coolant Pre-heater Control Breaker Tripped - Condition Exists

FAULT CODE 1833

Engine Block/Coolant Pre-heater Control Breaker Tripped - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1833 PID: SPN: 3604 FMI: 11/31 LAMP: Amber SRT: | Engine Block/Coolant Pre-heater Control Breaker Tripped - Condition Exists. The ECM has diagnosed that the engine heater circuit breaker has been tripped. | Engine may not start or may be difficult to start.
Engine Coolant Heater

Circuit Description

Coolant preheater warms coolant to a preset temperature.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine heater circuit breaker has been tripped.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and engine heater ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Tripped engine coolant heater circuit breaker.
Refer to Troubleshooting Fault Code 1833.

Last Modified: 20-Jul-2015


Engine Coolant Circulating Pump Breaker Tripped - Condition Exists

FAULT CODE 1834

Engine Coolant Circulating Pump Breaker Tripped - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1834 PID: SPN: 3605 FMI: 11/31 LAMP: Amber SRT: | Engine Coolant Circulating Pump Breaker Tripped - Condition Exists. The ECM has diagnosed that the HT coolant circulating pump power supply circuit breaker trip circuit is active. | None on performance.
HT Coolant Pump Relay

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the HT coolant pump relay is tripped.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

Refer to Troubleshooting Fault Code 1834.

Last Modified: 20-Jul-2015


Engine Oil Priming Pump Control Breaker Tripped - Condition Exists

FAULT CODE 1835

Engine Oil Priming Pump Control Breaker Tripped - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1835 PID: SPN: 3589 FMI: 11/31 LAMP: Amber SRT: | Engine Oil Priming Pump Control Breaker Tripped - Condition Exists. The ECM has diagnosed that the oil priming pump circuit breaker has been tripped. | None on performance.
Engine Oil Priming Pump

Circuit Description

The engine can be configured to use either the pre-lube oil pressure switch, the engine oil pressure sensor, or both to make pre-lube cycle success determination. If both the switch and sensor are enabled in the engine calibration for pre-lube use, then both have to indicate pre-lube pressure is at the appropriate level before the cycle is considered successful.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump circuit breaker has been tripped.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and oil priming pump ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1835.

Last Modified: 20-Jul-2015


Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1836

Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1836 PID: S306 SPN: 2981 FMI: 1/1 LAMP: Red SRT: | Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. The ECM has diagnosed that the LT coolant pressure system has become too low. | Engine will shut down.
LT Coolant Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine has been running for more than 1 minute.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the LT coolant pressure has become too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.
  • In severe cases, the ECM will immediately shut down the engine.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and allow it to run at rated speed, full load for 2 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Low coolant level
  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1836.

Last Modified: 25-Aug-2015


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1837

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1837 PID: S64 SPN: 723 FMI: 2/2 LAMP: Red SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | The engine will shut down or will not start.
Engine Position Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Both engine speed/position sensors are located on the back side of the front gear housing above the fuel pump drive.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the engine speed sensor 1.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 1837.

Last Modified: 25-Aug-2015


kW Electrical Load Signal - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1838

kW Electrical Load Signal - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1838 PID: SPN: 2452 FMI: 0/0 LAMP: Red SRT: | kW Electrical Load Signal - Data Valid But Above Normal Operating Range - Most Severe Level. Overload protection is enabled and load is higher than partial continous load threshold for set persistance time. | Engine will be shut down.
ECM

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Most Severe Level. Overload protection is enabled and load is higher than partial continous load threshold for set persistance time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

Refer to Troubleshooting Fault Code 1838.

Last Modified: 20-Jul-2015


Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1839

Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1839 PID: P159 SPN: 159 FMI: 3/3 LAMP: Amber SRT: | Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. The fuel supply pressure sensor has been shorted to a voltage source. | None on performance.
Fuel Supply Pressure Sensor

Circuit Description

The fuel supply pressure sensor recieves 5 volts from the ECM and monitors the pressure from the gas regulator.

Component Location

Located in the Gas supply line.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel supply pressure sensor has been shorted to a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Malfunctioning engine fuel supply pump intake pressure sensor.
Refer to Troubleshooting Fault Code 1839.

Last Modified: 20-Jul-2015


Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1841

Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1841 PID: P159 SPN: 159 FMI: 4/4 LAMP: Amber SRT: | Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The fuel supply pressure sensor has been shorted to ground. | None on performance.
Fuel Supply Pressure Sensor

Circuit Description

The fuel supply pressure sensor recieves 5 volts from the ECM and monitors the pressure from the gas regulator.

Component Location

Located in the Gas supply line.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel supply pressure sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Malfunctioning engine fuel supply pump intake pressure sensor.
Refer to Troubleshooting Fault Code 1841.

Last Modified: 20-Jul-2015


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in a right bank hand hole cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning crankcase pressure sensor.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 20-Jul-2015


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in a right bank hand hole cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Malfunctioning crankcase pressure sensor.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 20-Jul-2015


Coolant Temperature 2 (LT) Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2111

Coolant Temperature 2 (LT) Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2111 PID: P52 SPN: 52 FMI: 3/3 LAMP: Amber SRT: | Coolant Temperature 2 (LT) Sensor Circuit - Voltage Above Normal or Shorted to High Source. The ECM has diagnosed that the LT coolant temperature sensor has been shorted to a voltage source. | Possible reduced engine performance.
LT Coolant Temperature Sensor

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The LT coolant temperature sensor is located between the LT coolant pump and the aftercooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2111.

Last Modified: 20-Jul-2015


Coolant Temperature 2 (LT) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2112

Coolant Temperature 2 (LT) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2112 PID: P52 SPN: 52 FMI: 4/4 LAMP: Amber SRT: | Coolant Temperature 2 (LT) Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The ECM has diagnosed that the LT coolant temperature sensor is shorted to ground. | Possible reduced engine performance.
LT Coolant Temperature Sensor

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The LT coolant temperature sensor is located between the LT coolant pump and the aftercooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2112.

Last Modified: 20-Jul-2015


Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2113

Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2113 PID: P52 SPN: 52 FMI: 0/16 LAMP: Amber SRT: | Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The ECM has diagnosed that the LT coolant temperature has exceeded the warning threshold. | Possible reduced engine performance.
LT Coolant Temperature Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The LT coolant temperature sensor is located between the LT coolant pump and the aftercooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2113.

Last Modified: 20-Jul-2015


Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2114

Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2114 PID: P52 SPN: 52 FMI: 0/0 LAMP: Red SRT: | Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has diagnosed that the LT engine coolant temperature has exceeded the high critical threshold. | Engine will be shut down.
LT Coolant Temperature Sensor

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The LT coolant temperature sensor is located between the LT coolant pump and the aftercooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the LT engine coolant temperature has exceeded the high critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Low coolant level, or air in the cooling system
  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2114.

Last Modified: 20-Jul-2015


Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2115

Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2115 PID: S306 SPN: 2981 FMI: 3/3 LAMP: Amber SRT: | Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. The ECM has diagnosed that the LT coolant pressure sensor signal has been shorted to a power source. | None on performance.
LT Coolant Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The LT coolant pressure sensor is located between the coolant pump and the aftercooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the LT coolant pressure sensor signal has been shorted to a power source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2115.

Last Modified: 20-Jul-2015


Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2116

Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2116 PID: S306 SPN: 2981 FMI: 4/4 LAMP: Amber SRT: | Engine Secondary Coolant Circuit Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The ECM has diagnosed that the LT coolant pressure sensor signal has been shorted to ground. | None on performance.
LT Coolant Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The LT coolant pressure sensor is located between the coolant pump and the aftercooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the LT coolant pressure sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2116.

Last Modified: 20-Jul-2015


Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2117

Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2117 PID: S306 SPN: 2981 FMI: 1/18 LAMP: Amber SRT: | Engine Secondary Coolant Circuit Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The ECM has diagnosed that the LT engine coolant pressure has dropped below the low warnong threshold. | None on performance.
LT Coolant Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The LT coolant pressure sensor is located between the coolant pump and the aftercooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the LT coolant pressure has dropped below the low warning threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Low coolant level, or air in the cooling system
  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2117.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2121

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2121 PID: S129 SPN: 1137 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2121.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2122

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2122 PID: S131 SPN: 1139 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2122.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2123

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2123 PID: S133 SPN: 1141 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2123.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2124

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2124 PID: S135 SPN: 1143 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2124.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2125

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2125 PID: S137 SPN: 1145 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2125.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2126

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2126 PID: S139 SPN: 1147 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2126.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2127

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2127 PID: S141 SPN: 1149 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2127.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2128

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2128 PID: S143 SPN: 1151 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2128.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2131

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2131 PID: S130 SPN: 1138 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2131.

Last Modified: 29-Jul-2015


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2132

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2132 PID: S132 SPN: 1140 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2132.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2133

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2133 PID: S134 SPN: 1142 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2133.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2134

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2134 PID: S136 SPN: 1144 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2134.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2135

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2135 PID: S138 SPN: 1146 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2135.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2136

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2136 PID: S140 SPN: 1148 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2136.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2137

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2137 PID: S142 SPN: 1150 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2137.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2138

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2138 PID: S144 SPN: 1152 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2138.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2144

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2144 PID: S144 SPN: 1152 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 2144.

Last Modified: 20-Jul-2015


Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2154

Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2154 PID: S151 SPN: 3549 FMI: 3/3 LAMP: Amber SRT: | Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. The ECM has diagnosed that the post-filter oil pressure sensor has been shorted to a power source. | None on performance.
Post-filter Oil Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The post-filter oil pressure sensor is located between the oil filter and the oil cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the post-filter oil pressure sensor has been shorted to a power source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the engine oil filter outlet pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2154.

Last Modified: 20-Jul-2015


Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2155

Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2155 PID: S151 SPN: 3549 FMI: 4/4 LAMP: Amber SRT: | Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The ECM has diagnosed that the post-filter oil pressure sensor has been shorted to ground. | None on performance.
Post-filter Oil Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The post-filter oil pressure sensor is located between the oil filter and the oil cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the post-filter oil pressure sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the engine oil filter outlet pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2155.

Last Modified: 20-Jul-2015


Electronic Fuel Injection Control Valve Circuit - Root Cause Not Known

FAULT CODE 2184

Electronic Fuel Injection Control Valve Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2184 PID: S18 SPN: 633 FMI: 11/11 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Root Cause Not Known. The Fuel Control Valve (FCV) has a position error. | Possible reduced engine performance.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) has reported to the Engine Control Module (ECM) that it has a position error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged FCV.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2184.

Last Modified: 20-Jul-2015


Fault Code Path Selection

FAULT CODE 224-fc2186
Fault Code Path Selection

Is the sensor supply 4 circuit fault code generated from ECM source address 00? | Go to 224-fc2186sa00
Is the sensor supply 4 circuit fault code generated from ECM source address 01? | Go to 224-fc2186sa01

Last Modified: 27-Jul-2015


Intake Manifold Absolute Pressure Sensor Disagrees With the Compressor Outlet Pressure Sensor - Condition Exists

FAULT CODE 2191

Intake Manifold Absolute Pressure Sensor Disagrees With the Compressor Outlet Pressure Sensor - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2191 PID: P102 SPN: 102 FMI: 11/31 LAMP: Amber SRT: | Intake Manifold Absolute Pressure Sensor Disagrees With the Compressor Outlet Pressure Sensor - Condition Exists. The intake manifold pressure and the compressor outlet pressure are mismatching. | Possible reduced engine performance.
Intake Manifold Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The pressure differential (delta P) between the turbocharger compressor outlet pressure sensor and the intake manifold pressure sensor has exceeded the pressure threshold for a period of 30 seconds and ignition timing retardation has reached the limit of adjustment.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

If turbocharger boost pressure is low, then the ECM will command the throttle plate to open in order to try and maintain engine speed and load. At the same time, the engine's ignition timing is retarded in order to try and recover turbocharger boost pressure. If turbocharger boost pressure remains low, the throttle plate position will again be increased and the ignition timing will be further retarded. Fault Code 2191 will be activated when the delta P threshold and limit of ignition timing retardation are reached. Due to the increased throttle plate position for a given load, throttle margin is lost and engine performance may be reduced as a result.

Refer to Troubleshooting Fault Code 2191.

Last Modified: 20-Jul-2015


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: S253 SPN: 630 FMI: 11/31 LAMP: Amber SRT: | Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists. Internal ECM failure. | Possible reduced engine performance.
ECM

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 2217.

Last Modified: 20-Jul-2015


Engine Cylinder 11 (A6) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2281

Engine Cylinder 11 (A6) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2281 PID: S100 SPN: 1362 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 11 (A6) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the warning level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be severely reduced immediately after the fault code becomes active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

Knock related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

Rocker lever

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2281.

Last Modified: 20-Jul-2015


Engine Cylinder 11 (A6) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2282

Engine Cylinder 11 (A6) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2282 PID: S100 SPN: 1362 FMI: 0/0 LAMP: Red SRT: | Engine Cylinder 11 (A6) Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Knock above the critical level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2282.

Last Modified: 20-Jul-2015


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S18 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. The Fuel Control Valve (FCV) has reported to the ECM that it has powered up incorrectly. | Possible reduced engine performance.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) has reported to the Engine Control Module (ECM) that it has powered up incorrectly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code can become active for any of the following reasons:

  • Damaged Fuel Control Valve (FCV)
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2311.

Last Modified: 20-Jul-2015


Fuel Control Valve Solenoid Driver 2 Circuit - Condition Exists

FAULT CODE 2313

Fuel Control Valve Solenoid Driver 2 Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2313 PID: S83 SPN: 1244 FMI: 11/31 LAMP: Amber SRT: | Fuel Control Valve Solenoid Driver 2 Circuit - Condition Exists. The Fuel Control Valve (FCV) on Bank B has reported to the ECM that it has powered up incorrectly. | Possible reduced engine performance.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) on Bank B has reported to the Engine Control Module (ECM) that it has powered up incorrectly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged Fuel Control Valve (FCV)
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2313.

Last Modified: 20-Jul-2015


Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2427

Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2427 PID: S305 SPN: 2980 FMI: 3/3 LAMP: Amber SRT: | Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. The ECM has diagnosed the fuel outlet pressure sensor has been shorted to a voltage source. | Engine will shut down.
Fuel Outlet Pressure Sensor

Circuit Description

The fuel inlet and outlet sensors are supplied 5 volts by the ECM and monitor the fuel pressure before and after the FCV.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel outlet pressure sensor has been shorted to a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel outlet pressure sensor is used.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2427.

Last Modified: 03-Dec-2015


Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2428

Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2428 PID: S305 SPN: 2980 FMI: 4/4 LAMP: Amber SRT: | Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The ECM has diagnosed that fuel outlet pressure sensor has been shorted to ground. | Engine will shut down.
Fuel Outlet Pressure Sensor

Circuit Description

The ECM provides 5 volt signal and return to the fuel pressure inlet and outlet sensors.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel outlet pressure sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel outlet pressure sensor is used.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2428.

Last Modified: 03-Dec-2015


Engine Misfire for Multiple Cylinders - Condition Exists

FAULT CODE 2457

Engine Misfire for Multiple Cylinders - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2457 PID: SPN: 1322 FMI: 11/31 LAMP: Red SRT: | Engine Misfire for Multiple Cylinders - Condition Exists. The ECM has diagnosed that the engine is experiencing misfire on multiple cylinders. | Engine will be shut down.
ECM

Circuit Description

N/A

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a misfire of two or more cylinders.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle start the engine and allow it to run at 100% load for 3 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2457.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2458

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2458 PID: S130 SPN: 1138 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2458.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2459

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2459 PID: S132 SPN: 1140 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2459.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2461

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2461 PID: S134 SPN: 1142 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2461.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2462

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2462 PID: S136 SPN: 1144 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2462.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2463

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2463 PID: S138 SPN: 1146 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2463.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2464

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2464 PID: S140 SPN: 1148 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2464.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2465

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2465 PID: S142 SPN: 1150 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2465.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2466

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2466 PID: S144 SPN: 1152 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2466.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2469

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2469 PID: S129 SPN: 1137 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2469.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2471

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2471 PID: S131 SPN: 1139 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2471.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2472

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2472 PID: S133 SPN: 1141 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2472.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2473

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2473 PID: S135 SPN: 1143 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2473.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2475

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2475 PID: S137 SPN: 1145 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2475.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2476

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2476 PID: S139 SPN: 1147 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2476.

Last Modified: 29-Jul-2015


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2477

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2477 PID: S141 SPN: 1149 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2477.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2478

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2478 PID: S143 SPN: 1151 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor has detected temperature below the warning level. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was less than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2478.

Last Modified: 20-Jul-2015


Engine Starter Mode Before Ready Status - Condition Exists

FAULT CODE 2482

Engine Starter Mode Before Ready Status - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2482 PID: SPN: 1675 FMI: 11/31 LAMP: Red SRT: | Engine Starter Mode Before Ready Status - Condition Exists. The ECM has diagnosed that the engine is not ready to perform a start. | Engine may run rough, may stop running, may not start, or may be difficult to start.
ECM

Circuit Description

N/A

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the engine is not ready to perform a start.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information only fault code, and does not indicate an issue with the starter.

This fault code is usually accompanied by other fault codes of a higher priority. All other faults codes should be addressed prior to addressing FC2482.

Refer to Troubleshooting Fault Code 2482.

Last Modified: 20-Jul-2015


Engine Starter Mode Engagement - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2483

Engine Starter Mode Engagement - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2483 PID: SPN: 1675 FMI: 7/7 LAMP: Red SRT: | Engine Starter Mode Engagement - Mechanical System Not Responding or Out of Adjustment. The ECM has diagnosed that the starter has failed to properly start the engine after multiple start attempts. | Engine may not start. Engine will be shut down.
ECM

Circuit Description

N/A

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the starter has failed to properly start the engine after multiple start attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

A relay in the DC interface panel determines which pins in the starter connection are used for the start signal. The pins depend on whether or not an air starter or an electric starter are in use. Refer to the engine wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code 2483.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 1 (A1) - Abnormal Rate of Change

FAULT CODE 2484

Exhaust Gas Temperature Cylinder 1 (A1) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2484 PID: S129 SPN: 1137 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2484.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 3 (A2) - Abnormal Rate of Change

FAULT CODE 2485

Exhaust Gas Temperature Cylinder 3 (A2) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2485 PID: S131 SPN: 1139 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2485.

Last Modified: 29-Jul-2015


Exhaust Gas Temperature Cylinder 5 (A3) - Abnormal Rate of Change

FAULT CODE 2486

Exhaust Gas Temperature Cylinder 5 (A3) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2486 PID: S133 SPN: 1141 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2486.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 7 (A4) - Abnormal Rate of Change

FAULT CODE 2487

Exhaust Gas Temperature Cylinder 7 (A4) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2487 PID: S135 SPN: 1143 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2487.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 9 (A5) - Abnormal Rate of Change

FAULT CODE 2488

Exhaust Gas Temperature Cylinder 9 (A5) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2488 PID: S137 SPN: 1145 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2488.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 11 (A6) - Abnormal Rate of Change

FAULT CODE 2489

Exhaust Gas Temperature Cylinder 11 (A6) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2489 PID: S139 SPN: 1147 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2489.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 13 (A7) - Abnormal Rate of Change

FAULT CODE 2491

Exhaust Gas Temperature Cylinder 13 (A7) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2491 PID: S141 SPN: 1149 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2491.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 15 (A8) - Abnormal Rate of Change

FAULT CODE 2492

Exhaust Gas Temperature Cylinder 15 (A8) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2492 PID: S143 SPN: 1151 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2492.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 2 (B1) - Abnormal Rate of Change

FAULT CODE 2494

Exhaust Gas Temperature Cylinder 2 (B1) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2494 PID: S130 SPN: 1138 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2494.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 4 (B2) - Abnormal Rate of Change

FAULT CODE 2495

Exhaust Gas Temperature Cylinder 4 (B2) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2495 PID: S132 SPN: 1140 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 4 (B2) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes. If the fault code does not go inactive after key ON, it may be necessary to drive the vehicle for at least 5 continuous minutes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2495.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 6 (B3) - Abnormal Rate of Change

FAULT CODE 2496

Exhaust Gas Temperature Cylinder 6 (B3) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2496 PID: S134 SPN: 1142 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 6 (B3) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2496.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 8 (B4) - Abnormal Rate of Change

FAULT CODE 2497

Exhaust Gas Temperature Cylinder 8 (B4) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2497 PID: S136 SPN: 1144 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2497.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 10 (B5) - Abnormal Rate of Change

FAULT CODE 2498

Exhaust Gas Temperature Cylinder 10 (B5) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2498 PID: S138 SPN: 1146 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 10 (B5) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2498.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 12 (B6) - Abnormal Rate of Change

FAULT CODE 2499

Exhaust Gas Temperature Cylinder 12 (B6) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2499 PID: S140 SPN: 1148 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 12 (B6) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2499.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 14 (B7) - Abnormal Rate of Change

FAULT CODE 2511

Exhaust Gas Temperature Cylinder 14 (B7) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2511 PID: S142 SPN: 1150 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 14 (B7) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2511.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 16 (B8) - Abnormal Rate of Change

FAULT CODE 2512

Exhaust Gas Temperature Cylinder 16 (B8) - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2512 PID: S144 SPN: 1152 FMI: 10/10 LAMP: Red SRT: | Exhaust Gas Temperature Cylinder 16 (B8) - Abnormal Rate of Change. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | Engine will be shut down.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection shutdown limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2512.

Last Modified: 20-Jul-2015


Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 2517

Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2517 PID: S309 SPN: 1127 FMI: 3/3 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source. The ECM has diagnosed the compressor outlet pressure sensor is shorted to a voltage source. | Possible reduced engine performance.
Compressor Outlet Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to compressor outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the ECM on the compressor outlet pressure sensor signal circuit.

Component Location

Located between the turbo outlet and charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed the the compressor outlet pressure sensor has been shorted to a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged sensor
Refer to Troubleshooting Fault Code 2517.

Last Modified: 20-Jul-2015


Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2518

Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2518 PID: S309 SPN: 1127 FMI: 4/4 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source. The ECM diagnosed the compressor outlet pressure sensor has been shorted to ground. | Possible reduced engine performance.
Compressor Outlet Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to compressor outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the ECM on the compressor outlet pressure sensor signal circuit.

Component Location

Located between the turbo outlet and charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM diagnosed the compressor outlet pressure sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged sensor
Refer to Troubleshooting Fault Code 2518.

Last Modified: 20-Jul-2015


Bank Identifier Incorrect - Root Cause Not Known

FAULT CODE 2521

Bank Identifier Incorrect - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2521 PID: SPN: 1225 FMI: 11/11 LAMP: Red SRT: | Bank Identifier Incorrect - Root Cause Not Known. The incorrect bank indentification detected by the ECM. | Engine may not start.
Left and Right Bank Identification Circuits

Circuit Description

Each ECM reads the status of two pins to determine whether it is on the left bank or the right bank upon power up. A proper combination requires that one of these pins be shorted to ECM Switch Return and the other left open. The short is permanently wired inside the wiring harness.

Component Location

Located in the Engine Harness

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The incorrect bank indentification detected by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each ECM must have a unique identification as established by the two bank identification pins upon start up. If both pins on either ECM are shorted to ECM switch return or open, a fault will occur. The two ECMs must not have the same pin shorted to ECM switch return.

Refer to Troubleshooting Fault Code 2521.

Last Modified: 20-Jul-2015


Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2522

Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2522 PID: S90 SPN: 1352 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2522.

Last Modified: 20-Jul-2015


Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2523

Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2523 PID: S91 SPN: 1353 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2523.

Last Modified: 20-Jul-2015


Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2524

Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2524 PID: S92 SPN: 1354 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2524.

Last Modified: 20-Jul-2015


Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2525

Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2525 PID: S93 SPN: 1355 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2525.

Last Modified: 20-Jul-2015


Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2526

Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2526 PID: S94 SPN: 1356 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2526.

Last Modified: 20-Jul-2015


Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2527

Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2527 PID: S95 SPN: 1357 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 2527.

Last Modified: 20-Jul-2015


Engine Cylinder 7 (A4) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2528

Engine Cylinder 7 (A4) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2528 PID: S96 SPN: 1358 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 7 (A4) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2528.

Last Modified: 20-Jul-2015


Engine Cylinder 8 (B4) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2529

Engine Cylinder 8 (B4) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2529 PID: S97 SPN: 1359 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 8 (B4) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2529.

Last Modified: 20-Jul-2015


Engine Cylinder 9 (A5) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2531

Engine Cylinder 9 (A5) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2531 PID: S98 SPN: 1360 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 9 (A5) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2531.

Last Modified: 20-Jul-2015


Engine Cylinder 10 (B5) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2532

Engine Cylinder 10 (B5) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2532 PID: S99 SPN: 1361 FMI: 0/16 LAMP: Red SRT: | Engine Cylinder 10 (B5) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Knock above the warning level has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine with a minimum intake manifold pressure of 22 psi for at least 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

When the Warning threshold is reached and persists for a pre-set period of time, the ECM will register a Warning alarm for the affected cylinder and the engine will continue to run. The ECM will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the ECM will slowly advance the timing for that cylinder back to its standard timing setting. If detonation persists, the timing retardation is repeated, up to a maximum of three timing retardation. If, following the final timing, retardation knock is still present the ECM will initiate a CRITICAL shutdown of the engine.

All detonation-related shutdowns and persistant light knock events should be fully investigated in order to prevent engine damage.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

The PCC3300 Generator Control receives and displays knock as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +)

Refer to Troubleshooting Fault Code 2532.

Last Modified: 20-Jul-2015


Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2544

Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2544 PID: P21 SPN: 1136 FMI: 0/0 LAMP: Red SRT: | Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. High internal ECM temperature detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected internal temperatures above the critical limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Incorrect or restricted air flow over the ECM and engine.
Refer to Troubleshooting Fault Code 2544.

Last Modified: 20-Jul-2015


Air Compressor Actuator Driver Circuit Breaker - Condition Exists

FAULT CODE 2567

Air Compressor Actuator Driver Circuit Breaker - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2567 PID: S89 SPN: 1351 FMI: 11/31 LAMP: Amber SRT: | Air Compressor Actuator Driver Circuit Breaker - Condition Exists. The ECM has diagnosed that the circuit breaker for the air starter has tripped. | Engine may not start.
ECM

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the circuit breaker for the air starter has tripped.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

A relay in the DC interface panel determines which pins in the starter connection are used for the start signal. The pins depend on whether or not an air starter or an electric starter are in use. Refer to the engine wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code 2567.

Last Modified: 20-Jul-2015


Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2568

Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2568 PID: P159 SPN: 159 FMI: 0/0 LAMP: Red SRT: | Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has diagnosed that the fuel supply pressure has become too high for safe engine operation. | Engine will be shut down.
Fuel Supply Pressure Sensor

Circuit Description

The fuel supply pressure sensor recieves 5 volts from the ECM and monitors the pressure from the gas regulator.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel supply pressure has become too high for safe engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • Damaged sensor
  • Gas pressure regulator
Refer to Troubleshooting Fault Code 2568.

Last Modified: 20-Jul-2015


Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2569

Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2569 PID: P159 SPN: 159 FMI: 1/1 LAMP: Red SRT: | Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Most Severe Level. The ECM has diagnosed that the fuel supply pressure has become too low for safe engine operation. | Engine will be shut down.
Fuel Supply Pressure Sensor

Circuit Description

The fuel supply pressure sensor recieves 5 volts from the ECM and monitors the pressure from the gas regulator.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel supply pressure has become too low for safe engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged sensor
  • Damaged wiring harness
  • Gas pressure regulator
Refer to Troubleshooting Fault Code 2569.

Last Modified: 20-Jul-2015


Engine Spark Plug #1 (A1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2586

Engine Spark Plug #1 (A1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2586 PID: SPN: 1294 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug #1 (A1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A1 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2586.

Last Modified: 20-Jul-2015


Engine Spark Plug #2 (B1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2587

Engine Spark Plug #2 (B1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2587 PID: SPN: 1295 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug #2 (B1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B1 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2587.

Last Modified: 20-Jul-2015


Engine Spark Plug #3 (A2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2588

Engine Spark Plug #3 (A2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2588 PID: SPN: 1296 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug #3 (A2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A2 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2588.

Last Modified: 20-Jul-2015


Engine Spark Plug #4 (B2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2589

Engine Spark Plug #4 (B2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2589 PID: SPN: 1297 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug #4 (B2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B2 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2589.

Last Modified: 20-Jul-2015


Engine Spark Plug #5 (A3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2591

Engine Spark Plug #5 (A3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2591 PID: SPN: 1298 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug #5 (A3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A3 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2591.

Last Modified: 20-Jul-2015


Engine Spark Plug #6 (B3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2592

Engine Spark Plug #6 (B3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2592 PID: SPN: 1299 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug #6 (B3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B3 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2592.

Last Modified: 20-Jul-2015


Engine Spark Plug #1 (A1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2593

Engine Spark Plug #1 (A1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2593 PID: SPN: 1294 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug #1 (A1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A1 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2593.

Last Modified: 20-Jul-2015


Engine Spark Plug #2 (B1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2594

Engine Spark Plug #2 (B1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2594 PID: SPN: 1295 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug #2 (B1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B1 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2594.

Last Modified: 20-Jul-2015


Engine Spark Plug #3 (A2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2595

Engine Spark Plug #3 (A2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2595 PID: SPN: 1296 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug #3 (A2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A2 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2595.

Last Modified: 20-Jul-2015


Engine Spark Plug #4 (B2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2596

Engine Spark Plug #4 (B2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2596 PID: SPN: 1297 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug #4 (B2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B2 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2596.

Last Modified: 20-Jul-2015


Engine Spark Plug #5 (A3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2597

Engine Spark Plug #5 (A3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2597 PID: SPN: 1298 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug #5 (A3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A3 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2597.

Last Modified: 20-Jul-2015


Engine Spark Plug #6 (B3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2598

Engine Spark Plug #6 (B3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2598 PID: SPN: 1299 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug #6 (B3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B3 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2598.

Last Modified: 20-Jul-2015


Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2653

Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2653 PID: SPN: 2433 FMI: 0/16 LAMP: Amber SRT: | Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level. The exhaust gas temperature sensor has detected temperature above the critical level. | None on performance.
Exhaust Gas Temperature Sensor

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the turbine inlet temperature from the right bank has become too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 2653.

Last Modified: 21-Jul-2015


Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2654

Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2654 PID: SPN: 2433 FMI: 0/0 LAMP: Red SRT: | Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has diagnosed that the turbine inlet temperature from the right has become too high. | Engine will be shut down.
Exhaust Gas Temperature Sensor

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the turbine inlet temperature from the right bank has become too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.
  • In severe cases, the ECM will immediately shut down the engine.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 2654.

Last Modified: 21-Jul-2015


Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2657

Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2657 PID: SPN: 2434 FMI: 0/16 LAMP: Amber SRT: | Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The ECM has diagnosed that the turbin inlet temperature from the left bank has become too high. | None on performance.
Exhaust Gas Temperature Sensor

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the turbine inlet temperature from the left bank has become too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 2657.

Last Modified: 21-Jul-2015


Engine Exhaust Gas Temperature - Bank 1- Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2658

Engine Exhaust Gas Temperature - Bank 1- Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2658 PID: SPN: 2434 FMI: 0/0 LAMP: Red SRT: | Engine Exhaust Gas Temperature - Bank 1- Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has diagnosed that the turbine inlet temperature from the left bank has become too high. | Engine will be shut down.
Exhaust Gas Temperature Sensor

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the turbine inlet temperature from the left bank has become too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.
  • In severe cases, the ECM will immediately shut down the engine.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust gas temperature sensor circuit measures the exhaust temperature of its respective cylinder. The ECM monitors the temperature and compares it to the threshold limit in the calibration.

Refer to Troubleshooting Fault Code 2658.

Last Modified: 21-Jul-2015


Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2737

Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2737 PID: P173 SPN: 173 FMI: 0/0 LAMP: Red SRT: | Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has diagnosed that the turbine inlet temperature has become too high. | Engine will be shut down.
Turbine Inlet Temperature Sensor

Circuit Description

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The exhaust stack temperature sensor is located in the exhaust elbow, after the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the turbine inlet temperature has become too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle start the engine and allow it to run at 100% load for 3 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code indicates that the exhaust temperature has exceeded the engine protection limits for high exhaust temperature.

Refer to Troubleshooting Fault Code 2737.

Last Modified: 21-Jul-2015


Engine Ignition Control Module #1 - Condition Exists

FAULT CODE 2766

Engine Ignition Control Module #1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2766 PID: SPN: 1292 FMI: 11/31 LAMP: Red SRT: | Engine Ignition Control Module #1 - Condition Exists. The ECM has diagnosed that the ignition module on Bank A has failed. | Engine will be shut down.
Ignition Module

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

One Ignition Control Module (ICM) is located on each bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the ignition control module on Bank A has failed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • A damaged ignition module.
Refer to Troubleshooting Fault Code 2766.

Last Modified: 21-Jul-2015


Engine Ignition Control Module #2 - Condition Exists

FAULT CODE 2767

Engine Ignition Control Module #2 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2767 PID: SPN: 1293 FMI: 11/31 LAMP: Red SRT: | Engine Ignition Control Module #2 - Condition Exists. The ECM has diagnosed that the ignition module on Bank B has failed. | Engine will be shut down.
Ignition Module

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

One Ignition Control Module (ICM) is located on each bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the ignition control module on Bank B has failed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • A damaged ignition module.
Refer to Troubleshooting Fault Code 2767.

Last Modified: 21-Jul-2015


Engine Network Master Slave Communication - Abnormal Update Rate

FAULT CODE 2768

Engine Network Master Slave Communication - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2768 PID: SPN: 629 FMI: 9/9 LAMP: Red SRT: | Engine Network Master Slave Communication - Abnormal Update Rate. The ECM has diagnosed that the panel module has stopped communicating. | Engine will be shut down.
ECM

Circuit Description

N/A

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the panel module has stopped communicating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code only exists in Power Generation applications using multiplexed inputs, and will only go active if the ECM stops receiving information from the generator drive controller over the data link

Refer to Troubleshooting Fault Code 2768.

Last Modified: 20-Jul-2015


Engine Network Slave Message - Abnormal Update Rate

FAULT CODE 2769

Engine Network Slave Message - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2769 PID: SPN: 639 FMI: 9/9 LAMP: Red SRT: | Engine Network Slave Message - Abnormal Update Rate. The ECM has diagnosed that the child module has stopped responding. | Engine will be shut down.
ECM

Circuit Description

CAN (Controller Area Network) is the high speed communication line for many of the Vehicle electronic control units (VECU). The CAN communication bus has two 2 lines (CAN H line, CAN L line). These lines are inputted to the Engine Control Module. If the ECM does not receive any messages across the CAN bus for a period of time, this fault will set.

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the child module has stopped communicating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, a bad OEM VECU, or a bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.
Refer to Troubleshooting Fault Code 2769.

Last Modified: 20-Jul-2015


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: P110 SPN: 110 FMI: 1/18 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine coolant temperature is below normal operating temperature limits. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Engine coolant temperature was less than 60°C [140°F] for over 1 hour during a period of extended idle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault indicates that coolant temperature is below a calibratible limit set in the ECM.

  • Refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree tree in the base engine service manual.
Refer to Troubleshooting Fault Code 2789.

Last Modified: 23-Jul-2015


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2793

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2793 PID: SPN: 110 FMI: 1/1 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. Engine coolant temperature is below normal operating temperature limits. | Engine will be shut down.
Engine Coolant Temperature Sensor

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was less than a calibrated threshold

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree tree in the base engine service manual.
Refer to Troubleshooting Fault Code 2793.

Last Modified: 20-Jul-2015


Generator Electrical Load Signal - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2796

Generator Electrical Load Signal - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2796 PID: SPN: 2452 FMI: 0/15 LAMP: Amber SRT: | Generator Electrical Load Signal - Data Valid But Above Normal Operating Range - Least Severe Level. Overload protection is enabled and load is higher than partial continuous load threshold for set persistence time. | None on performance.
Generator Electrical Load (KW) Signal Circuit

Circuit Description

On GenSets with PCC3300, altenator voltage and current is sensed directly at the PCC3300 unless alternator voltage is greater than 600 VAC then a PT is employed to reduce alternator voltage below 600 VAC during normal operation for PCC3300 sensing.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

Overload protection is enabled and load is higher than partial continuous load threshold for set persistence time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Alternator kW load is compared to three calibratable thresholds:

• Maximum Critical Overload Threshold with smallest fault persistence time with fault resulting in emergency shutdown.

• Medium Critical Overload Threshold (Maximum Critcial Overload Threshold > Medium Critical Overload Threshold > GenSet Rating) with longer fault persistence time than Maximum Critical Overload and fault resulting in a controlled shutdown.

• Low Critical Overload Threshold (Medium Critical Overload Threshold > Low Critical Overload Threshold > Genset Rating) with fault resulting in a warning.

Refer to Troubleshooting Fault Code 2796.

Last Modified: 20-Jul-2015


Engine Turbocharger 1 Boost Pressure - Abnormal Rate of Change

FAULT CODE 2799

Engine Turbocharger 1 Boost Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2799 PID: SPN: 1127 FMI: 10/10 LAMP: Red SRT: | Engine Turbocharger 1 Boost Pressure - Abnormal Rate of Change. The ECM has diagnosed a large change in pressure sensor voltage above the threshold. | Engine will be shut down.
Manifold Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM is constantly monitoring the compressor outlet pressure sensor signal. The ECM compares the current compressor outlet pressure reading (p-1) with the immediately preceding compressor outlet pressure reading (p). If the difference between p-1 and p (Delta p) exceeds 16psia for more than 0.01 seconds, Fault Code 2799 is activated.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This feature provides protection for the charge-air system, valve train, and power cylinders when a rapid rise in compressor outlet pressure occurs (an intake manifold over-pressure condition). The ECM compares the current compressor outlet pressure reading (p-1) with the immediately preceding compressor outlet pressure reading (p), and if the difference between p-1 and p (Delta p) exceeds 16 psia for more than 0.01 seconds, the ECM logs a fault and requests a shutdown.

Possible cause of this fault code:

• Check for external coolant leaks between each cylinder head and the block. Signs of coolant and/or oil leaks would indicate the cylinder heads have lifted during the intake manifold backfire event.

  • Plugged or restricted air filter plugged
  • Leaks in the charge air system plumbing
  • Check throttle pressure differential sensor.

• Check for free movement of the throttle throughout the full range.

• Check the charge-air cooler for leaks (coolant and air/fuel mixture). Check the charge-air cooler element for any damage resulting from the intake manifold over-pressure event.

  • Remove the valve covers. Check valve clearances. Check for any abnormalities or mis-aligned rocker gear, valve stems, valve spring assemblies, and displaced valve collets.
  • Bar the engine over by hand. Any tightness when rotating must be investigated. Dropped intake/exhaust valves and coolant leakage internal to the power cylinders must be considered, which can result in further consequential damage to power cylinder components.
  • Inspect the turbocharger compressor wheel blades for signs of damage and contact with the compressor housing. If there are any signs of damage, then the turbocharger must be replaced before starting the generator set.
  • Following start-up of the generator set, carefully monitor individual cylinder exhaust temperatures via the Human Machine Interface. Any cold cylinders must be investigated using appropriate investigation and troubleshooting methods.
Refer to Troubleshooting Fault Code 2799.

Last Modified: 20-Jul-2015


Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2811

Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2811 PID: SPN: 1127 FMI: 0/0 LAMP: Red SRT: | Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operational Range - Most Severe Level. With compressor outlet pressure (COP) maximum diagnostic enabled and the COP maximum is greater than the COP maximum threshold for the COP maximum set duration. | Engine will be shut down.
Compressor Outlet Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to compressor outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the ECM on the compressor outlet pressure sensor signal circuit.

Component Location

Located between the turbo outlet and charge air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

With compressor outlet pressure (COP) maximum diagnostic enabled and the COP maximum is greater than the COP maximum threshold for the COP maximum set duration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This feature provides protection for the charge-air system, valve train, and power cylinders when a rapid rise in compressor outlet pressure occurs (an intake manifold over-pressure condition). The ECM compares the current compressor outlet pressure reading (p-1) with the immediately preceding compressor outlet pressure reading (p), and if the difference between p-1 and p (Delta p) exceeds 16 psia for more than 0.01 seconds, the ECM logs a fault and requests a shutdown.

Refer to Troubleshooting Fault Code 2811.

Last Modified: 20-Jul-2015


Electronic Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2812

Electronic Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2812 PID: SPN: 3464 FMI: 2/2 LAMP: Red SRT: | Electronic Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect. No communication with the Throttle Control Valve. | Engine will be shut down.
Throttle Control Valve

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that it has stopped receiving messages from the Throttle Control Valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, run the “Actuator Diagnostic Tests” test in INSITE.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • A malfunctioning engine intake air throttle actuator
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2812.

Last Modified: 29-Jul-2015


Exhaust Gas Temperature Cylinder 1 (A1) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2837

Exhaust Gas Temperature Cylinder 1 (A1) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2837 PID: SPN: 1137 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2837.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 3 (A2) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2838

Exhaust Gas Temperature Cylinder 3 (A2) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2838 PID: SPN: 1139 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2838.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 5 (A3) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2839

Exhaust Gas Temperature Cylinder 5 (A3) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2839 PID: SPN: 1141 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2839.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 7 (A4) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2841

Exhaust Gas Temperature Cylinder 7 (A4) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2841 PID: SPN: 1143 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2841.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 9 (A5) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2842

Exhaust Gas Temperature Cylinder 9 (A5) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2842 PID: SPN: 1145 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2842.

Last Modified: 29-Jul-2015


Exhaust Gas Temperature Cylinder 11 (A6) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2843

Exhaust Gas Temperature Cylinder 11 (A6) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2843 PID: SPN: 1147 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2843.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 13 (A7) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2844

Exhaust Gas Temperature Cylinder 13 (A7) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2844 PID: SPN: 1149 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2844.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 15 (A8) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2845

Exhaust Gas Temperature Cylinder 15 (A8) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2845 PID: SPN: 1151 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2845.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 2 (B1) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2847

Exhaust Gas Temperature Cylinder 2 (B1) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2847 PID: SPN: 1138 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2847.

Last Modified: 09-Feb-2016


Exhaust Gas Temperature Cylinder 4 (B2) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2848

Exhaust Gas Temperature Cylinder 4 (B2) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2848 PID: SPN: 1140 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 4 (B2) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2848.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 6 (B3) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2849

Exhaust Gas Temperature Cylinder 6 (B3) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2849 PID: SPN: 1142 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 6 (B3) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2849.

Last Modified: 09-Feb-2016


Exhaust Gas Temperature Cylinder 8 (B4) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2851

Exhaust Gas Temperature Cylinder 8 (B4) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2851 PID: SPN: 1144 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2851.

Last Modified: 09-Feb-2016


Exhaust Gas Temperature Cylinder 10 (B5) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2852

Exhaust Gas Temperature Cylinder 10 (B5) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2852 PID: SPN: 1146 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 10 (B5) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2852.

Last Modified: 09-Feb-2016


Exhaust Gas Temperature Cylinder 12 (B6) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2853

Exhaust Gas Temperature Cylinder 12 (B6) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2853 PID: SPN: 1148 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 12 (B6) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2853.

Last Modified: 20-Jul-2015


Exhaust Gas Temperature Cylinder 14 (B7) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2854

Exhaust Gas Temperature Cylinder 14 (B7) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2854 PID: SPN: 1150 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 14 (B7) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhasut Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2854.

Last Modified: 29-Jul-2015


Exhaust Gas Temperature Cylinder 16 (B8) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2855

Exhaust Gas Temperature Cylinder 16 (B8) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2855 PID: SPN: 1152 FMI: 2/2 LAMP: Maintenance SRT: | Exhaust Gas Temperature Cylinder 16 (B8) - Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature reading deviated from the average exhaust gas temperature reading of the engine. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature deviated from the average of the exhaust gas temperatures by more than the engine protection warning limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, varying fault locations, etc. Individual cylinder variation alarms can be an indication of mis-firing within the cylinder, potentially caused by a malfunctioning spark plug, spark plug wire, spark plug coil, or an ignition control module, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

Refer to Troubleshooting Fault Code 2855.

Last Modified: 20-Jul-2015


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2857

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2857 PID: P103 SPN: 103 FMI: 0/0 LAMP: Red SRT: | Turbocharger Number 1 Speed High - Data Valid but Above Normal Operational Range - Most Severe Level. High turbocharger speed has been detected. | Engine will be shut down.
Turbocharger Speed Sensor

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The ECM detected the turbocharger shaft rotation speed as greater than the critical high speed threshold for the critical dwell time. High turbocharger shaft speed can result in shortened shaft bearing life or significant turbocharger damage with aftercooler contamination or engine contaminant ingestion if turbocharger rotating components break due to the high speed rotational forces. This can be caused by:

  • A damaged turbocharger speed sensor

• Engine running in an overload condition

• Engine running at or near rated load but the air/fuel mixture is too lean

Refer to Troubleshooting Fault Code 2857.

Last Modified: 20-Jul-2015


Engine ECM to Power Command Controller (PCC) Communication - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2863

Engine ECM to Power Command Controller (PCC) Communication - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2863 PID: SPN: 520381 FMI: 2/2 LAMP: Red SRT: | Engine ECM to Gen Set Controller Communications - Data Erratic, Intermittent, or Incorrect. The ECM J1939 communication data link with generator set control message timed out error count is higher than fault threshold. | Engine will be shut down.
J1939

Circuit Description

On generator sets with PowerCommand® control 3300, the generator set circuit breaker position is a PowerCommand® control baseboard input. Idle/rated mode of operation is controlled by the PowerCommand® control 3300 and can be toggled either via InPower™ electronic service tool or in the generator set human machine interface. The PowerCommand® control 3300 communicates these signals to the ECM via the J1939 communications network.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM J1939 communication data link with generator set control message timed out error count is higher than fault threshold.

Action Taken When the Fault Code is Active

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The SAE J1939 data link is a network data link on which each ECM is attached via a network stub connection. Make sure that the electronic service tool is set up for J1939 communications (if applicable) when using this data link.

Refer to Troubleshooting Fault Code 2863.

Last Modified: 20-Jul-2015


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2864

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2864 PID: SPN: 632 FMI: 3/3 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or short to voltage source detected at fuel shutoff valve circuit. | Engine will be shut down.
Fuel Shutoff Valve

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the Fuel Shutoff Valve (FSO) control wire has been shorted to a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning fuel shutoff valve.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 2864.

Last Modified: 21-Jul-2015


Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2868

Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2868 PID: SPN: 3604 FMI: 0/16 LAMP: Amber SRT: | Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level. With the engine heater over temperature diagnostic enabled, the engine heater over temperature input is active and the engine heater is commanded on. | Warning, loss of engine heater control.
HT Coolant Temperature Sensor

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

With the engine heater over temperature diagnostic enabled, the engine heater over temperature input is active and the engine heater is commanded on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and engine heater ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Coolant heaters are employed to ease engine start-up by maintaining engine block temperature and assisting engine oil heater operation to near normal operating temperatures.

Refer to Troubleshooting Fault Code 2868.

Last Modified: 20-Jul-2015


High Temperature Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

FAULT CODE 2869

High Temperature Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2869 PID: SPN: 520382 FMI: 6/6 LAMP: Amber SRT: | High Temperature Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit. With the high temperature control support enabled, the high temperature control circuit driver current is greater than the driver's OOR high limit for the duration of the persistence time. | None on performance.
High Temperature Cooling Circuit

Circuit Description

The high temperature (HT) coolant control circuit driver is a 4-20mA signal, sent from the ECM to the high temperature controller. The high temperature (HT) controller uses this signal to determine the desired position of the temperature control valve.

Component Location

The temperarure control valve is located after the HT temperature sensor and before the block in the cooling circuit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

With the high temperature control support enabled, the high temperature control circuit driver current is greater than the driver's OOR high limit for the duration of the persistence time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The high temperature (HT) cooling circuit is controlled by an off engine temperature control valve. On-engine wax type thermostats are not used, as they do not provide the required level of temperature control. The high temperature (HT) control circuit consists of the CM700, temperature controller, 2 solid state relays (one to open the valve and one to close the valve), and the off engine mounted temperature control valve.

Refer to Troubleshooting Fault Code 2869.

Last Modified: 20-Jul-2015


High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit

FAULT CODE 2871

High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2871 PID: SPN: 520382 FMI: 5/5 LAMP: Amber SRT: | High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit. With High Temperature (HT) coolant temperature control support enabled, the HT temperature control circuit driver current is below the driver's OOR low limit for the duration of the persistence time. | None on performance.
High Temperature Cooling Circuit Driver

Circuit Description

The high temperature (HT) coolant control circuit driver is a 4-20mA signal, sent from the ECM to the high temperature controller. The high temperature (HT) controller uses this signal to determine the desired position of the temperature control valve.

Component Location

The temperarure control valve is located after the HT temperature sensor and before the block in the cooling circuit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

. With High Temperature (HT) coolant temperature control support enabled, the HT temperature control circuit driver current is below the driver's OOR low limit for the duration of the persistence time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The high temperature (HT) cooling circuit is controlled by an off engine temperature control valve. On-engine wax type thermostats are not used, as they do not provide the required level of temperature control. The high temperature (HT) control circuit consists of the CM700, temperature controller, 2 solid state relays (one to open the valve and one to close the valve), and the off engine mounted temperature control valve.

Refer to Troubleshooting Fault Code 2871.

Last Modified: 20-Jul-2015


High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists

FAULT CODE 2872

High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2872 PID: SPN: 520382 FMI: 11/31 LAMP: Amber SRT: | High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists. With High Temperature (HT) coolant temperature control support enabled, the HT Control Valve Trip signal is active. | None on performance.
HT High Temperature Cooling Circuit Driver

Circuit Description

The high temperature (HT) coolant control circuit driver is a 4-20mA signal, sent from the ECM to the high temperature controller. The high temperature (HT) controller uses this signal to determine the desired position of the temperature control valve.

Component Location

The temperarure control valve is located after the HT temperature sensor and before the block in the cooling circuit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

With High Temperature (HT) coolant temperature control support enabled, the HT Control Valve Trip signal is active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The high temperature (HT) cooling circuit is controlled by an off engine temperature control valve. On-engine wax type thermostats are not used, as they do not provide the required level of temperature control. The high temperature (HT) control circuit consists of the CM700, temperature controller, 2 solid state relays (one to open the valve and one to close the valve), and the off engine mounted temperature control valve.

Refer to Troubleshooting Fault Code 2872.

Last Modified: 20-Jul-2015


Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

FAULT CODE 2873

Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2873 PID: SPN: 520383 FMI: 6/6 LAMP: Amber SRT: | Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit. With Low Temperature (LT) and High Temperature (HT) coolant temperature control support enabled, the LT temperature control circuit driver current is above the driver's OOR high limit for the duration of the persistence time. | None on performance.
Low Temperature Cooling Circuit Driver

Circuit Description

The ECM supplies the LT temperature controller with a 24-VDC, 4 to 20-mA signal, which the LT temperature controller uses to determine the desired position of the LT temperature control valve.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

. With Low Temperature (LT) and High Temperature (HT) coolant temperature control support enabled, the LT temperature control circuit driver current is above the driver's OOR high limit for the duration of the persistence time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The terminology "LT Cooling Circuit" refers to the same cooling circuit as the "Aftercooler Cooling Circuit". For general applications, the Aftercooler term applies and therefore is employed in the fault description; for Energy Solutions applications, LT is more commonly employed and therefore referenced in this procedure to a greater extent than Aftercooler.

The LT coolant temperature control circuit consists of the ECM, one electronic temperature control, one off-engine temperature control valve and two solid state relays, one to command opening the temperature control valve and one to command closure. On-engine, wax-type thermostats are not used due to the requirement for increased circuit temperature control about the nominal operating temperature so-as to optimize the genset's efficiency.

Refer to Troubleshooting Fault Code 2873.

Last Modified: 20-Jul-2015


Aftercooler Cooling Circuit Current Driver - Current Below Normal or Open Circuit

FAULT CODE 2874

Aftercooler Cooling Circuit Current Driver - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2874 PID: SPN: 520383 FMI: 5/5 LAMP: Amber SRT: | Aftercooler Cooling Circuit Current Driver - Current Below Normal or Grounded Circuit. With Low Temperature (LT) and High Temperature (HT) coolant temperature control support enabled, the LT temperature control circuit driver current is below the driver's OOR high limit for the duration of the persistence time. | None on performance.
Low Temperature Cooling Circuit Driver

Circuit Description

The ECM supplies the LT temperature controller with a 24-VDC, 4 to 20-mA signal, which the LT temperature controller uses to determine the desired position of the LT temperature control valve.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

With Low Temperature (LT) and High Temperature (HT) coolant temperature control support enabled, the LT temperature control circuit driver current is below the driver's OOR high limit for the duration of the persistence time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The terminology "LT Cooling Circuit" refers to the same cooling circuit as the "Aftercooler Cooling Circuit". For general applications, the Aftercooler term applies and therefore is employed in the fault description; for Energy Solutions applications, LT is more commonly employed and therefore referenced in this procedure to a greater extent than Aftercooler.

The LT coolant temperature control circuit consists of the ECM, one electronic temperature control, one off-engine temperature control valve and two solid state relays, one to command opening the temperature control valve and one to command closure. On-engine, wax-type thermostats are not used due to the requirement for increased circuit temperature control about the nominal operating temperature so-as to optimize the genset's efficiency.

Refer to Troubleshooting Fault Code 2874.

Last Modified: 20-Jul-2015


Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists

FAULT CODE 2875

Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2875 PID: SPN: 520383 FMI: 11/31 LAMP: Amber SRT: | Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists. With Low Temperature (LT) coolant temperature control support enabled, the LT Control Valve Trip signal is active. | None on performance.
Low Temperature Cooling Circuit Driver

Circuit Description

The ECM supplies the LT temperature controller with a 24-VDC, 4 to 20-mA signal, which the LT temperature controller uses to determine the desired position of the LT temperature control valve.

Component Location

Generator Control Panel

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

With Low Temperature (LT) coolant temperature control support enabled, the LT Control Valve Trip signal is active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The terminology "LT Cooling Circuit" refers to the same cooling circuit as the "Aftercooler Cooling Circuit". For general applications, the Aftercooler term applies and therefore is employed in the fault description; for Energy Solutions applications, LT is more commonly employed and therefore referenced in this procedure to a greater extent than Aftercooler.

The LT coolant temperature control circuit consists of the ECM, one electronic temperature control, one off-engine temperature control valve and two solid state relays, one to command opening the temperature control valve and one to command closure. On-engine, wax-type thermostats are not used due to the requirement for increased circuit temperature control about the nominal operating temperature so-as to optimize the genset's efficiency.

Refer to Troubleshooting Fault Code 2875.

Last Modified: 20-Jul-2015


Turbocharger 1 Compressor Intake Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2876

Turbocharger 1 Compressor Intake Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2876 PID: SPN: 1172 FMI: 1/1 LAMP: Red SRT: | Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. The temperature of the air entering the turbocharger compressor inlet is below the critical threshold. | Engine will be shut down.
Compressor Inlet Temperature Sensor

Circuit Description

The turbocharger 1 compressor inlet air temperature sensor is a variable resistance sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The ECM module supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine compressor inlet air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed the the temperature of the air entering the turbocharger compressor inlet is below the critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Intake manifold pressure will increase as air density increases. Generally, air density increases as air temperature decreases. As air density increases, the likelihood for turbocharger compressor surge increases.

Possible cause of this fault code:

• Incorrect engine room ventilation fan control

• Incorrect engine room motorized louvre control

• Turbocharger compressor air inlet temperature sensor failed in range (this will not activate Fault Code 691 or 692).

Refer to Troubleshooting Fault Code 2876.

Last Modified: 20-Jul-2015


Turbocharger 1 Compressor Intake Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2877

Turbocharger 1 Compressor Intake Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2877 PID: SPN: 1172 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The temperature of the air entering the turbocharger compressor inlet is below the critical threshold. | Possible reduced engine performance.
Turbocharger Inlet Temperature Sensor

Circuit Description

The turbocharger 1 compressor inlet air temperature sensor is a variable resistance sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The ECM module supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine compressor inlet air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed the the temperature of the air entering the turbocharger compressor inlet is below the critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Intake manifold pressure will increase as air density increases. Generally, air density increases as air temperature decreases. As air density increases, the likelihood for turbocharger compressor surge increases.

Possible cause of this fault code:

• Incorrect engine room ventilation fan control

• Incorrect engine room motorized louvre control

• Turbocharger compressor air inlet temperature sensor failed in range (this will not activate Fault Code 691 or 692).

Refer to Troubleshooting Fault Code 2877.

Last Modified: 20-Jul-2015


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect. The intake manifold pressure reading is erratic or not rational. | Possible reduced engine performance.
Intake Manifold Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold pressure sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON and when engine has been stopped for 30 seconds.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the intake manifold pressure sensor is drifting in range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault are:

  • A damaged intake manifold pressure sensor
  • Leaks in the air intake system between the turbocharger and intake manifold
  • Restriction in the charge-air cooler
  • A damaged turbocharger speed sensor
  • A damaged turbocharger compressor intake temperature sensor.
Refer to Troubleshooting Fault Code 2973.

Last Modified: 20-Jul-2015


Engine Control Module Internal Failure - Special Instructions

FAULT CODE 2994

Engine Control Module Internal Failure - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2994 PID: SPN: 629 FMI: 14/14 LAMP: Amber SRT: | Engine Control Module Internal Failure – Special Instructions – Modbus Processor Fails to Initialize Properly at Power-up. | None on performance.
ECM

Circuit Description

N/A

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

Modbus Processor Fails to Initialize Properly at Power-up.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 2994.

Last Modified: 20-Jul-2015


Engine Cylinder 1 (A1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3111

Engine Cylinder 1 (A1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3111 PID: S90 SPN: 1352 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 1 (A1) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3111.

Last Modified: 20-Jul-2015


Engine Cylinder 2 (B1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3112

Engine Cylinder 2 (B1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3112 PID: S91 SPN: 1353 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 2 (B1) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3112.

Last Modified: 20-Jul-2015


Engine Cylinder 3 (A2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3113

Engine Cylinder 3 (A2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3113 PID: S92 SPN: 1354 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 3 (A2) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3113.

Last Modified: 20-Jul-2015


Engine Cylinder 4 (B2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3114

Engine Cylinder 4 (B2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3114 PID: S93 SPN: 1355 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 4 (B2) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3114.

Last Modified: 20-Jul-2015


Engine Cylinder 5 (A3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3115

Engine Cylinder 5 (A3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3115 PID: S94 SPN: 1356 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 5 (A3) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3115.

Last Modified: 20-Jul-2015


Engine Cylinder 6 (B3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3116

Engine Cylinder 6 (B3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3116 PID: S95 SPN: 1357 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 6 (B3) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3116.

Last Modified: 20-Jul-2015


Engine Cylinder 7 (A4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3117

Engine Cylinder 7 (A4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3117 PID: S96 SPN: 1358 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 7 (A4) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3117.

Last Modified: 20-Jul-2015


Engine Cylinder 8 (B4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3118

Engine Cylinder 8 (B4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3118 PID: S97 SPN: 1359 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 8 (B4) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3118.

Last Modified: 20-Jul-2015


Engine Cylinder 9 (A5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3119

Engine Cylinder 9 (A5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3119 PID: S98 SPN: 1360 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 9 (A5) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3119.

Last Modified: 20-Jul-2015


Engine Cylinder 10 (B5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3121

Engine Cylinder 10 (B5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3121 PID: S99 SPN: 1361 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 10 (B5) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3121.

Last Modified: 20-Jul-2015


Engine Cylinder 11 (A6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3122

Engine Cylinder 11 (A6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3122 PID: S100 SPN: 1362 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 11 (A6) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3122.

Last Modified: 20-Jul-2015


Engine Cylinder 12 (B6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3123

Engine Cylinder 12 (B6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3123 PID: S101 SPN: 1363 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 12 (B6) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3123.

Last Modified: 20-Jul-2015


Engine Cylinder 13 (A7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3124

Engine Cylinder 13 (A7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3124 PID: S102 SPN: 1364 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 13 (A7) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3124.

Last Modified: 20-Jul-2015


Engine Cylinder 14 (B7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3125

Engine Cylinder 14 (B7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3125 PID: S103 SPN: 1365 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 14 (B7) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine KnockSensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3125.

Last Modified: 20-Jul-2015


Engine Cylinder 15 (A8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3126

Engine Cylinder 15 (A8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3126 PID: S104 SPN: 1366 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 15 (A8) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3126.

Last Modified: 20-Jul-2015


Engine Cylinder 16 (B8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3127

Engine Cylinder 16 (B8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3127 PID: S105 SPN: 1367 FMI: 14/14 LAMP: Red SRT: | Engine Cylinder 16 (B8) Knock Sensor Excessive Mechanical Vibration - Special Instructions. Excessive mechanical vibration has been detected. | Engine will be shut down.
Engine Knock Sensor Circuit

Circuit Description

The Engine Control Module (ECM) uses the knock sensors to monitor each cylinder for excessive engine knock. The knock sensor is a piezoelectric type sensor that generates a voltage on the sensor signal wire proportional to the intensity of the knock being detected. The voltage generated by the sensor will increase as knock intensity increases.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and the intake manifold pressure is below 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected mechanical vibration above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Each cylinder is fitted with a knock sensor. The ECM on each bank monitors all the knock sensors for that back. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be comprimised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning Alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function properly, it must be installed and tightened to the correct torque.

The knock sensor can also detect mechanical noise. Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

Valve train / rocker gear wear

Excessive valve recession

Valve rotator cracked / broken

  • Rocker lever elephant foot o-ring displaced resulting in mechnical vibration

Connecting rod bushing / bearing excessive wear

Piston cooling nozzle bent or broken

Piston ring damage

Cylinder head gasket leakage

Exhaust (multi-duct) gasket leakage

Vibration resulting from loose engine parts / components

Refer to Troubleshooting Fault Code 3127.

Last Modified: 20-Jul-2015


Engine Spark Plug 7 (A4) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3262

Engine Spark Plug 7 (A4) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3262 PID: SPN: 1300 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 7 (A4) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A4 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3262.

Last Modified: 20-Jul-2015


Engine Spark Plug 7 (A4) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3263

Engine Spark Plug 7 (A4) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3263 PID: SPN: 1300 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 7 (A4) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A4 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3263.

Last Modified: 20-Jul-2015


Engine Spark Plug 8 (B4) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3264

Engine Spark Plug 8 (B4) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3264 PID: SPN: 1301 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 8 (B4) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B4 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3264.

Last Modified: 20-Jul-2015


Engine Spark Plug 8 (B4) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3265

Engine Spark Plug 8 (B4) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3265 PID: SPN: 1301 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 8 (B4) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B4 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3265.

Last Modified: 20-Jul-2015


Engine Spark Plug 9 (A5) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3266

Engine Spark Plug 9 (A5) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3266 PID: SPN: 1302 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 9 (A5) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A5 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3266.

Last Modified: 20-Jul-2015


Engine Spark Plug 9 (A5) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3267

Engine Spark Plug 9 (A5) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3267 PID: SPN: 1302 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 9 (A5) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A5 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3267.

Last Modified: 20-Jul-2015


Engine Spark Plug 10 (B5) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3268

Engine Spark Plug 10 (B5) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3268 PID: SPN: 1303 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 10 (B5) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B5 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3268.

Last Modified: 20-Jul-2015


Engine Spark Plug 10 (B5) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3269

Engine Spark Plug 10 (B5) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3269 PID: SPN: 1303 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 10 (B5) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B5 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3269.

Last Modified: 20-Jul-2015


Engine Spark Plug 11 (A6) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3271

Engine Spark Plug 11 (A6) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3271 PID: SPN: 1304 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 11 (A6) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A6 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3271.

Last Modified: 20-Jul-2015


Engine Spark Plug 11 (A6) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3272

Engine Spark Plug 11 (A6) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3272 PID: SPN: 1304 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 11 (A6) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A6 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3272.

Last Modified: 20-Jul-2015


Engine Spark Plug 12 (B6) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3273

Engine Spark Plug 12 (B6) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3273 PID: SPN: 1305 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 12 (B6) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B6 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3273.

Last Modified: 20-Jul-2015


Engine Spark Plug 12 (B6) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3274

Engine Spark Plug 12 (B6) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3274 PID: SPN: 1305 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 12 (B6) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Curcuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B6 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3274.

Last Modified: 20-Jul-2015


Engine Spark Plug 13 (A7) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3275

Engine Spark Plug 13 (A7) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3275 PID: SPN: 1306 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 13 (A7) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A7 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3275.

Last Modified: 20-Jul-2015


Engine Spark Plug 13 (A7) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3276

Engine Spark Plug 13 (A7) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3276 PID: SPN: 1306 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 13 (A7) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A7 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3276.

Last Modified: 20-Jul-2015


Engine Spark Plug 14 (B7) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3277

Engine Spark Plug 14 (B7) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3277 PID: SPN: 1307 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 14 (B7) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B7 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3277.

Last Modified: 20-Jul-2015


Engine Spark Plug 14 (B7) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3278

Engine Spark Plug 14 (B7) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3278 PID: SPN: 1307 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 14 (B7) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B7 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3278.

Last Modified: 20-Jul-2015


Engine Spark Plug 15 (A8) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3279

Engine Spark Plug 15 (A8) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3279 PID: SPN: 1308 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 15 (A8) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A8 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3279.

Last Modified: 20-Jul-2015


Engine Spark Plug 15 (A8) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3281

Engine Spark Plug 15 (A8) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3281 PID: SPN: 1308 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 15 (A8) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A8 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3281.

Last Modified: 20-Jul-2015


Engine Spark Plug 16 (B8) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3282

Engine Spark Plug 16 (B8) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3282 PID: SPN: 1309 FMI: 0/15 LAMP: None SRT: | Engine Spark Plug 16 (B8) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B8 is sparking with high voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3282.

Last Modified: 20-Jul-2015


Engine Spark Plug 16 (B8) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3283

Engine Spark Plug 16 (B8) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3283 PID: SPN: 1309 FMI: 1/17 LAMP: None SRT: | Engine Spark Plug 16 (B8) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level. Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Coil Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and intake manifold pressure is at least 22 psi.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B8 is sparking with low voltage.

Action Taken When the Fault Code is Active

None

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 3283.

Last Modified: 20-Jul-2015


Engine Electrical System Power Conservation Control - Voltage Above Normal or Shorted to High Source

FAULT CODE 3362

Engine Electrical System Power Conservation Control - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3362 PID: SPN: 3603 FMI: 3/3 LAMP: Amber SRT: | Engine Electrical System Power Conservation Control - Voltage Above Normal or Shorted to High Source. The ECM has dignosed that the battery conservation relay is shorted to a battery source. | None on performance.
ECM

Circuit Description

The electronic control module (ECM) uses the battery conservation relay driver circuit to control power to the electronic fuel control valve and the throttle actuator.

Component Location

The battery conservation relay driver circuit is located in the wiring harness, ECM, and original equipment manufacturer (OEM) control panel.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF. The fault will be active at the next key-ON event.

Conditions for Setting the Fault Codes

The ECM has dignosed that the battery conservation relay is shorted to a battery source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Ten seconds after the ECM has detected the engine has been shut down, it will de-energize the battery conservation relay which will disconnect power to the electronic fuel control valve and throttle actuator. This fault code occurs when the ECM battery conservation relay driver is commanded OFF, but still sees 24-VDC at the battery conservation relay supply pin in the ECM. This fault code also occurs if there is an open in this circuit.

Refer to Troubleshooting Fault Code 3362.

Last Modified: 20-Jul-2015


Engine Electrical System Power Conservation Control - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3363

Engine Electrical System Power Conservation Control - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3363 PID: SPN: 3603 FMI: 4/4 LAMP: Amber SRT: | Engine Electrical System Power Conservation Control - Voltage Below Normal or Shorted to Low Source. The ECM has diagnosed low voltage at the battery conservation relay. | Engine may run rough, may stop running, may not start, or may be difficult to start.
ECM

Circuit Description

The electronic control module (ECM) uses the battery conservation relay driver circuit to control power to the electronic fuel control valve and the throttle actuator.

Component Location

The battery conservation relay driver circuit is located in the wiring harness, ECM, and original equipment manufacturer (OEM) control panel.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF. The fault will be active at the next key-ON event.

Conditions for Setting the Fault Codes

This fault code occurs when the ECM battery conservation relay driver is commanded ON, but there is low voltage at the battery conservation relay supply pin in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Ten seconds after the ECM has detected the engine has been shut down, it will de-energize the battery conservation relay which will disconnect power to the electronic fuel control valve and throttle actuator. This fault code occurs when the ECM battery conservation relay driver is commanded ON, but there is low voltage at the battery conservation relay supply pin in the ECM.

Refer to Troubleshooting Fault Code 3363.

Last Modified: 20-Jul-2015


Knock Sensor Based Engine Derate - Condition Exists

FAULT CODE 3458

Knock Sensor Based Engine Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3458 PID: SPN: 731 FMI: 11/31 LAMP: Amber SRT: | Knock Sensor Based Engine Derate - Condition Exists. The ECM is reporting the engine is derating due to knock. | Engine power derate.
ECM

Circuit Description

N/A

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) is reporting that the engine is derating due to knock.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignituon and knock occuring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise accociated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of a knock is not identified and recitified, engine damage can occur.

Refer to Troubleshooting Fault Code 3458.

Last Modified: 20-Jul-2015


Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

FAULT CODE 3489

Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3489 PID: SPN: 3470 FMI: 11/31 LAMP: Amber SRT: | Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists. The Compressor Bypass Valve (CBV) has reported to the ECM that it has powered up incorrectly. | Possible reduced engine performance.
Compressor Bypass Valve

Circuit Description

The compressor bypass valve is controlled by the ECM and is used to bleed excessive boost pressure bofore the compressed mix reaches the throttle plate.

Component Location

The Compressor Bypass Valve is located in the piping between the Turbo and Throttle Valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Compressor Bypass Valve (CBV) has reported to the Engine Control Module (ECM) that it has powered up incorrectly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Damaged wiring harness
  • A malfunctioning Compressor Bypass Valve.
Refer to Troubleshooting Fault Code 3489.

Last Modified: 20-Jul-2015


Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3491

Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3491 PID: SPN: 99 FMI: 0/0 LAMP: Red SRT: | Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has diagnosed that the oil filter differential pressure, as measured by the inlet and outlet oil filter pressure sensors, has exceeded the critical threshold level. | Engine will be shut down.
Oil Filter Inlet and Outlet Pressure Sensors

Circuit Description

The engine control module (ECM) uses the oil filter intake pressure sensor and engine oil pressure sensor to determine the oil filter restriction.

Component Location

The post-filter oil pressure sensor is located between the oil filter and the oil cooler.

The pre-oil filter pressure sensor is located on the intake of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the oil filter differential pressure, as measured by the inlet and outlet oil filter pressure sensors, has exceeded the critical threshold level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • High oil filter restriction.
  • A malfunctioning engine oil filter intake pressure sensor.
  • A malfunctioning engine oil filter outlet pressure sensor.
Refer to Troubleshooting Fault Code 3491.

Last Modified: 20-Jul-2015


Engine Throttle Control Actuator CAN Commanded Shutdown - Special Instructions

FAULT CODE 3515

Engine Throttle Control Actuator CAN Commanded Shutdown - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3515 PID: P190 SPN: 3464 FMI: 14/14 LAMP: Red SRT: | Engine Throttle Control Actuator CAN Commanded Shutdown - Special Instructions. The Throttle Control Valve has reported to the ECM that it has been commanded to shut down. | Engine will be shut down.
Throttle Control Valve

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Throttle Control Valve has reported to the Engine Control Module (ECM) that it has been commanded to shut down.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning engine intake air throttle actuator
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3515.

Last Modified: 20-Jul-2015


Engine Throttle Control Actuator Temperature - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3521

Engine Throttle Control Actuator Temperature - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3521 PID: SPN: 3464 FMI: 1/17 LAMP: Amber SRT: | Engine Throttle Control Actuator Temperature - Data Valid But Below Normal Operating Range - Least Severe Level. Low engine throttle control actuator temperature has been detected. | None on performance.
Throttle Control Valve

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Throttle Control Valve has reported to the Engine Control Module (ECM) that its internal temperature is too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning engine intake air throttle actuator
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3521.

Last Modified: 20-Jul-2015


Engine Derate - Special Instructions

FAULT CODE 3584

Engine Derate - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3584 PID: SPN: 3644 FMI: 14/14 LAMP: Red SRT: | Engine Derate - Special Instructions. The generator set or utility paralleling circuit breaker has open while the engine is in an active state of self-derate. | Engine will be shut down.
Reference to site specific wiring diagrams for the generator set circuit breaker and the utility paralleling circuit breaker wiring.

Circuit Description

Engine derate features are only active while the generator set is operating in utility parallel mode. If any of the paralleling circuits breakers open (the utility paralleling circuit breaker or the generator set circuit breaker), while the engine is on load but in an active state of self-derate, then the control system will initiate an immediate shutdown in order to prevent severe engine over speed.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The generator set or utility paralleling circuit breaker has open while the engine is in an active state of self-derate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

For generator sets operating in utility parallel applications, a number of engine derate features have been introduced so that power generation can be maintained, but at a reduced output. The level of derate permitted is limited and varies between engine models and software versions.

Refer to Troubleshooting Fault Code 3584.

Last Modified: 29-Jul-2015


Generator Total Real Power - Root Cause Not Known

FAULT CODE 3585

Generator Total Real Power - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3585 PID: SPN: 2452 FMI: 11/11 LAMP: Amber SRT: | Generator Total Real Power - Root Cause Not Known. The ECM has diagnosed that the kilowatt load signal coming from the genset controller has been lost. | None on performance.
ECM

Circuit Description

N/A

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the kilowatt load signal coming from the genset controller has been lost.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code only exists in Power Generation applications using multiplexed inputs, and will only go active if the ECM stops receiving Speed Bias, Alternate Frequency, or Idle/Rated information from the generator drive controller over the data link.

Refer to Troubleshooting Fault Code 3585.

Last Modified: 20-Jul-2015


Generator Total Real Power - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3586

Generator Total Real Power - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3586 PID: SPN: 2452 FMI: 2/2 LAMP: Amber SRT: | Generator Total Real Power - Data Erratic, Intermittent, or Incorrect. The ECM has diagnosed that the kilowatt load signal coming from the genset controller is incorrect. | None on performance.
ECM

Circuit Description

N/A

Component Location

N/A

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the kilowatt load signal coming from the genset controller is incorrect.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code only exists in Power Generation applications using multiplexed inputs, and will only go active if the ECM stops receiving Speed Bias, Alternate Frequency, or Idle/Rated information from the generator drive controller over the data link.

Refer to Troubleshooting Fault Code 3586.

Last Modified: 20-Jul-2015


Engine Emissions Closed Loop Fueling Adjustment - Condition Exists

FAULT CODE 3594

Engine Emissions Closed Loop Fueling Adjustment - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3594 PID: SPN: 520485 FMI: 11/31 LAMP: Amber SRT: | Engine Emissions Closed Loop fueling (Limit) - Condition Exists. The engine closed loop fueling control has reached the limit of adjustment within the calibration. | Possible reduced engine performance.
ECM

Circuit Description

Torque-over-boost is a method of calculating the engines actual air/fuel ratio (measured) for a given operating condition and the key inputs are generator kilowatts (KW = torque) and intake manifold pressure (boost).

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the closed loop fueling control has reached the limit of adjustment within the calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

If the sensors used for fueling control and the fuel remain within specification (fuel Lower Heating Value (LHV) ±4 percent), then the fueling and exhaust emissions will be maintained across a wide range of operating conditions. The fueling and emissions can begin to drift out of specification if one or more of the input sensors or the fuel quality begins to deviate outside of its specification. The ECM can, up to a limit, compensate for these deviations. However, if the sensor condition or fuel quality continues to deteriorate, the ECM will eventually reach the limit of adjustment within the fuel map and engine performance will be compromised. When this limit of adjustment is reached, Fault Code 3594 will be activated.

Refer to Troubleshooting Fault Code 3594.

Last Modified: 20-Jul-2015


Engine Emissions Closed Loop Fueling Adjustment - Root Cause Not Known

FAULT CODE 3595

Engine Emissions Closed Loop Fueling Adjustment - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3595 PID: SPN: 520485 FMI: 11/11 LAMP: Red SRT: | Engine Emissions Closed Loop Fueling Adjustment - Root Cause Not Known. The ECM has diagnosed that the closed loop fueling control has reached the limit of adjustment within the calibration. | Engine will be shut down.
ECM

Circuit Description

Torque-over-boost is a method of calculating the engines actual air/fuel ratio (measured) for a given operating condition and the key inputs are generator kilowatts (KW = torque) and intake manifold pressure (boost).

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the closed loop fueling control has reached the limit of adjustment within the calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

If the sensors used for fueling control and the fuel remain within specification (fuel Lower Heating Value (LHV) ±4 percent), then the fueling and exhaust emissions will be maintained across a wide range of operating conditions. The fueling and emissions can begin to drift out of specification if one or more of the input sensors or the fuel quality begins to deviate outside of its specification. The ECM can, up to a limit, compensate for these deviations. However, if the sensor condition or fuel quality continues to deteriorate, the ECM will eventually reach the limit of adjustment within the fuel map and engine performance will be compromised. When this limit of adjustment is reached, Fault Code 3594 will be activated.

Refer to Troubleshooting Fault Code 3595.

Last Modified: 20-Jul-2015


Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3846

Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3846 PID: SPN: 633 FMI: 0/15 LAMP: Amber SRT: | Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Least Severe Level. The Fuel Control Valve (FCV) internal temperature is too high. | None on performance.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) has reported to the Engine Control Module (ECM) that its internal temperature is too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged wiring harness
  • Damaged Fuel Control Valve (FCV)
Refer to Troubleshooting Fault Code 3846.

Last Modified: 20-Jul-2015


Engine Fuel Actuator Control - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3847

Engine Fuel Actuator Control - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3847 PID: SPN: 633 FMI: 1/17 LAMP: Amber SRT: | Engine Fuel Actuator Control - Data Valid But Below Normal Operating Range - Least Severe Level. The Fuel Control Valve (FCV) internal temperature is too low. | None on performance.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) has reported to the Engine Control Module (ECM) that its internal temperature is too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged Fuel Control Valve (FCV)
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3847.

Last Modified: 20-Jul-2015


Engine Fuel Actuator Control - Special Instructions

FAULT CODE 3848

Engine Fuel Actuator Control - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3848 PID: SPN: 633 FMI: 14/14 LAMP: Red SRT: | Engine Fuel Actuator Control - Special Instructions. The Fuel Control Valve (FCV) run enable switch is set to OFF. | Engine may not start.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) has reported to the Engine Control Module (ECM) that its run enable switch is set to OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged Fuel Control Valve (FCV)
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3848.

Last Modified: 20-Jul-2015


Engine Fuel Actuator Control - Bad Intelligent Device or Component

FAULT CODE 3849

Engine Fuel Actuator Control - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3849 PID: SPN: 633 FMI: 12/12 LAMP: Red SRT: | Engine Fuel Actuator Control - Bad Intelligent Device or Component. The Fuel Control Valve (FCV) has an internal fault. | Engine will be shut down.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) has reported to the Engine Control Module (ECM) that it has an internal fault.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged Fuel Control Valve (FCV)
Refer to Troubleshooting Fault Code 3849.

Last Modified: 21-Jul-2015


Engine Turbocharger Compressor Bypass Actuator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3858

Engine Turbocharger Compressor Bypass Actuator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3858 PID: SPN: 3470 FMI: 0/15 LAMP: Amber SRT: | Engine Turbocharger Compressor Bypass Actuator - Data Valid But Above Normal Operating Range - Least Severe Level. The Compressor Bypass Valve (CBV) internal temperature is too high. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Compressor Bypass Valve

Circuit Description

The compressor bypass valve is controlled by the ECM and is used to bleed excessive boost pressure bofore the compressed mix reaches the throttle plate.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Compressor Bypass Valve (CBV) has reported to the Engine Control Module (ECM) that its internal temperature is too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning Turbine Bypass Valve
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3858.

Last Modified: 21-Jul-2015


Engine Turbocharger Compressor Bypass Actuator - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3859

Engine Turbocharger Compressor Bypass Actuator - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3859 PID: SPN: 3470 FMI: 1/17 LAMP: Amber SRT: | Engine Turbocharger Compressor Bypass Actuator - Data Valid But Below Normal Operating Range - Least Severe Level. The Compressor Bypass Valve (CBV) internal temperature is too low. | None on performance.
Compressor Bypass Valve

Circuit Description

The compressor bypass valve is controlled by the ECM and is used to bleed excessive boost pressure bofore the compressed mix reaches the throttle plate.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Compressor Bypass Valve (CBV) has reported to the Engine Control Module (ECM) that its internal temperature is too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning Compressor Bypass solenoid.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3859.

Last Modified: 21-Jul-2015


Engine Turbocharger Compressor Bypass Actuator - Root Cause Not Known

FAULT CODE 3861

Engine Turbocharger Compressor Bypass Actuator - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3861 PID: SPN: 3470 FMI: 11/11 LAMP: Amber SRT: | Engine Turbocharger Compressor Bypass Actuator - Root Cause Not Known. The Compressor Bypass Valve position is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Compressor Bypass Valve

Circuit Description

The compressor bypass valve is controlled by the ECM and is used to bleed excessive boost pressure bofore the compressed mix reaches the throttle plate.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Compressor Bypass Valve (CBV) has reported to the Engine Control Module (ECM) that its position is incorrect.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning Compressor Bypass solenoid.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3861.

Last Modified: 21-Jul-2015


Engine Turbocharger Compressor Bypass Actuator - Special Instructions

FAULT CODE 3862

Engine Turbocharger Compressor Bypass Actuator - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3862 PID: SPN: 3470 FMI: 14/14 LAMP: Amber SRT: | Engine Turbocharger Compressor Bypass Actuator - Special Instructions. The Compressor Bypass Valve (CBV) run enable switch is se to OFF. | Engine may not start or may be difficult to start.
Compressor Bypass Valve

Circuit Description

The compressor bypass valve is controlled by the ECM and is used to bleed excessive boost pressure bofore the compressed mix reaches the throttle plate.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Compressor Bypass Valve (CBV) has reported to the Engine Control Module (ECM) that its run enable switch is set to OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning Compressor Bypass solenoid.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3862.

Last Modified: 21-Jul-2015


Engine Turbocharger Compressor Bypass Actuator - Bad Intelligent Device or Component

FAULT CODE 3863

Engine Turbocharger Compressor Bypass Actuator - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3863 PID: SPN: 3470 FMI: 12/12 LAMP: Red SRT: | Engine Turbocharger Compressor Bypass Actuator - Bad Intelligent Device or Component. The Compressor Bypass Valve (CBV) has an internal failure. | Engine will be shut down.
Compressor Bypass Valve

Circuit Description

The compressor bypass valve is controlled by the ECM and is used to bleed excessive boost pressure bofore the compressed mix reaches the throttle plate.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Compressor Bypass Valve (CBV) has reported to the Engine Control Module (ECM) that it has an internal fault.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning Compressor Bypass solenoid.
Refer to Troubleshooting Fault Code 3863.

Last Modified: 21-Jul-2015


Engine Turbocharger Compressor Bypass Actuator - Received Network Data in Error

FAULT CODE 3864

Engine Turbocharger Compressor Bypass Actuator - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3864 PID: SPN: 3470 FMI: 2/19 LAMP: None SRT: | Engine Turbocharger Compressor Bypass Actuator - Received Network Data in Error. The Compressor Bypass Valve (CBV) has a CAN fault. | None on performance.
Compressor Bypass Valve

Circuit Description

The compressor bypass valve is controlled by the ECM and is used to bleed excessive boost pressure bofore the compressed mix reaches the throttle plate.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Compressor Bypass Valve (CBV) has reported to the Engine Control Module (ECM) that it has a CAN fault.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning Compressor Bypass solenoid.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3864.

Last Modified: 21-Jul-2015


Low Voltage Ride Through - Bad Intelligent Device or Component

FAULT CODE 3869

Low Voltage Ride Through - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3869 PID: SPN: 520527 FMI: 12/12 LAMP: Amber SRT: | Low Voltage Ride Through - Bad Intelligent Device or Component. Low voltage ride through detection in the genset controller is in error or not available. | None on performance.
ECM

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed that the low voltage ride through detection in the generator set is in error or not available.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage ride through (LVRT) applies to generator set connection to the utility(grid) and requires that the generator set remains connected to the utility during certaqin grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

Refer to Troubleshooting Fault Code 3869.

Last Modified: 21-Jul-2015


Low Voltage Ride Through - Abnormal Update Rate

FAULT CODE 3871

Low Voltage Ride Through - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3871 PID: SPN: 520527 FMI: 9/9 LAMP: Amber SRT: | Low Voltage Ride Through - Abnormal Update Rate. The ECM has diagnosed that the device monitoring low voltage ride through is no longer transmitting any data. | None on performance.
ECM

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the device monitoring low voltage ride through is no longer transmitting any data.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage ride through (LVRT) applies to generator set connection to the utility(grid) and requires that the generator set remains connected to the utility during certaqin grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

Refer to Troubleshooting Fault Code 3871.

Last Modified: 21-Jul-2015


Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3872

Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3872 PID: SPN: 520527 FMI: 2/2 LAMP: Amber SRT: | Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect. The ECM has diagnosed that there have been a significant number of low voltage ride through events. | None on performance.
ECM

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that there have been a significant number of low voltage ride through events.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage ride through (LVRT) applies to generator set connection to the utility(grid) and requires that the generator set remains connected to the utility during certaqin grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

Refer to Troubleshooting Fault Code 3872.

Last Modified: 21-Jul-2015


Low Voltage Ride Through - Abnormal Frequency or Pulse Width or Period

FAULT CODE 3873

Low Voltage Ride Through - Abnormal Frequency or Pulse Width or Period

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3873 PID: SPN: 520527 FMI: 8/8 LAMP: Red SRT: | Low Voltage Ride Through - Abnormal Frequency or Pulse Width or Period. The ECM has diagnosed that there have been a significant number of low voltage ride through events. | Engine will be shut down.
ECM

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that there have been a significant number of low voltage ride through events.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The ECM will immediately request a shutdown from the genset controller.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage ride through (LVRT) applies to generator set connection to the utility(grid) and requires that the generator set remains connected to the utility during certaqin grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

Refer to Troubleshooting Fault Code 3873.

Last Modified: 21-Jul-2015


Low Voltage Ride Through - Root Cause Not Known

FAULT CODE 3874

Low Voltage Ride Through - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3874 PID: SPN: 520527 FMI: 11/11 LAMP: Amber SRT: | Low Voltage Ride Through - Root Cause Not Known.The ECM has diagnosed that the low voltage ride through detection is stuck on. | None on performance.
ECM

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the low voltage ride through detection is stuck on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage ride through (LVRT) applies to generator set connection to the utility(grid) and requires that the generator set remains connected to the utility during certaqin grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

Refer to Troubleshooting Fault Code 3874.

Last Modified: 21-Jul-2015


Low Voltage Ride Through - Condition Exists

FAULT CODE 3875

Low Voltage Ride Through - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3875 PID: SPN: 520527 FMI: 11/31 LAMP: Amber SRT: | Low Voltage Ride Through - Condition Exists. The ECM has diagnosed that a low voltage ride through event is in progress. | None on performance.
ECM

Circuit Description

See OEM wiring diagram.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that a low voltage ride through event is in progress.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage ride through (LVRT) applies to generator set connection to the utility(grid) and requires that the generator set remains connected to the utility during certaqin grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

Refer to Troubleshooting Fault Code 3875.

Last Modified: 21-Jul-2015


Engine Turbocharger 1 Wastegate Actuator 1 - Current Below Normal or Open Circuit

FAULT CODE 3922

Engine Turbocharger 1 Wastegate Actuator 1 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3922 PID: SPN: 5421 FMI: 5/5 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator - Current Below Normal or Open Circuit. Motor terminal or motor coil open circuit has been detected by the electronic control module (ECM). | Possible reduced engine performance.
Waste Gate Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

The turbocharger wastegate location can vary depending on engine model and application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or turbocharger wastegate motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Turbocharger wastegate operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Turbocharger wastegate motor open circuit.
  • One of the turbocharger wastegate motor circuits shorted to ground in the wastegate motor.
Refer to Troubleshooting Fault Code 3922.

Last Modified: 21-Jul-2015


Engine Turbocharger Wastegate Actuator 1 Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3925

Engine Turbocharger Wastegate Actuator 1 Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3925 PID: SPN: 1188 FMI: 2/2 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Data Erratic, Intermittent, or Incorrect. An error has been detected in the turbocharger wastegate position sensor circuit. | Possible reduced engine performance.
Turbocharger Wastegate Circuit

Circuit Description

The turbocharger wastegate is controlled by a brushless motor located on top of the wastegate valve. The turbocharger wastegate motor uses three different motor legs to move the valve through its range of motion. The ECM uses the turbocharger wastegate motor A, B, and C wires to command the turbocharger wastegate to the appropriate position in order to maintain appropriate intake manifold pressure and turbocharger speed. The turbocharger wastegate motor contains three position sensors that detect the location of the wastegate. These sensors report the position of the wastegate back to the ECM over the turbocharger wastegate position A, B, and C wires.

Component Location

The turbocharger wastegate position sensors are internal to the turbocharger wastegate assembly and can not be serviced seperately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger wastegate position sensor signal voltage was higher or lower than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Turbocharger wastegate operation will be disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Turbocharger wastegate position sensor wiring shorted to ground, open circuit, or shorted to power supply.
Refer to Troubleshooting Fault Code 3925.

Last Modified: 23-Jul-2015


Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4617

Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4617 PID: SPN: 5631 FMI: 3/3 LAMP: Amber SRT: | Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. The Throttle Delta Pressure Sensor has been shorted to a power source. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Throttle Delta Pressure Sensor

Circuit Description

The engine control module (ECM) provides a dedicated 5 volt supply and ground to the Throttle Delta Pressure Sensor. The ECM monitors the voltage level on the Throttle Delta Pressure Sensor +5 volt supply circuit. If the voltage falls below or above a calibratible limit, a fault is recorded.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the throttle delta pressure sensor has been shorted to a power source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 4617.

Last Modified: 21-Jul-2015


Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4618

Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4618 PID: SPN: 5631 FMI: 4/4 LAMP: Amber SRT: | Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The Throttle Delta Pressure Sensor has been shorted to ground. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Throttle Delta Pressure Sensor

Circuit Description

The engine control module (ECM) provides a dedicated 5 volt supply and ground to the Throttle Delta Pressure Sensor. The ECM monitors the voltage level on the Throttle Delta Pressure Sensor +5 volt supply circuit. If the voltage falls below or above a calibratible limit, a fault is recorded.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the throttle delta pressure sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged wiring harness
  • Damaged sensor
Refer to Troubleshooting Fault Code 4618.

Last Modified: 21-Jul-2015


Engine Turbocharger 1 Boost Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4621

Engine Turbocharger 1 Boost Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4621 PID: SPN: 1127 FMI: 2/2 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure - Data Erratic, Intermittent, or Incorrect. Compressor outlet pressure sensor is drifiting in range. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Compressor outlet pressure sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to compressor outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the ECM on the compressor outlet pressure sensor signal circuit.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON and when engine has been stopped for 30 seconds.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the compressor outlet pressure sensor is drifting in range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and the shutdown request ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 4621.

Last Modified: 21-Jul-2015


Engine Fuel Valve 1 Intake Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4622

Engine Fuel Valve 1 Intake Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4622 PID: SPN: 1390 FMI: 2/2 LAMP: Amber SRT: | Engine Fuel Valve 1 Intake Pressure - Data Erratic, Intermittent, or Incorrect. Fuel inlet pressure sensor is drifting in range. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel inlet pressure sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON and when engine has been stopped for 30 seconds.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel inlet pressure sensor is drifting in range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and allow the ECM to be powered with the keyswitch and the shutdown request ON for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 4622.

Last Modified: 21-Jul-2015


Engine Gas Control Valve 1 Outlet Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4624

Engine Gas Control Valve 1 Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4624 PID: SPN: 2980 FMI: 2/2 LAMP: Amber SRT: | Engine Gas Control Valve 1 Outlet Pressure - Data Erratic, Intermittent, or Incorrect. Fuel outlet pressure sensor in drifting in range. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel outlet pressure sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel filter outlet pressure sensor provides a signal to the ECM on the fuel filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the fuel filter housing.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON and when engine has been stopped for 30 seconds.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel outlet pressure sensor is drifting in range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 4624.

Last Modified: 21-Jul-2015


Engine Throttle Valve Differential Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4636

Engine Throttle Valve Differential Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4636 PID: SPN: 5631 FMI: 2/2 LAMP: Amber SRT: | Engine Throttle Valve Differential Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect. Throttle delta pressure sensor is drifting in range. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Throttle delta pressure sensor

Circuit Description

The engine control module (ECM) provides a dedicated 5 volt supply and ground to the Throttle Delta Pressure Sensor. The ECM monitors the voltage level on the Throttle Delta Pressure Sensor +5 volt supply circuit. If the voltage falls below or above a calibratible limit, a fault is recorded.

Component Location

Located in the air intake piping.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the throttle delta pressure sensor is drifting in range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Damaged sensor
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 4636.

Last Modified: 21-Jul-2015


Engine Controlled Shutdown Request - Special Instructions

FAULT CODE 4687

Engine Controlled Shutdown Request - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4687 PID: SPN: 3606 FMI: 14/14 LAMP: Red SRT: | Engine Controlled Shutdown Request - Special Instructions. The genset controller is not responding to a shut down request. | Engine will be shut down.
ECM

Circuit Description

Some applications use the OEM switch input to drive an engine protection event in the form of an emergency engine shutoff switch, engine compartment cover location switch, or similar.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the genset controller is not responding to a shutdown request.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

(1) Other more precise fault codes exist (example: electrical circuit faults).

Refer to Troubleshooting Fault Code 4687.

Last Modified: 21-Jul-2015


Engine Turbocharger Wastegate Actuator 1 Position - Bad Intelligent Device or Component

FAULT CODE 5118

Engine Turbocharger Wastegate Actuator 1 Position - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5118 PID: SPN: 1188 FMI: 12/12 LAMP: Red SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Bad Intelligent Device or Component. Wastegate is stuck closed. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Wastegate Actuator

Circuit Description

The turbocharger wastegate actuator is used to limit the peak intake manifold pressure and turbocharger speed.

Component Location

The turbocharger wastegate location can vary depending on engine model and application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the wastegate is stuck closed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

  • Malfunctioning turbocharger wastegate
Refer to Troubleshooting Fault Code 5118.

Last Modified: 21-Sep-2015


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1257 (sa00)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1257 (sa00) PID: P234 SPN: 1563 FMI: 2/2 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may not start.
ECM

Circuit Description

CAN (Controller Area Network) is the high speed communication line for many of the Vehicle electronic control units (VECU). The CAN communication bus has two 2 lines (CAN H line, CAN L line). These lines are inputted to the Engine Control Module. If the ECM does not receive any messages across the CAN bus for a period of time, this fault will set.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 1257 (sa00).

Last Modified: 23-Jul-2015


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1257 (sa01)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1257 (sa01) PID: P234 SPN: 1563 FMI: 2/2 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may not start.
ECM

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 1257 (sa01).

Last Modified: 23-Jul-2015


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1257 (sa39)

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1257 (sa39) PID: P234 SPN: 1563 FMI: 2/2 LAMP: Red SRT: | Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect. The control module identification input state is incorrect. | Engine may not start.
ECM

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible cause of this fault code:

  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 1257 (sa39).

Last Modified: 21-Jul-2015


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187 (sa00)

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 (sa00) PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code 187 (sa00).

Last Modified: 13-Oct-2015


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187 (sa39)

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 (sa39) PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

  • Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.
Refer to Troubleshooting Fault Code 187 (sa39).

Last Modified: 13-Oct-2015


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186 (sa00)

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 (sa00) PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Possible reduced engine performance.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for Sensor Supply 4 voltage is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186 (sa00).

Last Modified: 21-Jul-2015


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186 (sa01)

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 (sa01) PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 VDC sensor supply circuit. | Possible reduced engine performance.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the Throttle Valve Differential Pressure Sensor.

Component Location

Throttle Valve Differential Pressure Sensor is located at the Throttle Actuator Assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for Sensor Supply 4 voltage is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186 (sa01).

Last Modified: 13-Oct-2015


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK19 CM2350 K105 | 4326157
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK50 CM2350 K108 | 4332823
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2350 K116 | 4367444
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2350 K117 | 4367449
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Nov-2015


FAULT CODE 545 - Engine Turbocharger Wastegate Actuator 1 Position - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK19 CM2350 K105 | 4326157
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK50 CM2350 K105 | 4332823
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 CM2350 K116 | 4367444
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 CM2350 K117 | 4367449
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 G CM2358 K110 | 4383781
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K105 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3925, 3971, or 3969 active or inactive counts?
STEP 2. | Check the turbocharger wastegate position sensor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3925 active and 545 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925, 3971, or 3969 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger wastegate motor position sensor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate from the engine harness.

Action

Inspect the engine harness and turbocharger wastegate connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness, or replace the turbocharger wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate from the engine harness.
  • Turn keyswitch ON.

Action

Check the appropriate circuit response.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925 active and 545 inactive?
YES NO

A malfunctioning turbocharger wastegate has been detected. Replace the turbocharger wastegate. Refer to Procedure 011-097 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK50 CM2350 K108 | 4332823
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K116 | 4367444
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K117 | 4367449
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 G CM2358 K110 | 4383781
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K121 | 4388645

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy, |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.25 kPa – g (0 ± 1 in H2O)?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate the engine.

Action

Use INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.25 kPa – g (0 ± 1 in H2O)?
YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2015


FAULT CODE 1526 - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1526 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 677 active and Fault Code 1526 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1526 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1526 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the exhaust gas temperature sensor 13 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 13 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active and Fault Code 1526 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 13 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES NO

Replace the exhaust gas temperature sensor 13. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 RETURN pin in the OEM harness ECM connector and the exhaust gas temperature sensor 13 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the OEM harness ECM connector and the exhaust gas temperature sensor 13 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 3925 - Engine Turbocharger Wastegate Actuator 1 Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK19 CM2350 K105 | 4326157
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK50 CM2350 K108 | 4332823
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 CM2350 K121 | 4388645
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388465
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
STEP 2. | Check the turbocharger wastegate 1 motor and circuit. |
 | STEP 2A. Inspect the turbocharger wastegate 1 motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 3925 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the engine harness. |
 | STEP 3A-2. Check for a short circuit in the engine harness. |
 | STEP 3A-3. Check for a short circuit to ground. |
 | STEP 3A-4. Check the fault codes. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187 troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger wastegate 1 motor and circuit.

Guided Step 2A - Inspect the turbocharger wastegate 1 motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 from the engine harness.

Action

Inspect the engine harness and the turbocharger wastegate 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the wastegate connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness, or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger wastegate 1 position +5 volt SUPPLY pin to the turbocharger wastegate 1 position RETURN pin at the turbocharger wastegate 1 connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3B

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger wastegate 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness, or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 1.

Action

Check for an open circuit in the turbocharger wastegate 1 position circuit.

  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL A pin at the turbocharger wastegate 1 engine harness connector and the turbocharger wastegate 1 position SIGNAL A pin at the ECM engine harness connector.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL B pin at the turbocharger wastegate 1 engine harness connector and the turbocharger wastegate 1 position SIGNAL B pin at the ECM engine harness connector.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL C pin at the turbocharger wastegate 1 engine harness connector and the turbocharger wastegate 1 position SIGNAL C pin at the ECM engine harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 1.

Action

Check for a short circuit in the turbocharger wastegate 1 position circuit.

  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL A pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL B pin at the ECM engine harness connector and all other pins in the ECM connector.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL C pin at the ECM engine harness connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the turbocharger wastegate 1.

Action

Check for a short circuit to ground.

  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL A pin at the ECM engine harness connector and ground.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL B pin at the ECM engine harness connector and ground.
  • Measure the resistance between the turbocharger wastegate 1 position SIGNAL C pin at the ECM engine harness connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the turbocharger wastegate 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925 active?
YES NO

Replace the turbocharger wastegate. Refer to Procedure 011-097 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged pins. Repair or replace the engine harness, or replace the wastegate motor, whichever has the damaged pins.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger wastegate 1 position +5 volt SUPPLY pin to the turbocharger wastegate 1 position RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3925 active?
YES NO

An open wastegate position supply or return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Oct-2015


FAULT CODE 121 - Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Engine speed sensor fault code active?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Inspect the engine speed sensor. | Damaged engine speed sensor?
 | STEP 2C. Check for an open circuit. | Less than 2k ohms?
 | STEP 2D. Check for short circuit to engine block ground. | More than 100k ohms?
 | STEP 2E. Check for short circuit between coils. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 2k ohms?
 | STEP 3C. Check for short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect electronic service tool.

Action

Check for an active fault code.

  • Using the electronic service tool, read the fault codes.

Engine speed sensor fault code active?
YES NO
No Repair

Using the electronic service tool, clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair or replace the engine harness or the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.

Damaged engine speed sensor?
YES NO

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit in the sensor.

  • Measure the resistance from the engine speed sensor signal pin to the engine speed sensor return pin.

Note: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Less than 2k ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for short circuit to ground.

  • Measure the resistance between the engine speed sensor signal pin to the engine block ground.

Note: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for short circuit between coils.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor signal pin of one coil and the engine speed sensor signal pin of the other coil.
  • Measure the resistance between the engine speed sensor return pin to the engine speed sensor return pin.

Note: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the control module.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Moisture or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the control module.
  • Connect the engine harness to the Engine Speed Sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor signal pin to the speed sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Less than 2k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch STOP mode.
  • Disconnect the engine harness from the control module.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor signal pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the control module.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit pin to pin.

  • Measure the resistance between the engine speed sensor signal pin and all other pins of the engine harness connector.
  • Measure the resistance between the engine speed sensor return pin and all other pins of the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
STEP 2. | Check the oil pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 135 inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 135 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil pressure sensor.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the oil pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the oil pressure sensor (rifle).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the oil pressure sensor (rifle). Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the oil pressure sensor breakout cable between the sensor and the harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the oil pressure sensor (rifle).

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the oil pressure sensor (rifle) and the CM2358.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the oil pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from the oil pressure RETURN pin on the engine harness connector to the oil pressure RETURN pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the oil pressure sensor connector.

Action

Check for the appropriate CM2358 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 141 will become active upon disconnecting the sensor.

Fault Code 135 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 signal pin resistance.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the 50-pin A Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin B Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin C Deutsch™ connector from the CM2358.

Action

Check the CM2358 SIGNAL pin resistance.

  • Measure the resistance from the oil rifle pressure SIGNAL pin on the CM2358 to CM2358 sensor supply circuit number 2 RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 135 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 136 - Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Oil Pressure SensorSwitch | Refer to Procedure 019-066 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
STEP 2. | Check the oil inlet pressure sensor (pre-filter). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 136 is inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 136 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place auto/run/stop switch STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil inlet pressure sensor (pre-filter).

Fault Code 227 active?
YES | NO
No Repair | No Repair

Sensor supply Fault Code 227

Go to 2A

Guided Step 2 - Check the oil inlet pressure sensor (pre-filter).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place auto/run/stop switch STOP mode.
  • Disconnect the engine harness connector from the oil inlet pressure (pre-filter) sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the oil inlet pressure sensor (pre-filter). Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place auto/run/stop switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil inlet pressure sensor (pre-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place auto/run/stop switch in STOP mode.
  • Install the oil inlet pressure sensor (pre-filter) breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the oil inlet pressure sensor (pre-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the oil inlet pressure sensor (pre-filter). Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the engine harness from the oil inlet pressure sensor (pre-filter) and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the oil pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the oil pressure RETURN pin on the engine harness connector to the oil pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness connector to the oil pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure SUPPLY pin on the engine harness connector to the oil pressure SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the oil inlet pressure sensor (pre-filter) connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 137 will become active upon disconnecting the sensor.

Fault Code 136 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the 50-pin A Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin B Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin C Deutsch™ connector from the CM2358.

Action

Check the CM2358 SIGNAL pin resistance.

  • Measure the resistance from the oil inlet pressure SIGNAL pin on the CM2358 to the CM2358 sensor supply circuit number 2 pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place auto/run/stop switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 136 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place auto/run/stop switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 137 - Pre-Oil Filter Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 active?
STEP 2. | Check the pre-oil filter pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 137 inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 137 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit..
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the pre-oil filter pressure sensor.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Sensor supply Fault Code 227

Go to 2A

Guided Step 2 - Check the pre-oil filter pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the pre-oil filter pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the pre-oil filter pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the pre-oil filter pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pre-oil filter pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the pre-oil filter pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the pre-oil filter pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the pre-oil filter pressure sensor and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the oil pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the oil pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the oil pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the oil pressure RETURN pin on the engine harness connector to the oil pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure SIGNAL pin on the engine harness connector to the oil pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the oil pressure SUPPLY pin on the engine harness connector to the oil pressure SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the pre-oil filter pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Place a jumper wire between the oil inlet pressure (pre-filter) SUPPLY pin and the oil inlet pressure (pre-filter) SIGNAL pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 136 will become active upon disconnecting the sensor.

Fault Code 137 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the 50-pin A Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin B Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin C Deutsch™ connector from the CM2358.

Action

Check the CM2358 SIGNAL pin resistance.

  • Measure the resistance from the oil inlet pressure SIGNAL pin on the CM2358 to the CM2358 sensor supply circuit number 2 pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 137 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Energize keyswitch circuit..
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 active?
STEP 2. | Check the engine oil rifle pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 141 is inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 141 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine oil rifle pressure sensor.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Sensor Supply Fault Code 141

Go to 2A

Guided Step 2 - Check the engine oil rifle pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil rifle pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine oil rifle pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil rifle pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil rifle pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the engine oil rifle pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil rifle pressure sensor and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the engine oil rifle pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine oil rifle pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine oil rifle pressure sensor SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil rifle pressure sensor RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil rifle pressure sensor SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the engine oil rifle pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine oil rifle pressure sensor RETURN pin on the engine harness connector to the engine oil rifle pressure sensor RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil rifle pressure sensor SIGNAL pin on the engine harness connector to the engine oil rifle pressure sensor SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil rifle pressure sensor SUPPLY pin on the engine harness connector to the engine oil rifle pressure sensor SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine oil rifle pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Place a jumper wire between the engine oil rifle pressure sensor SUPPLY pin and the engine oil rifle pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 135 will become active upon installing the jumper.

Fault code 141 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 signal pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the 50-pin A Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin B Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin C Deutsch™ connector from the CM2358.

Action

Check the CM2358 SIGNAL pin resistance.

  • Measure the resistance from the engine oil rifle pressure sensor SIGNAL pin on the CM2358 to the CM2358 sensor supply circuit number 2 RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 141 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 142 - Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 135 or 141 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 142 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 135 or 141 active?
YES NO
No Repair

Reference the Lubricating Oil Pressure High troubleshooting symptom tree in Section TS in the QSV91-G6 CM2358 V101 Service Manual, Bulletin 4332687.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate more than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Jun-2013


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 135 or 141 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code in inactive. | Fault Code 142 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 135 or 141 active?
YES NO
No Repair

Reference the Lubricating Oil Pressure Low symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 142 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Jun-2013


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault codes active?
STEP 2. | Check the engine coolant temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check sensor resistance. | 600 to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 144 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 144 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine coolant temperature sensor.

Fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault codes

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the engine coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..
  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table..

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin.

600 to 36k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table..

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table..

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor and the CM2358.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires.

  • Measure the resistance from the engine coolant temperature sensor SIGNAL pin in the engine harness connector to the engine block ground.
  • Measure the resistance from the engine coolant temperature sensor RETURN pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin in the engine coolant temperature sensor connector to the sensor SIGNAL pin in the CM2358.
  • Measure the resistance from the RETURN pin in the engine coolant temperature sensor connector to the RETURN pin in the CM2358.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes .

Note: Fault Code 145 will become active upon disconnecting the sensor.

Fault Code 144 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 144 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

Do not remove the radiator pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the radiator pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault codes active?
STEP 2. | Check the engine coolant temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check sensor resistance. | 600 to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 145 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 145 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ the electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine coolant temperature sensor.

Fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault codes

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the engine coolant temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor.

  • Measure the resistance between the coolant temperature SIGNAL pin and the coolant temperature RETURN pin.

600 to 36k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor and the CM2358.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the coolant temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the coolant temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect engine harness from engine coolant temperature sensor.
  • Disconnect engine harness from the CM2358.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires.

  • Measure the resistance from the coolant temperature SIGNAL pin in the engine harness connector to the engine block ground.
  • Measure the resistance from the coolant temperature RETURN pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin in the engine coolant temperature sensor connector to the sensor SIGNAL pin in the CM2358.
  • Measure the resistance from the RETURN pin in the engine coolant temperature sensor connector to the RETURN pin in the CM2358.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 144 will become active upon disconnecting the sensor.

Fault Code 145 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 145 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 144 or 145 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 146 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144 or 145 active?
YES NO
No Repair

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in the QSV91-G6 CM2358 V101 Service Manual, Bulletin 4332687.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault cods.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2013


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 144 or 145 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 151 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144 or 145 active?
YES NO
No Repair

Reference the Coolant Temperature Above Normal troubleshooting symptom tree in the QS91-G6 CM2358 V101 Service Manual, Bulletin 4332687.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize the keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting stops or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jun-2013


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault codes active?
STEP 2. | Check the intake manifold temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check sensor resistance. | 600 to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 154 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 154 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the intake manifold temperature sensor.

Fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code

Go to 2A

Guided Step 2 - Check the intake manifold temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the intake manifold temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the intake manifold temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the intake manifold temperature sensor.

  • Measure the resistance between the intake manifold temperature SIGNAL pin and the intake manifold temperature RETURN pin.

600 to 36k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the intake manifold temperature sensor connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold temperature sensor and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake manifold temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires.

  • Measure the resistance from the intake manifold temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the intake manifold temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the intake manifold temperature sensor connector to the sensor SIGNAL pin on the CM2358.
  • Measure the resistance from the RETURN pin on the intake manifold temperature sensor connector to the RETURN pin on the CM2358.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 153 will become active upon disconnecting the sensor.

Fault Code 154 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 154 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 153 or 154 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 155 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 153 or 154 active?
YES NO
No Repair

Reference the Intake Air Manifold Temperature Above Specification troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 155 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE ™electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Jun-2013


FAULT CODE 177 - Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Power supply Fault Code 441 or 442 active?
STEP 2. | Check the engine throttle. |
 | STEP 2A. Check the actuator operation. | Pass the testing?
 | STEP 2B. Inspect the engine throttle control actuator. | Sticking or restriction or debris blocking the engine throttle?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Power supply Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine throttle.

Guided Step 2A - Check the actuator operation.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck actuator valve.

  • Perform the Electronic Throttle Control Actuator Test.

Pass the testing?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine intake throttle.

Action

Check for a restriction.

  • Remove the engine intake throttle.
  • Inspect the engine intake throttle for a restriction or debris blocking the throttle plate or throttle actuator sticking.

Refer to Procedure 005-052 in the Associated Procedures Table.

Sticking or restriction or debris blocking the engine throttle?
YES NO

Remove the restriction or debris.

Replace the engine throttle control actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator motor from the engine harness.

Action

Inspect the engine harness and the engine throttle actuator motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 187 (Source Address 00) - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the fuel inlet pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the fuel inlet temperature sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the fuel outlet pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the compressor outlet pressure and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the fuel inlet pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet pressure sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet pressure sensor from the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the fuel inlet pressure sensor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel inlet temperature sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the fuel inlet temperature sensor.

Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the fuel outlet pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate 1 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedurres Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger wastegate from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the turbocharger wastegate 1.

Refer to Procedure 011-097 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the compressor outlet pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor outlet pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor outlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the compressor outlet pressure sensor.

Refer to Procedure 011-097 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A short circuit to ground has been detected on the sensor supply 2 circuit.

Repair or replace the damaged section of engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Jun-2015


FAULT CODE 187 (Source Address 39) Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine conrol module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2 supply and return. |
 | STEP 2A. Inspect the engine crankcase blowby pressure sensor and circuit connected to the sensor supply 2 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the air filter restriction pressure sensor and circuit connected to the sensor supply 2 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2 supply and return.

Guided Step 2A - Inspect the crankcase blowby pressure sensor and circuit connected to the sensor supply 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase blowby pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection had been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase blowby pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the crankcase blowby pressure sensor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the air filter restriction pressure sensor and circuit connected to the sensor supply 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the air filter restriction pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspect techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the air filter restriction pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the air filter restriction pressure sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-May-2015


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the active fault codes. |
 | STEP 1A. Check the active fault codes. | Fault Code 197 and/or 235 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 197 inactive?
 | STEP 2B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 197 and/or 235 active?
YES NO

Reference Coolant Loss troubleshooting symptom tree in Section TS in the QSV91-G6 CM2358 V101 Service Manual, Bulletin 4332687.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 197 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Jun-2013


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault codes active?
STEP 2. | Check the engine oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check sensor resistance. | 600 to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 212 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 212 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine oil temperature sensor.

Fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine oil temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 2B

5A

Guided Step 2B - Check sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check the resistance of the engine oil temperature sensor.

  • Measure the resistance between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin.

600 to 36k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine oil temperature sensor connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine oil temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires

  • Measure the resistance from the engine oil temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine oil temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine oil temperature sensor connector to the sensor SIGNAL pin on the CM2358.
  • Measure the resistance from the RETURN pin on the engine oil temperature sensor connector to the return SIGNAL pin on the CM2358.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate CM2358 response.

  • Place a jumper wire between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 213 will become active upon installing the jumper.

Fault Code 212 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 212 is inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault codes active?
STEP 2. | Check the engine oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check sensor resistance. | 600 to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 213 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 213 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine oil temperature sensor.

Fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troublehooting tree

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the engine oil temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check the resistance of the engine oil temperature sensor.

  • Measure the resistance between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin.

600 to 36k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine oil temperature sensor connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Reference the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine oil temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM3258.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires.

  • Measure the resistance from the engine oil temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine oil temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine oil temperature sensor connector to the sensor SIGNAL pin on the CM2358.
  • Measure the resistance from the RETURN pin on the engine oil temperature sensor connector to the RETURN pin on the CM2358.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 212 will become active upon disconnecting the sensor.

Fault Code 213 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 213 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 212 or 213 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 214 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 212 or 213 active?
YES NO
No Repair

Reference the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in the QSV91G CM2358 V101 Service Manul, Bulletin 4332687.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found within the Overview section of this troubleshooting procedure.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting chart

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Jun-2013


FAULT CODE 219 - Engine Oil Level Remote Reservoir - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Level Sensor | Refer to Procedure 019-056 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil remote reservoir level. |
 | STEP 1A. Inspect the engine oil remote reservoir level. | Low oil level?
STEP 2. | Check the original equipment manufacturer (OEM) interface harness. |
 | STEP 2A. Inspect the make-up tank oil level low sensor and OEM harness connector pins. | Dirty or damaged pins?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the make-up tank oil level low sensor.

Guided Step 1A - Inspect the engine oil remote reservoir level.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the remote engine oil reservoir level.

  • Check engine oil remote reservoir level.

Low oil level?
YES NO

Add engine oil.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the original equipment manufacturer (OEM) interface harness.

Guided Step 2A - Inspect the make-up tank oil level low sensor and OEM harness connector pins.

Conditions

  • Check that make-up oil tank is full.
  • Turn keyswitch OFF.
  • Disconnect the make-up tank oil level low sensor from the OEM harness.
  • Disconnect the OEM harness from the OEM interface harness at the connector.

Action

Inspect the make-up tank oil level low sensor and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the OEM harness.

  • Refer to Procedure 019-201 in Section 19.
  • Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Replace the make-up tank oil level low sensor.

  • Refer to Procedure 019-056 in the Associated Procedures Table.

Replace the lubricating oil level sensor.

  • Refer to Procedure 019-056 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jun-2015


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Engine Model | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify no fault codes are active for any sensor sharing sensor supply circuit number 2.

Fault Code 227 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from all sensors that share sensor supply circuit number 2.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the sensor supply circuit number 2 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Read the fault codes using INSITE™ electronic service tool.

Fault Code 227 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete.

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jun-2015


FAULT CODE 228 - Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 231 or 232 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate for longer than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 231 or 232 active?
YES NO
No Repair

See Coolant Pressure is Low troubleshooting symptom tree.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 231 - Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the coolant pressure sensor circuit (high temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault code 231 is inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault code 231 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Sensor Supply Fault Code 386

Go to 2A

Guided Step 2 - Check the coolant pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the coolant pressure sensor circuit (high temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-219 in Section 19.
  • Replace the coolant pressure sensor (high temperature). Refer to Procedure 019-016 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the coolant pressure sensor circuit (high temperature)supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/auto/stop switch in STOP mode.
  • Install the oil pressure sensor breakout cable between the sensor and the harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the coolant pressure sensor circuit (high temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the coolant pressure sensor (high temperature). Refer to Procedure 019-016 in the Associated Procedures Table.

.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the coolant pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the coolant pressure sensor circuit (high temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the coolant pressure sensor circuit (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the coolant pressure sensor circuit (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the coolant pressure sensor circuit (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness,if present.
  • Disconnect the engine harness from the coolant pressure sensor circuit (high temperature).

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from the coolant pressure sensor circuit (high temperature) RETURN pin on the engine harness connector to the coolant pressure sensor circuit (high temperature) RETURN pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the coolant pressure sensor circuit (high temperature) connector.

Action

Check for the appropriate CM2358 response.

  • Use INSITE™ the electronic service tool to verify the fault codes.

Note: Fault Code 232 will become active upon disconnecting the sensor.

Fault code 231 is inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check the CM2358 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the 50-pin A Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin B Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin C Deutsch™ connector from the CM2358.

Action

Check the CM2358 SIGNAL pin resistance.

  • Measure the resistance from the coolant pressure sensor circuit (high temperature) SIGNAL pin on the CM3258 to the CM2358 sensor supply circuit number 1 RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in RUN and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code 231 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 232 - Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the engine coolant pressure sensor circuit (high temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 232 is inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 232 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the coolant pressure sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the coolant pressure sensor circuit (high temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the coolant pressure sensor circuit (high temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the coolant pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the coolant pressure sensor circuit (high temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the coolant pressure sensor breakout cable between the sensor circuit (high temperature) and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the coolant pressure sensor circuit (high temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the coolant pressure sensor (high temperature). Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant pressure sensor circuit (high temperature) and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the coolant pressure sensor (high temperature).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the coolant pressure sensor circuit (high temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure SUPPLY (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure RETURN (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure SIGNAL (high temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the coolant pressure sensor (high temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine coolant pressure RETURN (high temperature) pin on the engine harness connector to the engine coolant pressure RETURN (high temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure SIGNAL (high temperature) pin on the engine harness connector to the engine coolant pressure SIGNAL (high temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure SUPPLY (high temperature) pin on the engine harness connector to the engine coolant pressure SUPPLY (high temperature) pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the coolant pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Place a jumper wire between the engine coolant pressure (high temperature) supply pin and the engine coolant pressure (high temperature) signal pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 231 will become active upon installing the jumper.

Fault code 232 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 signal pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the 50-pin A Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin B Deutsch™ connector from the CM2358.
  • Disconnect the 50-pin C Deutsch™ connector from the CM2358.

Action

Check the CM2358 SIGNAL pin resistance.

  • Measure the resistance from the engine coolant pressure SIGNAL pin on the CM2358 to the CM2358 sensor supply circuit number 2 RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 232 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 23-May-2015


FAULT CODE 233 - Coolant Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 231 or 232 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 233 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Enerize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 231 or 232 active?
YES NO
No Repair

Refer to the Coolant Pressure Low troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 233 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Jun-2013


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Load transient?
 | STEP 1B. Check the engine rpm with the monitor mode. | Correct rpm reading?
 | STEP 1C. Check for an inactive fault code at idle or rated speed. | Fault Code 234 inactive?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for proper operating conditions.

  • Verify the fault code did not occur after the load transient.

Load transient?
YES NO
No Repair

Check the engine for damage.

  • Check that the electronics are functional.
  • Check the base engine for damage because of an overspeed condition.

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with the monitor mode.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with the monitor mode.

Monitor the engine rpm using the electronic service tool.

Correct rpm reading?
YES NO
No Repair

Check the engine position sensor as outlined in Fault Code 121.

Go to 1C

See Fault Code 121.

Guided Step 1C - Check for an inactive fault code at idle or rated speed.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes at idle or rated speed?

  • Check for active Fault Code 234 when the engine is not running above the engine overspeed shutdown threshold.

Fault Code 234 inactive?
YES NO
No Repair

Connect a Cummins® Authorized Repair Location.

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 235 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES NO

See the Coolant Loss symptom troubleshooting tree.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 238 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply 3 circuit.

Fault Code 238 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine control module (ECM).

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to the circuit diagram or the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from all the sensors that share sensor supply 3 circuit.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the sensor supply circuit 3 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from all the sensors that share sensor supply 3 circuit.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor SUPPLY pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 238 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-May-2015


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 239 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply 3 circuit.

Fault Code 239 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine control module (ECM).

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to the circuit diagram or the wiring diagram for connector pin identification. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from all the sensors that share sensor supply 3 circuit.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the sensor supply 3 circuit positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 239 active?
YES NO

Contact the a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 239 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-May-2015


FAULT CODE 248 - Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383871

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor 1 accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Thermocouple agree with the exhaust gas temperature sensor 1 reading in INSITE™ electronic service tool.
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 248 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the exhaust gas temperature sensor 1 accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature sensor 1 accuracy with a thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the exhaust gas temperature sensor 1.

NOTE: The probe must extend into the exhaust flow and must not touch the exhaust manifold, except at the probe threads.

  • Connect INSITE™ electronic service tool to the vehicle data link.
  • Compare the exhaust gas temperature sensor 1 reading on the service tool monitor screen to the reading from the temperature probe.

NOTE: If no temperature measuring device is available, answer yes to this step.

Thermocouple agree with the exhaust gas temperature sensor 1 reading in INSITE™ electronic service tool.
YES NO
No Repair

A faulty exhaust gas temperature sensor 1 has been detected.

Replace the exhaust gas temperature sensor 1. Refer to Procedure 019-013 in the Associated Procedures Table.

Follow the Exhaust Gas Temperature Above Normal troubleshooting tree in the original equipment manufacturer (OEM) seervice manual

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 248 is inactive.

Fault Code 248 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 15-May-2015


FAULT CODE 253 - Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 018-003 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active Fault Code 253. | Fault Code 253 active?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 137, 143, 219, 415, 481, 555, 556, 1362, 1785, 1787, 1788, 1825, 2553, and/or 3491 active/inactive?
STEP 2. | Check the engine oil day tank. |
 | STEP 2A. Check the oil level within the engine oil day tank. | Engine oil day tank oil level low?
 | STEP 2B. Check for oil flow between the engine oil day tank and the Murphy® oil level switch. | Oil flow from engine oil day tank to the Murphy® oil level switch?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 253 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active Fault Code 253.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electric service tool to read for active Fault Code 253.

Fault Code 253 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read for multiple active/inactive fault codes.

Fault Codes 137, 143, 219, 415, 481, 555, 556, 1362, 1785, 1787, 1788, 1825, 2553, and/or 3491 active/inactive?
YES NO

Follow the appropriate troubleshooting steps for the active/inactive fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine oil day tank.

Guided Step 2A - Check the oil level within the engine oil day tank.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the oil level within the engine oil day tank.

Engine oil day tank oil level low?
YES NO

Fill the engine oil day tank with engine oil of the correct specification. Refer to Procedure 018-003 in the Associated Procedures Table.

  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for oil flow between the engine oil day tank and the Murphy® oil level switch.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually check for oil flow between the engine oil day tank and the Murphy® oil level switch.

  • Temporarily disconnect the oil supply pipe from the engine oil day tank to the Murphy oil level switch from the connection at the Murphy oil level switch.
  • Use a suitable container to catch the oil, check that there is a good flow of oil from the engine oil day tank.
  • Contact a Cummins® Authorized Repair Location.

Oil flow from engine oil day tank to the Murphy® oil level switch?
YES NO
No Repair

Poor or no oil flow has been detected between the engine oil day tank and the Murphy® oil level switch. Check for the following conditions:

  • Engine oil day tank to Murphy® oil level switch oil supply pipe - isolation valve fully open.
  • Engine oil day tank - check for blockages at oil outlet, such as foreign matter, etc.
  • Engine oil day tank to Murphy® oil level switch oil supply pipe - no restrictions caused by routing or securing of flexible pipe work.
  • Engine oil day tank to Murphy® oil level switch oil supply pipe - no restrictions caused by internal blockages.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 2B

Guided Step 3 - Clear the fault codes

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

Use INSITE™ electronic service tool to verify Fault Code 253 is inactive.

Fault Code 253 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 15-May-2015


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the fuel shutoff valve and generator control harness connector pins. | Damaged pins?
 | STEP 2B. Check the valve supply voltage | 24 VDC?
STEP 3. | Check the generator control harness. |
 | STEP 3A. Inspect the generator control harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 engine and CM2358 panel module response. |
 | STEP 4A. Check for the appropriate CM2358 engine and 2358 panel module response. | Fault Code 254 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the fuel shutoff valve and generator control harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the generator control harness connector from the fuel shutoff valve.

Action

Inspect the valve and generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify the connectors and pins.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Crank engine.
  • Disconnect the main generator control harness from the fuel shutoff valve.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

NOTE: Make sure the engine is not performing a purge cycle when making this measurement.

24 VDC?
YES NO
No Repair

Check the battery connections and the fuses in the harness. See the engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the generator control harness.

Guided Step 3A - Inspect the generator control harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the generator control harness from the fuel shutoff valve and the CM2358 engine and CM2358 panel module.

Action

Inspect the generator control harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify the connectors and pins.

Damaged pins?
YES NO

Replace the generator control harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch crcuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the generator control harness from the extension harness, if equipped.
  • Disconnect the generator control harness from the fuel shutoff valve.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve RETURN pin on the generator control harness connector to all other pins in the generator control harness connector.
  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the generator control harness connector to all other pins in the generator control harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the generator control harness. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the generator control harness from the extension harness, if equipped.
  • Disconnect the generator control harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin on the generator control harness connector to the fuel shutoff valve SUPPLY pin on the generator control harness sensor connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin on the generator control harness connector to the fuel shutoff valve RETURN pin on the generator control harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the circuit diagram or the engine wiring diagram for the appropriate circuit.

Less than 10 ohms?
YES NO
No Repair

Replace the generator control harness. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 engine and CM2358 panel module response.

Guided Step 4A - Check for the appropriate CM2358 engine and CM2358 panel module response.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the fuel control valve actuator connector.
  • Place run/stop/auto switch in RUN mode. Crank engine.

Action

Check for the appropriate CM2358 engine and CM2358 panel module response.

  • Remove the fuel shutoff valve relays. Crank the engine. See the engine wiring diagram for the appropriate circuit.
  • Use INSITE® electronic service tool to verify the fault codes.

NOTE: Fault Code 255 will become inactive.

Fault Code 254 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the engine fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 263 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 263 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine fuel temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine fuel temperature sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the engine fuel temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

 No Repair

Go to 2B

5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor.

Action

Check the resistance of the engine fuel temperature sensor.

  • Measure the resistance between the engine fuel temperature SIGNAL pin and the engine fuel temperature RETURN pin.

600 to 36k ohms?
YES NO
No Repair

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine fuel temperature sensor connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358
  • Disconnect the engine harness from the engine fuel temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine fuel temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine fuel temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires

  • Measure the resistance from the engine fuel temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine fuel temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine fuel temperature sensor
  • Disconnect the engine harness from the CM2358.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine fuel temperature sensor connector to the sensor SIGNAL pin on the CM2358.
  • Measure the resistance from the RETURN pin on the engine fuel temperature sensor connector to the RETURN signal pin on the CM2358.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate CM2358 response.

  • Place a jumper wire between the engine fuel temperature SIGNAL pin and the engine fuel temperature RETURN pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 265 will become active upon installing the jumper.

Fault Code 263 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 263 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-May-2015


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault codes active?
STEP 2. | Check the engine fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 265 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 265 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the fuel temperature sensor.

Fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine fuel temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor.

Action

Check the resistance of the engine fuel temperature sensor.

  • Measure the resistance between the fuel temperature SIGNAL pin and the fuel temperature RETURN pin.

600 to 36k ohms?
YES NO
No Repair

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine fuel temperature sensor connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358.
  • Disconnect the engine harness from the engine fuel temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires.

  • Measure the resistance from the fuel temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the fuel temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine fuel temperature sensor.
  • Disconnect the engine harness from the CM2358.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine fuel temperature sensor connector to the sensor SIGNAL pin on the CM2358.
  • Measure the resistance from the RETURN pin on the engine fuel temperature sensor connector to the RETURN pin on the CM2358.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine fuel temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Use INSITE™ electronic service too to verify the fault codes.

Note: Fault Code 263 will become active upon disconnecting the sensor.

Fault Code 265 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault Code 265 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-May-2015


FAULT CODE 277 - Electronic Fuel Injection Control Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781
Fuel Control Valve Body Assembly | Refer to Procedure 006-049 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 441 or 442 active?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the actuator and engine harness connector pins. | Sticking, restriction, or debris blocking the engine throttle?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES NO
No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair the damaged pins.

Repair or replace the engine harness, the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel control valve body assembly. Refer to Procedure 006-049 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF
  • Remove the engine intake throttle.

Action

Check for a restriction

  • Remove the engine intake throttle.
  • Inspect the engine intake throttle for a restriction or debris blocking the throttle plate or throttle actuator sticking. Refer to Procedure 005-052 in the Associated Procedures Table.

Sticking, restriction, or debris blocking the engine throttle?
YES NO

Remove the restriction or debris.

Replace the engine throttle control actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.
  • Use the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the left bank ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the ECM connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the ECM connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine wiring harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Use the wiring diagram to identify shared sensors.

Action

Check the engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness ECM connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness ECM connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit. Use the appropriate wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine wiring harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Malfunction - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 343 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes. INSITE™ electronic service tool will identify which ECM has actived the fault code.

Fault Code 343 active?
YES NO

An internal fault has been identified within the ECM that has activated the fault code.

Repalce the appropriate ECM.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 346 - Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 346 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 346. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 346 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Contact the nearest authorized repair location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 346.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 346.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 346.

Less than three counts?
YES NO
No Repair

Contact the nearest authorized repair location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate more than one minute.
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 346 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 352 - Sensor Supply 1 Voltage - Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 352 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify no fault codes are active for any sensor sharing sensor supply circuit number 1.

Fault Code 352 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code Procedure Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connect shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. See the circuit diagram or wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-360 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the sensor supply circuit number 1 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor SUPPLY pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from all sensors that share sensor supply circuit number 1.
  • Energize the keyswitch circuit.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Read the fault codes using the electronic service tool.

Fault Code 352 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 354 - Intake Manifold Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 engine module response. |
 | STEP 4A. Check for the appropriate CM2358 engine module response. | Fault Code 354 inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohm.
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the intake manifold pressure sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

See the sensor supply Fault Code 386.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connect shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mdoe.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the intake manifold pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold pressure sensor and the CM2358 engine module.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connect shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the intake manifold pressure RETURN pin on the engine harness connector to the intake manifold pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the engine harness connector to the intake manifold pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure SUPPLY pin on the engine harness connector to the intake manifold pressure SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 engine module response.

Guided Step 4A - Check for an appropriate CM2358 engine module response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the intake manifold pressure sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 engine module response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 137 will become active upon disconnecting the sensor.

Fault Code 354 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the CM2358 engine module.

Action

Check the CM2358 engine module SIGNAL pin resistance.

  • Measure the resistance from the intake manifold pressure SIGNAL pin on the CM2358 engine module to the CM2358 engine module sensor supply circuit number 1 RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 355 - Intake Manifold Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 355 active?
STEP 2. | Check the intake manifold pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 engine module response. |
 | STEP 4A. Check for the appropriate CM2358 engine module response. | Fault Code 355 inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohm.
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the intake manifold pressure sensor.

Fault Code 355 active?
YES | NO
No Repair | No Repair

See the sensor supply Fault Code 355.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the intake manifold pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mdoe.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the intake manifold pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold pressure sensor and the CM2358 engine module.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the intake manifold pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the intake manifold pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the intake manifold pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the intake manifold pressure RETURN pin on the engine harness connector to the intake manifold pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure SIGNAL pin on the engine harness connector to the intake manifold pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure SUPPLY pin on the engine harness connector to the intake manifold pressure SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 engine module response.

Guided Step 4A - Check for an appropriate CM2358 engine module response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the intake manifold pressure sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 engine module response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 137 will become active upon disconnecting the sensor.

Fault Code 355 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the CM2358 engine module.

Action

Check the CM2358 engine module SIGNAL pin resistance.

  • Measure the resistance from the intake manifold pressure SIGNAL pin on the CM2358 engine module to the CM2358 engine module sensor supply circuit number 1 RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 359 - Engine Failed Automatic Start - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode. Operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Use INSITE™ electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

See the Engine Performance troubleshooting tree in Section TT.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/stop/auto switch in STOP mode
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Use electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing Sensor Supply Circuit Number 1.

Fault Code 386 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or intermittent fault code procedure. Refer to Procedure 019-362.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Reference the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360 in Section 19.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share Sensor Supply Circuit Number 1.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Sensor Supply Circuit Number 1 positive (+) 5 VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 or Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Contact the nearest authorized repair location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 412 - SAE J1587/J1922 Datalink - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 412 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode and operate engine for greater than one minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Refer to Procedure 019-166 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than one minute.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 412 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-Jun-2015


FAULT CODE 414 - SAE J1587/1922 Datalink - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 477, 478 or 412 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Keyswitch circuit energized.
  • Turn run/stop/auto switch to RUN mode and operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 477, 478 or 412 active?
YES NO
No Repair

Refer to Procedure 019-166 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 135 or 141 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode and operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 135 or 141 active?
YES NO
No Repair

Use the following troubleshooting symptom tree in Section TS in the QSK60 G CM2358 K110, Bulletin 4383781. Go to the Lubricating Oil Pressure Low symptom tree.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 212 or 214 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Keyswitch circuit energized.
  • Place the run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 212 or 214 active?
YES NO
No Repair

Go to the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS in the QSK60 G CM2358 K110 Service Manual, Bulletin 4383781.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 426 - J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Keyswitch circuit energized.
  • Place the run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Use the following procedure for troubleshooting procedures for the Society of Automotive Engineers (SAE) J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 427 - SAE J1939 Datalink - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Keyswitch circuit energized.
  • Place the run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Use the following procedures for troubleshooting procedures for the Society of Automotive Engineers (SAE) J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 volts of direct current (VDC) (24 VDC system)?
 | STEP 1C. Verify volts of alternating current (VAC) supplied is between 115 and 250 VAC. | 115 to 250 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Inspect the original equipment manufacturer (OEM) harness and OEM interface harness connector pins. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin. | Greater than 100 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Reference the Power Supply Manual.

 No Repair

Go to 3A

1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7 volts of direct current (VDC) (24 VDC system)?
YES NO
No Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify volts of alternating current (VAC) supplied is between 115 and 250 VAC.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Verify the VAC supplied.

  • Measure the VAC supplied to the DC power supply.

115 to 250 VAC?
YES NO

Repair or replace the DC power supply.

Make sure input circuit breakers are turned ON.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check each fuse in the battery supply circuit to see if any fuse is blown.

  • Use the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the wiring harness and connector pins forthe following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Inspect the original equipment manufacturer (OEM) harness and OEM interface harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power SUPPLY pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Greater than 100 ohms?
YES NO

Return to troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 1A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 volts of direct current (VDC) (24 VDC system)?
 | STEP 1C. Verify volts of alternating current (VAC) supplied is between 115 and 250 VAC. | 115 to 250 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Inspect the original equipment manufacturer (OEM) harness and OEM interface harness connector pins. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin. | Greater than 100 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Reference the Power Supply Manual.

 No Repair

Go to 3A

1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7 volts of direct current (VDC) (24 VDC system)?
YES NO
No Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify volts of alternating current (VAC) supplied is between 115 and 250 VAC.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Verify the VAC supplied.

  • Measure the VAC supplied to the DC power supply.

115 to 250 VAC?
YES NO

Repair or replace the DC power supply.

Make sure input circuit breakers are turned ON.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check each fuse in the battery supply circuit to see if any fuse is blown.

  • Use the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the wiring harness and connector pins forthe following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Inspect the original equipment manufacturer (OEM) harness and OEM interface harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power SUPPLY pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Greater than 100 ohms?
YES NO

Return to troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 1A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 453 - Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Gas Mass Flow Sensor | Refer to Procedure 019-101 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 239 active?
STEP 2. | Check the gas mass flow sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 8 to 15 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or amaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for an appropriate CM2358 response. | Fault Code 453 is inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using an electronic service tool, read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 239.

Go to 2A

Guided Step 2 - Check the gas mass flow sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the gas mass flow sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the gas mass flow sensor, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.
  • Connect the electronic service tool.

Action

Check the gas mass flow sensor supply voltage.

  • Measure the sensor supply voltage.

8 to 15 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the main engine harness from the CM2358.
  • Connect the electronic service tool.

Action

Check the gas mass flow sensor signal voltage.

  • Measure the signal voltage at the main harness CM2358 connector with a multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the gas mass flow sensor and the CM2358.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the gas mass flow sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the gas mass flow sensor

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the gas mass flow sensor return pin on the engine harness connector to the gas mass flow sensor RETURN pin on the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the gas mass flow sensor.
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Use the electronic service tool to verify the fault codes.

Fault Code 454 will become active upon disconnecting the sensor.

Fault Code 453 is inactive?
YES NO
No Repair

Contact the nearest Authorized Cummins® Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 454 - Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Gas Mass Flow Sensor | Refer to Procedure 019-101 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 238 active?
STEP 2. | Check the gas mass flow sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 8 to 15 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or amaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for an appropriate CM2358 response. | Fault Code 454 is inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using an electronic service tool, read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Reference the Sensor Supply Fault Code 238.

Go to 2A

Guided Step 2 - Check the gas mass flow sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the gas mass flow sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the gas mass flow sensor, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.
  • Connect the electronic service tool.

Action

Check the gas mass flow sensor supply voltage.

  • Measure the sensor supply voltage.

8 to 15 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the main engine harness from the CM2358.
  • Connect the electronic service tool.

Action

Check the gas mass flow sensor signal voltage.

  • Measure the signal voltage at the main harness CM2358 connector with a multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the gas mass flow sensor and the CM2358.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the gas mass flow sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the gas mass flow sensor

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the gas mass flow sensor return pin on the engine harness connector to the gas mass flow sensor RETURN pin on the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the gas mass flow sensor.
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Place a jumper line between the gas mass flow sensor SUPPLY pin and the gas mass flow sensor SIGNAL pin on the sensor connector.
  • Check the appropriate CM2358 response after 30 seconds.
  • Use the electronic service tool to verify the fault codes.

Fault Code 453 will become active upon disconnecting the sensor.

Fault Code 454 is inactive?
YES NO
No Repair

Contact the nearest Authorized Cummins® Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 459 - Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit on the capacitive coil driver connector. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the capacitive coil driver. |
 | STEP 3A. Check the ignition timing signal. | 5 VDC?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 459 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Inspect the pins of the CM2358 connectors and the capacitive coil driver connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Disconnect the wiring harness connector from the capacitive coil driver.

Disconnect the main harness connectors from the CM2358.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit on the capacitive coil driver connector.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition timing SIGNAL pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24 VDC SUPPLY pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24 VDC RETURN pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the ignition timing SIGNAL pin to all other pins on the CM2358 connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.

Replace the wiring harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition timing SIGNAL pin on the capacitive coil driver wiring harness connector to engine block ground.
  • Measure the resistance from the 24 VDC SUPPLY pin on the capacitive coil driver harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.

Replace the wiring harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Check for an open circuit on the signal, power supply, and power return lines.

  • Measure the resistance from the ignition timing SIGNAL pin on the capacitive coil driver wiring harness connector to the ignition timing SIGNALpin on the CM2358 connector.
  • Measure the resistance from the 24 VDC SUPPLY pin on the capacitive coil driver wiring harness connector to the 24 VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24 VDC RETURN pin on the capacitive coil driver wiring harness connector to the 24 VDC return on the power supply.
  • Measure the resistance from the 24 VDC SUPPLY pin on the CM2358 wiring harness connector to the 24 VDC supply on the power supply.
  • Measure the resistance from the 24 VDC RETURN pin on the CM2358 wiring harness connector to the 24 VDC return on the power supply.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the wiring harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the capacitive coil driver.

Guided Step 3A - Check the ignition timing signal.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connectors from the right bank CM2358.

Action

Check the voltage on the ignition timing SIGNAL pin of the CM2358 main harness connector.

Install a jumper across the contacts of the capacitive coil driver power supply relay. Make sure that 24 VDC is applied to the circuit.

  • Use a multimeter to measure the ignition timing signal voltage.

5 VDC?
YES NO
No Repair

Contact the nearest Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Use the electronic service tool to verify the fault codes.

Fault Codes 459 inactive?
YES NO
No Repair

Contact the nearest Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 462 - Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit on the capacitive coil driver connector. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the capacitive coil driver. |
 | STEP 3A. Check the ignition reference signal. | 5 VDC?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 462 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Inspect the pins of the CM2358 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Disconnect the wiring harness connector from the capacitive coil driver.

Disconnect the main harness connectors from the CM2358.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit on the capacitive coil driver connector.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition reference SIGNAL pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24 VDC SUPPLY pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24 VDC RETURN pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the ignition timing SIGNAL pin to all other pins on the CM2358 connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.

Replace the wiring harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the ignition reference SIGNAL pin on the capacitive coil driver wiring harness connector to engine block ground.
  • Measure the resistance from the 24 VDC SUPPLY pin on the capacitive coil driver harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-208 in Section 19.

Replace the wiring harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Check for an open circuit on the signal, power supply, and power return lines.

  • Measure the resistance from the ignition reference SIGNAL pin on the capacitive coil driver wiring harness connector to the ignition timing SIGNALpin on the CM2358 connector.
  • Measure the resistance from the 24 VDC SUPPLY pin on the capacitive coil driver wiring harness connector to the 24 VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24 VDC RETURN pin on the capacitive coil driver wiring harness connector to the 24 VDC return on the power supply.
  • Measure the resistance from the 24 VDC SUPPLY pin on the CM2358 wiring harness connector to the 24 VDC supply on the power supply.
  • Measure the resistance from the 24 VDC RETURN pin on the CM2358 wiring harness connector to the 24 VDC return on the power supply.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the wiring harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the capacitive coil driver.

Guided Step 3A - Check the ignition reference signal.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connectors from the right bank CM2358.

Action

Check the voltage on the ignition reference SIGNAL pin on the CM2358 main harness connector.

Install a jumper across the contacts of the capacitive coil driver power supply relay. Make sure that 24 VDC is applied to the circuit.

  • Use a multimeter to measure the ignition reference signal voltage.

5 VDC?
YES NO
No Repair

Contact the nearest Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Use the electronic service tool to verify the fault codes.

Fault Codes 462 inactive?
YES NO
No Repair

Contact the nearest Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 477 - Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 VDC (24 VDC system)?
 | STEP 1C. Verify 120 VAC supplied to DC power supply. | 120 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the battery cable connections. | Less than 10 ohms?
 | STEP 2B. Check the battery supply fuses. | Fuse OK?
 | STEP 2C. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2D. Inspect the original equipment manufacturer (OEM) harness and OEM interface harness connector pins. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin | Greater than 100 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Reference the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7 VDC (24 VDC system)?
YES NO
No Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120 VAC supplied to DC power supply.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Measure the 120 VAC input to the DC power supply.

  • Use the circuit diagram or wiring diagram for component pin identification.

120 VDC?
YES NO

Repair or replace the DC power supply.

Make sure input circuit breakers are turned ON.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check each fuse in the isolated battery supply circuit to see if any fuse is blown.

  • Reference the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the wiring harness connector from the capacitive coil driver.
  • Disconnect the main harness connectors from the CM2358.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the original equipment manufacturer (OEM) harness and OEM interface harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power SUPPLY pin on the engine harness connector to all other pins on the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Greater than 100 ohms?
YES NO

Return to troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 1A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 478 - Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7 VDC (24 VDC system)?
 | STEP 1C. Verify 120 VAC supplied to DC power supply. | 120 VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the battery ground connections. | Less than 10 ohms?
 | STEP 2B. Check the battery supply fuses. | Fuse OK?
 | STEP 2C. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2D. Inspect the original equipment manufacturer (OEM) harness and OEM interface harness connector pins. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin-to-pin | Greater than 100 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Reference the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7 VDC (24 VDC system)?
YES NO
No Repair

Charge or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120 VAC supplied to DC power supply.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Measure the 120 VAC input to the DC power supply.

Use the circuit diagram or wiring diagram for component pin identification.

120 VDC?
YES NO

Repair or replace the DC power supply.

Make sure input circuit breakers are turned ON.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair the battery ground connection. Refer to Procedure 019-197 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check each fuse in the isolated battery supply circuit to see if any fuse is blown.

  • Reference the circuit diagram or wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the original equipment manufacturer (OEM) harness and OEM interface harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin-to-pin.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the extension harness, if installed.
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power SUPPLY pin on the engine harness connector to all other pins on the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify the connectors and pins.

Greater than 100 ohms?
YES NO

Return to troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 1A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 153 and 154 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use an electronic service tool to read the active fault codes.

Fault Codes 153 and 154 active?
YES NO
No Repair

Use the following troubleshooting symptom tree in Section TS in the QSK60 G CM2358 K110, Bulletin 4383781. Go to the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jun-2015


FAULT CODE 561 - Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3111 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 561 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3111 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place Run/Stop/Auto switch in the RUN mode and operate greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-May-2013


FAULT CODE 562 - Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3112 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 562 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3112 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-May-2013


FAULT CODE 563 - Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3113 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 563 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3113 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-May-2013


FAULT CODE 564 - Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3114 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 564 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3114 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-May-2013


FAULT CODE 565 - Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3115 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 565 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3115 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate for greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-May-2013


FAULT CODE 566 - Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3116 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 566 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3116 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in the RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Run/Stop/Auto switch in the RUN mode and operate greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-May-2013


FAULT CODE 567 - Engine Cylinder 7 (A4) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3117 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 567 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3117 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-May-2013


FAULT CODE 568 - Engine Cylinder 8 (B4) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3118 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 568 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3118 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the RUN mode and operate greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-May-2013


FAULT CODE 569 - Engine Cylinder 9 (A5) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3119 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 569 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3119 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 569 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place Run/Stop/Auto switch in the STOP mode.
  • Connect all components.
  • Place Run/Stop/Auto switch in the RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Jun-2013


FAULT CODE 571 - Engine Cylinder 1 (A1) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 571 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 572 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 571 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 571 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 1 (A1) signal pin in the knock sensor connector to the knock cylinder number 1 (A1) signal pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 1 (A1) return pin in the knock sensor connector to the knock cylinder number 1 (A1) return pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 1 (A1) signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode (only run the engine after relocating the cylinder 1 (A1) knock sensor to cylinder 2 (B1) and operate the engine longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 1 (A1) to cylinder head 2 (B1). Install the knock sensor from cylinder head 2 (B1) to cylinder head 1 (A1). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in RUN mode and operate the engine for longer than 1 minute.

Fault Code 572 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 571 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Jul-2015


FAULT CODE 572 - Engine Cylinder 2 (B1) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 572 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 571 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 572 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 572 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 2 (B1) signal pin in the knock sensor connector to the knock cylinder number 2 (B1) signal pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 2 (B1) return pin in the knock sensor connector to the knock cylinder number 2 (B1) return pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 2 (B1) signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode (only run the engine after relocating the cylinder 2 (B1) knock sensor to cylinder 1 (A1) and operate the engine longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 2 (B1) to cylinder head 1 (A1). Install the knock sensor from cylinder head 1 (A1) to cylinder head 2 (B1). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in the RUN mode and operate the engine for longer than 1 minute.

Fault Code 571 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 572 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Jul-2015


FAULT CODE 573 - Engine Cylinder 3 (A2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 573 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 574 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 573 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 573 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 3 (A2) signal pin in the knock sensor connector to the knock cylinder number 3 (A2) signal pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 3 (A2) return pin in the knock sensor connector to the knock cylinder number 3 (A2) return pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 3 (A2) signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode (only run the engine after relocating the cylinder 3 (A2) knock sensor to cylinder 4 (B2) and operate greater than one minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 3 (A2) to cylinder head 4 (B2). Install the knock sensor from cylinder head 4 (B2) to cylinder head 3 (A2). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in RUN mode and operate the engine for longer than 1 minute.

Fault Code 574 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 573 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Jul-2015


FAULT CODE 574 - Engine Cylinder 4 (B2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 574 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 573 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 574 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 574 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 4 (B2) SIGNAL pin in the knock sensor connector to the knock cylinder number 4 (B2) SIGNAL pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 4 (B2) RETURN pin in the knock sensor connector to the knock cylinder number 4 (B2) RETURN pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance from the knock cylinder number 4 (B2) signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened.

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode (only run the engine after relocating the cylinder 4 (B2) knock sensor to cylinder 3 (A2) and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head 4 (B2) to cylinder head 3 (A2). Install the knock sensor from cylinder head 3 (A2) to cylinder head 4 (B2). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in RUN mode and operate the engine for longer than 1 minute.

Fault Code 573 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 574 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Jul-2015


FAULT CODE 575 - Engine Cylinder 5 (A3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781
Normal Starting Procedure | Refer to Procedure 101-014 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 575 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 576 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 575 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 575 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 5 (A3) SIGNAL pin in the knock sensor connector to the knock cylinder number 5 (A3) SIGNAL pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 5 (A3) RETURN pin in the knock sensor connector to the knock cylinder number 5 (A3) RETURN pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance from the knock cylinder number 5 (A3) SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened.

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode (only run the engine after relocating the cylinder 5 (A3) knock sensor to cylinder 6 (B3) and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head 5 (A3) to cylinder head 6 (B3). Install the knock sensor from cylinder head 6 (B3) to cylinder head 5 (A3). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute. Refer to Procedure 101-014 in the Associated Procedures Table.

Fault Code 576 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 575 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2015


FAULT CODE 576 - Engine Cylinder 6 (B3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 576 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 575 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 576 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 576 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 6 (B3) SIGNAL pin in the knock sensor connector to the knock cylinder number 6 (B3) SIGNAL pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 6 (B3) RETURN pin in the knock sensor connector to the knock cylinder number 6 (B3) RETURN pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance from the knock cylinder number 6 (B3) SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened.

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode (only run the engine after relocating the cylinder 6 (B3) knock sensor to cylinder 5 (A3) and operate greater than one minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head 6 (B3) to cylinder head 5 (A3). Install the knock sensor from cylinder head 5 (A3) to cylinder head 6 (B3). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute. Use the following procedure in the QSK60 G CM2358 K110 Operations and Maintenance Manual, Bulletin 4383782. Refer to Procedure 101-014 in Section 1.

Fault Code 575 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 576 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2015


FAULT CODE 577 - Engine Cylinder 7 (A4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 577 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 578 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 577 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 577 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 7 (A4) SIGNAL pin in the knock sensor connector to the knock cylinder number 7 (A4) SIGNAL pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 7 (A4) RETURN pin in the knock sensor connector to the knock cylinder number 7 (A4) RETURN pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance from the knock cylinder number 7 (A4) SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened.

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode (only run the engine after relocating the cylinder 7 (A4) knock sensor to cylinder 8 (B4) and operate greater than one minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head 7 (A4) to cylinder head 8 (B4). Install the knock sensor from cylinder head 8 (B4) to cylinder head 7 (A4). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute. Use the following procedure in the QSK60 G CM2358 K110 Operations and Maintenance Manual, Bulletin 4383782. Refer to Procedure 101-014 in Section 1.

Fault Code 578 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 577 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2015


FAULT CODE 578 - Engine Cylinder 8 (B4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 578 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 577 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 578 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 578 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 8 (B4) SIGNAL pin in the knock sensor connector to the knock cylinder number 8 (B4) SIGNAL pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 8 (B4) RETURN pin in the knock sensor connector to the knock cylinder number 8 (B4) RETURN pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance from the knock cylinder number 8 (B4) SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened.

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode (only run the engine after relocating the cylinder 8 (B4) knock sensor to cylinder 7 (A4) and operate greater than one minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 8 (B4) to cylinder head 7 (A4). Install the knock sensor from cylinder head 7 (A4) to cylinder head 8 (B4). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute. Use the following procedure in the QSK60 G CM2358 K110 Operations and Maintenance Manual, Bulletin 4383782. Refer to Procedure 101-014 in Section 1.

Fault Code 577 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 578 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2015


FAULT CODE 579 - Engine Cylinder 9 (A5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 579 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 1275 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 579 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place auto/run/stop switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 579 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place auto/run/stop switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 9 (A5) SIGNAL pin in the knock sensor connector to the knock cylinder number 9 (A5) SIGNAL pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 9 (A5) RETURN pin in the knock sensor connector to the knock cylinder number 9 (A5) RETURN pin in the CM2358 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance from the knock cylinder number 9 (A5) SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place auto/run/stop switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened.

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in the Associated Procedures.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place auto/run/stop switch in RUN mode (only run the engine after relocating the cylinder 9 (A5) knock sensor to cylinder 10 (B5) and operate greater than one minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head 9 (A5) to cylinder head 10 (B5). Install the knock sensor from cylinder head 10 (B5) to cylinder head 9 (A5). Refer to Procedure 019-346 in Section 19.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute. Use the following procedure in the QSK60 G CM2358 K110 Operations and Maintenance Manual, Bulletin 4383782. Refer to Procedure 101-014 in Section 1.

Fault Code 1275 active?
YES NO

Replace the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place auto/run/stop switch in RUN mode and operate greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 579 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place auto/run/stop switch in RUN mode and operate greater than one minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 20-Jul-2015


FAULT CODE 584 - Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 584 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.

Action

Inspect the starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin.

Refer to the generator set wiring diagrams for starter lockout relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.
  • Disconnect the harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the generator set wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the malfunctioned connection.

Clean, repair, or replace the OEM harness.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect ECM and wiring harness connector pins.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL wire pin at the harness ECM connector plug C.

Refer to the generator set wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay SIGNAL wire has been detected in the harness.

Refer to the generator set wiring diagram for connector pin identification.

Repair or replace the harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.
  • Disconnect the harness from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout relay SIGNAL wire pin in the ECM connector plug C and all other pins in the ECM connector plug C.

Refer to the generator set wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the harness.

Refer to the generator set wiring diagram for connector pin identification.

Repair or replace the harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswicth circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

None.

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine at rated speed for 1 minute no load.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 584 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Reset the engine - press the Reset button located on the generator control front panel.
  • Use INSITE™ electronic service tool to clear the inactive fault code.

Fault Code 584 cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 28-Jul-2015


FAULT CODE 585 - Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Greater than 6 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the starter lockout relay. | Greater than 100k ohms?
 | STEP 2D. Check the starter lockout relay diagnostic supply voltage, supply line and return circuit. | Greater than 3.75 VDC?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect ECM and wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-061 in Section 19.

Guided Step 2 - Check starter lockout relay circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the starter relay from the original equipment manufacturer (OEM) harness.

Action

Inspect the starter relay and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connections.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter relay resistance.

  • Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Use to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the starter lockout relay from the harness.

Action

Check for a pin-to-ground short circuit in the starter lockout relay.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay.

Go to 2D

Go to 4A

Guided Step 2D - Check the starter lockout relay diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the harness.

Use to the circuit diagram or wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect ECM and wiring harness connector pins.

Conditions

  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the harness from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the harness.

Conditions

  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the starter lockout relay from the harness.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit to ground in the starter lockout relay harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the harness ECM connector and ground.

Use to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground on the starter lockout relay SIGNAL wire has been detected in the harness.

Use to the wiring diagram for starter lockout relay wiring configuration.

Repair or replace the harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the harness from the ECM.
  • Disconnect the starter lockout relay from the harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the harness.

Use the wiring diagram for connector pin identification.

Repair or replace the harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 595 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active/inactive fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 595 active?
 | STEP 1B. Check for active and inactive fault codes. | Fault Codes 155, 177, 222, 618, 686, 687, 691, 741, 742, 783, 1285, 1295, 1444, 1446, 1471, 1472, 1579, 1581, 1582, 1795, 1796, 1797, 1799, 2191, 2281, 2457, 2458, 2459, 2461, 2462, 2463, 2464, 2465, 2466, 2469, 2471, 2472, 2473, 2475, 2476, 2477, 2478, 2531, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2532, 3489, 3594, and/or 3595 active or inactive?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damage connector or pigtail harness?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 635 and 1065 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at rated speed to check for fault activation. | Fault Code 595 became active during normal engine operation?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active/inactive fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Run the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595 active?
YES NO

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for active and inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for active and inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 155, 177, 222, 618, 686, 687, 691, 741, 742, 783, 1285, 1295, 1444, 1446, 1471, 1472, 1579, 1581, 1582, 1795, 1796, 1797, 1799, 2191, 2281, 2457, 2458, 2459, 2461, 2462, 2463, 2464, 2465, 2466, 2469, 2471, 2472, 2473, 2475, 2476, 2477, 2478, 2531, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2532, 3489, 3594, and/or 3595 active or inactive?

YES NO

Follow the appropriate troubleshooting steps for the active/inactive fault code or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check for a damaged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage connector or pigtail harness?
YES NO

Repair or replace the damaged connector or turbocharger speed sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-209 in Section 19.
  • Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Measure the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 635 and 1065 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Check for a short circuit to ground in the turbocharger speed sensor.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Clean the connector and pins.

Repair or replace the engine harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector to the turbocharger speed sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the ECM connector to the turbocharger speed SIGNAL (+) pin at the turbocharger speed sensor connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the ECM connector to the turbocharger speed RETURN (-) pin at the turbocharger speed sensor connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-209 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor connector.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short to ground in the engine harness.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the engine harness:

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the ECM connector to all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at rated speed to check for fault activation.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Connect the engine harness connector to the ECM module.
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal/rated load.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595 became active during normal engine operation?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

An intermittent fault condition exists.

  • The troubleshooting procedures performed may have corrected an intermittent connection problem when the engine harness connections were connected.
  • Make sure that the ECM grounds and engine/generator set chassis grounds are in good condition. Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jun-2015


FAULT CODE 641 - Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2484 or 2837 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2484 or 2837 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 642 - Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2485 or 2838 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2485 or 2838 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 643 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2486 or 2839 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2486 or 2839 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 644 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2487 or 2841 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2487 or 2841 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 645 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2488 or 2842 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2488 or 2842 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 646 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2489 or 2843 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2489 or 2843 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 647 - Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2491 or 2844 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2491 or 2844 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 648 - Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2492 or 2845 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2492 or 2845 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 652 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2494 or 2847 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2494 or 2847 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 653 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2495 or 2848 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2495 or 2848 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-May-2013


FAULT CODE 654 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2496 or 2849 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2496 or 2849 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-May-2013


FAULT CODE 655 - Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2851 or 2497 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than one minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2851 or 2497 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) symptom trees in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-May-2015


FAULT CODE 656 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2852 or 2498 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than one minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2852 or 2498 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) symptom trees in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-May-2015


FAULT CODE 657 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2853 or 2499 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than one minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2853 or 2499 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) symptom trees in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 658 - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2854 or 2511 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than one minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2854 or 2511 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) symptom trees in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 26-May-2015


FAULT CODE 686 - Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 686 active?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged connector or pigtail harness?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 500 and 1100 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins or connectors?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code occurs again. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Fault Code 686 become active during normal operation?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 686 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 686 active?
YES NO
No Repair

Use INSITE™ electronic service tool to clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check for a malfunctioning turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector or pigtail harness?
YES NO

Repair or replace the damaged connector or turbocharger speed sensor.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Check the sensor resistance.

  • Use a multimeter to measure the resistance of the turbocharger speed sensor from the speed SIGNAL (+) pin to the speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 500 and 1100 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance of the turbocharger speed sensor from the speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

NOTE: The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within 10 ohms of the sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code occurs again.

Guided Step 4A - Operate the engine at normal load to check for fault activation.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in RUN mode.

Action

Operate the engine at normal/rated load.

  • Use INSITE™ electronic service tool to check if Fault Code 686 becomes active.

Fault Code 686 become active during normal engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

An intermittent fault condition exists. The troubleshooting procedures performed may have corrected an intermittent connection problem when the engine harness connections were connected.

Make sure that the ECM grounds and engine/generator set chassis grounds are in good condition. Refer to Procedure 019-362 in Section 19.

Go to 5A

5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

Operate the engine within the "Conditions for Clearing the Faults Code" found in the Overview section of this troubleshooting procedure.

Fault Code 686 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Jun-2015


FAULT CODE 687 - Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active/inactive fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 687 active?
 | STEP 1B. Check for active and inactive fault codes. | Fault Codes 1447, 1448, 1459, 1791 and/or 1792 active/inactive?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged connector or pigtail harness?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 635 and 1065 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at rated speed to check for fault activation. | Fault Code 687 became active during normal engine operation?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active/inactive fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Run the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 687 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for active and inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for active and inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1447, 1448, 1459, 1791 and/or 1792 active/inactive?
YES NO

Follow the appropriate troubleshooting steps for the active/inactive fault code or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check for a damaged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector or pigtail harness?
YES NO

Repair or replace the damaged connector or turbocharger speed sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-209 in Section 19.
  • Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Measure the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 635 and 1065 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Check for a short circuit to ground in the turbocharger speed sensor.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Clean the connector and pins.

Repair or replace the engine harness

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-209 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector to the turbocharger speed sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the ECM connector to the turbocharger speed SIGNAL (+) pin at the turbocharger speed sensor connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the ECM connector to the turbocharger speed RETURN (-) pin at the turbocharger speed sensor connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-209 in Section 19.

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector to the turbocharger speed sensor connector.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short to ground in the engine harness.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the engine harness:

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the ECM connector to all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at rated speed to check for fault activation.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Connect the engine harness connector to the ECM module.
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal/rated load.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 687 became active during normal engine operation?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

An intermittent fault condition exists.

  • The troubleshooting procedures performed may have corrected an intermittent connection problem when the engine harness connections were connected.
  • Make sure that the ECM grounds and engine/generator set chassis grounds are in good condition. Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jun-2015


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 2B. Check the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor resistance. | 750 to 1500 ohms?
 | STEP 2D. Check for a short circuit to ground in the crankshaft engine speed sensor. | Greater than 100K ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault code.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 686 active?
YES NO

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check for the crankshaft engine speed sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the crankshaft engine speed sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair or replace the damaged engine harness connector or crankshaft engine speed sensor.

  • Repair or replace the damaged connector. Refer to Procedure 019-206 in Section 19.
  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the crankshaft engine speed sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the crankshaft engine speed sensor from the engine harness.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

Measure the voltage between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed RETURN pin at the sensor connector of the engine harness.

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Damaged crankshaft engine speed sensor?
YES NO

The crankshaft engine speed sensor is damaged.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the crankshaft engine speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL (+) pin to the speed RETURN (-) pin at the sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

750 to 1500 ohms?
YES NO
No Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the crankshaft engine speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL (+) pin on the sensor to the engine ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The crankshaft engine speed sensor is damaged.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358 module.

Action

Inspect the engine harnesses and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagramto identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins or connector?
YES NO

Clean the connector and pins.

Repair the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM2358 connector to the crankshaft engine speed SIGNAL (+) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM2358 connector to the turbocharger speed RETURN (-) pin at the crankshaft engine speed sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for a short to ground in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM2358 connector to the engine ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for a pin-to-pin short in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM2358 connector to all other pins in the CM2358 connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM2358 connector to all other pins in the CM2358 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate engine for greater than 1 minute.

Action

Disable the fault code.

Operate the engine within the "Conditions for Clearing the Faults Code" found in the Overview section of this troubleshooting procedure.

Fault Code 689 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Jun-2015


FAULT CODE 691 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Turbocharger Compressor Inlet Temperature Sensor | Refer to Procedure 019-082 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged connector?
 | STEP 2B. Check the temperature sensor resistance. | 625 ohms to 36k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins or connectors?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the ECM response | Fault Code 692 active and Fault Code 691 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

Refer to Procedure 019-362 in Section 19.

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor connector and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the turbocharger intake air temperature sensor.

Action

Inspect the turbocharger intake air temperature sensor connector, the engine harness connector and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or the turbocharger compressor intake air temperature sensor, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the temperature sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor intake air sensor connector.

Action

Use a multimeter to measure the resistance of the turbocharger compressor intake air temperature sensor from the sensor SIGNAL (+) pin to the sensor RETURN (-) pin at the sensor.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the ECM connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter for a pin-to-pin short circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the ECM connector to all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response within 30 seconds.

  • Turn a jumper wire between the turbocharger compressor intake air temperature sensor SIGNAL (+) pin and the turbocharger compressor intake air temperature sensor RETURN (-) pin at the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

A problem has been detected within the ECM module.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jun-2015


FAULT CODE 692 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Turbocharger Compressor Inlet Temperature Sensor | Refer to Procedure 019-082 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the temperature sensor resistance. | 625 ohms to 36k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the ECM response | Fault Code 691 active and Fault Code 692 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES NO

Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor connector and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the turbocharger intake air temperature sensor.

Action

Inspect the turbocharger intake air temperature sensor connector, the engine harness connector and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or the turbocharger compressor intake air temperature sensor, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the temperature sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor intake air sensor connector.

Action

Use a multimeter to measure the resistance of the turbocharger compressor intake air temperature sensor from the sensor SIGNAL (+) pin to the sensor RETURN (-) pin at the sensor.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

The turbocharger compressor intake air temperature sensor has malfunctioned.

  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector to the engine ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter for a pin-to-pin short circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the ECM connector to all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response within 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple unrelated fault codes may become active at this time. These can be temporarily ignored.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

A problem has been detected within the ECM module.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jun-2015


FAULT CODE 697 - Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 or 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 697 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Run mode and operate for greater than one minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 697 or 2544 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than one minute.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine with the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 697 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 698 - Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 698 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than one minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 698 active?
YES NO

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than one minute.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 698 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 742 - Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Nmae | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 742 inactive?
STEP 2. | Check the turbocharger compressor intake pressure sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 741 active and Fault Code 742 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 742 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger compressor intake pressure sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the turbocharger compressor intake pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active and Fault Code 742 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine turbocharger compressor intake pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES NO

A damaged sensor has been detected.

  • Replace the turbocharger compressor intake pressure/temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature +5 volt SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 inactive?
YES NO

The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active and Fault Code 742 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 inactive?
YES NO

The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 751 - Gas Mass Flow 1 Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 453 or 454 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 751 inactive?
 | STEP 2B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check the engine control module (ECM).

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 453 or 454 active?
YES NO
No Repair

Reference the fuel system symptoms in the Engine Performance Troubleshooting Tree in Section TT on this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 751 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 781 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 1135 active?
 | STEP 1B. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Between 21 and 27 VDC?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 50 and 70 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1135 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary engine control module (ECM) supply voltage circuits.

Guided Step 2A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

Perform this check on ECM 2, 3, and 4.

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check of ECM 2, 3, and 4.

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the battery voltage SUPPLY pins and the battery voltage RETURN pins in the OEM harness connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 21 and 27 VDC?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the 16 pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16 pin power connector and the OEM harness connector at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

Go to 3A

Go to 4A

Guided Step 3 - Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector from the ECM.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 and 70 ohms?
YES NO

The SAE J1939 data link 2 resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

An open or shorted SAE J1939 data link 2 circuit has been detected in the engine harness.

For QSK95 CM2350 engines, check the terminating resistors and their connectors.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 09-Jun-2015


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Air/Fuel Mixer | Refer to Procedure 005-003 | QSK60 G CM2358 K110 | 4383781
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781
Aftercooler | Refer to Procedure 010-001 | QSK60 G CM2358 K110 | 4383781
Air Cleaner Element | Refer to Procedure 010-014 | QSK60 G CM2358 K110 | 4383781
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Temperataure Sensor | Refer to Procedure 019-059 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active Fault Code 783. | Fault Code 783 active?
 | STEP 1B. Check the ECM for any other active fault codes. | Other fault codes active?
STEP 2. | Check the intake manifold 1 temperature sensor. |
 | STEP 2A. Inspect the intake manifold 1 temperature sensor electrical connections. | Dirty or damaged pins?
 | STEP 2B. Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Thermocouple reading agree with the intake manifold temperature sensor reading in INSITE™ electronic service tool?
STEP 3. | Inspect the coil-on-plug assemblies. |
 | STEP 3A. Inspect the coil-on-plug assembly harness and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Inspect the coil-on-plug assemblies for cracks or other damage. | Damage found?
STEP 4. | Inspect the spark plugs. |
 | STEP 4A. Inspect the spark plugs. | Damage found?
STEP 5. | Check the air/fuel ratio. |
 | STEP 5A. Check the air/fuel ratio is correct as per engine rating/specification. | Air/fuel ratio to specification?
STEP 6. | Inspect the air intake filters for excessive restriction. |
 | STEP 6A. Check for air filter restriction. | Restriction present?
STEP 7. | Inspect air/fuel mixer for damage. |
 | STEP 7A. Inspect air/fuel mixer for damage. | Damage found?
STEP 8. | Inspect the turbocharger for damage. |
 | STEP 8A. Inspect the turbocharger for damage. | Damage or out of specification found?
STEP 9. | Inspect the charge-air system for damage. |
 | STEP 9A. Inspect the charge-air system for visible damage. | Damage found?
 | STEP 9B. Inspect the charge-air system for leaks. | Leak found?
STEP 10. | Inspect the throttle and throttle mounting flange. |
 | STEP 10A. Inspect the throttle driver and engine harness electrical connections. | Dirty or damaged pins?
 | STEP 10B. Inspect the throttle for damage. | Damage or misalignment found?
 | STEP 10C. Inspect the throttle mounting flange for leaking or cracks. | Leak or crack found?
 | STEP 10D. Inspect the throttle plate alignment. | Throttle plate misaligned?
 | STEP 10E. Check the throttle plate for free movement throughout the full range of movement. | Throttle drives through its full range with no throttle position feedback errors reported on INSITE™ electronic service tool?
STEP 11. | Check engine compression. |
 | STEP 11A. Check individual cylinder compression pressures. | Gross leakage detected?
STEP 12. | Check high temperature cooling system for leaks. |
 | STEP 12A. Check individual cylinders for signs of high temperature coolant leakage between the cylinder head and engine block. | High temperature coolant leakage detected?
STEP 13. | Clear the fault codes. |
 | STEP 13A. Clear the inactive fault codes. | Fault Code 783 cleared?
 | STEP 13B. Verify fault code is inactive. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault code 783.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 783.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 783 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM for any other active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for any other active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Other fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree in Section TS.

Go to 3A

Guided Step 2 - Inspect the intake manifold 1 temperature sensor.

Guided Step 2A - Inspect the intake manifold 1 temperature sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the intake manifold 1 temperature sensor and the engine harness connectors and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the intake manifold 1 temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold 1 air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 2B

Guided Step 2B - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a 3A thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold, except at the probe threads.
  • Compare the intake manifold 1 temperature sensor reading on the INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

NOTE: If a temperature measuring device is not available, answer Yes to this step.

Does the thermocouple reading agree with the intake manifold temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 3A

Go to 13A

Guided Step 3 - Inspect the coil-on-plug assemblies.

Guided Step 3A - Inspect the coil-on-plug assembly harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the-coil-on plug assembly connectors, the engine harness connectors, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or coil-on-plug assembly, whichever has the dirty or damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the coil-on-plug. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 3B

Guided Step 3B - Inspect the coil-on-plug assemblies for cracks or other damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the coil-on-plug assemblies for cracks or other damage.

  • Inspect the coil-on-plug. Refer to Procedure 013-024 in the Associated Procedures Table.

Coil-on-plug assembly cracked or damaged?
YES NO

Replace the coil-on-plug assembly.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 4A

Guided Step 4 - Inspect the spark plugs.

Guided Step 4A - Inspect the spark plugs.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plugs for cracks, contamination, signs of high temperature tracking down the porcelain, or other damage.

  • Inspect the spark plugs.

Refer to Procedure 013-016 in the Associated Procedures Table.

Damage found?
YES NO

Replace the spark plugs, as necessary.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 5A

Guided Step 5 - Check the air/fuel ratio.

Guided Step 5A - Check the air/fuel ratio is correct as per engine rating/specification.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode, generator circuit breaker closed, and rated load applied.

Action

Verify that the air/fuel ratio is not too rich.

  • Use the air/fuel adjustment wizard to verify the engine is not operating too rich with INSITE™ electronic service tool.

Air/fuel ratio to specification?
YES NO
No Repair

Correct the air/fuel ratio. Use INSITE™ electronic service tool.

Go to 6A

Go to 13A

Guided Step 6 - Inspect the air intake filters for excessive restriction.

Guided Step 6A - Inspect the engine air intake filters for excessive restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for engine air intake filter restriction or damage that can cause excessive restriction.

  • Refer to Procedure 010-086 in the Associated Procedures Table.

Restriction present?
YES NO

Replace the air cleaner elements.

  • Refer to Procedure 010-014 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 7A

Guided Step 7 - Inspect air/fuel mixer for damage.

Guided Step 7A - Inspect air/fuel mixer for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Refer to Procedure 005-003 in the Associated Procedures Table.

Damage found?
YES NO

Replace the air/fuel mixer.

  • Refer to Procedure 005-003 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 8A

Guided Step 8 - Inspect the turbocharger for damage.

Guided Step 8A - Inspect the turbocharger for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the turbocharger radial bearing clearance, axial bearing clearance, and impeller for damage or out of specification condition.

  • Check the turbocharger axial clearance.
  • Check the turbocharger radial clearance.

Damage or out of specification found?
YES NO

Replace the turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 9A

Guided Step 9 - Inspect the charge-air system for damage.

Guided Step 9A - Inspect the charge-air system for visible damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for damage.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Damage found?
YES NO

Repair or replace the damaged items.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-136 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 9B

Guided Step 9B - Inspect the charge-air system for leaks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for leaks.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Damage found?
YES NO

Repair or replace the damaged items.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-136 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 10A

Guided Step 10 - Inspect the throttle and throttle mounting flange.

Guided Step 10A - Inspect the throttle driver and engine harness electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the throttle driver connectors, engine harness connectors, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the throttle driver assembly, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 10B

Guided Step 10B - Inspect the throttle for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the throttle for damage, valve misalignment, and freedom of valve rotational movement.

  • Inspect the throttle for damage.

Damage or misalignment found?
YES NO

Repair or replace the throttle body assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 10C

Guided Step 10C - Inspect the throttle mounting flange for leaks or cracks.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the throttle mounting flange for leaks or cracks.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Leak or crack found?
YES NO

Repair or replace the throttle body assembly. Refer to Procedure 010-024 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 10D

Guided Step 10D - Inspect the throttle plate alignment.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the throttle plate alignment.

  • Check the throttle plate alignment within the air/fuel intake plenum. The throttle body must be centered within the plenum.

Throttle plate misaligned?
YES NO

Realign the throttle plate or replace the throttle assembly.

  • Loosen the throttle plate mounting bolts. Align the throttle plate on the throttle shaft so the throttle plate is centered within the air/fuel intake plenum.

No Repair

Go to 13A

Go to 10E

Guided Step 10E - Check the throttle for free movement throughout the full range of movement.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle plate for free movement throughout the full range of movement.

  • Use INSITE™ electronic service tool to check the throttle plate for free movement throughout the full range of movement.

Throttle drives through full range with no throttle position feedback errors reported in INSITE™ electronic service tool?
YES NO

Repair or replace the throttle assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 13A

Go to 11A

Guided Step 11 - Check the engine compression.

Guided Step 11A - Check individual cylinder compression pressures.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check individual cylinder compression for gross leakage.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

Gross leakage detected?
YES NO

Replace cylinder head gaskets as required. Check cylinder head retaining bolt length to specification and replace as required.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 13A

Go to 12A

Guided Step 12 - Check high temperature cooling system for leaks.

Guided Step 12A - Check individual cylinders for signs of high temperature coolant leakage between the cylinder head and engine block.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check individual cylinders for signs of high temperature coolant leakage between the cylinder head and engine block.

  • Refer to Procedure 002-021 in the Associated Procedures Table.

High temperature coolant leakage detected?
YES NO

Replace cylinder head gaskets as required. Check cylinder head retaining bolt length to specification and replace as required. Refer to Procedure 002-021 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 13A

Go to 13A

Guided Step 13 - Clear the fault codes.

Guided Step 13A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine turn keyswitch. Use INSITE™ electronic service tool to verify the inactive fault codes are cleared.

Fault Code 783 cleared?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 13B

Go to the appropriate fault code troubleshooting tree

Guided Step 13B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 783 is inactive.

Fault code inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 1213 - Engine Turbocharger 1 Boost Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2517 or 2518 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is active. | Fault code inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2517 or 2518 active?
YES NO
No Repair

Check the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again..

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 1243 - Engine Derate - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

Troubleshooting presents the risk of equipment damage, personal injury, or death. Troubleshooting must be performed by trained, experienced technicians.
CAUTION

To avoid the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Intake manifold, oil pressure, turbocharger, wastegate, or fuel system fault codes active or high counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Intake manifold, oil pressure, turbocharger, wastegate, or fuel system fault codes active or high counts?
YES NO

Appropriate fault code troubleshooting tree.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the troubleshooting tree Engine Noise Excessive - Combustion Knocks in Section TS.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 1257 (Source Address 00) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1257 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed in the ECM.

Does the calibration correspond with the ECM source address?
YES NO
No Repair

The ECM has the wrong calibration.

Download the correct calibration in the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 pins and the control module identification RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open control module identification circuit has been detected in the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 and RETURN pins and all other pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

A pin-to-pin short circuit control module identification has been detected in the engine harness.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1257 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 15-Jun-2015


FAULT CODE 1257 (Source Address 01) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed in the ECM.

Calibration correspond with the ECM source address?
YES NO
No Repair

The ECM has the wrong calibration.

Download the correct calibration in the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 pins and the control module identification RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open control module identification circuit has been detected in the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 and RETURN pins and all other pins.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit on the control module identification circuit has been detected in the engine harness.

Replace the damaged section of the engine harness.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 1257 (Source Address 39) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration corresponds with the ECM source address?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration.

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed in the ECM.

Calibration corresponds with the ECM source address?
YES NO
No Repair

The ECM has the wrong calibration.

Download the correct calibration in the ECM.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the control module identification pins on the engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the engine harness ECM connector control module identification input 2 and 3 pins and the control module identification RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open control module identification circuit has been detected in the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine harness ECM connector control module identification INPUT 2 and 3 and RETURN pins and all other pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit control module identification has been detected in the engine harness.

Replace the damaged section of harness.

Check all harnesses connected in series.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-May-2015


FAULT CODE 1274 - Engine Cylinder 10 (B5) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3121 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code1274 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than one minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 3121 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than one minute.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1274 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than one minute.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 02-Jun-2015


FAULT CODE 1275 - Engine Cylinder 10 (B5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781
Normal Starting Procedure | Refer to Procedure 101-014 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1275 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check the knock sensor is tightened to specification. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 579 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1275 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1275 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor wiring harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair or replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-204 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM connector.

Action

Check for an open circuit:

  • Measure the resistance from knock cylinder number 10 SIGNAL pin in the knock sensor connector to the knock cylinder number 10 SIGNAL pin in the ECM connector.
  • Measure the resistance from knock cylinder number 10 RETURN pin in the knock sensor connector to the knock cylinder number 10 RETURN pin in the ECM connector.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure to identify connectors and pins. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from knock cylinder number 10 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for resistance measurement. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Refer to Procedure 019-204 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened to specification.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check the knock sensor is tightened to specification.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor tightened to specification?
YES NO
No Repair

Tighten the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 10 to cylinder head number 9. Install the knock sensor from cylinder head number 9 to cylinder head number 10. Refer to Procedure 019-346 in the Associated Procedures Table.
  • Place the run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute. Refer to Procedure 101-014 in the Associated Procedures Table.

Fault Code 579 active?
YES NO

Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1275 is inactive.

Fault Code 1275 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 1277 - Engine Cylinder 11 (A6) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781
Normal Starting Procedure | Refer to Procedure 101-014 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 male Deutsch™ test lead, and Part Number 3824812 female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1277 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check the knock sensor is tightened to specification. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1282 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1277 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1277 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor wiring harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair or replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-204 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM connector.

Action

Check for an open circuit:

  • Measure the resistance from knock cylinder number 11 SIGNAL pin in the knock sensor connector to the knock cylinder number 11 SIGNAL pin in the ECM connector.
  • Measure the resistance from knock cylinder number 11 RETURN pin in the knock sensor connector to the knock cylinder number 11 RETURN pin in the ECM connector.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure to identify connectors and pins. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from knock cylinder number 11 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness.Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened to specification.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check the knock sensor is tightened to specification.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-043 in the Associated Procedures Table.

Knock sensor tightened to specification?
YES NO
No Repair

Tighten the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute (only after relocating the cylinder 11 knock sensor to cylinder 12).
  • Connect INSITE™ electronic service tool.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 11 to cylinder head number 12. Install the knock sensor from cylinder head number 12 to cylinder head number 11. Refer to Procedure 019-346 in the Associated Procedures Table.
  • Place the run/auto/stop switch in RUN mode and operate the engine for greater than 1 minute. Refer to Procedure 101-014 in the Associated Procedures Table.

Fault Code 1282 active?
YES NO

Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1277 is inactive.

Fault Code 1277 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 1281 - Engine Cylinder 12 (B6) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3123 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 1281 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in RUN mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 3123 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in RUN mode and running for greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1281 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Jul-2015


FAULT CODE 1282 - Engine Cylinder Number 12 Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1282 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check the knock sensor is tightened to specification. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1277 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1282 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1282 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Refer to Procedure 019-346 in Section 19.

Knock sensor wiring harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Cummins® Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 12 SIGNAL pin in the knock sensor connector to the knock cylinder number 12 SIGNAL pin in the ECM.
  • Measure the resistance from the knock cylinder number 12 RETURN pin in the knock sensor connector to the knock cylinder number 12 RETURN pin in the ECM.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from knock cylinder number 12 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Refer to Procedure 019-204 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened to specification.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check the knock sensor is tightened to specification.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to specification?
YES NO
No Repair

Tighten the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run stop/auto switch in RUN mode. Operate the engine only after locating the cylinder number 12 knock sensor to cylinder 11.
  • Operate engine for greater than 1 minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 12 to cylinder head number 11. Install the knock sensor from cylinder head number 11 to cylinder head number 12. Refer to Procedure 019-346 in Section 19.
  • Place the run/stop/auto switch in the RUN mode and operate the engine for greater than 1 minute.

Fault Code 1277 active?
YES NO

Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1285 - Engine Cylinder Number 13 (A7) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1286 or 3124 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 1285 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 1286 or 3124 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode and running for greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jun-2015


FAULT CODE 1286 - Engine Cylinder 13 (A7) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3124 active?
 | STEP 1B. Verify the fault code is inactive | Fault Code 1286 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 3124 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and running for greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-May-2015


FAULT CODE 1287 - Engine Cylinder Number 13 Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1287 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check the knock sensor is tightened correctly. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1292 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1287 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1287 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor wiring harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Cummins® Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 13 SIGNAL pin in the knock sensor connector to the knock cylinder number 13 SIGNAL pin in the ECM.
  • Measure the resistance from the knock cylinder number 13 RETURN pin in the knock sensor connector to the knock cylinder number 13 RETURN pin in the ECM.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from knock cylinder number 13 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associates Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened correctly.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check the knock sensor is tightened correctly.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor tightened to specification?
YES NO
No Repair

Tighten the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 13 to cylinder head number 14. Install the knock sensor from cylinder head number 14 to cylinder head number 13. Refer to Procedure 019-346 in the Associated Procedures Table.
  • Place the run/stop/auto switch in the RUN mode and operate the engine for greater than 1 minute.

Fault Code 1292 active?
YES NO

Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1287 is inactive.

Fault Code 1287 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 28-Jul-2015


FAULT CODE 1291 - Engine Cylinder 14 (B7) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3125 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 1291 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 3125 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and running for greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 1292 - Engine Cylinder Number 14 Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1292 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is tightened correctly. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1287 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1292 active?
YES NO

Follow the troubleshooting steps or contact a Cummins® Authorized Repair Location

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 14 SIGNAL pin in the knock sensor connector to the knock cylinder number 14 SIGNAL pin in the ECM.
  • Measure the resistance from the knock cylinder number 14 RETURN pin in the knock sensor connector to the knock cylinder number 14 RETURN pin in the ECM.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from knock cylinder number 14 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is tightened correctly.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is tightened correctly.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor tightened to specification?
YES NO
No Repair

Tighten the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode. (Operate the engine only after relocating the cylinder 14 knock sensor to cylinder 13)
  • Operate engine for greater than 1 minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 14 to cylinder head number 13. Install the knock sensor from cylinder head number 13 to cylinder head number 14. Refer to Procedure 019-346 in the Associated Procedures Table.
  • Place the run/stop/auto switch in the RUN mode and operate the engine for greater than 1 minute.

Fault Code 1287 active?
YES NO

Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1295 - Engine Cylinder 15 (A8) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1296 or 3126 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 1295 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 1296 or 3126 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 1295 inactive?
YES NO
No Repair

Fault code inactive?

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-May-2013


FAULT CODE 1296 - Engine Cylinder 15 (A8) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3126 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 1296 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 3126 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSIGHT™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in this manual.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 1297 - Engine Cylinder 15 (A8) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1297 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is tightened correctly. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1584 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1297 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1297 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the knock sensor wiring harness is connected to the knock sensor.

  • Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor wiring harness connected?
YES NO
No Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 15 (A8) SIGNAL pin in the knock sensor connector to the knock cylinder number 15 (A8) SIGNAL pin in the CM2358 B connector.
  • Measure the resistance from the knock cylinder number 15 (A8) RETURN pin in the knock sensor connector to the knock cylinder number 15 (A8) RETURN pin in the CM2358 B connector.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from knock cylinder number 15 (A8) SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is tightened correctly.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is tightened correctly.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor tightened to specification?
YES NO
No Repair

Tighten the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode. (Operate the engine only after relocating the cylinder 15 (A8) knock sensor to cylinder 16 (B8)).
  • Operate the engine for greater than 1 minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 15 (A8) to cylinder head number 16 (B8). Install the knock sensor from cylinder head number 16 (B8) to cylinder head number 15 (A8). Refer to Procedure 019-346 in the Associated Procedures Table.
  • Place the run/stop/auto switch in the RUN mode and operate the engine for greater than 1 minute. Use the following procedure in the QSK60 G CM2358 K110 Operations and Maintenance Manual, Bulletin 4383782. Refer to Procedure 101-014 in Section 1.

Fault Code 1584 active?
YES NO

Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Faults Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1297 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 1362 - Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Filter Head | Refer to Procedure 007-015 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active or inactive fault codes. |
 | STEP 1A. Check for Fault Code 1362. | Active or inactive counts of Fault Code 1362?
 | STEP 1B. Check for multiple fault codes. | Active or inactive counts of Fault Codes 136, 137, 141, 143, 415, and 3491?
STEP 2. | Lubricating oil filters |
 | STEP 2A. Replace the lubricating oil filters. | Oil filters contaminated?
STEP 3. | Lubricating oil pressure sensors. |
 | STEP 3A. Check the pre- and post-filter lubricating oil pressure sensors. | Pressure sensor malfunctioning?
STEP 4. | Lubricating oil filter head |
 | STEP 4A. Check the lubricating oil filter head. | Lubricating oil filter head malfunctioning?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1362 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active or inactive fault codes.

Guided Step 1A - Check for Fault Code 1362.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1362?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for multiple fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Codes 136, 137, 141, 143, 415 and 3491?
YES NO

Troubleshoot any of the above fault codes. See relevant fault code tree in Section TF of this manual.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Lubricating oil filters

Guided Step 2A - Replace the lubricating oil filters.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove, inspect, and replace the lubricating oil filters.

  • Cut open the lubricating oil filters and identify any debris or oil contamination. Check the lubricating oil condition as per Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin Number 3810340.
  • Contact a Cummins® Authorized Repair Location.

Oil filters contaminated?
YES NO

Replace the engine lubricating oil if the oil shows signs of contamination or the oil analysis results recommend that the lubricating oil should be replaced.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Lubiricating oil pressure sensors

Guided Step 3A - Check the pre and post-filter lubricating oil pressure sensors.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the operation and range of pre and post-filter lubricating oil pressure sensors.

Pressure sensor malfunctioning?
YES NO

Replace pressure sensor.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Lubricating oil filter head.

Guided Step 4A - Check the lubricating oil filter head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the lubricating oil filter head assembly.

  • Refer to Procedure 007-015 in the Associated Procedures Table.

Lubricating oil filter head malfunctioning?
YES NO

Repair or replace as required.

 No Repair

Go to 5A

5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for greater than 1 minute.

Action

Use INSITE™ electronic service tool to verify Fault Code 1362 is inactive.

Fault Code 1362 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 1434 - Operator Interface Mode Transition to Emergency Stop (Due to Remote E-Stop) - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. | Fault Code 1434 cleared?

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

  • Interview the operator to determine the reason for the remote emergency stop switch being activated.
  • Connect INSITE™ electronic service tool.
  • Reset either the local or remote emergency stop switch.
  • Reset the engine - press the Reset switch located on the generator control front panel.

Action

Take any actions based on the operator's comments and then reset the remote emergency stop switch.

  • Use INSITE™ electronic service tool to clear the fault code.

Fault Code 1434 cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 29-May-2015


FAULT CODE 1474 - Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for software compatibility. |
 | STEP 1A. Check for software compatibility. | Fault Code 1474 active?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for software compatibility.

Guided Step 1A - Check for software compatibility.

Conditions

  • Connect the electronic service tool.
  • Place run/stop/auto switch in STOP mode.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the software version of each ECM.

Fault Code 1474 active?
YES NO

Use the electronic service tool to load compatible software into the ECM's.

 No Repair

Repair complete.

Repair complete.

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-May-2015


FAULT CODE 1521 - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking ameasurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 -Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1521 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 3 (A2). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 672 active and Fault Code 1521 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1521 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 672 active and Fault Code 1521 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1521 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 672 active and Fault Code 1521 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active and Fault Code 1521 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 1522 - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1522 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 673 active and Fault Code 1522 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1522 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 673 active and Fault Code 1522 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1522 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 673 active and Fault Code 1522 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active and Fault Code 1522 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1523 - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust GasTemperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1523 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 674 active and Fault Code 1523 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1523 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 674 active and Fault Code 1523 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1523 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 674 active and Fault Code 1523 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active and Fault Code 1523 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1524 - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust GasTemperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK6 0G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement, Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1524 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 675 active and Fault Code 1524 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1524 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 675 active and Fault Code 1524 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1524 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 675 active and Fault Code 1524 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active and Fault Code 1524 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature sensor RETURN pin and the engine harness exhaust gas temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature sensor SIGNAL pin and the engine harness exhaust gas temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1525 - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1525 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 676 active and Fault Code 1525 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1525 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 676 active and Fault Code 1525 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1525 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperaturee sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 676 active and Fault Code 1525 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active and Fault Code 1525 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature sensor RETURN pin and the engine harness exhaust gas temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature sensor SIGNAL pin and the engine harness iexhaust gas temperaturesensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1527 - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1527 active?
STEP 2. | Check the exhaust temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 678 active and Fault Code 1527 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1527 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 678 active and Fault Code 1527 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1527 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 678 active and Fault Code 1527 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor.

Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature SIGNAL pin and exhaust gas temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 678 active and Fault Code 1527 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engineharness ECM connector exhaust gas temperature sensor RETURN pin and the engine harness exhaust gas temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-031 in the Associated Procedures Table.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature sensor SIGNAL pin and the engine harness exhaust gas temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1529 - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1529 inactive?
STEP 2. | Check the exhaust temperature sensor and circuit cylinder 2 (B1) . |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 721 active and Fault Code 1529 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1529 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 721 active and Fault Code 1529 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1529 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 721 active and Fault Code 1529 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor.

Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 721 active and Fault Code 1529 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1531 - Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1531 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 6 (B3). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1531 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5 VDC supply to the exhaust temperature sensor. | 4.75 to 5.25 VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1531 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 6 (B3).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 (B3) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 6 (B3).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24 VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 (B3) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 6 (B3).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 6 (B3).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 6 (B3). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 6 (B3).
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive, Fault Code 671 active?
YES NO
No Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5 VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 6 (B3) exhaust temperature sensor.

Action

Check the 5 VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 6 (B3).
  • Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the CM850 module.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1531 is inactive.

Fault Code 1531 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 28-Jul-2015


FAULT CODE 1532 - Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1532 active?
STEP 2. | Check the exhaust temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 724 active and Fault Code 1532 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1532 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 724 active and Fault Code 1532 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1532 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 724 active and Fault Code 1532 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor.

Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 724 active and Fault Code 1532 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engineharness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-031 in the Associated Procedures Table.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1533 - Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 1533 inactive?
STEP 2. | Check the exhaust temperature sensor and circuit cylinder 10 (B5). |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 725 active and Fault Code 1533 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1533 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 725 active and Fault Code 1533 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1533 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 725 active and Fault Code 1533 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor.

Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intakemanifold air temperature sensor SIGNAL pinand intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 725 active and Fault Code 1533 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-031 in the Associated Procedures Table.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1534 - Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking ameasurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 -Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP .1. | Check for active fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1534 inactive?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 12 (B6). |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 726 active and Fault Code 1534 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1534 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 726 active and Fault Code 1534 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1534 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES NO
No Repair

  • Refer to Procedure 019-362 in Section 19.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit cylinder 12 (B6).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 726 active and Fault Code 1534 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor.

Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 726 active and Fault Code 1534 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1535 - Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking ameasurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 -Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1535 inactive?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 14 (B7). |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 727 active and Fault Code 1535 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1535 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 727 active and Fault Code 1535 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1535 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 727 active and Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor.

Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 727 active and Fault Code 1535 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness exhaust gas temperature temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1536 - Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking ameasurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 -Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1536 inactive?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 16 (B8). |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 728 active and Fault Code 1536 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1536 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 728 active and Fault Code 1536 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1536 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive?
YES NO
No Repair

  • Refer to Procedure 019-362 in Section 19.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 728 active and Fault Code 1536 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor.

Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 728 active and Fault Code 1536 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1546 - Engine Primary Speed Sensor (Engine Crankshaft Speed/Position Sensor) Lost - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 1546 active?
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 2B. Inspect the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor resistance. | 750 to 1500 ohms?
 | STEP 2D. Check for short circuit to ground in the crankshaft engine speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1546 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1546 active?
YES NO

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Use INSITE™ electronic service tool to clear the inactive fault codes.

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the crankshaft engine speed sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the crankshaft engine speed sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair or replace the damaged engine harness connector or crankshaft engine speed sensor.

  • Repair or replace the damage connector. Refer to Procedure 019-206 in Section 19.
  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the crankshaft engine speed sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Metal debris on end of sensor.
  • Damage to end of sensor caused by contacting the flywheel.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of sensor.

Damaged crankshaft engine speed sensor?
YES NO

The crankshaft engine speed sensor is damaged.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the crankshaft engine speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Check the resistance of the sensor.

  • Use a multimeter to measure the resistance of the crankshaft engine speed sesnor from the speed SIGNAL (+) pin to the speed RETURN (-) pin at the sensor connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

750 to 1500 ohms?
YES NO
No Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for short circuit to ground in the crankshaft engine speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Check the sensor for a short to ground.

  • Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL (+) pin on the sensor to the engine ground.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The crankshaft engine speed sensor is damaged.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connectors?
YES NO

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for an open circuit in the engine harness.

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the ECM connector to the crankshaft engine speed SIGNAL (+) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the ECM connector to the crankshaft speed RETURN (-) pin at the crankshaft engine speed sensor connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness.

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the ECM connector to the engine ground.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for a pin-to-pin short in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 1579 - Engine Cylinder 12 (B6) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1281 or 3123 active?
 | STEP 1B. Verify the fault code is inactive. | Fault code inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 1281 or 3123 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-May-2013


FAULT CODE 1581 - Engine Cylinder 14 (B7) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1291 or 3125 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 1581 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 1291 or 3125 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-May-2013


FAULT CODE 1582 - Engine Cylinder 16 (B8) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1583 or 3127 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 1582 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 1583 or 3127 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-May-2013


FAULT CODE 1583 - Engine Cylinder 16 (B8) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Bearings, Main | Refer to Procedure 001-006 | QSK60 G CM2358 K110 | 4383781
Camshaft | Refer to Procedure 001-008 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Fuel Recommendations and Specifications | Refer to Procedure 018-002 | QSK60 G CM2358 K110 | 4383781
Cooling System | Refer to Procedure 018-018 | QSK60 G CM2358 K110 | 4383781
Air Intake System | Refer to Procedure 018-019 | QSK60 G CM2358 K110 | 4383781
Exhaust System | Refer to Procedure 018-020 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference signal. |
 | STEP 3A. Check the kilowatt load transducer sensed killowatts against the generator set controller killowatts, if applied. | Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the generator set controller calibration. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances to specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor to specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspection of cylinder 16 cylinder head. |
 | STEP 7A. Check spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Inspect the cylinder head. | Cylinder head leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash setting correct?
 | STEP 7E. Inspect the valve train. | Valve train wear?
STEP 8. | Inspect cylinder 16 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and inspect for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Power cylinder damage?
 | STEP 8C. Inspect connecting rod bearings. | Connecting rod damage?
 | STEP 8D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Inspect cylinder 16 and adjacent cylinders main bearings. | Cylinder 16 or immediately adjacent main bearings worn or damaged?
STEP 9. | Check ECM calibration and clear fault codes. |
 | STEP 9A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 9B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.
  • Use the following troubleshooting symptom tree in the QSK60 G CM2358 K110, Bulletin,438378. Engine Noise Excessive - Combustion Knocks troubleshooting symptom tree in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode and operate at the highest load possible with no knock - must be at a minimum 70 percent load.
  • Connect an exhaust gas analyzer.
  • Connect INSITE™ electronic service tool.

Action

Measure the exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, to check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specifications in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

  • Use INSITE™ electronic service tool and reference the exhaust gas analyzer. Adjust the open and closed loop fueling offsets so that the mono-nitrogen oxides (NOx) and Oxygen (O2) emissions meet the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer sensed killowatts against the generator set controller killowatts, if applied.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

  • Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp / load reference signal.
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

This guided step should only be followed for generator sets without a kilowatt load transducer installed.

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode with load available.
  • Connect a power analyzer or digital multimeter.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals.
  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3, and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode, operating at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Refer to Procedure 018-019 in the Associated Procedures Table.

Intake manifold temperature within specification?
YES NO
No Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Refer to Procedure 018-018 in the Associated Procedures Table.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine. Refer to Procedure 018-018 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.
  • The intake manifold temperature sensor may have malfunctioned in-range and the related fault codes will not be activated. Go to Fault Code 153 or Fault Code 154.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Go to the appropriate specifications in Section V.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode, operating at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure. Refer to Procedure 018-019 in the Associated Procedures Table.

Intake manifold pressure within specification?
YES NO
No Repair

Check the following:

  • If installed, check the operation of the compressor bypass valve (single turbochargers engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the intake manifold pressure sensor.

The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated. Go to Fault Code 354 or Fault Code 355 in Section TF.

  • Refer to Procedure 019-359 in Section 19.
  • Use the appropriate specifications information in Section V.

Intake manifold pressure sensor to specification?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the quality of the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for the generator set (methane number and fuel contaminants limits). Refer to Procedure 018-002 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 16 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the spark plug.

Inspect the spark plug for the following:

  • Spark plug is installed correctly
  • Spark plug ”J” connector is damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Cylinder 16 spark plug gap excessive?
YES NO

  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 7C

Guided Step 7C - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 16 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 16 cylinder head.

Cylinder 16 cylinder head leaking gaskets or loose components?
YES NO

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose components on or immediately around cylinder 16 cylinder head. Use the appropriate procedures.

 No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Check the valve lash.

  • Check that the cylinder 16 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect cylinder 16 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 16 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Valve train wear?
YES NO

Replace the damaged components.

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

Adjust the valve lash. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 9A

Go to 8A

Guided Step 8 - Inspect cylinder 16 power cylinder.

Guided Step 8A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode

Action

Inspect the oil filters for debris..

  • Remove the lubricating oil filter. Refer to Procedure 001-008 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the internal power cylinder for the following:

If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 16 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 16 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 16 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 16 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 16 and immediately adjacent main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect cylinder 16 and immediately adjacent main bearings.

  • Inspect cylinder 16 and immediately adjacent main bearings. Refer to Procedure 001-006 in the Associated Procedures Table.

Cylinder 16 or immediately adjacent main bearings worn or damaged?
YES NO

Replace the main bearings as required (cylinder 16 or immediately adjacent cylinders).

  • Replace the main bearings. Refer to Procedure 001-006 in the Associated Procedures Table.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Check ECM calibration and clear fault codes.

Guided Step 9A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 9B

Go to 9B

Guided Step 9B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 1584 - Engine Cylinder Number 16 (B8) Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Knock Sensor | Refer to Procedure 019-346 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3824811 - male Deutsch™ test lead and Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1584 active?
STEP 2. | Check the wiring harness |
 | STEP 2A. Check that the knock sensor wiring harness is connected to knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 1297 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1584 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1584 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.
  • Go to the Engine Noise Excessive Combustion Knocks troubleshooting symptom tree.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor harness connected?
YES NO
No Repair

  • Connect the knock sensor harness to the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM2358 B connector.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for an open circuit.

  • Measure the resistance from knock cylinder number 16 (B8) SIGNAL pin in the knock sensor connector to the knock cylinder number 16 (B8) SIGNAL pin in the CM558 connector B.
  • Measure the resistance from knock cylinder number 16 (B8) RETURN pin in the knock sensor connector to the knock cylinder number 16 (B8) RETURN pin in the CM558 connector B.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Disconnect the knock sensor harness from the knock sensor.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from knock cylinder number 16 (B8) SIGNAL pin in the knock sensor harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Disconnect the knock sensor harness from the knock sensor.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the knock sensor is correctly tightened.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in the Associated Procedures Table.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

  • Tighten the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode (only operate the engine after relocating the cylinder 16 (B8) knock sensor to cylinder 15 (A8) and engine operating for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head 16 (B8) to cylinder head 15(A8). Install the knock sensor from cylinder head 15 (A8) to cylinder head 16 (B8). Refer to Procedure 019-346 in the Associated Procedures Table.
  • Place the run/stop/auto switch in the RUN mode and operate the engine for greater than 1 minute. Use the following procedure in the QSV91G CM2358 Operations and Maintenance Manual, Bulletin 4332688. Refer to Procedure 101-014 in Section 1.

Is Fault Code 1297 active?
YES NO

Replace the knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Faults Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1584 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 1618 - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1618 in active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 1 (A1). |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 671 active and Fault Code 1618 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1618 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 671 active and Fault Code 1618 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1618 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 671 active and Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 is active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor.

Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 671 active and Fault Code 1618 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1619 - Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1619 inactive?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 4 (B2). |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fualt Code 722 and Fault Code 1619 inactive?
 | STEP 2C. Check the fault code and verify sensor condition. | Fault Code 1619 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 722 active and Fault Code 1619 inactive?
 | STEP 3C. Check for an open circuit in the engine harness | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault code 1619 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the engine harness exhaust gas temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Fault Code 722 active and Fault Code 1619 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step -

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE® electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 1619 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas temperature sensor SIGNAL pin and exhaust gas temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active and Fault Code 1619 inactive?
YES NO
No Repair

Replace the ECM. Refer to 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature sensor RETURN pin and the engine harness exhaust gas temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature sensor SIGNAL pin and the engine harness exhaust gas temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short:

  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES NO

None. The removal and installation of theconnector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A malfunction mode should have been detected

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1696 - Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the wastegate actuator and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1696 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the wastegate actuator and circuit connected to the sensor supply and return.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the wastegate actuator from the engine harness.

Action

Inspect the wastegate actuator and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the wastegate actuator from the engine harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Repair or replace the wastegate actuator circuit.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the wastegate actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine harness ECM connector sensor SUPPLY 5 pin and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the wastegate actuator from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the engine harness ECM connector sensor SUPPLY 5 pin and the engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness. Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2015


FAULT CODE 1737 - Engine Throttle Control Actuator - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Replace the digital throttle assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jun-2015


FAULT CODE 1738 - Engine Throttle Control Actuator - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Replace the digital throttle assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jun-2015


FAULT CODE 1739 - Engine Throttle Control Actuator - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Replace the digital throttle assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jun-2015


FAULT CODE 1741 - Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check the engine room ventilation fans. |
 | STEP 3A. Check the operation of the engine room ventilation fans. | Engine room ventilation fans operating correctly?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1741 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Make sure all other temperature related fault codes are addressed prior to continuing with these troubleshooting steps.
  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Replace the digital throttle assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine room ventilation fans.

Guided Step 3A - Check the operation of the engine room ventilation fans.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode. Operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room ventilation fans.

  • Ventilation fans are operating when the generator set is operating.
  • Ventilation fans "run-on" for specified period following normal shutdown.

Engine room ventilation fans operating correctly?
YES NO
No Repair

Repair or replace the engine room ventilation fans, fan supply, or fan control. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 1741 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair complete.

Go to the appropriate troubleshooting tree.

Last Modified: 18-May-2015


FAULT CODE 1742 - Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check the engine room ventilation fans. |
 | STEP 3A. Check the operation of the engine room ventilation fans. | Engine room ventilation fans operating correctly?
STEP 4. | Check engine control module (ECM) calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Replace the digital throttle assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine room ventilation fans.

Guided Step 3A - Check the operation of the engine room ventilation fans.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room ventilation fans.

  • Ventilation fans are operating when the generator set is operating.
  • Ventilation fans "run-on" for specified period following normal shutdown.

Engine room ventilation fans operating correctly?
YES NO
No Repair

Repair or replace the engine room ventilation fans, fan supply, or fan control. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-May-2015


FAULT CODE 1761 - Engine Fuel Valve 1 Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Control Valve Body Assembly | Refer to Procedure 006-049 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 455, 511, 2311, and/or 2867 active?
STEP 2. | Check the fuel control valve for free movement. |
 | STEP 2A. Check the fuel control valve for movement and compare the commanded position signal and feedback position signal for excessive deviation. | Fuel control valve has free movement and commanded position signal and feedback position signal exceeds the 30 percent deviation limit?
STEP 3. | Check the fuel control valve actuator. |
 | STEP 3A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle is 10 to 91 percent?
 | STEP 3C. Check the fuel control valve actuator feedback signal voltage. | 0 to 5 VDC?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check for ECM response. |
 | STEP 5A. Check for an appropriate ECM response. | Fault Code 1761 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 455, 511, 2311, and/or 2867 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the fuel control valve for free movement.

Guided Step 2A - Check the fuel control valve for free movement and compare the commanded position signal and feedback position signal for excessive deviation.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement and compare the commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the fuel control valve for free movement. Drive the fuel control valve to a number of positions through its range and compare the commanded position and position feedback data. Use the Actuator Diagnostics Tests within the ECM Diagnostics Tests feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Fuel control valve has free movement and commanded position signal and feedback position signal exceeds the 30 perccent deviation limit?

YES | NO
No Repair | No Repair

Go to 3A

Go to 5A

Guided Step 3 - Check the fuel control valve actuator.

Guided Step 3A - Inspect the actuator and engine harness connector pins.

Conditions

  • Disconnect the engine harness connector from the fuel control valve actuator.
  • De-energize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Turn run/stop/auto switch to STOP mode.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the harness connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel control valve. Refer to Procedure 006-049 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Overview section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 91 percent?
YES NO
No Repair

Check the power supply connections and the fuses. See the engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3C

Guided Step 3C - Check the fuel control valve actuator feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator feedback signal voltage.

  • Use INSITE™ electronic service tool, to monitor the fuel control valve feedback position voltage.

Useo the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Overview section of this document for position feedback voltage specifications.

Feedback voltage 0 to 5 VDC?
YES NO
No Repair

A fault has been detected with the fuel control valve actuator.

  • Replace the fuel control valve. Refer to Procedure 006-049 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness from the fuel control valve actuator and the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness from the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve actuator commanded position SIGNAL (+) pin to all other pins in the engine harness.
  • Measure the resistance from the fuel control valve actuator position FEEDBACK pin to all other pins in the engine harness.
  • Measure the resistance from the fuel control valve actuator RETURN (–) pin to all other pins in the engine harness.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Turn run/stop/auto switch to STOP mode.
  • Isolater the generator set 24 volt power supply.
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Check for an open circuit.

  • Measure the resistance from the fuel control valve actuator commanded position SIGNAL (+) pin in the engine harness connector to the fuel control valve actuator commanded position SIGNAL (+) pin in the fuel control valve actuator connector.
  • Measure the resistance from the fuel control valve actuator RETURN (–) pin in the engine harness connector to the fuel control valve actuator RETURN (–) pin in the fuel control valve actuator connector.
  • Measure the resistance from the fuel control valve actuator position FEEDBACK pin in the engine harness connector to the fuel control valve actuator position FEEDBACK pin in the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check for ECM response.

Guided Step 5A - Check for the appropriate ECM response.

Conditions

  • Energize keyswitch circuit.
  • Turn run/stop/auto switch to RUN mode and operate engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.
  • Contact a Cummins® Authorized Repair Location

Fault Code 1761 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jun-2015


FAULT CODE 1767 - Engine Gas Control Valve Outlet Pressure 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the pressure sensor and circuit. |
 | STEP 2A. Inspect the pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1768 active and Fault Code 1767 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1767 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1767 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the pressure sensor and circuit.

Guided Step 2A - Inspect the pressure sensor and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect pressure sensor from the engine harness.

Action

Inspect the engine harness and the pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the pressure sensor from the engine harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1768 active and Fault Code 1767 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the pressure sensor from the engine harness.
  • Energize keyswitch circuit.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pressure +5 volt SUPPLY pin to the pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • De-energize keyswitch circuit.
  • Connect the pressure sensor to the engine harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1767 active?
YES NO

A damaged sensor has been detected.

Replace the pressure sensor.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1768 active and Fault Code 1767 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1767 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.
  • Energize keyswitch circuit.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pressure +5 volt SUPPLY pin to the pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1767 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jul-2015


FAULT CODE 1768 - Engine Gas Control Valve Outlet Pressure 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1768 active?
STEP 2. | Check the turbocharger compressor intake pressure sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1767 active and Fault Code 1768 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1768 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1768 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the pressure sensor and circuit.

Guided Step 2A - Inspect the pressure sensor and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the pressure sensor from the engine harness.

Action

Inspect the engine harness and pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the pressure sensor from the engine harness.
  • Energize keyswitch circuit.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pressure +5 volt SUPPLY pin to the pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the pressure sensor from the engine harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the pressure +5 volt SUPPLY pin and the pressure SIGNAL pin at the pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1767 active and Fault Code 1768 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • De-energize keyswitch circuit.
  • Connect the pressure sensor to the engine harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1768 active?
YES NO

A damaged sensor has been detected.

Replace the sensor.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.
  • Energize keyswitch circuit.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pressure +5 volt SUPPLY pin to the pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1768 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM connector.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the pressure +5 volt SUPPLY pin and the pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1767 active and Fault Code 1768 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1768 inactive?
YES NO

The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jul-2015


FAULT CODE 1774 - Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1774 active?
STEP 2. | Check the engine oil priming pump circuit and sensors. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the original equipment manufacturer (OEM) pump switch input connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM pump switch input voltage. | 4.75 to 5.25-VDC?
STEP 3. | Check the engine oil priming pump. |
 | STEP 3A. Check the engine priming pump operation. | Pump operating?
STEP 4. | Clear the fault code. |
 | STEP 4A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1774 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine oil priming circuit and sensors

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the oil pressure sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged oil pressure sensor.

Check all harnesses connected in series.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM pump switch input connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the oil pressure sensor or harness connector.

Clean the connector and pins.

 No Repair

Go to 4A

Go to 3A

Guided Step 2C - Check the OEM pump switch input voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pump switch input connector from the OEM harness connector.
  • Turn keyswitch ON.

Action

Check the input voltage.

  • Measure the voltage between the OEM pump switch input pin and OEM pump switch return.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine oil priming pump

Guided Step 3A - Check the engine oil priming pump operation.

Conditions

  • Turn keyswitch ON.

Action

  • Check if the engine oil priming pump is operating.

Pump operating?
YES NO
No Repair

Troubleshoot the engine oil priming pump.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 16-Jun-2015


FAULT CODE 1775 - Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1775 inactive?
STEP 2. | Check the relay and circuit. |
 | STEP 2A. Inspect the relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1775 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1775 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the relay and circuit.

Guided Step 2A - Inspect the relay and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the relay for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance between the relay SIGNAL pin and the relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the relay. See equipment manufacturer service information.

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the relay return circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the relay RETURN pin at the relay connector to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector. Disconnect the relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector relay RETURN pin and the OEM harness relay connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Go to 3C

Less than 10 ohms?

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1775 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Jun-2015


FAULT CODE 1778 - Engine Block/Coolant Pre-Heater Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1778 active?
STEP 2. | Check the coolant pre-heater and circuit. |
 | STEP 2A. Inspect the coolant pre-heater and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1779 active and Fault Code 1778 inactive?
 | STEP 2C. Check the fault codes and verify the coolant heater condition. | Fault Code 1778 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM, engine harness, and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1778 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the coolant pre-heater and circuit.

Guided Step 2A - Inspect the coolant pre-heater and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the coolant heater from the OEM harness.

Action

Inspect the OEM harness and coolant heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3823510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness.
  • Replace the coolant heater

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the coolant heater control valve from the OEM harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the coolant heater control valve SIGNAL pin and the coolant heater RETURN pin at the coolant heater OEM harness connector.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1779 active and Fault Code 1778 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the coolant heater condition.

Conditions

  • De-energize keyswitch circuit.
  • Connect the coolant heater to the OEM harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1778 active?
YES NO

A malfunctioning coolant heater has been detected.

  • Replace the coolant heater. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM, engine harness, and OEM harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness.

Action

Inspect the engine harness, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the engine harness.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the coolant heater control valve from the OEM harness.

Action

Check for an open supply circuit.

  • Measure the resistance between the coolant heater SIGNAL pin at the OEM harness connector and the coolant heater SIGNAL pin at the engine harness.
  • Measure the resistance between the coolant heater SIGNAL pin at the engine harness connector and the coolant heater SIGNAL pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open signal circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the engine harness.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the coolant heater control valve from the OEM harness.

Action

Check for an open supply circuit.

  • Measure the resistance between the coolant heater RETURN pin at the OEM harness connector and the coolant heater RETURN pin at the engine harness.
  • Measure the resistance between the coolant heater RETURN pin at the engine harness connector and the coolant heater RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

An open signal circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the engine harness.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the coolant heater control valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the coolant heater SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance between the coolant heater SIGNAL pin at the engine harness ECM connector and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jul-2015


FAULT CODE 1779 - Engine Block/Coolant Pre-Heater Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1779 active?
STEP 2. | Check the coolant pre-heater and circuit. |
 | STEP 2A. Inspect the coolant pre-heater and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1778 active and Fault Code 1779 inactive?
 | STEP 2C. Check the fault codes and verify the coolant heater condition. | Fault Code 1779 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM, engine harness, and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1779 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the coolant pre-heater and circuit.

Guided Step 2A - Inspect the coolant pre-heater and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the coolant heater from the OEM harness.

Action

Inspect the OEM harness and coolant heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3823510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness.
  • Replace the coolant heater

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the coolant heater control valve from the OEM harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1778 active and Fault Code 1779 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the coolant heater condition.

Conditions

  • De-energize keyswitch circuit.
  • Connect the coolant heater to the OEM harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1779 active?
YES NO

A malfunctioning coolant heater has been detected.

  • Replace the coolant heater. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM, engine harness, and OEM harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the OEM harness connector from the engine harness.

Action

Inspect the engine harness, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness, or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the engine harness.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the coolant heater control valve from the OEM harness.

Action

Check for an open supply circuit.

  • Measure the resistance between the coolant heater SIGNAL pin at the OEM harness connector and the coolant heater SIGNAL pin at the engine harness.
  • Measure the resistance between the coolant heater SIGNAL pin at the engine harness connector and the coolant heater SIGNAL pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the coolant heater control valve from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the coolant heater SIGNAL pin at the OEM harness ECM connector and block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open signal circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the coolant heater from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the SIGNAL pin at the OEM harness ECM connector and block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jul-2015


FAULT CODE 1781 - Engine Controlled Shutdown Request Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1781 inactive?
STEP 2. | Check the relay and circuit. |
 | STEP 2A. Inspect the relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the relay for an open circuit. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the relay. |
 | STEP 2C. Check the relay diagnostic supply voltage, supply line, and return circuit. | Greater than 3.75 VDC?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 339 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic settings.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1781 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the relay and circuit.

Guided Step 2A - Inspect the relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the relay from the OEM harness.

Action

Inspect the OEM harness and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance between the relay SIGNAL pin and the relay RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the relay. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the relay.

Conditions

  • Turn keyswitch OFF.
  • Diconnect the relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the relay SIGNAL pin and ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the relay diagnostic supply voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the relay SIGNAL pin and the relay RETURN pin at the relay connector of the OEM harness.

Use the OEM wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the OEM harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the relay SIGNAL pin in the OEM harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver signal line has been detected in the OEM harness.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 1781 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 1782 - Engine Controlled Shutdown Request Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1782 inactive?
STEP 2. | Check the relay and circuit. |
 | STEP 2A. Inspect the relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1782 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1782 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the relay and circuit.

Guided Step 2A - Inspect the relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the relay from the OEM harness.

Action

Inspect the OEM harness and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance between the relay SIGNAL pin and the relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the relay. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the relay RETURN pin at the relay connector to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

  • If the RETURN is wired to the ECM, repair or replace the OEM harness.
  • If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.
  • Repair or replace the OEM harness.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector relay RETURN pin and the OEM harness relay connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the idle shutdown SIGNAL wire has been detected in the OEM harness.

  • Repair or replace the OEM harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

  • Repair or replace the OEM harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1782 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 1785 - Engine Oil Priming Pump Manual On Switch - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1785 inactive?
STEP 2. | Check the original equipment manufacturer (OEM) switch circuit. |
 | STEP 2A. Inspect the OEM switch. | Dirty or damaged pins?
 | STEP 2B. Check the OEM switch. | Switch operating correctly?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100K ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1785 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1785 inactive?
YES | NO
No Repair | No Repair

An intermittent fault condition exists. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM switch circuit.

Guided Step 2A - Inspect the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the switch from the OEM harness.

Action

Inspect the switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the switch from the OEM harness.

Action

Check the functionality of the switch.

  • See equipment manufacturer service information.

Switch operating correctly?
YES NO
No Repair

Replace the switch. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the switch pin in the OEM harness ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the switch circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the switch from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the switch pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector switch pin and the OEM harness switch pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Repair or replace the OEM harness.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1785 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 1786 - Engine Oil Priming Pump Control - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the oil priming pump. |
 | STEP 1A. Check the oil priming pump and oil priming pump relay, if equipped. | Oil priming pump within specifications?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the ECM connectors. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the oil priming pump.

Guided Step 1A - Check the oil priming pump and oil priming pump relay, if equipped.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the oil priming pump or oil priming pump relay.

Action

Check the oil priming pump for the following:

  • Damaged pins.
  • Open or short circuits.
  • Excessive current draw (power oil priming pump directly from battery).
  • Perform this test in accordance with the OEM instructions.

Oil priming pump within specifications?
YES NO
No Repair

Repair or replace the oil priming pump. See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and the ECM connectors.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness connector.

Action

Inspect the engine harness and the ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or ECM, whichever has the damaged pins.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from the engine harness connector to the OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the engine harness to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the OEM harness connector.

Action

Check for a short circuit between pins.

  • Measure the resistance from pin to pin in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the oil priming pump solenoid or relay.
  • Disconnect the engine harness from the OEM harness connector.

Action

Inspect the OEM harness and connector for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or oil priming pump relay, whichever has damaged pins.

  • Repair or replace the OEM harness.
  • Replace the oil priming pump relay. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the oil priming pump solenoid or relay.
  • Disconnect the engine harness from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance from the pin on the OEM side to the oil priming pump solenoid or relay.

Less than 10 ohms?
YES NO
No Repair

Replace the OEM harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the OEM harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the oil priming pump solenoid or relay.
  • Disconnect the engine harness from the OEM harness connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure resistance from OEM harness connector to ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the OEM harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the oil priming pump solenoid or relay.
  • Disconnect the engine harness from the OEM harness connector.

Action

Check for a short circuit from pin-to-pin in the OEM harness.

  • Measure resistance from pin J of the OEM harness connector to all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the OEM harness.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Clear the fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 1786 is inactive.

Fault Code 1786 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting chart

Last Modified: 15-Jun-2015


FAULT CODE 1787 - Engine Oil Priming State - Post-Lubrication - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Active or inactive counts of Fault Code 1774, 1775, 1785, 1786 or 1835?
 | STEP 1B. Check for fault codes. | Active or inactive counts of Fault Code 1787?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1774, 1775, 1785, 1786 or 1835?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1787?
YES NO

Use the troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High troubleshooting symptom tree in Section TS in the appropriate original equipment manufacturer (OEM) service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jul-2015


FAULT CODE 1788 - Engine Oil Priming State - Maintenance Lubrication - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1774 or 1775 active or inactive counts?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with INSITE™ electronic service tool. | Oil pressure correlate with a known value?
STEP 3. | Check the oil supply. |
 | STEP 3A. Check for adequate oil supply. | Equipment has adequate oil supply?
STEP 4. | Check the oil inlet restriction. |
 | STEP 4A. Check the oil inlet restriction. | Oil inlet restriction less than specification?
STEP 5. | Check the oil filters. |
 | STEP 5A. Check the oil filters. | Oil filters need changed?
STEP 6. | Check the oil pump actuator. |
 | STEP 6A. Inspect the oil pump actuator. | Debris or damage present?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector circuit fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1774 or 1775 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Install a gauge or digital multimeter pressure sensor at the oil pump outlet.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Monitor oil delivery pressure with INSITE™ electronic service tool with engine OFF and at idle.
  • Compare the reading in INSITE™ with a gauge or known value.
  • Oil pressure information in original equipment manufacturer (OEM) manual.

Oil pressure correlate with a known value?
YES NO
No Repair

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Check the oil supply.

Guided Step 3A - Check for adequate oil supply.

Conditions

  • Turn keyswitch ON.
  • Turn keyswitch OFF.

Action

Check for adequate oil supply.

  • Verify there is oil in the tank.

Equipment has an adequate oil supply?
YES NO
No Repair

Add oil to the oil tank or perform repairs to the tank or oil gauge.

Go to 4A

Go to 7A

Guided Step 4 - Check the oil inlet restriction.

Guided Step 4A - Check the oil inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the inlet restriction as follows:

  • Measure the inlet restriction and compare to specification.

Oil inlet restriction less than the specification?
YES NO
No Repair

  • Find the cause of the restriction and remove the restriction. Check for debris in the oil tank, oil tank vents clogged, and malfunctioning check valves.
  • Change the oil filters.
  • Inspect the oil lines and replace, if necessary.

Go to 5A

Go to 7A

Guided Step 5 - Check the oil filters.

Guided Step 5A - Check the oil filters.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil filters.

Oil filters need changed?
YES NO
No Repair

Check the OEM oil lines for loose fittings or damaged lines. See equipment manufacturer service information.

Inspect the oil lines and fittings and tighten or replace, if necessary.

Go to 7A

Go to 6A

Guided Step 6 - Check the oil pump actuator.

Guided Step 6A - Inspect the oil pump actuator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the oil pump actuator for debris.

  • Remove the oil pump actuator.
  • Inspect the oil pump actuator for debris and damage.

Debris or damage present?
YES NO

Replace the oil pump actuator.

Replace the oil pump.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jul-2015


FAULT CODE 1789 - Engine Oil Priming State - Pre-Lubrication - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1789?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1789?
YES NO

Low oil pressure has been detected. Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the appropriate original equipment manufacturer (OEM) service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 1791- Electrical Load, Failure to Meet Load and/or Speed Demand - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftercooler | Refer to Procedure 010-001 | QSK60 G CM2358 K110 | 4383781
Aftercooler Element | Refer to Procedure 010-008 | QSK60 G CM2358 K110 | 4383781
Air Cleaner Element | Refer to Procedure 010-014 | QSK60 G CM2358 K110 | 4383781
Air Intake Restriction | Refer to Procedure 010-031 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Air Intake System | Refer to Procedure 018-019 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes or high counts of inactive fault codes. | Fault Code 144, 145, 146, 153, 154, 155, 156, 157, 158, 177, 263, 265, 354, 355, 453, 454, 488, 512, 513, 691, 692, 751, 783, 1737, 1738, 1739, 1741, 1743, 1744, 1745, 1746, 1747, 1748,1749, 1751, 1752, 1759, 1761, 1765, 1766, 1767, 1768, 1783, 1793, 1821,1827, 1828, 1838, 1839, 1841, 1984, 2157, 2191, 2311, 2313,2427, 2428, 2455, 2456, 2457, 2517, 2518, 2569, 2643, 2644, 2752, 2812, 2866, 2867, 2876, 2877, 3384, 3391, 3475, 3476, 3499, 3511, 3512, 3514, 3521, 3522, 3594, and/or 3595 active?
STEP 2. | Check the air intake system. |
 | STEP 2A. Check the air intake system for restriction. | Air intake system restricted?
 | STEP 2B. Check the aftercooler for restriction. | Aftercooler restricted?
STEP 3. | Check the exhaust emissions. |
 | STEP 3A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 4. | Check the air inlet temperature. |
 | STEP 4A. Check the air inlet temperature. | Air inlet temperature high?
STEP 5. | Check the kilowatt load transducer, if installed. |
 | STEP 5A. Check the kilowatt load transducer-reference signal, if applied. | Kilowatt load transducer-sensed kilowatt matches generator set controller kilowatts?
 | STEP 5B. Check the calibration of the generator set controller. | Generator set controller voltage and ampere output calibration correct?
STEP 6. | Check the turbocharger(s). |
 | STEP 6A. Inspect the turbocharger(s). | Turbocharger(s) worn or damaged?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144, 145, 146, 153, 154, 155, 156, 157, 158, 177, 263, 265, 354, 355, 453, 454, 488, 512, 513, 691, 692, 751, 783, 1737, 1738, 1739, 1741, 1743, 1744, 1745, 1746, 1747, 1748,1749, 1751, 1752, 1759, 1761, 1765, 1766, 1767, 1768, 1783, 1793, 1821,1827, 1828, 1838, 1839, 1841, 1984, 2157, 2191, 2311, 2313,2427, 2428, 2455, 2456, 2457, 2517, 2518, 2569, 2643, 2644, 2752, 2812, 2866, 2867, 2876, 2877, 3384, 3391, 3475, 3476, 3499, 3511, 3512, 3514, 3521, 3522, 3594, and/or 3595 active?

YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the air intake system.

Guided Step 2A - Check the air intake system for restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the air intake system for restriction.

  • Air filters excessive restriction. See equipment manufacturer service information.
  • Air filters element damage. Refer to Procedure 010-014 in Associated Procedures Table.
  • Air intake restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake system restricted?
YES NO

  • Replace the air filter elements. Refer to Procedure 010-014 in Associated Procedures Table.
  • Repair or replace the air intake piping as appropriate. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check aftercooler for restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the aftercooler core on the charge-air inlet for signs of blockage such as dust build-up, core element damage/collapse, and oil carry-over, etc.

  • Remove the aftercooler assembly from the engine. Refer to Procedure 010-001 in the Associated Procedures Table.
  • Remove the aftercooler inlet cover. Refer to Procedure 010-008 in the Associated Procedures Table.

Aftercooler restricted?
YES NO

  • Clean the aftercooler core. Refer to Procedure 010-008 in the Associated Procedures Table.
  • Replace aftercooler assembly. Refer to Procedure 010-001 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the exhaust emissions.

Guided Step 3A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect an exhaust gas analyzer.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine at the highest load possible with no knock; should be at a minimum of 70 percent load.
  • Connect INSITE™ electronic service tool.

Action

Measure the exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, to check that the exhaust emissions are to the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location

Exhaust emissions to specification?
YES NO
No Repair

Use INSITE™ electronic service tool and see the exhaust gas analyzer to adjust the “open and closed-loop” fueling offsets so the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 7A

Guided Step 4 - Check the air inlet temperature.

Guided Step 4A - Check the air inlet temperature.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the air inlet temperature.

  • Check the temperature of the air entering the engine against the specification limit for the engine. Refer to Procedure 018-019 in the Associated Procedures Table.

Air inlet temperature high?
YES NO

The temperature of the air entering the engine is too high. Inspect the following balance-of-plant systems and repair or replace as necessary.

  • Engine room ventilation fans operation.
  • Motorized engine room louvres operation.
  • Engine room air intake grilles for blockages and other obstructions.
  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the kilowatt load transducer, if installed.

Guided Step 5A - Check the kilowatt load transducer-reference signal, if applied.

Conditions

Note: If the generator set is not fitted with a kilowatt load transducer, proceed to Step 5B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 7A

Guided Step 5B - Check the calibration of the generator set controller.

Conditions

Note: This guided step should only be followed for generator sets not installed with a kilowatt load transducer.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect a power analyzer or digital multimeter.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the genset controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller voltage and ampere output calibration correct?
YES NO
No Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 7A

Guided Step 6 - Check the turbocharger(s).

Guided Step 6A - Inspect the turbocharger(s).

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the turbocharger(s).

Inspect the turbocharger(s) for the following:

  • Excessive axial clearance.
  • Excessive radial clearance.
  • Turbocharger turbine or compressor damage.
  • Contact a Cummins® Authorized Repair Location

Turbocharger(s) worn or damaged?
YES NO
No Repair

A fault code has been detected with the turbocharger(s).

  • Replace the turbocharger(s) as necessary. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1792 - Generator Governing Speed Command: Engine Low Idle/Rated Speed with Genset Breakers Closed - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check generator set with PowerCommand™ Supervisor and generator set with PCC3300. |
 | STEP 1A. Read the PowerCommand™ Supervisor and PCC3300 fault codes. | PowerCommand™ Supervisor fault code?
 | STEP 1B. Check the ECM for active fault codes. | Fault Code 1792 active?
STEP 2. | Check the idle/rated command circuit. |
 | STEP 2A. Check for idle command input. | Idle commanded ON?
 | STEP 2B. Measure the resistance of K10-2 contact. | Less than 10 ohms?
 | STEP 2C. Measure the voltage drop across the K12 coil. | Between 5 VDC and 24 VDC?
 | STEP 2D. Check for short circuit to ground between the K10-2 contact and ECM. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground between the K10-2 coil and PLC6-7. | Greater than 100k ohms?
STEP 3. | Check the utlility parallel status circuit. |
 | STEP 3A. Measure the voltage at C44. | Between 5 VDC and 24 VDC?
 | STEP 3B. Measure the resistance of K12-3 contact. | Less than 10 ohms?
 | STEP 3C. Measure the voltage drop across the K12 coil. | Between 5 VDC and 24 VDC?
 | STEP 3D. Check for a short circuit to ground between K12-3 contact and ECM. | Greater than 100k ohms?
 | STEP 3E. Check for a short-circuit to B+ between C44 and K12-3 coil. | Greater than 100k ohms?
 | STEP 3F. Measure the voltage at C46. | Between 5 VDC and 24 VDC?
 | STEP 3G. Measure the resistance of K15-2 contact. | Less than 10 ohms?
 | STEP 3H. Measure the voltage drop across the K15 coil. | Between 5 VDC and 24 VDC?
 | STEP 3I. Check for a short-circuit to ground between K15 contact and K12. | Greater than 100k ohms?
 | STEP 3J. Check for a short-circuit to B+ between C46 and K15 coil. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 4B. Verify the fault code is inactive. | Fault Code 1792 inactive?
STEP 5. | Check the fault codes. |
 | STEP 5A. Check the ECM for active fault codes. | Fault Code 1792 active?
STEP 6. | Check the idle / rated command circuit. |
 | STEP 6A. Check for idle command input. | Idle command present?
STEP 7. | Check the utility parallel status circuit. |
 | STEP 7A. Check generator set circuit breaker position. | Breaker open?
 | STEP 7B. Check for PCC3300 TB10-1 short circuit to ground. | More than 100k ohms?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 8B. Verify the fault code is inactive. | Fault Code 1792 inactive?

Guided Step 1 - Check generator set with PowerCommand™ Supervisor and generator set with PCC3300.

Guided Step 1A - Read the PowerCommand™ Supervisor and PCC3300 fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code.

  • Verify whether fault code PowerCommand™ Supervisor or PCC3300 is active?

PowerCommand™ Supervisor fault code?
YES NO
No Repair

This is a PCC3300 fault code. Begin troubleshooting at Guided Step 5A.

Go to 1B

Go to 5A

Guided Step 1B - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1792 active?
YES NO
No Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the idle / rated command circuit.

Guided Step 2A - Check for idle command input.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode.

Action

Check the state of idle command via the generator set human machine interface as ON or OFF.

Idle commanded ON?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Measure the resistance of K10-2 contact.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Measure the resistance of K10-2 contact.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Measure the voltage drop across the K10 coil.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Measure the voltage drop across the K10 coil.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 5 VDC and 24 VDC?
YES NO
No Repair

Replace or replace K10 relay.

Go to 2E

Go to 4A

Guided Step 2D - Check for short circuit to ground between the K10-2 contact and ECM.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for a short circuit to ground between K10-2 contact and ECM via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace or replace the wire or connections between the K10-2 contact and ECM.

Go to 4A

Go to 4A

Guided Step 2E - Check for a short circuit to ground between the K10-2 coil and PLC6-7.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for a short circuit to ground between K10-2 and PLC6-7 via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace K10 relay.

Repair or replace the wire or connections between K10-2 coil and PLC6-7.

Go to 4A

Go to 4A

Guided Step 3 - Check the utlility parallel status circuit.

Guided Step 3A - Measure the voltage at C44.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode.

Action

Measure the voltage at C44.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 5 VDC and 24 VDC?
YES | NO
No Repair | No Repair

Go to 3F

Go to 3B

Guided Step 3B - Measure the resistance of K12-3 contact.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Measure the resistance of K12-3 contact.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3D

Guided Step 3C - Measure the voltage drop across the K12 coil.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Measure the voltage drop across the K12 coil.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 5 VDC and 24 VDC?
YES NO
No Repair

Repair or replace the K12 relay.

Go to 3E

Go to 4A

Guided Step 3D - Check for a short circuit to ground between K12-3 contact and ECM.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for a short circuit to ground between K12-3 contact and ECM via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the wire or connections between K12-3 and ECM.

Go to 4A

Go to 4A

Guided Step 3E - Check for a short circuit to B+ between C44 and K12-3 coil.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for a short circuit to ground between C43 and K12-3 coil via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the K12 relay.

Repair or replace the wire or connections between K12-3 and C44.

Go to 4A

Go to 4A

Guided Step 3F - Measure the voltage at C46.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode.

Action

Measure the voltage at C46.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 5 VDC and 24 VDC?
YES NO

Via the generator set human machine interface, remove the idle command and or remove the generator set from utility parallel mode of operation.

No Repair

Go to 4A

Go to 3G

Guided Step 3G - Measure the resistance of K15-2 contact.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Measure the resistance of K15-2 contact.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 3H

Go to 3I

Guided Step 3H - Measure the voltage drop across the K15 coil.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Measure the voltage drop across the K15 coil.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 5 VDC and 24 VDC?
YES NO
No Repair

Repair or replace the K15 relay.

Go to 3J

Go to 4A

Guided Step 3I - Check for a short circuit to ground between K15 contact and K12.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for a short circuit to ground between K15 contact and K12 via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the wire or connections between K12-3 and K15-2.

Go to 4A

Go to 4A

Guided Step 3J - Check for a short circuit to B+ between C46 and K15 coil.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for a short circuit to ground between C43 and K12-3 coil via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the K15 relay.

Repair or replace the wire or connections between K15-2 and C46.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch. Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to 4B

Appropriate troubleshooting steps

Guided Step 4B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Clear the inactive fault codes on the generator set control panel by pressing the 'Reset' button on the control panel and cyling the engine ECM keyswitch.
  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1792 inactive?

YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 5 - Check the fault codes.

Guided Step 5A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1792 active?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to 6A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 6 - Check the idle / rated command circuit.

Guided Step 6A - Check for idle command input.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Navigate to the "Adjust" screen via the generator set human machine interface and check the state of the rated / idle switch.

–

Idle command present?
YES NO

Remove the idle command by enabling rated command.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 7A

Go to 8A

Guided Step 7 - Check the utility parallel status circuit.

Guided Step 7A - Check the generator set circuit breaker position.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Visually confirm the position of the generator set circuit breaker as open or closed.

–

Breaker open?
YES NO
No Repair

Unload the generator set and open the generator set circuit breaker.

Go to 7B

Go to 8A

Guided Step 7B - Check for PCC3300 TB10-1 short circuit to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for PCC3300 TB10-1 short circuit to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the wire.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch. Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to 8B

Appropriate troubleshooting steps

Guided Step 8B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Clear the inactive fault codes on the generator set control panel by pressing the 'Reset' button on the control panel and cyling the engine ECM keyswitch.
  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 1792 inactive?

YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1793 - Engine Crankshaft Speed/Position Mismatch Between ECMs – Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | QSK60 G CM2358 K110 | 4383781
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple active fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Codes 121, 689, 1546, 1821, and/or 1837 active?
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged crankshaft engine speed sensor or engine harness connector pins?
 | STEP 2B. Check the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor resistance. | Resistance 750 to 1500 ohms?
 | STEP 2D. Check for a short circuit to ground in the crankshaft engine speed sensor. | Greater than 100k ohms?
STEP 3. | Check the camshaft engine speed/position sensor. |
 | STEP 3A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 3B. Check the camshaft engine speed/position sensor for damage. | Damaged camshaft engine speed/position sensor?
 | STEP 3C. Check the camshaft engine speed/position sensor resistance. | Less than 2k ohms?
 | STEP 3D. Check for a short circuit to ground in the camshaft engine speed/position sensor. | Greater than 100k ohms?
 | STEP 3E. Check the camshaft engine speed/position sensor for a short between coils. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins or connector?
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 5. | Check engine control module (ECM) calibration code and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in RUN mode.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Run the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 121, 689, 1546, 1821, and/or 1837 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the crankshaft engine speed sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the crankshaft engine speed sensor connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

  • Repair or replace the damaged connector. Refer to Procedure 019-206 in Section 19.
  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the crankshaft engine speed sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankshaft engine speed sensor connector.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Damaged crankshaft engine speed sensor?
YES NO

Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the crankshaft engine speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankshaft engine speed sensor connector.

Action

Measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL(+) pin to the speed RETURN (-) pin at the sensor connector. Use a multimeter.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 750 to 1500 ohms?
YES NO
No Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground in the crankshaft engine speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL(+) pin on the sensor to the engine ground. Use a multimeter.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The crankshaft engine speed sensor is damaged.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for the camshaft engine speed/position sensor.

Guided Step 3A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.

Action

Inspect the camshaft engine speed/position sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair or replace the damaged engine harness connector or camshaft engine speed/position sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged engine harness or connector. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the camshaft engine speed/position sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.
  • Remove the camshaft engine speed/position sensor.

Action

Inspect the camshaft engine speed/position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor.

Refer to Procedure 019-038 in the Associated Procedures Table.

Damaged camshaft engine speed/position sensor?
YES NO

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the camshaft engine speed/position sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Check the resistance of the sensor.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin to the speed/position. Use a multimeter.
  • Measure the resistance of the camshaft engine speed/position sensor backup SIGNAL (+) pin to the speed/position sensor backup RETURN (-) at the sensor connector. Use a multimeter.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the camshaft engine speed/position sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin on the sensor to the engine block ground. Use a multimeter.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the engine harness. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check the camshaft engine speed/position sensor for a short between coils.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check the sensor for a short circuit between coils.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin of one coil to all other pins in the sensor connector. Use a multimeter.
  • Measure the resistance of the camshaft engine speed/position sensor RETURN (-) pin to all other pins at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the engine harness. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from the engine camshaft speed/position sensor.

Action

Check for an open circuit in the engine harness. Use a multimeter.

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the ECM connector to the crankshaft engine speed SIGNAL (+) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the ECM connector to the crankshaft engine speed RETURN (-) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the ECM left bank connector to the camshaft engine/position speed SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the ECM left bank connector to the camshaft engine speed/position RETURN (-) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the ECM right bank connector to the camshaft engine/position speed backup SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the ECM right bank connector to the camshaft engine speed/position backup RETURN(-) pin at the camshaft engine speed/position sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Check for a short circuit-to-ground in the engine harness. Use a multimeter.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin to the speed/position.
  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the ECM connector to the engine block ground.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left bank ECM module to the engine block ground.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right bank ECM module to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness. Inspect the engine harness for a short to ground.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Check for a short circuit-to-ground in the engine harness. Use a multimeter.

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left bank ECM connector to all other pins in the left bank ECM connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the left bank ECM connector to all other connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right bank ECM connector to all other pins in the right bank ECM connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the right bank ECM connector to all other pins in the right bank ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Replace or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration code and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-May-2015


FAULT CODE 1794 - Undesired Thermal Situation Detected - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine room/container and generator set for any thermal damage. |
 | STEP 1A. Check the engine room/container and generator set for any thermal damage. | Engine room/container or generator set thermal damage located?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Active fault codes present?
STEP 3. | Clear the local generator room/container fire detection/alarm system. |
 | STEP 3A. Verify the fire detection/alarm system is acknowledged. | Generator room/container fire detection/alarm system acknowledged?
 | STEP 3B. Reset the fire detection system. | Generator room/container fire detection/alarm system reset?
STEP 4. | Check ECM calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine room/container and generator set for any thermal damage.

Guided Step 1A - Check the engine room/container and generator set for any thermal damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

When authorized as safe to proceed, check the engine room/container and generator set for any thermal damage. If the thermal event was local to the generator set, check for the following:

  • Engine fuel system leakage
  • Engine intake system/charge air leakage
  • Engine exhaust system leakage
  • Engine heaters for possible short circuit
  • Batteries and battery charger for possible short circuit or overload
  • Engine lubricating oil leakage onto hot surfaces
  • Engine coolant leakage onto hot surfaces
  • Alternator - possible winding short circuits and contaminants on windings
  • Alternator heaters possible short circuit or contact with contaminants
  • Switch gear possible short circuit
  • All wiring for possible short circuits
  • Ventilation fan motors for possible short circuits
  • Generator set panels (AC panel, DC panel, or generator interface box) for possible short circuits
  • Local oil make-up tank system oil leakage onto hot surfaces.

Contact a local Cummins® Authorized Repair Location.

Engine room/container or generator set thermal damage located?
YES NO

Rectify any engine room/container or generator set source of the thermal event. Repair all resulting in damage. Use the appropriate repair procedures.

  • Contact a local Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Active fault codes present?
YES NO

Follow the appropriate troubleshooting steps for active fault codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Clear the local generator room/container fire detection/alarm system.

Guided Step 3A - Verify the fire detection/alarm system is acknowledged.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the engine room/container fire alarm detection system is acknowledged.

  • Acknowledge the fire alarm via the system panel. See the fire detection system manual.
  • Contact your local Cummins® Authorized Repair Location.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Generator room/container fire detection/alarm system acknowledged?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Reset the fire detection system.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Reset the engine room/container fire detection system.

  • Reset the fire detection system via the system panel. See the fire detection system manual.
  • Contact your local Cummins® Authorized Repair Location.

Generator room/container fire detection/alarm system reset?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 1799 - Engine Turbocharger Compressor Bypass Actuator Control Command - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3864 active?
 | STEP 1B. Check for an active fault code. | Fault Code 1799 active?
STEP 2. | Check the engine compressor bypass throttle. |
 | STEP 2A. Check the turbocharger compressor bypass valve for free movement. | Sticking or restriction or debris blocking the engine compressor bypass throttle?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine compressor bypass throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • De-energize keyswitch circuit.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3864 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • De-energize keyswitch circuit.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1799 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine compressor bypass throttle.

Guided Step 2A - Check for a restricted engine compressor bypass throttle.

Conditions

  • De-energize keyswitch circuit.

Action

Check for a restriction.

  • Inspect the engine intake throttle for a restriction or debris blocking the throttle plate.

Sticking or restriction or debris blocking the engine compressor bypass throttle?
YES NO

Remove the restriction or debris.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine compressor bypass throttle actuator motor and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine compressor bypass throttle actuator motor from the engine harness.

Action

Inspect the engine harness and the engine compressor bypass throttle actuator motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-May-2015


FAULT CODE 1811 - Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1839 active?
STEP 2. | Check the valve proving system (VPS) module. |
 | STEP 2A. Inspect the VPS module and gas valve harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the VPS module supply voltage. | Supply voltage 18 VDC to 27.6 VDC?
STEP 3. | Check the VPS module harness. |
 | STEP 3A. Check the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for an ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 1811 inactive and Fault Code 1812 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1811 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1839 active?
YES NO

Troubleshoot the fault fode using the appropriate troubleshooting chart.

  • Reference Fault Code 1839 (Gas Supply Pressure Sensor - Voltage Above Normal or Shorted to High Source) in Section TF.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the valve proving system module

Guided Step 2A - Inspect the VPS module and gas valve harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the VPS module.

Action

Inspect the VPS module and the harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the damaged pins.

Repair or replace the gas valve harness or replace the VPS module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the gas valve harness.
  • Replace the VPS module. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the VPS module supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the harness from the VPS module.
  • Place run/stop/auto switch in RUN mode, operate engine, and perform a normal shutdown.
  • Connect INSITE™ electronic service tool.

Action

Immediately following the engine shutdown, check the VPS module supply voltage:

  • Use a multimeter to connect the multimeter test leads to the VPS SUPPLY and RETURN pins in the gas valve harness connector and check the VPS module supply voltage. Contact a Cummins® Authorized Repair Location.

Supply voltage 18 VDC to 27.6 VDC?
YES NO
No Repair

Check the 24 VDC power supply connections and the fuses in the harness. Refer to the appropriate engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the VPS module harness.

Guided Step 3A - Inspect the VPS module and gas valve harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the VPS module and the ECM module.

Action

Inspect the engine harness and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the damaged pins.

Repair or replace the appropriate harness section or replace the VPS module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the gas valve harness,the extension harness, or the Generator Interface Box (GIB) harness as appropriate. Contact a Cummins® Authorized Repair Location.
  • Replace the VPS module. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the harness from the VPS module and ECM.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the VPS module SUPPLY pin in the connector to all other pins in the GIB harness.
  • Measure the resistance from the VPS module RETURN pin in the connector to all other pins in the GIB harness.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness or harness connector.

  • Repair the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the harness from the VPS module and ECM.

Action

Check for an open circuit.

  • Measure the resistance from the VPS SUPPLY pin in the VPS module connector to the VPS module SUPPLY pin in ECM connector.
  • Measure the resistance from the VPS RETURN pin in the VPS module connector to the VPS module RETURN pin in ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness or the harness connector.

  • Repair the appropriate wiring harness. Contact a Cummins® Authorized Repair Location. Repair the engine harness.

Go to 4A

Go to 5A

Guided Step 4 - Check for a ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the harness from the VPS module.
  • Place run/stop/auto switch in the RUN mode, engine running, and perform a normal engine shutdown.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response:

  • Fault Code 1811 will become inactive and Fault Code 1812 will become active.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 1811 inactive and Fault Code 1812 active?
YES NO
No Repair

Replace the ECM . Refer to 019-031 in the Associated Procedures Table.

  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 3B

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1811 is inactive.

Fault Code 1811 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 1812 - Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1841 active?
STEP 2. | Check the valve proving system module. |
 | STEP 2A. Inspect the valve proving system module and gas valve harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the valve proving system module supply voltage. | Supply voltage 18 VDC to 27.6 VDC?
STEP 3. | Check the valve proving system module harness. |
 | STEP 3A. Check the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1812 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1841 active?
YES NO

Troubleshoot the fault code using the appropriate troubleshooting chart.

  • See Fault Code 1839 (Gas Supply Pressure Sensor - Voltage Above Normal or Shorted to High Source) in Section TF.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the valve proving system module.

Guided Step 2A - Inspect the valve proving system module and gas valve harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the valve proving system module.

Action

Inspect the valve proving system module and the harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the damaged pins.

Repair or replace the gas valve harness or replace the valve proving system module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the gas valve harness.
  • Replace the valve proving system module. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve proving system module supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the harness from the valve proving system module.
  • Place run/stop/auto switch in RUN mode, operate engine, and perform a normal shutdown.
  • Connect INSITE™ electronic service tool.

Action

Immediately following the engine shutdown, check the valve proving system module supply voltage:

  • Use a multimeter to connect the multimeter test leads to the valve proving system SUPPLY and RETURN pins in the gas valve harness connector and check the valve proving system module supply voltage. Contact a Cummins® Authorized Repair Location.

Supply voltage 18 VDC to 27.6 VDC?
YES NO
No Repair

Check the 24 VDC power supply connections and the fuses in the harness. See the appropriate engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the valve proving system module harness.

Guided Step 3A - Inspect the valve proving system module and gas valve harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the valve proving system module and ECM.

Action

Inspect the engine harness and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the damaged pins.

Repair or replace the appropriate harness section or replace the valve proving system module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the gas valve harness, extension harness, or generator interface box harness as appropriate. Contact a Cummins® Authorized Repair Location.
  • Replace the valve proving system module. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the harness from the valve proving system module and ECM.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the valve proving system module SUPPLY pin in the connector to all other pins in the generator interface box harness.
  • Measure the resistance from the valve proving system module RETURN pin in the connector to all other pins in the generator interface box harness.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness or harness connector.

  • Repair the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the harness from the valve proving system module and ECM.

Action

Check for an open circuit.

  • Measure the resistance from the valve proving system SUPPLY pin in the valve proving system module connector to the valve proving system module SUPPLY pin in ECM connector.
  • Measure the resistance from the valve proving system RETURN pin in the valve proving system module connector to the valve proving system module RETURN pin in ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness or the harness connector.

  • Repair the appropriate wiring harness. Contact a Cummins® Authorized Repair Location. Repair the engine harness.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1812 is inactive.

Fault Code 1812 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 1813 - Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve (FSOV), NG | Refer to Procedure 005-044 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1841 active?
STEP 2. | Check the fuel double solenoid shutoff valve (DSSV). |
 | STEP 2A. Check the upstream and downstream shutoff valves. | Dirty or damaged shutoff valves?
STEP 3. | Check the valve proving system (VPS) module. |
 | STEP 3A. Check the VPS module seals. | Damaged VPS seals?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1813 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1841 active?
YES NO

Troubleshoot the fault code using the appropriate troubleshooting chart.

  • Reference Fault Code 1839 (Gas Supply Pressure Sensor - Voltage Above Normal or Shorted to High Source) in Section TF.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel DSSV.

Guided Step 2A - Check the upstream and downstream shutoff valves.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the fuel DSSV.

Action

Check the upstream and downstream shutoff valves.

  • Remove the fuel DSSV from the main fuel supply line. Refer to Procedure 005-044 in the Associated Procedures Table.
  • Check the condition of the upstream and downstream shutoff valves. Contact a Cummins® Authorized Repair Location.

Check the upstream and downstream gas valves for the following:

  • Damaged valves and valve seats
  • Moisture in or on the valves
  • Dirt or debris in or on the valves.

Dirty or damaged shutoff valves?
YES NO

Repair or replace the fuel DSSV.

  • Flush the dirt, debris, or moisture form the connector pins. Contact a Cummins® Authorized Repair Location.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the gas valve harness. Contact a Cummins® Authorized Repair Location.
  • Replace the fuel DSSV. Refer to Procedure 005-044 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the VPS module.

Guided Step 3A - Check the VPS module seals.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the VPS module.

Action

Inspect the VPS module seals for the following:

  • Damaged seals
  • Dirt or debris on the seals
  • Dirt or debris on the integral VPS filters
  • See equipment manufacturer service information.

Damaged VPS seals?
YES NO

Repair or replace the VPS module.

  • Flush the dirt or debris from the seals
  • Replace the damged seals
  • Replace the VPS module integral filters. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1813 is inactive.

Fault Code 1813 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 1814 - Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve (FSOV), NG | Refer to Procedure 005-044 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1814 active?
STEP 2. | Check the fuel double solenoid shutoff valve (DSSV). |
 | STEP 2A. Check the upstream and downstream shutoff valves. | Dirty or damaged shutoff valves?
STEP 3. | Check the valve proving system (VPS) module. |
 | STEP 3A. Check the VPS module seals. | Damaged VPS seals?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1814 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1814 active?
YES NO

Troubleshoot the fault code using the appropriate troubleshooting chart.

  • Reference Fault Code 1839 (Gas Supply Pressure Sensor - Voltage Above Normal or Shorted to High Source) in Section TF.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel DSSV.

Guided Step 2A - Check the upstream and downstream shutoff valves.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the fuel DSSV.

Action

Check the upstream and downstream shutoff valves.

  • Remove the fuel DSSV from the main fuel supply line. Refer to Procedure 005-044 in the Associated Procedures Table.
  • Check the condition of the upstream and downstream shutoff valves. Contact a Cummins® Authorized Repair Location.

Check the upstream and downstream gas valves for the following:

  • Damaged valves and valve seats
  • Moisture in or on the valves
  • Dirt or debris in or on the valves.

Dirty or damaged shutoff valves?
YES NO

Repair or replace the fuel DSSV.

  • Flush the dirt, debris, or moisture form the connector pins. Contact a Cummins® Authorized Repair Location.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the gas valve harness. Contact a Cummins® Authorized Repair Location.
  • Replace the fuel DSSV. Refer to Procedure 005-044 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the VPS module.

Guided Step 3A - Check the VPS module seals.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the VPS module.

Action

Remove the VPS module and inspect the module seals.

  • Remove the VPS. Refer to Procedure 005-230 in the Associated Procedures Table.

Inspect the VPS module seals for the following:

  • Damaged seals
  • Dirt or debris on the seals
  • Dirt or debris on the integral VPS filters.

Damaged VPS seals?
YES NO

Repair or replace the VPS module.

  • Flush the dirt or debris from the seals
  • Replace the damged seals
  • Replace the VPS module integral filters.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1814 is inactive.

Fault Code 1814 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-May-2015


FAULT CODE 1815 - Engine Oil Pre-heater Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1815 active?
STEP 2. | Check wiring harness and engine oil pre-heater control circuit. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1816 active and Fault Code 1815 inactive?
 | STEP 2C. Check the fault codes and verify condition. | Fault Code 1815 active?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the control module response. | Fault Code 1816 active and Fault Code 1815 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1815 inactive?
STEP 4. | Check control module calibration and clear fault codes. |
 | STEP 4A. Check if an control module calibration update is available. | If a calibration update for this fault code is available, does the control module contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1815 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check wiring harness and engine oil pre-heater control circuit.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the harness connector

Action

Inspect the wiring harness and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the harness connector.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate power system control module response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1816 active and Fault Code 1815 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify condition.

Conditions

  • Connect all components.
  • Power up the system.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1815 active?
YES NO

An internal short in the control module has been detected.

  • Replace the control module.

None: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the harness connector.
  • Disconnect the wiring harness from the control module.

Action

Inspect the power system low voltage wiring harness connector and power system control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the control module or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the control module response.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the harness connector.
  • Disconnect the wiring harness from the control module.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate power system control module response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1816 active and Fault Code 1815 inactive?
YES NO
No Repair

Replace the control module.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the harness connector.
  • Disconnect the wiring harness from the control module.

Action

Check for the appropriate power system control module response after 30 seconds.

  • Measure the resistance between the SIGNAL pin at the control module harness connector and all other pins in the control module connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the power system harness.

  • Repair or replace the power system harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Power up the system.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1815 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault code should have been detected .

Go to 4A

Go to 1A

Guided Step 4 - Check control module calibration and clear fault codes.

Guided Step 4A - Check if an control module calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the control module code and revision number in the control module to the calibration revisions listed in the control module Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present control module code and revision number in the control module . The control module code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the control module contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the control module. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 1816 - Engine Oil Pre-heater Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1816 active?
STEP 2. | Check wiring harness and connector. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1815 active and Fault Code 1816 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1816 active?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the control module response. | Fault Code 1815 active and Fault Code 1816 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1816 inactive?
STEP 4. | Check battery control module calibration and clear fault codes. |
 | STEP 4A. Check if control module calibration update is available. | If a calibration update for this fault code is available, does the control module contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1816 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check wiring harness and connector.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the connector or wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the connector.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the SUPPLY pin and the SIGNAL pin at the engine oil pre-heater control circuit connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1815 active and Fault Code 1816 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify signal circuit condition.

Conditions

  • Connect all components.
  • Power up the system.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1816 active?
YES NO

An internal short in the control module has been detected.

  • Replace the control module.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the connector.
  • Disconnect the wiring harness from the control module.

Action

Inspect wiring harness and control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the control module or wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the control module response.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect wiring harness from the control module.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the SUPPLY pin and the SIGNAL pin at the engine oil pre-heater control circuit connector of the engine harness.

Check for the appropriate control module response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1815 active and Fault Code 1816 inactive?
YES NO
No Repair

Replace the control module.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Power down the system.
  • Disconnect the wiring harness from the connector.
  • Disconnect wiring harness from the control module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the control SIGNAL pin at the control module harness connector and all other pins in the control module connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the power system harness.

Repair or replace the power system harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Power up the system.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1816 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check battery control module calibration and clear fault codes.

Guided Step 4A - Check if control module calibration update is available.

Conditions

  • Connect all components.
  • Power up the system.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Compare the control module code and revision number in the control module to the calibration revisions listed in the control module Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present control module code and revision number in the control module. The control module code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the control module contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the control module. Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Power up the system.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 1817 - Engine Oil Pre-heater Control Circuit Breaker Tripped - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 1817 active?
STEP 2. | Check the circuit breaker. |
 | STEP 2A. Inspect the circuit breaker connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit breaker for failures. | Switch closes?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness and the engine control module connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Clear the fault codes. | Fault Code 1817 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1817 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the circuit breaker.

Guided Step 2A - Inspect the circuit breaker connector pins.

Conditions

  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the OEM harness from the circuit breaker.

Action

Inspect the OEM harness and the circuit breaker connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set circuit breaker connector. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit breaker for failures.

Conditions

  • Place the run/stop/auto switch in STOP mode.

Action

Manually check to see if the switch can close.

Switch closes?
YES NO
No Repair

Replace the circuit breaker. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the OEM harness from the board terminal block.

Action

Inspect the OEM harness and the engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the base board.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the circuit breaker.

Action

Check for a short circuit from wire to wire.

  • Measure the resistance from the circuit breaker position wire on the OEM harness connector to all other wires on the OEM harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the circuit breaker.

Action

Check for an open circuit in the supply wire.

  • Measure the resistance from the circuit breaker SUPPLY pin on the OEM harness connector to the circuit breaker SUPPLY pin on the OEM harness controller connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the OEM harness.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in RUN mode and idle for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 1817 is inactive.

Fault Code 1817 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Place the run/stop/auto switch in AUTO position.
Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 1818 - Engine Oil Pre-heater Control Circuit - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1817 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1818 active?
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1818 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1817 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1818 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the engine control module (ECM).

Action

Inspect the OEM harness pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Flush the dirt, debris, or moisture from the connector pins. Repair or replace the OEM harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the OEM harness. Refer to Procedure 019-204 in Section 19.
  • Replace the OEM harness.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for an open circuit.

  • Measure the resistance from the OEM harness connector to the corresponding pin of the OEM switch connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the OEM harness.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit to ground.

  • Measure the resistance from the OEM harness connector, OEM side, to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the OEM harness.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the OEM switch.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the OEM harness connector, OEM side, to all other pins in the connector.

More than 100k ohms?
YES NO
No Repair

Replace the OEM harness.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 1818 is inactive.

Fault Code 1818 inactive?
YES NO
No Repair

The engine protection limit has been exceeded for the OEM supplied input. See equipment manufacturer service information.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 1821 - Engine Crankshaft Speed/Position Very Low Engine Speed Detected When Engine is Supposed to be Running - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | QSK60 G CM2358 K110 | 4383781
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 121, 234, 689, 1546, 1793 and/or 1837 active?
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged crankshaft engine speed sensor or engine harness connector pins?
 | STEP 2B. Inspect the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor resistance. | Resistance 750 to 1500 ohms?
 | STEP 2D. Check for a short circuit to ground in the crankshaft engine speed sensor. | Greater than 100k ohms?
STEP 3. | Check the camshaft engine speed/position sensor. |
 | STEP 3A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 3B. Inspect the sensor for damage. | Damaged camshaft engine speed/position sensor?
 | STEP 3C. Check the resistance of the sensor. | Less than 2k ohms?
 | STEP 3D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit between coils. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1821 inactive?
 | STEP 5B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 121, 234, 689, 1546, 1793 and/or 1837 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-360 in Section 19.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check for the crankshaft engine speed sensor

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the crankshaft engine speed sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair or replace the damaged engine harness connector or crankshaft engine speed sensor.

  • Repair or replace the damaged connector. Refer to Procedure 019-206 in Section 19.
  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the crankshaft engine speed sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from the crankshaft engine speed sensor connector.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged crankshaft engine speed sensor?
YES NO

The crankshaft engine speed sensor is damaged.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the crankshaft engine speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL(+) pin to the speed RETURN (-) pin at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 750 to 1500 ohms?
YES NO
No Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the crankshaft engine speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL(+) pin on the sensor to the engine ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The crankshaft engine speed sensor is damaged.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for the camshaft engine speed/position sensor

Guided Step 3A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from the control module.

Action

Inspect the camshaft engine speed/position sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged camshaft speed/position sensor or engine harness connector pins?
YES NO

Repair or replace the damaged engine harness connector or camshaft engine speed/position sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged engine harness or connector. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the camshaft engine speed/position sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.
  • Remove the camshaft engine speed/position sensor.

Action

Inspect the camshaft engine speed/position sensor for the following:

  • Metal debris on the end of the sensor.
  • Damage to the end of the sensor caused by contacting the flywheel.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of the sensor.
  • Refer to Procedure 019-038 in the Associated Procedures Table.

Damaged camshaft engine speed/position sensor?
YES NO

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the camshaft engine speed/position sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check the resistance of the sensor.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin to the speed/position RETURN (-) pin at the sensor connector.
  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor backup SIGNAL (+) pin to the speed/position sensor backup RETURN (-) at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the camshaft engine speed/position sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin on the sensor to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check the camshaft engine speed/position sensor for a short between coils.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check the sensor for short circuit between coils.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin of one coil to all other pins in the sensor connector.
  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor RETURN (-) pin to all other pins at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from the ECMs.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Clean the connector and pins.

  • Replace the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open-circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from the ECMs.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from the engine camshaft speed/position sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the ECM connector to the crankshaft engine speed SIGNAL (+) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the ECM connector to the crankshaft engine speed RETURN (-) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the ECM left-bank connector to the camshaft engine/position speed SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the ECM left-bank connector to the camshaft engine speed/position RETURN (-) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the ECM right-bank connector to the camshaft engine/position speed backup SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the ECM right-bank connector to the camshaft engine speed/position backup RETURN (-) pin at the camshaft engine speed/position sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from the ECMs.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the ECM connector to the engine block ground.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left-bank ECM module to the engine block ground.
  • Measure the resistance from camshaft engine speed/position backup SIGNAL (+) pin at the right-bank ECM module to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness. Inspect the engine harness for a short to ground.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from the ECMs.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left-bank ECM connector to all other pins in the left-bank ECM connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the left-bank ECM connector to all other pins in the right-bank ECM connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right-bank ECM connector to all other pins in the right-bank ECM connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the right-bank ECM connector to all other pins in the right-bank ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1821 is inactive.

Fault Code 1821 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-May-2015


FAULT CODE 1822 - Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1822 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 1822 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault code 1822 active?
YES NO

Reference troubleshooting trees t021-240 (Coolant Pressure Low - High Temperature Circuit) and t021-250 (Coolant Pressure Low - Low Temperature Circuit) in section TS in the Troubleshooting and Repair Manual, QSK60G CM700 Generator, Bulletin 4021396.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1822 is inactive.

Fault Code 1822 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 1823 - Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1823 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 1823 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1823 active?
YES NO

Reference troubleshooting trees t021-240 (Coolant Pressure Low - High Temperature Circuit) and t021-250 (Coolant Pressure Low - Low Temperature Circuit) in section TS in the Troubleshooting and Repair Manual, QSK60G CM700 Generator, Bulletin 4021396.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in RUN mode and operatre engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1823 is inactive.

Fault Code 1823 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 1824 - Engine Oil Temperature Sensor 1 Circuit, Too Cold for High Idle - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil System | Refer to Procedure 018-017 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 213, 2789, 2793, 2871, or 2872 active?
STEP 2. | Check the engine goes to rated speed. |
 | STEP 2A. Check the engine goes to rated speed. | Engine has speed increased to rated speed?
STEP 3. | Check the oil cooling system. |
 | STEP 3A. Check the oil temperature. | Engine oil temperature to specification?
STEP 4. | Check the engine oil temperature sensor 1. |
 | STEP 4A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the resistance of the oil temperature sensor. | 625 ohms to 36k ohms?
 | STEP 4C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check ECM calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 213, 2789, 2793, 2871, or 2872 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

 No Repair

5A

Go to 2A

Guided Step 2 - Check the engine goes to rated speed

Guided Step 2A - Check the engine goes to rated speed.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for more than 1 minute.

Action

Continue to run the engine at low idle (900 rpm).

  • Operate the engine and observe for oil temperature rise. The engine should go to rated speed within 30 minutes. Refer to Procedure 101-015 in Section 1 of the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782.

Engine has speed increased to rated speed?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the oil cooling system

Guided Step 3A - Check the oil temperature.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for more than 1 minute.

Action

Verify the engine oil temperature system operating temperature is to specification.

  • Via the generator set human machine interface, check the engine oil operating temperature is to specification. Refer to Procedure 018-017 in the Associated Procedures Table.

Engine oil temperature to specification?
YES NO
No Repair

Proceed to the next troubleshooting procedure.

Go to 5A

Go to 4A

Guided Step 4 - Check the engine oil temperature sensor 1.

Guided Step 4A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness connector from the oil temperature sensor and the ECM.
  • Disconnect any other sensors that share the same signal or return circuits.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the resistance of the oil temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the oil temperature sensor.
  • Disconnect any other sensors that share the same signal or return circuits.

Action

Check the resistance of the engine oil temperature sensor:

  • Measure the resistance between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin.
  • Refer to Procedure 018-017 in the Associated Procedures Table.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

Repair the engine oil temperature sensor.

Replace the oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the oil temperature sensor.
  • Disconnect any other sensors that share the same signal or return circuits.

Action

Check for a short circuit to ground:

  • Measure the resistance from each of the pins of the engine oil temperature sensor connector to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair the engine oil temperature sensor.

Replace the oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration code and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 1825 - Engine Waste Oil Reservoir Level - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the waste oil tank level. |
 | STEP 1A. Check the waste oil tank level. | Fluid level in waste oil tank sight glass at the level of the sensor?
STEP 2. | Check the waste oil tank level sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the engine control module (ECM) response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 2283 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify the waste oil tank level.

Guided Step 1A - Check the waste oil tank level.

Conditions

  • Place run/stop/auto switch in STOP position.

Action

Check the waste oil tank level.

  • Inspect the waste oil tank level by observing the fluid level in the sight glass located on the side of the waste oil tank.
  • Compare the location of the sensor with the fluid level in the sight glass.

Fluid level in waste oil tank sight glass at the level of the sensor?
YES NO

Drain the waste oil tank.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Check the waste oil tank level sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness connector from the waste oil tank level sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness or the waste oil tank level sensor, whichever has the damaged pins.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the waste oil tank level sensor. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness connector from the waste oil tank level sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the waste oil tank level sensor to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the waste oil tank level sensor. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness connector from the waste oil tank level sensor and the ECM.

Action

Inspect the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness connector from the waste oil tank level sensor.
  • Disconnect the harness connector from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the waste oil tank level sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the waste oil tank level sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness connector from the waste oil tank level sensor.
  • Disconnect the harness connector from the ECM.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires.

  • Measure the resistance from the waste oil tank level sensor SIGNAL pin in the harness connector to the engine block ground.
  • Measure the resistance from the waste oil tank level sensor RETURN pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness connector from the waste oil tank level sensor.
  • Disconnect the harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin in the waste oil tank level sensor connector to the sensor SIGNAL pin in the ECM.
  • Measure the resistance from the RETURN pin in the waste oil tank level sensor connector to the sensor RETURN pin in the ECM.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM response.

Guided Step 1A - Check for the appropriate ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness connector from the waste oil tank level sensor.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the waste oil tank level sensor SIGNAL pin and RETURN pin of the sensor connector.
  • Check for the appropriate ECM response after 30 seconds.
  • Use the electronic service tool to read the fault codes.

Note: Fault Code 2283 will become active upon disconnecting the sensor.

Fault Code 2283 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Facility.

Go to 5A

Go to
Repair complete.
Go to

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-May-2015


FAULT CODE 1826 - Incompatible Software Version Determined in Slave Controller - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for software compatibility |
 | STEP 1A. Check for software compatibility. | Fault Code 1826 active?
STEP 2. | Check ECM calibration code and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for software compatibility

Guided Step 1A - Check for software compatibility.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch on PowerCommand® Supervisor front panel in STOP mode.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the software version of each ECM.

Fault Code 1826 active?
YES NO

Use the electronic service tool to load compatible software into the ECM.

 No Repair

Repair complete.

Repair complete.

Guided Step 2 - Check ECM calibration code and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 1827 - Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1827 active?
STEP 2. | Check the fuel inlet pressure sensor and circuit. |
 | STEP 2A. Check the fuel inlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1828 active and Fault Code 1827 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Supply voltage 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1827 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1827 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel inlet pressure sensor and circuit.

Guided Step 2A - Check the fuel inlet pressure sensor and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the fuel inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, harness connector or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the fuel inlet pressure sensor from the engine harness.
  • Energize keyswitch circuit.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1828 active and Fault Code1827 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the fuel inlet pressure sensor from the engine harness. Install the pressure sensor breakout harness between the sensor and sensor harness connector.
  • Energize keyswitch circuit.

Action

Check the supply voltage and return circuit.

  • Measure the supply voltage between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor RETURN pin at the fuel inlet pressure sensor breakout harness test connectors.

Supply voltage 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • De-energize keyswitch circuit.
  • Connect the fuel inlet pressure sensor to the engine harness.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1827 active?
YES NO

A damaged sensor has been detected.

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the CM2358 left bank module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnesses and connectors in the circuit. See the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the fuel inlet pressure sensor from the engine harness.
  • Disconnect the engine harness from the left bank CM2358 module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the CM2358 connector to all other pins in the engine harness.
  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the CM2358 connector to all other pins in the engine harness.
  • Perform these checks on all interconnecting harnesses and connectors in the circuit.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 1828 - Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1828 active?
STEP 2. | Check the fuel inlet pressure sensor and circuit. |
 | STEP 2A. Check the fuel inlet pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Supply voltage 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | Signal voltage 0.50 to 4.50 VDC?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and connector pins. | Wiring harness and ECM connector pins OK?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 1828 inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohms?
STEP 5. | Check ECM calibration code and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP mode.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1828 active?
YES NO

See Fault Code 227 (Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source).

  • Use the following procedure for general inspection technques. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel inlet pressure sensor.

Guided Step 2A - Check the fuel inlet pressure sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the fuel inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, harness connector or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Energize keyswitch circuit.
  • Disconnect the fuel pressure sensor from the engine harness. Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the fuel inlet pressure supply voltage.

  • Measure the supply voltage with a mulitmeter between the breakout harness supply and return test connectors.

Supply voltage 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the fuel pressure sensor from the engine harness. Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal circuit.

  • Measure the signal voltage with a multimeter between the breakout harness signal and return test connectors.

Signal voltage 0.50 to 4.50 VDC?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness from the CM2358 left bank module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnesses and connectors in the circuit. See the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and ECM connector pins OK?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the fuel inlet pressure sensor from the engine harness.
  • Disconnect the engine harness from the left bank CM2358 module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the CM2358 connector to all other pins in the engine harness.
  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the CM2358 connector to all other pins in the engine harness.
  • Perform these checks on all interconnecting harnesses and connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal or supply circuit has been detected in the engine harness.

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the fuel inlet pressure sensor from the engine harness.
  • Disconnect the engine harness from the left bank CM2358 module.

Action

Check for an open circuit in the engine harness:

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the CM2358 connector to the fuel inlet pressure sensor SIGNAL pin in the engine harness fuel inlet pressure sensor connector.
  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the CM2358 connector to the fuel inlet pressure sensor SUPPLY pin in the engine harness fuel inlet pressure sensor connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the CM2358 connector to the fuel inlet pressure sensor RETURN pin in the engine harness fuel inlet pressure sensor connector.
  • Perform these checks on all interconnecting harnesses and connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the signal, supply, or return circuit has been detected in the engine harness.

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the fuel inletpressure sensor connector.
  • Connect INSITE™ elctronic service tool.

Action

Check for the appropriate CM2358 response:

  • Place a jumper wire between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 1827 will become active upon installing the jumper wire.

Fault Code 1828 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 signal pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the left-bank CM2358 module.

Action

Check the CM2358 SIGNAL pin resistance:

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin on the CM2358 to the CM2358 fuel inlet pressure sensor RETURN pin.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

Replace the left-bank CM2358 module.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 4B

Guided Step 5 - Check ECM calibration code and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 1833 - Engine Block/Coolant Pre-heater Control Breaker Tripped - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1B. Check the fault codes. | Fault Code 1833 active?
STEP 2. | Check the circuit breaker. |
 | STEP 2A. Inspect the circuit breaker connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for circuit breaker failures. | Switch closes?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness and the engine control module connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1833 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1833 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the circuit breaker.

Guided Step 2A - Inspect the circuit breaker connector pins.

Conditions

  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the OEM harness from the circuit breaker.

Action

Inspect the OEM harness and the circuit breaker connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set circuit breaker connector. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for circuit breaker failures.

Conditions

  • Place the run/stop/auto switch in STOP mode.

Action

Manually check to see if the switch can close.

Switch closes?
YES NO
No Repair

Replace circuit breaker. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the OEM harness from the board terminal block.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set circuit breaker connector. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the OEM harness from the engine control module.
  • Disconnect the OEM harness from the circuit breaker.

Action

Check for a short circuit from wire to wire.

  • Measure the resistance from the circuit breaker position wire on the OEM harness connector to all other wires on the OEM harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the OEM harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP mode.
  • Disconnect the OEM harness from the engine control module.
  • Disconnect the OEM harness from the circuit breaker.

Action

Check for an open circuit in the supply wire.

  • Measure the resistance from the circuit breaker supply pin on the OEM harness connector to the circuit breaker supply pin on the OEM harness controller connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-213 in Section 19.
  • Replace the OEM harness.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in RUN mode and idle for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1833 is inactive.

Fault Code 1833 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Place the run/stop/auto switch in AUTO position.
Repair complete.

Appropriate troubleshooting chart

Last Modified: 02-Jun-2015


FAULT CODE 1834 - Engine Coolant Circulating Pump Breaker Tripped - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Generator Set with PowerCommand™ Supervisor and Generator Set with PCC3300 |
 | STEP 1A. Read the PowerCommand™ Supervisor and PCC3300 fault code. | Fault code a PowerCommand™ Supervisor?
STEP 2. | Check the HT control valve trip sensing circuit. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit between ECM and circuit breaker. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit between circuit breaker and VDC Source. | Less than 10 ohms?
STEP 3. | Check the HT control valve supply circuit. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground between circuit breaker and contactor A. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground between circuit breaker and contactor B. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground between contactor A and HT control valve. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground between contactor B and HT control valve. | Greater than 100k ohms?
STEP 4. | Check for high resistance across contactors. |
 | STEP 4A. Check for high resistance across contactor A. | Less than 10 ohms?
 | STEP 4B. Check for high resistance across contactor B. | Less than 10 ohms?
STEP 5. | Check circuit breaker trip switch resistance. |
 | STEP 5A. Check for high resistance across circuit breaker trip switch with main switch closed. | Less than 10 ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 1834 inactive?
STEP 7. | Check the fault codes. |
 | STEP 7A. Check the ECM for active fault codes. | Fault Code 1834 active?
STEP 8. | Check the HT control valve trip sensing circuit. |
 | STEP 8A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 8B. Check for an open circuit between ECM and MCB9 trip circuit. | Less than 10 ohms?
 | STEP 8C. Check for an open circuit between MCB9 trip circuit and MCB8 trip circuit. | Less than 10 ohms?
STEP 9. | Check the HT control valve supply circuit. |
 | STEP 9A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 9B. Check for a short circuit to ground between MCB9 and contactor A. | Greater than 100k ohms?
 | STEP 9C. Check for a short circuit to ground between MCB9 and contactor B. | Greater than 100k ohms?
 | STEP 9D. Check for a short circuit to ground between contactor A and HT control valve. | Greater than 100k ohms?
 | STEP 9E. Check for a short circuit to ground between contactor B and HT control valve. | Greater than 100k ohms?
STEP 10. | Check for high resistance across contactors. |
 | STEP 10A. Check for high resistance across contactor A. | Less than 10 ohms?
 | STEP 10B. Check for high resistance across contactor B. | Less than 10 ohms?
STEP 11. | Check circuit breaker trip switch resistance. |
 | STEP 11A. Check for high resistance across MCB8 trip switch with main switch closed. | Less than 10 ohms?
 | STEP 11B. Check for high resistance across MCB9 trip switch with main switch closed. | Less than 10 ohms?
STEP 12. | Clear the fault codes. |
 | STEP 12A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 12B. Verify the fault code is inactive. | Fault Code 1834 inactive?

Guided Step 1 - Check the generator set with PowerCommand™ Supervisor and generator set with PCC3300.

Guided Step 1A - Read the PowerCommand™ Supervisor and PCC3300 fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code.

  • Verify whether fault code PowerCommand™ Supervisor or PCC3300 is active?

Is active fault code a PowerCommand™ Supervisor?
YES NO
No Repair

This is a PCC3300 fault code. Begin troubleshooting at Guided Step 7A.

Go to 2A

Go to 7A

Guided Step 2 - Check the HT control valve trip sensing circuit.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and ECM.

Action

Inspect the circuit breaker trip circuit and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the harness or the MCB, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the contact pins. Use electrical contact cleaner, Part Number 3824510.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for an open circuit between ECM and circuit breaker.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and ECM.

Action

Check for an open circuit.

  • Measure the harness' electrical resistance from the MCB6 trip circuit out to the ECM.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit between circuit breaker and VDC source.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip in and VDC source.

Action

Check for an open circuit.

  • Measure the MCB6 trip supply harness' electrical resistance between VDC source and MCB6 trip in.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 6A

Go to 3A

Guided Step 3 - Check the HT control valve supply

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the VAC isolator, MCB6 main, KM6A contactor, KM6B contactor and HT control valve.

Action

Inspect the harnesses and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the harness, MCB, KM, or HT control valve, or whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the contact pins. Use electrical contact cleaner, Part Number 3824510.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a short circuit to ground between circuit breaker and contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 main out and KM6A contactor in.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the MCB6 main circuit outlet to electrical ground.
  • Measure the harness' electrical resistance from the KM6A contactor circuit inlet to electrical ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground between circuit breaker and contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 main out and KM6B contactor in.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the MCB6 main circuit outlet to electrical ground.
  • Measure the harness' electrical resistance from the KM6B contactor circuit inlet to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground between contactor A and HT control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor out to HT control valve.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the KM6A contactor out to electrical ground.
  • Measure the harness' electrical resistance from the HT control valve to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to ground between contactor B and HT control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor out to HT control valve.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the KM6B contactor out to electrical ground.
  • Measure the harness' electrical resistance from the HT control valve to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 4A

Go to 6A

Guided Step 4 - Check for high resistance across contactors.

Guided Step 4A - Check for high resistance across contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor and driver in and out.

Action

Supply KM6A driver in with +24 VDC. Check resistance across KM6A contactor.

  • Measure KM6A contactor's electrical resistance from contactor in to out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the KM6A.

Go to 4B

Go to 6A

Guided Step 4B - Check for high resistance across contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the KM6B contactor and driver in and out.

Action

Supply KM6B driver in with +24VDC. Check resistance across KM6B contactor.

  • Measure KM6B contactor's electrical resistance from contactor in to out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the KM6B.

Go to 5A

Go to 6A

Guided Step 5 - Check circuit breaker trip switch resistance.

Guided Step 5A - Check for high resistance across circuit breaker trip switch with main switch closed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at MCB6 trip switch in and out and MCB6 main switch in and out.

Action

Close MCB6 main switch. Check resistance of MCB6 trip circuit.

  • Measure electrical resistance of MCB6 trip circuit in and out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace the MCB6.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Clear the inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch. Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to 6B

Appropriate troubleshooting steps

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1834 is inactive.

Fault Code 1834 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 7 - Check the fault codes.

Guided Step 7A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1834 active?
YES | NO
No Repair | No Repair

Go to 8A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 8 - Check the HT control valve trip sensing circuit.

Guided Step 8A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and ECM.

Action

Inspect the circuit breaker trip circuit and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the harness or the MCB, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the contact pins. Use electrical contact cleaner, Part Number 3824510.

 No Repair

Go to 12A

Go to 8B

Guided Step 8B - Check for an open circuit between ECM and MCB9 trip circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB9 trip out and ECM.

Action

Check for an open circuit.

  • Measure the harness' electrical resistance from the MCB9 trip circuit out to the ECM.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 8C

Go to 12A

Guided Step 8C - Check for an open circuit between MCB9 trip circuit and MCB8 trip circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB9 trip out and MCB8 trip in.

Action

Check for an open circuit.

  • Measure the harnesses' electrical resistance from the MCB9 trip circuit out to MCB8 trip circuit in.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 8D

Go to 12A

Guided Step 8D - Check for an open circuit between MCB8 trip circuit and battery regulator out return.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB8 trip out and battery regulator out return.

Action

Check for an open circuit.

  • Measure the MCB6 trip supply harness' electrical resistance between VDC source and MCB6 trip in.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 12A

Go to 9A

Guided Step 9 - Check the HT control valve supply

Guided Step 9A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the VAC isolators, MCB8 and MCB9 mains, KM6A contactor, KM6B contactor and HT control valve.

Action

Inspect the harnesses and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the harness, MCB, KM, or HT control valve of which ever has the damaged pins.

  • Flush the dirt, debris, or moisture from the contact pins. Use electrical contact cleaner, Part Number 3824510.

 No Repair

Go to 12A

Go to 9B

Guided Step 9B - Check for a short circuit to ground between MCB9 and contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB9 main out and KM6A contactor in.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the MCB9 main circuit outlet to electrical ground.
  • Measure the harness' electrical resistance from the KM6A contactor circuit inlet to electrical ground.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 9C

Go to 12A

Guided Step 9C - Check for a short circuit to ground between MCB9 and contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB9 main out and KM6B contactor in.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the MCB9 main circuit outlet to electrical ground.
  • Measure the harness' electrical resistance from the KM6B contactor circuit inlet to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 9D

Go to 12A

Guided Step 9D - Check for a short circuit to ground between contactor A and HT control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor out to HT control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM6A contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the HT control valve to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 9E

Go to 12A

Guided Step 9E - Check for a short circuit to ground between contactor B and HT control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor out to HT control valve.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the KM6B contactor out to electrical ground.
  • Measure the harness' electrical resistance from the HT control valve to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

Go to 10A

Go to 12A

Guided Step 10 - Check for high resistance across contactors.

Guided Step 10A - Check for high resistance across contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor and driver in and out.

Action

Supply KM6A driver in with +24 VDC. Check resistance across KM6A contactor.

  • Measure KM6A contactor's electrical resistance from contactor in to out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the KM6A.

Go to 10B

Go to 12A

Guided Step 10B - Check for high resistance across contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the KM6B contactor and driver in and out.

Action

Supply KM6B driver in with +24 VDC. Check resistance across KM6B contactor.

  • Measure KM6B contactor's electrical resistance from contactor in to out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the KM6B.

Go to 11A

Go to 12A

Guided Step 11 - Check circuit breaker trip switch resistance.

Guided Step 11A - Check for high resistance across MCB8 trip switch with MCB8 main switch closed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB8 trip switch in and out and MCB8 main switch in and out.

Action

Close MCB8 main switch. Check resistance of MCB8 trip circuit.

  • Measure electrical resistance of MCB6 trip circuit in and out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the MCB8.

Go to 11B

Go to 12A

Guided Step 11B - Check for high resistance across MCB9 trip switch with MCB9 main switch closed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB9 trip switch in and out and MCB9 main switch in and out.

Action

Close MCB9 main switch. Check resistance of MCB8 trip circuit.

  • Measure electrical resistance of MCB9 trip circuit in and out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace the MCB8.

Go to 12A

Go to 12A

Guided Step 12 - Clear the fault codes.

Guided Step 12A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Clear the inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch. Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Go to 12B

Appropriate troubleshooting steps

Guided Step 12B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1834 is inactive.

Fault Code 1834 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jul-2015


FAULT CODE 1835 - Engine Oil Priming Pump Control Breaker Tripped - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 1835 active?
STEP 2. | Check the circuit breaker. |
 | STEP 2A. Inspect the circuit breaker connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit breaker for malfunctions. | Visible malfunctions?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1835 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the circuit breaker.

Guided Step 2A - Inspect the circuit breaker connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM harness from the circuit breaker.

Action

Inspect the OEM harness and the circuit breaker connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19,Refer to Procedure 019-205 in Section 19, or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set circuit breaker connector. Reference the site documentation.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit breaker for malfunctions..

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Manually check to see if the switch can close.

Visible malfunctions?
YES NO

Replace circuit breaker. Reference site documentation.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the engine control module connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM harness from the board terminal block.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19, or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM harness from the engine control module.
  • Disconnect the OEM harness from the circuit breaker.

Action

Check for a short circuit from wire-to-wire.

  • Measure the resistance from the circuit breaker position wire on the OEM harness connector to all other wires on the OEM harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19,Refer to Procedure 019-205 in Section 19, or Refer to Procedure 019-213 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM harness from the engine control module.
  • Disconnect the OEM harness from the circuit breaker.

Action

Check for an open circuit in the SUPPLY wire.

  • Measure the resistance from the circuit breaker SUPPLY pin on the OEM harness connector to the circuit breaker SUPPLY pin on the OEM harness controller connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Repair the OEM harness. Refer to Procedure 019-203 in Section 19,Refer to Procedure 019-205 in Section 19, or Refer to Procedure 019-213 in Section 19.
  • Replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1836 - Engine Coolant Pressure 2 (LT) Low Temperature Sensor - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Active or inactive counts of Fault Code 1836?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1836?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jun-2015


FAULT CODE 1837 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1837 active?
STEP 2. | Check the camshaft engine speed/position sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 2B. Check the camshaft speed/position sensor for damage. | Damaged camshaft engine speed/position sensor?
 | STEP 2C. Check the camshaft engine speed/position sensor resistance. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to ground in the camshaft engine speed/position sensor. | Greater than 100k ohms?
 | STEP 2E. Check the camshaft engine speed/position sensor for a short circuit between coils. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the engine control module (ECM) connector pins. | Dirty or damaged pins or connectors?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in RUN mode.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal load conditions.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1837 active?
YES NO

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the camshaft engine speed/position sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.

Action

Inspect the engine harness and camshaft engine speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair or replace the damaged engine harness connector or camshaft engine speed/position sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness or connector. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the camshaft engine speed sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the camshaft engine speed/position sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.
  • Remove the camshaft engine speed/position sensor.

Action

Inspect the camshaft engine speed/position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Damaged camshaft engine speed/position sensor?
YES NO

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the camshaft engine speed/position sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Use a multimeter to check the resistance of the sensor.

  • Measure the resistance from the camshaft engine speed/position sensor SIGNAL positive (+) pin to the engine speed/position sensor RETURN negative (-) pin in the engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position sensor backup SIGNAL positive (+) pin to the engine speed/position sensor backup RETURN negative (-) pin in the engine speed/position sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the camshaft engine speed/position sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor

Action

Use a multimeter to check for a short circuit to ground.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin on the sensor to the engine block ground.

See the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurment techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the camshaft engine speed/position sensor for a short circuit between coils.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check the sensor for a short circuit between coils.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin of one coil to all other pins in the sensor connector.
  • Measure the resistance of the camshaft engine speed/position sensor RETURN (-) pin to all other pins at the sensor connector.

See the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the harness from both CM2358 modules.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Perform these checks on all interconnecting harness connectors in the circuit.

See the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connectors?
YES NO

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM2358 control modules.
  • Connect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the CM2358 left bank connector to the camshaft engine/position speed SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the CM2358 left bank connector to the camshaft engine speed/position RETURN (-) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the CM2358 right bank connector to the camshaft engine/position speed backup SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the CM2358 right bank connector to the camshaft engine speed/position backup RETURN (-) pin at the camshaft engine speed/position sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM2358 control modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the camshaft engine speed/position sensor SIGNAL (+) pin at the left bank CM2358 module to the engine block ground.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right bank CM2358 control module to the engine block ground.

See the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short to ground has been detected in the engine harness. Inspect the engine harness for a short to ground.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM2358 control modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left bank CM2358 connector to all other pins in the left bank CM2358 connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the left bank CM2358 connector to all other pins in the right bank CM2358 connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right bank CM2358 connector to all other pins in the right bank CM2358 connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the right bank CM2358 connector to all other pins in the right bank CM2358 connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 1838 - kW Electrical Load Signal - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Generator Set with PowerCommand® Supervisor and Generator Set with PCC3300. |
 | STEP 1A. Read the PowerCommand® Supervisor and PCC3300 fault codes. | Is active fault code a PowerCommand® Supervisor?
STEP 2. | Check the kilowatt accuracy. |
 | STEP 2A. Verify the kilowatt load demanded by the parallel controller is not above the generator set limits. | Kilowatt load command below set limits?
STEP 3. | Check the ECM value. |
 | STEP 3A. Verify that the fault simulation feature for the kW overload is not enabled. | Fault simulation disabled?
STEP 4. | Check the current transformers. |
 | STEP 4A. Inspect the current transformers and current transformer connections. | Current transformer connections correct?
 | STEP 4B. Check the AC harness. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 5. | Check the PT/CT board. |
 | STEP 5A. Check the PT/CT board 3 ohm resistors. | 3 ohm resistors good?
 | STEP 5B. Inspect the PT/CT board and the generator control harness connector pins. | Dirty of damaged pins?
STEP 6. | Check the generator control harness. |
 | STEP 6A. Inspect the generator control harness and the ECM connector pins. | Dirty of damaged pins?
 | STEP 6B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 6C. Check for an open circuit. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 7B. Verify the fault code is inactive. | Fault Code 1838 inactive?
STEP 8. | Check the fault codes. |
 | STEP 8A. Check the ECM for active fault codes. | Fault Code 1838 active?
STEP 9. | Check the kilowatt accuracy. |
 | STEP 9A. Verify the kilowatt load demanded by the parallel controller is not above the generator set limits. | Kilowatt load command below set limits?
STEP 10. | Check the ECM value. |
 | STEP 10A. Verify that the fault simulation feature for the kW overload is not enabled. | Fault simulation disabled?
STEP 11. | Check the current transformers. |
 | STEP 11A. Inspect the current transformers and current transformer connections. | Current transformer connections correct?
 | STEP 11B. Check the AC harness. | Dirty or damaged pins?
 | STEP 11C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 11D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 12. | Check the generator control harness. |
 | STEP 12A. Inspect the generator control harness and the ECM connector pins. | Dirty of damaged pins?
 | STEP 12B. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 12C. Check for an open circuit. | Less than 10 ohms?
 | STEP 12D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 13. | Clear the fault codes. |
 | STEP 13A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 13B. Verify the fault code is inactive. | Fault Code 1838 inactive?

Guided Step 1 - Check the Generator Set with PowerCommand® Supervisor and Generator Set with PCC3300.

Guided Step 1A - Read the PowerCommand® Supervisor and PCC3300 fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code.

Verify whether fault code PowerCommand® Supervisor or PCC3300 is active.

Is active fault code a PowerCommand® Supervisor?
YES NO
No Repair

This is a PCC3300 fault code. Begin troubleshooting at Guided Step 8A.

Go to 1A

Go to 8A

Guided Step 2 - Check the kilowatt accuracy.

Guided Step 2A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Kilowatt load command not above set limits?

YES NO
No Repair

  • Refer to customer/facility/installation documentation.

Go to 3A

Go to 7A

Guided Step 3 - Check the ECM value.

Guided Step 3A - Verify that the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify that the fault simulation feature for the kilowatt overload is not enabled.

Fault simulation disabled?
YES NO
No Repair

  • kW overload is enabled. Refer to customer/facility/installation documentation.

Go to 4A

Go to 7A

Guided Step 4 - Check the current transformers.

Guided Step 4A - Inspect the current transformers and current transformer connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

 No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the AC harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the AC harness and/or PT/CT board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.
  • Replace the PT/CT Board.

No Repair

Go to 7A

Go to 4C

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT board connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

Go to 5A

Go to 7A

Guided Step 5 - Check the PT/CT board.

Guided Step 5A - Check the PT/CT board 3 ohm resistors.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.

Action

Verify the 3-ohm resistors from PT/CT board connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Are the 3 ohm resistors good?
YES NO
No Repair

Replace the PT/CT board.

  • Replace the PT/CT Board.

Go to 5B

Go to 7A

Guided Step 5B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the generator control harness and the CM700 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the generator control, ECM and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set parallel board.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the generator control harness.

Guided Step 6A - Inspect the generator control harness and the ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the generator control harness from the ECM.

Action

Inspect the generator control harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the generator control, PT/CT board and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set or parallel board. See wiring diagram for appropriate board.

No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness ECM connector to engine block ground.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control, PT/CT board and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the PT/CT board. See wiring diagram for appropriate board.

Go to 6C

Go to 7A

Guided Step 6C - Check for an open circuit in the generator control harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness PT/CT board connector to the aligned generator control harness ECM connector pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.

Go to 6D

Go to 7A

Guided Step 6D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each pin on the generator control harness ECM connector to all other pins on the generator control harness ECM connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining active fault codes.

Go to 7B

Appropriate troubleshooting steps

Guided Step 7B - Verify the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1838 is inactive.

Fault Code 1838 inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 8 - Check the fault codes.

Guided Step 8A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1838 active?
YES | NO
No Repair | No Repair

Go to 9A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 9 - Check the kilowatt accuracy.

Guided Step 9A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Kilowatt load command not above set limits?

YES NO
No Repair

  • Refer to customer/facility/installation documentation.

Go to 10A

Go to 13A

Guided Step 10 - Check the ECM value.

Guided Step 10A - Verify that the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify that the fault simulation feature for the kilowatt overload is not enabled.

Fault simulation disabled?
YES NO
No Repair

  • kW overload simulation is enabled. Reference the customer/facility/installation documentation to disable fault simulation.

Go to 11A

Go to 13A

Guided Step 11 - Check the current transformers.

Guided Step 11A - Inspect the current transformers and current transformer connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

No Repair

Go to 13A

Go to 11B

Guided Step 11B - Check the AC harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the AC harness from the PT/CT Board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the AC harness and/or PT/CT board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.
  • Replace the PT/CT Board.

No Repair

Go to 13A

Go to 11C

Guided Step 11C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness generator control connector toengine block ground.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

Go to 11D

Go to 13A

Guided Step 11D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

Go to 12A

Go to 13A

Guided Step 12 - Check the generator control harness.

Guided Step 12A - Inspect the generator control harness and the ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the generator control harness from the ECM.

Action

Inspect the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set control board.

No Repair

Go to 13A

Go to 12B

Guided Step 12B - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness ECM connector to engine block ground.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.

Go to 6C

Go to 13A

Guided Step 12C - Check for an open circuit in the generator control harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness generator control connector to the aligned ECM connector pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.

Go to 12D

Go to 13A

Guided Step 12D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from each of the pins on the generator control harness generator control connector to all other ECM connector pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.

Go to 13A

Go to 13A

Guided Step 13 - Clear the fault codes.

Guided Step 13A - Clear the inactive fault codes.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining active fault codes.

Go to 13B

Appropriate troubleshooting steps

Guided Step 13B - Verify the fault code is inactive.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1838 is inactive.

Fault Code 1838 inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1839 - Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1839 active?
STEP 2. | Check the fuel supply pressure sensor and circuit. |
 | STEP 2A. Check the fuel supply pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1841 active and Fault Code 1839 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Supply voltage 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1839 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and harness connector pins. | Wiring harness and ECM connector pins OK?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1839 active?
YES NO

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel supply pressure sensor and circuit.

Guided Step 2A - Check the fuel supply pressure sensor and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor.

Action

Inspect the gas valve harness and fuelsupply pressure sensor connector pinsfor the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the gas valve harness, the harness connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the gas valve wiring harness. Contact your local Cummins® Authorized Repair Location.
  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor.
  • Energize keyswitch circuit.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1841 active and Fault Code 1839 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor and install the pressure sensor breakout harness between the sensor and sensor harness connector.
  • Energize keyswitch circuit.

Action

Check the supply voltage and return circuit.

  • Measure the supply voltage between the fuel supply pressure sensor SUPPLY pin and the fuel supply pressure sensor RETURN pin at the fuel supply pressure sensor breakout harness test connectors.

Supply voltage 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Place run/stop/auto switch in the STOP mode.
  • De-energize keyswitch circuit.
  • Connect the harness to the fuel pressure sensor.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1839 active?
YES NO

A damaged sensor has been detected.

Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the harness from the ECM connectors.

Action

Inspect the Generator Interface Box (GIB) harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnesses and connectors in the circuit. Refer to the wiring diagram to identify connectorsand pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and ECM connector pins OK?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the appropriate harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the Generator Interface Box (GIB) wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the harness and gas valve from the fuel supply pressure sensor.
  • Disconnect the harness from the ECM connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel supply pressure sensor SIGNAL pin in the ECM connector to all other pins in the engine harness.
  • Measure the resistance from the fuel supply pressure sensor SUPPLY pin in the ECM connector to all other pins in the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the appropriate harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the Generator Interface Box (GIB) wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the extension harness. Contact a Cummins® Authorized Repair Location.
  • Replace the harness and gas valve. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 4B

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 1841 - Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1841 active?
STEP 2. | Check the fuel supply pressure sensor. |
 | STEP 2A. Check the fuel supply pressure sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Fuel supply sensor supply voltage 4.75 and 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | Supply voltage 0.50 and 4.50-VDC?
STEP 3. | Check the Generator Interface Box (GIB)/ECM wiring harness. |
 | STEP 3A. Inspect the GIB/ECM wiring harness and connector pins. | Wiring harness and ECM connector pins OK?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 1841 inactive?
 | STEP 4B. Check the ECM SIGNAL pin resistance. | Less than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1841 active?
YES NO

Reference the Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source troubleshooting steps.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel supply pressure sensor.

Guided Step 2A - Check the fuel supply pressure sensor and harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor.

Action

Inspect the harness and fuel supply pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the gas valve harness, the harness connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the gas valve wiring harness. Contact your local Cummins® Authorized Repair Location.
  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor and install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Energize keyswitch circuit.

Action

Check for the fuel supply pressure sensor supply voltage.

  • Measure the supply voltage by measuring between the breakout harness supply and return test connectors with a multimeter.

Fuel supply pressure sensor supply voltage 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor and install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Energize keyswitch circuit.

Action

Check for the fuel supply pressure sensor signal voltage.

  • Measure the supply voltage by measuring between the breakout harness supply and return test connectors with a multimeter.

Signal voltage 0.50 to 4.50-VDC?
YES NO
No Repair

Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 5A

Guided Step 3 - Check the generator interface box (GIB)/ECM wiring harness.

Guided Step 3A - Inspect the GIB/ECM wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the harness from the ECM connectors.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnesses and connectors in the circuit. Refer to the wiring diagram to identify connectorsand pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and ECM connector pins OK?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the appropriate harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the Generator Interface Box (GIB) wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the harness and gas valve from the fuel supply pressure sensor.
  • Disconnect the harness from the ECM connectors.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel supply pressure sensor SIGNAL pin in the ECM connector to all other pins in the engine harness.
  • Measure the resistance from the fuel supply pressure sensor SUPPLY pin in the ECM connector to all other pins in the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal, supply, or return circuit has been detected in the harness.

Repair or replace the appropriate harness or the harness connector.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the harness and gas valve from the fuel supply pressure sensor.
  • Disconnect the harness from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance from the fuel supply pressure sensor SIGNAL pin in the ECM connector to the fuel supply pressure sensor SIGNAL pin in the gas valve harness fuel supply pressure sensor connector.
  • Measure the resistance from the fuel supply pressure sensor SUPPLY pin in the ECM connector to the fuel supply pressure sensor SUPPLY pin in the gas valve harness fuel supply pressure sensor connector.
  • Measure the resistance from the fuel supply pressure sensor RETURN pin in the ECM connector to the fuel supply pressure sensor RETURN pin in the gas valve harness fuel supply pressure sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the signal, supply, or return circuit has been detected in the harness.

Repair or replace the appropriate harness or the harness connector.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the fuel supply pressure sensor connector.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the fuel supply pressure sensor SUPPLY pin and the fuel supply pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1839 will become active upon installing the jumper wire.

Fault Code 1841 inactive?
YES NO
No Repair

A pin-to-pin short circuit on the signal, supply, or return circuit has been detected in the harness.

Repair or replace the appropriate harness or the harness connector.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the harness from the ECM.

Action

Check the ECM SIGNAL pin resistance.

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin on the ECM to the ECM fuel inlet pressure sensor RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Replace the left bank ECM.

  • Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 or 227 active?
STEP 2. | Check the crankcase pressure sensor and circuit |
 | STEP 2A. Check the crankcase blowby pressure sensor. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Greater than 10 ohms?
STEP 4. | Check for ECM response. |
 | STEP 4A.. Check for the appropriate ECM response. | Fault Code 1843 inactive?
 | STEP 4B. Check the ECM SIGNAL pin resistance. | Greater than 100k ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for J1939 data link Fault Codes 187 and 227.

Fault Codes 187 or 227 active?
YES | NO
No Repair | No Repair

Sensor Supply Fault Code 187 or 227

Go to 2A

Guided Step 2 - Check the crankcase blowby pressure sensor and circuit.

Guided Step 2A - Check the crankcase blowby pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Pace run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankcase blowby pressure sensor.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or replace the crankcase blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase blowby pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's SUPPLY and RETURN connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase blowby pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's supply and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankcase blowby pressure sensor and the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energized keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the crankcase blowby pressure sensor.

Action

Check for a short from pin-to-pin.

  • Measure the resistance from the crankcase blowby pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the crankcase blowby pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from thecrankcase blowby pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from the crankcase blowby pressure RETURN pin on the engine harness connector to the crankcase blowby pressure RETURN pin on the engine harness sensor rconnector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Greater than 10 ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 4 - Check for a ECM response.

Guided Step 4A - Check for an appropriate ECM response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the crankcase blowby pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response.

  • Use INSITE™ electronic service tool to verify that fault codes.

Fault Code 1844 will become active upon disconnecting the sensor.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Blowby Pressure Sensor | Refer to Procedure 019-011 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 or 227 active?
STEP 2. | Check the crankcase blowby pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor s voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for ECM response. |
 | STEP 4A.. Check for the appropriate ECM response. | Fault Code 1844 inactive?
 | STEP 4B. Check the ECM SIGNAL pin resistance. | Less than 100K ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for J1939 data link Fault Codes 187 and 227.

Fault Codes 187 or 227 active?
YES | NO
No Repair | No Repair

Sensor Supply Fault Code 187 or 227

Go to 2A

Guided Step 2 - Check the crankcase blowby pressure sensor.

Guided Step 2A - Check the crankcase blowby pressure sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankcase blowby pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or replace the crankcase blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase blowby pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase blowby pressure sensor SIGNAL voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankcase blowby pressure sensor and the ECM module.

Action

Inspect the engine harness and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the crankcase blowby pressure sensor.

Action

Check for a short from pin-to-pin.

  • Measure the resistance from the crankcase blowby pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the crankcase blowby pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the crankcase blowby pressure sensor SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the crankcase blowby pressure sensor RETURN pin on the engine harness connector to the crankcase blowby pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the crankcase blowby pressure sensor SIGNAL pin on the engine harnessconnector to the crankcase blowby pressure sensor SIGNAL pin on theengine harness sensor connector.
  • Measure the resistance from the crankcase blowby pressure sensor SUPPLY pin on the engine harnessconnector to the crankcase blowby pressure sensor SUPPLY pin on theengine harness sensor connector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for ECM response.

Guided Step 4A - Check for an appropriate ECM response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the crankcase blowby pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response.

  • Place a jumper wire between the crankcase blowby pressure sensor SUPPLY pin and the crankcase blowby pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 will become active upon installing the jumper.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the ECM module.

Action

Check the ECM SIGNAL pin resistance.

  • Measure the resistance from the crankcase blowby pressure SIGNAL pin on the ECM to the ECM sensor RETURN pin.

Greater than 100k ohms?
YES NO
No Repair

Contact the a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2111 - Coolant Temperature 2 (LT) Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Other fault codes active?
STEP 2. | Check the engine coolant temperature sensor (low temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 2111 inactive?
STEP 5. | Check ECM calibration code and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto in STOP mode.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the engine specific wiring diagram to verify no fault codes are active for any sensor sharing a common electrical ground/return with the engine coolant temperature sensor (low temperature).

Other fault codes active?
YES | NO
No Repair | No Repair

See the appropriate fault code.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor (low temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor (low temperature).

Action

Inspect the harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO
No Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine coolant temperature sensor (low temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2B

5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check the resistance of the engine coolant temperature sensor (low temperature).

  • Measure the resistance between the engine coolant temperature sensor SIGNAL (low temperature) pin and the engine coolant temperature sensor RETURN (low temperature) pin.

600 ohms to 36k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (low temperature) connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature) and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor RETURN (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor SIGNAL (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit to ground in the signal and return wires.

  • Measure the resistance from the engine coolant temperature sensor SIGNAL (low temperature) pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine coolant temperature sensor RETURN (low temperature) pin on the engine harness connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor (low temperature).
  • Disconnect the engine harness from the CM2358.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine coolant temperature sensor (low temperature)) connector to the sensor SIGNAL pin on the CM2358.
  • Measure the resistance from the RETURN pin on the engine coolant temperature sensor (low temperature) connector to the return SIGNAL pin on the CM2358.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).
  • Connect the electronic service tool.

Action

Check for appropriate CM2358 response.

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL (low temperature) pin and the engine coolant temperature sensor RETURN (low temperature) pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 2112 will become active upon installing the jumper.

Fault Code 2111 inactive?
YES NO
No Repair

Contact the nearest authorized repair location.

Go to 5A

Repair complete.

Guided Step 5 - Check ECM calibration code and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 2112 - Coolant Temperature 2 (LT) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Other fault codes active?
STEP 2. | Check the engine coolant temperature sensor (low temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 2112 inactive?
STEP 5. | Check ECM calibration code and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical ground/return with the engine coolant temperature sensor (low temperature).

Other fault codes active?
YES | NO
No Repair | No Repair

See the appropriate fault code.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor (low temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor (low temperature).

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broke pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair or replace the engine harness or the engine coolant temperature sensor (low temperature) , whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check the resistance of the engine coolant temperature sensor (low temperature).

  • Measure the resistance between the engine coolant temperature sensor SIGNAL (low temperature) pin and the engine coolant temperature sensor RETURN (low temperature) pin.

600 ohms to 36k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (low temperature) connector to the engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature) and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM2358.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine coolant temperature RETURN (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature SIGNAL (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).
  • Disconnect the engine harness from the CM2358.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the engine coolant temperature SIGNAL (low temperature) pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine coolant temperature RETURN (low temperature) pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor (low temperature).
  • Disconnect the engine harness from the CM2358.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine coolant temperature sensor (low temperature) connector to the sensor SIGNAL pin on the CM2358.
  • Measure the resistance from the RETURN pin on the engine coolant temperature sensor (low temperature) connector to the RETURN pin on the CM2358.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM2358 response.

Guided Step 4A - Check for the appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2111 will become active upon disconnecting the sensor.

Fault Code 2112 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact the nearest authorized repair location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration code and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 2113 - Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2111 or 2112 active?
STEP 2. | Check ECM calibration code and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Enerigze keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate for greater than 1 minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2111 or 2112 active?
YES NO
No Repair

See Coolant Temperature Above Normal - Low Temperature Circuit troubleshooting symptom tree in Section TS.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration code and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-May-2015


FAULT CODE 2114 - Coolant Temperature 2 (LT) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the engine control module (ECM) for active fault codes. | Fault Codes 2111 and 2112 active?
STEP 2. | Check ECM calibration code and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for more than 1 minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2111 and 2112 active?
YES NO
No Repair

See Coolant Temperature Above Normal - Low Temperature Circuit troubleshooting symptom tree in Section TS.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration code and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-May-2015


FAULT CODE 2115 - Engine Coolant Pressure 2 (LT) Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 386 active?
STEP 2. | Check the engine coolant pressure sensor (low temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 2115 inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohm.
STEP 5. | Check ECM calibration code and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify no fault codes are active for any sensor sharing a common electrical supply with the engine coolant pressure sensor (low temperature).

Fault Code 386 active?
YES | NO
No Repair | No Repair

See the Sensor Supply Fault Code 386.

Go to 2A

Guided Step 2 - Check the engine coolant pressure sensor (low temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant pressure sensor (low temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair or replace the engine harness or the engine coolant pressure sensor (low temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant pressure sensor (low temperature). Refer to Procedure 019-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the engine coolant pressure sensor (low temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the engine coolant pressure sensor (low temperature) breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the engine coolant pressure sensor (low temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Replace the engine coolant pressure sensor (low temperature). Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto in STOP mode.
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature) and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine coolant pressure sensor (low temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure SUPPLY (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure RETURN (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure SIGNAL (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if equipped.
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine coolant pressure RETURN (low temperature) pin on the engine harness connector to the engine coolant pressure RETURN (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure SIGNAL (low temperature) pin on the engine harness connector to the engine coolant pressure SIGNAL (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure SUPPLY (low temperature) pin on the engine harness connector to the engine coolant pressure SUPPLY (low temperature) pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM23580 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine coolant pressure sensor (low temperature) connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2116 will become active upon disconnecting the sensor.

Fault Code 2115 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the 50 pin A Deutsch™ connector from the CM2358.
  • Disconnect the 50 pin B Deutsch™ connector from the CM2358.
  • Disconnect the 50 pin C Deutsch™ connector from the CM2358.

Action

Check the CM2358 SIGNAL pin resistance.

  • Measure the resistance from the engine coolant pressure SIGNAL (low temperature) pin on the CM2358 to the CM2358 sensor supply circuit number 1 pin.

Less than 100k ohms?
YES NO
No Repair

Contact the nearest Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration code and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2116 - Engine Coolant Pressure 2 (LT) Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 352 active?
STEP 2. | Check the engine coolant pressure sensor (low temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 2116 inactive?
 | STEP 4B. Check the CM2358 signal pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2116 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine coolant pressure sensor (low temperature).

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference the sensor supply Fault Code 352.

Go to 2A

Guided Step 2 - Check the engine coolant pressure sensor (low temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connector from the engine coolant pressure sensor (low temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the engine coolant pressure sensor (low temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..
  • Replace the engine coolant pressure sensor (low temperature). Refer to Procedure 019-016 in the Associated Procedures Table..

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the engine coolant pressure sensor (low temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Install the engine coolant pressure sensor (low temperature) breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the engine coolant pressure sensor (low temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Replace the engine coolant pressure sensor (low temperature).

Refer to Procedure 019-016 in the Associated Procedures Table..

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature) and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine coolant pressure sensor (low temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure sensor (low temperature) SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure sensor (low temperature) RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure sensor (low temperature) SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine coolant pressure sensor RETURN (low temperature) pin on the engine harness connector to the engine coolant pressure sensor RETURN (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure sensor SIGNAL (low temperature) pin on the engine harness connector to the engine coolant pressure sensor SIGNAL (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure sensor SUPPLY (low temperature) pin on the engine harness connector to the engine coolant pressure sensor SUPPLY (low temperature) pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine coolant pressure sensor (low temperature) connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Place a jumper wire between the engine coolant pressure sensor RETURN (low temperature) SUPPLY pin and the engine coolant pressure sensor RETURN (low temperature) SIGNAL pin of the sensor connector.
  • Check for the appropriate CM2358 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

Note: Fault Code 2115 will become active upon installing the jumper.

Fault Code 2116 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 signal pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Disconnect the 50-pin A Deutsch connector from the CM2358.
  • Disconnect the 50-pin B Deutsch connector from the CM2358.
  • Disconnect the 50-pin C Deutsch connector from the CM2358.

Action

Check the CM2358 signal pin resistance.

  • Measure the resistance from the engine coolant pressure sensor SIGNAL (low temperature) pin on the CM2358 to the CM2358 sensor supply circuit number 1 RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and running for greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2116 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 15-Jun-2015


FAULT CODE 2117 - Engine Coolant Pressure 2 (LT) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2115 or 2116 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 2117 inactive?
 | STEP 2B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2115 or 2116 active?
YES NO
No Repair

Reference the Coolant Pressure (Low Temperature) Below Normal troubleshooting symptom tree in the QSV91-G6 CM2358 V101 Series Engine, Bulletin 4332687.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location.

Repair complete.

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect all components
  • Connect the electronic service tool.
  • Energize keyswitch circuit.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 2121 - Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2837, 2484, or 641 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault Code 2121 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2837, 2484, or 641 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE® electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2122 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2838, 2485, or 642 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault Code 2122 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2838, 2485, or 642 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2122 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2123 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2839, 2486, or 643 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2123 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2839, 2486, or 643 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2123 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2124 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2841, 2487, or 644 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2124 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2841, 2487, or 644 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2124 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2125 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2842, 2488, or 645 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2125 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2842, 2488, or 654 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2125 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2126 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2843, 2489, or 646 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2126 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2843, 2489, or 646 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2126 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2127 - Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2844, 2491, or 647 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2127 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2844, 2491, or 647 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2127 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2128 - Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2845, 2492, or 648 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2128 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2845, 2492, or 648 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2128 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2131 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2847, 2494, or 652 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2131 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2847, 2494, or 652 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2131 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2132 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2848, 2495, or 653 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2132 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2848, 2495, or 653 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2132 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2133 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2849, 2496, or 654 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2133 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2849, 2496, or 654 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2133 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2134 - Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2851, 2497, or 655 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2134 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2851, 2497, or 655 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2134 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2135 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2852, 2498, or 656 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2135 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2852, 2498, or 656 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2135 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2136 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2853, 2499, or 657 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2136 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2853, 2499, or 657 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2136 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2137 - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2854, 2511, or 658 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2137 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2854, 2511, or 658 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2137 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2138 - Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2855, 2512, or 2144 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Verify the fault code is inactive. | Fault code 2138 inactive?
 | STEP 2C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2855, 2512, or 2144 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear full codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibraton revisions listed in the ECM Calibraton Revision History for applicable changes related to the fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revison number in the ECM. The ECM code and revison number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize the keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2138 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2C

Go to 1A

Guided Step 2C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2144 - Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2855 or 2512 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2855 or 2512 active?
YES NO
No Repair

Reference the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) fault code troubleshooting trees in Section TF.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-May-2013


FAULT CODE 2154 - Post-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824776 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor (post-filter). |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check for CM2358 module response. |
 | STEP 3A. Check for the appropriate CM2358 module response. | Fault Code 2154 is inactive?
 | STEP 3B. Check the CM2358 module SIGNAL pin resistance. | Less than 100k ohm?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify that fault code is inactive. | Fault Code 2154 is inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor (post-filter).

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil pressure sensor (post-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine oil pressure sensor/switch. Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the engine oil pressure sensor crcuit (post-filter) breakout cable between the sensor and the sensor harness connector.
  • Connect electronic service tool.

Action

Check the engine oil pressure sensor circuit (post-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the harness connector.
  • Connect electronic service tool.

Action

Check the engine oil pressure sensor circuit (post-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

0.46 to 4.56-VDC?
YES NO
No Repair

Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil pressure sensor circuit (post-filter) and the CM2358 module.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the engine oil pressure sensor circuit (post-filter).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine oil pressure sensor circuit (post-filter).

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the engine oil pressure sensor circuit (post-filter).

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) RETURN pin on the engine harness connector to the engine oil pressure sensor circuit (post-filter) RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) SIGNAL pin on the engine harness connector to the engine oil pressure sensor circuit (post-filter) SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) SUPPLY pin on the engine harness connector to the engine oil pressure sensor circuit (post-filter) SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 4A

Go to 5A

Guided Step 3 - Check for a CM2358 module response.

Guided Step 3A - Check for an appropriate CM2358 module response.

Conditions

  • Keyswitch circuit energized.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine oil pressure sensor Circuit (post-filter) connector.

Action

Check for the appropriate CM2358 module response.

  • Use electronic service tool, verify the fault codes.

Note: Fault Code 2155 will become active upon disconnection of the sensor.

Fault Code 2154 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 3B - Check the CM2358 module SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connectors from the CM2358 module.

Action

Check the CM2358 module SIGNAL pin resistance.

  • Measure the resistance from the oil pressure SIGNAL pin on the CM2358 module to CM2358 module sensor supply circuit RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2154 is inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2155 - Post-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383871
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 G CM2358 K110 | 4383871

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor (post-filter). |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check for a ECM response. |
 | STEP 3A. Check for the appropriate ECM response. | Fault Code 2155 is inactive?
 | STEP 3B. Check the CENSE™ module signal pin resistance. | Less than 100k ohm?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine oil pressure sensor (post-filter).

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil pressure sensor (post-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (post-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (post-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil pressure sensor (post-filter) and the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine oil pressure sensor (post-filter).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor (post-filter).

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the engine oil pressure sensor (post-filter) SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (post-filter) RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (post-filter) SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine oil pressure sensor (post-filter).

Action

Check for an open circuit in the RETURN wire.

  • Measure the resistance from the engine oil pressure sensor (post-filter) RETURN pin on the engine harness connector to the engine oil pressure sensor (post-filter) RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (post-filter) SIGNAL pin on the engine harness connector to the engine oil pressure sensor (post-filter) SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (post-filter) SUPPLY pin on the engine harness connector to the engine oil pressure sensor (post-filter) SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techiques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 3 - Check the ECM response.

Guided Step 3A - Check for an appropriate ECM response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine oil pressure sensor (post-filter) connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2154 will become active upon disconnecting the sensor.

Fault Code 2155 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 3B - Check the ECM SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connectors from the ECM.

Action

Check the ECM SIGNAL pin resistance.

  • Measure the resistance from the oil pressure SIGNAL pin on the ECM to the ECM sensor supply circuit return pin.
  • Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2184 - Electronic Fuel Injection Control Valve Circuit - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 441 or 442 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2184 inactive?
STEP 2. | Check the fuel control valve and circuit. |
 | STEP 2A. Inspect the fuel control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel control valve. | 2 to 5 ohms?
 | STEP 2C. Check for a short to ground in the fuel control valve. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check fuel system. |
 | STEP 4A. Verify secondary fuel system. | Is pressure correct for the engine family?
 | STEP 4B. Check for a stuck open fuel control valve. | Secondary fuel pressure drop within 50 seconds of keyswitch ON?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2184 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel control valve and circuit.

Guided Step 2A - Inspect the fuel control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect fuel control valve from the engine harness.

Action

Inspect the engine harness and fuel control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel control valve output pin and the fuel control valve RETURN pin at the fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

2 to 5 ohms?
YES NO
No Repair

  • Replace the fuel control valve.
  • Use INSITE™ electronic service tool to reset the fuel tables.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short to ground in the fuel control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a fuel control valve output short to ground.

  • Measure the resistance between the fuel control valve SUPPLY pin and at the fuel control valve connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the fuel control valve.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector 1 from the ECM.

Action

Inspect the engine harness and ECM connector 1 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector 1 or engine harness connector.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 from the ECM.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the fuel control valve output pin in the engine harness ECM connector 1 and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the fuel control valve output line has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector 1 and connector 2 from the ECM.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for pin to pin short.

  • Measure the resistance between the fuel control valve SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 1.
  • Measure the resistance between the fuel control valve SUPPLY pin in the engine harness ECM connector 1 and all other pins in the engine connector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to pin short circuit on the fuel control valve SUPPLY wire has been detected in the engine harness.

Repair the damaged pins. Replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check fuel system.

Guided Step 4A - Check for a stuck fuel control valve.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck fuel control valve.

  • Use INSITE™ electronic service tool to monitor the secondary fuel pressure while the keyswitch is ON.

If the fuel control valve is stuck open, raw fuel will be dumped into the engine and out the exhaust.

Secondary fuel pressure drop within 50 seconds of keyswitch ON?
YES NO

A damaged fuel control valve has been detected.

Replace the fuel control valve.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2186 (Source Address 00) - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 4 supply and return. |
 | STEP 2A. Inspect the exhaust gas temperature sensors and circuit connected to the sensor supply 4 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the throttle differential pressure sensor and circuit connected to the sensor supply 4 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine position sensor and circuit connected to the sensor supply 4 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2186 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 4 supply and return.

Guided Step 2A - Inspect the exhaust gas temperature sensors and circuit connected to the sensor supply 4 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor A1 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Repeat this step to exhaust gas temperature sensor A1, A2, A3, A3, A4, A5, A6, A7 and A8.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor A1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Repeat this step to exhaust gas temperature sensor A1, A2, A3, A3, A4, A5, A6, A7 and A8.

Fault Code 2186 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the throttle differential pressure sensor and circuit connected to the sensor supply 4 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensors from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the throttle differential pressure sensor.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine position sensor and circuit connected to the sensor supply 4 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the engine position sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2186 (Source Address 01) - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 4 supply and return. |
 | STEP 2A. Inspect the exhaust gas temperature sensors and circuit connected to the sensor supply 4 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2186 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 4 supply and return.

Guided Step 2A - Inspect the exhaust gas temperature sensors and circuit connected to the sensor supply 4 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor B1 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Repeat this step to exhaust gas temperature sensor B1, B2, B3, B3, B4, B5, B6, B7 and B8.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor B1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Repeat this step to exhaust gas temperature sensor B1, B2, B3, B3, B4, B5, B6, B7 and B8.

Fault Code 2186 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in theECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jun-2015


FAULT CODE 2191 - Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftercooler | Refer to Procedure 010-001 | QSK60 G CM2358 K110 | 4383781
Air Cleaner Element | Refer to Procedure 010-014 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Exhaust Restriction | Refer to Procedure 011-009 | QSK60 G CM2358 K110 | 4383781
Aftercooler | Refer to Procedure 010-001 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the engine control module (ECM) for active Fault Code 2191. | Fault Code 2191 active?
 | STEP 1B. Check ECM for multiple active fault codes. | Fault Codes 153, 154, 155, 354, 355, 488, 2113, 2114, 2517, and /or 2518?
STEP 2. | Inspect the air filters for excessive restriction. |
 | STEP 2A. Check the engine air filter restriction. | Engine air filter restricted?
 | STEP 2B. Check the engine room or container air inlet filter restriction, if installed. | Engine room or container air inlet filter restricted?
STEP 3. | Check the exhaust emissions. |
 | STEP 3A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 4. | Inspect the turbocharger(s). |
 | STEP 4A. Inspect the turbocharger (s) for damage or excessive wear. | Turbocharger(s) damaged or out of specification?
STEP 5. | Check the exhaust restriction. |
 | STEP 5A. Measure the exhaust back pressure. | Exhaust back pressure exceeds specification?
STEP 6. | Check the aftercooler. |
 | STEP 6A. Check the aftercooler core for restriction or damage. | Aftercooler core restricted or damaged?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 2191.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the ECM for active Fault Code 2191.

  • Use INSITE™ electronic service tool to read for active Fault Code 2191.

Fault Code 2191 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read for multiple active fault codes 153, 154, 155, 354, 355, 488, 2113, 2114, 2517, and/or 2518.

Fault Codes 153, 154, 155, 354, 355, 488, 2113, 2114, 2517, and /or 2518?
YES NO

Troubleshoot the active fault code(s).

 No Repair

Go to the appropriate fault code troubleshooting procedure within Section TF.

Go to 2A

Guided Step 2 - Inspect the air filters for excessive restriction.

Guided Step 2A - Check the engine air filter restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the engine air filter restriction or damage that may cause excessive restriction.

Engine air filter restricted?
YES NO

Replace the air cleaner elements.

  • Refer to Procedure 010-014 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the engine room or container air inlet filter restriction, if installed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Only perform Guided Step 2B if engine room or container air inlet filters are fitted. If they are not fitted proceed to Guided Step 3A

Action

Check the engine room or container air inlet filter restriction or damage that may cause excessive restriction.

See equipment manufacturer service information for engine room or container air filter restriction specifications and inspection procedures.

Engine room or container air inlet filter restricted?
YES NO

Replace the engine room or container air cleaner elements.

  • See equipment manufacturer service information for engine room or container air filter element replacement procedures.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the exhaust emissions.

Guided Step 3A - Measure the exhaust emissions.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode, generator circuit breaker closed and rated load applied.

Action

Check that the exhaust emissions are to specification.

  • Use an emissions analysis to verify that the engine exhaust emissions are not running too lean.

Exhaust emissions to specification?
YES NO
No Repair

Correct the exhaust emissions.

  • Use INSITE™ electronic service tool to tune the exhaust emissions.

Go to 4A

Go to 7A

Guided Step 4 - Inspect the turbocharger(s)

Guided Step 4A - Inspect the turbocharger (s) for damage or excessive wear.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the turbocharger radial bearing clearance, axial bearing clearance and impeller for damage or out-of-specification condition.

  • Check the turbocharger axial clearance.
  • Check the turbocharger radial clearance.

Inspect the turbine and impeller for damage or excessive wear. If damage is detected contact ABB for the repair.

Turbocharger(s) damaged or out of specification?
YES NO

Replace the turbocharger(s).

  • Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the exhaust restriction.

Guided Step 5A - Check the exhaust back pressure.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode, generator circuit breaker closed and rated load applied.

Action

Check that the exhaust back pressure specification is not exceeded.

  • Measure the exhaust back pressure. Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust back pressure exceeds specification?
YES NO

Inspect the exhaust system and associated components and remove restriction.

  • See equipment manufacturer service information.

Replace the exhaust system components causing the restriction.

  • See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the aftercooler.

Guided Step 6A - Check the aftercooler for restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the aftercooler core is not restricted or damaged.

  • Inspect the aftercooler core. Refer to Procedure 010-001 in the Associated Procedures Table.

Aftercooler core restricted or damaged?
YES NO
No Repair

Clean or replace the aftercooler core.

  • Clean or replace the aftercooler core. Refer to Procedure 010-001 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2217 - Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 343, 346, 441, 442, 1826, 2294, and/or 2863 active?
STEP 2. | Calibrate the ECM. |
 | STEP 2A. Calibrate the ECM. | Calibrations download successful?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for multiple active fault codes.

  • Use INSITE™ electronic service tool to check for multiple active fault codes.

Fault Codes 343, 346, 441, 442, 1826, 2294, and/or 2863 active?
YES NO

Troubleshoot the fault code using the appropriate troubleshooting guide.

Refer to Procedure 019-362 in Section 19.

Appropriate fault code troubleshooting tree.

Go to 3A

Guided Step 2 - Calibrate the ECM.

Guided Step 2A - Calibrate the ECM.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECMs. Refer to Procedure 019-032 in Section 19.
  • Repeat for each engine ECM, as appropriate.

Calibrations download successful?
YES NO
No Repair

Replace the right or left bank ECM or parent ECM as appropriate.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2281 - Engine Cylinder 11 (B6) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2282 or 3122 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Codes 2281 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in Run mode and run for greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2282 or 3122 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS of the QSV91-G6 CM2358 V101 Service Manual, Bulletin 4332687.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in Run mode and run for greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2281 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and Run the engine for greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-May-2013


FAULT CODE 2282 - Engine Cylinder 11 (A6) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3122 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Codes 2282 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in Run mode and run for greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3122 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS of the QSV91-G6 CM2358 V101 Service Manual, Bulletin 4332687.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in Run mode and run for greater than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2282 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Run mode and Run the engine for greater than one minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-May-2013


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 91 percent?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short-to-ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2311 and/or 2864, 2866, and 2867 active?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent Pulse Width Modulation duty cycle signal at the ECM connector. | Percent duty cycle 10 to 91 percent?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codse.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active or high inactive counts?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Replace the damaged pins.

Repair or replace the engine harness, the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Percent duty cycle 10 to 91 percent?
YES NO
No Repair

Check the power supply connections and the fuses. Use the engine wiring diagram for the appropriate circuit.

Go to 3A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the ECM connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the ECM connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. or the harness connector.

  • Repair the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedure Table.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors

Action

Check the engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness ECM connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness ECM connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the fuel control valve actuator.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 2311 and/or 2864, 2866, and 2867 active?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel pump actuator.

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the fuel control valve commanded position percent pulse width modulation (PWM) duty cycle signal at the ECM connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left-bank ECM connector.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the ECM connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Use the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications

Percent duty cycle 10 to 91 percent?
YES NO
No Repair

A fault has been detected with the ECM.

  • Replace the left bank ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2313 - Fuel Control Valve Solenoid Driver 2 Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fueling actuator. |
 | STEP 1A. Inspect the fueling actuator and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the fault codes. | Fault Code 2313 inactive?
 | STEP 1C. Check the fueling actuator resistance. | 0.1 to 0.8 ohms?
 | STEP 1D. Check for a short to ground. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the whole circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short to voltage in the engine harness. | Less than 1.5 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 2313 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fueling actuator.

Guided Step 1A - Inspect the fueling actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Inspect the engine harness and fueling actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2313 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1C

Guided Step 1C - Check the fueling actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check for an open circuit in the fueling actuator.

  • Measure the resistance between the rear fueling actuator (+) pin and the rear fueling actuator (-) pin of the rear fueling actuator.

Note: Since the actuator resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the resistance.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

0.1 to 0.8 ohms?
YES NO
No Repair

Replace the fueling actuator.

Go to 1D

Go to 3A

Guided Step 1D - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.

Action

Check for a short to ground in the fueling actuator.

Measure the resistance between the following rear fueling actuator pins and engine block ground:

  • Rear fueling actuator (+) pin.
  • Rear fueling actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fueling actuator.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the whole circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the fueling actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check the whole circuit.

  • Measure the resistance between the rear fueling actuator (+) pin and the rear fueling actuator (-) pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

Measure the resistance between the following engine harness ECM connector pins and all other pins in the engine harness ECM connector:

  • Rear fueling actuator (+) pin
  • Rear fueling actuator (-) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short to voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fueling actuator.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check for a short circuit to voltage source in the engine harness.

Measure the voltage from the following engine harness ECM connector pins to engine block ground:

  • Rear fueling actuator (+) pin
  • Rear fueling actuator (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 3 minutes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2313 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Repair complete

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-May-2015


FAULT CODE 2427 - Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824776 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 227 active?
STEP 2. | Check the fuel outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for CM2358 module response. |
 | STEP 4A. Check for the appropriate CM2358 module response. | Fault Code 2427 inactive?
 | STEP 4B. Check the CM2358 module SIGNAL pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 2427 inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel outlet pressure sensor.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Reference the sensor supply fault code 227.

Go to 2A

Guided Step 2 - Check the fuel outlet pressure.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the fuel outlet pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..
  • Replace the Fuel Outlet Pressure Sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the engine oil pressure sensor circuit (post-filter) breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the engine oil pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the harness connector.
  • Connect the electronic service tool.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Replace the fuel outlet pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the fuel outlet pressure sensor circuit and the CM2358 module.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel outlet pressure sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the fuel outlet pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outletpressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the fuel outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) RETURN pin on the engine harness connector to the engine oil pressure sensor circuit (post-filter) RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) SIGNAL pin on the engine harness connector to the engine oil pressure sensor circuit SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor circuit SUPPLY pin on the engine harness connector to the engine oil pressure sensor circuit SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 4A

Go to 4A

Guided Step 4 - Check for a CM2358 module response.

Guided Step 4A - Check for an appropriate CM2358 module response.

Conditions

  • Keyswitch circuit energized.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine oil pressure sensor circuit (post-filter) connector.

Action

Check for the appropriate CM2358 module response.

  • Using the electronic service tool, verify the fault codes.

Note: Fault Code 2428 will become active upon disconnection of the sensor.

Fault Code 2427 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 module SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connectors from the CM2358 module.

Action

Check the CM2358 module SIGNAL pin resistance.

  • Measure the resistance from the oil pressure SIGNAL pin on the CM2358 module to CM2358 module sensor supply circuit RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Contact the nearest Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Faults Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2427 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2428 - Gas Control Valve 1 Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the engine control module (ECM) for active fault codes. | Fault Code 352 active?
STEP 2. | Check the fuel outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM2358 response. |
 | STEP 4A. Check for the appropriate CM2358 response. | Fault Code 2428 inactive?
 | STEP 4B. Check the CM2358 SIGNAL pin resistance. | Less than 100k ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2428 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel outlet pressure sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference the sensor supply Fault Code 227.

Go to 2A

Guided Step 2 - Check the fuel outlet pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the fuel outlet pressure sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the fuel outlet pressure sensor supply voltage.

  • Measure the supply voltage by the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the signal voltage by the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the fuel outlet pressure sensor and the CM2358.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or the fuel outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel outlet pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel outlet pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 3C

Go to 5A

Guided Step 3C - Check for a open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel outlet pressure RETURN pin on the engine harness connector to fuel outlet pressure RETURN pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin on the engine harness connector to fuel outlet pressure SIGNAL pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure SUPPLY pin on the engine harness connector to fuel outlet pressure SUPPLY pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM2358 response.

Guided Step 4A - Check for an appropriate CM2358 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the fuel outlet pressure sensor connector
  • Connect the electronic service tool.

Action

Check for the appropriate CM2358 response.

  • Use the electronic service tool to verify the fault codes.

Note: Fault Code 2427 will become active upon disconnecting the sensor.

Fault Code 2428 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM2358 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connectors from the CM2358.

Action

Check the CM2358 SIGNAL pin resistance.

  • Measure the resistance from the fuel outlet pressure SIGNAL pin on the CM2358 to the CM2358 sensor SUPPLY circuit number 1 pin.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Faults Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2428 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 28-Jul-2015


FAULT CODE 2457 - Engine Misfire for Multiple Cylinders - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Power supply fault codes active or high counts?
 | STEP 1B. Check for fault codes. | Fault Code 277, 687, 1761, 1799, 2184, 2313, 3836, 3847, 3859 active or high counts?
 | STEP 1C. Check for fault codes. | Engine throttle fault codes active or high counts?
 | STEP 1D. Check for fault codes. | Fault Code 459, 462, 2766 or 2767 active or high counts?
STEP 2. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Power supply fault codes active or high counts?
YES NO

Appropriate fault code troubleshooting tree.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 277, 687, 1761, 1799, 2184, 2313, 3836, 3847, 3859 active or high counts?
YES NO

Appropriate fault code troubleshooting tree.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Engine throttle fault codes active or high counts?
YES NO

Appropriate fault code troubleshooting tree.

 No Repair

Go to 2A

1D

Guided Step 1D - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 459, 462, 2766 or 2767 active or high counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration code and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2458 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK50 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK50 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK50 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 721, 2494, and/or 2847 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or troubleshoot cylinder damage first?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2458 inactive, Fault Code 2459 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 2 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2458 inactive?
 | STEP 6C. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 721, 2494, and/or 2847 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the Spark Plug Gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the Ignition System.

Guided Step 3A - Check the ignition coil on cylinder 2.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check cylinder 2 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 2 and 4.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2458 is inactive and that Fault Code 2459 is active.

Fault Code 2458 inactive and Fault Code 2459 active?
YES NO
No Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 2 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 2 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 2 overhead setting correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the Run mode and engine running for more than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2458 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Clear the inactive fault code.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 27-Jul-2015


FAULT CODE 2459 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 722, 2495, and/or 2848 active?
STEP 2. | Check the spark plug on cylinder 4. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or troubleshoot cylinder damage first?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2459 inactive, Fault Code 2458 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 4 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2459 inactive?
 | STEP 6C. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 722, 2495, and/or 2848 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 4.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 4.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Run/Stop/Auto switch in the OFF mode.

Action

Check cylinder 4 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 4 and 2.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2459 is inactive and that Fault Code 2458 is active.

Fault Code 2459 inactive and Fault Code 2458 active?
YES NO
No Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 4.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 4 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 4 overhead setting is correct. Refer to Procedure 003-004 in the Associated Procedures Table.

Cylinder 4 overhead setting correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2459 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.

Action

Clear the inactive fault code.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Jul-2015


FAULT CODE 2461 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 723, 2496, and/or 2849 active?
STEP 2. | Check the spark plug on cylinder 6. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or troubleshoot cylinder damage first?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2461 inactive, Fault Code 2462 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 6 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2461 inactive?
 | STEP 6C. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 723, 2496, and/or 2849 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 6.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 6.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check cylinder 4 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 6 and 8.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2461 is inactive and that Fault Code 2462 is active.

Fault Code 2461 inactive and Fault Code 2462 active?
YES NO
No Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 4.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 6 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 6 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 6 overhead setting correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 2461 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.

Action

Clear the inactive fault code.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Jul-2015


FAULT CODE 2462 - Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 724, 2497, and/or 2851 active?
STEP 2. | Check the spark plug on cylinder 8. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or troubleshoot cylinder damage first?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2462 inactive, Fault Code 2461 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 8 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2462 inactive?
 | STEP 6C. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 724, 2497, and/or 2851 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 8.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 8.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check cylinder 4 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 8 and 6.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2461 is inactive and that Fault Code 2462 is active.

Fault Code 2462 inactive and Fault Code 2461 active?
YES NO
No Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 8.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 8 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 8 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 6 overhead setting correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2462 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.

Action

Clear the inactive fault code.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2015


FAULT CODE 2463 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 725, 2498, and/or 2852 active?
STEP 2. | Check the spark plug on cylinder 10. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or troubleshoot cylinder damage first?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2463 inactive, Fault Code 2464 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 10 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2463 inactive?
 | STEP 6C. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 725, 2498, and/or 2852 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 10.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 10.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check cylinder 4 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 10 and 12.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2461 is inactive and that Fault Code 2462 is active.

Fault Code 2463 inactive and Fault Code 2464 active?
YES NO
No Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 10.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the Stop mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 10 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 10 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 6 overhead setting correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in the Run mode and engine running for more than one minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2463 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the Stop mode.

Action

Clear the inactive fault code.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Jul-2015


FAULT CODE 2464 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non-Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 12. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 12. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2464 inactive, Fault Code 2463 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 12 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2464 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 12.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • Place run/stop/auto switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 12.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the STOP mode.

Action

Check cylinder 12 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 12 and 10.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2464 is inactive and that Fault Code 2463 is active.

Fault Code 2464 inactive and Fault Code 2463 active?
YES NO

Replace the exhaust temperature sensor that was originally installed in cylinder 12 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

4.75 to 5.25-VDC?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the ECM connector to all other pins in the ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness ECM connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness ECM connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 12 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in the STOP mode.

Action

Check overhead set.

  • Check that cylinder 12 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 12 overhead setting correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2465 - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Nmae | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes 2457, 2767, 727, 2511 and/or 2854 active?
STEP 2. | Check the spark plug on cylinder 14. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 14. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2465 inactive, Fault Code 2466 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 14 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2465 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in Stop mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes 2457, 2767, 727, 2511 and/or 2854 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 14.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 14.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 16 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 14 and 16.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2465 is inactive and that Fault Code 2466 is active.

Fault Code 2465 inactive and Fault Code 2466 active?
YES NO
No Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor.

Action

Check the 5 volt supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 14.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 14 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.

Action

Check overhead set.

  • Check that cylinder 14 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 14 overhead setting correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2465 is inactive.

Fault Code 2465 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2466 - Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Nmae | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 728, 2512, and/or 2855 active?
STEP 2. | Check the spark plug on cylinder 16. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 16. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2466 inactive, Fault Code 2465 active?
 | STEP 4B. Check the 5 volt supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 16 overhead set. |
 | STEP 5A. Check the overhead set. | Cylinder 16 overhead setting correct?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2466 inactive?
 | STEP 6C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 728, 2512, and/or 2855 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 16.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 16.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring as found necessary. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 16 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 16 and 14.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2466 is inactive and that Fault Code 2465 is active.

Fault Code 2466 inactive and Fault Code 2465 active?
YES NO
No Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5 volt supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor.

Action

Check the 5 volt supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 16.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 16 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 16 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 16 overhead setting correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2469 - Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Nmae | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 671, 2484, and/or 2837 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2469 inactive, Fault Code 2471 active?
 | STEP 4B. Check the 5 volt supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 1 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear the fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2469 inactive?
 | STEP 6C. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 671, 2484, and/or 2837 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Check the ignition coil resistance. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring, if necessary. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2469 inactive and that Fault Code 2471 is active.

Fault Code 2469 inactive and Fault Code 2471 active?
YES NO
No Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 1.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 1 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 1.

  • Check that the cylinder 1 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 1 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 1. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear the fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present EMC code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2471 - Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Nmae | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 672, 2485 and/or 2838 active?
STEP 2. | Check the spark plug on cylinder 3. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2471 inactive, Fault Code 2472 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 3 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault code inactive?
 | STEP 6C. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 672, 2485 and/or 2838 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 3.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Replace the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 3.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 3 and 5.
  • Install the temperature sensor from cylinder 3 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 3.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2471 is inactive and that Fault Code 2472 is active.

Fault Code 2471 inactive and Fault Code 2472 active?
YES NO

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 3 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 3.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 3 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 3.

  • Check that the cylinder 3 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 3 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 3. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present EMC code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2471 is inactive.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2472 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 673, 2486 and/or 2839 active?
STEP 2. | Check the spark plug on cylinder 5. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2472 inactive, Fault Code 2473 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 5 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault code inactive?
 | STEP 6C. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 673, 2486 and/or 2839 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 5.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Replace the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 5.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 5 and 7.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2472 is inactive and that Fault Code 2473 is active.

Fault Code 2472 inactive and Fault Code 2473 active?
YES NO

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 5.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 5 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 5.

  • Check that the cylinder 5 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 5 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 5. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present EMC code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2471 is inactive.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2473 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 674, 2487 and/or 2841 active?
STEP 2. | Check the spark plug on cylinder 7. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2473 inactive, Fault Code 2475 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 7 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault code inactive?
 | STEP 6C. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 674, 2487 and/or 2841 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 7.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Replace the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 7.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 7 and 9.
  • Install the temperature sensor from cylinder 7 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 7.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2473 is inactive and that Fault Code 2475 is active.

Fault Code 2473 inactive and Fault Code 2475 active?
YES NO

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 7.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 7 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 7.

  • Check that the cylinder 7 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 7 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 7. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present EMC code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2473 is inactive.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2475 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 675, 2488 and/or 2842 active?
STEP 2. | Check the spark plug on cylinder 9. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2475 inactive, Fault Code 2476 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 9 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault code inactive?
 | STEP 6C. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 675, 2488 and/or 2842 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 9.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Replace the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 9.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 9 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 9 and 11.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2475 is inactive and that Fault Code 2476 is active.

Fault Code 2475 inactive and Fault Code 2476 active?
YES NO

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5 VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor.

Action

Check the 5 VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 9 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 9.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 9 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 9.

  • Check that the cylinder 9 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 9 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 9. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present EMC code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2475 is inactive.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2476 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 676, 2489 and/or 2843 active?
STEP 2. | Check the spark plug on cylinder 11. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2476 inactive, Fault Code 2477 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 11 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault code inactive?
 | STEP 6C. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 676, 2489 and/or 2843 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 11.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Replace the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 11.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 11 and 13.
  • Install the temperature sensor from cylinder 11 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 11.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2476 is inactive and that Fault Code 2477 is active.

Fault Code 2476 inactive and Fault Code 2477 active?
YES NO

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5 VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor.

Action

Check the 5 VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 11.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 11 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 11.

  • Check that the cylinder 11 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 11 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 11. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present EMC code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2476 is inactive.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2477 - Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 677, 2491 and/or 2844 active?
STEP 2. | Check the spark plug on cylinder 13. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2477 inactive, Fault Code 2478 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 13 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault code inactive?
 | STEP 6C. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 677, 2491 and/or 2844 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 13.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Replace the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 13.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 13 and 15.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2477 is inactive and that Fault Code 2478 is active.

Fault Code 2477 inactive and Fault Code 2478 active?
YES NO

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 13.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 13 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in OFF mode.

Action

Check cylinder 13.

  • Check that the cylinder 13 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 13 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 13. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present EMC code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES | NO
No Repair | No Repair

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 2477 is inactive.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 2478 - Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457, 2767, 678, 2492, and/or 2845 active?
STEP 2. | Check the spark plug on cylinder 15. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2478 inactive and Fault Code 2479 active?
 | STEP 4B. Check the 5 volt supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 15 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check ECM calibration and clear the fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2478 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457, 2767, 678, 2492, and/or 2845 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 15.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Replace the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 15.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Check the ignition coil resistance. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • De-energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 15 and 17.
  • Install the temperature sensor from cylinder 15 to cylinder 17.
  • Install the temperature sensor from cylinder 17 to cylinder 15.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2478 inactive and that Fault Code 2497 is active.

Fault Code 2478 inactive and Fault Code 2479 active?
YES NO

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5 volt supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor.

Action

Check the 5 volt supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 15.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CM2358 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM2358 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 15 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.

Action

Check overhead set.

  • Check that the cylinder 15 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 15 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 15. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6C

Go to 1A

Guided Step 6C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 28-Jul-2015


FAULT CODE 2482 - Engine Starter Mode Before Ready Status - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in RUN mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2483 - Engine Starter Mode Engagement - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2482 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in RUN mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2482 active?
YES NO
No Repair

Reference the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2484 - Exhaust Gas Temperature Cylinder 1 (A1) - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check the ECM for active fault codes. | Fault Code 2469 active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2484 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine
  • Connect INSITE electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensore circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2469 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2484 inactive?
YES NO
No Repair

Retun to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2485 - Exhaust Gas Temperature Cylinder 3 (A2) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check the ECM for active fault codes. | Fault Code 2471 or active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault code inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine
  • Connect INSITE electronic service tool
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2471 or active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2485 inactive?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2486 - Exhaust Gas Temperature Cylinder 5 (A3) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 2472 or active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2486 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2472 or active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2486 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2487 - Exhaust Gas Temperature Cylinder 7 (A4) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check the ECM for active fault codes. | Fault Code 2473 or active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available dose the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2487 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2473 or active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2487 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 28-Jul-2015


FAULT CODE 2488 - Exhaust Gas Temperature Cylinder 9 (A5) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check the ECM for active fault codes. | Fault Code 2475 or active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2488 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2475 or active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2488 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2489 - Exhaust Gas Temperature Cylinder 11 (A6) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check the ECM for active fault codes. | Fault Code 2476 or active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available dose the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2489 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2476 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2489 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 28-Jul-2015


FAULT CODE 2491 - Exhaust Gas Temperature Cylinder 13 (A7) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check the ECM for active fault codes. | Fault Code 2477 or active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2491 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2477 or active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2491 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2492 - Exhaust Gas Temperature Cylinder 15 (A8) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check the ECM for active fault codes. | Fault Code 2478 or active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available dose the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2492 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2478 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2492 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2494 - Exhaust Gas Temperature Cylinder 2 (B1) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 2458 active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2494 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2458 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2494 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2495 - Exhaust Gas Temperature Cylinder 4 (B2) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 2495 active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify the fault code is inactive. | Fault Code 2495 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check the ECM for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2495 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2495 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2496 - Exhaust Gas Temperature Cylinder 6 (B3) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Spark Plugs (Non-Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap correct?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 1. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins damaged?
 | STEP 3C. Check for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2469 inactive and Fault Code 2471 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Engine harness and connector pins OK?
 | STEP 4D. Check for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 1 overhead set. |
 | STEP 5A. Check the overhead set. | Cylinder 1 overhead setting correct?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Keyswitch circuit energized.
  • Place run/stop/auto switch in RUN mode and running for greater than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap correct?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring.

Check the ignition coil resistance. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins damaged?
YES NO

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510. Install the appropriate connector seal if it is damaged or missing. Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3C

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the RUN mode.

Action

Check cylinder 1 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for greater than one minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2469 inactive and that Fault Code 2471 is active.

Fault Code 2469 inactive and Fault Code 2471 active?
YES NO

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 1.

Use a wiring diagram for connector pin identification or the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Engine harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510. Install the appropriate connector seal if it is damaged or missing. Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the ECM.

Action

Check for a short circuit pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the ECM connector to all other pins in the ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness ECM connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness ECM connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC SUPPLY pin in the engine harness ECM connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 1 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 1.

  • Check that the cylinder 1 overhead setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Cylinder 1 overhead setting correct?
YES NO
No Repair

Adjust the overhead setting on cylinder 1. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2497 - Exhaust Gas Temperature Cylinder 8 (B4) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 2462 active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify that the fault code is inactive. | Fault Code 2497 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2462 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2497 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2498 - Exhaust Gas Temperature Cylinder 10 (B5) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 2463 active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify that the fault code is inactive. | Fault Code 2498 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2463 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2498 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 21-Jul-2015


FAULT CODE 2499 - Exhaust Gas Temperature Cylinder 12 (B6) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383871

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 2464 active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify that the fault code is inactive. | Fault Code 2499 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2464 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2499 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 20-Jul-2015


FAULT CODE 2511 - Exhaust Gas Temperature Cylinder 14 (B7) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 2465 active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify that the fault code is inactive. | Fault Code 2511 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2465 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2511 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 20-Jul-2015


FAULT CODE 2512 - Exhaust Gas Temperature Cylinder 16 (B8) - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Gas Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the exhaust gas temperature sensor circuit accuracy. |
 | STEP 1A. Verify the exhaust gas temperature sensor circuit accuracy. | Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Fault Code 2466 active?
STEP 3. | Check ECM calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available does the ECM contain that revision or higher?
 | STEP 3B. Verify that the fault code is inactive. | Fault Code 2512 inactive?
 | STEP 3C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the exhaust gas temperature sensor circuit accuracy.

Guided Step 1A - Verify the exhaust gas temperature sensor circuit accuracy.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect the electronic service tool.

Action

Use an infrared thermometer to verify the exhaust gas temperature sensor circuit cylinder accuracy.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature sensor circuit cylinder reading on INSITE™ electronic service tool monitor screen.

Temperature measurement from the infrared thermometer within 15 percent of the exhaust gas temperature sensor circuit cylinder reading with INSITE™ electronic service tool?

YES NO
No Repair

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2466 active?

YES NO
No Repair

Reference the Exhaust Temperature is High (single cylinder) and the Exhaust Temperature is High (multiple cylinders) troubleshooting symptom trees in this manual.

Appropriate troubleshooting chart.

Go to 3A

Guided Step 3 - Check the ECM calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and dataplate in Features and Parameters.

If a calibration update for this fault code is available does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and idle the engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Condition for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2512 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3C

Go to 1A

Guided Step 3C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshooting any remaining active fault code.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 20-Jul-2015


FAULT CODE 2517 - Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 227, 263, 1827, and 2427 active?
STEP 2. | Check the compressor outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 2517 inactive?
 | STEP 4B. Check the ECM SIGNAL pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2517 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the compressor outlet pressure sensor.

Fault Codes 227, 263, 1827, and 2427 active?
YES | NO
No Repair | No Repair

Troubleshoot the fault code using the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the compressor outlet pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the compressor outlet pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the compressor outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the compressor outlet pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the compressor outlet pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Install the compressor outlet pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the compressor outlet pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the compressor outlet pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the compressor outlet pressure sensor and the ECM.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness with damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the compressor outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the compressor outlet pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the compressor outlet pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the compressor outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the compressor outlet pressure RETURN pin on the engine harness connector to the compressor outlet pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the engine harness connector to the compressor outlet pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure SUPPLY pin on the engine harness connector to the compressor outlet pressure SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM response.

Guided Step 4A - Check for an appropriate ECM response.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the compressor outlet pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the fuel delivery pressure sensor SUPPLY pin and the fuel SUPPLY pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2518 will become active upon disconnecting the sensor.

Fault Code 2517 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM SIGNAL pin resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the main harness connectors from the ECM.

Action

Check the ECM SIGNAL pin resistance.

  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the ECM to the ECM sensor supply circuit number two RETURN pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2518 - Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 187, 265, 1828, and 2428 active?
STEP 2. | Check the compressor outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 2518 inactive?
 | STEP 4B. Check the ECM SIGNAL pin resistance. | Less than 100k ohm?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the compressor outlet pressure sensor.

Fault Code 187, 265, 1828, and 2428 active?
YES | NO
No Repair | No Repair

Troubleshoot the fault code using the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the compressor outlet pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the compressor outlet pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness or replace the compressor outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the compressor outlet pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the compressor outlet pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Install the compressor outlet pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the compressor outlet pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

  • Replace the compressor outlet pressure sensor. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the compressor outlet pressure sensor and the ECM.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness with damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the compressor outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the compressor outlet pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the compressor outlet pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the compressor outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the compressor outlet pressure RETURN pin on the engine harness connector to the compressor outlet pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the engine harness connector to the compressor outlet pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure SUPPLY pin on the engine harness connector to the compressor outlet pressure SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM response.

Guided Step 4A - Check for an appropriate ECM response.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the compressor outlet pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Place a jumper wire between the fuel delivery pressure sensor SUPPLY pin and the fuel supply pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2517 will become active upon adding the jumper.

Fault Code 2518 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM signal pin resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the main harness connectors from the ECM.

Action

Check the ECM SIGNAL pin resistance.

  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the ECM to the ECM sensor supply circuit number two RETURN pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jun-2015


FAULT CODE 2521 - Bank Identifier Incorrect - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the left bank CM2358. | Fault Code 2521 active?
 | STEP 1B. Check the right bank CM2358. | Fault Code 2521 active?
STEP 2. | Check the left bank CM2358 bank identification circuit. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify a short circuit between bank identification pin 1 and left bank CM2358 switch return. | Less than 10 ohms?
 | STEP 2C. Verify an open circuit on bank identification pin 2. | Greater than 100k ohms?
STEP 3. | Check the right bank CM2358 bank identification circuit. |
 | STEP 3A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify a short circuit between bank identification pin 2 and right bank CM2358 switch return. | Less than 10 ohms?
 | STEP 3C. Verify an open circuit on bank identification pin 1. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify that the fault code is inactive. | Fault Code 2521 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the left bank CM2358.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Check for bank identification error fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 2521 is active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check right bank CM2358.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Check for bank identification error fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 2521 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 2 - Check the left bank CM2358 bank identification circuit.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the left bank CM2358.

Action

Inspect the harness connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-204 in Section 19.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify a short circuit between bank identification pin 1 and left bank CM2358 switch return.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the left bank CM2358.

Action

Harness connector - pin-to-pin continuity check.

  • Measure the resistance between bank identification pin 1 and left bank CM2358 switch return.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

  • Add a short circuit between bank identification pin 1 and left bank CM2358 switch return.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Verify an open circuit on bank identification pin 2.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the left bank CM2358.

Action

Harness connector - pin to pin continuity check:

  • Measure the resistance between bank identification pin 2 and left bank CM2358 switch return.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

  • Restore an open circuit between bank identification pin 2 and left bank CM2358 switch return.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the right bank CM2358 bank identification circuit.

Guided Step 3A - Inspect the harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the right bank CM2358.

Action

Inspect the harness connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-204 in Section 19.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Verify a short circuit between bank identification pin 2 and right bank CM2358 switch return.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the right bank CM2358.

Action

Harness connector - pin-to-pin continuity check:

  • Measure the resistance between bank identification pin 2 and right bank CM2358 switch return.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

  • Add a short circuit between bank identification pin 2 and Right Bank CM2358 switch return.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Verify an open circuit on bank identification pin 1.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the right bank CM2358.

Action

Harness connector - pin-to-pin continuity check:

  • Measure the resistance between bank identification pin 1 and right bank CM2358 switch return.
  • Reference the circuit diagram or wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

  • Restore an open circuit between bank identification pin 1 and right bank CM2358 switch return.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Faults Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2521 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2015


FAULT CODE 2522 - Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 561 or 3111 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2522 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 561 or 3111 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree.

Go to the appropriate troubleshooting chart.

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine with the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2522 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 04-Jun-2015


FAULT CODE 2523 - Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 562 or 3112 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2523 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 562 or 3112 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree.

Go to the appropriate troubleshooting chart.

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine with the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2523 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 03-Jun-2015


FAULT CODE 2524 - Engine Cylinder 2 (A2) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 563 or 3113 active?
STEP 2. | Check ECM calibration code and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 563 or 3113 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 2525 - Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 564 or 3114 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2525 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 564 or 3114 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2525 active?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Apr-2015


FAULT CODE 2526 - Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 565 or 3115 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2526 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 565 or 3115active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2526 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Apr-2015


FAULT CODE 2527 - Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 566 or 3116 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2527 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 566 or 3116 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2527 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jun-2015


FAULT CODE 2528 - Engine Cylinder 7 (A4) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 567 or 3117 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2528 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 567 or 3117 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2528 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2529 - Engine Cylinder 8 (B4) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 568 or 3118 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2529 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 568 or 3118 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2529 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2531 - Engine Cylinder 9 (A5) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 569 or 3119 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2531 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 569 or 3119 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2531 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2532 - Engine Cylinder 10 (B5) Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1274 or 3121 active?
 | STEP 1B. Verify the fault code is inactive. | Fault Code 2532 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 1274 or 3121 active?
YES NO
No Repair

Reference the Engine Noise - Combustion Knocks in this manual.

Appropriate troubleshooting chart

Go to 1B

Guided Step 1B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN and run the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Codes 2532 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 2544 - Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 2544 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2544 active?
YES NO

Allow the ECM to cool and restart the engine. If the fault reoccurs, contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2544 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Appropriate troubleshooting chart

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2567 - Air Compressor Actuator Driver Circuit Breaker - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 2567 active?
STEP 2. | Check the circuit breaker. |
 | STEP 2A. Inspect the circuit breaker connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit breaker for malfunctions. | Visible malfunctions?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2567 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the circuit breaker.

Guided Step 2A - Inspect the circuit breaker connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM harness from the circuit breaker.

Action

Inspect the OEM and the circuit breaker connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set circuit breaker connector. Reference site documentation.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit breaker for malfunctions.

Conditions

  • Place the run/stop/auto switch in the STOP position.

Action

Manually check to see if the switch can close.

Visible malfunctions?
YES NO

Replace circuit breaker. Reference site documentation.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and the ECM connector pins.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM harness from the board terminal block.

Action

Inspect the OEM and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the OEM harness or the voltage regulator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510. Install the appropriate connector seal if it is damaged or missing. Repair the generator control harness. Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM harness from the engine control module.
  • Disconnect the OEM harness from the circuit breaker.

Action

Check for a short circuit from wire-to-wire.

  • Measure the resistance from the circuit breaker position wire on the OEM harness connector to all other wires on the OEM harness connector.

Greater than 100k ohms?
YES NO
No Repair

Repair the OEM harness.

  • Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.

Replace the OEM harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the circuit breaker.

Action

Check for an open circuit in the supply wire.

  • Measure the resistance from the circuit breaker supply pin on the OEM harness connector to the circuit breaker supply pin on the OEM harness controller connector.

Less than 10k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-203 in Section 19, Refer to Procedure 019-205 in Section 19 or Refer to Procedure 019-213 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2568 - Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Regulator, NG | Refer to Procedure 005-042 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

In most countries, inspection, repair, and adjustment of Natural Gas supply systems and components can only be undertaken by qualified and certified personnel. In many regions, accreditation to a nationally recognized trade organization is also required. It is necessary to comply with all local and national codes and legislation when performing these maintenance procedures.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Code 1839 or 1841 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2568 active?
STEP 2. | Check the fuel supply pressure. |
 | STEP 2A. Check the fuel supply pressure at the inlet to the fuel control valve. | Fuel supply pressure 130 to 150 mBar [1.885 to 2.176 psi]?
STEP 3. | Check the fuel supply pressure sensor. |
 | STEP 3A. Check the fuel supply pressure sensor and harness connector. | Dirty or damaged pins?
 | STEP 3B. Verify the engine fuel supply pressure sensor reading. | Fuel pressure within 5 percent?
STEP 4. | Check ECM calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1839 or 1841 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2568 active?
YES NO

Proceed to the next troubleshooting step or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel supply pressure.

Guided Step 2A - Check the fuel supply pressure at the inlet to the fuel control valve.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine at no load for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure at the inlet to the fuel control valve.

  • Use INSITE™ electronic service tool to verify the fuel inlet pressure at the fuel control valve.

Fuel supply pressure 130 to 150 mBar [1.885 to 2.176 psi]?
YES NO
No Repair

High pressure has been detected at the intake to the fuel control valve.

  • Adjust the fuel supply pressure to between 150 and 180 mBar [2.176 and 2.611 psi] at the outlet of the fuel supply pressure regulator.
  • Repair or replace the malfunctioning fuel supply pressure regulator. Use the following procedures for information on the fuel control valve. Refer to Procedure 005-042 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel supply pressure sensor.

Guided Step 3A - Check the fuel supply pressure sensor and harness connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor.

Action

Inspect the gas valve/fuel supply pressure sensor harness and fuel supply pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the gas valve harness, the harness connector, or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the gas valve wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Verify the engine fuel supply pressure sensor reading.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine at no load for greater than 1 minute
  • Connect INSITE™ electronic service tool.
  • Connect a mechanical manometer/pressure gauge to the gas pressure test point immediately after the fuel supply gas pressure regulator.

Note: The mechanical manometer/pressure gauge used for this test must be approved for use with natural gas systems.

Action

Verify the engine fuel supply pressure reading.

  • Use INSITE™ electronic service tool to monitor the fuel supply pressure sensor value.
  • Compare the electronic reading with the fuel supply pressure displayed on the mechanical manometer/pressure gauge.

Fuel pressure within 5 percent?
YES NO
No Repair

Replace the fuel supply pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 2569 - Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Regulator, NG | Refer to Procedure 005-042 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

In most countries, inspection, repair, and adjustment of Natural Gas supply systems and components can only be undertaken by qualified and certified personnel. In many regions, accreditation to a nationally recognized trade organization is also required. It is necessary to comply with all local and national codes and legislation when performing these maintenance procedures.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 1839 or 1841 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2569 active?
STEP 2. | Check the fuel supply pressure. |
 | STEP 2A. Check the fuel supply pressure at the inlet to the fuel control valve. | Fuel supply pressure 130 to 150 mBar [1.885 to 2.176 psi]?
STEP 3. | Check the fuel supply pressure sensor. |
 | STEP 3A. Check the fuel supply pressure sensor and harness connector. | Dirty or damaged pins?
 | STEP 3B. Verify the engine fuel supply pressure sensor reading. | Fuel pressure within 5 percent?
STEP 4. | Check ECM calibration code and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1839 or 1841 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2569 active?
YES NO

Proceed to the next troubleshooting step or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel supply pressure.

Guided Step 2A - Check the fuel supply pressure at the inlet to the fuel control valve.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine at no load for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure at the inlet to the fuel control valve.

  • Use INSITE™ electronic service tool to verify the fuel inlet pressure at the fuel control valve.

Fuel supply pressure 130 yo 150 mBar [1.885 to 2.176 psi]?
YES NO
No Repair

High pressure has been detected at the intake to the fuel control valve.

  • Adjust the fuel supply pressure to between 150 and 180 mBar [2.176 and 2.611 psi] at the outlet of the fuel supply pressure regulator.
  • Repair or replace the malfunctioning fuel supply pressure regulator. Use the following procedures for information on the fuel control valve. Refer to Procedure 005-042 in the Associated Procedures Table

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel supply pressure sensor.

Guided Step 3A - Check the fuel supply pressure sensor and harness connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor.

Action

Inspect the gas valve/fuel supply pressure sensor harness and fuel supply pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the gas valve harness, harness connector, or sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the gas valve wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Verify the engine fuel supply pressure sensor reading.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine at no load for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect a mechanical manometer/pressure gauge to the gas pressure test point immediately after the fuel supply gas pressure regulator.

Note: The mechanical manometer/pressure gauge used for this test must be approved for use with natural gas systems.

Action

Verify the engine fuel supply pressure reading.

  • Use INSITE™ electronic service tool to monitor the fuel supply pressure sensor value.
  • Compare the electronic reading with the fuel supply pressure displayed on the mechanical manometer/pressure gauge.

Fuel pressure within 5 percent?
YES NO
No Repair

  • Replace the fuel supply pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 2586 - Engine Spark Plug #1 (A1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 1 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383781 for spark plug maintenance intervals. Refer to Procedure 358-001 in Section 2.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 1.

  • Test the cylinder 1 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2587 - Engine Spark Plug #2 (B1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration code and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 2 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 358-001 in Section 2.

Spark plug damaged or excessive gap?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 ignition coil.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease buildup on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

  • Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil for cylinder 2.

  • Test the cylinder 2 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

  • Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2588 - Engine Spark Plug #3 (A2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 3 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 3.

  • Test the cylinder 3 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2589 - Engine Spark Plug #4 (B2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 4 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 4.

  • Test the cylinder 2 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2591 - Engine Spark Plug #5 (A3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 5 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 5.

  • Test the cylinder 5 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2592 - Engine Spark Plug #6 (B3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 6 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 6.

  • Test the cylinder 6 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2593 - Engine Spark Plug #1 (A1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 1 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2594 - Engine Spark Plug #2 (B1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 2 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2595 - Engine Spark Plug #3 (A2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 3 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2596 - Engine Spark Plug #4 (B2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 4 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 2597 - Engine Spark Plug #5 (A3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 5 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2598 - Engine Spark Plug #6 (B3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 6 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Note: Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782, for spark plug maintenance intervals. Refer to Procedure 359-001 in Section 3.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2653 - Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK60 G CM2358 K110 | 4383781
Air Intake Restriction | Refer to Procedure 010-031 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Compressor bypass actuator, fuel control valve, throttle valve, turbocharger, crankshaft, or camshaft fault codes active?
 | STEP 1C. Verify the exhaust gas temperature bank 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2B. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2C. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting fault code tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Compressor bypass actuator, fuel control valve, throttle valve, turbocharger, crankshaft, or camshaft fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature bank 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature bank 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 2654 - Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK60 G CM2358 K110 | 4383781
Air Intake Restriction | Refer to Procedure 010-031 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Compressor bypass actuator, fuel control valve, throttle valve, turbocharger, crankshaft, or camshaft fault codes active?
 | STEP 1C. Verify the exhaust gas temperature bank 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2B. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2C. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting fault code tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Compressor bypass actuator, fuel control valve, throttle valve, turbocharger, crankshaft, or camshaft fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature bank 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature bank 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 2657 - Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK60 G CM2358 K110 | 4383781
Air Intake Restriction | Refer to Procedure 010-031 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Compressor bypass actuator, fuel control valve, throttle valve, turbocharger, crankshaft, or camshaft fault codes active?
 | STEP 1C. Verify the exhaust gas temperature bank 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2B. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2C. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting fault code tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Compressor bypass actuator, fuel control valve, throttle valve, turbocharger, crankshaft, or camshaft fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature bank 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 1 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature bank 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 2658 - Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK60 G CM2358 K110 | 4383781
Air Intake Restriction | Refer to Procedure 010-031 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Compressor bypass actuator, fuel control valve, throttle valve, turbocharger, crankshaft, or camshaft fault codes active?
 | STEP 1C. Verify the exhaust gas temperature bank 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2B. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2C. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting fault code tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Compressor bypass actuator, fuel control valve, throttle valve, turbocharger, crankshaft, or camshaft fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature bank 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 1 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

A damaged exhaust gas temperature bank 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-May-2015


FAULT CODE 2737 - Exhaust Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2737. | Active or inactive counts of Fault Code 2737?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2737.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2737?
YES NO

See Exhaust Gas Temperature Above Normal symptom troubleshooting tree in Section TS.

 No Repair

Go to the appropriate troubleshooting symptom tree.

Repair complete.

Last Modified: 22-May-2015


FAULT CODE 2766 - Engine Ignition Control Module #1 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Power supply fault codes active or high counts?
STEP 2. | Check the ignition control module (ICM) and ignition harness. |
 | STEP 2A. Inspect the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-ground short in the ignition harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 2E. Check for voltage at the coils. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration code and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. Operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the active fault codes.

Power supply fault codes active or high counts?
YES | NO
No Repair | No Repair

Troubleshoot the non-ignition related fault codes.

Go to 2A

Guided Step 2 - Check the ICM and ignition harness.

Guided Step 2A - Inspect the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM or ICM ports. Damage can result. Do not blow compressed air in the ECM ports or connect. Compressed air can contain moisture due to condensation.

Dirty or damaged pins?
YES NO

Repair the harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM connector C2.
  • Disconnect the ignition harness from all the coils.

Action

Check for an open circuit for each cylinder misfiring.

  • Measure the resistance between the ignition harness ICM connector C2 primary RETURN pins and the ignition harness coil connector.
  • Measure the resistance between the ignition harness ICM connector C2 charge voltage pin and the ignition harness coil connector charge voltage pins.
  • Measure the resistance between the ignition harness ICM connector C2 secondary RETURN pin and the ignition harness coil connector secondary RETURN pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-ground short in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector C2 from the ICM.
  • Disconnect the ignition harness for all coils.

Action

Check for a pin-to-ground short in the ignition harness.

  • Measure the resistance between the charge voltage pins at the coil connectors and engine block ground.
  • Measure the resistance between the secondary RETURN pin at the coil connectors and engine block ground.
  • Measure the resistance between the primary RETURN pin at the coil connectors and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the ignition harness.

Repair or replace the harness. Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector C2 from the ICM.
  • Disconnect the ignition harness for all coils.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between the secondary RETURN pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between the primary RETURN pins in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the ignition harness.

Repair or replace the harness. Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for voltage at the coils.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Action

Check the ignition coils of the misfiring cylinder.

  • Test the misfiring cylinders to determine if the plugs are receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

The coils must be tested in the vertical position to prevent coil damage.

Steady spark observed?
YES NO

Perform an Ignition Coil Short to Ground Test. Refer to Procedure 013-024 in the Associated Procedures Table.

Replace the ignition coil of the misfiring cylinder. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2767 - Engine Ignition Control Module #2 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Power supply fault codes active or high counts?
STEP 2. | Check the ignition control module (ICM) and ignition harness. |
 | STEP 2A. Inspect the ICM and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the ignition harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-ground short in the ignition harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the ignition harness. | Greater than 100k ohms?
 | STEP 2E. Check for voltage at the coils. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration code and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. Operate the engine in the condition in which the misfire occurred.

  • Use INSITE™ electronic service tool to read the active fault codes.

Power supply fault codes active or high counts?
YES | NO
No Repair | No Repair

Troubleshoot the non-ignition related fault codes.

Go to 2A

Guided Step 2 - Check the ICM and ignition harness.

Guided Step 2A - Inspect the ICM and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinders for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM or ICM ports. Damage can result. Do not blow compressed air in the ECM ports or connect. Compressed air can contain moisture due to condensation.

Dirty or damaged pins?
YES NO

Repair the harness with the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Replace the ICM. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness from the ICM connector C2.
  • Disconnect the ignition harness from all the coils.

Action

Check for an open circuit for each cylinder misfiring.

  • Measure the resistance between the ignition harness ICM connector C2 primary RETURN pins and the ignition harness coil connector.
  • Measure the resistance between the ignition harness ICM connector C2 charge voltage pin and the ignition harness coil connector charge voltage pins.
  • Measure the resistance between the ignition harness ICM connector C2 secondary RETURN pin and the ignition harness coil connector secondary RETURN pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the ignition harness.

Repair or replace the ignition harness.

  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-203 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-ground short in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector C2 from the ICM.
  • Disconnect the ignition harness for all coils.

Action

Check for a pin-to-ground short in the ignition harness.

  • Measure the resistance between the charge voltage pins at the coil connectors and engine block ground.
  • Measure the resistance between the secondary RETURN pin at the coil connectors and engine block ground.
  • Measure the resistance between the primary RETURN pin at the coil connectors and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the ignition harness.

Repair or replace the harness. Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the ignition harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition harness connector C2 from the ICM.
  • Disconnect the ignition harness for all coils.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the charge voltage pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between the secondary RETURN pin in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.
  • Measure the resistance between the primary RETURN pins in the ignition harness ICM connector 2 and all other pins in the ignition harness connector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the ignition harness.

Repair or replace the harness. Refer to Procedure 019-202 in Section 19.

Refer to Procedure 019-203 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for voltage at the coils.

Conditions

  • Turn keyswitch ON.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Action

Check the ignition coils of the misfiring cylinder.

  • Test the misfiring cylinders to determine if the plugs are receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

The coils must be tested in the vertical position to prevent coil damage.

Steady spark observed?
YES NO

Perform an Ignition Coil Short to Ground Test. Refer to Procedure 013-024 in the Associated Procedures Table.

Replace the ignition coil of the misfiring cylinder. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2768 - Engine Network Master Slave Communication - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 441, 442, 477 and/or 478 active?
 | STEP 1B. Check for active fault codes. | Fault Code 343 or 346 active?
 | STEP 1C. Check for active fault codes. | Fault Code 426, 427, 781, 412, or 414 active?
STEP 2. | Check ECM calibration code and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 441, 442, 477 and/or 478 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all components.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 343 or 346 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Connect all components.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 426, 427, 781, 412, or 414 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2769 - Engine Network Slave Message - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2768 active?
 | STEP 1B. Check for active fault codes. | Fault Code 343 or 346 active?
STEP 2. | Check engine control module (ECM) calibration code and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in the STOP mode.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2768 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-417 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in the STOP mode.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 343 or 346 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-417 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2789 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 144, 145, 1824, 2869, 2871, or 2872 active?
STEP 2. | Check the high temperature system temperature control module. |
 | STEP 2A. Check the high temperature system temperature control module is powered up. | High-temperature control module powered up?
 | STEP 2B. Check the high temperature system temperature control module system for alarms. | High temperature control module displaying system alarms?
STEP 3. | Check the voltage power supply. |
 | STEP 3A. Check the 24 volt power supply to the high temperature system temperature control module. | Between 20 and 29 VDC?
 | STEP 3B. Check the voltage supply fuse. | Less than 10 ohms?
 | STEP 3C. Check the voltage supply harness and connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the temperature input signal. |
 | STEP 4A. Check the 4-20mA input from the engine control module (ECM) to the high temperature system temperature control module. | Input signal between 4 and 20mA?
 | STEP 4B. Check the ECM to high temperature system temperature control module interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the voltage output from the high temperature system temperature control module. |
 | STEP 5A. Check the voltage output at the high temperature system temperature control module. | Between 20 and 29 VDC?
 | STEP 5B. Check the voltage input at the high temperature system temperature control CLOSE relay. | Between 20 and 29 VDC?
 | STEP 5C. Check the high temperature system temperature control module to CLOSE relay interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 5D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the voltage supply to the high temperature system temperature control valve. |
 | STEP 6A. Check the voltage input to the high temperature control valve CLOSE input terminals. | Voltage output 120/240 VAC?
 | STEP 6B. Check the high temperature system temperature control valve is closed. | High-temperature control valve closed?
 | STEP 6C. Check the voltage output at the high temperature system temperature control CLOSE relay. | Voltage output 120 to 240 VAC?
 | STEP 6D. Check the voltage harness and connector pins. | Dirty or damaged pins?
 | STEP 6E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 6F. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the high temperature cooling system radiator fans. |
 | STEP 7A. Check the high temperature cooling system radiator fans control logic. | High-temperature radiator fans operating correctly?
STEP 8. | Check ECM calibration code and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144, 145, 1824, 2869, 2871, or 2872 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the high temperature system temperature control module.

Guided Step 2A - Check the high temperature system temperature control module is powered up.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Energize 24 volt switched and unswitched power supplies.

Action

Check the high temperature system temperature control module is powered up.

  • Check that the high temperature system temperature control module display panel is illuminated.

High temperature control module powered up?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the high temperature system temperature control module for system alarms.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Energize 24 volt switched and unswitched power supplies.

Action

Check the high temperature system temperature control module for system alarms.

  • Use the high temperature system temperature control module display to check for system alarms.

High temperature control module displaying system alarms?
YES NO

Troubleshoot and repair the high temperature control system faults.

  • Troubleshoot and repair the high temperature control system faults as indicated by the alarms displayed on the high temperature control module display.
  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 3A

Guided Step 3 - Check the voltage power display.

Guided Step 3A - Check the 24 volt power supply to the high temperature system temperature control module.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Energize 24 volt switched and unswitched power supplies.

Action

Check the 24 volt power supply to the high temperature system temperature control module:

  • Check for 24 VDC at the high temperature control module 24 VDC (+), 24 VDC (-), 1A OP1, and 1A OP2 terminals.
  • Use the circuit diagram or wiring diagram for temperature control module termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Between 20 and 29 VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the voltage supply fuse.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Energize 24 volt switch and unswitched power supplies.

Action

Check the 24 volt supply inline fuse.

  • Use a multimeter to check the condition of the inline fuse.

Use the circuit diagram or wiring diagram for fuse designation and rating.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 8A

Guided Step 3C - Check the voltage and supply harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the voltage power supply and high temperature control module.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pin, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 3D

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the voltage isolator switch and high temperature control module voltage input terminals.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the voltage isolator switch 24 volt SUPPLY pin in the ECM connector to all other pins in the voltage harness.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 3E

Go to 8A

Guided Step 3E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the voltage isolator switch and high temperature control module voltage input terminals.

Action

Check for an open circuit.

  • Measure the resistance from the voltage isolator SUPPLY pin in the voltage harness connector to the voltage input SUPPLY pin in the high temperature controller voltage connector.
  • Measure the resistance from the voltage isolator RETURN pin in the voltage harness connector to the voltage input RETURN pin in the high temperature controller voltage connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 8A

Guided Step 4 - Check the temperature input signal.

Guided Step 4A - Check the 4-20mA input from the ECM to the high temperature system temperature control module.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the high temperature 4-20mA signal from the ECM to the high temperature control module.

  • Connect an ammeter in series with 4-20mA positive wire running between the ECM and the high temperature control module.

Use the circuit diagram or wiring diagrams for termination and pin identification.

Contact a Cummins® Authorized Repair Location.

Input signal between 4 and 20mA?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM to high temperature system temperature control module interconnect harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the ECM and high temperature control module.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pin, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 4C

Guided Step 4C - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the ECM and high temperature control module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the ECM high temperature input SIGNAL pin in the ECM connector to all other pins in the ECM connector B.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4D

Go to 8A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the ECM and high temperature control module.

Action

Check for an open circuit.

  • Measure the resistance from the high temperature input SIGNAL pin in the ECM connector harness connector to the high temperature input SIGNAL pin in the high temperature control module connector.
  • Measure the resistance from the high temperature input RETURN pin in the ECM connector harness connector to the high temperature input RETURN pin in the high temperature control module connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 8A

Guided Step 5 - Check the voltage output from the high temperature system temperature control module.

Guided Step 5A - Check the voltage output at the high temperature system temperature control module.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the 24 VDC output at the high temperature system temperature control module CLOSE terminals.

  • Check for 24 VDC output at the high temperature system temperature control module CLOSE terminals. Use a multimeter.

Use the circuit diagram or wiring diagrams for connector and pin identification.

Contact a Cummins® Authorized Repair Location.

Between 20 and 29 VDC?
YES NO
No Repair

Replace the high temperature system temperature control module.

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 8A

Guided Step 5B - Check the voltage input at the high temperature system temperature control CLOSE relay.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the 24 VDC input at the high temperature system temperature control CLOSE relay input terminals.

  • Check for 24 VDC input at the high temperature system temperature control module CLOSE terminals.Use a multimeter.

Use the circuit diagram or wiring diagram for relay termination and pin identification.

Contact a Cummins® Authorized Repair Location.

Between 20 and 29 VDC?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check the high temperature system temperature control module to CLOSE relay harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, and pin, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the interconnect harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 5D

Guided Step 5D - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the high-temperature module output SIGNAL pin in the high temperature module 24 VDC output connector to all other pins in the connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 5E

Go to 8A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for an open circuit.

  • Measure the resistance from the high temperature module 24 VDC output SIGNAL pin in the voltage control harness connector to the high temperature input SIGNAL pin on the high temperature control CLOSE relay connector.
  • Measure the resistance from the high temperature module 24 VDC output RETURN pin on the voltage control harness connector to the high temperature input return pin on the high temperature control CLOSE relay connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the interconnect harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 8A

Guided Step 6 - Check the voltage supply to the high temperature system temperature control valve.

Guided Step 6A - Check the voltage input to the high temperature control valve CLOSE input terminals.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the 120/240 VAC input at the high temperature system temperature control CLOSE valve input terminals.

  • Check for 120/240 VAC input at the high temperature system temperature control CLOSE valve input terminals. Use a multimeter.

Use the circuit diagram or wiring diagrams for termination and pin identification.

Contact a Cummins® Authorized Repair Location.

Voltage output 120/240 VAC?
YES NO
No Repair

Replace the high temperature system temperature control module.

  • Contact a Cummins® Authorized Repair Location.

Go to 6B

Go to 8A

Guided Step 6B - Check the high temperature system temperature control valve is closed.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Manually check the high temperature system temperature control valve (1) is closed.

  • Use the valve manual OPEN/CLOSE turn wheel to check that the high temperature system temperature control valve is closed.

Contact a Cummins® Authorized Repair Location.

High temperature control valve closed?
YES NO
No Repair

Replace the high temperature system control valve.

  • Contact a Cummins® Authorized Repair Location.

Go to 6C

Go to 8A

Guided Step 6C - Check the voltage output at the high temperature system temperature control CLOSE relay.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the 120/240 VAC output at the high temperature system temperature control CLOSE relay output terminals.

  • Check for 120/240 VAC output at the high temperature system temperature control CLOSE relay output terminals. Use a multimeter.

Use the circuit diagram or wiring diagram for relay termination and pin identification.

Contact a Cummins® Authorized Repair Location.

Voltage output 120/240 VAC
YES NO
No Repair

Replace the high-temperature system CLOSE relay.

  • Contact a Cummins® Authorized Repair Location.

Go to 6D

Go to 8A

Guided Step 6D - Check the voltage harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the voltage harness connectors from the high temperature control valve, CLOSE relay, and main circuit breaker.

Action

Inspect the voltage harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, and pin, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the voltage interconnect harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the voltage interconnect harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 6E

Guided Step 6E - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set voltage supply.
  • Disconnect the voltage harness connectors from the high temperature control module, CLOSE relay, and main circuit breaker.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the voltage input connection to the high temperature control valve to all other pins in the VAC harness.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the voltage harness or the harness connector.

  • Repair or replace the voltage interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 6F

Go to 8A

Guided Step 6F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for an open circuit.

  • Measure the resistance from the voltage input SIGNAL pin in the high temperature voltage harness connector to the voltage output SIGNAL pin in the CLOSE relay voltage harness connector.
  • Measure the resistance from the voltage COMMON pin in the high temperature voltage harness connector to the voltage COMMON pin in the main circuit breaker voltage harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the interconnect harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 8A

Guided Step 7 - Check the high temperature cooling system radiator fans.

Guided Step 7A - Check the high temperature cooling system radiator fans control logic.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the high-temperature cooling system radiator fans for the correct operation.

  • If installed, check the operation of the high temperature cooling system radiator fans. Check for control logic versus ambient air temperature (number of fans running/fan speed in low ambient temperatures).
  • Contact a Cummins® Authorized Repair Location.

High temperature radiator fans operating correctly?
YES NO
No Repair

Repair the high temperature cooling system radiator fans.

  • Adjust the high temperature cooling system radiator fans control logic to provide improved radiator fan control/temperature regulation for the ambient conditions.

Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2793 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 144, 145, 1824, 2789, 2869, 2871, or 2872 active?
STEP 2. | Check the high temperature system temperature control module. |
 | STEP 2A. Check the high temperature system temperature control module is powered up. | High temperature control module powered up?
 | STEP 2B. Check the high temperature system temperature control module system for alarms. | High temperature control module displaying system alarms?
STEP 3. | Check the voltage power supply. |
 | STEP 3A. Check the 24 volt power supply to the high temperature system temperature control module. | Between 20 and 29 VDC?
 | STEP 3B. Check the voltage supply fuse. | Less than 10 ohms?
 | STEP 3C. Check the voltage supply harness and connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the temperature input signal. |
 | STEP 4A. Check the 4-20mA input from the engine control module (ECM) to the high temperature system temperature control module. | Input signal between 4 and 20mA?
 | STEP 4B. Check the ECM to high temperature system temperature control module interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the voltage output from the high temperature system temperature control module. |
 | STEP 5A. Check the voltage output at the high temperature system temperature control module. | Between 20 and 29 VDC?
 | STEP 5B. Check the voltage input at the high temperature system temperature control CLOSE relay. | Between 20 and 29 VDC?
 | STEP 5C. Check the high temperature system temperature control module to CLOSE relay interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 5D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the voltage supply to the high temperature system temperature control valve. |
 | STEP 6A. Check the voltage input to the high temperature control valve CLOSE input terminals. | Voltage output 120/240 VAC?
 | STEP 6B. Check the high temperature system temperature control valve is closed. | High-temperature control valve closed?
 | STEP 6C. Check the voltage output at the high temperature system temperature control CLOSE relay. | Voltage output 120 to 240 VAC?
 | STEP 6D. Check the voltage harness and connector pins. | Dirty or damaged pins?
 | STEP 6E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 6F. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the high temperature cooling system radiator fans. |
 | STEP 7A. Check the high temperature cooling system radiator fans control logic. | High temperature radiator fans operating correctly?
STEP 8. | Check ECM calibration code and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144, 145, 1824, 2789, 2869, 2871, or 2872 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the high temperature system temperature control module.

Guided Step 2A - Check the high temperature system temperature control module is powered up.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Energize 24 volt switched and unswitched power supplies.

Action

Check the high temperature system temperature control module is powered up.

  • Check that the high temperature system temperature control module display panel is illuminated.

High temperature control module powered up?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the high temperature system temperature control module for system alarms.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Energize 24 volt switched and unswitched power supplies.

Action

Check the high temperature system temperature control module for system alarms.

  • Use the high temperature system temperature control module display to check for system alarms.

High temperature control module displaying system alarms?
YES NO

Troubleshoot and repair the high temperature control system faults.

  • Troubleshoot and repair the high temperature control system faults as indicated by the alarms displayed on the high temperature control module display.
  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 3A

Guided Step 3 - Check the voltage power display.

Guided Step 3A - Check the 24 volt power supply to the high-temperature system temperature control module.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Energize 24 volt switched and unswitched power supplies.

Action

Check the 24 volt power supply to the high temperature system temperature control module:

  • Check for 24 VDC at the high temperature control module 24 VDC (+), 24 VDC (-), 1A OP1, and 1A OP2 terminals.
  • Use the circuit diagram or wiring diagram for temperature control module termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Between 20 and 29 VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the voltage supply fuse.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Energize 24 volt switch and unswitched power supplies.

Action

Check the 24 volt supply inline fuse.

  • Use a multimeter to check the condition of the inline fuse.

Use the circuit diagram or wiring diagram for fuse designation and rating.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 8A

Guided Step 3C - Check the voltage and supply harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the voltage power supply and high temperature control module.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pin, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 3D

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the voltage isolator switch and high temperature control module voltage input terminals.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the voltage isolator switch 24 volt SUPPLY pin in the ECM connector to all other pins in the voltage harness.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 3E

Go to 8A

Guided Step 3E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the voltage isolator switch and high temperature control module voltage input terminals.

Action

Check for an open circuit.

  • Measure the resistance from the voltage isolator SUPPLY pin in the voltage harness connector to the voltage input SUPPLY pin in the high temperature controller voltage connector.
  • Measure the resistance from the voltage isolator RETURN pin in the voltage harness connector to the voltage input RETURN pin in the high temperature controller voltage connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 8A

Guided Step 4 - Check the temperature input signal.

Guided Step 4A - Check the 4-20mA input from the ECM to the high temperature system temperature control module.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the high-temperature 4-20mA signal from the ECM to the high temperature control module.

  • Connect an ammeter in series with 4-20mA positive wire running between the ECM and the high temperature control module.

Use the circuit diagram or wiring diagrams for termination and pin identification.

Contact a Cummins® Authorized Repair Location.

Input signal between 4 and 20mA?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM to high temperature system temperature control module interconnect harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the ECM and high temperature control module.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pin, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 4C

Guided Step 4C - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the ECM and high temperature control module.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the ECM high temperature input SIGNAL pin in the ECM connector to all other pins in the ECM connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM to high emperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4D

Go to 8A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the ECM and high temperature control module.

Action

Check for an open circuit.

  • Measure the resistance from the high temperature input SIGNAL pin in the ECM connector harness connector to the high temperature input SIGNAL pin in the high temperature control module connector.
  • Measure the resistance from the high temperature input RETURN pin in the ECM connector harness connector to the high temperature input RETURN pin in the high temperature control module connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 8A

Guided Step 5 - Check the voltage output from the high temperature system temperature control module.

Guided Step 5A - Check the voltage output at the high temperature system temperature control module.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the 24 VDC output at the high temperature system temperature control module CLOSE terminals.

  • Check for 24 VDC output at the high temperature system temperature control module CLOSE terminals. Use a multimeter.

Use the circuit diagram or wiring diagrams for connector and pin identification.

Contact a Cummins® Authorized Repair Location.

Between 20 and 29 VDC?
YES NO
No Repair

Replace the high temperature system temperature control module.

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 8A

Guided Step 5B - Check the voltage input at the high temperature system temperature control CLOSE relay.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the 24 VDC input at the high temperature system temperature control CLOSE relay input terminals.

  • Check for 24 VDC input at the high temperature system temperature control module CLOSE terminals. Use a multimeter.

Use the circuit diagram or wiring diagram for relay termination and pin identification.

Contact a Cummins® Authorized Repair Location.

Between 20 and 29 VDC?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check the high temperature system temperature control module to CLOSE relay harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, and pin, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the interconnect harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 5D

Guided Step 5D - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the high temperature module output SIGNAL pin in the high temperature module 24 VDC output connector to all other pins in the connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 5E

Go to 8A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for an open circuit.

  • Measure the resistance from the high temperature module 24 VDC output SIGNAL pin in the voltage control harness connector to the high temperature input SIGNAL pin on the high temperature control CLOSE relay connector.
  • Measure the resistance from the high temperature module 24 VDC output RETURN pin on the voltage control harness connector to the high temperature input return pin on the high temperature control CLOSE relay connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the interconnect harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 8A

Guided Step 6 - Check the voltage supply to the high temperature system temperature control valve.

Guided Step 6A - Check the voltage input to the high temperature control valve CLOSE input terminals.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the 120/240 VAC input at the high temperature system temperature control CLOSE valve input terminals.

  • Check for 120/240 VAC input at the high temperature system temperature control CLOSE valve input terminals. Use a multimeter.

Use the circuit diagram or wiring diagrams for termination and pin identification.

Contact a Cummins® Authorized Repair Location.

Voltage output 120/240 VAC?
YES NO
No Repair

Replace the high temperature system temperature control module.

  • Contact a Cummins® Authorized Repair Location.

Go to 6B

Go to 8A

Guided Step 6B - Check the high temperature system temperature control valve is closed.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Manually check the high temperature system temperature control valve (1) is closed.

  • Use the valve manual OPEN/CLOSE turn wheel to check that the high temperature system temperature control valve is closed.

Contact a Cummins® Authorized Repair Location.

High-temperature control valve closed?
YES NO
No Repair

Replace the high temperature system control valve.

  • Contact a Cummins® Authorized Repair Location.

Go to 6C

Go to 8A

Guided Step 6C - Check the voltage output at the high temperature system temperature control CLOSE relay.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the 120/240 VAC output at the high temperature system temperature control CLOSE relay output terminals.

  • Check for 120/240 VAC output at the high temperature system temperature control CLOSE relay output terminals. Use a multimeter.

Use the circuit diagram or wiring diagram for relay termination and pin identification.

Contact a Cummins® Authorized Repair Location.

Voltage output 120/240 VAC
YES NO
No Repair

Replace the high-temperature system CLOSE relay.

  • Contact a Cummins® Authorized Repair Location.

Go to 6D

Go to 8A

Guided Step 6D - Check the voltage harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the voltage harness connectors from the high temperature control valve, CLOSE relay, and main circuit breaker.

Action

Inspect the voltage harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, and pin, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the voltage interconnect harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the voltage interconnect harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 8A

Go to 6E

Guided Step 6E - Check for a pin-to-pin short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set voltage supply.
  • Disconnect the voltage harness connectors from the high temperature control module, CLOSE relay, and main circuit breaker.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the voltage input connection to the high temperature control valve to all other pins in the VAC harness.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the voltage harness or the harness connector.

  • Repair or replace the voltage interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 6F

Go to 8A

Guided Step 6F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for an open circuit.

  • Measure the resistance from the voltage input SIGNAL pin in the high temperature voltage harness connector to the voltage output SIGNAL pin in the CLOSE relay voltage harness connector.
  • Measure the resistance from the voltage COMMON pin in the high temperature voltage harness connector to the voltage COMMON pin in the main circuit breaker voltage harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the interconnect harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 8A

Guided Step 7 - Check the high temperature cooling system radiator fans.

Guided Step 7A - Check the high temperature cooling system radiator fans control logic.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for longer than 1 minute.

Action

Check the high-temperature cooling system radiator fans for the correct operation.

  • If installed, check the operation of the high temperature cooling system radiator fans. Check for control logic versus ambient air temperature (number of fans running/fan speed in low ambient temperatures).
  • Contact a Cummins® Authorized Repair Location.

High-temperature radiator fans operating correctly?
YES NO
No Repair

Repair the high temperature cooling system radiator fans.

  • Adjust the high temperature cooling system radiator fans control logic to provide improved radiator fan control/temperature regulation for the ambient conditions.

Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2796 - Generator Electrical Load Signal - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the generator set with PowerCommand™ Supervisor and generator set with PCC3300. |
 | STEP 1A. Read the PowerCommand™ Supervisor and PCC3300 fault codes. | Active fault code a PowerCommand™ Supervisor?
STEP 2. | Check the kilowatt accuracy. |
 | STEP 2A. Verify the kilowatt load demanded by the parallel controller is not above the generator set limits. | Kilowatt load command below set limits?
STEP 3. | Check the ECM value. |
 | STEP 3A. Verify the fault simulation feature for the kilowatt overload is not enabled. | Fault simulation disabled?
STEP 4. | Check the current transformers. |
 | STEP 4A. Inspect the current transformers and current transformer connections. | Dirty or damaged pins?
 | STEP 4B. Check the AC harness. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Check the PT/CT board. |
 | STEP 5A. Check the PT/CT board 3 ohm resistors. | Resistors good?
 | STEP 5B. Inspect the PT/CT board and the generator control harness connector pins. | Dirty of damaged pins?
STEP 6. | Check the generator control harness. |
 | STEP 6A. Inspect the generator control harness and the ECM connector pins. | Dirty of damaged pins?
 | STEP 6B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 6C. Check for an open circuit in the generator control harness. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 7B. Verify the fault code is inactive. | Fault Code 2796 inactive?
STEP 8. | Check the fault codes. |
 | STEP 8A. Check the ECM for active fault codes. | Fault Code 2796 active?
STEP 9. | Check the kilowatt accuracy. |
 | STEP 9A. Verify the kilowatt load demanded by the parallel controller is not above the generator set limits. | Kilowatt load command below set limits?
STEP 10. | Check the ECM value. |
 | STEP 10A. Verify the fault simulation feature for the kilowatt overload is not enabled. | Fault simulation disabled?
STEP 11. | Check the current transformers. |
 | STEP 11A. Inspect the current transformers and current transformer connections. | Dirty or damaged pins?
 | STEP 11B. Check the AC harness. | Dirty or damaged pins?
 | STEP 11C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 11D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 12. | Check the generator control harness. |
 | STEP 12A. Inspect the generator control harness and the ECM connector pins. | Dirty of damaged pins?
 | STEP 12B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 12C. Check for an open circuit in the generator control harness. | Less than 10 ohms?
 | STEP 12D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 13. | Check the ECM calibration and clear the fault codes. |
 | STEP 13A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 13B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the generator set with PowerCommand™ Supervisor and generator set with PCC3300.

Guided Step 1A - Read the PowerCommand™ Supervisor and PCC3300 fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code.

Verify whether fault code PowerCommand™ Supervisor or PCC3300 are active.

Active fault code a PowerCommand™ Supervisor?
YES NO
No Repair

This is a PCC3300 fault code. Begin troubleshooting at Guided Step 8A.

Go to 1A

Go to 8A

Guided Step 2 - Check the kilowatt accuracy.

Guided Step 2A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Kilowatt load command below set limits?
YES NO
No Repair

  • See customer/facility/installation documentation.

Go to 3A

Go to 7A

Guided Step 3 - Check the ECM value.

Guided Step 3A - Verify the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify the fault simulation feature for the kilowatt overload is not enabled.

Fault simulation disabled?
YES NO
No Repair

  • Kilowatt overload is enabled. See customer/facility/installation documentation.

Go to 4A

Go to 7A

Guided Step 4 - Check the current transformers.

Guided Step 4A - Inspect the current transformers and current transformer connections.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

 No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the AC harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or replace the AC harness and/or PT/CT board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.
  • Replace the PT/CT Board.

 No Repair

Go to 7A

Go to 4C

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT board connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

Go to 4D

Go to 7A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

Go to 4A

Go to 7A

Guided Step 5 - Check the PT/CT board.

Guided Step 5A - Check the PT/CT board 3 ohm resistors.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT Board.

Action

Verify the 3 ohm resistors from PT/CT board connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistors good?
YES NO
No Repair

Replace the PT/CT board.

Go to 5B

Go to 7A

Guided Step 5B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the generator control harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the generator control, ECM, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the generator set parallel board.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the generator control harness.

Guided Step 6A - Inspect the generator control harness and the ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the ECM.

Action

Inspect the generator control harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the genset or parallel board. See wiring diagram for appropriate board.

 No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness ECM connector to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the PT/CT board. See wiring diagram for appropriate board.

Go to 6C

Go to 7A

Guided Step 6C - Check for an open circuit in the generator control harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness PT/CT board connector to the aligned generator control harness ECM connector pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.

Go to 6D

Go to 7A

Guided Step 6D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each pin on the generator control harness ECM connector to all other pins on the generator control harness ECM connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

  • Troubleshoot any remaining active fault codes.

Go to 7B

Go to the appropriate troubleshooting steps.

Guided Step 7B - Verify the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2796 is inactive.

Fault Code 2796 inactive?
YES NO
No Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 8 - Check the fault codes.

Guided Step 8A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2796 active?
YES | NO
No Repair | No Repair

Go to 9A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 9 - Check the kilowatt accuracy.

Guided Step 9A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Kilowatt load command below set limits?
YES NO
No Repair

  • See customer/facility/installation documentation.

Go to 10A

Go to 13A

Guided Step 10 - Check the ECM value.

Guided Step 10A - Verify the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify the fault simulation feature for the kilowatt overload is not enabled.

Fault simulation disabled?
YES NO
No Repair

  • Kilowatt overload is enabled. See customer/facility/installation documentation.

Go to 11A

Go to 13A

Guided Step 11 - Check the current transformers.

Guided Step 11A - Inspect the current transformers and current transformer connections.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

 No Repair

Go to 13A

Go to 11B

Guided Step 11B - Check the AC harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or replace the AC harness and/or PT/CT board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.
  • Replace the PT/CT board.

 No Repair

Go to 13A

Go to 11C

Guided Step 11C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT board connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

Go to 11D

Go to 13A

Guided Step 11D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness.

Go to 12A

Go to 13A

Guided Step 12 - Check the generator control harness.

Guided Step 12A - Inspect the generator control harness and the ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the ECM.

Action

Inspect the generator control harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the genset or parallel board. See wiring diagram for appropriate board.

 No Repair

Go to 13A

Go to 12B

Guided Step 12B - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness ECM connector to engine block ground.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness.
  • Replace the PT/CT board. See wiring diagram for appropriate board.

Go to 6C

Go to 13A

Guided Step 12C - Check for an open circuit in the generator control harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness PT/CT board connector to the aligned generator control harness ECM connector pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.

Go to 12D

Go to 13A

Guided Step 12D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the ECM.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each pin on the generator control harness ECM connector to all other pins on the generator control harness ECM connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 13A

Go to 13A

Guided Step 13 - Check ECM calibration and clear fault codes.

Guided Step 13A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 13B

Go to 13B

Guided Step 13B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2799 - Engine Turbocharger 1 Boost Pressure - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air/Fuel Mixer | Refer to Procedure 005-003 | QSK60 G CM2358 K110 | 4383781
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781
Aftercooler | Refer to Procedure 010-001 | QSK60 G CM2358 K110 | 4383781
Air Cleaner Element | Refer to Procedure 010-014 | QSK60 G CM2358 K110 | 4383781
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Turbocharger Compressor Bypass Control Valve | Refer to Procedure 010-136 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2799 active?
STEP 2. | Inspect intake air filters for excessive restriction. |
 | STEP 2A. Check air filter restriction. | Restriction present?
STEP 3. | Inspect the air/fuel mixer for damage. |
 | STEP 3A. Inspect the air/fuel mixer for damage. | Damage found?
STEP 4. | Inspect the turbocharger for damage. |
 | STEP 4A. Inspect the turbocharger for damage. | Damage or out of specification found?
STEP 5. | Inspect the charge-air system for damage. |
 | STEP 5A. Inspect the charge-air system for visible damage. | Damage found?
 | STEP 5B. Inspect charge-air system for leaks. | Leaks found?
STEP 6. | Inspect the throttle and throttle mounting flange. |
 | STEP 6A. Inspect the throttle driver and engine harness electrical connections. | Dirty or damaged pins?
 | STEP 6B. Inspect the throttle for damage. | Damage or misalignment found?
 | STEP 6C. Inspect the throttle mounting flange for leaking or cracks. | Leaks or cracks found?
STEP 7. | Check ECM calibration code and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2799 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Inspect the intake air filters for excessive restriction.

Guided Step 2A - Check air filter restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air filter restriction or damage that can cause excessive restriction.

Restriction present?
YES NO

  • Inspect and/or replace the air cleaner elements. Refer to Procedure 010-014 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Inspect the air/fuel mixer for damage.

Guided Step 3A - Inspect the air/fuel mixer for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Refer to Procedure 005-003 in the Associated Procedures Table.

Damage found?
YES NO

Replace the air/fuel mixer. Refer to Procedure 005-003 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Inspect the turbocharger for damage.

Guided Step 4A - Inspect the turbocharger for damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Refer to Procedure 005-003 in the Associated Procedures Table.

Damaged or out of specification found?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Inspect the charge-air system for damage.

Guided Step 5A - Inspect the charge-air system for visible damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for damage.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

Damage found?
YES NO

Repair or replace the damaged component.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-136 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Inspect the charge-air system for leaks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the charge-air ducting, compressor bypass circuit and aftercooler for leaks.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

Leaks found?
YES NO

Repair or replace the damaged component.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-136 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspect the throttle and throttle mounting flange.

Guided Step 6A - Inspect the throttle driver and engine harness electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the throttle driver connectors and the engine harness connectors and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the engine harness or the throttle driver assembly, whichever has the dirty or damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 7A

Go to 6B

Guided Step 6B - Inspect the throttle for damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the throttle for damage.

Check the throttle for damage, valve misalignment, and freedom of valve rotational movement.

Damage or misalignment found?
YES NO

Repair or replace the throttle body assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6C

Guided Step 6C - Inspect the throttle mounting flange for leaking or cracks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the throttle mounting flange for leaking or cracks.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Leaks or cracks found?
YES NO

Repair or replace the throttle body assembly. Refer to Procedure 010-024 in the Associated Procedures Table.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2811 - Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air/Fuel Mixer | Refer to Procedure 005-003 | QSK60 G CM2358 K110 | 4383781
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781
Aftercooler | Refer to Procedure 010-001 | QSK60 G CM2358 K110 | 4383781
Air Cleaner Element | Refer to Procedure 010-014 | QSK60 G CM2358 K110 | 4383781
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK60 G CM2358 K110 | 4383781
Turbocharger | Refer to Procedure 010-033 | QSK60 G CM2358 K110 | 4383781
Turbocharger Compressor Bypass Control Valve | Refer to Procedure 010-136 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2811 active?
STEP 2. | Inspect intake air filters for excessive restriction. |
 | STEP 2A. Check air filter restriction. | Restriction present?
STEP 3. | Inspect the air/fuel mixer for damage. |
 | STEP 3A. Inspect the air/fuel mixer for damage. | Damage found?
STEP 4. | Inspect the turbocharger for damage. |
 | STEP 4A. Inspect the turbocharger for damage. | Damage or out of specification found?
STEP 5. | Inspect the charge-air system for damage. |
 | STEP 5A. Inspect the charge-air system for visible damage. | Damage found?
 | STEP 5B. Inspect the charge-air system for leaks. | Leaks found?
STEP 6. | Inspect throttle and throttle mounting flange. |
 | STEP 6A. Inspect the throttle driver and engine harness electrical connections. | Dirty or damaged pins?
 | STEP 6B. Inspect the throttle for damage. | Damage or misalignment found?
 | STEP 6C. Inspect the throttle mounting flange for leaking or cracks. | Leaks or cracks found?
STEP 7. | Check ECM calibration code and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service. tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2811 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Inspect the intake air filters for excessive restriction.

Guided Step 2A - Check air filter restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air filter restriction or damage that can cause excessive restriction.

Restriction present?
YES NO

  • Inspect and/or replace the air cleaner elements. Refer to Procedure 010-014 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Inspect the air/fuel mixer for damage.

Guided Step 3A - Inspect the air/fuel mixer for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Refer to Procedure 005-003 in the Associated Procedures Table.

Damage found?
YES NO

Replace the air/fuel mixer. Refer to Procedure 005-003 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Inspect the turbocharger for damage.

Guided Step 4A - Inspect the turbocharger for damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Refer to Procedure 005-003 in the Associated Procedures Table.

Damage or out of specification found?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Inspect the charge-air system for damage.

Guided Step 5A - Inspect the charge-air system for visible damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for damage.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

Damage found?
YES NO

Repair or replace the damaged component.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-136 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5B

Guided Step 5B - Inspect the charge-air system for leaks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for leaks.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

Leaks found?
YES NO

Repair or replace the damaged component.

  • Refer to Procedure 010-024 in the Associated Procedures Table.
  • Refer to Procedure 010-136 in the Associated Procedures Table.
  • Refer to Procedure 010-001 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspect the throttle and throttle mounting flange.

Guided Step 6A - Inspect the throttle driver and engine harness electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the throttle driver connectors and the engine harness connectors and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair or replace the engine harness or the throttle driver assembly, whichever has the dirty or damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 7A

Go to 6B

Guided Step 6B - Inspect throttle for damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect throttle for damage.

Check the throttle for damage, valve misalignment, and freedom of valve rotational movement.

Damage or misalignment found?
YES NO

Repair or replace the throttle body assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6C

Guided Step 6C - Inspect the throttle mounting flange for leaking or cracks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the throttle mounting flange for leaking or cracks.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Leaks or cracks found?
YES NO

Repair or replace the throttle body assembly. Refer to Procedure 010-024 in the Associated Procedures Table.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2812 - Engine Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

There may be other generator set fault codes activated as a result of Fault Code 2812 being triggered. To avoid the possibility of damaging a new digital throttle assembly, all other active fault codes must be investigated and rectified before replacing the digital throttle assembly.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 441 or 442 active?
 | STEP 1B. Check for fault codes. | Fault Codes 412, 414, 426, 427, and/or 781 active?
 | STEP 1C. Check for fault codes. | Fault Codes 1761, 686, and/or 4621 active?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check engine control module (ECM) calibration code and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes or high counts of inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Code 441 or 442 active?
YES NO
No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes or high counts of inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 412, 414, 426, 427, and/or 781 active?
YES NO
No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes or high counts of inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 1761, 686, and/or 4621 active?
YES NO
No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test.

Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Replace the digital throttle assembly. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Jun-2015


FAULT CODE 2837 - Exhaust Gas Temperature Cylinder 1 (A1) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2469, 2766, 2484, 641, 1618, and/or 2121 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2837 inactive, Fault Code 2838 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 1 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 1 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2469, 2766, 2484, 641, 1618, and/or 2121 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.

Perform these checks on all interconnectingharness connectors in the circuit.

Refer to the wiring diagram toidentifyconnectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2837 inactive and Fault Code 2838 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 1.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 1 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 1 overhead setting is correct.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 1 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2838 - Exhaust Gas Temperature Cylinder 3 (A2) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2471, 2766, 2485, 642, 1521 and/or 2122 active?
STEP 2. | Check the spark plug on cylinder 3. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2837 inactive, Fault Code 2838 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 3 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 3 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2471, 2766, 2485, 642, 1521 and/or 2122 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 3.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?

YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 3.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2837 inactive and Fault Code 2838 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 3 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 3.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 3 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 3 overhead setting is correct.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 3 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2839 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2472, 2766, 2486, 643, 1522, and/or 2123 active?
STEP 2. | Check the spark plug on cylinder 5. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2839 inactive, Fault Code 2841 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 5 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 5 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read thefault codes.

Fault Code 2472, 2766, 2486, 643, 1522, and/or 2123 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 5.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 5.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.

Perform these checks on all interconnectingharness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 5 and 7.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2839 inactive and Fault Code 2841 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 5.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 5 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 5 overhead setting is correct.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 5 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2841 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2473, 2766, 2487, 644, 1523, and/or 2124 active?
STEP 2. | Check the spark plug on cylinder 7. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2841 inactive, Fault Code 2839 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 7 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 7 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2473, 2766, 2487, 644, 1523, and/or 2124 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 7.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 7.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 7 and 5.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2841 inactive and Fault Code 2839 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 7 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 7.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 7 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check that the cylinder 7 overhead setting is correct.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 7 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2842 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2475, 2766, 2488, 645, 1524, and/or 2125 active?
STEP 2. | Check the spark plug on cylinder 9. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2842 inactive, Fault Code 2843 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 9 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 9 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2475, 2766, 2488, 645, 1524, and/or 2125 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 9.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 9.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 9 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 9 and 11.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2842 inactive and Fault Code 2843 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 9.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 9 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 9 overhead setting is correct.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 9 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2843 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2476, 2766, 2489, 646, 1525, and/or 2126 active?
STEP 2. | Check the spark plug on cylinder 11. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2843 inactive, Fault Code 2842 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 11 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 11 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2476, 2766, 2489, 646, 1525, and/or 2126 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 11.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 11.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 11 and 9.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2843 is inactive and Fault Code 2842 is active.

Fault Code 2843 inactive and Fault Code 2842 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 11.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 11 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 11 overhead setting is correct.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 11 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2844 - Exhaust Gas Temperature Cylinder 13 (A7) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2477, 2766, 2491, 647, 1526 and/or 2127 active?
STEP 2. | Check the spark plug on cylinder 13. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 13. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2844 inactive and Fault Code 2845 active?
 | STEP 4B. Check the 5 VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25 VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 13 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 13 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2844 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2477, 2766, 2491, 647, 1526 and/or 2127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 13.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 13.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 13 and 15.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and command the engine to operate on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2843 is inactive and Fault Code 2842 is active.

Fault Code 2844 inactive and Fault Code 2845 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5 VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 13.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 VOLT SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 13 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 13 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 13 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head - intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. See equipment manufacturer service information.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troublshooting procedure.

Fault Code 2844 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2845 - Exhaust Gas Temperature Cylinder 15 (A8) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2478, 2766, 2492, 648, 1527 and/or 2128 active?
STEP 2. | Check the spark plug on cylinder 15. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 15. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2845 inactive and Fault Code 2844 active?
 | STEP 4B. Check the 5 VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25 VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 15 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 15 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2845 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2478, 2766, 2492, 648, 1527 and/or 2128 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 15.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 15.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins.

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 15 and 13.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and command the engine to operate on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2845 is inactive and Fault Code 2844 is active.

Fault Code 2845 inactive and Fault Code 2844 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5 VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 15.
  • See the wiring diagram for harness termination and location.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 VOLT SUPPLY pin in the exhaust gas temperature sensor connector
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 15 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 13 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 15 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head - intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2845 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2847 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2458, 2766, 2494, 652, 1529 and/or 2131 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 2. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2847 inactive, Fault Code 2848 active?
 | STEP 4B. Check the 5 VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25 VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 2 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 2 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2847 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2458, 2766, 2494, 652, 1529 and/or 2131 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the correct torque specification.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 2.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 2 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 2 and 4.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and command the engine to operate on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2847 is inactive and Fault Code 2848 is active.

Fault Code 2847 inactive and Fault Code 2448 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5 VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 2.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 2 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 2 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 2 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head - intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. See equipment manufacturer service information. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2847 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2848 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2459, 2766, 2495, 653, 1619 and/or 2132 active?
STEP 2. | Check the spark plug on cylinder 4. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 4. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2848 inactive, Fault Code 2847 active?
 | STEP 4B. Check the 5 VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25 VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 4 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 4 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2848 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2459, 2766, 2495, 653, 1619 and/or 2132 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 4.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the correct torque specification.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 4.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 4 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 4 and 2.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2848 is inactive and Fault Code 2847 is active.

Fault Code 2848 inactive and Fault Code 2447 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5 VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 4.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 4 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 4 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 4 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head - intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2848 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2849 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2461, 2766, 2496, 654, 1531, and/or 2133 active?
STEP 2. | Check the spark plug on cylinder 6. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 6. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2849 inactive, Fault Code 2851 active?
 | STEP 4B. Check the 5 VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25 VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 6 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 6 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2849 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2461, 2766, 2496, 654, 1531, and/or 2133 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 6.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 6.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 6 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 6 and 8.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 013-016 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2848 is inactive and Fault Code 2847 is active.

Fault Code 2849 inactive and Fault Code 2851 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5 VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 6.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 6 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 4 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 6 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2849 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2851 - Exhaust Gas Temperature Cylinder 8 (B4) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2462, 2766, 2497, 655, 1532, and/or 2134 active?
STEP 2. | Check the spark plug on cylinder 8. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 8. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2851 inactive, Fault Code 2849 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 8 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 8 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2851 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2462, 2766, 2497, 655, 1532, and/or 2134 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 8.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the correct torque specification.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 8.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 8 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 8 and 6.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and operate the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2848 is inactive and Fault Code 2847 is active.

Fault Code 2851 inactive and Fault Code 2849 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 8.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 8 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 8 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 8 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head - intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2851 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2852 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2463, 2766, 2498, 656, 1533, and/or 2135 active?
STEP 2. | Check the spark plug on cylinder 10. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 10. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2852 inactive, Fault Code 2853 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 10 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 10 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2852 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2463, 2766, 2498, 656, 1533, and/or 2135 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 10.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the correct torque specification.
  • Replace the spark plug. Refer to Procedure 013-016 in Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 10.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 10 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 10 and 12.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Associated Procedures Table.

Start the engine and operate the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2852 is inactive and Fault Code 2853 is active.

Fault Code 2852 inactive and Fault Code 2853 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 10.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 10 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 10 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 10 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head - intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2852 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2853 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2464, 2766, 2499, 657, 1534, and/or 2136 active?
STEP 2. | Check the spark plug on cylinder 12. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 12. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2853 inactive, Fault Code 2852 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 12 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 12 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2853 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2464, 2766, 2499, 657, 1534, and/or 2136 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 12.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 12.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 12 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 12 and 10.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and operate the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2853 is inactive and Fault Code 2852 is active.

Fault Code 2853 inactive and Fault Code 2852 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 12 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 12.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 12 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 12 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 12 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head - intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2853 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2854 - Exhaust Gas Temperature Cylinder 14 (B7) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2465, 2766, 2511, 658, 1535, and/or 2137 active?
STEP 2. | Check the spark plug on cylinder 14. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 14. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2854 inactive, Fault Code 2855 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 14 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 14 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2854 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2465, 2766, 2511, 658, 1535, and/or 2137 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 14.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 14.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 14 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 14 and 16.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and operate the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2854 is inactive and Fault Code 2855 is active.

Fault Code 2854 inactive and Fault Code 2855 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in the Associated Procedures Table

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 14.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-013 in the Associated Procedures Table

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-013 in the Associated Procedures Table

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 14 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 14 overhead setting is correct.

Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 14 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head - intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2854 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2855 - Exhaust Gas Temperature Cylinder 16 (B8) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2466, 2766, 2512, 2144, 1536 and/or 2138 active?
STEP 2. | Check the spark plug on cylinder 16. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 16. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2855 inactive, Fault Code 2854 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 16 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 16 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2855 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2466, 2766, 2512, 2144, 1536 and/or 2138 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 16.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug contaminated or damaged?
YES NO

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap incorrect?
YES NO

Replace the spark plug.

  • Refer to Procedure 013-016 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 16.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 16 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 16 and 14.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in the Associated Procedures Table.

Start the engine and command the engine to perform on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to that check Fault Code 2855 is inactive and Fault Code 2854 is active.

Fault Code 2855 inactive and Fault Code 2854 active?
YES NO
No Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 VOLT SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 16.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM2358 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM2358 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM2358 module connector to all other pins in the CM2358 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM2358 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM2358 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM2358 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 VOLT SUPPLY pin in the engine harness CM2358 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 16 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the cylinder 16 overhead setting is correct.

  • Refer to Procedure 003-006 in the Associated Procedures Table.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 16 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head intake or exhaust valve / valve seat for any damage.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Repair as necessary:

  • Replace the cylinder head.
  • Refer to Procedure 002-004 in the Associated Procedures Table.

Adjust the overhead setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine for more than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2855 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 2857 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Turbocharger Speed Sensor | Refer to Procedure 019-390 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an intermittent fault condition. |
 | STEP 1A. Operate the engine at rated speed to check for fault activation. | Fault Code 2857 active?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 450 and 800 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Fault Code 2857 becomes active during engine operation?
STEP 5. | Check ECM calibration code and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for an intermittent fault condition.

Guided Step 1A - Operate the engine at rated speed to check for fault activation.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at rated speed to check for fault activation.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2857 active?
YES NO
No Repair

An intermittent fault condition exists. The problem can be with the turbocharger speed sensor circuit.

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for a damaged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, engine harness connector, and turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Connector or pigtail harness damaged?
YES NO

A damaged connection has been detected in the turbocharger speed sensor or engine harness connector.

Repair or replace the damaged connector or turbocharger speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-390 in the Associated Procedures Table.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor.

Action

Measure the turbocharger speed sensor resistance.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

  • See the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 450 and 800 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor.

Action

Check for a short circuit to ground in the turbocharger speed sensor.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

  • See the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector, or pins, if possible.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Disconnect the engine harness from the ECM.

Action

Check the turbocharger speed sensor circuit continuity.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

Note: The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

  • See the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

  • Repair or replace the engine harness or connector(s).
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short to ground in the engine harness.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

  • See the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a pin-to-pin short in the engine harness.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

  • See the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short between pins of the engine harness.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at idle or high idle to check for fault activation.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Connect the engine harness to the ECM.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle.

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for greater than 1 minute.

Fault Code 2857 becomes active during engine operation?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

  • An intermittent fault condition exists. The problem can exist in the turbocharger speed sensor circuit.
  • Be certain the ECM and chassis grounds are in good condition.

Go to 5A

Refer to Procedure 019-362 in Section 19.

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2863 - Engine ECM to Power Command Controller (PCC) Communication - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Data link Circuit, Proprietary | Refer to Procedure 019-417 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2863 active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 2863 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2863 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the engine harness and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Use the following procedure for data link circuit. Refer to Procedure 019-417 in the Associated Procedures Table.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or ECM.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for the data link circuit. Refer to Procedure 019-417 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

NOTE: Press the “RESET” button on the panel. This will clear all the inactive fault codes as well as key cycle the engine.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Faults Code" found in the Overview section of this troubleshooting procedure.

Fault Code 2863 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 21-Jul-2015


FAULT CODE 2864 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve (FSOV), NG | Refer to Procedure 005-044 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the fuel shutoff valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel shutoff valve supply voltage. | Supply voltage 18 to 27.6 VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for ECM response. |
 | STEP 4A. Check for the appropriate ECM response. | Fault Code 2864 inactive?
STEP 5. | Check ECM calibration code and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES NO

Go to the appropriate fault code troubleshooting tree.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the fuel shutoff valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the fuel shutoff valve and the harness for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the damaged pins.

Repair or replace the fuel shutoff valve harness or replace the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Contact a Cummins® Authorized Repair Location.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 005-044 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel shutoff valve supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Crank engine.
  • Disconnect the main engine harness from the fuel shutoff valve.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Connect the multimeter test leads to the fuel shutoff valve SUPPLY and RETURN pins in the gas valve harness connector. Check the supply voltage. Contact a Cummins® Authorized Repair Location.

Supply voltage 18 to 27.6 VDC?
YES NO
No Repair

Check the 24 VDC power supply, power supply connections, and fuses in the harness. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the fuel shutoff valve and ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the fuel shutoff valve harness or the appropriate extension harness. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the harness from the fuel control valve and ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin in the ECM connector to all other pins in the connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin in the ECM connector to all other pins in the connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness or harness connector.

  • Repair the appropriate wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness or appropriate wiring harness extension. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the harness from the fuel shutoff valve and ECM.

Action

Check for an open circuit in the SUPPLY and RETURN wires.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin in the fuel shutoff valve connector to the fuel shutoff valve SUPPLY pin in the ECM module connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin in the fuel shutoff valve connector to the fuel shutoff valve RETURN pin in the ECM module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness or the harness extension.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness or appropriate wiring harness extension. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for ECM response.

Guided Step 4A - Check for the appropriate ECM response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and crank engine.
  • Disconnect the engine harness connector from the fuel shutoff valve.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Install a jumper wire to the fuel shutoff valve relays. Crank the engine.
  • Use the circuit diagram or wiring diagram for connector pin and relay identification.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2864 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-May-2015


FAULT CODE 2868 - Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Nmae | Bulletin Number
Coolant Heater | Refer to Procedure 008-011 | QSK60 G CM2358 K110 | 4383781
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2868 active?
STEP 2. | Check the engine coolant level. |
 | STEP 2A. Check the coolant level. | Coolant level low?
STEP 3. | Check the engine coolant temperature sensor and sensor circuit. |
 | STEP 3A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the engine coolant temperature sensor. | 600 ohms to 36k ohm?
 | STEP 3C. Check for short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
STEP 4. | Check the coolant heater thermostat. |
 | STEP 4A. Inspect the harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check thermostat performance. | Within specifications?
STEP 5. | Check the control contactor. |
 | STEP 5A. Inspect the harness and connections. | Dirty, damaged, or loose connections?
 | STEP 5B. Check the coil supply voltage. | 23 to 26 VDC?
 | STEP 5C. Check the contactor performance. | Within specifications?
STEP 6. | Check the ECM calibration and clear the fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2868 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the engine coolant level.

Guided Step 2A - Check the coolant level.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the level of the coolant.

  • Refer to Procedure 008-066 in Section 3 in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782.

Coolant level low?
YES NO

Add coolant to the appropriate level.

  • Refer to Procedure 008-066 in Section 3 in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the engine coolant temperature sensor and sensor circuit.

Guided Step 3A - Inspect the sensor and harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Inspect the engine harness connector and sensor pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine coolant temperature sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the resistance of the engine coolant temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL and RETURN pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

600 ohms to 36k ohms?
YES NO
No Repair

  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Check for short-circuit to ground.

  • Measure the resistance from each pin of the coolant temperature sensor to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine coolant temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100 ohms?
YES NO
No Repair

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 6A

Guided Step 3E - Check the sensor supply voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the engine coolant temperature sensor supply voltage.

  • Measure the supply voltage at the engine coolant temperature sensor connector SUPPLY pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general voltage measurement techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the coolant heater thermostat.

Guided Step 4A - Inspect the harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Inspect the thermostat connector and pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the connector or heater.

  • Replace the connector. Refer to Procedure 019-206 in Section 19.
  • Replace the coolant heater. Refer to Procedure 008-011 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check thermostat performance.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check thermostat performance.

  • Use INSITE™ electronic service tool to read the coolant temperature.
  • With the engine coolant temperature below 127°C [260°F], measure the resistance of the thermostat.
  • After measurement, enable the engine coolant heater. If engine coolant temperature exceeds 127°C [260°F], measure the resistance of the thermostat again.
  • Coolant temperature less than 127°C [260°F], resistance less than 10 ohms
  • Coolant temperature greater than 127°C [260°F], resistance greater than 10 ohms.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within specifications?
YES NO
No Repair

Repair or replace the thermostat or heater.

  • Replace the thermostat.
  • Replace the heater. Refer to Procedure 018-011 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check the control connector.

Guided Step 5A - Inspect the harness and connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect contactor KM1 harness and connections for:

  • Loose connections
  • Moisture in or on the connections
  • Dirt or debris in or on the connections
  • Wire insulation damage.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, damaged, or loose connections?
YES NO

Repair the harness or connections as needed by:

  • Securing connection terminations
  • Replacing wire segments with damage.

Replace KM1 contactor.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections.
  • Restore voltage supply to generator interface box.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the coil supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check contactor KM1 coil supply voltage.

  • Use INSITE™ electronic service tool to enable the engine coolant heater.
  • Measure the voltage at the contactor coil inlet and outlet.

Use a circuit diagrams for coil connection identification and the following procedure for general voltage measurement techniques. Refer to Procedure 019-359 in Section 19.

23 to 26 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5C

Go to 6A

Guided Step 5C - Check the contactor performance.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check contactor KM1 performance.

  • Measure the resistance across all lines of the contactor switch when not energized.
  • Use INSITE™ electronic service tool to enable the engine coolant heater.
  • Measure the resistance across all lines when energized. Do not measure coil resistance.
  • Contactor coil energized, resistance is less than 10 ohms.
  • Contactor coil not energized, resistance is greater than 100k ohms.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within specifications?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Replace KM1 contactor.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections.
  • Restore voltage supply to generator interface box.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2869 - High Temperature Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2869 active?
STEP 2. | Check the high temperature cooling control driver circuit. |
 | STEP 2A. Inspect the temperature controller and engine harness connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100 ohms?
STEP 4. | Check ECM calibration code and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2869 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the high temperature cooling control driver circuit.

Guided Step 2A - Inspect the temperature controller and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the temperature controller.

Action

Inspect the temperature controller and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or temperature controller, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the temperature controller.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness and connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the high temperature control circuit pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. See the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

  • Repair the engine harness.
  • Refer to Procedure 019-204 in Section 19
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 2871 - High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the engine control module (ECM) for active fault codes. | Fault Code 2871 active?
STEP 2. | Verify the signal circuit. |
 | STEP 2A. Verify the signal current between ECM and temperature controller. | 4 to 20 mA?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration code and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2871 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Verify the signal current.

Guided Step 2A - Verify the signal current between the ECM and temperature controller.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the circuit.

  • Measure the electrical current between the high temperature temperature controller supply and the high temperature temperature controller.

Use the following procedure for general current measurement techniques. Refer to Procedure 019-359 in Section 19.

Vary the high temperature temperature controller target temperature about the observed coolant temperature to modulate signal current.

4 to 20 mA?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness at the temperature controller and the ECM.

Action

Inspect the temperature controller and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in temperature controller or engine harness connector.

Repair or replace the engine harness or the temperature controller, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness at the temperature controller connector and ECM connector.

Action

Inspect the temperature controller and the engine harness connector pins for the following:

  • Measure the resistance from the high temperature temperature control circuit pin on the engine harness to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness at the temperature controller connector and the ECM connector.

Action

Check for an open circuit.

  • Measure the high temperature controller supply resistance between the ECM harness connector pin and the temperature controller harness connector pin.
  • Measure the high temperature controller return resistance between the ECM harness connector pin and the temperature controller harness connector pin.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-May-2015


FAULT CODE 2872 - High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2872 active?
STEP 2. | Check the high temperature control valve trip sensing circuit. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit between the ECM and circuit breaker. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit between circuit breaker and VDC source. | Less than 10 ohms?
STEP 3. | Check the high temperature control valve supply circuit. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground between circuit breaker and contactor A. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground between circuit breaker and contactor B. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground between contactor A and high temperature control valve. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground between contactor B and high temperature control valve. | Greater than 100k ohms?
STEP 4. | Check for high resistance across contactors. |
 | STEP 4A. Check for high resistance across contactor A. | Less than 10 ohms?
 | STEP 4B. Check for high resistance across contactor B. | Less than 10 ohms?
STEP 5. | Check circuit breaker trip switch resistance. |
 | STEP 5A. Check for high resistance across circuit breaker trip switch with main switch closed. | Less than 10 ohms?
STEP 6. | Check ECM calibration code and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2872 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the high temperature control valve trip sensing circuit.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and ECM.

Action

Inspect the circuit breaker trip circuit and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Repair or replace the engine harness, or the MCB, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for an open circuit between the ECM and circuit breaker.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and ECM.

Action

Check for an open circuit.

  • Measure the harnesses' electrical resistance from the MCB6 trip circuit out to the ECM.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit between circuit breaker and VDC source.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip in and VDC source.

Action

Check for an open circuit.

  • Measure the MCB6 trip supply harnesses' electrical resistance between VDC source and MCB6 trip in.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6A

Go to 3A

Guided Step 3 - Check the high temperature control valve supply circuit.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the VAC isolator, MCB6 main, KM6A contactor, KM6B contactor, and high temperature control valve.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Repair or replace the engine harness, or the MCB, KM, high temperature control valve, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a short circuit to ground between circuit breaker and contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the MCB6 main out connector and KM6A contactor in connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the harnesses' electrical resistance from the MCB6 main circuit outlet to electrical ground.
  • Measure the harnesses' electrical resistance from the KM6A contactor circuit inlet to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground between circuit breaker and contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the MCB6 main out connector and KM6B contactor in connector.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the MCB6 main circuit outlet to electrical ground.
  • Measure the harnesses' electrical resistance from the KM6B contactor circuit inlet to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground between contactor A and high temperature control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6A contactor out to high temperature control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM6A contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the high temperature control valve to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to ground between contactor B and high temperature control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6B contactor out connector to high temperature control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM6B contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the high temperature control valve to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check for high resistance across contactors.

Guided Step 4A - Check for high resistance across contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6A contactor and driver in connector and out connector.

Action

Supply KM6A driver in with +24VDC. Check resistance across KM6A contactor.

  • Measure KM6A contactor's electrical resistance from contactor in connector to the out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace KM6A.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached to all contactor assembly electrical connections
  • Restore voltage supply to generator interface box.

Go to 4B

Go to 6A

Guided Step 4B - Check for high resistance across contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6B contactor and driver in connector and out connector.

Action

Supply KM6B driver in with +24VDC. Check resistance across KM6B contactor.

  • Measure KM6B contactor's electrical resistance from contactor in connector to the out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace KM6B.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached to all contactor assembly electrical connections
  • Restore voltage supply to generator interface box.

Go to 5A

Go to 6A

Guided Step 5 - Check circuit breaker trip switch resistance.

Guided Step 5A - Check for high resistance across circuit breaker trip switch with main switch closed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6A contactor and driver in connector and out connector.

Action

Close MCB6 main switch. Check resistance of MCB6 trip circuit.

  • Measure electrical resistance of MCB6 trip circuit in connector and out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jun-2015


FAULT CODE 2873 - Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2873 active?
STEP 2. | Verify the signal current. |
 | STEP 2A. Verify the signal current between the ECM and temperature controller. | 4 to 20mA?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Check ECM calibration code and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2873 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Verify the signal current.

Guided Step 2A - Verify the signal current between the ECM and temperature controller.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the current.

  • Measure the electrical current between the low temperature temperature controller supply and the low temperature temperature controller.

Use the following procedure for general current measurement techniques. Refer to Procedure 019-359 in Section 19.

Vary the low temperature temperature controller target temperature about the observed coolant temperature to modulate signal current.

4 to 20mA?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from the temperature controller and the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Repair or replace the engine harness, or the temperature controller, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the temperature controller and ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the low temperature temperature control circuit pin on the engine harness to all other pins in the engine harness connector.
  • Perform these check on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-May-2015


FAULT CODE 2874 - Aftercooler Cooling Circuit Current Driver - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2874 active?
STEP 2. | Verify the signal current. |
 | STEP 2A. Verify the signal current between the ECM and temperature controller. | 4 to 20mA?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration code and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2874 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Verify the signal current.

Guided Step 2A - Verify the signal current between the ECM and temperature controller.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the current.

  • Measure the electrical current between the low temperature temperature controller supply and the low temperature temperature controller.

Use the following procedure for general current measurement techniques. Refer to Procedure 019-359 in Section 19.

Vary the low temperature temperature controller target temperature about the observed coolant temperature to modulate signal current.

4 to 20mA?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from the temperature controller and the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Repair or replace the engine harness, or the temperature controller, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the temperature controller and ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the low temperature temperature control circuit pin on the engine harness to all other pins in the engine harness connector.
  • Perform these check on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the temperature controller and ECM.

Action

Check for an open circuit.

  • Measure the low temperature temperature controller supply resistance between the ECM harness connector pin and the temperature controller harness connector pin.
  • Measure the low temperature temperature controller Return resistance between the ECM harness connector pin and the temperature controller harness connector pin.
  • Perform these check on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2875 - Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2875 active?
STEP 2. | Check the low temperature control valve trip sensing circuit. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit between ECM and circuit breaker. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit between circuit breaker and VDC Source. | Less than 10 ohms?
STEP 3. | Check the low temperature control valve supply circuit. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground between circuit breaker and contactor A. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground between circuit breaker and contactor B. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground between contactor A and low temperature control valve. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground between contactor B and low temperature control valve. | Greater than 100k ohms?
STEP 4. | Check for high resistance across contactors. |
 | STEP 4A. Check for high resistance across contactor A. | Less than 10 ohms?
 | STEP 4B. Check for high resistance across contactor B. | Less than 10 ohms?
STEP 5. | Check circuit breaker trip switch resistance. |
 | STEP 5A. Check for high resistance across circuit breaker trip switch with main switch closed. | Less than 10 ohms?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2875 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the low temperature control valve trip sensing circuit.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB7 trip out and ECM.

Action

Inspect the circuit breaker trip circuit and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Repair or replace the engine harness, or the MCB, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for an open circuit between ECM and circuit breaker.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB7 trip out and ECM.

Action

Check for an open circuit.

  • Measure the harnesses' electrical resistance from the MCB7 trip circuit out to the ECM.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit between circuit breaker and VDC source.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB7 trip in and VDC source.

Action

Check for an open circuit.

  • Measure the MCB7 trip supply harnesses' electrical resistance between VDC source and MCB7 trip in.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6A

Go to 3A

Guided Step 3 - Check the low temperature control valve supply circuit.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the VAC isolator, MCB7 main, KM7A contactor, KM7B contactor and low temperature control valve.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Repair or replace the engine harness, or the MCB, KM, low temperature control valve, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a short circuit to ground between circuit breaker and contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the MCB7 main out connector and KM7A contactor in connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the harnesses' electrical resistance from the MCB7 main circuit outlet to electrical ground.
  • Measure the harnesses' electrical resistance from the KM7A contactor circuit inlet to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground between circuit breaker and contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the MCB7 main out connector and KM7B contactor in connector.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the MCB7 main circuit outlet to electrical ground.
  • Measure the harnesses' electrical resistance from the KM7B contactor circuit inlet to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground between contactor A and low temperature control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7A contactor out to low temperature control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM7A contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the low temperature control valve to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to ground between contactor B and low temperature control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7B contactor out connector to low temperature control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM7B contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the low temperature control valve to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check for high resistance across contactors.

Guided Step 4A - Check for high resistance across contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7A contactor and driver in connector and out connector.

Action

Supply KM7A driver in with +24 VDC. Check resistance across KM7A contactor.

  • Measure KM7A contactor's electrical resistance from contactor in connector to the out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace KM7A.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections
  • Restore voltage supply to generator interface box.

Go to 4B

Go to 6A

Guided Step 4B - Check for high resistance across contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7B contactor and driver in connector and out connector.

Action

Supply KM7B driver in with +24 VDC. Check resistance across KM7B contactor.

  • Measure KM7B contactor's electrical resistance from contactor in connector to the out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Replace KM7B.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections
  • Restore voltage supply to generator interface box.

Go to 5A

Go to 6A

Guided Step 5 - Check circuit breaker trip switch resistance.

Guided Step 5A - Check for high resistance across circuit breaker trip switch with main switch closed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7A contactor and driver in connector and out connector.

Action

Close MCB7 main switch. Check resistance of MCB7 trip circuit.

  • Measure electrical resistance of MCB7 trip circuit in connector and out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 2876 - Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Turbocharger Compressor Inlet Temperature Sensor | Refer to Procedure 019-082 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2876 active?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 135, 136, 137, 141, 144,145, 212, 213, 231, 232, 352, 386, 2111, 2112, 2115, 2116, 2154, 2155, and/or 2877 active/inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor connector and connector pins. | Dirty or damaged pins ?
 | STEP 2B. Check the temperature sensor resistance. | Resistance 625 ohms to 36k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open-circuit in the engine harness. | Less than10 ohms?
 | STEP 3C. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check the supply voltage at the ECM. | 4.75 to 5.25-VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2876 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 135, 136, 137, 141, 144,145, 212, 213, 231, 232, 352, 386, 2111, 2112, 2115, 2116, 2154, 2155, and/or 2877 active/inactive?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor connector and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger intake air temperature sensor.

Action

Inspect the turbocharger intake air temperature sensor connector, the engine harness connector and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or the turbocharger compressor intake air temperature sensor, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in Section 19 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the temperature sensor resistance.

Conditions

  • De-energized keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor intake air sensor connector.

Action

Use a multimeter to measure the resistance of the turbocharger compressor intake air temperature sensor from the sensor SIGNAL (+) pin to the sensor RETURN (-) pin at the sensor.

  • Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 625 ohms to 36k ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness .

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL(+) pin at the ECM connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN(-) pin at the ECM connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector
  • Use the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter, check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL(+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN(-) pin at the ECM connector to all other pins in the ECM connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL(+) pin at the ECM connector to the engine block ground.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the engine harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the supply voltage at the ECM.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the ECM module.

Action

Use a multimeter to check the turbocharger compressor inlet temperature supply voltage at the ECM.

  • Measure the voltage between the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector B on the ECM to the engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general voltage measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

  • A fault has been detected within the ECM module. Replace the ECM module. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 2877 - Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Turbocharger Compressor Inlet Temperature Sensor | Refer to Procedure 019-082 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2877 active?
 | STEP 1B. Check for multiple active/inactive active fault codes. | Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 352, 386, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor connector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the temperature sensor resistance. | Resistance 625 ohms to 36k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check the supply voltage at the ECM. | 4.75 to 5.25-VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 2877 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 352, 386, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor connector and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger intake air temperature sensor.

Action

Inspect the turbocharger intake air temperature sensor connector, the engine harness connector, and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or the turbocharger compressor intake air temperature sensor, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the temperature sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor intake air sensor connector.

Action

Check the temperature sensor resistance.

  • Use a multimeter to measure the resistance of the turbocharger compressor intake air temperature sensor from the sensor SIGNAL (+) pin to the sensor RETURN (-) pin at the sensor.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 625 ohms to 36k ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.

Action

Inspect the compressor inlet air temperature sensor connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the ECM connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the ECM connector to all other pins in the ECM connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector to the engine block ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the supply voltage at the ECM.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the wiring harness from the ECM module.

Action

Use a multimeter to check the turbocharger compressor inlet temperature supply voltage at the ECM.

  • Measure the voltage between the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the ECM connector on the ECM to the engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 2973 - Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 354 and Fault Code 355. | Fault Code 354 or Fault Code 355 active?
STEP 2. | Check the intake manifold 1 pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 1 pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 355 active?
 | STEP 2C. Check the circuit response. | Fault Code 354 active?
STEP 3. | Check the engine control module (ECM) and engine harness |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 355 active?
 | STEP 3C. Check the circuit response. | Fault Code 354 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 354 and Fault Code 355.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 354 or Fault Code 355 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the intake manifold 1 pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold 1 pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold 1 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the intake manifold 1 pressure +5 volt SUPPLY pin and the intake manifold 1 pressure SIGNAL pin at the intake manifold 1 pressure sensor connector of the engine harness.

Fault Code 354 active?
YES NO

An in-range malfunction of the intake manifold 1 pressure sensor has been detected.

Replace the intake manifold 1 pressure sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 355 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the intake manifold 1 pressure +5 volt SUPPLY pin and the intake manifold 1 pressure SIGNAL pin at the intake manifold 1 pressure sensor connector of the engine harness.

Fault Code 354 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration code and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 2994 - Engine Control Module Internal Failure - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 2994 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 2994. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code inactive. | Fault Code 2994 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to verify that the Fault Code 2994 is inactive.

Fault Code 2994 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 2994.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 2994.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 2994.

Less than three counts?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 3111 - Engine Cylinder 1 (A1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Camshaft | Refer to Procedure 001-008 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil System | Refer to Procedure 007-037 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3111 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Inspect cylinder 1 (A1) cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 1 (A1) power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Cylinder 1(A1) power cylinder damaged?
 | STEP 3C. Inspect connecting rod bearings. | Cylinder 1 (A1) connecting rod bearings damaged?
 | STEP 3D. Inspect piston cooling nozzle. | Cylinder 1 (A1) piston cooling nozzle bent or broken?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3111 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3111 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • See Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 1 (A1) cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 1 (A1) cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-004 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 1 (A1) cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 1 (A1) cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the valve train.

Inspect the cylinder 1 (A1) valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 1 (A1) camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the camshaft follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 1 (A1) power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-037 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 1 (A1) power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 1 (A1) connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 1 (A1) connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings.

  • Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 1 (A1) piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle.

  • Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 3111 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair complete.

Go to the appropriate troubleshooting tree.

Last Modified: 21-Jul-2015


FAULT CODE 3112 - Engine Cylinder 2 (B1) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Camshaft | Refer to Procedure 001-008 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3112 and/or 3111, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?
STEP 2. | Inspect cylinder 2 (B1) cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 2 (B1) power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3112 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3112 and/or 3111, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127, 3128, 3129 active?

YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks troubleshooting symptom tree in Section TS.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 2 (B1) cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 2 (B1) cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-004 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 2 (B1) cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 2 (B1) cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the valve train.

Inspect the cylinder 2 (B1) valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-004 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • cylinder 2 (B1) camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 2 (B1) power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-002 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 2 (B1) power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 2 (B1) connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 2 (B1) connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 2 (B1) piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code 3112 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 3113 - Engine Cylinder 3 (A2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Camshaft | Refer to Procedure 001-008 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3114 and/or 3111, 3112, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 3 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 3 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Cylinder 4 power cylinder damaged?
 | STEP 3C. Inspect connecting rod bearings. | Cylinder 4 connecting rod bearings damaged?
 | STEP 3D. Inspect piston cooling nozzle. | Cylinder 4 piston cooling nozzle bent or broken?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3114 and/or 3111, 3112, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 3 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 3 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 3 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 3 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/stop/auto switch in STOP mode.

Action

Check the valve lash.

  • Check that cylinder 3 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the valve train.

Inspect the cylinder 3 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear.
  • Cylinder 3 camshaft lobe wear. Refer to Procedure 004-001 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 3 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 3 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 3 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 3 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 3 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3114 - Engine Cylinder 4 (B2) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Camshaft | Refer to Procedure 001-008 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3114 and/or 3111, 3112, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 4 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 4 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Cylinder 4 power cylinder damaged?
 | STEP 3C. Inspect connecting rod bearings. | Cylinder 4 connecting rod bearings damaged?
 | STEP 3D. Inspect piston cooling nozzle. | Cylinder 4 piston cooling nozzle bent or broken?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3114 and/or 3111, 3112, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 4 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 4 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 4 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 4 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/stop/auto switch in STOP mode.

Action

Check the valve lash.

  • Check that cylinder 4 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Inspect the valve train.

Inspect the cylinder 4 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear.
  • Cylinder 3 camshaft lobe wear. Refer to Procedure 004-001 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 4 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 4 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 4 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 4 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 4 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3115 - Engine Cylinder 5 (A3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 5 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 5 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 5 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 5 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases
  • Refer to Procedure 002-021 in the Associated Procedures Table
  • Loose engine components on or immediately around cylinder 5 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 5 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the valve lash.

  • Check that cylinder 5 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 5 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 5 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 5 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 5 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 5 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 5 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 5 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 3116 - Engine Cylinder 6 (B3) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 6 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 6 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 6 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 6 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases
  • Refer to Procedure 002-021 in the Associated Procedures Table
  • Loose engine components on or immediately around cylinder 6 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 6 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the valve lash.

  • Check that cylinder 6 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 6 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 6 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 6 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 6 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 6 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 6 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 6 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3117 - Engine Cylinder 7 (A4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 7 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 7 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 7 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 7 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 7 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 7 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the valve lash.

  • Check that cylinder 7 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 7 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 7 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 7 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 7 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 7 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 7 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 7 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3118 - Engine Cylinder 8 (B4) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 8 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 8 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 8 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 8 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 8 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 8 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the valve lash.

  • Check that cylinder 8 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 8 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 8 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 8 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 8 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 8 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 8 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 8 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3119 - Engine Cylinder 9 (A5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 9 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 9 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 9 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 9 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 9 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 9 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the valve lash.

  • Check that cylinder 5 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 9 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 5 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 9 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 9 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 9 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 9 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 9 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3121 - Engine Cylinder 10 (B5) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 10 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 10 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 10 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 10 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 10 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 10 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the valve lash.

  • Check that cylinder 10 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 10 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 10 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 10 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 10 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 10 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 10 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 10 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3122 - Engine Cylinder 11 (A6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 11 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 11 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 11 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 11 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 11 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 11 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the valve lash.

  • Check that cylinder 11 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 11 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 11 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 11 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 11 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 11 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 11 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 11 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3123 - Engine Cylinder 12 (B6) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 12 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 12 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 12 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 12 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 12 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 12 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the valve lash.

  • Check that cylinder 12 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 12 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 12 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 12 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 12 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 12 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 12 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 12 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3124 - Engine Cylinder 13 (A7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 13 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 13 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 13 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 13 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 13 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 13 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the valve lash.

  • Check that cylinder 13 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 13 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 13 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 13 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 13 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 13 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 13 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 13 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 3125 - Engine Cylinder 14 (B7) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 14 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 14 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 14 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 14 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder 14 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder 14 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the valve lash.

  • Check that cylinder 14 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the valve train.

Inspect the cylinder 14 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Inlet or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder 14 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 14 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder 14 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 14 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder 14 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder 14 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3126 - Engine Cylinder 15 (A8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4387381
Camshaft | Refer to Procedure 001-008 | QSK60 G CM2358 K110 | 4387381
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4387381
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4387381
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4387381
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4387381
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4387381
Overhead Set (OBD) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4387381
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4387381
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4387381
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4387381
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4387381

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3126 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, and 3127 active?
STEP 2. | Inspect cylinder number 15 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder number 15 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Cylinder number 15 connecting rod bearings damage?
 | STEP 3D. Inspect piston cooling nozzle. | Cylinder number 15 piston cooling nozzle bent or broken?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3126 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3126 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, and 3127 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder number 15 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder number 15 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder number 15 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder number 15 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the valve lash.

  • Check that cylinder number 15 valve lash setting is correct. Refer to Procedure 011-007 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the valve train.

Inspect the cylinder number 15 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Intake or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder number 15 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder number 15 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the lubricating oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Damage to power cylinder components?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder number 15 connecting rod bearings for excessive wear or other damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder number 15 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder number 15 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3126 is inactive.

Fault Code 3126 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 3127 - Engine Cylinder 16 (B8) Knock Sensor Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4387381
Camshaft | Refer to Procedure 001-008 | QSK60 G CM2358 K110 | 4387381
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4387381
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4387381
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4387381
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4387381
Cylinder Head GaSket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4387381
Overhead Set (OBD) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4387381
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4387381
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4387381
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4387381
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4387381

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3127 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126 active?
STEP 2. | Inspect cylinder number 16 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder number 16 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3127 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3127 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder number 16 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder number 16 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around cylinder number 16 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose engine components on or immediately around cylinder number 16 cylinder head.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the valve lash.

  • Check that cylinder number 16 valve lash setting is correct. Refer to Procedure 003-006 in the Associated Procedures Table.

Valve lash correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the valve train.

Inspect the cylinder number 16 valve train for the following:

  • Correct valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.
  • Intake or exhaust valve wear or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Cam follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Cylinder number 16 camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Worn or improperly installed valve train components?
YES NO

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the cam follower assembly. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

  • Adjust the valve lash setting. Refer to Procedure 003-006 in the Associated Procedures Table.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder number 16 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

Note: If a borescope is available, the inspection can be performed without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage. Refer to Procedure 002-004 in the Associated Procedures Table.

Cylinder number 16 power cylinder damaged?
YES NO

Replace the damaged components.

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the cylinder liner. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder number 16 connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Cylinder number 16 connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Refer to Procedure 001-046 in the Associated Procedures Table.

Cylinder number 16 piston cooling nozzle bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3127 is inactive.

Fault Code 3127 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 27-Jul-2015


FAULT CODE 3262 - Engine Spark Plug 7 (A4) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 7 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 7 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 7 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 7.

  • Test the cylinder 7 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3263 - Engine Spark Plug 7 (A4) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 7 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 7 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3264 - Engine Spark Plug 8 (B4) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 8 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 8 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 8 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 8.

  • Test the cylinder 8 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3265 - Engine Spark Plug 8 (B4) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 8 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 8 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3266 - Engine Spark Plug 9 (A5) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 9 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 9 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 9 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 9.

  • Test the cylinder 9 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3267 - Engine Spark Plug 9 (A5) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 9 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 9 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3268 - Engine Spark Plug 10 (B5) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 10 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 10 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 10 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 10.

  • Test the cylinder 10 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3269 - Engine Spark Plug 10 (B5) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 10 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 10 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3271 - Engine Spark Plug 11 (A6) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 11 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 11 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 11 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 11.

  • Test the cylinder 11 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3272 - Engine Spark Plug 11 (A6) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 11 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 11 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Jul-2015


FAULT CODE 3273 - Engine Spark Plug 12 (B6) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 12 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 12 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 12 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 12.

  • Test the cylinder 12 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3274 - Engine Spark Plug 12 (B6) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 12 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 12 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3275 - Engine Spark Plug 13 (A7) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 13 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 13 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 13 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 13.

  • Test the cylinder 13 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3276 - Engine Spark Plug 13 (A7) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 13 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 13 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3277 - Engine Spark Plug 14 (B7) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 14 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 14 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 14 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 14.

  • Test the cylinder 14 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3278 - Engine Spark Plug 14 (B7) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 14 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 14 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3279 - Engine Spark Plug 15 (A8) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 15 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 15 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 15 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 15.

  • Test the cylinder 15 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3281 - Engine Spark Plug 15 (A8) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 15 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 15 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3282 - Engine Spark Plug 16 (B8) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil spring. | Excessive grease or broken coil spring?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 16 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 16 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2C

Guided Step 2C - Check the coil spring.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 16 spark plug.
  • Remove the spark plug boot from the ignition coil.

Action

Inspect the coil spring for the following:

  • Broken spring
  • Grease build up on the end of the spring.

Excessive grease or broken coil spring?
YES NO

A damaged or dirty coil spring has been detected.

Remove excess grease from the end of the spring or replace the coil.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2D

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Refer to Procedure 013-024 in the Associated Procedures Table.
  • Turn the keyswitch ON.

Action

Check the ignition coil of cylinder 16.

  • Test the cylinder 16 coil to determine if the plug is receiving voltage
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Note: The coil must be tested in the vertical position or damage to the coil can result.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3283 - Engine Spark Plug 16 (B8) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Sparks Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Coil-on-Plug | Refer to Procedure 013-024 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active misfire fault codes?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
STEP 3. | Check engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Perform a stall test.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active misfire fault codes?
YES | NO
No Repair | No Repair

Troubleshoot the misfire fault codes.

Go to 2A

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 16 ignition coil from the ignition harness.

Action

Inspect the ignition harness and ignition coil connector pins of the misfiring cylinder for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the harness. Refer to Procedure 019-202 in Section 19.
  • Use the following procedure for information to replace the ignition coil. Refer to Procedure 013-024 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 16 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3362 - Engine Electrical System Power Conservation Control - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the harness to the original equipment manufacturer (OEM) control panel. |
 | STEP 1A. Inspect the harness to the OEM control panel. | Dirty or damaged pins?
 | STEP 1B. Check for an open in the battery conservation circuit. | Less than 10 ohms?
 | STEP 1C. Check the OEM control panel and relay. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the ECM and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the harness to the OEM control panel.

Guided Step 1A - Inspect the harness to the OEM control panel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness to the OEM control panel.

Action

Inspect the harness to the control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness connector, or harness to the OEM control panel, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. See equipment manufacturer service information.
  • Repair the ignition ground connector. Refer to Procedure 019-207 in Section 19.

 No Repair

Go to 1C

Go to 3A

Guided Step 1B - Check for an open in the battery conservation circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness to the OEM control panel.
  • Remove the diagnostic lamp.
  • Disconnect the ECM connector.

Action

Check for an open circuit as follows:

  • Measure the resistance from the battery conservation relay RETURN wire at the battery conservation relay in the OEM control panel to the battery.
  • Measure the resistance from the battery conservation relay SUPPLY pin at the battery conservation relay in the OEM control panel to the battery conservation relay SUPPLY pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

  • An open circuit has been detected. Determine the section of the harness containing the open circuit and repair or replace. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relay.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relay for proper relay function, proper wiring, short circuits, open circuits, and/or damage.

  • Refer to the OEM service manual.

Any issues?
YES NO

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. See equipment manufacturer service information.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness to the OEM control panel connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from battery conservation relay supply at ECM connector to all of the other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the connectors. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2015


FAULT CODE 3363 - Engine Electrical System Power Conservation Control - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the harness to the original equipment manufacturer (OEM) control panel. |
 | STEP 1A. Inspect the harness to the OEM control panel connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 1C. Check the OEM control panel and relays. | Any issues?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine control module (ECM) and the harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the harness to the OEM control panel.

Guided Step 1A - Inspect the harness to the OEM control panel connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness to the OEM control panel connector.

Action

Inspect the harness to the OEM control panel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness connector or harness to the OEM control panel harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the OEM harness. See equipment manufacturer service information.

 No Repair

Go to 1C

Go to 3A

Guided Step 1B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness to the OEM control panel connector.
  • Remove the diagnostic lamp.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from the battery conservation relay SUPPLY pin on the harness to the OEM control panel connector to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the harness. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 1C - Check the OEM control panel and relay.

Conditions

  • Turn keyswitch OFF.

Action

Check the OEM control panel and relay for proper relay function, proper wiring, short circuits, and/or damage.

  • See equipment manufacturer service information.

Any issues?
YES NO

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and the harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

No damaged pins?
YES NO

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness to the OEM control panel connector.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit from pin-to-pin as follows:

  • Measure the resistance from ECM connector battery conservation relay SUPPLY pin to all of the other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the connectors. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 2C

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness to the OEM control panel connector.
  • Disconnect the harness from ECM.

Action

Check for a short circuit to ground as follows:

  • Measure the resistance from ECM connector battery conservation relay SUPPLY pin to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged connection has been detected in the ECM connector or engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the harness.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-May-2015


FAULT CODE 3458 - Knock Sensor Based Engine Derate - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Bearings, Connecting Rod | Refer to Procedure 001-005 | QSK60 G CM2358 K110 | 4383781
Main, Bearings | Refer to Procedure 001-006 | QSK60 G CM2358 K110 | 4383781
Camshaft | Refer to Procedure 001-008 | QSK60 G CM2358 K110 | 4383781
Cylinder Liner | Refer to Procedure 001-028 | QSK60 G CM2358 K110 | 4383781
Piston and Cylinder Liners | Refer to Procedure 001-045 | QSK60 G CM2358 K110 | 4383781
Piston Cooling Nozzle | Refer to Procedure 001-046 | QSK60 G CM2358 K110 | 4383781
Piston Rings | Refer to Procedure 001-047 | QSK60 G CM2358 K110 | 4383781
Cylinder Head | Refer to Procedure 002-004 | QSK60 G CM2358 K110 | 4383781
Cylinder Head Gasket | Refer to Procedure 002-021 | QSK60 G CM2358 K110 | 4383781
Overhead Set (OBC) | Refer to Procedure 003-006 | QSK60 G CM2358 K110 | 4383781
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK60 G CM2358 K110 | 4383781
Cam Follower Assembly | Refer to Procedure 004-001 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Manifold, Dry | Refer to Procedure 011-007 | QSK60 G CM2358 K110 | 4383781
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | QSK60 G CM2358 K110 | 4383781
Cooling System | Refer to Procedure 018-018 | QSK60 G CM2358 K110 | 4383781
Air Intake System | Refer to Procedure 018-019 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3458 and 1243 active?
STEP 2. | Check the kilowatt load reference signal. |
 | STEP 2A. Check the kilowatt load transducer reference signal, if installed. | Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
 | STEP 2B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 3. | Check the intake manifold temperature. |
 | STEP 3A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 3B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances to specification?
STEP 4. | Check the intake manifold pressure. |
 | STEP 4A. Check the intake manifold pressure sensor. | Intake manifold pressure within specification?
 | STEP 4B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor to specification?
STEP 5. | Check the quality of the natural gas supply to the generator set. |
 | STEP 5A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 6. | Inspect all the cylinder heads. |
 | STEP 6A. Check the spark plugs. | Spark plug contaminated or damaged?
 | STEP 6B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 6C. Check the cylinder head. | Cylinder heads: leaking gaskets or loose components?
 | STEP 6D. Check the valve lash. | Valve lash settings correct?
 | STEP 6E. Check the valve train. | Valve train worn?
STEP 7. | Inspect all the power cylinders. |
 | STEP 7A. Cut open the lubricating oil filters and inspect for debris. | Debris present in oil filter?
 | STEP 7B. Check the power cylinders. | Power cylinder damaged?
 | STEP 7C. Inspect the connecting rod bearings. | Connecting rod bearings damaged?
 | STEP 7D. Inspect the piston cooling nozzles. | Piston cooling nozzle bent or damaged?
 | STEP 7E. Check the main bearings. | Main bearings worn or damaged?
STEP 8. | Check ECM calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3458 and 1243 active?
YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise Excessive - Combustion Knocks troubleshooting symptom tree in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the kilowatt load reference signal.

Guided Step 2A - Check the kilowatt load transducer reference signal, if installed.

Conditions

Note: If the generator set is not installed with a kilowatt load transducer, proceed to Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp / load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 8A

Guided Step 2B - Check the calibration of the generator set controller.

Conditions

Note: This guided step should only be followed for generator sets without a kilowatt load transducer installed.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals.
  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

  • Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 8A

Guided Step 3 - Check the intake manifold temperature.

Guided Step 3A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the RUN mode, operating at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Refer to Procedure 018-019 in the Associated Procedures Table.

Intake manifold temperature within specification?
YES NO
No Repair

Check the following:

  • Check the temperature of the High Temperature (HT) and Low Temperature (LT) coolant outlets from the engine. Refer to Procedure 018-018 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 3B

Go to 8A

Guided Step 3B - Check the intake manifold temperature sensor.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.
  • Note: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference to Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 4A

Go to 8A

Guided Step 4 - Check the intake manifold pressure.

Guided Step 4A - Check the intake manifold pressure sensor.

Conditions

  • Connect all components
  • Energize keyswith circuit.
  • Place Run/Stop/Auto switch in the RUN mode, operating at maximum possible load with no knock present.

Action

Check the intake manifold pressure sensor.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Refer to Procedure 018-019 in the Associated Procedures Table.

Intake manifold pressure within specification?
YES NO
No Repair

Check the following:

  • If installed, check the operation of the Compressor Bypass Valve (single turbochargers engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 8A

Guided Step 4B - Check the intake manifold pressure sensor

Conditions

  • De-energize keyswitch circuit.
  • Run/Stop/Auto switch in the STOP mode.

Action

Check the intake manifold pressure sensor.

Note: The intake manifold pressure sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor to specification?
YES NO
No Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 5A

Go to 8A

Guided Step 5 - Check the quality of the natural gas supply to the generator set.

Guided Step 5A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits). Use the following procedure in the QSK60 G CM2358 K110 Operation and Maintenance Manual, Bulletin 4383782. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 8A

Guided Step 6 - Inspect all cylinder heads.

Guided Step 6A - Check the spark plugs.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check the spark plugs.

Inspect all the spark plugs for the following:

  • Spark plug correctly tightened.
  • Spark plug “J” connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plugs contaminated or damaged?
YES NO

  • Tighten the spark plugs to the specified torque.
  • Replace the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check the spark plug gap on all cylinders.

  • Remove the spark plugs and measure the spark plug electrode gap. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug gap excessive?
YES NO

Replace the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check all the cylinder heads.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check all the cylinder heads.

Inspect all cylinder heads for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Loose engine components on or immediately around the cylinder heads.

Cylinder heads: leaking gaskets or loose components?
YES NO

Repair as necessary.

  • Replace the cylinder head gasket. Refer to Procedure 002-021 in the Associated Procedures Table.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in the Associated Procedures Table.
  • Tighten any loose components on or immediately around the cylinder head. Reference the appropriate procedures.

 No Repair

Go to 8A

Go to 6D

Guided Step 6D - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check the valve lash.

  • Check that valve lash setting is correct on all cylinders. Refer to Procedure 003-006 in the Associated Procedure Table.

Valve lash settings correct?
YES NO
No Repair

Proceed to next troubleshooting step.

Go to 7A

Go to 6E

Guided Step 6E - Check the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check the valve train.

Inspect the valve train on all cylinders for the following:

  • Inlet or exhaust valve wear/recession or damage. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Camshaft follower wear. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Camshaft lobe wear. Refer to Procedure 001-008 in the Associated Procedures Table.

Valve train worn?
YES NO

Repair as necessary:

  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.
  • Replace the camshaft follower. Refer to Procedure 004-001 in the Associated Procedures Table.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in the Associated Procedures Table.
  • Replace the camshaft. Refer to Procedure 001-008 in the Associated Procedures Table.

Adjust the valve lash. Refer to Procedure 003-006 in the Associated Procedure Table.

Go to 8A

Go to 7A

Guided Step 7 - Inspect all power cylinders.

Guided Step 7A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Cut open the oil filters and inspect for debris.

  • Remove the lubricating oil filters. Refer to Procedure 007-013 in the Associated Procedures Table.
  • Cut open the oil filters and inspect for debris in the filter medium.
  • Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Proceed to the next troubleshooting step.

 No Repair

Go to 7B

Go to 7D

Guided Step 7B - Check the power cylinders.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the power cylinders.

Inspect the internal power cylinders for the following:

Note: If available, these inspections can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Cylinder liner bore damage. Refer to Procedure 001-028 in the Associated Procedures Table.
  • Cylinder head flame face damage.

Power cylinder damaged?
YES NO

Repair as necessary:

  • Replace the piston rings. Refer to Procedure 001-047 in the Associated Procedures Table.
  • Replace the liner. Refer to Procedure 001-045 in the Associated Procedures Table.
  • Replace the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 7C

Guided Step 7C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect all cylinder connecting rod bearings for excessive wear or damage. Refer to Procedure 001-005 in the Associated Procedures Table.

Connecting rod bearings damaged?
YES NO

Replace the connecting rod bearings. Refer to Procedure 001-005 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 7D

Guided Step 7D - Inspect the piston cooling nozzles.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzles.

Inspect the piston cooling nozzles on all cylinder locations for the following:

  • Bent cooling nozzles
  • Broken cooling nozzles.

Piston cooling nozzles bent or broken?
YES NO

Replace the piston cooling nozzle. Refer to Procedure 001-046 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 7E

Guided Step 7E - Inspect the main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the main bearings.

  • Inspect main bearings on all cylinder locations. Refer to Procedure 001-046 in the Associated Procedures Table.

Main bearings worn or damaged?
YES NO

  • Replace the main bearings as required. Refer to Procedure 001-46 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 8A

Guided Step 8 - Check ECM calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 3489 - Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Power supply 441 or 442 fault codes active or high counts?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Power supply 441 or 442 fault codes active or high counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger compressor bypass actuator.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Inspect the turbocharger compressor bypass actuator connector, the engine harness connector and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the turbocharger compressor actuator connector or harness connector.

Repair or replace the engine harness or the turbocharger compressor bypass actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the turbocharger compressor bypass valve. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the ECM connector to all other pins in the ECM connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit to engine block ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the ECM connector to engine block ground.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the ECM connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the ECM connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Apr-2015


FAULT CODE 3491 - Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil Filter Head | Refer to Procedure 007-015 | QSK60 G CM2358 K110 | 4383781
Lubricating Oil System | Refer to Procedure 007-037 | QSK60 G CM2358 K110 | 4383781
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 G CM2358 K110 | 4383781
Post-Oil Filter Pressure Sensor | Refer to Procedure 019-447 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3491 - Engine Oil Filter Restriction High. | Active or inactive counts of Fault Code 3491?
 | STEP 1B. Check for multiple fault codes. | Active or inactive counts of Fault Codes 415, 136, 137, 141 and 143?
STEP 2. | Check the lubricating oil filters. |
 | STEP 2A. Replace the lubricating oil filters. | Oil filters contaminated?
STEP 3. | Check the lubricating oil pressure sensors. |
 | STEP 3A. Check the pre and post-filter oil pressure sensors. | Pressure sensor found malfunctioning?
STEP 4. | Check the lubricating oil filter head. |
 | STEP 4A. Check the lubricating oil filter head. | Lubricating oil filter head malfunctioning?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active or inactive fault codes.

Guided Step 1A - Check for Fault Code 3491 - Engine Oil Filter Restriction High.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Code 3491?
YES NO

Proceed to next troubleshooting step.

 No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for multiple fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Codes 415, 136, 137, 141 and 143?
YES NO

Troubleshoot any the above fault codes.

  • See the relevant fault code troubleshooting procedure in Section TF.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the lubricating oil filters.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode

Action

Remove, inspect, and replace the lubricating oil filters.

  • Loose connector
  • Remove and replace the lubricating oil filters. Refer to Procedure 007-013 in the Associated Procedures Table.

Cut open the lubricating oil filters and inspect for debris or oil contamination.

Check the lubricating oil condition as per Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin 3810340, or Contact a Cummins® Authorized Repair Location.

Oil filters contaminated?
YES NO

Replace the engine lubricating oil if the oil shows signs of contamination or the oil analysis results recommend that the lubricating oil should be replaced.

  • Replace the engine lubricating oil. Refer to Procedure 007-037 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the lubricating oil pressure sensors.

Guided Step 3A - Check the pre and post-filter oil pressure sensors.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode

Action

Check the operation and range of the pre and post-filter lubricating oil pressure sensors.

  • Refer to Procedure 019-126 in the Associated Procedures Table.
  • Refer to Procedure 019-447 in the Associated Procedures Table.

Pressure sensor found malfunctioning?
YES NO

Replace the appropriate pressure sensor.

Replace the malfunctioning pressure sensor .

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-126 in the Associated Procedures Table.
  • Refer to Procedure 019-447 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the lubricating oil filter head.

Guided Step 4A - Check the lubricating oil filter head.

Conditions

  • De-energize keyswitch circuit
  • Place Run/Stop/Auto switch in STOP mode

Action

Inspect the lubricating oil filter head assembly.

  • Refer to Procedure 007-015 in the Associated Procedures Table.

Lubricating oil filter head malfunctioning?
YES NO

Repair or replace the lubricating oil filter head.

  • Refer to Procedure 007-015 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3515 - Engine Throttle Control Actuator CAN Commanded Shutdown - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault code 426, 427, or 781 active or high counts?
STEP 2. | Check the throttle control actuator. |
 | STEP 2A. Inspect the throttle control actuator connector and engine harness connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault code 426, 427, or 781 active or high counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the throttle control actuator.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the throttle control actuator.

Action

Inspect the throttle control actuator connector, the engine harness connector and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the throttle control actuator connector or harness connector.

Repair or replace the engine harness or the throttle control actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the throttle control actuator. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the throttle control actuator.

Action

Use a multimeter to check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the throttle control actuator SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the throttle control actuator RETURN (-) pin at the ECM connector to all other pins in the ECM connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the throttle control actuator.

Action

Use a multimeter to check for a short circuit to engine block ground in the engine harness:

  • Measure the resistance from the throttle control actuator SIGNAL (+) pin at the ECM connector to engine block ground.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM module.
  • Disconnect the engine harness from the throttle control actuator.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the throttle control actuator SIGNAL (+) pin at the ECM connector to the throttle control actuator SIGNAL (+) pin at the throttle control actuator connector.
  • Measure the resistance from the throttle control actuator RETURN (-) pin at the ECM connector to the throttle control actuator RETURN (-) pin at the throttle control connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Apr-2015


FAULT CODE 3521 - Engine Throttle Control Actuator Temperature - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 441 or 442 active?
 | STEP 1B. Check for fault codes. | Fault Code 783, 2876, and/or 2877 active?
STEP 2. | Check for leakage. |
 | STEP 2A. Check for leakage. | Any leakage in the fuel system or air handling system?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES NO
No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault codse.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 783, 2876, and/or 2877 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for leakage.

Guided Step 2A - Check for leakage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for leakage in the fuel system and air handling system.

Any leakage in the fuel system or air handling system?
YES NO

Repair or replace any damaged components.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Apr-2015


FAULT CODE 3584 - Engine Derate - Special Instructions

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3584 active?
STEP 2. | Check the PowerCommand® generator control panel. |
 | STEP 2A. Check if the generator set PowerCommand® generator control panel has requested the generator set circuit breaker to open. | Generator set PowerCommand® generator control has an active generator set circuit breaker inhibit?
 | STEP 2B. Check if the generator set PowerCommand® generator control panel has requested the utility paralleling circuit breaker to open. | Generator set PowerCommand® generator control has an active utility paralleling circuit breaker inhibit?
STEP 3. | Check the generator set circuit breaker |
 | STEP 3A. Check the status generator set circuit breaker. | Generator set circuit breaker tripped?
 | STEP 3B. Check the status of the generator set circuit breaker protection devices. | Generator set circuit breaker utility protection devices tripped?
STEP 4. | Check the utility paralleling circuit breaker |
 | STEP 4A. Check the status utility paralleling circuit breaker. | Utility paralleling circuit breaker tripped?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 3584 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3584 active?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the PowerCommand® Generator Control Panel

Guided Step 2A - Check if the generator set PowerCommand® generator control panel has requested the generator set circuit breaker to open.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check if the generator set PowerCommand® generator control panel has requested the generator set circuit breaker to open.

For PowerCommand® Supervisor 3100 generator control check for:

  • Circuit breaker Inhibit command being activated via an external control. Check light emitting diode (LED) DS9 (1) on the customer interface board, A34 (2) if the LED is illuminated, the circuit breaker inhibit command has been requested. Alternatively, check for the generator set Breaker Close INHIBIT notification on the human machine interface (HMI) located in the generator control panel (GCP).
  • Contact a Cummins® Authorized Repair Location.

For PowerCommand® Control 3300 generator control check for:

  • Via the control panel Human Machine Interface (HMI), check the status of the generator CB Inh/#28 (Advance Controller Status Screen 5 of 6) the status will state ACTIVE if a generator set circuit breaker Inhibit has been requested.
  • Contact a Cummins® Authorized Repair Location.

The generator set PowerCommand® generator control has an active generator set circuit breaker inhibit?
YES NO

Investigate the cause of the generator set circuit breaker being commanded to open.

  • Contact site operators and check reason for generator set circuit breaker inhibit being activated.
  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check if the generator set PowerCommand® generator control panel has requested the utility paralleling circuit breaker to open.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check if the generator set PowerCommand® generator control panel has requested the utility paralleling circuit breaker to open.

NOTE: This step only applies to generator sets fitted with PowerCommand® Control 3300 generator control.

  • Via the control panel HMI, check the status of the Util CB Inh/#25 (Advance Controller Status Screen 5 of 6) the status will state ACTIVE if a utility paralleling circuit breaker inhibit has been requested.
  • Contact a Cummins® Authorized Repair Location.

The generator set PowerCommand® generator control has an active utility paralleling circuit breaker inhibit?
YES NO

Investigate the cause of the generator set circuit breaker being commanded to open.

  • Contact site operators and check reason for generator set circuit breaker inhibit being activated.
  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the generator set circuit breaker.

Guided Step 3A - Check the status generator set circuit breaker.

Conditions

  • Connect all components
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the status generator set circuit breaker.

  • Generator set circuit breaker tripped.
  • Contact a Cummins® Authorized Repair Location.

Generator set circuit breaker tripped?
YES NO

Investigate and rectify the cause of the generator set circuit breaker tripping.

  • Attempt to reset the generator set circuit breaker.
  • Check for instantaneous short circuit.
  • Check for long-time short circuit.
  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the status of the generator set circuit breaker protection devices.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the status of the generator set circuit breaker utility protection devices.

Check the following:

  • Generator set circuit breaker utility protection relay tripped.
  • Vector shift or rate of change of frequency (ROCOF) relay tripped.
  • Contact a Cummins® Authorized Repair Location.

Generator set circuit breaker utility protection devices tripped?
YES NO

Investigate the cause of the generator set utility protection devices tripping.

  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the utility paralleling circuit breaker.

Guided Step 4A - Check the status utility paralleling circuit breaker.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the status utility paralleling circuit breaker.

  • Utility paralleling circuit breaker tripped.
  • Contact a Cummins® Authorized Repair Location.

Utility paralleling circuit breaker tripped?
YES NO

Investigate and rectify the cause of the utility paralleling circuit breaker tripping.

  • Attempt to RESET the utility paralleling circuit breaker.
  • Check for instantaneous short circuit.
  • Check for long-time short circuit.
  • Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3584 is inactive.

Fault Code 3584 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 26-May-2015


FAULT CODE 3585 - Generator Total Real Power - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 296. | Active or inactive counts of Fault Code 2863?
 | STEP 1B. Check for Fault Code 296. | Active or inactive counts of Fault Code 3585?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2863.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2863?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 3585.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Active or inactive counts of Fault Code 3585?
YES NO

See equipment manufacturer service information.

 No Repair

See equipment manufacturer service information.

Repair complete.

Last Modified: 16-Apr-2015


FAULT CODE 3586 - Generator Total Real Power - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 296. | Active or inactive counts of Fault Code 2863?
 | STEP 1B. Check for Fault Code 296. | Active or inactive counts of Fault Code 3586?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2863?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Active or inactive counts of Fault Code 3586?
YES NO

See equipment manufacturer service information.

 No Repair

See equipment manufacturer service information.

Repair complete.

Last Modified: 02-Jun-2015


FAULT CODE 3594 - Engine Emissions Closed Loop Fueling Adjustment - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Control Valve Body Assembly | Refer to Procedure 006-049 | QSK60 G CM2358 K110 | 4383781
Fuel Recommendations and Specifications | Refer to Procedure 018-002 | QSK60 G CM2358 K110 | 4383781
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781
Gas Mass Flow Sensor | Refer to Procedure 019-101 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, and/or 2867 active?
STEP 2. | Check the coolant temperature sensor (high temperature coolant circuit). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 625 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the intake manifold temperature and pressure sensors. |
 | STEP 3A. Inspect the intake manifold temperature sensor, pressure sensor, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance intake manifold temperature sensor. | 625 ohms to 36k ohms?
 | STEP 3C. Check the intake manifold pressure sensor supply voltage. | 4.75 VDC to 5.25 VDC?
 | STEP 3D. Check the intake manifold pressure sensor signal voltage. | 0.5 VDC to 4.5 VDC?
 | STEP 3E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the fuel inlet and fuel outlet pressure sensors. |
 | STEP 4A. Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel inlet and fuel outlet pressure sensors supply voltage. | 4.75 VDC to 5.25 VDC?
 | STEP 4C. Check the fuel inlet pressure sensor signal voltage. | 1.7 VDC to 4.5 VDC?
 | STEP 4D. Check the fuel outlet pressure sensor signal voltage. | 0.5 VDC to 4.5 VDC?
 | STEP 4E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the gas mass flow sensor. |
 | STEP 5A. Inspect the gas mass flow sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the gas mass flow sensor supply voltage. | 8 VDC to 15 VDC?
 | STEP 5C. Check the gas mass flow sensor signal voltage. | 0.46 VDC to 4.50 VDC?
 | STEP 5D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the fuel control valve. |
 | STEP 6A. Check the fuel control valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 6B. Inspect the fuel control valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check the actuator commanded signal percent duty cycle signal. | Percent duty cycle 10 to 91 percent?
 | STEP 6D. Check the fuel control valve feedback signal voltage. | 0 VDC to 5 VDC?
 | STEP 6E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6F. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the kilowatt load reference signal, if installed. |
 | STEP 7A. Check the kilowatt load transducer referance signal. | Kilowatt load transducer-sensed kilowatt matches generator set controller kilowatts?
 | STEP 7B. Check the calibration of the generator set controller. | Generator set controller voltage and ampere output calibration correct?
STEP 8. | Check the quality of the natural gas supply to the generator set. |
 | STEP 8A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 3594 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, and/or 2867 active?

YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference 4021353-t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 9A

Go to 2A

Guided Step 2 - Check the coolant temperature sensor (high temperature circuit).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the ECM connector.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 9A

Guided Step 2C - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature)
  • Disconnect the harness from the ECM connector.

Action

Check for a short circuit to engine ground.

Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 9A

Guided Step 2D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) SIGNAL pin in the ECM connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) RETURN pin in the ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 9A

Guided Step 3 - Check the intake manifold temperature and pressure sensors.

Guided Step 3A - Inspect the intake manifold temperature sensor, pressure sensor, and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the intake manifold temperature sensor connector.
  • Disconnect the intake manifold pressure sensor.
  • Disconnect the left bank ECM connector.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3B

Guided Step 3B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 3C

Go to 9A

Guided Step 3C - Check the intake manifold temperature sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the breakout cable SUPPLY and RETURN test connectors.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

  • Proceed to troubleshooting step 3E.

Go to 3D

Go to 3E

Guided Step 3D - Check the intake manifold temperature sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the SIGNAL voltage by connecting a multimeter to the breakout cable SIGNAL and RETURN test connectors.

0.46 VDC to 4.50 VDC?
YES NO
No Repair

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 3E

Go to 9A

Guided Step 3E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check for a short circuit to engine ground.

Measure the resistance from the SUPPLY pin of the intake manifold temperature sensor connector to the engine block ground.

  • Measure the resistance from the SIGNAL pin of the intake manifold temperature sensor connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 9A

Guided Step 3F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check the intake manifold temperature and pressure sensor circuits for an open circuit

  • Measure the resistance from the intake manifold temperature sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor SIGNAL pin in the left bank ECM connector.
  • Measure the resistance from the intake manifold temperature sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor RETURN pin in the left bank ECM connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SUPPLY pin in the left bank ECM connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor RETURN pin in the left bank ECM connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SIGNAL pin in the left bank ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 9A

Guided Step 4 - Check the fuel inlet and fuel outlet pressure sensors

Guided Step 4A - Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the fuel inlet pressure sensor harness connector.
  • Disconnect the fuel outlet pressure sensor connector.
  • Disconnect the left bank ECM connector.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel inlet and outlet pressure sensors. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 4B

Guided Step 4B - Check the fuel inlet and fuel outlet pressure sensors supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor supply voltage.

  • Measure the SUPPLY voltage by connecting a multimeter to the breakout cable SUPPLY and RETURN test connectors.

Check the fuel outlet pressure sensor SUPPLY voltage.

  • Measure the SUPPLY voltage by connecting a multimeter to the breakout cable supply and RETURN test connectors.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4E

Guided Step 4C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the breakout cable SIGNAL and RETURN test connectors.

1.7 VDC to 4.50 VDC?
YES NO
No Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4D

Go to 9A

Guided Step 4D - Check the fuel outlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the SIGNAL voltage by connecting a multimeter to the breakout cable SIGNAL and RETURN test connectors.

0.5 VDC to 4.50 VDC?
YES NO
No Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4E

Go to 9A

Guided Step 4E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel outlet sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 9A

Guided Step 4F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check the fuel inlet and fuel outlet pressure sensor circuits for an open circuit.

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SUPPLY pin in the left bank ECM connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor RETURN pin in the left bank ECM connector.
  • Measure the resistance from the fuel inlet pressure SIGNAL return pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SIGNAL pin in the left bank ECM connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SUPPLY pin in the left bank ECM connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor RETURN pin in the left bank ECM connector.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SIGNAL pin in the left bank ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 9A

Guided Step 5 - Check the gas mass flow sensor.

Guided Step 5A - Inspect the gas mass flow sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left bank ECM connector.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel inlet and outlet pressure sensors. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 5B

Guided Step 5B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor SUPPLY and RETURN connector pins in the main engine harness.

8.0 VDC to 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5D

Guided Step 5C - Check the gas mass flow sensor signal voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the left bank ECM connector.

Action

Check the gas mass flow sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the left bank ECM connector.

0.46 VDC to 4.50 VDC?
YES NO
No Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

Go to 5D

Go to 9A

Guided Step 5D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5E

Go to 9A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check the gas mass flow sensor circuits for an open circuit.

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the left bank ECM connector.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the left bank ECM connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the left bank ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6A

Go to 9A

Guided Step 6 - Check the fuel control valve.

Guided Step 6A - Check the fuel control valve for free movement.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test within the ECM Diagnostic Tests option and compare the actuator commanded position and position feedback signals.
  • Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

7A or 7B as appropriate

Go to 6B

Guided Step 6B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the left bank ECM connector.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the inlet and outlet pressure sensors. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 6C

Guided Step 6C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the Commanded Signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL positive (+) and RETURN negative (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 to 91 percent?
YES NO
No Repair

Check the power supply connections and the fuses. Use the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 6D

Go to 6E

Guided Step 6D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN negative (-) pins. The feedback signal must be between 0 VDC to 5 VDC.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 VDC to 5 VDC?
YES NO
No Repair

  • Replace the fuel control valve. Refer to Procedure 006-049 in the Associated Procedures Table.

Go to 6E

Go to 9A

Guided Step 6E - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect all sensors that have a shared supply or return with the fuel control valve.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL positive (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN negative (-) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position feedback pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6F

Go to 9A

Guided Step 6F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the harness from the left bank ECM connector.

Action

Check the fuel control valve for an open circuit.

  • Measure the resistance from the fuel control valve position actuator SIGNAL positive (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL positive (+) pin in the left bank ECM connector.
  • Measure the resistance from the fuel control valve position actuator RETURN negative (-) pin in the fuel control valve connector to the fuel control valve position actuator RETURN negative (-) pin in the left bank ECM connector.
  • Measure the resistance from the fuel control valve position feedback pin in the fuel control valve connector to the fuel control valve position feedback pin in the left bank ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 7A

Go to 9A

Guided Step 7 - Check the kilowatt load transducer, if installed.

Guided Step 7A - Check the kilowatt load transducer reference signal.

Conditions

If the generator set is not fitted with a Kilowatt Load Transducer, proceed to Guided Step 7B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliampere / load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 9A

Guided Step 7B - Check the calibration of the generator set controller.

Conditions

This guided step should only be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect a power analyzer or digital multimeter.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1-L2, L2-L3, and L3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 9A

Guided Step 8 - Check the quality of the natural gas supply to the generator set.

Guided Step 8A - Check the quality of the natural gas supply

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the kilowatt load transducer reference signal.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure for fuel recommendations and specification information. Refer to Procedure 018-002 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3594 is inactive.

Fault Code 3594 inactive?
YES NO

  • Use INSITE™ electronic service tool and an exhaust gas analyzer to check the exhaust emissions against the specification for the engine and fine-tune as required.
  • Contact a Cummins® Authorized Repair Location.
  • Use the following procedure for fuel recommendations and specification information. Refer to Procedure 018-002 in the Associated Procedures Table.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 3595 - Engine Emissions Closed Loop Fueling Adjustment - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Control Valve Body Assembly | Refer to Procedure 006-049 | QSK60 G CM2358 K110 | 4383781
Fuel Recommendations and Specifications | Refer to Procedure 018-002 | QSK60 G CM2358 K110 | 4383781
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 G CM2358 K110 | 4383781
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781
Gas Mass Flow Sensor | Refer to Procedure 019-101 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867, and/or 3494 active?
STEP 2. | Check the coolant temperature sensor (high temperature coolant circuit). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | Resistance between 625 ohms and 36k ohms?
 | STEP 2C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the intake manifold temperature and pressure sensors. |
 | STEP 3A. Inspect the intake manifold temperature sensor, pressure sensor, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance intake manifold temperature sensor. | Resistance between 625 ohms and 36k ohms?
 | STEP 3C. Check the intake manifold pressure sensor supply voltage. | Voltage between 4.75 VDC and 5.25 VDC?
 | STEP 3D. Check the intake manifold pressure sensor signal voltage. | Voltage between 0.5 VDC and 4.5 VDC?
 | STEP 3E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the fuel inlet and fuel outlet pressure sensors. |
 | STEP 4A. Inspect the fuel inlet and fuel outlet pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel inlet and fuel outlet pressure sensors supply voltage. | Voltage between 4.75 VDC and 5.25 VDC?
 | STEP 4C. Check the fuel inlet pressure sensor signal voltage. | Voltage between 1.7 VDC and 4.5 VDC?
 | STEP 4D. Check the fuel outlet pressure sensor signal voltage. | Voltage between 0.5 VDC and 4.5 VDC?
 | STEP 4E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the gas mass flow sensor. |
 | STEP 5A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the sensor supply voltage. | Voltage between 8 VDC and 15 VDC?
 | STEP 5C. Check the sensor signal voltage. | Voltage between 0.46 VDC and 4.56 VDC?
 | STEP 5D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the fuel control valve actuator. |
 | STEP 6A. Check the fuel control valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 6B. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check the actuator commanded signal percent duty cycle signal. | Percent duty cycle 10 to 91 percent?
 | STEP 6D. Check the actuator commanded position feedback signal. | Voltage between 0 VDC and 5 VDC?
 | STEP 6E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6F. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the kilowatt load reference signal. |
 | STEP 7A. If fitted, check the kilowatt load transducer sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
 | STEP 7B. Check the generator set controller calibration. | Generator set controller voltage and ampere output calibration correct?
STEP 8. | Check the quality of the natural gas supply to the generator set. |
 | STEP 8A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for generator set?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 3595 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3494 active?

YES NO

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise Excessive - Combustion Knocks troubleshooting symptom tree in Section TS.

Go to 9A

Go to 2A

Guided Step 2 - Check the coolant temperature sensor (high temperature circuit).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the ECM connector.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 9A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

Voltage between 625 ohms and 36k ohms?
YES NO
No Repair

  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 9A

Guided Step 2C - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the ECM connector.

Action

Check for a short circuit.

Check for a short circuit to engine ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 9A

Guided Step 2D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) SIGNAL pin in the ECM connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) RETURN pin in the ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 9A

Guided Step 3 - Check the intake manifold temperature and pressure sensors.

Guided Step 3A - Inspect the intake manifold temperature sensor, pressure sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the intake manifold temperature sensor connector.
  • Disconnect the intake manifold pressure sensor.
  • Disconnect the left bank ECM connector.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 3B

Guided Step 3B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin.

Resistance between 625 ohms and 36k ohms?
YES NO
No Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 3C

Go to 9A

Guided Step 3C - Check the intake manifold temperature sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the breakout cable SUPPLY and RETURN test connectors.

Voltage between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Check the intake manifold temperature sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the breakout cable SIGNAL and RETURN test connectors.

Voltage between 0.46 VDC and 4.50 VDC?
YES NO
No Repair

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

Go to 3E

Go to 9A

Guided Step 3E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check for a short circuit.

Check for a short circuit to engine ground.

  • Measure the resistance from the SUPPLY pin of the intake manifold temperature sensor connector to the engine block ground.
  • Measure the resistance from the SIGNAL pin of the intake manifold temperature sensor connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 9A

Guided Step 3F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the intake manifold pressure sensor.
  • Disconnect the engine harness from the intake manifold temperature sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check the intake manifold temperature and pressure sensor circuits for an open circuit

  • Measure the resistance from the intake manifold temperature sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor SIGNAL pin in the left bank ECM connector.
  • Measure the resistance from the intake manifold temperature sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor RETURN pin in the left bank ECM connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SUPPLY pin in the left bank ECM connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor RETURN pin in the left bank ECM connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SIGNAL pin in the left bank ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 9A

Guided Step 4 - Check the fuel inlet and fuel outlet pressure sensors.

Guided Step 4A - Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the fuel inlet pressure sensor harness connector.
  • Disconnect the fuel outlet pressure sensor connector.
  • Disconnect the left bank ECM connector.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel inlet and outlet pressure sensors. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 4B

Guided Step 4B - Check the fuel inlet and fuel outlet pressure sensors supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the breakout cable SUPPLY and RETURN test connectors.

Check the fuel outlet pressure sensor supply voltage.

  • Measure the SUPPLY voltage by connecting a multimeter to the breakout cable supply and RETURN test connectors.

Voltage between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4E

Guided Step 4C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the breakout cable SIGNAL and RETURN test connectors.

Voltage between 1.7 VDC and 4.50 VDC?
YES NO
No Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4D

Go to 9A

Guided Step 4D - Check the fuel outlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the breakout cable SIGNAL and RETURN test connectors.

Voltage between 0.5 VDC and 4.50 VDC?
YES NO
No Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 4E

Go to 9A

Guided Step 4E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel outlet sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4F

Go to 9A

Guided Step 4F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel inlet pressure sensor.
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check the fuel inlet and fuel outlet pressure sensor circuits for an open circuit.

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SUPPLY pin in the left bank ECM connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor RETURN pin in the left bank ECM connector.
  • Measure the resistance from the fuel inlet pressure SIGNAL return pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SIGNAL pin in the left bank ECM connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SUPPLY pin in the left bank ECM connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor RETURN pin in the left bank ECM connector.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SIGNAL pin in the left bank ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 9A

Guided Step 5 - Check the gas mass flow sensor.

Guided Step 5A - Inspect the gas mass flow sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the left bank ECM connector.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel inlet and outlet pressure sensors. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 5B

Guided Step 5B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor SUPPLY and RETURN connector pins in the main engine harness.

Voltage between 8.0 VDC and 15.0 VDC?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5D

Guided Step 5C - Check the gas mass flow sensor signal voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main engine harness from the left bank ECM connector.

Action

Check the gas mass flow sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the left bank ECM connector.

Voltage between 0.46 VDC and 4.50 VDC?
YES NO
No Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 in the Associated Procedures Table.

Go to 5D

Go to 9A

Guided Step 5D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 5E

Go to 9A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the gas mass flow sensor.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check the gas mass flow sensor circuits for an open circuit.

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the left bank ECM connector.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the left bank ECM connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the left bank ECM connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 6A

Go to 9A

Guided Step 6 - Check the fuel control valve.

Guided Step 6A - Check the fuel control valve for free movement.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test within the ECM Diagnostic Tests option and compare the actuator commanded position and position feedback signals.
  • Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES | NO
No Repair | No Repair

7A or 7B as appropriate.

Go to 6B

Guided Step 6B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the left bank ECM connector.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the inlet and outlet pressure sensors. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 9A

Go to 9A

Guided Step 6C - Check the actuator commanded signal precent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL positive and RETURN negative pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 to 91 percent?
YES NO
No Repair

Check the power supply connections and the fuses. Refer to the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 6D

Go to 6E

Guided Step 6D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position FEEDBACK and RETURN negative pins. The feedback signal must be between 0 VDC and 5 VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 0 VDC and 5 VDC?
YES NO
No Repair

Replace the fuel control valve. Refer to Procedure 006-049 in the Associated Procedures Table.

Go to 6E

Go to 9A

Guided Step 6E - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect all sensors that have a shared supply or return with the fuel control valve.
  • Disconnect the engine harness from the left bank ECM connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL positive (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN negative (-) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position FEEDBACK pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6F

Go to 9A

Guided Step 6F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • De-energize 24 VDC power supply.
  • Disconnect the engine harness from the fuel control valve.
  • Disconnect the harness from the left bank ECM connector.

Action

Check the fuel control valve for an open circuit.

  • Measure the resistance from the fuel control valve position actuator SIGNAL positive (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL positive (+) pin in the left bank ECM connector.
  • Measure the resistance from the fuel control valve position actuator RETURN negative (-) pin in the fuel control valve connector to the fuel control valve position actuator RETURN negative (-) pin in the left bank ECM connector.
  • Measure the resistance from the fuel control valve position FEEDBACK pin in the fuel control valve connector to the fuel control valve position FEEDBACK pin in the left bank ECM connector.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 7A

Go to 9A

Guided Step 7 - Check the kilowatt load transducer (if fitted)

Guided Step 7A - Check the kilowatt load transducer reference signal.

Conditions

If the Generator Set is not fitted with a kilowatt load transducer, proceed to Guided Step 7B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliampere / load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 9A

Guided Step 7B - Check the calibration of the generator set controller.

Conditions

This guided step should only be followed for Generator Sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1-L2, L2-L3, and L3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 9A

Guided Step 8 - Check the quality of the Natural Gas supply to the generator set.

Guided Step 8A - Check the quality of the Natural Gas supply

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the kilowatt load transducer reference signal.

  • Check the quality of the Natural Gas supplied to the generator set meets or exceeds minimum requirement for Generator Set (methane number and fuel contaminants limits).
  • Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and running for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3595 is inactive.

Fault Code 3595 inactive?
YES NO

  • Use INSITE™ electronic service tool and an exhaust gas analyzer to check the exhaust emissions against the specification for the engine and fine-tune as required.
  • Contact a Cummins® Authorized Repair Location.
  • Refer to Procedure 018-002 in the Associated Procedures Table.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 27-Jul-2015


FAULT CODE 3846 - Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Fault Code 3846 active and/or high counts of inactive?
STEP 2. | Check the fuel actuator. |
 | STEP 2A. Check the power supply. | Power supply Fault Code 2311 active or high counts of inactive fault codes?
STEP 3. | Check the engine room ventilation fans. |
 | STEP 3A. Check the operation of the engine room ventilation fans. | Engine room ventilation fans operating correctly?
 | STEP 3B. Check air flow through the container. | Normal engine room air flow?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Fault Code 3846 active/or high counts of inactive?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel actuator.

Guided Step 2A - Check the power supply.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

Power supply Fault Code 2311 active or high counts of inactive fault codes?
YES NO

Go to the appropriate fault code troubleshooting tree.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine room ventilation fans.

Guided Step 3A - Check the operation of the engine room ventilation fans.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room ventilation fans.

  • Ventilation fans are operating when the generator set is operating.
  • Ventilation fans "run-on" for specified period following normal shutdown.

Engine room ventilation fans operating correctly?
YES NO
No Repair

Repair or replace the engine room ventilation fans, fan supply, or fan control. Contact a Cummins® Authorized Repair Location.

Go to 3B

Go to 4A

Guided Step 3B - Check air flow through container.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room air flow.

  • Ventilation fans are operating when the generator set is operating.
  • Ventilation fans "run-on" for specified period following normal shutdown.

Normal engine room air flow?
YES NO
No Repair

Recover engine room air flow.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 3847 - Engine Fuel Actuator Control - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of Fault Code 2311?
STEP 2. | Check engine room temperature. |
 | STEP 2A. Check engine room temperature. | Engine room temperature below AEB manual?
STEP 3. | Check the fuel actuator. |
 | STEP 3A. Check the fuel actuator. | Ice on the device?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate generator set for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 2311?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine room temperature.

Guided Step 2A - Check engine room temperature.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room temperature.

Engine room temperature below AEB manual?
YES NO
No Repair

Recover engine room temperature.

Go to 3B

Go to 4A

Guided Step 3 - Check the fuel actuator.

Guided Step 3A - Check the fuel actuator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel actuator device.

Ice on the device?
YES NO

Remove the ice.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 3848 - Engine Fuel Actuator Control - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3848 active?
 | STEP 1B. Read the fault codes. | Active or inactive counts of Fault Code 2311, 3846, 3847, 3849, or 3851?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3848 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Active or inactive counts of Fault Code 2311, 3846, 3847, 3849, or 3851?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 3849 - Engine Fuel Actuator Control - Bad Intelligent Device Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel actuator fault codes. |
 | STEP 1A. Check the fuel actuator. | Fault Code 2311 active?
STEP 2. | Check the fuel actuator. |
 | STEP 2A. Inspec the fuel actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fuel actuator fault codes.

Guided Step 1A - Check the fuel actuator.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Fault Code 2311 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the fuel actuator.

Guided Step 2A - Inspect the fuel actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel actuator from the engine harness.

Action

Inspect the engine harness and fuel actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

A damaged fuel actuator has been detected.

Replace the fuel actuator.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 3858 - Engine Turbocharger Compressor Bypass Actuator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Fault Code 3858 active and/or high counts of inactive?
STEP 2. | Check the actuator. |
 | STEP 2A. Check the power supply. | Power supply Fault Codes 3489, 441, 442, and/or 478 active or high counts of inactive fault codes?
STEP 3. | Check engine room ventilation fans. |
 | STEP 3A. Check the operation of the engine room ventilation fans. | Engine room ventilation fans operating correctly?
 | STEP 3B. Check air flow through container. | Normal engine room air flow?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Fault Code 3858 active and/or high counts of inactive?
YES NO

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the actuator.

Guided Step 2A - Check the power supply.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

Power supply Fault Codes 3489, 441, 442, and/or 478 active or high counts of inactive fault codes?
YES NO

Go to the appropriate fault code troubleshooting tree.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine room ventilation fans.

Guided Step 3A - Check the operation of the engine room ventilation fans.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room ventilation fans.

  • Ventilation fans are operating when the generator set is operating.
  • Ventilation fans "run-on" for a specified period following normal shutdown.

Engine room ventilation fans operating correctly?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check air flow through the container.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room air flow.

  • Ventilation fans are operating when the generator set is operating.
  • Ventilation fans "run-on" for a specified period following normal shutdown.

Check the air flow according to Application Engineering Bulletin (AEB) manual.

Normal engine room air flow?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 3859 - Engine Turbocharger Compressor Bypass Actuator - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of power supply Fault Codes 441, 442, 477, 478, and/or 3489?
STEP 2. | Check the engine room temperature. |
 | STEP 2A. Check the engine room temperature. | Engine room temperature below Application Engineering Bulletin (AEB) manual?
STEP 3. | Check the actuator. |
 | STEP 3A. Check the actuator. | Ice on the device?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate generator set for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of power supply Fault Codes 441, 442, 477, 478, and/or 3489?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine room temperature.

Guided Step 2A - Check engine room temperature.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room temperature.

Engine room temperature below AEB manual?
YES NO
No Repair

Recover engine room temperature.

Go to 3B

Go to 4A

Guided Step 3 - Check the actuator.

Guided Step 3A - Check the actuator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the actuator device.

Ice on the device?
YES NO

Remove ice.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 3861 - Engine Turbocharger Compressor Bypass Actuator - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Power supply Fault Codes 441, 442, 477, 478, and/or 3849 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3849 active?
STEP 2. | Check the valve circuit. |
 | STEP 2A. Inspect the turbocharger compressor bypass valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fault codes and verify the turbocharger compressor bypass valve connector condition. | Fault Code 3861 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 3861 active?
STEP 4. | Check the engine throttle. |
 | STEP 4A. Check for a restricted actuator. | Restricted or debris blocking the actuator?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Power supply Fault Codes 441, 442, 477, 478, and/or 3849 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3864 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the valve circuit.

Guided Step 2A - Inspect the turbocharger compressor bypass valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass valve from the engine harness.

Action

Inspect the engine harness and turbocharger compressor bypass valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fault codes and verify the turbocharger compressor bypass valve connector condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor bypass valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3861 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 5A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the turbocharger compressor bypass valve engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the turbocharger compressor bypass valve engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass valve from the engine harness.
  • Disconnect the fuel control valve from the harness.
  • Disconnect the engine harness from the ECM connector.
  • Remove the SAE J1939 termination resistor from the engine harness.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness.

Repair or replace the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass valve from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) sire at the ECM engine harness connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness.

Repair or replace the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 5A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3861 active?
YES NO

Replace the turbocharger compressor bypass actuator.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check the engine throttle.

Guided Step 4A - Check for a restricted actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check for a restriction.

  • Inspect the actuator for a restriction or debris blocking the throttle plate.

Restriction or debris blocking the actuator?
YES NO

Remove the restriction or debris.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 3862 - Engine Turbocharger Compressor Bypass Actuator - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3862 active?
 | STEP 1B. Read the fault codes. | Active or inactive counts of Fault Codes 3489, 3858, 3859, 3861, and/or 3864?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3862 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Codes 3489, 3858, 3859, 3861, and/or 3864?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2015


FAULT CODE 3863 - Engine Turbocharger Compressor Bypass Actuator - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Compressor Bypass Control Valve | Refer to Procedure 010-136 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the turbocharger compressor bypass faults. |
 | STEP 1A. Check the power supply fault codes. | Power supply Fault Codes 441, 442, 477, 478, and/or 3489 active?
 | STEP 1B. Check the turbocharger compressor bypass actuator. | Fault Code 3863 active?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Inspect the turbocharger compressor bypass actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the turbocharger compressor bypass faults.

Guided Step 1A - Check the power supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Power supply Fault Codes 441, 442, 477, 478, and/or 3489 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the turbocharger compressor bypass actuator.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Fault Code 3863 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the turbocharger compressor bypass actuator.

Guided Step 2A - Inspect the turbocharger compressor bypass actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass actuator from the engine harness.

Action

Inspect the engine harness and turbocharger compressor bypass actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

A damaged turbocharger compressor bypass actuator has been detected.

Replace the turbocharger compressor bypass actuator. Refer to Procedure 010-136 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3864 - Engine Turbocharger Compressor Bypass Actuator - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3864 active?
STEP 2. | Check the engine control module (ECM) and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the J1939 data link harness. | Greater 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 2E. Check for an active fault code. | Fault Code 3864 active?
STEP 3. | Check the turbocharger compressor bypass actuator. |
 | STEP 3A. Inspect the turbocharger compressor bypass actuator connector pins. | Dirty or damaged pins?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3864 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the actuator engine harness connector and the SAE J1939 data link (+) wire at the ECM engine harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the actuator engine harness connector and the SAE J1939 data link (-) wire at the ECM engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass actuator from the engine harness.
  • Disconnect the fuel control valve from the harness.
  • Disconnect the engine harness from the ECM connector.
  • Remove the SAE J1939 termination resistor from the engine harness.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An short circuit has been detected in the J1939 data link harness.

Repair or replace the engine harness.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel control valve from the engine harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM engine harness connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3864 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the turbocharger compressor bypass actuator.

Guided Step 3A - Inspect the turbocharger compressor bypass actuator connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor bypass actuator from the engine harness.

Action

Inspect the turbocharger compressor bypass actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector or turbocharger compressor bypass actuator connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the turbocharger compressor bypass actuator.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 3869 - Low Voltage Ride Through - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3869 active or high inactive counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 3869 inactive?
 | STEP 2B. Clear the inactive fault codes. | Fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3869 active or high inactive counts?
YES NO

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual, Bulletin Number 0900-0670.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify that Fault Code 3869 is inactive.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3869 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 26-May-2015


FAULT CODE 3871 - Low Voltage Ride Through - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3871 and/or 426, 427, 781, and 3872 active or high inactive counts??
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3871 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3871 and/or 426, 427, 781, and 3872 active or high inactive counts?
YES NO

Proceed to next troubleshooting step.

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect engine wiring harness connectors from all ECMs.

Action

Check the J1939 data link circuit.

  • Check the Society of Automotive Engineers (SAE) J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair or replace the engine harness of the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Refer to Cummins Power Generation® generator set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the generator interface box. Refer to Cummins Power Generation® generator interface panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3871 is inactive.

Fault Code 3871 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location of all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 26-May-2015


FAULT CODE 3872 - Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3872 and/or 426, 427, 781, 3871, 3873, 3874 or 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3872 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3872 and/or 426, 427, 781, 3871, 3873, 3874 or 3875 active or high inactive counts?
YES NO
No Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all engine control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference the Cummins Power Generation® Generator Set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the Generator Interface Box. Refer to Cummins Power Generation® Generator Interface Panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3872 is inactive.

Fault Code 3872 inactive?
YES NO

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual Bulletin Number 0900-0670.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 3873 - Low Voltage Ride Through - Abnormal Frequency or Pulse Width or Period

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3873 and/or 426, 427, 781, 3871, 3872, 3874 and 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3873 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3873 and/or 426, 427, 781, 3871, 3872, 3874 and 3875 active or high inactive counts?
YES NO

Proceed to next troubleshooting step.

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect engine wiring harness connectors from all ECMs.

Action

Check the J1939 data link circuit.

  • Check the Society of Automotive Engineers (SAE) J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair or replace the engine harness of the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Refer to Cummins Power Generation® generator set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the generator interface box. Refer to Cummins Power Generation® generator interface panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3871 is inactive.

Fault Code 3871 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location of all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 28-Jul-2015


FAULT CODE 3874 - Low Voltage Ride Through - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3874 and/or 426, 427, 781, 3871, 3872, 3873 or 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3874 inactive?
 | STEP 3A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3874 and/or 426, 427, 781, 3871, 3872, 3873 or 3875 active or high inactive counts?
YES NO
No Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the Generator Set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all engine control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor Refer to Cummins Power Generation® Generator Set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the Generator Interface Box. Refer to Cummins Power Generation® Generator Interface Panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3874 is inactive.

Fault Code 3874 inactive?
YES NO

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual Bulletin Number 0900-0670.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Jul-2015


FAULT CODE 3875 - Low Voltage Ride Through - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3875 active or high inactive counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3875 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 3922 - Engine Turbocharger Compressor Bypass Actuator - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 7383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault coes. | Fault Code 3922 active?
STEP 2. | Check the variable flow turbocharger actuator motor and circuit. |
 | STEP 2A. Inspect the variable flow turbocharger actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the variable flow turbocharger actuator motor circuit. | Any measurements greater than 5 ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 3922 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the variable flow turbocharger actuator motor supply and return circuit. | Less than 10 ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 3922 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3922 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the variable flow turbocharger actuator motor and circuit.

Guided Step 2A - Inspect the variable flow turbocharger actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable flow turbocharger actuator from the engine harness.

Action

Inspect the engine harness variable flow turbocharger actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the variable flow turbocharger actuator motor circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable flow turbocharger actuator from the engine harness.

Action

Check the variable flow turbocharger actuator supply and return circuit.

  • Measure the resistance from the variable flow turbocharger actuator motor SUPPLY A pin to the variable flow turbocharger actuator motor SUPPLY B pin at the variable flow turbocharger actuator connector.
  • Measure the resistance from the variable flow turbocharger actuator motor SUPPLY A pin to the variable flow turbocharger actuator motor SUPPLY C pin at the variable flow turbocharger actuator connector.
  • Measure the resistance from the variable flow turbocharger actuator motor SUPPLY B pin to the variable flow turbocharger actuator motor SUPPLY C pin at the variable flow turbocharger actuator motor connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Any measurements greater than 5 ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3922 active?
YES NO

An open circuit has been detected in the variable flow turbocharger actuator motor.

Replace the variable flow turbocharger actuator.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the variable flow turbocharger actuator motor supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the variable flow turbocharger actuator motor supply and return circuit.

  • Measure the resistance from the variable flow turbocharger actuator motor SUPPLY A pin at the variable flow turbocharger actuator engine harness connector to the variable flow turbocharger actuator motor SUPPLY A pin at the ECM connector.
  • Measure the resistance from the variable flow turbocharger actuator motor SUPPLY B pin at the variable flow turbocharger actuator engine harness connector to the variable flow turbocharger actuator motor SUPPLY B pin at the ECM connector.
  • Measure the resistance from the variable flow turbocharger actuator motor SUPPLY C pin at the variable flow turbocharger actuator engine harness connector to the variable flow turbocharger actuator motor SUPPLY C pin at the ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3922 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 4617 - Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-061 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active or high counts?
 | STEP 1B. Check for an inactive fault code. | Fault Code 4617 inactive?
STEP 2. | Check the throttle delta pressure sensor and circuit. |
 | STEP 2A. Inspect the throttle delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4618 active and Fault Code 4617 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 4617 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active or high counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 4617 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the throttle delta pressure sensor and circuit.

Guided Step 2A - Inspect the throttle delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle delta pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness and throttle delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

See the circuit diagram or wiring diagram for all engine harness interconnections.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-061 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle delta pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4618 active and Fault Code 4617 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle delta pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the throttle delta pressure sensor 5 volt SUPPLY (sensor supply 2) pin to the throttle delta pressure sensor RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Use the wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the throttle delta pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4617 active?
YES NO

A damaged throttle delta pressure sensor has been detected.

Replace the throttle delta pressure sensor. Refer to Procedure 019-061 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

See the circuit diagram or wiring diagram for all engine interconnections.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4618 active and Fault Code 4617 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4617 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected in the throttle delta pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

See the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

See the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the throttle delta pressure 5 volt SUPPLY (sensor supply 2) pin to the throttle delta pressure RETURN (sensor return 2) pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4617 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open throttle delta pressure return (sensor return 2) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Use the circuit diagram or wiring diagram for all engine harness interconnections.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 4618 - Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 4618 inactive?
STEP 2. | Check the throttle delta pressure sensor and circuit. |
 | STEP 2A. Inspect the throttle delta pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 4617 active and Fault Code 4618 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 4618 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 4618 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19

Go to 2A

Guided Step 2 - Check the throttle delta pressure sensor and circuit.

Guided Step 2A - Inspect the throttle delta pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle delta pressure sensor from the engine harness.

Action

Inspect the engine harness and throttle delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle delta pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the throttle delta pressure sensor +5 volt SUPPLY pin to the throttle delta pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the throttle delta pressure sensor +5 volt SUPPLY pin and the throttle delta pressure sensor SIGNAL pin at the throttle delta pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4617 active and Fault Code 4618 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the throttle delta pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4618 active?
YES NO

A damaged sensor has been detected.

Replace the sensor.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the throttle delta pressure sensor +5 volt SUPPLY pin to the throttle delta pressure sensor RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4618 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the throttle delta pressure sensor +5 volt SUPPLY pin and the throttle delta pressure sensor SIGNAL pin at the engine control module engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4617 active and Fault Code 4618 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4618 inactive?
YES NO

The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 4621 - Engine Turbocharger 1 Boost Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or high inactive counts of Fault Code 2517 or 2518?
STEP 2. | Check the throttle intake pressure sensor. |
 | STEP 2A. Check for a stuck in range sensor. | INSITE™ electronic service tool reading sensor value changes in response to engine operation?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 2517 or 2518?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the throttle intake pressure sensor.

Guided Step 2A - Check for a stuck in range sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. Operate at varying speeds and load.

  • Start INSITE™ electronic service tool Data Monitor/Logger. Observe the INSITE™ electronic service tool reading for the throttle intake pressure.

INSITE™ electronic service tool reading sensor value changes in response to engine operation?
YES NO
No Repair

Replace the throttle intake pressure sensor.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 4622 - Engine Throttle Valve Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1827 or 1828 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness circuit. | Short circuit or open circuit?
STEP 3. | Check the sensor and circuit. |
 | STEP 3A. Inspect the sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fault codes and verify sensor condition. | Fault Code 4622 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1827 or 1828 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine harness circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the sensor single circuit.

  • Check for a short circuit or open circuit in the single line.

Short circuit or open circuit?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the sensor and circuit.

Guided Step 3A - Inspect the sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor from the engine harness.

Action

Inspect the engine harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4622 active?
YES NO

A damaged sensor has been detected.

Replace the sensor.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 4624 - Engine Gas Control Valve 1 Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Fuel Pressure Sensor | Refer to Procedure 019-188 | QSK60 G CM2358 K110 | 4383781

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2427 or 2428 active?
STEP 2. | Check the pressure sensor. |
 | STEP 2A. Check for a stuck in range sensor. | INSITE™ electronic service tool reading sensor value changes in response to engine operation?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness circuit. | Short circuit or open circuit?
STEP 4. | Check the sensor and circuit. |
 | STEP 4A. Inspect the sensor and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fault codes and verify sensor condition. | Fault Code 4624 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2427 or 2428 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the pressure sensor.

Guided Step 2A - Check for a stuck in range sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. Operate at varying speeds and load.

  • Start INSITE™ electronic service tool Data Monitor/Logger and observe the INSITE™ electronic service tool reading for the pressure.

INSITE™ electronic service tool reading sensor value changes in response to engine operation?
YES | NO
No Repair | No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the engine harness circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the sensor supply circuit.

  • Check for a short circuit and open circuit in the supply line.

Short circuit or open circuit?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the sensor and circuit.

Guided Step 4A - Inspect the sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor from the engine harness.

Action

Inspect the engine harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4624 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 4636 - Engine Throttle Valve Differential Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 2186 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 4636 inactive?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine harness circuit. | Short circuit or open circuit?
STEP 3. | Check the sensor and circuit. |
 | STEP 3A. Inspect the sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fault codes and verify sensor condition. | Fault Code 4636 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 4636 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine harness circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the sensor supply, return, and signal circuits.

  • Check for a short circuit and open circuit in the supply line.
  • Check for a short circuit and open circuit in the return line.
  • Check for a short circuit and open circuit in the signal line.

Short circuit or open circuit?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the sensor and circuit.

Guided Step 3A - Inspect the sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor from the engine harness.

Action

Inspect the engine harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4636 active?
YES NO

A damaged sensor has been detected.

Replace the sensor.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 4687 - Engine Controlled Shutdown Request - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2863, 1781, or 1782 active?
 | STEP 1B. Check the ECM for active fault codes. | Fault Code 4687 active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2863, 1781, or 1782 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4687 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Use the following procedure for the data link circuit. Refer to Procedure 019-417 in the Associated Procedures Table.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or ECM.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for the data link circuit. Refer to Procedure 019-417 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 5118 - Engine Turbocharger Wastegate Actuator 1 Position - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Wastegate Assembly | Refer to Procedure 011-097 | QSK60 G CM2358 K110 | 4383781

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Sensor supply fault codes or Fault Code 1696 active or high counts?
 | STEP 1B. Read the fault codes. | Fault Code 545, 3922, or 3925 active?
STEP 2. | Check the turbocharger wastegate actuator. |
 | STEP 2A. Check the actuator operation. | Pass testing?
 | STEP 2B. Check for a restricted engine throttle. | Restriction or debris blocking the engine actuator?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes or Fault Code 1696 active or high counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 545, 3922, or 3925 active?
YES NO

Appropriate fault code troubleshooting tree.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the turbocharger wastegate actuator.

Guided Step 2A - Check the actuator operation.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck actuator valve.

  • Perform the wastegate actuator test.

Pass testing?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a restricted engine throttle.

Conditions

  • De-energize keyswitch circuit.

Action

Check for a restriction.

  • Inspect the engine actuator for a restriction or debris blocking the valve.

Restriction or debris blocking the engine actuator?
YES NO

Remove the restriction or debris.

Replace the actuator. Refer to Procedure 011-097 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jun-2015


INDEX
224-fc121.htm

224-t05-121.htm

224-fc135.htm

224-t05-135.htm

224-fc136.htm

224-t05-136.htm

224-fc137.htm

224-t05-137.htm

224-fc141.htm

224-t05-141.htm

224-fc142.htm

224-t05-142.htm

224-fc143.htm

224-t05-143.htm

224-fc144.htm

224-t05-144.htm

224-fc145.htm

224-t05-145.htm

224-fc146.htm

224-t05-146.htm

224-fc151.htm

224-t05-151.htm

224-fc153.htm

214-t05-153.htm

224-fc154.htm

224-t05-154.htm

224-fc155.htm

224-t05-155.htm

224-fc177.htm

224-t05-177.htm

224-fc187.htm

224-fc187sa00.htm

224-t05-187sa00.htm

224-fc187sa39.htm

224-t05-187sa39.htm

224-fc197.htm

224-t05-197.htm

224-fc212.htm

224-t05-212.htm

224-fc213.htm

224-t05-213.htm

224-fc214.htm

224-t05-214.htm

224-fc219.htm

224-t05-219.htm

224-fc227.htm

224-t05-227.htm

224-fc228.htm

224-t05-228.htm

224-fc231.htm

224-t05-231.htm

224-fc232.htm

224-t05-232.htm

224-fc233.htm

224-t05-233.htm

224-fc234.htm

224-t05-234.htm

224-fc235.htm

224-t05-235.htm

224-fc238.htm

224-t05-238.htm

224-fc239.htm

224-t05-239.htm

224-fc248.htm

224-t05-248.htm

224-fc253.htm

224-t05-253.htm

224-fc254.htm

224-t05-254.htm

224-fc263.htm

224-t05-263.htm

224-fc265.htm

224-t05-265.htm

224-fc277.htm

224-t05-277.htm

224-fc343.htm

224-t05-343.htm

224-fc346.htm

224-t05-346.htm

224-fc352.htm

224-t05-352.htm

224-fc354.htm

224-t05-354.htm

224-fc355.htm

224-t05-355.htm

224-fc359.htm

224-t05-359.htm

224-fc386.htm

224-t05-386.htm

224-fc412.htm

224-t05-412.htm

224-fc414.htm

224-t05-414.htm

224-fc415.htm

224-t05-415.htm

224-fc421.htm

224-t05-421.htm

224-fc426.htm

224-t05-426.htm

224-fc427.htm

224-t05-427.htm

224-fc441.htm

224-t05-441.htm

224-fc442.htm

224-t05-442.htm

224-fc453.htm

224-t05-453.htm

224-fc454.htm

224-t05-454.htm

224-fc459.htm

224-t05-459.htm

224-fc462.htm

224-t05-462.htm

224-fc477.htm

224-t05-477.htm

224-fc478.htm

224-t05-478.htm

224-fc488.htm

224-t05-488.htm

224-fc545.htm

214-t05-545.htm

224-fc556.htm

214-t05-556.htm

224-fc561.htm

224-t05-561.htm

224-fc562.htm

224-t05-562.htm

224-fc563.htm

224-t05-563.htm

224-fc564.htm

224-t05-564.htm

224-fc565.htm

224-t05-565.htm

224-fc566.htm

224-t05-566.htm

224-fc567.htm

224-t05-567.htm

224-fc568.htm

224-t05-568.htm

224-fc569.htm

224-t05-569.htm

224-fc571.htm

224-t05-571.htm

224-fc572.htm

224-t05-572.htm

224-fc573.htm

224-t05-573.htm

224-fc574.htm

224-t05-574.htm

224-fc575.htm

224-t05-575.htm

224-fc576.htm

224-t05-576.htm

224-fc577.htm

224-t05-577.htm

224-fc578.htm

224-t05-578.htm

224-fc579.htm

224-t05-579.htm

224-fc584.htm

224-t05-584.htm

224-fc585.htm

224-t05-585.htm

224-fc595.htm

224-t05-595.htm

224-fc641.htm

224-t05-641.htm

224-fc642.htm

224-t05-642.htm

224-fc643.htm

224-t05-643.htm

224-fc644.htm

224-t05-644.htm

224-fc645.htm

224-t05-645.htm

224-fc646.htm

224-t05-646.htm

224-fc647.htm

224-t05-647.htm

224-fc648.htm

224-t05-648.htm

224-fc652.htm

224-t05-652.htm

224-fc653.htm

224-t05-653.htm

224-fc654.htm

224-t05-654.htm

224-fc655.htm

224-t05-655.htm

224-fc656.htm

224-t05-656.htm

224-fc657.htm

224-t05-657.htm

224-fc658.htm

224-t05-658.htm

224-fc686.htm

224-t05-686.htm

224-fc687.htm

224-t05-687.htm

224-fc689.htm

224-t05-689.htm

224-fc691.htm

224-t05-691.htm

224-fc692.htm

224-t05-692.htm

224-fc697.htm

224-t05-697.htm

224-fc698.htm

224-t05-698.htm

224-fc742.htm

224-t05-742.htm

224-fc751.htm

224-t05-751.htm

224-fc781.htm

224-t05-781.htm

224-fc783.htm

224-t05-783.htm

224-fc1213.htm

224-t05-1213.htm

224-fc1243.htm

224-t05-1243.htm

224-fc1257.htm

224-fc1257sa00.htm

224-t05-1257sa00.htm

224-fc1257sa01.htm

224-t05-1257sa01.htm

224-fc1257sa39.htm

224-t05-1257sa39.htm

224-fc1274.htm

224-t05-1274.htm

224-fc1275.htm

224-t05-1275.htm

224-fc1277.htm

224-t05-1277.htm

224-fc1281.htm

224-t05-1281.htm

224-fc1282.htm

224-t05-1282.htm

224-fc1285.htm

224-t05-1285.htm

224-fc1286.htm

224-t05-1286.htm

224-fc1287.htm

224-t05-1287.htm

224-fc1291.htm

224-t05-1291.htm

224-fc1292.htm

224-t05-1292.htm

224-fc1295.htm

224-t05-1295.htm

224-fc1296.htm

224-t05-1296.htm

224-fc1297.htm

224-t05-1297.htm

224-fc1362.htm

224-t05-1362.htm

224-fc1434.htm

224-t05-1434.htm

224-fc1474.htm

224-t05-1474.htm

224-fc1521.htm

224-t05-1521.htm

224-fc1522.htm

224-t05-1522.htm

224-fc1523.htm

224-t05-1523.htm

224-fc1524.htm

224-t05-1524.htm

224-fc1525.htm

224-t05-1525.htm

224-fc1526.htm

214-t05-1526.htm

224-fc1527.htm

224-t05-1527.htm

224-fc1529.htm

224-t05-1529.htm

224-fc1531.htm

224-t05-1531.htm

224-fc1532.htm

224-t05-1532.htm

224-fc1533.htm

224-t05-1533.htm

224-fc1534.htm

224-t05-1534.htm

224-fc1535.htm

224-t05-1535.htm

224-fc1536.htm

224-t05-1536.htm

224-fc1546.htm

224-t05-1546.htm

224-fc1579.htm

224-t05-1579.htm

224-fc1581.htm

224-t05-1581.htm

224-fc1582.htm

224-t05-1582.htm

224-fc1583.htm

224-t05-1583.htm

224-fc1584.htm

224-t05-1584.htm

224-fc1618.htm

224-t05-1618.htm

224-fc1619.htm

224-t05-1619.htm

224-fc1696.htm

224-t05-1696.htm

224-fc1737.htm

224-t05-1737.htm

224-fc1738.htm

224-t05-1738.htm

224-fc1739.htm

224-t05-1739.htm

224-fc1741.htm

224-t05-1741.htm

224-fc1742.htm

224-t05-1742.htm

224-fc1761.htm

224-t05-1761.htm

224-fc1767.htm

224-t05-1767.htm

224-fc1768.htm

224-t05-1768.htm

224-fc1774.htm

224-t05-1774.htm

224-fc1775.htm

224-t05-1775.htm

224-fc1778.htm

224-t05-1778.htm

224-fc1779.htm

224-t05-1779.htm

224-fc1781.htm

224-t05-1781.htm

224-fc1782.htm

224-t05-1782.htm

224-fc1785.htm

224-t05-1785.htm

224-fc1786.htm

224-t05-1786.htm

224-fc1787.htm

224-t05-1787.htm

224-fc1788.htm

224-t05-1788.htm

224-fc1789.htm

224-t05-1789.htm

224-fc1791.htm

224-t05-1791.htm

224-fc1792.htm

224-t05-1792.htm

224-fc1793.htm

224-t05-1793.htm

224-fc1794.htm

224-t05-1794.htm

224-fc1799.htm

224-t05-1799.htm

224-fc1811.htm

224-t05-1811.htm

224-fc1812.htm

224-t05-1812.htm

224-fc1813.htm

224-t05-1813.htm

224-fc1814.htm

224-t05-1814.htm

224-fc1815.htm

224-t05-1815.htm

224-fc1816.htm

224-t05-1816.htm

224-fc1817.htm

224-t05-1817.htm

224-fc1818.htm

224-t05-1818.htm

224-fc1821.htm

224-t05-1821.htm

224-fc1822.htm

224-t05-1822.htm

224-fc1823.htm

224-t05-1823.htm

224-fc1824.htm

224-t05-1824.htm

224-fc1825.htm

224-t05-1825.htm

224-fc1826.htm

224-t05-1826.htm

224-fc1827.htm

224-t05-1827.htm

224-fc1828.htm

224-t05-1828.htm

224-fc1833.htm

224-t05-1833.htm

224-fc1834.htm

224-t05-1834.htm

224-fc1835.htm

224-t05-1835.htm

224-fc1836.htm

224-t05-1836.htm

224-fc1837.htm

224-t05-1837.htm

224-fc1838.htm

224-t05-1838.htm

224-fc1839.htm

224-t05-1839.htm

224-fc1841.htm

224-t05-1841.htm

224-fc1843.htm

224-t05-1843.htm

224-fc1844.htm

224-t05-1844.htm

224-fc2111.htm

224-t05-2111.htm

224-fc2112.htm

224-t05-2112.htm

224-fc2113.htm

224-t05-2113.htm

224-fc2114.htm

224-t05-2114.htm

224-fc2115.htm

224-t05-2115.htm

224-fc2116.htm

224-t05-2116.htm

224-fc2117.htm

224-t05-2117.htm

224-fc2121.htm

224-t05-2121.htm

224-fc2122.htm

224-t05-2122.htm

224-fc2123.htm

224-t05-2123.htm

224-fc2124.htm

224-t05-2124.htm

224-fc2125.htm

224-t05-2125.htm

224-fc2126.htm

224-t05-2126.htm

224-fc2127.htm

224-t05-2127.htm

224-fc2128.htm

224-t05-2128.htm

224-fc2131.htm

224-t05-2131.htm

224-fc2132.htm

224-t05-2132.htm

224-fc2133.htm

224-t05-2133.htm

224-fc2134.htm

224-t05-2134.htm

224-fc2135.htm

224-t05-2135.htm

224-fc2136.htm

224-t05-2136.htm

224-fc2137.htm

224-t05-2137.htm

224-fc2138.htm

224-t05-2138.htm

224-fc2144.htm

224-t05-2144.htm

224-fc2154.htm

224-t05-2154.htm

224-fc2155.htm

224-t05-2155.htm

224-fc2184.htm

224-t05-2184.htm

224-fc2186.htm

224-fc2186sa00.htm

224-t05-2186sa00.htm

224-fc2186sa01.htm

224-t05-2186sa01.htm

224-fc2191.htm

224-t05-2191.htm

224-fc2217.htm

224-t05-2217.htm

224-fc2281.htm

224-t05-2281.htm

224-fc2282.htm

224-t05-2282.htm

224-fc2311.htm

224-t05-2311.htm

224-fc2313.htm

224-t05-2313.htm

224-fc2427.htm

224-t05-2427.htm

224-fc2428.htm

224-t05-2428.htm

224-fc2457.htm

224-t05-2457.htm

224-fc2458.htm

224-t05-2458.htm

224-fc2459.htm

224-t05-2459.htm

224-fc2461.htm

224-t05-2461.htm

224-fc2462.htm

224-t05-2462.htm

224-fc2463.htm

224-t05-2463.htm

224-fc2464.htm

224-t05-2464.htm

224-fc2465.htm

224-t05-2465.htm

224-fc2466.htm

224-t05-2466.htm

224-fc2469.htm

224-t05-2469.htm

224-fc2471.htm

224-t05-2471.htm

224-fc2472.htm

224-t05-2472.htm

224-fc2473.htm

224-t05-2473.htm

224-fc2475.htm

224-t05-2475.htm

224-fc2476.htm

224-t05-2476.htm

224-fc2477.htm

224-t05-2477.htm

224-fc2478.htm

224-t05-2478.htm

224-fc2482.htm

224-t05-2482.htm

224-fc2483.htm

224-t05-2483.htm

224-fc2484.htm

224-t05-2484.htm

224-fc2485.htm

224-t05-2485.htm

224-fc2486.htm

224-t05-2486.htm

224-fc2487.htm

224-t05-2487.htm

224-fc2488.htm

224-t05-2488.htm

224-fc2489.htm

224-t05-2489.htm

224-fc2491.htm

224-t05-2491.htm

224-fc2492.htm

224-t05-2492.htm

224-fc2494.htm

224-t05-2494.htm

224-fc2495.htm

224-t05-2495.htm

224-fc2496.htm

224-t05-2496.htm

224-fc2497.htm

224-t05-2497.htm

224-fc2498.htm

224-t05-2498.htm

224-fc2499.htm

224-t05-2499.htm

224-fc2511.htm

224-t05-2511.htm

224-fc2512.htm

224-t05-2512.htm

224-fc2517.htm

224-t05-2517.htm

224-fc2518.htm

224-t05-2518.htm

224-fc2521.htm

224-t05-2521.htm

224-fc2522.htm

224-t05-2522.htm

224-fc2523.htm

224-t05-2523.htm

224-fc2524.htm

224-t05-2524.htm

224-fc2525.htm

224-t05-2525.htm

224-fc2526.htm

224-t05-2526.htm

224-fc2527.htm

224-t05-2527.htm

224-fc2528.htm

224-t05-2528.htm

224-fc2529.htm

224-t05-2529.htm

224-fc2531.htm

224-t05-2531.htm

224-fc2532.htm

224-t05-2532.htm

224-fc2544.htm

224-t05-2544.htm

224-fc2567.htm

224-t05-2567.htm

224-fc2568.htm

224-t05-2568.htm

224-fc2569.htm

224-t05-2569.htm

224-fc2586.htm

224-t05-2586.htm

224-fc2587.htm

224-t05-2587.htm

224-fc2588.htm

224-t05-2588.htm

224-fc2589.htm

224-t05-2589.htm

224-fc2591.htm

224-t05-2591.htm

224-fc2592.htm

224-t05-2592.htm

224-fc2593.htm

224-t05-2593.htm

224-fc2594.htm

224-t05-2594.htm

224-fc2595.htm

224-t05-2595.htm

224-fc2596.htm

224-t05-2596.htm

224-fc2597.htm

224-t05-2597.htm

224-fc2598.htm

224-t05-2598.htm

224-fc2653.htm

224-t05-2653.htm

224-fc2654.htm

224-t05-2654.htm

224-fc2657.htm

224-t05-2657.htm

224-fc2658.htm

224-t05-2658.htm

224-fc2737.htm

224-t05-2737.htm

224-fc2766.htm

224-t05-2766.htm

224-fc2767.htm

224-t05-2767.htm

224-fc2768.htm

224-t05-2768.htm

224-fc2769.htm

224-t05-2769.htm

224-fc2789.htm

224-t05-2789.htm

224-fc2793.htm

224-t05-2793.htm

224-fc2796.htm

224-t05-2796.htm

224-fc2799.htm

224-t05-2799.htm

224-fc2811.htm

224-t05-2811.htm

224-fc2812.htm

224-t05-2812.htm

224-fc2837.htm

224-t05-2837.htm

224-fc2838.htm

224-t05-2838.htm

224-fc2839.htm

224-t05-2839.htm

224-fc2841.htm

224-t05-2841.htm

224-fc2842.htm

224-t05-2842.htm

224-fc2843.htm

224-t05-2843.htm

224-fc2844.htm

224-t05-2844.htm

224-fc2845.htm

224-t05-2845.htm

224-fc2847.htm

224-t05-2847.htm

224-fc2848.htm

224-t05-2848.htm

224-fc2849.htm

224-t05-2849.htm

224-fc2851.htm

224-t05-2851.htm

224-fc2852.htm

224-t05-2852.htm

224-fc2853.htm

224-t05-2853.htm

224-fc2854.htm

224-t05-2854.htm

224-fc2855.htm

224-t05-2855.htm

224-fc2857.htm

224-t05-2857.htm

224-fc2863.htm

224-t05-2863.htm

224-fc2864.htm

224-t05-2864.htm

224-fc2868.htm

224-t05-2868.htm

224-fc2869.htm

224-t05-2869.htm

224-fc2871.htm

224-t05-2871.htm

224-fc2872.htm

224-t05-2872.htm

224-fc2873.htm

224-t05-2873.htm

224-fc2874.htm

224-t05-2874.htm

224-fc2875.htm

224-t05-2875.htm

224-fc2876.htm

224-t05-2876.htm

224-fc2877.htm

224-t05-2877.htm

224-fc2973.htm

224-t05-2973.htm

224-fc2994.htm

224-t05-2994.htm

224-fc3111.htm

224-t05-3111.htm

224-fc3112.htm

224-t05-3112.htm

224-fc3113.htm

224-t05-3113.htm

224-fc3114.htm

224-t05-3114.htm

224-fc3115.htm

224-t05-3115.htm

224-fc3116.htm

224-t05-3116.htm

224-fc3117.htm

224-t05-3117.htm

224-fc3118.htm

224-t05-3118.htm

224-fc3119.htm

224-t05-3119.htm

224-fc3121.htm

224-t05-3121.htm

224-fc3122.htm

224-t05-3122.htm

224-fc3123.htm

224-t05-3123.htm

224-fc3124.htm

224-t05-3124.htm

224-fc3125.htm

224-t05-3125.htm

224-fc3126.htm

224-t05-3126.htm

224-fc3127.htm

224-t05-3127.htm

224-fc3262.htm

224-t05-3262.htm

224-fc3263.htm

224-t05-3263.htm

224-fc3264.htm

224-t05-3264.htm

224-fc3265.htm

224-t05-3265.htm

224-fc3266.htm

224-t05-3266.htm

224-fc3267.htm

224-t05-3267.htm

224-fc3268.htm

224-t05-3268.htm

224-fc3269.htm

224-t05-3269.htm

224-fc3271.htm

224-t05-3271.htm

224-fc3272.htm

224-t05-3272.htm

224-fc3273.htm

224-t05-3273.htm

224-fc3274.htm

224-t05-3274.htm

224-fc3275.htm

224-t05-3275.htm

224-fc3276.htm

224-t05-3276.htm

224-fc3277.htm

224-t05-3277.htm

224-fc3278.htm

224-t05-3278.htm

224-fc3279.htm

224-t05-3279.htm

224-fc3281.htm

224-t05-3281.htm

224-fc3282.htm

224-t05-3282.htm

224-fc3283.htm

224-t05-3283.htm

224-fc3362.htm

224-t05-3362.htm

224-fc3363.htm

224-t05-3363.htm

224-fc3458.htm

224-t05-3458.htm

224-fc3489.htm

224-t05-3489.htm

224-fc3491.htm

224-t05-3491.htm

224-fc3515.htm

224-t05-3515.htm

224-fc3521.htm

224-t05-3521.htm

224-fc3584.htm

224-t05-3584.htm

224-fc3585.htm

224-t05-3585.htm

224-fc3586.htm

224-t05-3586.htm

224-fc3594.htm

224-t05-3594.htm

224-fc3595.htm

224-t05-3595.htm

224-fc3846.htm

224-t05-3846.htm

224-fc3847.htm

224-t05-3847.htm

224-fc3848.htm

224-t05-3848.htm

224-fc3849.htm

224-t05-3849.htm

224-fc3858.htm

224-t05-3858.htm

224-fc3859.htm

224-t05-3859.htm

224-fc3861.htm

224-t05-3861.htm

224-fc3862.htm

224-t05-3862.htm

224-fc3863.htm

224-t05-3863.htm

224-fc3864.htm

224-t05-3864.htm

224-fc3869.htm

224-t05-3869.htm

224-fc3871.htm

224-t05-3871.htm

224-fc3872.htm

224-t05-3872.htm

224-fc3873.htm

224-t05-3873.htm

224-fc3874.htm

224-t05-3874.htm

224-fc3875.htm

224-t05-3875.htm

224-fc3922.htm

224-t05-3922.htm

224-fc3925.htm

214-t05-3925.htm

224-fc4617.htm

224-t05-4617.htm

224-fc4618.htm

224-t05-4618.htm

224-fc4621.htm

224-t05-4621.htm

224-fc4622.htm

224-t05-4622.htm

224-fc4624.htm

224-t05-4624.htm

224-fc4636.htm

224-t05-4636.htm

224-fc4687.htm

224-t05-4687.htm

224-fc5118.htm

224-t05-5118.htm