B6.7 G CMOH6.0 B125

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • The Closed Loop Control Feature is disabled.
  • The wastegate is fully open.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 122.

Last Modified: 17-Aug-2015
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • The Closed Loop Control Feature is disabled.
  • The wastegate is fully open.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 123.

Last Modified: 17-Aug-2015


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor can either be Hall effect or potentiometer type sensor that is integrated into the accelerator pedal assembly. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM and accelerator pedal must be calibrated to each other for proper engine response. This is required when a new accelerator pedal is installed, replaced, an ECM is replaced, a new calibration is downloaded to the ECM, or the accelerator pedal wiring is disconnected while keyswitch is “ON”. With keyswitch “ON”, slowly push the accelerator to the floor and release. Do this three times. This recalibrates the ECM and accelerator pedal. Note: The three wires in the accelerator position sensor circuit must be twisted together.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be moniotred with the electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 131.

Last Modified: 17-Aug-2015


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor can either be Hall effect or potentiometer type sensor that is integrated into the accelerator pedal assembly. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM and accelerator pedal must be calibrated to each other for proper engine response. This is required when a new accelerator pedal is installed, replaced, an ECM is replaced, a new calibration is downloaded to the ECM, or the accelerator pedal wiring is disconnected while keyswitch is “ON”. With keyswitch “ON”, slowly push the accelerator to the floor and release. Do this three times. This recalibrates the ECM and accelerator pedal. Note: The three wires in the accelerator position sensor circuit must be twisted together.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be moniotred with the electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged accelerator pedal or lever position sensor

Open circuit in the accelerator signal, supply wire in the harness or connectors

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 132.

Last Modified: 17-Aug-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 135.

Last Modified: 17-Aug-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141.

Last Modified: 17-Aug-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144.

Last Modified: 17-Aug-2015


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1443

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1443 PID: P168 SPN: 168 FMI: 1/1 LAMP: Red SRT: | Battery 1 Voltage - Data Valid But Below Normal Operating Range - Most Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine power derate.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

  • “This diagnostic runs continuously when the engine is running and engine speed is greater than 1000 RPM

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 1443.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1443.

Last Modified: 17-Aug-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The wastegate is fully open.
  • Fan will stay ON if controlled by the engine control module (ECM).
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145.

Last Modified: 17-Aug-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | The engine will operate in Limp Home mode.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 107°C [225°F].

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151.

Last Modified: 17-Aug-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153.

Last Modified: 17-Aug-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154.

Last Modified: 17-Aug-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

The intake manifold pressure is larger than 135kPa.

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manfiold air temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning intake manifold pressure/temperature sensor
  • Malfunctioning Fan
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 17-Aug-2015


Engine Fuel Temperature Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1754

Engine Fuel Temperature Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1754 PID: SPN: 3468 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at Engine Fuel Temperature circuit. | Possible reduced engine performance.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • A default value for the fuel temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine gas temperature/pressure sensor.
  • A short circuit to voltage source in the engine harness
Refer to Troubleshooting Fault Code 1754.

Last Modified: 17-Aug-2015


Engine Fuel Temperature Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1755

Engine Fuel Temperature Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1755 PID: SPN: 3468 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at Engine Fuel Temperature circuit. | Possible reduced engine performance.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • A default value for the fuel temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • A malfunctioning engine gas temperature/pressure sensor.
Refer to Troubleshooting Fault Code 1755.

Last Modified: 17-Aug-2015


Engine Fuel Valve 2 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1765

Engine Fuel Valve 2 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1765 PID: SPN: 3466 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Valve 2 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at Engine Fuel Valve 2 Intake Pressure circuit. | Possible reduced engine performance.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine fuel valve intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel valve intake pressure sensor provides a signal to the ECM on the engine fuel valve intake pressure sensor signal circuit. This sensor signal voltage changes based on the fuel pressure in the engine fuel metering valve.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel valve intake pressure signal voltage was out of range high

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit shorted to sensor supply or battery voltage
  • A malfunctioning engine gas temperature/pressure sensor.
Refer to Troubleshooting Fault Code 1765.

Last Modified: 17-Aug-2015


Engine Fuel Valve 2 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1766

Engine Fuel Valve 2 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1766 PID: SPN: 3466 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Valve 2 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at Engine Fuel Valve 2 Intake Pressure circuit. | Possible reduced engine performance.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine fuel valve intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel valve intake pressure sensor provides a signal to the ECM on the engine fuel valve intake pressure sensor signal circuit. This sensor signal voltage changes based on the fuel pressure in the engine fuel metering valve.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel valve intake pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • A malfunctioning engine gas temperature/pressure sensor.
Refer to Troubleshooting Fault Code 1766.

Last Modified: 17-Aug-2015


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 PID: SPN: 3464 FMI: 7/7 LAMP: Red SRT: | Electronic Throttle Control Actuator - Mechanical system not responding or out of adjustment. The engine intake air throttle actuator has failed the auto zero span check. | Engine can ONLY idle or engine will NOT accelerate to full speed.
Engine Throttle Control Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running for more than 20 seconds.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor signal is incorrect.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine may shutdown
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle actuator
  • Frozen, plugged, or restricted engine intake air throttle.
  • A malfunctioning engine intake air throttle position sensor
Refer to Troubleshooting Fault Code 177.

Last Modified: 17-Aug-2015


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | The engine will operate in Limp Home mode.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.
  • The engine will have limp-home throttle control only.
  • The wastegate is fully open.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 187.

Last Modified: 17-Aug-2015


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: P190 SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine speed has exceeded a critical limit. | The throttle duty cycle will be set to 0 percent.
Engine Crankshaft Position and Camshaft Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Gain adjust setting is not set correctly

External fuel sources drawn into the intake air passage

Reverse powering (motoring) of the engine

Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 1992.

Last Modified: 17-Aug-2015


Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2189

Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2189 PID: S58 SPN: 51 FMI: 7/7 LAMP: Amber SRT: | Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment. The throttle position sensor 1 and throttle position sensor 2 disagree the throttle position | The engine will operate in Limp Home mode.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the absolute difference between the throttle position signal 1 and throttle position signal 2 are greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 2189.

Last Modified: 17-Aug-2015


Intake Manifold Absolute Pressure Sensor Disagrees With the Compressor Outlet Pressure Sensor - Condition Exists

FAULT CODE 2191

Intake Manifold Absolute Pressure Sensor Disagrees With the Compressor Outlet Pressure Sensor - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2191 PID: P102 SPN: 102 FMI: 11/31 LAMP: Amber SRT: | Intake Manifold Absolute Pressure Sensor Disagrees With the Compressor Outlet Pressure Sensor - Condition Exists. The intake manifold pressure and the compressor outlet pressure are mismatching. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal reading is unreasonably high but still within the sensor range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • The Closed Loop Control Feature is disabled.
  • The wastegate is fully open.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning turbocharger wastegate.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 2191.

Last Modified: 17-Aug-2015


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the barometric pressure reading is used.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to sensor supply or battery voltage.

A malfunctioning barometric air pressure sensor

Refer to Troubleshooting Fault Code 221 .

Last Modified: 29-Oct-2019


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the barometric pressure reading is used.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground

A malfunctioning barometric air pressure sensor

Refer to Troubleshooting Fault Code 222 .

Last Modified: 29-Oct-2019


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | The engine will operate in Limp Home mode.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.
  • The wastegate is fully open.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 17-Aug-2015


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Engine will shut down.
Engine Crankshaft Position and Camshaft Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 234.

Last Modified: 17-Aug-2015


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect. The ECM lost the vehicle speed signal or is reading an erratic value. | None on performance.
Wheel-Based Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs when the engine speed is greater than 1200 RPM and the intake manifold pressure is greater than 60 kPa.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 241.

Last Modified: 17-Aug-2015


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P84 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Signal indicates an intermittent connection or VSS tampering. | None on performance.
Wheel-Based Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM detects a valid engine speed signal from the vehicle speed sensor.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 242.

Last Modified: 17-Aug-2015


Throttle Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2519

Throttle Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2519 PID: P51 SPN: 51 FMI: 2/2 LAMP: Red SRT: | Throttle Position Sensor - Data Erratic, Intermittent, or Incorrect. A fault throttle position signal has been detected | The engine will operate in Limp Home mode.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected any faults related to the throttle position sensor 1 and/or throttle position sensor 2.”

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible caused of this fault code include:

  • A damaged engine throttle actuator.
  • Damaged engine harness
Refer to Troubleshooting Fault Code 2519.

Last Modified: 17-Aug-2015


Engine Fuel Shutoff Valve Driver Circuit - Current Below Normal or Open Circuit

FAULT CODE 258

Engine Fuel Shutoff Valve Driver Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 258 PID: S17 SPN: 632 FMI: 5/5 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver Circuit - Current Below Normal or Open Circuit. An open or short Fault has been detected at the high pressure fuel shutoff valve and low pressure fuel shutoff valve circuits. | Engine power derate.
Engine Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

Location of the high pressure fuel shutoff valve is OEM dependent. Refer to OEM service manual.

The low pressure fuel shutoff valve is under the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit on the high pressure fuel shutoff valve and low pressure fuel shutoff valve circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine may shutdown

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • A pin-to-pin short circuit
  • Damaged wiring harness
  • A malfunctioning fuel shutoff valve.
Refer to Troubleshooting Fault Code 258.

Last Modified: 17-Aug-2015


Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2643

Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2643 PID: SPN: 3673 FMI: 3/3 LAMP: Amber SRT: | Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | The engine will operate in Limp Home mode.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that throttle position 2 signal voltage is above 4.98-VDC for more than 1 second

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible caused of this fault code include:

  • A damaged engine throttle actuator.
  • A signal circuit shorted to sensor supply or battery voltage
Refer to Troubleshooting Fault Code 2643.

Last Modified: 17-Aug-2015


Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2644

Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2644 PID: SPN: 3673 FMI: 4/4 LAMP: Amber SRT: | Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | The engine will operate in Limp Home mode.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that throttle position 2 signal voltage is above 4.98-VDC for more than 1 second

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A damaged engine throttle actuator.
  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 2644.

Last Modified: 17-Aug-2015


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 11/31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. The ECM has detected there are unknown bit changes in FLASH memory in read or write operation. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 2661.

Last Modified: 17-Aug-2015


Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

FAULT CODE 2752

Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2752 PID: SPN: 3464 FMI: 6/6 LAMP: Red SRT: | Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit. An open fault has been detected in Engine Throttle Control Actuator circuit. | Possible reduced engine performance.
Engine Throttle Control Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running and the throttle duty cycle is greater than calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the Engine Throttle Control Actuator circuit

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle actuator
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 2752.

Last Modified: 17-Aug-2015


Engine Network Master Slave Communication - Abnormal Update Rate

FAULT CODE 2768

Engine Network Master Slave Communication - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2768 PID: SPN: 629 FMI: 9/9 LAMP: Red SRT: | Engine Network Master Slave Communication - Abnormal Update Rate. The ECM has detected CPU load is higher than calibrated maximum threshold. | Engine torque output will be reduced.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected CPU usage is higher than calibrated maximum threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Noise on speed, cam, and/or crank sensors
  • Too much data is logged
Refer to Troubleshooting Fault Code 2768.

Last Modified: 17-Aug-2015


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2793

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2793 PID: SPN: 110 FMI: 1/1 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. Engine coolant temperature is below normal operating temperature limits. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load for at least 5 minutes.

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module detected the coolant temperature do not increases from initial temperature as expected when vehicle run enough time with load for warming up.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include.

  • Malfunctioning engine coolant temperature sensor
  • Malfunctioning engine coolant thermostat.
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 2793.

Last Modified: 17-Aug-2015


Electronic Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2812

Electronic Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2812 PID: SPN: 3464 FMI: 2/2 LAMP: Red SRT: | Electronic Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect. No communication with the Throttle Control Valve. | Possible reduced engine performance.
Engine Throttle Control Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle does not drop below the calibrated spring test low threshold during the throttle power down sequence

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The diagnosis runs during the module power down sequence. The throttle is commanded open and then allowed to close with no driver current. If the throttle does not drop below the calibrated spring test low threshold within a calibrated period the fault will be suspected.

Possible causes of this fault code include:

  • Frozen, plugged, or restricted engine intake air throttle.
  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 2812.

Last Modified: 17-Aug-2015


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect. The intake manifold pressure reading is erratic or not rational. | Possible reduced engine performance.
Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

  • The engine coolant temperature is greater than the calibrated threshold at initial key ON.
  • This diagnostic runs continuously when the engine output torque is greater than the calibrated threshold for 5 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the difference between the Barometric value and the Intake Manifold Pressure is less than a calibrated threshold for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault are:

  • Malfunctioning intake manifold pressure/temperature sensor
  • Leaks in the air intake system between the throttle and intake manifold.
  • Malfunctioning barometric pressure sensor
  • Frozen, plugged, or restricted engine intake air throttle.
Refer to Troubleshooting Fault Code 2973.

Last Modified: 17-Aug-2015


Engine Control Module Internal Failure - Special Instructions

FAULT CODE 2994

Engine Control Module Internal Failure - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2994 PID: SPN: 629 FMI: 14/14 LAMP: Amber SRT: | Engine Control Module Internal Failure - Special Instructions. The ECM has detected an invalid calibration file on the ECU. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code are:

  • Engine calibration issue.
Refer to Troubleshooting Fault Code 2994.

Last Modified: 17-Aug-2015


Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 311

Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 PID: S1 SPN: 651 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 1 when voltage is turned off. | Engine power derate.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and installed on the Fuel Metering Valve. The circuits are the pulse-width modulation (PWM) drivers in the engine control module (ECM) that controls the injectors. All injector drivers are monitored for an open, shorted to ground condition and short to voltage conditions.

Component Location

The injectors are located in the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to power supply, short to ground or open circuit error on an injector circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

  • Short circuit to voltage source in the engine harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 311.

Last Modified: 25-Aug-2015


Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 312

Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 PID: S5 SPN: 655 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 5 when the voltage is turned off. | Engine power derate.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and installed on the Fuel Metering Valve. The circuits are the pulse-width modulation (PWM) drivers in the engine control module (ECM) that controls the injectors. All injector drivers are monitored for an open, shorted to ground condition and short to voltage conditions.

Component Location

The injectors are located in the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to power supply, short to ground or open circuit error on an injector circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 312.

Last Modified: 25-Aug-2015


Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 313

Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 PID: S3 SPN: 653 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 3 when voltage is turned off. | Engine power derate.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and installed on the Fuel Metering Valve. The circuits are the pulse-width modulation (PWM) drivers in the engine control module (ECM) that controls the injectors. All injector drivers are monitored for an open, shorted to ground condition and short to voltage conditions.

Component Location

The injectors are located in the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to power supply, short to ground or open circuit error on an injector circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 313.

Last Modified: 25-Aug-2015


Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 314

Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 PID: S6 SPN: 656 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 6 when voltage is turned off. | Engine power derate.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and installed on the Fuel Metering Valve. The circuits are the pulse-width modulation (PWM) drivers in the engine control module (ECM) that controls the injectors. All injector drivers are monitored for an open, shorted to ground condition and short to voltage conditions.

Component Location

The injectors are located in the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to power supply, short to ground or open circuit error on an injector circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 314.

Last Modified: 25-Aug-2015


Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 315

Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 PID: S2 SPN: 652 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 2 when voltage is turned off. | Engine power derate.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and installed on the Fuel Metering Valve. The circuits are the pulse-width modulation (PWM) drivers in the engine control module (ECM) that controls the injectors. All injector drivers are monitored for an open, shorted to ground condition and short to voltage conditions.

Component Location

The injectors are located in the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to power supply, short to ground or open circuit error on an injector circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine harness or injector.

Short circuit to voltage source in the engine harness.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 315.

Last Modified: 25-Aug-2015


Clutch Switch Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3159

Clutch Switch Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3159 PID: SPN: 598 FMI: 3/3 LAMP: Amber SRT: | Clutch Switch Circuit - Voltage Above Normal or Shorted to High Source. An invalid Clutch Switch signal has been detected. | None on performance.
Clutch Switch Circuit

Circuit Description

The clutch pedal switch provides a discrete input indicating if the operator is depressing the clutch or not. It is strictly an on/off signal. The clutch pedal switch is used for torque management and vehicle safety.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs when the vehicle speed is greater than 60 km/h and accelerator pedal position is greater than the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a high signal voltage or open circuit at Clutch Switch Circuit while engine is under load.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A A malfunctioning Clutch Pedal Switch
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3159.

Last Modified: 17-Aug-2015


Clutch Switch Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3161

Clutch Switch Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3161 PID: SPN: 598 FMI: 4/4 LAMP: Amber SRT: | Clutch Switch Circuit - Voltage Below Normal or Shorted to Low Source. An invalid Clutch Switch signal has been detected. | None on performance.
Clutch Switch Circuit

Circuit Description

The clutch pedal switch provides a discrete input indicating if the operator is depressing the clutch or not. It is strictly an on/off signal. The clutch pedal switch is used for torque management and vehicle safety.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs when the vehicle speed changes from 2 kph to 25 kph for 10 times.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an invalid Clutch Switch signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A A malfunctioning Clutch Pedal Switch
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3161.

Last Modified: 17-Aug-2015


Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 321

Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 PID: S4 SPN: 654 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit. Current detected at injector Number 4 when voltage is turned off. | Engine power derate.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and installed on the Fuel Metering Valve. The circuits are the pulse-width modulation (PWM) drivers in the engine control module (ECM) that controls the injectors. All injector drivers are monitored for an open, shorted to ground condition and short to voltage conditions.

Component Location

The injectors are located in the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to power supply, short to ground or open circuit error on an injector circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

Short circuit to ground in the engine harness or injector.

Low or high resistance in the injector.

Refer to Troubleshooting Fault Code 321.

Last Modified: 25-Aug-2015


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The injector solenoid valves control fueling quantity and installed on the Fuel Metering Valve. The circuits are the pulse-width modulation (PWM) drivers in the engine control module (ECM) that controls the injectors. All injector drivers are monitored for an open, shorted to ground condition and short to voltage conditions.

Component Location

The injectors are located in the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Duty Cycle is above the calibration threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of a single injector fault include:

  • A plugged fuel filter
  • Malfunctioning fuel injectors
Refer to Troubleshooting Fault Code 322.

Last Modified: 25-Aug-2015


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P110 SPN: 110 FMI: 2/2 LAMP: Amber SRT: | Engine Coolant Temperature - Data Erratic Intermittent or Incorrect. The engine coolant temperature sensor is reading an erratic value at initial key ON. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

“The Engine Control Module (ECM) detected the Coolant Temperature reading was higher or lower than other temperature sensors after 8 hours(engine off).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible cause of this fault code:

  • Malfunctioning engine coolant temperature sensor
  • High resistance in the engine coolant temperature sensor signal or return lines.

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 334.

Last Modified: 17-Aug-2015


Clutch Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3357

Clutch Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3357 PID: SPN: 598 FMI: 2/2 LAMP: Amber SRT: | Clutch Switch - Data Erratic, Intermittent, or Incorrect. A wrong Clutch Switch signal has been detected. | None on performance.
Clutch Switch Circuit

Circuit Description

The clutch pedal switch provides a discrete input indicating if the operator is depressing the clutch or not. It is strictly an on/off signal. The clutch pedal switch is used for torque management and vehicle safety.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

  • This diagnostic runs when the vehicle is in motion and engine speed is greater than 1200 RPM.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an invalid Clutch Switch signal.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A A malfunctioning Clutch Pedal Switch
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3357.

Last Modified: 17-Aug-2015


Engine Throttle Control Actuator - Current Below Normal or Open Circuit

FAULT CODE 3514

Engine Throttle Control Actuator - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3514 PID: SPN: 3464 FMI: 5/5 LAMP: Red SRT: | Engine Throttle Control Actuator - Current Below Normal or Open Circuit. An high current has been detected in Engine Throttle Control Actuator circuit. | Engine will shut down.
Engine Throttle Control Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the overcurrent in Engine Throttle Control Actuator circuit when the actuator is commanded ON

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • An engine speed derate will occur when the fault is registered.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The purpose of this diagnostics is to monitor the temperature on the throttle driver chip built in ECM. The chip outputs a signal to the main processor if it overtemps due to high current conditions.

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • Frozen, plugged, or restricted engine intake air throttle.
  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 3514.

Last Modified: 17-Aug-2015


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | The engine will operate in Limp Home mode.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.
  • The Fuel Adaptive Feature is disabled.
  • The wastegate is fully open.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352.

Last Modified: 17-Aug-2015


Transmission Neutral Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3551

Transmission Neutral Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3551 PID: SPN: 604 FMI: 2/2 LAMP: Amber SRT: | Transmission Neutral Switch - Data Erratic, Intermittent, or Incorrect. An Invalid Transmission Neutral Switch signal has been detected. | Engine torque output will be reduced.
Neutral Switch Circuit

Circuit Description

The transmission neutral switch provides a discrete input indicating if the transmission is in the neutral position or not in gear. It is strictly an on/off signal. The transmission neutral switch is used for torque management and vehicle safety.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

  • This diagnostic runs when the vehicle speed is greater than 60 km/h and accelerator pedal position is greater than 20%.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an invalid Transmission Neutral Switch signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning Transmission Neutral Switch
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3551.

Last Modified: 17-Aug-2015


Cruise Control Enable Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3841

Cruise Control Enable Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3841 PID: SPN: 596 FMI: 2/2 LAMP: Amber SRT: | Cruise Control Enable Switch - Data Erratic, Intermittent, or Incorrect. The cruise control signal voltage is reading an erratic value. | None on performance.
Cruise Control Enable Switch Circuit

Circuit Description

The cruise control enable switch provides a discrete input indicating that the operator wishes to engage or disengage cruise control.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Cruise Enable Switch is stuck on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Turn the key switch ON.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning Cruise Enable Switch
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 3841.

Last Modified: 17-Aug-2015


Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3846

Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3846 PID: SPN: 633 FMI: 0/15 LAMP: Amber SRT: | Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Least Severe Level. The Fuel Control Valve (FCV) internal temperature is too high. | None on performance.
Engine Control Module (ECM)

Circuit Description

The injector solenoid valves control fueling quantity and installed on the Fuel Metering Valve. The circuits are the pulse-width modulation (PWM) drivers in the engine control module (ECM) that controls the injectors. All injector drivers are monitored for an open, shorted to ground condition and short to voltage conditions.

Component Location

The injectors are located in the fuel metering valve and can’t be service separately

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel per cylinder (FPC) is greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel metering valve.
  • Damaged engine harness
Refer to Troubleshooting Fault Code 3846.

Last Modified: 17-Aug-2015


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | The engine will operate in Limp Home mode.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.
  • The engine will have limp-home throttle control only.
  • The wastegate is fully open.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 386.

Last Modified: 17-Aug-2015


Engine Turbocharger Wastegate Actuator 1 Position - Current Below Normal or Open Circuit

FAULT CODE 3971

Engine Turbocharger Wastegate Actuator 1 Position - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3971 PID: SPN: 1188 FMI: 5/5 LAMP: Amber SRT: | Engine Turbocharger Wastegate Actuator 1 Position - Current below normal or open circuit. Motor terminal or motor coil open circuit has been detected by the ECM. | Engine power derate.
Wastegate Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses the engine turbocharger wastegate control valve to control the pressure in the diaphragm canister of the turbocharger actuator. The turbocharger actuator is connected to the turbocharger wastegate.

Component Location

The engine turbocharger wastegate control valve is located on the intake manifold block just upstream of the throttle and connected by a tube to the turbocharger actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on the Wastegate Control Valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced.
  • The wastegate is fully open.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The wastegate control valve solenoid will detect only one fault that is shared for all possible wiring or hardware failures including, open, shorted to ground and shorted to battery. The valve can detect short to voltage condition only when the driver is active, and can detect open or short to ground conditions only when the driver is off.

Possible causes of this fault code include:

  • Malfunctioning turbocharger wastegate.
  • Damaged engine harness
Refer to Troubleshooting Fault Code 3971.

Last Modified: 17-Aug-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Engine power derate.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure sensor
Refer to Troubleshooting Fault Code 415.

Last Modified: 17-Aug-2015


Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 436

Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 436 PID: P105 SPN: 105 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect. The intake manifold temperature sensor is reading an erratic value at initial key ON or while the engine is running. | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold Temperature is much different than other temperature sensors.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 436.

Last Modified: 17-Aug-2015


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Engine power derate.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442.

Last Modified: 17-Aug-2015


Engine Cylinder 1 (A1) Knock - Condition Exists

FAULT CODE 4811

Engine Cylinder 1 (A1) Knock - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4811 PID: SPN: 1352 FMI: 11/31 LAMP: Amber SRT: | Engine Cylinder 1 (A1) Knock - Condition Exists. Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 4811.

Last Modified: 17-Aug-2015


Engine Cylinder 2 (B1) Knock - Condition Exists

FAULT CODE 4812

Engine Cylinder 2 (B1) Knock - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4812 PID: SPN: 1353 FMI: 11/31 LAMP: Amber SRT: | Engine Cylinder 2 (B1) Knock - Condition Exists. Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 4812.

Last Modified: 17-Aug-2015


Engine Cylinder 3 (A2) Knock - Condition Exists

FAULT CODE 4813

Engine Cylinder 3 (A2) Knock - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4813 PID: SPN: 1354 FMI: 11/31 LAMP: Amber SRT: | Engine Cylinder 3 (A2) Knock - Condition Exists. Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 4813.

Last Modified: 17-Aug-2015


Engine Cylinder 4 (B2) Knock - Condition Exists

FAULT CODE 4814

Engine Cylinder 4 (B2) Knock - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4814 PID: SPN: 1355 FMI: 11/31 LAMP: Amber SRT: | Engine Cylinder 4 (B2) Knock - Condition Exists. Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 4814.

Last Modified: 17-Aug-2015


Engine Cylinder 5 (A3) Knock - Condition Exists

FAULT CODE 4815

Engine Cylinder 5 (A3) Knock - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4815 PID: SPN: 1356 FMI: 11/31 LAMP: Amber SRT: | Engine Cylinder 5 (A3) Knock - Condition Exists. Knock above the critical level has been detected | Engine power derate.
Engine Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 4815.

Last Modified: 17-Aug-2015


Engine Cylinder 6 (B3) Knock - Condition Exists

FAULT CODE 4816

Engine Cylinder 6 (B3) Knock - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4816 PID: SPN: 1357 FMI: 11/31 LAMP: Amber SRT: | Engine Cylinder 6 (B3) Knock - Condition Exists. Knock above the critical level has been detected | Engine power derate.
Engine Knock Sensor 2 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 4816.

Last Modified: 17-Aug-2015


Barometric Air Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 495

Barometric Air Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 495 PID: P108 SPN: 108 FMI: 1/1 LAMP: Red SRT: | Barometric Air Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure reading was less than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine harness
  • A malfunctioning barometric air pressure sensor
Refer to Troubleshooting Fault Code 495.

Last Modified: 17-Aug-2015


Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 512

Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3/3 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | The engine will operate in Limp Home mode.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the signal voltage on the engine throttle position 1 signal pin is greater than 4.98-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A damaged engine throttle actuator.
  • A signal circuit shorted to sensor supply or battery voltage
Refer to Troubleshooting Fault Code 512.

Last Modified: 17-Aug-2015


Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 513

Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 SPN: 51 FMI: 4/4 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source | The engine will operate in Limp Home mode.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle position 1 signal voltage is below 0.05-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A damaged engine throttle actuator.
  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 513.

Last Modified: 17-Sep-2015


Engine PTO Governor Enable Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5213

Engine PTO Governor Enable Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5213 PID: SPN: 980 FMI: 2/2 LAMP: Amber SRT: | Engine PTO Governor Enable Switch - Data Erratic, Intermittent, or Incorrect. The PTO control enable switch stuck in On state since key-on. | None on performance.
Engine PTO Enable Switch Circuit

Circuit Description

The PTO control enable switch provides a discrete input indicating that the operator wishes to engage or disengage the Power Take Off (PTO) governor.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the PTO control enable switch is stuck on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Turn the key switch ON.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning PTO control enable switch
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 5213.

Last Modified: 17-Aug-2015


Engine Intake Air Pressure - Voltage Above Normal or Shorted to High Source

FAULT CODE 5249

Engine Intake Air Pressure - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5249 PID: SPN: 106 FMI: 3/3 LAMP: Amber SRT: | Engine Intake Air Pressure - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the Engine Intake Air Pressure circuit. | Possible reduced engine performance.
Engine Intake Air Pressure Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Engine Intake Air Pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Engine Intake Air Pressure sensor provides a signal to the ECM on the Engine Intake Air Pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in front of the throttle.

Component Location

Engine Intake Air Pressure sensor is located on the connection tube which in front of the throttle housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Engine Intake Air Pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the Engine Intake Air Pressure reading is used.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The Engine Intake Air Pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 5249, check for multiple faults.”

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning Engine Intake Air Pressure sensor
Refer to Troubleshooting Fault Code 5249.

Last Modified: 17-Aug-2015


Engine Intake Air Pressure - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5251

Engine Intake Air Pressure - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5251 PID: SPN: 106 FMI: 4/4 LAMP: Amber SRT: | Engine Intake Air Pressure - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the Engine Intake Air Pressure circuit. | Possible reduced engine performance.
Engine Intake Air Pressure Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Engine Intake Air Pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Engine Intake Air Pressure sensor provides a signal to the ECM on the Engine Intake Air Pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in front of the throttle.

Component Location

Engine Intake Air Pressure sensor is located on the connection tube which in front of the throttle housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Engine Intake Air Pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the Engine Intake Air Pressure reading is used.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The Engine Intake Air Pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 5251, check for multiple faults

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Malfunctioning Engine Intake Air Pressure sensor
Refer to Troubleshooting Fault Code 5251.

Last Modified: 17-Aug-2015


Keyswitch Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 587

Keyswitch Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 587 PID: S151 SPN: 158 FMI: 4/4 LAMP: Red SRT: | Keyswitch Circuit - Voltage Below Normal or Shorted to Low Source. Keyswitch supply voltage is below the minimum system voltage level. | Engine will shut down.
Switched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low keyswitch supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • A malfunctioning keyswitch
  • A malfunctioning engine control module (ECM)
  • A short circuit to ground in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 587.

Last Modified: 17-Aug-2015


Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 5957

Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5957 PID: SPN: 3468 FMI: 1/17 LAMP: Amber SRT: | Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Least Severe Level. Too fast Fuel Temperature decreasing rate. | Engine power derate.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Fuel Temperature decreasing rate was too fast.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Engine coolant level low
  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning coolant heat exchanger
Refer to Troubleshooting Fault Code 5957.

Last Modified: 17-Aug-2015


Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 5958

Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5958 PID: SPN: 3468 FMI: 1/18 LAMP: Amber SRT: | Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level. Too fast Fuel Temperature decreasing rate. | Engine power derate.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Fuel Temperature decreasing rate was too fast and keeping longer time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Engine coolant level low
  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning coolant heat exchanger
Refer to Troubleshooting Fault Code 5958.

Last Modified: 17-Aug-2015


Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 5959

Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5959 PID: SPN: 3468 FMI: 1/1 LAMP: Amber SRT: | Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Most Severe Level. Too fast Fuel Temperature decreasing rate | The engine will operate in Limp Home mode.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Fuel Temperature decreasing rate was too fast and occurring as first time in this power cycle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Engine coolant level low
  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning coolant heat exchanger
Refer to Troubleshooting Fault Code 5959.

Last Modified: 17-Aug-2015


Engine Fuel Temperature 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5961

Engine Fuel Temperature 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5961 PID: SPN: 3468 FMI: 2/2 LAMP: Amber SRT: | Engine Fuel Temperature 2 - Data Erratic, Intermittent, or Incorrect. Fuel Temperature differs with other temperature sensors | None on performance.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel temperature differs with average temperature by other temperature sensors at Key On.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine harness
  • A malfunctioning engine gas temperature/pressure sensor.
Refer to Troubleshooting Fault Code 5961.

Last Modified: 17-Aug-2015


Engine Fuel Temperature 2 - Data Not Rational - Drifted High

FAULT CODE 5962

Engine Fuel Temperature 2 - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5962 PID: SPN: 3468 FMI: 2/20 LAMP: Amber SRT: | Engine Fuel Temperature 2 - Data Not Rational - Drifted High. Fuel temperature has been remaining higher than expected at current engine running condition. | None on performance.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the coolant temperature is above 50°C.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel temperature was greater than the calibrated threshold for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine harness
  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning coolant heat exchanger
Refer to Troubleshooting Fault Code 5962.

Last Modified: 17-Aug-2015


Engine Fuel Temperature 2 - Data Not Rational - Drifted Low

FAULT CODE 5963

Engine Fuel Temperature 2 - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5963 PID: SPN: 3468 FMI: 2/21 LAMP: Amber SRT: | Engine Fuel Temperature 2 - Data Not Rational - Drifted Low. Fuel temperature has been remaining lower than expected at current engine running condition. | The engine will operate in Limp Home mode.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the coolant temperature is above 50°C.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel temperature was lower than the calibrated threshold for 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Engine coolant level low
  • Damaged engine harness
  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning coolant heat exchanger
Refer to Troubleshooting Fault Code 5963.

Last Modified: 17-Aug-2015


Battery 2 Voltage - Data Not Rational - Drifted High

FAULT CODE 5965

Battery 2 Voltage - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5965 PID: SPN: 444 FMI: 2/20 LAMP: Red SRT: | Battery 2 Voltage - Data Not Rational - Drifted High. Power relay output voltage is above the calibrated value when the power relay is de-energized. | Engine power derate.
Power Relay Circuit

Circuit Description

The ECM has some special power management features to reduce power consumption under certain operating conditions. When the ignition key is turned on, the ECM powers up all the power relays that feed power to the O2 sensor heater, electronic throttle, high pressure and low-pressure shutoff valves, and wastegate control valve power. If within a defined amount of time, which is adjustable, the ECM does not sense engine motion then the power to the relays will be shut off. This will conserve vehicle battery power. The ECM will return power to the relays when any engine motion is detected or the diagnostic tool runs any special modes.

Component Location

Location of the power relay is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

“This diagnostic runs when the keyswitch is in the ON position and the power relay is de-energized

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power relay output voltage is above the calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning relay
  • Damaged engine harness
  • A short circuit to voltage source in the OEM harness.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5965.

Last Modified: 17-Aug-2015


Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5966

Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5966 PID: SPN: 100 FMI: 0/15 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The engine oil pressure (rifle) has exceeded the high warning threshold. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure is above maximum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code are:

  • Malfunctioning engine oil pressure sensor.
  • Malfunctioning oil pump.
Refer to Troubleshooting Fault Code 5966.

Last Modified: 17-Aug-2015


Accelerator Pedal Position 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5969

Accelerator Pedal Position 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5969 PID: SPN: 91 FMI: 0/16 LAMP: Amber SRT: | Accelerator Pedal Position 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. The pedal sensor voltage is above its rational maximum voltage. | Engine torque output will be reduced.
Accelerator Pedal or Lever Circuit

Circuit Description

The accelerator position sensor can either be Hall effect or potentiometer type sensor that is integrated into the accelerator pedal assembly. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning accelerator pedal or lever position sensor.
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 5969.

Last Modified: 17-Aug-2015


Accelerator Pedal Position 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 5971

Accelerator Pedal Position 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5971 PID: SPN: 91 FMI: 1/18 LAMP: Amber SRT: | Accelerator Pedal Position 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level. The pedal sensor voltage is below its rational minimum voltage. | Engine torque output will be reduced.
Accelerator Pedal or Lever Circuit

Circuit Description

The accelerator position sensor can either be Hall effect or potentiometer type sensor that is integrated into the accelerator pedal assembly. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was less than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged wiring harness
  • Malfunctioning accelerator pedal or lever position sensor.
Refer to Troubleshooting Fault Code 5971.

Last Modified: 17-Aug-2015


Accelerator Pedal or Lever Idle Validation Switch - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5972

Accelerator Pedal or Lever Idle Validation Switch - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5972 PID: SPN: 558 FMI: 7/7 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Switch - Mechanical System Not Responding or Out of Adjustment. Voltage at idle validation on idle and off idle circuit does not match accelerator pedal position | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal position. The idle validation switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The idle validation switch is located on the accelerator pedal assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal or lever position and idle validation switch did not match.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault is logged when both the on-idle and off-idle validation switches disagree with the accelerator pedal or lever position signal. Turning the keyswitch ON while partially depressing the accelerator pedal or lever can cause this fault code to go active. This fault code will stay active until the pedal or lever is cycled through its full travel.

When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.

Refer to Troubleshooting Fault Code 5972.

Last Modified: 17-Aug-2015


Tachograph Circuit - Current Below Normal or Open Circuit

FAULT CODE 5974

Tachograph Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5974 PID: SPN: 1620 FMI: 5/5 LAMP: Amber SRT: | Tachograph Circuit - Current Below Normal or Open Circuit. An open or short Fault has been detected at the tachograph circuit. | None on performance.
Engine Control Module (ECM)

Circuit Description

The electronic control module (ECM) can supply an output signal to operate the vehicle tachograph.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit on the tachograph circuit.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Turn the key switch ON.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning tachograph
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 5974.

Last Modified: 17-Aug-2015


Fan Drive Circuit - Current Below Normal or Open Circuit

FAULT CODE 5977

Fan Drive Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5977 PID: SPN: 977 FMI: 5/5 LAMP: Amber SRT: | Fan Drive Circuit - Current Below Normal or Open Circuit. An open or short fault has been detected in the fan drive circuit. | None on performance.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short fault in the fan control circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open circuit in the harness or fan control solenoid.
  • Malfunctioning Fan

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5977.

Last Modified: 17-Aug-2015


Fan 2 Drive Circuit - Current Below Normal or Open Circuit

FAULT CODE 5978

Fan 2 Drive Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5978 PID: SPN: 1557 FMI: 5/5 LAMP: Amber SRT: | Fan 2 Drive Circuit - Current Below Normal or Open Circuit. An open or short fault has been detected in the fan 2 drive circuit. | None on performance.
Fan 2 Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short fault in the fan 2 control circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open circuit in the harness or fan control solenoid.
  • Malfunctioning Fan

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 5978.

Last Modified: 17-Aug-2015


Malfunction Indicator Lamp Circuit - Current Below Normal or Open Circuit

FAULT CODE 5982

Malfunction Indicator Lamp Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5982 PID: SPN: 1213 FMI: 5/5 LAMP: Amber SRT: | Malfunction Indicator Lamp Circuit - Current Below Normal or Open Circuit. An open or short circuit has been detected in MIL lamp circuit. | None on performance.
Indicator Lamp Circuit

Circuit Description

The Malfunction Indicator Lamp (MIL) is a regulatory lamp. This lamp indicates to the operator that a failure has occurred in the engine that is currently causing the emissions output to be outside the legal limits.

The fault code lamp circuits consist of the light bulb, lamp signal output, and VDC supply from the keyswitch circuit.

Component Location

Refer to the OEM service manual for lamp location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit in the MIL lamp circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning MIL Lamp
  • An open circuit in the OEM harness
Refer to Troubleshooting Fault Code 5982.

Last Modified: 17-Aug-2015


Maintenance Lamp Circuit - Current Below Normal or Open Circuit

FAULT CODE 5984

Maintenance Lamp Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5984 PID: SPN: 2648 FMI: 5/5 LAMP: Amber SRT: | Maintenance Lamp Circuit - Current Below Normal or Open Circuit. An open or short fault has been detected in Amber lamp circuit. | None on performance.
Indicator Lamp Circuit

Circuit Description

The amber lamp indicates that a malfunction has occurred, but the failure can be diagnosed at the next earliest service event. Most circuit fault codes (out-of-range high and out-of-range low), and many system fault codes illuminate the amber lamp because the electronic control system will prevent engine damage when the fault code occurs. The amber lamp can have the word WARNING printed on it.

The fault code lamp circuits consist of the light bulb, lamp signal output, and VDC supply from the keyswitch circuit.

Component Location

Refer to the OEM service manual for lamp location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit in the Amber lamp circuit

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning Amber Lamp
  • Damaged engine harness
Refer to Troubleshooting Fault Code 5984.

Last Modified: 17-Aug-2015


Red Stop Lamp Driver Circuit - Current Below Normal or Open Circuit

FAULT CODE 5985

Red Stop Lamp Driver Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5985 PID: SPN: 623 FMI: 5/5 LAMP: Amber SRT: | Red Stop Lamp Driver Circuit - Current Below Normal or Open Circuit. An open or short circuit has been detected in Red Stop lamp circuit. | None on performance.
Indicator Lamp Circuit

Circuit Description

The red lamp indicates to the operator that the engine should immediately be shut down before severe engine damage occurs.

The fault code lamp circuits consist of the light bulb, lamp signal output, and VDC supply from the keyswitch circuit.

Component Location

Refer to the OEM service manual for lamp location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit in the Red Stop lamp circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning Red Stop Lamp
  • Damaged engine harness
Refer to Troubleshooting Fault Code 5985.

Last Modified: 17-Aug-2015


Engine Coolant Temperature - Abnormal Rate of Change

FAULT CODE 5986

Engine Coolant Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5986 PID: SPN: 110 FMI: 10/10 LAMP: Amber SRT: | Engine Coolant Temperature - Abnormal Rate of Change. Engine Coolant Temperature sensor is not responding to changes in actual temperature. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

  • “This diagnostic runs continuously when the engine has been running for 5 minutes and the coolant temperature is greater than the calibrated threshold

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature sensor is not responding to changes in actual temperature.

Action Taken When the Fault Code is Active

  • The Closed Loop Control Feature is disabled.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning engine coolant temperature sensor
  • Malfunctioning engine coolant thermostat.
  • Malfunctioning engine ECM
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 5986.

Last Modified: 17-Aug-2015


Driver's Demand Engine - Percent Torque - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5987

Driver's Demand Engine - Percent Torque - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5987 PID: SPN: 512 FMI: 7/7 LAMP: Amber SRT: | Driver's Demand Engine - Percent Torque - Mechanical System Not Responding or Out of Adjustment. | The engine will operate in Limp Home mode.
Accelerator Pedal and Brake Switch Circuit

Circuit Description

The accelerator position sensor can either be Hall effect or potentiometer type sensor that is integrated into the accelerator pedal assembly. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The brake switch is an original equipment manufacturer (OEM) supplied switch. The switch is supplied 5 volts through the OEM wiring harness. The return is routed to the OEM switch return.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

The brake switch is an OEM supplied component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the brake switch position shows vehicle is on brake but accelerator pedal position does mismatch.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault are:

  • Malfunctioning accelerator pedal or lever position sensor.
  • A malfunctioning brake pedal position switch
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 5987.

Last Modified: 17-Aug-2015


Engine Override Control Mode - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5988

Engine Override Control Mode - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5988 PID: SPN: 695 FMI: 7/7 LAMP: Amber SRT: | Engine Override Control Mode - Mechanical System Not Responding or Out of Adjustment. Transmission system controller 1 and brake pedal position mismatch. | The engine will operate in Limp Home mode.
Brake Switch Circuit

Circuit Description

The brake pedal switch provides a discrete input indicating if the operator is depressing the pedal or not. It is strictly an on/off signal. The brake pedal switch is used for torque management and vehicle safety.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the transmission system controller 1 speed/torque demand and brake signals mismatch.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning brake switch
  • A malfunctioning transmission ECU
  • A malfunctioning SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 5988.

Last Modified: 17-Aug-2015


Intake Manifold 1 Pressure - Data Not Rational - Drifted High

FAULT CODE 5989

Intake Manifold 1 Pressure - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5989 PID: SPN: 102 FMI: 2/20 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Not Rational - Drifted High. The ECM has diagnosed the Intake Manifold Pressure sensor reads an unreasonably high value for the current RPM and TPS command value. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running and the commanded TPS value is less than the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the current Engine Intake Air Pressure value minus the current Intake Manifold Pressure value is less than the 40kPa in low TPS command regions for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Closed Loop Control Feature is disabled.
  • The Fuel Adaptive Feature is disabled.
  • An engine speed derate will occur when the fault is registered.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

  • Malfunctioning intake manifold pressure/temperature sensor
  • Leaks in the air intake system between the throttle and intake manifold.
  • Malfunctioning Engine Intake Air Pressure sensor
  • Frozen, plugged, or restricted engine intake air throttle.
Refer to Troubleshooting Fault Code 5989.

Last Modified: 17-Aug-2015


Intake Manifold 1 Pressure - Data Not Rational - Drifted Low

FAULT CODE 5991

Intake Manifold 1 Pressure - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5991 PID: SPN: 102 FMI: 2/21 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Data Not Rational - Drifted Low. The Intake Manifold Pressure sensor reads significantly low. | The engine will operate in Limp Home mode.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running and the commanded TPS value is greater than the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the Intake Manifold Pressure sensor reads significantly low for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Closed Loop Control Feature is disabled.
  • The Fuel Adaptive Feature is disabled.
  • The wastegate is fully open.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible caused of this fault code include:

  • Malfunctioning intake manifold pressure/temperature sensor
  • Malfunctioning barometric pressure sensor
  • Leaks in the air intake system between the throttle and intake manifold.
  • Frozen, plugged, or restricted engine intake air throttle.
Refer to Troubleshooting Fault Code 5991.

Last Modified: 17-Aug-2015


Intake Manifold 1 Pressure - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5992

Intake Manifold 1 Pressure - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5992 PID: SPN: 102 FMI: 7/7 LAMP: Amber SRT: | Intake Manifold 1 Pressure - Mechanical System Not Responding or Out of Adjustment. The Engine Control Module (ECM) has diagnosed the excessive Intake Manifold Pressure reading combined with high rate of change of Intake Manifold Pressure. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine is operating under load and the engine speed is greater than the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed the excessive Intake Manifold Pressure sensor reads and high rate of change of Intake Manifold Pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

Valve damage or valve held open (listen for intake valve “chirping” noise in the intake)

  • Base engine timing is incorrect.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 5992.

Last Modified: 17-Aug-2015


Engine Intake Air Pressure - Data Not Rational - Drifted High

FAULT CODE 5993

Engine Intake Air Pressure - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5993 PID: SPN: 106 FMI: 2/20 LAMP: Amber SRT: | Engine Intake Air Pressure - Data Not Rational - Drifted High. Engine Intake Air Pressure is above the commanded range. | Possible reduced engine performance.
Engine Intake Air Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Engine Intake Air Pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Engine Intake Air Pressure sensor provides a signal to the ECM on the Engine Intake Air Pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in front of the throttle.

Component Location

Engine Intake Air Pressure sensor is located on the connection tube which in front of the throttle housing.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running and the throttle position sensor is greater than the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Engine Intake Air Pressure was above the commanded range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

This diagnostic was intended to catch any discrepencies in the engine air flow calculation caused by errors in intake manifold pressure sensor, Engine Intake Air Pressure sensor, or throttle flow area for the current TPS value. The virtual Engine Intake Air Pressure value is estimated from a model which uses TPS, intake manifold pressure and intake manifold temperature inputs. The virtual Engine Intake Air Pressure is compared against the PTP sensor value from a percent error standpoint. If the percent error exceeds the calibrated threshold the fault will be suspected.

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
  • Malfunctioning intake manifold pressure/temperature sensor
  • Malfunctioning Engine Intake Air Pressure sensor
Refer to Troubleshooting Fault Code 5993.

Last Modified: 17-Aug-2015


Engine Intake Air Pressure - Data Not Rational - Drifted Low

FAULT CODE 5994

Engine Intake Air Pressure - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5994 PID: SPN: 106 FMI: 2/21 LAMP: Amber SRT: | Engine Intake Air Pressure - Data Not Rational - Drifted Low. Engine Intake Air Pressure is below the commanded range. | Possible reduced engine performance.
Engine Intake Air Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Engine Intake Air Pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Engine Intake Air Pressure sensor provides a signal to the ECM on the Engine Intake Air Pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in front of the throttle.

Component Location

Engine Intake Air Pressure sensor is located on the connection tube which in front of the throttle housing.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running and the throttle position sensor is greater than the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Engine Intake Air Pressure was below the commanded range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

This diagnostic was intended to catch any discrepencies in the engine air flow calculation caused by errors in intake manifold pressure sensor, Engine Intake Air Pressure sensor, or throttle flow area for the current TPS value. The virtual Engine Intake Air Pressure value is estimated from a model which uses TPS, intake manifold pressure and intake manifold temperature inputs. The virtual Engine Intake Air Pressure is compared against the PTP sensor value from a percent error standpoint. If the percent error exceeds the calibrated threshold the fault will be suspected.

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
  • Malfunctioning intake manifold pressure/temperature sensor
  • Malfunctioning Engine Intake Air Pressure sensor
Refer to Troubleshooting Fault Code 5994.

Last Modified: 17-Aug-2015


Engine Intake Air Pressure - Condition Exists

FAULT CODE 5995

Engine Intake Air Pressure - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5995 PID: SPN: 106 FMI: 11/31 LAMP: Amber SRT: | Engine Intake Air Pressure - Condition Exists. A disagreement has been detected between the Intake manifold pressure and the engine intake air pressure. | None on performance.
Engine Intake Air Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Engine Intake Air Pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Engine Intake Air Pressure sensor provides a signal to the ECM on the Engine Intake Air Pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in front of the throttle.

Component Location

Engine Intake Air Pressure sensor is located on the connection tube which in front of the throttle housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the pressure differences between the Intake manifold pressure and the engine intake air pressure at key on is greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, key OFF for 1 minute, then key ON for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning intake manifold pressure/temperature sensor
  • Malfunctioning Engine Intake Air Pressure sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 5995.

Last Modified: 17-Aug-2015


Engine Fuel Valve 2 Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5996

Engine Fuel Valve 2 Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5996 PID: SPN: 3466 FMI: 0/16 LAMP: Amber SRT: | Engine Fuel Valve 2 Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine Fuel Valve 2 Intake Pressure is above engine protection limit. | Possible reduced engine performance.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine fuel valve intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel valve intake pressure sensor provides a signal to the ECM on the engine fuel valve intake pressure sensor signal circuit. This sensor signal voltage changes based on the fuel pressure in the engine fuel metering valve.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected Engine Fuel Valve 2 Intake Pressure was greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning high pressure regulator
Refer to Troubleshooting Fault Code 5996.

Last Modified: 17-Aug-2015


Engine Fuel Valve 2 Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 5997

Engine Fuel Valve 2 Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5997 PID: SPN: 3466 FMI: 1/18 LAMP: Amber SRT: | Engine Fuel Valve 2 Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine Fuel Valve 2 Intake Pressure is lower than engine protection limit. | Possible reduced engine performance.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine fuel valve intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel valve intake pressure sensor provides a signal to the ECM on the engine fuel valve intake pressure sensor signal circuit. This sensor signal voltage changes based on the fuel pressure in the engine fuel metering valve.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected Engine Fuel Valve 2 Intake Pressure was lower than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A plugged fuel filter
  • A malfunctioning fuel shutoff valve.
  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning high pressure regulator
  • Low Fuel Tank pressure
Refer to Troubleshooting Fault Code 5997.

Last Modified: 17-Aug-2015


Engine Fuel Valve 2 Intake Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 5998

Engine Fuel Valve 2 Intake Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5998 PID: SPN: 3466 FMI: 0/0 LAMP: Red SRT: | Engine Fuel Valve 2 Intake Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Engine Fuel Valve 2 Intake Pressure is abnormally high. | Engine will shut down.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine fuel valve intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel valve intake pressure sensor provides a signal to the ECM on the engine fuel valve intake pressure sensor signal circuit. This sensor signal voltage changes based on the fuel pressure in the engine fuel metering valve.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected Engine Fuel Valve 2 Intake Pressure was greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning high pressure regulator
Refer to Troubleshooting Fault Code 5998.

Last Modified: 17-Aug-2015


Engine Fuel Valve 2 Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 5999

Engine Fuel Valve 2 Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5999 PID: SPN: 3466 FMI: 1/1 LAMP: Amber SRT: | Engine Fuel Valve 2 Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. Engine Fuel Valve 2 Intake Pressure is abnormally low. | Engine power derate.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine fuel valve intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel valve intake pressure sensor provides a signal to the ECM on the engine fuel valve intake pressure sensor signal circuit. This sensor signal voltage changes based on the fuel pressure in the engine fuel metering valve.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected Engine Fuel Valve 2 Intake Pressure was lower than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.

Engine torque will be severely reduced immediately after the fault code becomes active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A plugged fuel filter
  • A malfunctioning fuel shutoff valve.
  • A malfunctioning engine gas temperature/pressure sensor.
  • Malfunctioning high pressure regulator
  • Low Fuel Tank pressure
Refer to Troubleshooting Fault Code 5999.

Last Modified: 17-Aug-2015


Engine Fuel Leakage 2 - Abnormal Rate of Change

FAULT CODE 6111

Engine Fuel Leakage 2 - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6111 PID: SPN: 1240 FMI: 10/10 LAMP: Red SRT: | Engine Fuel Leakage 2 - Abnormal Rate of Change. A possible fuel leak has been detected in the fuel system. | Engine power derate.
Engine Gas Temperature/Pressure Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the Engine Fuel temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine fuel temperature. When the engine fuel is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the engine fuel is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The engine gas temperature/pressure sensor is located on the fuel metering valve.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a possible leak is occurring in the fuel system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

After engine shutdown this diagnosis monitors the absolute pressure measured by the Engine Gas Temperature/Pressure sensor to determine if a possible leak is occurring in the fuel system. This fault indicates leakage either externally between the shutoff value and injectors, failed injector that is leaking when shutoff, or an internal leaking regulator.

Possible causes of this fault code include:

  • A malfunctioning fuel shutoff valve.
  • A malfunctioning fuel metering valve.

A leak in the fuel system

  • Malfunctioning high pressure regulator
Refer to Troubleshooting Fault Code 6111.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Root Cause Not Known

FAULT CODE 6112

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6112 PID: SPN: 3057 FMI: 11/11 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Root Cause Not Known. A circuit fault on the Oxygen (or Exhaust Gas) Sensor have been detected. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on Oxygen (or Exhaust Gas) Sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor

Damaged ECM

  • Damaged engine harness
Refer to Troubleshooting Fault Code 6112.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Special Instructions

FAULT CODE 6113

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6113 PID: SPN: 3057 FMI: 14/14 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Special Instructions. A circuit fault on the Oxygen (or Exhaust Gas) Sensor have been detected. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on Oxygen (or Exhaust Gas) Sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged ECM
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6113.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 6114

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6114 PID: SPN: 3057 FMI: 0/15 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Least Severe Level. A circuit fault on the Oxygen (or Exhaust Gas) Sensor have been detected. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on Oxygen (or Exhaust Gas) Sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor

Damaged ECM

  • Damaged engine harness
Refer to Troubleshooting Fault Code 6114.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6115

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6115 PID: SPN: 3057 FMI: 2/2 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Erratic, Intermittent, or Incorrect. Oxygen (or Exhaust Gas) Sensor air calibration has failed. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine is running while the air calibration has ran.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the correction factor drifts outside set limits 5 times.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
Refer to Troubleshooting Fault Code 6115.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 6116

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6116 PID: SPN: 3057 FMI: 1/17 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Below Normal Operating Range - Least Severe Level. Oxygen (or Exhaust Gas) sensor air calibration correction factor is below the threshold. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the Oxygen (or Exhaust Gas) sensor air calibration correction factor is below the threshold 5 times.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The wastegate control valve solenoid will detect only one fault that is shared for all possible wiring or hardware failures including, open, shorted to ground and shorted to battery. The valve can detect short to voltage condition only when the driver is active, and can detect open or short to ground conditions only when the driver is off.

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
Refer to Troubleshooting Fault Code 6116.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6117

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6117 PID: SPN: 3057 FMI: 0/16 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Moderately Severe Level. Oxygen (or Exhaust Gas) sensor air calibration correction factor is above the threshold. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the Oxygen (or Exhaust Gas) sensor air calibration correction factor is above the threshold 5 times.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The wastegate control valve solenoid will detect only one fault that is shared for all possible wiring or hardware failures including, open, shorted to ground and shorted to battery. The valve can detect short to voltage condition only when the driver is active, and can detect open or short to ground conditions only when the driver is off.

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
Refer to Troubleshooting Fault Code 6117.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Voltage Above Normal or Shorted to High Source

FAULT CODE 6118

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6118 PID: SPN: 3057 FMI: 3/3 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Voltage Above Normal or Shorted to High Source. A circuit fault on the Oxygen (or Exhaust Gas) Sensor have been detected. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running while the Oxygen (or Exhaust Gas) Sensor has been warmed up.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on Oxygen (or Exhaust Gas) Sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged ECM
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6118.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6119

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6119 PID: SPN: 3057 FMI: 4/4 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Voltage Below Normal or Shorted to Low Source. A circuit fault on the Oxygen (or Exhaust Gas) Sensor have been detected. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running while the Oxygen (or Exhaust Gas) Sensor has been warmed up.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on Oxygen (or Exhaust Gas) Sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged ECM
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6119.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6121

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6121 PID: SPN: 3057 FMI: 0/0 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Most Severe Level. A circuit fault on the Oxygen (or Exhaust Gas) Sensor have been detected. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running in the closed loop mode for 1 minutes

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on Oxygen (or Exhaust Gas) Sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor

Damaged ECM

  • Damaged engine harness
Refer to Troubleshooting Fault Code 6121.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 6122

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6122 PID: SPN: 3057 FMI: 1/1 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Below Normal Operating Range - Most Severe Level. Oxygen (or Exhaust Gas) sensor is responding too slowly to changes in the air fuel ratio. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine is running in the closed loop mode and the fuel shut off valve is cutting off

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the Oxygen (or Exhaust Gas) sensor has a low response time to changes in the air/fuel ratio.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The purpose of this diagnostic algorithm is to an Oxygen (or Exhaust Gas) sensor that has a slow response time. As the sensor ages the response time to changes in the air/fuel ratio can increase to the point that the control system can no longer maintain good air/fuel control and the emissions will increase.

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
Refer to Troubleshooting Fault Code 6122.

Last Modified: 17-Aug-2015


Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Abnormal Rate of Change

FAULT CODE 6123

Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6123 PID: SPN: 3057 FMI: 10/10 LAMP: Amber SRT: | Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Abnormal Rate of Change. Oxygen (or Exhaust Gas) sensor is responding too slowly to changes in the air fuel ratio. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine is running in the closed loop mode after a fuel shut off event.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the Oxygen (or Exhaust Gas) sensor has a low response time to changes in the air/fuel ratio.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The purpose of this diagnostic algorithm is to an Oxygen (or Exhaust Gas) sensor that has a slow response time. As the sensor ages the response time to changes in the air/fuel ratio can increase to the point that the control system can no longer maintain good air/fuel control and the emissions will increase.

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
Refer to Troubleshooting Fault Code 6123.

Last Modified: 17-Sep-2015


Engine Timing Sensor - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6124

Engine Timing Sensor - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6124 PID: SPN: 637 FMI: 7/7 LAMP: Amber SRT: | Engine Timing Sensor - Mechanical System Not Responding or Out of Adjustment. The Camshaft Position signal is loss. | None on performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

Problems that can cause this fault:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the secondary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code 6124.

Last Modified: 17-Aug-2015


Engine Position Sensor - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6125

Engine Position Sensor - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6125 PID: SPN: 636 FMI: 7/7 LAMP: Amber SRT: | Engine Position Sensor - Mechanical System Not Responding or Out of Adjustment. The Crank Position signal is loss. | None on performance.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

Possible causes of this fault code include:

  • Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit.
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket.
  • Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit.
  • Look for pin wear at the speed sensor.
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code 6125.

Last Modified: 17-Aug-2015


Engine Timing Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6126

Engine Timing Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6126 PID: SPN: 637 FMI: 2/2 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly
  • Damaged camshaft gear.

Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

  • Mechanical misalignment.
Refer to Troubleshooting Fault Code 6126.

Last Modified: 17-Aug-2015


Engine Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6127

Engine Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6127 PID: SPN: 636 FMI: 2/2 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly
  • Damaged camshaft gear.

Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

  • Mechanical misalignment.
Refer to Troubleshooting Fault Code 6127.

Last Modified: 17-Aug-2015


Engine Timing Sensor - Root Cause Not Known

FAULT CODE 6128

Engine Timing Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6128 PID: SPN: 637 FMI: 11/11 LAMP: Amber SRT: | Engine Timing Sensor - Root Cause Not Known. The ECM has detected a noise signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a noise signal of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged speed indicator lobe.
  • Sensor air gap that is too large or small.
Refer to Troubleshooting Fault Code 6128.

Last Modified: 17-Aug-2015


Engine Position Sensor - Root Cause Not Known

FAULT CODE 6129

Engine Position Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6129 PID: SPN: 636 FMI: 11/11 LAMP: Amber SRT: | Engine Position Sensor - Root Cause Not Known. The ECM has detected a noise signal from the crankshaft position sensor. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

The crankshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a noise signal of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.
  • Damaged or malfunctioning engine speed sensor
  • Damaged speed indicator lobe.
  • Sensor air gap that is too large or small.
Refer to Troubleshooting Fault Code 6129.

Last Modified: 17-Aug-2015


Engine Exhaust O2 Sensor Fueling Correction - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6131

Engine Exhaust O2 Sensor Fueling Correction - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6131 PID: SPN: 1695 FMI: 0/16 LAMP: Amber SRT: | Engine Exhaust O2 Sensor Fueling Correction - Data Valid But Above Normal Operating Range - Moderately Severe Level. Adaptive fuel control reached the high threshold. | Possible reduced engine performance.
Engine Control Module

Circuit Description

The fuel control to the engine is adjusted via feedback from the Engine Exhaust O2 sensor in the exhaust stream. There are two correction terms, the closed loop term and the adaptive learn term. The adaptive learn is a slow learn process based on Engine Exhaust O2 sensor feedback that is stored in a table for future use even when closed loop is not active. Adaptive correction is allowed to correct only within certain limits and has a fault when the high or low limit is reached. If there are other system faults they should be diagnosed first as they could be the root cause of the fuel learn limit fault.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the fuel adapt feature is Enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the current Fuel Adapt value is greater than or equal to the calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Intake Air Pressure sensor
  • Malfunctioning intake manifold pressure/temperature sensor
  • Damaged engine turbocharger outlet oxygen sensor
  • Malfunctioning high pressure regulator
  • A malfunctioning engine gas temperature/pressure sensor.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 6131.

Last Modified: 17-Aug-2015


Engine Exhaust O2 Sensor Fueling Correction - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 6132

Engine Exhaust O2 Sensor Fueling Correction - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6132 PID: SPN: 1695 FMI: 1/18 LAMP: Amber SRT: | Engine Exhaust O2 Sensor Fueling Correction - Data Valid But Above Normal Operating Range - Moderately Severe Level. Adaptive fuel control reached the low threshold. | Possible reduced engine performance.
Engine Control Module

Circuit Description

The fuel control to the engine is adjusted via feedback from the Engine Exhaust O2 sensor in the exhaust stream. There are two correction terms, the closed loop term and the adaptive learn term. The adaptive learn is a slow learn process based on Engine Exhaust O2 sensor feedback that is stored in a table for future use even when closed loop is not active. Adaptive correction is allowed to correct only within certain limits and has a fault when the high or low limit is reached. If there are other system faults they should be diagnosed first as they could be the root cause of the fuel learn limit fault.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the fuel adapt feature is Enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the current Fuel Adapt value is lower than or equal to the calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Intake Air Pressure sensor
  • Malfunctioning intake manifold pressure/temperature sensor
  • Malfunctioning high pressure regulator
  • Damaged engine turbocharger outlet oxygen sensor
  • A malfunctioning engine gas temperature/pressure sensor.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 6132.

Last Modified: 17-Aug-2015


Engine Throttle Valve 1 Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6133

Engine Throttle Valve 1 Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6133 PID: SPN: 51 FMI: 0/0 LAMP: Amber SRT: | Engine Throttle Valve 1 Position - Data Valid But Above Normal Operating Range - Most Severe Level. The Throttle Position Sensor 1 voltage is above a rational high threshold | Possible reduced engine performance.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the raw adapt low value of the throttle position sensor 1 is above the maximum possible voltage

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The diagnosis runs during the module power down sequence. The throttle is commanded open and then allowed to close with no driver current. If the raw adapt low value is above the maximum possible voltage, the fault will be set.

Possible causes of this fault code include:

  • Frozen, plugged, or restricted engine intake air throttle.
  • A malfunctioning engine intake air throttle actuator
  • A malfunctioning engine intake air throttle position sensor
Refer to Troubleshooting Fault Code 6133.

Last Modified: 17-Aug-2015


Engine Throttle Valve 1 Position - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 6134

Engine Throttle Valve 1 Position - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6134 PID: SPN: 51 FMI: 1/1 LAMP: Amber SRT: | Engine Throttle Valve 1 Position - Data Valid But Below Normal Operating Range - Most Severe Level. The Throttle Position Sensor 1 voltage is below a rational high threshold. | Possible reduced engine performance.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the raw adapt low value of the throttle position sensor 1 is below the minimum possible voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The diagnosis runs during the module power down sequence. The throttle is commanded open and then allowed to close with no driver current. If the raw adapt low value is below the minimum possible voltage, the fault will be set.

Possible causes of this fault code include:

  • Frozen, plugged, or restricted engine intake air throttle.
  • A malfunctioning engine intake air throttle position sensor
  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 6134.

Last Modified: 17-Aug-2015


Engine Throttle Valve 2 Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6135

Engine Throttle Valve 2 Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6135 PID: SPN: 3673 FMI: 0/0 LAMP: Amber SRT: | Engine Throttle Valve 2 Position - Data Valid But Above Normal Operating Range - Most Severe Level. The Throttle Position Sensor 2 voltage is above a rational high threshold. | Possible reduced engine performance.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the raw adapt low value of the throttle position sensor 2 is above the maximum possible voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The diagnosis runs during the module power down sequence. The throttle is commanded open and then allowed to close with no driver current. If the raw adapt low value is above the maximum possible voltage, the fault will be set.

Possible causes of this fault code include:

  • Frozen, plugged, or restricted engine intake air throttle.
  • A malfunctioning engine intake air throttle actuator
  • A malfunctioning engine intake air throttle position sensor
Refer to Troubleshooting Fault Code 6135.

Last Modified: 17-Aug-2015


Engine Throttle Valve 2 Position - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 6136

Engine Throttle Valve 2 Position - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6136 PID: SPN: 3673 FMI: 1/1 LAMP: Amber SRT: | Engine Throttle Valve 2 Position - Data Valid But Below Normal Operating Range - Most Severe Level. The Throttle Position Sensor 2 voltage is below a rational high threshold. | Possible reduced engine performance.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and air/fuel mixer housing.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the raw adapt low value of the throttle position sensor 2 is below the minimum possible voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

The diagnosis runs during the module power down sequence. The throttle is commanded open and then allowed to close with no driver current. If the raw adapt low value is below the minimum possible voltage, the fault will be set.

Possible causes of this fault code include:

  • Frozen, plugged, or restricted engine intake air throttle.
  • A malfunctioning engine intake air throttle actuator
  • A malfunctioning engine intake air throttle position sensor
Refer to Troubleshooting Fault Code 6136.

Last Modified: 17-Aug-2015


Source Address 3 - Abnormal Update Rate

FAULT CODE 6137

Source Address 3 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6137 PID: SPN: 2003 FMI: 9/9 LAMP: Amber SRT: | Source Address 3 - Abnormal Update Rate. The ECM expected information from a multiplexed electronic transmission controller 1 but did not receive it soon enough or did not receive it at all | The engine will operate in Limp Home mode.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use electronic service tool to monitor multiplexed components.

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6137.

Last Modified: 17-Aug-2015


Source Address 3 - Received Network Data in Error

FAULT CODE 6138

Source Address 3 - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6138 PID: SPN: 2003 FMI: 2/19 LAMP: Amber SRT: | Source Address 3 - Received Network Data in Error. The ECM received an invalid message from a multiplexed electronic transmission controller 1 | None on performance.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault is used to detect when the electronic transmission controller 1 CAN message is invalid. This fault will set if the output Shaft Speed of the electronic transmission controller 1 is greater than 8032 RPM.

Possible causes of this fault code include:

  • A malfunctioning SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 6138.

Last Modified: 17-Aug-2015


Source Address 238 - Abnormal Update Rate

FAULT CODE 6139

Source Address 238 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6139 PID: SPN: 2238 FMI: 9/9 LAMP: Amber SRT: | Source Address 238 - Abnormal Update Rate. The ECM expected information from a multiplexed tachograph but did not receive it soon enough or did not receive it at all. | None on performance.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6139.

Last Modified: 17-Aug-2015


Source Address 238 - Received Network Data in Error

FAULT CODE 6141

Source Address 238 - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6141 PID: SPN: 2238 FMI: 2/19 LAMP: Amber SRT: | Source Address 238 - Received Network Data in Error. The ECM received an invalid message from a multiplexed tachograph. | None on performance.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault is used to detect when the tachograph CAN message is invalid. This fault will set if the tachograph vehicle speed is greater than 251 miles.

Possible causes of this fault code include:

  • A malfunctioning SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 6141.

Last Modified: 17-Aug-2015


Source Address 11 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6142

Source Address 11 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6142 PID: SPN: 2011 FMI: 2/2 LAMP: Amber SRT: | Source Address 11 - Data Erratic, Intermittent, or Incorrect. The ECM expected information from a multiplexed electronic brake controller 2 but did not receive it soon enough or did not receive it at all. | None on performance.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 6142.

Last Modified: 17-Aug-2015


Source Address 11 - Received Network Data in Error

FAULT CODE 6143

Source Address 11 - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6143 PID: SPN: 2011 FMI: 2/19 LAMP: Amber SRT: | Source Address 11 - Received Network Data in Error. The ECM received an invalid message from a multiplexed electronic brake controller 2 | None on performance.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault is used to detect when the electronic brake controller 2 CAN message is invalid. This fault will set if the Front Axle Speed of the electronic brake controller 2 is greater than 251 miles.

Possible causes of this fault code include:

  • A malfunctioning SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 6143.

Last Modified: 17-Aug-2015


Source Address 239 - Abnormal Update Rate

FAULT CODE 6144

Source Address 239 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6144 PID: SPN: 2239 FMI: 9/9 LAMP: Amber SRT: | Source Address 239 - Abnormal Update Rate. The ECM expected information from a multiplexed electronic brake controller 2 but did not receive it soon enough or did not receive it at all. | None on performance.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 6144.

Last Modified: 17-Aug-2015


J1939 Network #1, Primary Vehicle Network - Root Cause Not Known

FAULT CODE 6145

J1939 Network #1, Primary Vehicle Network - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6145 PID: SPN: 639 FMI: 11/11 LAMP: Amber SRT: | J1939 Network #1, Primary Vehicle Network - Root Cause Not Known. A wiring problem has been detected at SAE J1939 data link circuit. | At least one multiplexed device will not operate properly.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

Possible causes of this fault code include:

  • A malfunctioning SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 6145.

Last Modified: 17-Aug-2015


Source Address 11 - Bad Intelligent Device or Component

FAULT CODE 6147

Source Address 11 - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6147 PID: SPN: 2011 FMI: 12/12 LAMP: Amber SRT: | Source Address 11 - Bad Intelligent Device or Component. The ECM expected information from a multiplexed electronic brake controller 1 but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 6147.

Last Modified: 17-Aug-2015


J1939 Network #1, Primary Vehicle Network - Special Instructions

FAULT CODE 6148

J1939 Network #1, Primary Vehicle Network - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6148 PID: SPN: 639 FMI: 14/14 LAMP: Amber SRT: | J1939 Network #1, Primary Vehicle Network - Special Instructions. A wiring problem has been detected at SAE J1939 data link circuit. | At least one multiplexed device will not operate properly.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 6148.

Last Modified: 17-Aug-2015


Source Address 11 - Abnormal Update Rate

FAULT CODE 6149

Source Address 11 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6149 PID: SPN: 2011 FMI: 9/9 LAMP: Amber SRT: | Source Address 11 - Abnormal Update Rate. The ECM expected information from a multiplexed high resolution wheel Speed but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 6149.

Last Modified: 17-Aug-2015


Relative Humidity - Voltage Above Normal or Shorted to High Source

FAULT CODE 6151

Relative Humidity - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6151 PID: SPN: 354 FMI: 3/3 LAMP: Amber SRT: | Relative Humidity - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the Relative Humidity Sensor Circuit. | None on performance.
Humidity Sensor Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the OH6 ECM and used for controlling the engine. The OH6 ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Relative Humidity signal voltage was greater than 4.9-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning air intake humidity/temperature sensor
  • An open return circuit in the engine harness
  • A short to voltage source in the engine harness
Refer to Troubleshooting Fault Code 6151.

Last Modified: 17-Aug-2015


Relative Humidity - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6152

Relative Humidity - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6152 PID: SPN: 354 FMI: 4/4 LAMP: Amber SRT: | Relative Humidity - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the Relative Humidity Sensor Circuit. | None on performance.
Humidity Sensor Circuit

Circuit Description

The Humidity Sensor is a capacitive sensor that measures Relative Humidity (RH) as well as the air temperature at the sensor (RHT). The OH6 system uses the RH, RHT, and Barometric values to calculate Specific Humidity (SH). The SH value is used as a correction factor.

Component Location

The humidity sensor is located on the air inlet connection, which is connected to the compressor housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Relative Humidity signal voltage was lower than 0.1-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning air intake humidity/temperature sensor
  • A short circuit to ground in the harness
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 6152.

Last Modified: 17-Aug-2015


Relative Humidity - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6153

Relative Humidity - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6153 PID: SPN: 354 FMI: 0/0 LAMP: Amber SRT: | Relative Humidity - Data Valid But Above Normal Operating Range - Most Severe Level. A high humidity value is detected. | None on performance.
Humidity Sensor Circuit

Circuit Description

The Humidity Sensor is a capacitive sensor that measures Relative Humidity (RH) as well as the air temperature at the sensor (RHT). The OH6 system uses the RH, RHT, and Barometric values to calculate Specific Humidity (SH). The SH value is used as a correction factor.

Component Location

The humidity sensor is located on the air inlet connection, which is connected to the compressor housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 5 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the specific humidity value is above the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning air intake humidity/temperature sensor
Refer to Troubleshooting Fault Code 6153.

Last Modified: 17-Aug-2015


Relative Humidity - Abnormal Rate of Change

FAULT CODE 6154

Relative Humidity - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6154 PID: SPN: 354 FMI: 10/10 LAMP: Amber SRT: | Relative Humidity - Data Valid But Above Normal Operating Range - Most Severe Level. The Relative Humidity (RH) sensor has stopped responding to changes in ambient humidity. | None on performance.
Humidity Sensor Circuit

Circuit Description

The Humidity Sensor is a capacitive sensor that measures Relative Humidity (RH) as well as the air temperature at the sensor (RHT). The OH6 system uses the RH, RHT, and Barometric values to calculate Specific Humidity (SH). The SH value is used as a correction factor.

Component Location

The humidity sensor is located on the air inlet connection, which is connected to the compressor housing of the turbocharger.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine has been running while the relative humidity and engine coolant temperature met the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Relative Humidity (RH) value is stuck at the same value for 3 consecutive drive cycle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning air intake humidity/temperature sensor
Refer to Troubleshooting Fault Code 6154.

Last Modified: 17-Aug-2015


Engine Control Module - Root Cause Not Known

FAULT CODE 6155

Engine Control Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6155 PID: SPN: 629 FMI: 11/11 LAMP: Amber SRT: | Engine Control Module - Root Cause Not Known. The ECM has detected there are unknown bit changes in SRAM memory in read or write operation. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, key OFF for 1 minute, then key ON for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 6155.

Last Modified: 17-Aug-2015


Engine Intake Manifold Desired Absolute Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6156

Engine Intake Manifold Desired Absolute Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6156 PID: SPN: 1692 FMI: 0/16 LAMP: Amber SRT: | Engine Intake Manifold Desired Absolute Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Higher boost pressure has been detected. | Engine power derate.
Wastegate Control Valve Circuit

Circuit Description

ECM monitors the boost pressure by reading the intake manifold pressure’s value. The electronic control module (ECM) uses the engine turbocharger wastegate control valve to control the pressure in the diaphragm canister of the turbocharger actuator. The turbocharger actuator is connected to the turbocharger wastegate.

Component Location

The engine turbocharger wastegate control valve is located on the intake manifold block just upstream of the throttle and connected by a tube to the turbocharger actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the boost pressure is greater than a calibration threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be severely reduced immediately after the fault code becomes active.

  • The wastegate is fully open.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Sticking turbocharger wastegate.
  • Malfunctioning turbocharger wastegate
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6156.

Last Modified: 17-Aug-2015


Engine Intake Manifold Desired Absolute Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 6157

Engine Intake Manifold Desired Absolute Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6157 PID: SPN: 1692 FMI: 1/18 LAMP: Amber SRT: | Engine Intake Manifold Desired Absolute Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Lower boost pressure has been detected. | Possible reduced engine performance.
Wastegate Control Valve Circuit

Circuit Description

ECM monitors the boost pressure by reading the intake manifold pressure’s value. The electronic control module (ECM) uses the engine turbocharger wastegate control valve to control the pressure in the diaphragm canister of the turbocharger actuator. The turbocharger actuator is connected to the turbocharger wastegate.

Component Location

The engine turbocharger wastegate control valve is located on the intake manifold block just upstream of the throttle and connected by a tube to the turbocharger actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 1200 RPM.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the boost pressure is lower than a calibration threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Sticking turbocharger wastegate.
  • Malfunctioning turbocharger wastegate.
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6157.

Last Modified: 17-Aug-2015


Engine Intake Manifold Desired Absolute Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6158

Engine Intake Manifold Desired Absolute Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6158 PID: SPN: 1692 FMI: 0/0 LAMP: Amber SRT: | Engine Intake Manifold Desired Absolute Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Excessive boost pressure has been detected. | Engine power derate.
Wastegate Control Valve Circuit

Circuit Description

ECM monitors the boost pressure by reading the intake manifold pressure’s value. The electronic control module (ECM) uses the engine turbocharger wastegate control valve to control the pressure in the diaphragm canister of the turbocharger actuator. The turbocharger actuator is connected to the turbocharger wastegate.

Component Location

The engine turbocharger wastegate control valve is located on the intake manifold block just upstream of the throttle and connected by a tube to the turbocharger actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the boost pressure is greater than a calibration threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced.
  • The wastegate is fully open.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning turbocharger wastegate.
  • Sticking turbocharger wastegate.
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6158.

Last Modified: 17-Aug-2015


Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6159

Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6159 PID: SPN: 4755 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit. | Engine torque output will be reduced.
Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Aftertreatment Gas Oxidation Catalyst differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Aftertreatment Gas Oxidation Catalyst differential pressure sensor provides a signal to the ECM on the Aftertreatment Gas Oxidation Catalyst differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the Oxidation catalyst

Component Location

The Aftertreatment Gas Oxidation Catalyst differential pressure sensor is mounted on the Oxidation catalyst body.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment gas oxidation catalyst differential pressure signal voltage was greater than 4.8-VDC

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment gas oxidation catalyst differential pressure is used.
  • Engine torque will be severely reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A signal wire shorted to sensor supply or battery voltage
  • An open return circuit in the harness, connectors, or sensor
  • A damaged aftertreatment gas oxidation catalyst differential pressure sensor.
Refer to Troubleshooting Fault Code 6159.

Last Modified: 17-Aug-2015


Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6161

Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6161 PID: SPN: 4755 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit. | Engine power derate.
Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Aftertreatment Gas Oxidation Catalyst differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Aftertreatment Gas Oxidation Catalyst differential pressure sensor provides a signal to the ECM on the Aftertreatment Gas Oxidation Catalyst differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the Oxidation catalyst

Component Location

The Aftertreatment Gas Oxidation Catalyst differential pressure sensor is mounted on the Oxidation catalyst body.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Aftertreatment Gas Oxidation Catalyst differential pressure signal voltage was less than 0.05-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced.
  • A default value for the aftertreatment gas oxidation catalyst differential pressure is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A damaged aftertreatment gas oxidation catalyst differential pressure sensor.
  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground
Refer to Troubleshooting Fault Code 6161.

Last Modified: 17-Aug-2015


Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 6162

Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6162 PID: SPN: 4755 FMI: 1/1 LAMP: Amber SRT: | Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure - Data Valid But Below Normal Operating Range - Most Severe Level. A lower pressure drop than expected detected at the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit. | Engine power derate.
Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Aftertreatment Gas Oxidation Catalyst differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Aftertreatment Gas Oxidation Catalyst differential pressure sensor provides a signal to the ECM on the Aftertreatment Gas Oxidation Catalyst differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the Oxidation catalyst

Component Location

The Aftertreatment Gas Oxidation Catalyst differential pressure sensor is mounted on the Oxidation catalyst body.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than 70 kPa and engine speed is greater than 1000 RPM

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Aftertreatment Gas Oxidation Catalyst differential pressure was less than 1 kPa.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A damaged catalyst.
  • A damaged aftertreatment gas oxidation catalyst differential pressure sensor.
Refer to Troubleshooting Fault Code 6162.

Last Modified: 17-Aug-2015


Engine Knock Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 6163

Engine Knock Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6163 PID: SPN: 731 FMI: 5/5 LAMP: Amber SRT: | Engine Knock Sensor Circuit - Current Below Normal or Open Circuit. An open circuit has been detected on Knock 1 sensor | Engine power derate.
Engine Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock 1 sensor circuit has an open circuit fault.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include.

  • A damaged knock sensor 1
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6163.

Last Modified: 17-Aug-2015


Engine Knock Sensor Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 6164

Engine Knock Sensor Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6164 PID: SPN: 731 FMI: 6/6 LAMP: Amber SRT: | Engine Knock Sensor Circuit - Current Above Normal or Grounded Circuit. A short circuit has been detected on Knock 1 sensor. | Engine power derate.
Engine Knock Sensor 1 Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock 1 sensor circuit has a short circuit fault.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A damaged knock sensor 1
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6164.

Last Modified: 17-Aug-2015


Engine Ignition Coil #1 - Special Instructions

FAULT CODE 6167

Engine Ignition Coil #1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6167 PID: SPN: 1268 FMI: 14/14 LAMP: Amber SRT: | Engine Ignition Coil #1 - Special Instructions. An open coil secondary circuit has been detected on coil1. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected there is an open ignition coil secondary fault on coil 1

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Malfunctioning in the coil extension
  • Malfunctioning Engine Ignition Coil
Refer to Troubleshooting Fault Code 6167.

Last Modified: 17-Aug-2015


Engine Ignition Coil #2 - Special Instructions

FAULT CODE 6171

Engine Ignition Coil #2 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6171 PID: SPN: 1269 FMI: 14/14 LAMP: Amber SRT: | Engine Ignition Coil #2 - Special Instructions. An open coil secondary circuit has been detected on coil 2. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected there is an open ignition coil secondary fault on coil 2.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6171.

Last Modified: 17-Aug-2015


Engine Ignition Coil #3 - Special Instructions

FAULT CODE 6174

Engine Ignition Coil #3 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6174 PID: SPN: 1270 FMI: 14/14 LAMP: Amber SRT: | Engine Ignition Coil #3 - Special Instructions. An open coil secondary circuit has been detected on coil 3. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected there is an open ignition coil secondary fault on coil 3.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6174.

Last Modified: 17-Aug-2015


Engine Ignition Coil #4 - Special Instructions

FAULT CODE 6177

Engine Ignition Coil #4 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6177 PID: SPN: 1271 FMI: 14/14 LAMP: Amber SRT: | Engine Ignition Coil #4 - Special Instructions. An open coil secondary circuit has been detected on coil 4 | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected there is an open ignition coil secondary fault on coil 4.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6177.

Last Modified: 17-Aug-2015


Engine Ignition Coil #5 - Special Instructions

FAULT CODE 6181

Engine Ignition Coil #5 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6181 PID: SPN: 1272 FMI: 14/14 LAMP: Amber SRT: | Engine Ignition Coil #5 - Special Instructions. An open coil secondary circuit has been detected on coil 5 | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected there is an open ignition coil secondary fault on coil 5.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6181.

Last Modified: 17-Aug-2015


Engine Ignition Coil #6 - Special Instructions

FAULT CODE 6184

Engine Ignition Coil #6 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6184 PID: SPN: 1273 FMI: 14/14 LAMP: Amber SRT: | Engine Ignition Coil #6 - Special Instructions. An open coil secondary circuit has been detected on coil 6 | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected there is an open ignition coil secondary fault on coil 6.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6184.

Last Modified: 17-Aug-2015


Engine Ignition Coil #1 - Condition Exists

FAULT CODE 6185

Engine Ignition Coil #1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6185 PID: SPN: 1268 FMI: 11/31 LAMP: Amber SRT: | Engine Ignition Coil #1 - Condition Exists. An shortening charge time has been detected on coil 1. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is less than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Malfunctioning Engine Ignition Coil
Refer to Troubleshooting Fault Code 6185.

Last Modified: 17-Aug-2015


Engine Ignition Coil #2 - Condition Exists

FAULT CODE 6186

Engine Ignition Coil #2 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6186 PID: SPN: 1269 FMI: 11/31 LAMP: Amber SRT: | Engine Ignition Coil #2 - Condition Exists. An shortening charge time has been detected on coil 2. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is less than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Malfunctioning Engine Ignition Coil
Refer to Troubleshooting Fault Code 6186.

Last Modified: 17-Aug-2015


Engine Ignition Coil #3 - Condition Exists

FAULT CODE 6187

Engine Ignition Coil #3 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6187 PID: SPN: 1270 FMI: 11/31 LAMP: Amber SRT: | Engine Ignition Coil #3 - Condition Exists. An shortening charge time has been detected on coil 3. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is less than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Malfunctioning Engine Ignition Coil
Refer to Troubleshooting Fault Code 6187.

Last Modified: 17-Aug-2015


Engine Ignition Coil #4 - Condition Exists

FAULT CODE 6188

Engine Ignition Coil #4 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6188 PID: SPN: 1271 FMI: 11/31 LAMP: Amber SRT: | Engine Ignition Coil #4 - Condition Exists. An shortening charge time has been detected on coil 4. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is less than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque may be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Malfunctioning Engine Ignition Coil
Refer to Troubleshooting Fault Code 6188.

Last Modified: 17-Aug-2015


Engine Ignition Coil #5 - Condition Exists

FAULT CODE 6189

Engine Ignition Coil #5 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6189 PID: SPN: 1272 FMI: 11/31 LAMP: Amber SRT: | Engine Ignition Coil #5 - Condition Exists. An shortening charge time has been detected on coil 5. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is less than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
Refer to Troubleshooting Fault Code 6189.

Last Modified: 17-Aug-2015


Engine Ignition Coil #6 - Condition Exists

FAULT CODE 6191

Engine Ignition Coil #6 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6191 PID: SPN: 1273 FMI: 11/31 LAMP: Amber SRT: | Engine Ignition Coil #6 - Condition Exists. An shortening charge time has been detected on coil 6 | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is less than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
Refer to Troubleshooting Fault Code 6191.

Last Modified: 17-Aug-2015


Engine Exhaust O2 Sensor Closed Loop Operation - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6192

Engine Exhaust O2 Sensor Closed Loop Operation - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6192 PID: SPN: 1696 FMI: 7/7 LAMP: Amber SRT: | Engine Exhaust O2 Sensor Closed Loop Operation - Mechanical System Not Responding or Out of Adjustment. The closed loop compensation is unable to get the engine exhaust O2 sensor air-fuel ratio within in a range of Desired air- fuel ratio. | Possible reduced engine performance.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine is running in the closed loop mode.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the absolute difference between desired and measured fuel- air ratio is greater than a threshold for 8 seconds.”

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel metering valve.
  • Damaged wiring harness

A restriction in the fuel system

Refer to Troubleshooting Fault Code 6192.

Last Modified: 17-Aug-2015


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 6194

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6194 PID: SPN: 190 FMI: 0/15 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Least Severe Level. The engine speed has exceeded the calibration limit. | None on performance.
Engine Crankshaft Position and Camshaft Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
  • A damaged engine throttle actuator.

Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

  • Frozen, plugged, or restricted engine intake air throttle.
Refer to Troubleshooting Fault Code 6194.

Last Modified: 17-Aug-2015


Engine Knock 2 Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 6195

Engine Knock 2 Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6195 PID: SPN: 6651 FMI: 5/5 LAMP: Amber SRT: | Engine Knock 2 Sensor Circuit - Current Below Normal or Open Circuit. An open circuit has been detected on Knock 2 sensor. | Engine power derate.
Engine Knock 2 Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock 2 sensor circuit has an open circuit fault.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • A damaged knock sensor 2
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6195.

Last Modified: 17-Aug-2015


Engine Knock 2 Sensor Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 6196

Engine Knock 2 Sensor Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6196 PID: SPN: 6651 FMI: 6/6 LAMP: Amber SRT: | Engine Knock 2 Sensor Circuit - Current Above Normal or Grounded Circuit. A short circuit has been detected on Knock 2 sensor. | Engine power derate.
Engine Knock 2 Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock 2 sensor circuit has a short circuit fault.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A damaged knock sensor 2
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6196.

Last Modified: 17-Aug-2015


Engine Ignition Coil #1 - Root Cause Not Known

FAULT CODE 6197

Engine Ignition Coil #1 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6197 PID: SPN: 1268 FMI: 11/11 LAMP: Amber SRT: | Engine Ignition Coil #1 - Root Cause Not Known. An lengthening charge time has been detected on coil 1. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6197.

Last Modified: 17-Aug-2015


Engine Ignition Coil #2 - Root Cause Not Known

FAULT CODE 6198

Engine Ignition Coil #2 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6198 PID: SPN: 1269 FMI: 11/11 LAMP: Amber SRT: | Engine Ignition Coil #2 - Root Cause Not Known. An lengthening charge time has been detected on coil 2. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6198.

Last Modified: 17-Aug-2015


Engine Ignition Coil #3 - Root Cause Not Known

FAULT CODE 6199

Engine Ignition Coil #3 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6199 PID: SPN: 1270 FMI: 11/11 LAMP: Amber SRT: | Engine Ignition Coil #3 - Root Cause Not Known. An lengthening charge time has been detected on coil 3. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6199.

Last Modified: 17-Aug-2015


Engine Ignition Coil #4 - Root Cause Not Known

FAULT CODE 6211

Engine Ignition Coil #4 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6211 PID: SPN: 1271 FMI: 11/11 LAMP: Amber SRT: | Engine Ignition Coil #4 - Root Cause Not Known. An lengthening charge time has been detected on coil 4. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6211.

Last Modified: 17-Aug-2015


Engine Ignition Coil #5 - Root Cause Not Known

FAULT CODE 6212

Engine Ignition Coil #5 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6212 PID: SPN: 1272 FMI: 11/11 LAMP: Amber SRT: | Engine Ignition Coil #5 - Root Cause Not Known. A lengthening charge time has been detected on coil 5. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is greater than the calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6212.

Last Modified: 17-Aug-2015


Engine Ignition Coil #6 - Root Cause Not Known

FAULT CODE 6213

Engine Ignition Coil #6 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6213 PID: SPN: 1273 FMI: 11/11 LAMP: Amber SRT: | Engine Ignition Coil #6 - Root Cause Not Known. An lengthening charge time has been detected on coil 6. | Engine power derate.
Engine Ignition Coil Circuit

Circuit Description

Each cylinder has its own coil. Spark timing is controlled by the electronic control module (ECM). The ECM sends firing signals to the individual coils. The ECM commands to energize the ignition coil for the present cylinder in the firing sequence. The coils are charged to the required energy to ensure a strong enough spark to jump the gap and initiate combustion. The coils amplify the ECM signals and fire the spark plugs. The signals sent from the coils are approximately 15,000 to 30,000 VDC.

Component Location

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive coil charge time is greater than the calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The Fuel Adaptive Feature is disabled.
  • Engine torque will be reduced.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Malfunctioning Engine Ignition Coil
  • Malfunctioning in the coil extension
Refer to Troubleshooting Fault Code 6213.

Last Modified: 17-Aug-2015


Hybrid System Fault - Abnormal Update Rate

FAULT CODE 6214

Hybrid System Fault - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6214 PID: SPN: 5889 FMI: 9/9 LAMP: Amber SRT: | Hybrid System Fault - Abnormal Update Rate. The ECM expected information from a multiplexed hybrid device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the OH6 ECM over the SAE J1939 data link.

Messages sent from OEM Hybrid System Controller are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® engine ECM and OEM Hybrid System Controller must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 6214.

Last Modified: 17-Aug-2015


O2 Sensor Power Relay Driver Control Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6215

O2 Sensor Power Relay Driver Control Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6215 PID: SPN: 5871 FMI: 0/16 LAMP: Amber SRT: | O2 Sensor Power Relay Driver Control Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level. The oxygen heater temperature is greater than expected. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine is running in the closed loop mode.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the oxygen heater temperature is greater than 930°C [1706°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6215.

Last Modified: 17-Aug-2015


O2 Sensor Power Relay Driver Control Circuit - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 6216

O2 Sensor Power Relay Driver Control Circuit - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6216 PID: SPN: 5871 FMI: 1/18 LAMP: Amber SRT: | O2 Sensor Power Relay Driver Control Circuit - Data Valid But Below Normal Operating Range - Moderately Severe Level. The oxygen heater temperature is lower than expected. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs when the engine is running in the closed loop mode.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the oxygen heater temperature is lower than 720°C [1328°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6216.

Last Modified: 17-Aug-2015


O2 Sensor Power Relay Driver Control Circuit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6217

O2 Sensor Power Relay Driver Control Circuit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6217 PID: SPN: 5871 FMI: 7/7 LAMP: Amber SRT: | O2 Sensor Power Relay Driver Control Circuit - Mechanical System Not Responding or Out of Adjustment. The oxygen heater temperature is not within calibrated limits. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running while the Oxygen (or Exhaust Gas) Sensor has been warmed up.

Conditions for Setting the Fault Codes

This fault code is triggered when the diagnostic detects that the oxygen heater temperature is not within calibrated limits for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6217.

Last Modified: 17-Aug-2015


O2 Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6218

O2 Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6218 PID: SPN: 5871 FMI: 3/3 LAMP: Amber SRT: | O2 Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source. The oxygen Sensor signal output voltage is too high. | Engine torque output will be reduced.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running while the Oxygen (or Exhaust Gas) Sensor has been warmed up.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the oxygen sensor circuit

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6218.

Last Modified: 17-Aug-2015


O2 Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6219

O2 Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6219 PID: SPN: 5871 FMI: 4/4 LAMP: Amber SRT: | O2 Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine actual exhaust oxygen signal circuit. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running while the Oxygen (or Exhaust Gas) Sensor has been warmed up.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the oxygen sensor circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6219.

Last Modified: 17-Aug-2015


Turbocharger 1 Compressor Intake Temperature - Current Below Normal or Open Circuit

FAULT CODE 6221

Turbocharger 1 Compressor Intake Temperature - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6221 PID: SPN: 1172 FMI: 5/5 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature - Current Below Normal or Open Circuit. High signal voltage detected at the Turbocharger 1 Compressor Intake Temperature Sensor Circuit. | None on performance.
Humidity Sensor Circuit

Circuit Description

The Humidity Sensor is a capacitive sensor that measures Relative Humidity (RH) as well as the air temperature at the sensor (RHT). The OH6 system uses the RH, RHT, and Barometric values to calculate Specific Humidity (SH). The SH value is used as a correction factor.

Component Location

The humidity sensor is located on the air inlet connection, which is connected to the compressor housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Turbocharger Compressor Intake Temperature Sensor signal voltage was greater than 4.9-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning air intake humidity/temperature sensor
  • An open return circuit in the engine harness, connectors, or sensor
  • A short to voltage source in the engine harness
Refer to Troubleshooting Fault Code 6221.

Last Modified: 17-Aug-2015


Turbocharger 1 Compressor Intake Temperature - Current Above Normal or Grounded Circuit

FAULT CODE 6222

Turbocharger 1 Compressor Intake Temperature - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6222 PID: SPN: 1172 FMI: 6/6 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature - Current Above Normal or Grounded Circuit. Low signal voltage detected at the Turbocharger 1 Compressor Intake Temperature Sensor Circuit. | None on performance.
Humidity Sensor Circuit

Circuit Description

The Humidity Sensor is a capacitive sensor that measures Relative Humidity (RH) as well as the air temperature at the sensor (RHT). The OH6 system uses the RH, RHT, and Barometric values to calculate Specific Humidity (SH). The SH value is used as a correction factor.

Component Location

The humidity sensor is located on the air inlet connection, which is connected to the compressor housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Turbocharger Compressor Intake Temperature Sensor signal voltage was lower than 0.1-VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible caused of this fault code include:

  • Malfunctioning air intake humidity/temperature sensor
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 6222.

Last Modified: 17-Aug-2015


Turbocharger 1 Compressor Intake Temperature - Special Instructions

FAULT CODE 6223

Turbocharger 1 Compressor Intake Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6223 PID: SPN: 1172 FMI: 14/14 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature - Special Instructions. Turbocharger 1 Compressor Intake Temperature signal voltage has stopped responding to changes in the actual temperature. | None on performance.
Humidity Sensor Circuit

Circuit Description

The Humidity Sensor is a capacitive sensor that measures Relative Humidity (RH) as well as the air temperature at the sensor (RHT). The OH6 system uses the RH, RHT, and Barometric values to calculate Specific Humidity (SH). The SH value is used as a correction factor.

Component Location

The humidity sensor is located on the air inlet connection, which is connected to the compressor housing of the turbocharger.

Conditions for Running the Diagnostics

  • Engine Coolant Temperature is less than 50°C [122°F]

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Turbocharger Compressor Intake Temperature Sensor signal voltage has stopped responding to changes in the actual temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning air intake humidity/temperature sensor
Refer to Troubleshooting Fault Code 6223.

Last Modified: 17-Aug-2015


O2 Sensor Power Relay Driver Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 6225

O2 Sensor Power Relay Driver Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6225 PID: SPN: 5871 FMI: 5/5 LAMP: Amber SRT: | O2 Sensor Power Relay Driver Control Circuit - Current Below Normal or Open Circuit. An open or shorted to ground fault has been detected at Oxygen (or Exhaust Gas) sensor heater circuit. | Engine power derate.
Oxygen (or Exhaust Gas) Sensor Circuit

Circuit Description

The engine turbocharger outlet oxygen sensor circuit consists of a heater and an oxygen sensor. The heater is supplied 24 volts through the main power relay. The heater uses the 24 volts to operate the oxygen sensor properly. The main power consumption for the sensor is from the heater. Current to the heater is always controlled by the electronic control module (ECM). The sensor is used to measure the oxygen content in the exhaust stream after the turbocharger turbine outlet and provide the output signal to ECM. The ECM uses this information during closed loop operation to control fueling to the engine.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the engine is running while the Oxygen (or Exhaust Gas) Sensor has been warmed up.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or shorted to ground fault at Oxygen (or Exhaust Gas) sensor heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.
  • The Fuel Adaptive Feature is disabled.
  • The Closed Loop Control Feature is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged engine turbocharger outlet oxygen sensor
  • Damaged ECM
  • Damaged engine harness
Refer to Troubleshooting Fault Code 6225.

Last Modified: 17-Aug-2015


Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 771

Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 771 PID: S246 SPN: 597 FMI: 4/4 LAMP: Amber SRT: | Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the brake switch circuit. | Engine power derate.
Brake Switch Circuit

Circuit Description

The brake pedal switch provides a discrete input indicating if the operator is depressing the pedal or not. It is strictly an on/off signal. The brake pedal switch is used for torque management and vehicle safety.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

  • This diagnostic runs when the vehicle speed changes from 50 km/h to 2 km/h 10 times.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the brake switch is not changing.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning brake switch
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 771.

Last Modified: 17-Aug-2015


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: P105 SPN: 105 FMI: 10/10 LAMP: Red SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change. Possible damage to the intake valves has been detected. | Engine will shut down.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load for at least 5 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake Manifold Temperature is not changing as expected.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the elctronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 783.

Last Modified: 17-Aug-2015


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold absolute pressure and temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold absolute pressure and temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold absolute pressure and temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold absolute pressure and temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold absolute pressure and temperature sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold absolute pressure and temperature sensor +5 VDC SUPPLY pin to the intake manifold absolute pressure and temperature sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold absolute pressure and temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold absolute pressure and temperature sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold absolute pressure and temperature sensor +5 VDC SUPPLY pin to the intake manifold absolute pressure and temperature sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold absolute pressure and temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold absolute pressure and temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for inactive fault code.

  • Use Toolkit electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold absolute pressure and temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold absolute pressure and temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold absolute pressure and temperature sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold absolute pressure and temperature sensor +5 VDC SUPPLY pin to the intake manifold absolute pressure and temperature sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold absolute pressure and temperature sensor +5 VDC SUPPLY pin and the intake manifold absolute pressure and temperature sensor SIGNAL pin at the intake manifold absolute pressure and temperature sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold absolute pressure and temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector C, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold absolute pressure and temperature sensor +5 VDC SUPPLY pin to the intake manifold absolute pressure and temperature sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold absolute pressure and temperature sensor +5 VDC SUPPLY pin and the intake manifold absolute pressure and temperature sensor SIGNAL pin at the engine control module engine connector C.

See the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 131 active?
STEP 3. | Check the ECM, Original Equipment Manufacturer (OEM), and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector A pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM and engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 VDC SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 131 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, Original Equipment Manufacturer (OEM), and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM and engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness or engine harness. Refer to Procedure 019-071 in Section 19 and Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in OEM harness or engine harness. Troubleshoot OEM harness and engine harness to determine which contains the pin-to-pin short circuit.

Repair or replace the OEM harness or engine harness. Refer to Procedure 019-071 in Section 19 and Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 132 is active?
STEP 3. | Check the ECM, Original Equipment Manufacturer (OEM), and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector A pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine and OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM and engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 VDC SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 VDC SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 132 is active?
YES NO

A damaged accelerator pedal has been detected. See equipment manufacturer service information for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, Original Equipment Manufacturer (OEM), and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector A and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector A.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM and engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness or engine harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM and engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness or engine harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in OEM harness or engine harness. Troubleshoot OEM harness and engine harness to determine which contains the pin-to-pin short circuit.

Repair or replace the OEM harness or engine harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector A and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness or engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the pin-to-ground short circuit.

Repair or replace the OEM harness or engine harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector B and C pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VDC SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector B and C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and connector C.

Action

Inspect the engine harness and ECM engine connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B and C or engine harness connector B and C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C oil pressure sensor RETURN pin and the engine harness oil pressure sensor RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the oil pressure sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector B and C pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 VDC SUPPLY A pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 VDC SUPPLY A pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use Toolkit electronic service tool to read the fault codes.

See the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector B and C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM engine connector B and C pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector B and C or engine harness connector B and C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C oil pressure sensor +5 VDC SUPPLY pin and the engine harness oil pressure sensor +5 VDC SUPPLY A pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B oil pressure sensor SIGNAL pin and the engine harness oil pressure sensor SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the oil pressure sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the oil pressure sensor SIGNAL pin in the engine harness ECM connector B and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for an inactive or intermittent fault code.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector C.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Aug-2015


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector C pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector C and ground.

See the circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use Toolkit electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO

See the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Aug-2015


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector C pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure/temperature sensor TEMPERATURE SIGNAL pin and intake manifold pressure/temperature sensor RETURN pin at the engine harness intake manifold pressure/temperature sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure/temperature sensor TEMPERATURE SIGNAL pin and intake manifold pressure/temperature sensor RETURN pin at the ECM connector C.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C intake manifold pressure/temperature sensor RETURN pin and the engine harness intake manifold pressure/temperature sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C intake manifold pressure/temperature sensor TEMPERATURE SIGNAL pin and the engine harness intake manifold pressure/temperature sensor connector TEMPERATURE SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure/temperature sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-May-2015


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector C pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure/temperature sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector C.

Clean the connector C and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold pressure/temperature sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold pressure/temperature sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-May-2015


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Monitor intake manifold air temperature. | Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 155 active?
STEP 3. | Check Engine Control Module (ECM) calibration code and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Monitor intake manifold air temperature.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use Toolkit electronic service tool to monitor the intake temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.
  • Start the engine at idle for at least 1 minute.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 155 active?
YES NO

See the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration code and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 177 - Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 177 inactive?
STEP 2. | Check the engine throttle control actuator operation. |
 | STEP 2A. Check for active fault codes. | Did the actuator pass the test?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 177 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine throttle control actuator operation.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle clean test.

  • Use Toolkit electronic service tool to conduct the throttle clean test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply 2. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the aftertreatment 1 gas oxidation catalyst differential pressure sensor and circuit connected to the sensor supply 2. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM, Original Equipment Manufacturer (OEM) harness, and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector A pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the accelerator pedal or lever position sensor.

Refer to Procedure 019-085 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the aftertreatment 1 gas oxidation catalyst differential pressure sensor and circuit connected to the sensor supply 2.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 gas oxidation catalyst differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connection.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment 1 gas oxidation catalyst differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the aftertreatment 1 gas oxidation catalyst differential pressure sensor.

Refer to Procedure 019-376 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM, Original Equipment Manufacturer (OEM) harness, and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A connector.

Action

Inspect the ECM harness and ECM connector A connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Disconnect the aftertreatment 1 gas oxidation catalyst differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor supply 2 +5 VDC pin in the ECM connector A and all other pins in the ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness or engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Disconnect the aftertreatment 1 gas oxidation catalyst differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor supply 2 +5 VDC pin in the ECM connector A and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for an inactive fault code.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine wiring harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure sensor +5 VDC SUPPLY pin to the barometric pressure sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector correct the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector C.

Action

Inspect the engine wiring harness and ECM engine connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine wiring harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector correct the fault.

A pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector C.

Action

Inspect the engine wiring harness and ECM engine connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure sensor +5 VDC SUPPLY pin to the barometric pressure sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector correct the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use recommended Cummins® electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revision or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Nov-2019


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and wiring harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for inactive fault code.

  • Use recommended Cummins® electronic service tool to read the inactive fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine wiring harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure sensor +5 VDC SUPPLY pin to the barometric pressure sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the barometric pressure sensor +5 VDC SUPPLY pin and the barometric pressure sensor SIGNAL pin at the barometric air pressure sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector correct the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector C.

Action

Inspect the engine wiring harness and ECM engine connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connector C, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure sensor +5 VDC SUPPLY pin to the barometric pressure sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector correct the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector C.

Action

Inspect the engine wiring harness and ECM engine connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine wiring harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the barometric pressure sensor +5 VDC SUPPLY pin and the barometric pressure sensor SIGNAL pin at the engine control module engine connector C.

See the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use recommended Cummins® electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector correct the fault.

An open circuit or a pin-to-pin short circuit has been detected on the signal wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use recommended Cummins® electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revision or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Nov-2019


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the Original Equipment Manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harnesses. | Greater than 100k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector A pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harnesses. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 227 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Original Equipment Manufacturer (OEM) harness.

Guided Step 2A - Inspect the OEM harness and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM 31-pin connector.

Action

Inspect the OEM harness, OEM harness 31-pin connector, and engine harness 31-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM 31-pin connector.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Disconnect the aftertreatment 1 gas oxidation catalyst differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor supply 2 +5 VDC pin in the OEM harness 31-pin connector and all other pins in the OEM harness 31-pin connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A connector.

Action

Inspect the ECM harness and ECM connector A, B, and C connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the OEM harness from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor supply 2 +5 VDC pin in the ECM connector A and all other pins in the ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2015


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger | Refer to Procedure 010-033 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 G CMOH6.0 B125 | 4383640
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring downhill?
 | STEP 1B. Check for active fault codes. | Active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, and 3514?
 | STEP 1C. Inspect the Turbocharger for any damage. | Damage and leaks found?
 | STEP 1D. Check the engine Revolutions Per Minute (rpm) with Toolkit electronic service tool. | Correct rpm reading?
 | STEP 1E. Inspect the engine harness, crankshaft position sensor and camshaft position sensor connector pins. | Dirty or damaged pins?
 | STEP 1F. Check for an inactive fault code. | Does an active fault code exist?
 | STEP 1G. Check for an active fault code at low engine rpm. | Fault code 234 active at low engine rpm?
 | STEP 1H. Test the vehicle. | Fault code 234 inactive?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Interview the operator for conditions when the fault is set, such as motoring downhill or throttle depressed.

Motoring downhill?
YES NO

Check for engine damage.

  • Electronics OK.
  • Check the base engine for damage due to overspeed condition.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, and 3514.

Active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, and 3514?
YES | NO
No Repair | No Repair

Troubleshoot active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, and 3514.

Go to 1C

Guided Step 1C - Inspect the Turbocharger for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Turbocharger for damage and leaks.

See the Turbocharger Leaks Engine Oil or Fuel troubleshooting symptom tree in Section TS.

Damage and leaks found?
YES NO

Repair and replace the Turbocharger.

Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check the engine Revolutions Per Minute (rpm) with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate engine.
  • Connect Toolkit electronic service tool.

Action

Check the engine rpm with Toolkit electronic service tool.

  • Compare the engine speed reading on Toolkit electronic service tool to a mechanical tachometer or digital optical tachometer, Part Number 3377462, or equivalent.

Correct rpm reading?
YES NO
No Repair

Inspect the engine camshaft speed/position sensor 1 and engine camshaft speed/position sensor 2 as outlined in Fault Code 6126 and Fault Code 6127.

Go to 1E

Troubleshoot Fault Codes 6126 and 6127.

Guided Step 1E - Inspect the engine harness, crankshaft position sensor and camshaft position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor and camshaft position sensor from the engine harness.

Action

Inspect the engine harness and sensors connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1F

Guided Step 1F - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Does an active fault code exist?
YES | NO
No Repair | No Repair

Troubleshoot active Fault Code.

Go to 1G

Guided Step 1G - Check for an active fault code at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start engine and let it idle for 1 minute.

  • Check for an inactive fault code at low engine rpm.
  • Use Toolkit electronic service tool to read the fault codes.

Fault code 234 active at low engine rpm?
YES NO

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1H

Guided Step 1H - Test the vehicle.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Test the vehicle.

  • Connect Toolkit electronic service tool to read the fault codes.

Fault Code 234 inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 241 active?
 | STEP 1B. Determine if the vehicle speed sensor is a vehicle electronic control unit multiplexed component that is enabled for multiplexing over the Society of Automotive Engineers (SAE) J1939 data link to the Engine Control Module (ECM). | Is the vehicle speed sensor a multiplex component?
 | STEP 1C. Check for active fault codes. | Fault Codes 6145 and/or 6148 active?
STEP 2. | Check the vehicle speed sensor. |
 | STEP 2A. Inspect the Original Equipment Manufacturer (OEM) harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Read the fault codes. | Fault Code 241 active?
 | STEP 2C. Verify correct sensor type is selected in Toolkit electronic service tool. | Correct sensor type selected?
 | STEP 2D. Check the vehicle speed sensor for proper adjustment. | 1/2 to 3/4 of a turn out from the gear?
 | STEP 2E. Check for proper operation of the OEM vehicle speed sensor. | Vehicle speed sensor operating properly?
 | STEP 2F. Check the vehicle speed sensor for a short circuit between coils. | Greater than 100k ohms?
STEP 3. | Check the OEM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Read the fault codes. | Fault Code 241 active?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 241 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and move the vehicle so that the ECM can read a vehicle speed.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 241 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Determine if the vehicle speed sensor is a vehicle electronic control unit multiplexed component that is enabled for multiplexing over the Society of Automotive Engineers (SAE) J1939 data link to the Engine Control Module (ECM).

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Determine if the vehicle speed sensor is a multiplex component over the SAE J1939 data link to the ECM.

Is the vehicle speed sensor a multiplex component?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Codes 6145 and/or 6148 active?
YES NO
No Repair

A damaged OEM vehicle speed sensor or damaged OEM wiring harness has been found.

Replace the sensor. See equipment manufacturer service information.

Repair or replace the harness. See equipment manufacturer service information.

Troubleshoot Fault Codes 6145 and/or 6148.

Go to 4A

Guided Step 2 - Check the vehicle speed sensor.

Guided Step 2A - Inspect the Original Equipment Manufacturer (OEM) harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or the OEM harness.

Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the OEM harness. See equipment manufacturer service information.
  • Replace the sensor. Refer to Procedure 019-090 in Section 19.
  • Replace the sensor. Refer to Procedure 019-091 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and move the vehicle so that the ECM can read a vehicle speed.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 241 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 2C

Go to 4A

Guided Step 2C - Verify correct sensor type is selected in Toolkit electronic service tool.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Use Toolkit electronic service tool to check vehicle speed sensor type selected matches actual vehicle speed sensor type.

Correct sensor type selected?
YES NO
No Repair

Use Toolkit electronic service tool to select the correct sensor type.

Go to 2D

Go to 4A

Guided Step 2D - Check the vehicle speed sensor for proper adjustment.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check the vehicle speed sensor for proper adjustment, and verify that the correct number of tailshaft teeth is entered in Toolkit electronic service tool.

1/2 to 3/4 of a turn out from the gear?
YES NO
No Repair

Adjust the sensor. Refer to Procedure 019-091 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for proper operation of the OEM vehicle speed sensor.

Conditions

  • Turn keyswitch OFF.
  • See equipment manufacturer service information for vehicle speed sensor type and troubleshooting directions.

Action

Check for proper operation of the vehicle speed sensor.

  • See equipment manufacturer service information for sensor locations and sensor type.
  • See equipment manufacturer service information for troubleshooting information.

Vehicle speed sensor operating properly?
YES NO
No Repair

  • Replace the sensor. Refer to Procedure 019-090 in Section 19.
  • Replace the sensor. Refer to Procedure 019-091 in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - Check the vehicle speed sensor for a short circuit between coils.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance from the vehicle speed sensor SIGNAL pin in the vehicle speed sensor connector to the vehicle speed sensor SIGNAL pin in the second vehicle speed sensor connector, sensor side.

NOTE: If the sensor only has one coil answer YES to this question.

Greater than 100k ohms?
YES NO
No Repair

  • Replace the sensor. Refer to Procedure 019-090 in Section 19.
  • Replace the sensor. Refer to Procedure 019-091 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and move the vehicle so the ECM can read the vehicle speed.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 241 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect engine harness ECM connector A.

Action

Check for an open circuit.

  • Measure the resistance from the vehicle speed sensor SUPPLY pin in the ECM connector A to the vehicle speed sensor SUPPLY pin in the sensor harness connector.
  • Measure the resistance from the vehicle speed sensor RETURN pin in the ECM connector A to the vehicle speed sensor RETURN pin in the sensor harness connector.
  • Measure the resistance from the vehicle speed sensor SIGNAL pin in the ECM connector A to the vehicle speed sensor SIGNAL pin in the sensor harness connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness and/or engine harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness and/or engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector A.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the vehicle speed sensor SIGNAL pin in the ECM connector A to ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been found. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the OEM harness and/or engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector A, B, and C.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the vehicle speed sensor SIGNAL pin in the ECM connector A to all other pins in the ECM connectors A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been found. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the OEM harness and/or engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and move the vehicle so that the ECM can read a vehicle speed.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 241 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 242 - Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the feature settings are correct. |
 | STEP 1A. Verify that the vehicle speed sensor and the setting in Toolkit electronic service tool match. | Setting in Toolkit electronic service tool matches the speed sensor type on the vehicle?
 | STEP 1B. Determine if the vehicle speed sensor is a vehicle electronic control unit multiplexed component that is enabled for multiplexing over the Society of Automotive Engineers (SAE) J1939 data link to the Engine Control Module (ECM). | Is the vehicle speed sensor a multiplex component?
 | STEP 1C. Check for active fault codes. | Fault Code 6145 or 6148 active?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering, incorrect installation, or external device present?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use Toolkit electronic service tool to monitor the vehicle speed signal. | Toolkit electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed is accurate?
 | STEP 3C. Check for an inactive fault code. | Fault Code 242 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify the feature settings are correct.

Guided Step 1A - Verify that the vehicle speed sensor and the setting in Toolkit electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool to check vehicle speed sensor type selected matches actual vehicle speed sensor type.

  • Verify that the vehicle speed sensor type parameter setting in Toolkit electronic service tool matches the physical sensor type on the vehicle.

Setting in Toolkit electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Change the setting in the ECM with Toolkit electronic service tool to match the vehicle speed sensor type.

Go to 1B

Go to 4A

Guided Step 1B - Determine if the vehicle speed sensor is a vehicle electronic control unit multiplexed component that is enabled for multiplexing over the Society of Automotive Engineers (SAE) J1939 data link to the Engine Control Module (ECM).

Conditions

  • Determine proper Original Equipment Manufacturer (OEM) vehicle electronic control unit multiplexing configuration.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Determine if the vehicle speed sensor is a multiplex component over the SAE J1939 data link to the ECM.

Is the vehicle speed sensor a multiplex component?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to check for active Fault Codes 6145 and 6148.

Fault Code 6145 or 6148 active?
YES NO
No Repair

A damaged OEM vehicle speed sensor or damaged OEM wiring harness has been found.

Check for an improperly mounted sensor, externally mounted device, or any evidence of tampering to the OEM harness or vehicle speed sensor.

Replace the sensor. See equipment manufacturer service information.

Repair or replace the harness. See equipment manufacturer service information.

Troubleshoot Fault Codes 6145 and/or 6148.

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering, incorrect installation, or external device present?
YES NO

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.
  • Disconnect engine harness ECM connector A.

Action

Check for an open circuit.

  • Measure the resistance from the vehicle speed sensor SUPPLY pin in the ECM connector A to the vehicle speed sensor SUPPLY pin in the sensor harness connector.
  • Measure the resistance from the vehicle speed sensor RETURN pin in the ECM connector A to the vehicle speed sensor RETURN pin in the sensor harness connector.
  • Measure the resistance from the vehicle speed sensor SIGNAL pin in the ECM connector A to the vehicle speed sensor SIGNAL pin in the sensor harness connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness and/or engine harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness and/or engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector A.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from the vehicle speed sensor SIGNAL pin in the ECM connector A to ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been found. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the OEM harness and/or engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector A, B, and C.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the vehicle speed sensor SIGNAL pin in the ECM connector A to all other pins in the ECM connectors A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been found. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the OEM harness and/or engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use Toolkit electronic service tool to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is zero when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Use Toolkit electronic service tool to compare the vehicle speed reading to the speedometer reading on the dash.

Toolkit electronic service tool readout and the vehicle speedometer match?
YES NO
No Repair

Verify that the tire size, rear axle ratio, and tailshaft gear teeth parameters are set correctly in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.
  • Operate vehicle.

Action

Use Toolkit electronic service tool to verify that the speed reported is accurate or reasonable for the present gear.

  • (For example: 64 km/h [ 40 mph ] in top gear is probably inaccurate data.)

Vehicle speed is accurate?
YES NO
No Repair

Verify that the tire size, rear axle ratio, and tailshaft gear teeth parameters are set correctly in the ECM.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 242 active?
YES NO

  • Replace the sensor. Refer to Procedure 019-090 in Section 19.
  • Replace the sensor. Refer to Procedure 019-091 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 258 - Engine Fuel Shutoff Valve Driver Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve (FSOV), NG | Refer to Procedure 005-044 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 258 inactive?
STEP 2. | Check the fuel shutoff valves and circuit. |
 | STEP 2A. Inspect the fuel shutoff valves connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the high pressure Fuel Shutoff Valve for an open or short circuit. | Between 6.39 to 7.81 ohms?
 | STEP 2C. Check the low pressure Fuel Shutoff Valve for an open or short circuit. | Between 6.39 to 7.81 ohms?
 | STEP 2D. Check for a short circuit to ground in the high pressure fuel shutoff valve solenoid. | More than 100k ohms?
 | STEP 2E. Check for a short circuit to ground in the low pressure fuel shutoff valve solenoid. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a short circuit in the engine harness and OEM harness. | More than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 258 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 258 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel shutoff valves and circuit.

Guided Step 2A - Inspect the fuel shutoff valves connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure fuel shutoff valve connector from the OEM harness.
  • Disconnect the low pressure fuel shutoff valve connector from the engine harness.

Action

Inspect the OEM harness, high pressure fuel shutoff valve connector and low pressure fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the high pressure Fuel Shutoff Valve for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure fuel shutoff valve from the OEM harness.

Action

Check for a short circuit in the high pressure fuel shutoff valve solenoid.

  • Measure the solenoid resistance on the fuel shutoff valve connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 6.39 to 7.81 ohms?
YES NO
No Repair

Replace the fuel shutoff valve. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the low pressure Fuel Shutoff Valve for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the low pressure fuel shutoff valve from the engine harness.

Action

Check for a short circuit in the low pressure fuel shutoff valve solenoid.

  • Measure the solenoid resistance on the low pressure fuel shutoff valve connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 6.39 to 7.81 ohms?
YES NO
No Repair

Replace the low pressure fuel shutoff valve. Refer to Procedure 005-044 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the high pressure fuel shutoff valve solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure fuel shutoff valve from the OEM harness.

Action

Check for a short circuit to ground in the high pressure fuel shutoff valve solenoid.

  • Measure the resistance between the high pressure fuel shutoff valve (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the high pressure fuel shutoff valve. See equipment manufacturer service information.

Go to 3E

Go to 4A

Guided Step 2E - Check for a short circuit to ground in the low pressure fuel shutoff valve solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the low pressure fuel shutoff valve from the engine harness.

Action

Check for a short circuit to ground in the low pressure fuel shutoff valve solenoid.

  • Measure the resistance between the low pressure fuel shutoff valve (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the low pressure fuel shutoff valve. Refer to Procedure 005-044 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B and C or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure fuel shutoff valve from the OEM harness.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between the high pressure fuel shutoff valve POWER SUPPLY pin in OEM harness high pressure fuel shutoff valve connector and the high pressure fuel shutoff valve POWER SUPPLY pin in the engine harness ECM connector B.
  • Measure the resistance between the high pressure fuel shutoff valve SIGNAL pin in OEM harness high pressure fuel shutoff valve connector and the high pressure fuel shutoff valve SIGNAL pin in the engine harness ECM connector C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness.

Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the low pressure fuel shutoff valve from the engine harness.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the low pressure fuel shutoff valve POWER SUPPLY pin in engine harness low pressure fuel shutoff valve connector and the low pressure fuel shutoff valve POWER SUPPLY pin in the engine harness ECM connector B.
  • Measure the resistance between the low pressure fuel shutoff valve SIGNAL pin in engine harness low pressure fuel shutoff valve connector and the low pressure fuel shutoff valve SIGNAL pin in the engine harness ECM connector C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high pressure fuel shutoff valve from the OEM harness.
  • Disconnect the low pressure fuel shutoff valve from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness and OEM harness.

  • Measure the resistance between the fuel shutoff valves POWER SUPPLY pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.
  • Measure the resistance between the fuel shutoff valve SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness or OEM harness.

Troubleshoot OEM harness and engine harness to determine which contains the pin-to-pin short circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 258 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 311 - Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with Toolkit electronic service tool. | Fault Code 311 active?
STEP 2. | Check the injector and injector circuit for a damage. |
 | STEP 2A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the injector circuit for an open or short circuit. | Between 3.5 to 4.9 ohms?
 | STEP 2C. Check the injector circuit for a short to ground circuit. | Greater than 100k ohms?
STEP 3. | Check the engine harness for a damage. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the Original Equipment Manufacturer (OEM) harness. | Less than 1 ohm?
 | STEP 3E. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3F. Check for active fault codes. | Fault code 311 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 311 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector and injector circuit for a damage.

Guided Step 2A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 1.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the injector circuit for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 1.

Action

Check for an open or short circuit.

  • Measure the resistance between the injector 1 POWER pin and injector 1 SIGNAL pin at the injector 1.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 3.5 to 4.9 ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the injector circuit for a short to ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 1.

Action

Check for a short to ground circuit.

  • Measure the resistance between the injector 1 POWER pin and cylinder block.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness for a damage.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector C.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine harness from the Injector 1.

Action

Check for an open circuit.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector C of the engine harness to the injector 1 SIGNAL pin at the Injector 1 connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open injector 1 SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 1.

Action

Check for an open circuit.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the Fuel Metering Valve drive relay and the injector 1 POWER SUPPLY pin in the engine harness injector 1 connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the Fuel Metering Valve drive relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the engine harness from the injector 1 connector.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the injector 1 SIGNAL pin in ECM connector C and all other pins in the connector A, B and C.

See the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault code 311 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 312 - Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with Toolkit electronic service tool. | Fault Code 312 active?
STEP 2. | Check the injector and injector circuit for a damage. |
 | STEP 2A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the injector circuit for an open or short circuit. | Between 3.5 to 4.9 ohms?
 | STEP 2C. Check the injector circuit for a short to ground circuit. | Greater than 100k ohms?
STEP 3. | Check the engine harness for a damage. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the Original Equipment Manufacturer (OEM) harness. | Less than 1 ohm?
 | STEP 3E. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3F. Check for active fault codes. | Fault code 312 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes

Fault Code 312 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector and injector circuit for a damage.

Guided Step 2A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 5.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the injector circuit for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 5.

Action

Check for an open or short circuit.

  • Measure the resistance between the injector 5 POWER pin and injector 5 SIGNAL pin at the injector 5.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 3.5 to 4.9 ohms?
YES NO
No Repair

A damaged injector has been detected. Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the injector circuit for a short to ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 5.

Action

Check for a short to ground circuit.

  • Measure the resistance between the injector 5 POWER pin and cylinder block.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness for a damage.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector C.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine harness from the Injector 5.

Action

Check for an open circuit.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector C of the engine harness to the injector 5 SIGNAL pin at the Injector 5 connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open injector 5 SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 5.

Action

Check for an open circuit.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the Fuel Metering Valve drive relay and the injector 5 POWER SUPPLY pin in the engine harness injector 5 connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the Fuel Metering Valve drive relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the engine harness from the injector 5 connector.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the injector 5 SIGNAL pin in ECM connector C and all other pins in the connector A, B and C.

See the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault code 312 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Sep-2015


FAULT CODE 313 - Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with Toolkit electronic service tool. | Fault Code 313 active?
STEP 2. | Check the injector and injector circuit for a damage. |
 | STEP 2A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the injector circuit for an open or short circuit. | Between 3.5 to 4.9 ohms?
 | STEP 2C. Check the injector circuit for a short to ground circuit. | Greater than 100k ohms?
STEP 3. | Check the engine harness for a damage. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the Original Equipment Manufacturer (OEM) harness. | Less than 1 ohm?
 | STEP 3E. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3F. Check for active fault codes. | Fault code 313 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 313 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector and injector circuit for a damage.

Guided Step 2A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 3.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged locking tab connector.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the injector circuit for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 3.

Action

Check for an open or short circuit.

  • Measure the resistance between the injector 3 POWER pin and injector 3 SIGNAL pin at the injector 3.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 3.5 to 4.9 ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the injector circuit for a short to ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 3.

Action

Check for a short to ground circuit.

  • Measure the resistance between the injector 3 POWER pin and cylinder block.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness for a damage.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector C.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine harness from the Injector 3.

Action

Check for an open circuit.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector C of the engine harness to the injector 3 SIGNAL pin at the Injector 3 connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open injector 3 SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 3.

Action

Check for an open circuit.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the Fuel Metering Valve drive relay and the injector 3 POWER SUPPLY pin in the engine harness injector 3 connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the Fuel Metering Valve drive relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the engine harness from the injector 3 connector.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the injector 3 SIGNAL pin in ECM connector C and all other pins in the connector A, B and C.

See the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine let it idle for 1 minute.

Use Toolkit electronic service tool to read the fault codes.

Fault code 313 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 314 - Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with Toolkit electronic service tool. | Fault Code 314 active?
STEP 2. | Check the injector and injector circuit for a damage. |
 | STEP 2A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the injector circuit for an open or short circuit. | Between 3.5 to 4.9 ohms?
 | STEP 2C. Check the injector circuit for a short to ground circuit. | Greater than 100k ohms?
STEP 3. | Check the engine harness for a damage. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the Original Equipment Manufacturer (OEM) harness. | Less than 1 ohm?
 | STEP 3E. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3F. Check for active fault codes. | Fault code 314 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 314 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector and injector circuit for a damage.

Guided Step 2A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 6.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the injector circuit for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 6.

Action

Check for an open or short circuit.

  • Measure the resistance between the injector 6 POWER pin and injector 6 SIGNAL pin at the injector 6.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 3.5 to 4.9 ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the injector circuit for a short to ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 6.

Action

Check for a short to ground circuit.

  • Measure the resistance between the injector 6 POWER pin and cylinder block.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness for a damage.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector C.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine harness from the Injector 6.

Action

Check for an open circuit.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector C of the engine harness to the injector 6 SIGNAL pin at the Injector 6 connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open injector 6 SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 6.

Action

Check for an open circuit.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the Fuel Metering Valve drive relay and the injector 6 POWER SUPPLY pin in the engine harness injector 6 connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the Fuel Metering Valve drive relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the engine harness from the injector 6 connector.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the injector 6 SIGNAL pin in ECM connector C and all other pins in the connector A, B and C.

See the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness

Repair or replace the damaged engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault code 314 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 315 - Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with Toolkit electronic service tool. | Fault Code 315 active?
STEP 2. | Check the injector and injector circuit for a damage. |
 | STEP 2A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the injector circuit for an open or short circuit. | Between 3.5 to 4.9 ohms?
 | STEP 2C. Check the injector circuit for a short to ground circuit. | Greater than 100k ohms?
STEP 3. | Check the engine harness for a damage. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the Original Equipment Manufacturer (OEM) harness. | Less than 1 ohm?
 | STEP 3E. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3F. Check for active fault codes. | Fault code 315 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 315 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector and injector circuit for a damage.

Guided Step 2A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 2.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the injector circuit for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 2.

Action

Check for an open or short circuit.

  • Measure the resistance between the injector 2 POWER pin and injector 2 SIGNAL pin at the injector 2.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 3.5 to 4.9 ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the injector circuit for a short to ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 2.

Action

Check for a short to ground circuit.

  • Measure the resistance between the injector 2 POWER pin and cylinder block.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness for a damage.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector C.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine harness from the Injector 2.

Action

Check for an open circuit.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector C of the engine harness to the injector 2 SIGNAL pin at the Injector 2 connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open injector 2 SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 2.

Action

Check for an open circuit.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the Fuel Metering Valve drive relay and the injector 2 POWER SUPPLY pin in the engine harness injector 2 connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the Fuel Metering Valve drive relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the engine harness from the injector 2 connector.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the injector 2 SIGNAL pin in ECM connector C and all other pins in the connector A, B and C.

See the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault code 315 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 321 - Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with Toolkit electronic service tool. | Fault Code 321 active?
STEP 2. | Check the injector and injector circuit for a damage. |
 | STEP 2A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the injector circuit for an open or short circuit. | Between 3.5 to 4.9 ohms?
 | STEP 2C. Check the injector circuit for a short to ground circuit. | Greater than 100k ohms?
STEP 3. | Check the engine harness for a damage. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the Original Equipment Manufacturer (OEM) harness. | Less than 1 ohm?
 | STEP 3E. Check the engine harness for a pin-to-pin short. | Greater than 100k ohms?
 | STEP 3F. Check for active fault codes. | Fault code 321 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 321 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector and injector circuit for a damage.

Guided Step 2A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 4.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the injector circuit for an open or short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 4.

Action

Check for an open or short circuit.

  • Measure the resistance between the injector 4 POWER pin and injector 4 SIGNAL pin at the injector 4.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 3.5 to 4.9 ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the injector circuit for a short to ground circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 4.

Action

Check for a short to ground circuit.

  • Measure the resistance between the injector 4 POWER pin and cylinder block.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged injector has been detected.

Replace the injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness for a damage.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness or ECM connector C.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine harness from the Injector 4.

Action

Check for an open circuit.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector C of the engine harness to the injector 4 SIGNAL pin at the Injector 4 connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open injector 4 SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the Injector 4.

Action

Check for an open circuit.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the Fuel Metering Valve drive relay and the injector 4 POWER SUPPLY pin in the engine harness injector 4 connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the Fuel Metering Valve drive relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the engine harness from the injector 4 connector.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the injector 4 SIGNAL pin in ECM connector C and all other pins in the connector A, B and C.

See the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault code 321 active?
YES NO

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 311, 312, 313, 314, 315, 321, 5997, 5999, 6111, 6156, or 6158 active?
 | STEP 1B. Read the fault codes with Toolkit electronic service tool. | Fault Code 322 active?
STEP 2. | Check the engine fuel system for blocks and sharp bend. |
 | STEP 2A. Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend. | Any blocks and sharp bend?
 | STEP 2B. Check the fuel system connections from fuel tank to fuel metering valve for leaks. | Fuel leaks?
 | STEP 2C. Check fuel filter for oil and clogging. | Evidence of oil and the fuel filter clogging?
 | STEP 2D. Perform the injector clean feature and clean the injectors. | Fault code 322 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 311, 312, 313, 314, 315, 321, 5997, 5999, 6111, 6156, or 6158 active?
YES | NO
No Repair | No Repair

Troubleshoot appropriate fault code.

Go to 1B

Guided Step 1B - Read the fault codes with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel system for blocks and sharp bend.

Guided Step 2A - Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Any blocks and sharp bend?
YES NO

A blocked or sharp bend fuel line has been detected in the fuel system. Repair or replace the blocked or sharp bend fuel line.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the fuel system connections from fuel tank to fuel metering valve for leaks.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for fuel leaks in the fuel system from fuel tank to fuel metering valve.

  • Check the fuel lines, and fuel connections for leaks.
  • Use the combustible gas detector service tool.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Repair or replace the leaking component.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check fuel filter for oil and clogging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the fuel filter and check the fuel filter for oil in and clogging.

Refer to Procedure 006-015 in the Associated Procedures Table.

Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil and the fuel filter clogging?
YES NO

Replace the fuel filter. Refer to Procedure 006-015 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Perform the injector clean feature and clean the injectors.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the Toolkit electronic service tool.

Action

Perform the injector clean feature and clean the injectors.

  • Use Toolkit electronic service tool to conduct the injector clean in the screen of Diagnostic Mode - Injector Cleaning.
  • Confirm the fuel metering valve works well.

Fault code 322 inactive?
YES NO
No Repair

A damaged fuel metering valve has been detected. Perform injector diagnostic test to isolate the damaged injector.

Replace the damaged injector. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Sep-2015


FAULT CODE 334 - Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

WARNING

Do not remove the pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine coolant temperature accuracy. |
 | STEP 1A. Check the sensor accuracy. | Temperature sensor reading with Toolkit electronic service tool correlate to the actual ambient temperature?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active?
 | STEP 2C. Check the circuit response. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 334 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine coolant temperature accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool to the vehicle data link.

Action

Monitor the engine coolant temperature reading against actual ambient temperature when the engine is cold.

  • Use Toolkit electronic service tool to monitor the engine coolant temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to the actual ambient temperature.

Temperature sensor reading with Toolkit electronic service tool correlate to the actual ambient temperature?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Place a jumper wire between the engine coolant temperature SIGNAL pin and the engine coolant temperature RETURN pin at the engine coolant temperature connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 334 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640
Humidity Sensor | Refer to Procedure 019-356 | B6.7 G CMOH6.0 B125 | 4383640
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 G CMOH6.0 B125 | 4383640
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 G CMOH6.0 B125 | 4383640
Engine Throttle Intake Pressure Sensor | Refer to Procedure 019-470 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 1. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the crankshaft position sensor and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine intake air pressure sensor and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the oil pressure sensor and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the intake manifold pressure/temperature sensor and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. Inspect the natural gas pressure/temperature sensor and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
 | STEP 2G. Inspect the humidity sensor and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2G-1. Check the circuit response. |
 | STEP 2H. Inspect the throttle actuator and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2H-1. Check the circuit response. |
 | STEP 2I. Inspect the barometric air pressure sensor and circuit connected to the sensor supply 1. | Dirty or damaged pins?
 | STEP 2I-1. Check the circuit response. |
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for inactive fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 1.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the crankshaft position sensor and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the crankshaft position sensor.

Refer to Procedure 019-365 in the Associate Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine intake air pressure sensor and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake air pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake air pressure sensor.

Refer to Procedure 019-470 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the oil pressure sensor and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the intake manifold pressure/temperature sensor and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Inspect the natural gas pressure/temperature sensor and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the natural gas pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the natural gas pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fuel metering valve.

Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 2G

Go to 4A

Guided Step 2G - Inspect the humidity sensor and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2G-1

Guided Step 2G-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the humidity sensor.

Refer to Procedure 019-356 in the Associated Procedures Table.

Go to 2H

Go to 4A

Guided Step 2H - Inspect the throttle actuator and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the engine harness.

Action

Inspect the engine harness and throttle actuator pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2H-1

Guided Step 2H-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the throttle actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the throttle actuator.

Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 2I

Go to 4A

Guided Step 2I - Inspect the barometric air pressure sensor and circuit connected to the sensor supply 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and throttle actuator pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2I-1

Guided Step 2I-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the barometric air pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Inspect the engine harness and ECM connector A, B, and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect all sensors and actuators connected to the sensor supply 1 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the sensor supply 1 pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect all sensors and actuators connected to the sensor supply 1 from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the sensor supply 1 pin in the engine harness ECM connector C and ground.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the Engine Control Module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Engine Control Module (ECM).

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Inspect the engine harness and ECM connector A, B, and C pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 386 active?

YES NO

Relace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 1 line.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil System | Refer to Procedure 007-037 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Lubricating oil level is above or below specification. | Lubricating oil level above or below specification?
 | STEP 1B. Check the sensor accuracy. | Sensor reading correct?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Lubricating oil level is above or below specification.

Conditions

  • Turn keyswitch OFF.

Action

Check oil level.

Lubricating oil level above or below specification?
YES NO

Drain or fill oil to bring oil level within specification.

  • Refer to Procedure 007-037 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the sensor accuracy.

Conditions

  • Connect a mechanical oil pressure gauge to the engine.
  • Connect Toolkit electronic service tool to the vehicle data link.

Action

Check the sensor accuracy.

  • Start and idle the engine and compare the oil pressure reading on the service tool monitor screen to the reading on the mechanical oil pressure gauge. If the display is absolute pressure then add atmospheric pressure to gauge reading.

NOTE: If internal engine noise is present and internal engine damage is suspected do not operate the engine. See the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS.

Sensor reading correct?
YES NO
No Repair

Replace the sensor if electronic service tool reading differs from mechanical gauge reading. Refer to Procedure 019-066 in the Associated Procedures Table.

See the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 436 - Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the intake manifold 1 temperature accuracy. |
 | STEP 1A. Check the sensor accuracy. | Temperature sensor reading with Toolkit electronic service tool correlate to the actual ambient temperature?
STEP 2. | Check the intake manifold absolute pressure and temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold absolute pressure and temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 436 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the intake manifold 1 temperature accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool to the vehicle data link.

Action

Monitor the intake manifold 1 temperature reading against actual ambient temperature when the engine is cold.

  • Use Toolkit electronic service tool to monitor the intake manifold 1 temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to the actual ambient temperature.

Temperature sensor reading with Toolkit electronic service tool correlate to the actual ambient temperature?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold absolute pressure and temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold absolute pressure and temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold absolute pressure and temperature sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Place a jumper wire between the intake manifold 1 temperature SIGNAL pin and the intake manifold 1 temperature RETURN pin at the intake manifold absolute pressure and temperature sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

Replace the intake manifold absolute pressure and temperature sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C intake manifold absolute pressure and temperature sensor RETURN pin and the engine harness intake manifold absolute pressure and temperature sensor RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C intake manifold absolute pressure and temperature sensor SIGNAL pin and the engine harness intake manifold absolute pressure and temperature sensor SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 436 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charging System Alternator | Refer to Procedure 013-001 | B6.7 G CMOH6.0 B125 | 4383640
Batteries | Refer to Procedure 013-007 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 442 inactive?
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery connections. | Batteries connected properly for the system voltage required?
 | STEP 2B. Determine battery voltage. | Voltages at least + 24 VDC under normal conditions and at least + 12 VDC during cranking?
STEP 3. | Check the charging system. |
 | STEP 3A. Check the alternator for correct charging voltage. | Charging system performing properly and pass the test?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tooll.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check to make sure batteries are installed correctly.

Batteries connected properly for the system voltage required?
YES NO
No Repair

Install the battery system correctly.

See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Determine battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the voltage across the negative (-) and positive (+) terminals of the battery.

Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while the engine is not running.

Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

  • Use a multimeter to read the battery voltage.

Voltages at least + 24 VDC under normal conditions and at least + 12 VDC during cranking?
YES NO
No Repair

A damaged or incorrect battery has been detected.

Charge or replace the battery. Refer to Procedure 013-007 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the charging system.

Guided Step 3A - Check the alternator for correct charging voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check and test the vehicle charging system.

  • Refer to Procedure 013-001 in the Associated Procedures Table.

Charging system performing properly and pass the test?
YES NO
No Repair

A damaged charging system has been detected.

Repair the charging system. Refer to Procedure 013-001 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 495 - Turbocharger Wastegate Actuator 1 Position - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 495 inactive?
STEP 2. | Check Barometric Air Pressure Sensor and circuit. |
 | STEP 2A. Inspect the Barometric Air Pressure Sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify Barometric Air Pressure reading. | Barometric Air Pressure value is the same as Intake Manifold Absolute Pressure and Temperature Sensor?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 495 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for inactive or Intermittent fault code.

Go to 2A

Guided Step 2 - Check Barometric Air Pressure Sensor and circuit.

Guided Step 2A - Inspect the Barometric Air Pressure Sensor and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the Barometric Air Pressure Sensor from the engine harness.

Action

Inspect the engine harness and Barometric Air Pressure Sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Verify Barometric Air Pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the Barometric Air Pressure Sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare Barometric Air Pressure to Intake Manifold Absolute pressure and Temperature Sensor.

Barometric Air Pressure value is the same as Intake Manifold Absolute Pressure and Temperature Sensor?
YES NO
No Repair

A damaged Barometric Air Pressure sensor has been detected.

Repair and replace the sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Aug-2015


FAULT CODE 512 - Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Electronic Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Codes 512 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 513 active?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 512 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 512 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 512 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and engine throttle connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from +5 VDC POWER SUPPLY pin to +5 VDC POWER SUPPLY RETURN pin at the engine throttle actuator connector of the engine harness.

Use a wiring diagram for connector pin indentification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 513 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check for fault codes and verify sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 512 inactive?
YES NO

Note: The removal and installation of the connectors correct the fault.

Replace the engine throttle actuator.

Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Note: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B and C or the engine harness connector B and C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector C.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between +5 VDC POWER SUPPLY pin in the engine harness ECM connector C and throttle position 1 sensor SIGNAL pin in the engine harness ECM connector C.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit between +5 VDC POWER SUPPLY pin in the engine harness ECM connector C and throttle position 1 sensor SIGNAL pin in the engine harness ECM connector C has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector A, B, and C.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between throttle position 1 sensor SIGNAL pin in the engine harness ECM connector C and all other pins in the ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit between power supply line and throttle position 1 sensor SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 512 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 513 - Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Electronic Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Codes 513 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 512 active and Fault Code 513 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 513 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 513 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and engine throttle connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from +5 VDC POWER SUPPLY pin to +5 VDC POWER SUPPLY RETURN pin at the engine throttle actuator connector of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Check the circuit response after 30 seconds.

Place a jumper wire between +5 VDC POWER SUPPLY pin and the throttle position 1 sensor SIGNAL pin in the engine harness engine throttle actuator connector. Use the circuit diagram or wiring diagram for connector pin identification.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 512 active and Fault Code 513 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 513 active?
YES NO

A damaged engine throttle actuator has been detected.

Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Note: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

Measure the voltage from +5 VDC POWER SUPPLY pin to +5 VDC POWER SUPPLY RETURN pin at the ECM engine connector C.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Note: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn the keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Place a jumper wire between +5 VDC POWER SUPPLY pin and the throttle position 1 sensor SIGNAL pin at the ECM engine connector C. Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 512 active and Fault Code 513 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 513 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin or pin-to-ground short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 587 - Keyswitch Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 587 inactive?
STEP 2. | Check the keyswitch and circuit. |
 | STEP 2A. Inspect the keyswitch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the keyswitch function. | Did the keyswitch function correctly?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness and/or Original Equipment Manufacturer (OEM) harness. | Greater than 1 ohms?
 | STEP 3C. Check for an open circuit in the engine harness and/or OEM harness. | Greater than 1 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 587 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 587 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the keyswitch and circuit.

Guided Step 2A - Inspect the keyswitch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the keyswitch from the OEM harness.

Action

Inspect the OEM harness and keyswitch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the keyswitch function.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch function.

  • Refer to Procedure 019-064 in Section 19.

Did the keyswitch function correctly?
YES NO

A damaged keyswitch has been detected.

Replace the keyswitch. Refer to Procedure 019-064 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A and B.

Action

Inspect the engine harness and ECM connector A and B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector A and B.

Clean the connector A, B and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness and/or Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the keyswitch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the keyswitch key-on pin in the engine harness ECM connector A and the keyswitch key-on pin in the OEM harness.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 1 ohms?
YES NO
No Repair

An open circuit on the key-on wire has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness and/or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.
  • Disconnect the Battery (-) from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the battery (-) pin in the engine harness ECM connector B and the battery (-) pin in the OEM harness.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 1 ohms?
YES NO
No Repair

An open circuit on the Battery (-) wire has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the keyswitch key-on pin in the engine harness ECM connector A and engine block ground.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit on the key-on wire has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 587 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Sep-2015


FAULT CODE 771 - Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 771 inactive?
STEP 2. | Check the Brake Switch and circuit. |
 | STEP 2A. Inspect the Brake Switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the functionality for Brake Switch. | Brake Switch function well?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the Original Equipment Manufacturer (OEM) and engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 771 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 771 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for intermittent or inactive fault code.

Go to 2A

Guided Step 2 - Check the Brake Switch and circuit.

Guided Step 2A - Inspect the Brake Switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Brake Switch from the OEM harness.

Action

Inspect the OEM harness and switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the functionality for Brake Switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Brake Switch from the OEM harness.

Action

Check the functionality for Brake Switch.

Refer to Procedure 019-088 in Section 19.

Brake Switch function well?
YES NO
No Repair

Brake Switch is not working well.

Readjust or replace the Brake Switch. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or the engine harness connector A.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the Original Equipment Manufacturer (OEM) and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM A.
  • Disconnect the Brake Switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A Brake Switch SIGNAL pin and the OEM harness Brake Switch connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM A.
  • Disconnect the Brake Switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A Brake Switch RETURN pin and the OEM harness Brake Switch connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM A, B and C.
  • Disconnect the Brake Switch from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the Brake Switch SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness and OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 771 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new Engine Control Module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 783 active?
 | STEP 1B. Inspect the intake manifold absolute pressure and temperature sensor for correct installation and any damage. | Damage found and installation position wrong?
STEP 2. | Check the intake manifold absolute pressure and temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold absolute pressure and temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 783 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Inspect the intake manifold absolute pressure and temperature sensor for correct installation and any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the intake manifold absolute pressure and temperature sensor for correct installation and any damage.

Damage found and installation position wrong?
YES NO

Replace and repair the intake manifold absolute pressure and temperature sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the intake manifold absolute pressure and temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold absolute pressure and temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Inspect the engine harness and intake manifold absolute pressure and temperature sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Place a jumper wire between the intake manifold absolute pressure and temperature sensor temperature SIGNAL pin and the intake manifold absolute pressure and temperature sensor RETURN pin at the intake manifold absolute pressure and temperature sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

Replace the intake manifold absolute pressure and temperature sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C intake manifold absolute pressure and temperature sensor RETURN pin and the engine harness intake manifold absolute pressure and temperature sensor RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C intake manifold absolute pressure and temperature sensor temperature SIGNAL pin and the engine harness intake manifold absolute pressure and temperature sensor temperature SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 1443 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Voltages at least +24 VDC under normal conditions and at least +12 VDC during cranking?
STEP 2. | Check the alternator and Original Equipment Manufacturer (OEM) harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the Engine Control Module (ECM) connector A and B. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for an open circuit in the power relay battery supply circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-ground short circuit in the harness. | Greater than 100k ohms?
 | STEP 2F. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
 | STEP 2G. Check for an inactive fault code. | Fault Code 1443 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Voltages at least +24 VDC under normal conditions and at least +12 VDC during cranking?
YES NO
No Repair

Charge or replace the battery.

See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and Original Equipment Manufacturer (OEM) harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the Engine Control Module (ECM) connector A and B.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM connector A and B.

Action

Inspect the engine harness and ECM connector A and B Battery supply pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector A and B.
  • Disconnect the battery wires from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the ECM harness connector A and the battery supply (+) terminal of the battery on the OEM harness.
  • Measure the resistance of the ECM battery supply (-) circuit between the ECM harness connector B and the battery supply (-) terminal of the battery on the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the power harness.

Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the power relay battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery wires from the OEM harness.
  • Disconnect the engine harness connector from the ECM connector B.

Action

Check for an open circuit.

  • Measure the resistance of the Battery (+) circuit between the battery supply (+) terminal of the battery on the OEM harness and Normal Open contact of the Fuel Metering Valve drive relay on the OEM harness.
  • Measure the resistance of the POWER SUPPLY (+) circuit between the ECM harness connector B and Normal Open contact of the Fuel Metering Valve drive relay on the OEM harness.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

Check the FUSE. If it damaged, replace the FUSE.

See equipment manufacturer service information.

If the FUSE function correctly, repair or replace the power harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the battery cables from Battery.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the ECM POWER SUPPLY (+) pin in ECM connector B and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the harnesses.

Repair or replace the engine harness and /or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit at the supply wire to the engine block ground.

Damaged wires?
YES NO

Repair or replace the damaged wire.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2G

Guided Step 2G - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1443 active?
YES NO

Replace the fuel metering valve drive relay. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Sep-2015


FAULT CODE 1754 - Engine Fuel Temperature Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1754 inactive?
STEP 2. | Check the engine gas temperature/pressure sensor and circuit. |
 | STEP 2A. Inspect the engine gas temperature/pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1755 active and Fault Code 1754 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1754 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector C pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1755 active and Fault Code 1754 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1754 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1754 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine gas temperature/pressure sensor and circuit.

Guided Step 2A - Inspect the engine gas temperature/pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine gas temperature/pressure sensor TEMPERATURE SIGNAL pin and engine gas temperature/pressure sensor RETURN pin at the engine harness engine gas temperature/pressure sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

See the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1755 active and Fault Code 1754 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine gas temperature/pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1754 active?
YES NO

A damaged sensor has been detected.

Replace the engine gas temperature/pressure sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine gas temperature/pressure sensor TEMPERATURE SIGNAL pin and engine gas temperature/pressure sensor RETURN pin at the ECM connector C.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1755 active and Fault Code 1754 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C engine gas temperature/pressure sensor RETURN pin and the engine harness engine gas temperature/pressure sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C engine gas temperature/pressure sensor TEMPERATURE SIGNAL pin and the engine harness engine gas temperature/pressure sensor connector TEMPERATURE SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine gas temperature/pressure sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1754 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Sep-2015


FAULT CODE 1755 - Engine Fuel Temperature Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1755 inactive?
STEP 2. | Check the engine gas temperature/pressure sensor and circuit. |
 | STEP 2A. Inspect the engine gas temperature/pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1754 active and Fault Code 1755 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1755 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector C pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1754 active and Fault Code 1755 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1755 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1755 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine gas temperature/pressure sensor and circuit.

Guided Step 2A - Inspect the engine gas temperature/pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1754 active and Fault Code 1755 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine gas temperature/pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1755 active?
YES NO

A damaged sensor has been detected.

Replace the engine gas temperature/pressure sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector C.

Clean the connector C and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1754 active and Fault Code 1755 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine gas temperature/pressure sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine gas temperature/pressure sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1755 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Sep-2015


FAULT CODE 1765 - Engine Fuel Valve 2 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1765 inactive?
STEP 2. | Check the Engine Gas Temperature/Pressure Sensor and circuit. |
 | STEP 2A. Inspect the Engine Gas Temperature/Pressure Sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1766 active and Fault Code 1765 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1765 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1765 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for inactive or intermittent fault code.

Go to 2A

Guided Step 2 - Check the Engine Gas Temperature/Pressure Sensor and circuit.

Guided Step 2A - Inspect the Engine Gas Temperature/Pressure Sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Inspect the engine harness and engine gas temperature/pressure sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1766 active and Fault Code 1765 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine gas temperature/pressure sensor +5 VDC SUPPLY pin to the engine gas temperature/pressure sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine gas temperature/pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1765 active?
YES NO

A damaged sensor has been detected.

Replace the engine gas temperature/pressure sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1766 active and Fault Code 1765 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1765 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine gas temperature/pressure sensor +5 VDC SUPPLY pin to the engine gas temperature/pressure sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1765 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Sep-2015


FAULT CODE 1766 - Engine Fuel Valve 2 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1766 inactive?
STEP 2. | Check the Engine Gas Temperature/Pressure Sensor and circuit. |
 | STEP 2A. Inspect the Engine Gas Temperature/Pressure Sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1765 active and Fault Code 1766 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1766 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector C pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for inactive fault code.

  • Use Toolkit electronic service tool to read the inactive fault codes.

Fault Code 1766 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for inactive or intermittent fault code.

Go to 2A

Guided Step 2 - Check the Engine Gas Temperature/Pressure Sensor and circuit.

Guided Step 2A - Inspect the Engine Gas Temperature/Pressure Sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.

Action

Inspect the engine harness and engine gas temperature/pressure sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine gas temperature/pressure sensor +5 VDC SUPPLY pin to the engine gas temperature/pressure sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine gas temperature/pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine gas temperature/pressure sensor +5 VDC SUPPLY pin and the engine gas temperature/pressure sensor pressure SIGNAL pin at the engine gas temperature/pressure sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1765 active and Fault Code 1766 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine gas temperature/pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1766 active?
YES NO

A damaged sensor has been detected.

Replace the engine gas temperature/pressure sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector C, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine gas temperature/pressure sensor +5 VDC SUPPLY pin to the engine gas temperature/pressure sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1766 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine gas temperature/pressure sensor +5 VDC SUPPLY pin and the engine gas temperature/pressure sensor pressure SIGNAL pin at the engine control module engine connector C.

See the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1765 active and Fault Code 1766 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1766 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Sep-2015


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 G CMOH6.0 B125 | 4383640
Crankshaft Position Sensorr | Refer to Procedure 019-365 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault code. | Is Fault Code 234 active?
 | STEP 1B. Check for active fault codes. | Active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, and 3514?
 | STEP 1C. Check the engine Revolutions Per Minute (rpm) with Toolkit electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness, crankshaft position sensor and camshaft position sensor connector pins. | Dirty or damaged pins?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active Fault Code.

Is Fault Code 234 active?
YES | NO
No Repair | No Repair

Troubleshoot active Fault Code 234.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, and 3514.

Active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, and 3514?
YES | NO
No Repair | No Repair

Troubleshoot active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, and 3514.

Go to 1C

Guided Step 1C - Check the engine Revolutions Per Minute (rpm) with Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate engine.
  • Connect Toolkit electronic service tool.

Action

Start the engine and check the engine rpm with Toolkit electronic service tool.

  • Compare the engine speed reading on Toolkit electronic service tool to a mechanical tachometer or digital optical tachometer, Part Number 3377462, or equivalent.

Correct rpm reading?
YES NO
No Repair

Inspect the engine camshaft speed/position sensor 1 and engine camshaft speed/position sensor 2 as outlined in Fault Code 6126 and Fault Code 6127.

Go to 1D

Troubleshoot Fault Codes 6126 and 6127.

Guided Step 1D - Inspect the engine harness, crankshaft position sensor and camshaft position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor and camshaft position sensor from the engine harness.

Action

Inspect the engine harness and sensors connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 2189 - Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2189 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault code 2189 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2189 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19 for an inactive or intermittent fault code.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and the engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

Repair or replace the harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM connector C.

Action

Check for an open circuit in the throttle position sensor circuit.

  • Measure the resistance between the engine harness ECM connector C throttle position 1 sensor SIGNAL pin and engine harness throttle actuator connector throttle position1 sensor SIGNAL pin.
  • Measure the resistance between the engine harness ECM connector C throttle position 2 sensor SIGNAL pin and engine harness throttle actuator connector throttle position 2 sensor SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Disconnect the engine harness from ECM connector A, B, and C.

Action

Check for a pin-to-pin short circuit in the throttle position sensor circuit.

  • Measure the resistance between the ECM connector C throttle position 1 sensor SIGNAL pin and all other pins in the ECM connector A, B, and C.
  • Measure the resistance between the ECM connector C throttle position 2 sensor SIGNAL pin and all pins in the ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Depress and release the accelerator pedal a few time. Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault code 2189 active?
YES NO

Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 2191 - Intake Manifold Absolute Pressure Sensor Disagrees With the Compressor Outlet Pressure Sensor - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are there active other fault codes about the throttle and intake manifold absolute pressure and temperature sensor?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2191 inactive?
STEP 2. | Verify the intake manifold absolute pressure and temperature sensor with the engine intake air pressure. |
 | STEP 2A. Verify intake manifold absolute pressure reading. | Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
STEP 3. | Check the engine throttle control actuator operation. |
 | STEP 3A. Check for active fault codes. | Did the actuator pass the test?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Usse Toolkit electronic service tool to read the fault codes.

Are there active other fault codes about the throttle and intake manifold absolute pressure and temperature sensor?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2191 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for inactive or intermittent fault code.

Go to 2A

Guided Step 2 - Verify the intake manifold absolute pressure and temperature sensor with the engine intake air pressure.

Guided Step 2A - Verify intake manifold absolute pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the intake manifold absolute pressure and temperature sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare intake manifold absolute pressure to engine intake air pressure sensor.

NOTE: Toolkit electronic service tool may display engine intake air pressure as turbocharger compressor outlet pressure.

Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
YES NO
No Repair

A damaged sensor has been detected.

Repair and replace the sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine throttle control actuator operation.

Guided Step 3A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle clean test.

  • Use Toolkit electronic service tool to conduct the throttle clean test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO
No Repair

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 2519 - Throttle Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are there any active other fault codes about the throttle?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Are there any active other fault codes about the throttle?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Aug-2015


FAULT CODE 2643 - Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2643 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Between 4.8-VDC and 5.2-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2644 active and Fault Code 2643 inactive?
 | STEP 2D. Check for fault codes and verify sensor condition. | Fault Code 2643 inactive?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2643 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and engine throttle connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from +5V POWER SUPPLY pin to +5V POWER SUPPLY RETURE pin at the engine throttle actuator connector of the engine harness.

Use a wiring diagram for connector pin indentification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8-VDC and 5.2-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2644 active and Fault Code 2643 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check for fault codes and verify sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2643 inactive?
YES NO

Note: The removal and installation of the connectors correct the fault.

Replace the engine throttle actuator.

Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Note: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

Measure the voltage from +5V POWER SUPPLY pin to +5V POWER SUPPLY RETURE pin at the ECM engine connector C.

Use a wiring diagram for connector pin indentification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8-VDC and 5.2-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2643 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Note: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2644 active and Fault Code 2643 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2643 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2644 - Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2644 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Between 4.8-VDC and 5.2-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2643 active and Fault Code 2644 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2644 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2644 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from +5V POWER SUPPLY pin to +5V POWER SUPPLY RETURE pin at the engine throttle actuator connector of the engine harness.

Use a wiring diagram for connector pin indentification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8-VDC and 5.2-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Check the circuit response after 30 seconds.

Place a jumper wire between +5V POWER SUPPLY pin and the Throttle Position 2 Sensor SIGNAL pin in the engine harness engine throttle actuator connector. Use the circuit diagram or wiring diagram for connector pin identification.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2643 active and Fault Code 2644 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine throttle actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2644 active?
YES NO

A damaged engine throttle actuator has been detected.

Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

NOTE: The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Note: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

Measure the voltage from +5V POWER SUPPLY pin to +5V POWER SUPPLY RETURE pin at the ECM engine connector C.

Use a wiring diagram for connector pin indentification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8-VDC and 5.2-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2644 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Note: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air into the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between +5V POWER SUPPLY pin and the Throttle Position 2 Sensor SIGNAL pin at the ECM engine connector C. Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 2643 active and Fault Code 2644 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2644 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin or pin-to- ground short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2015


FAULT CODE 2661 - At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Engine Control Module (ECM). |
 | STEP 1A. Check the ECM. | Fault Code 2661 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 2661. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the Engine Control Module (ECM).

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 2661 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 2661.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 2661.

  • Use Toolkit electronic service tool to read the inactive counts of Fault Code 2661.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Aug-2015


FAULT CODE 2752 - Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2752 active?
STEP 2. | Check the engine throttle control actuator. |
 | STEP 2A. Inspect the engine throttle control actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine throttle control actuator. | Between 1.3 to 2.6 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the Engine Control Module (ECM) connector B pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 2752 active?
 | STEP 3D. Check the engine throttle control actuator. | Did the actuator pass the test?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2752 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle control actuator.

Guided Step 2A - Inspect the engine throttle control actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle control actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle control actuator from the engine harness.

Action

Check for an open circuit in the engine throttle control actuator.

  • Measure the actuator resistance on the engine throttle control actuator connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 1.3 to 2.6 ohms?
YES NO
No Repair

Replace the defective engine throttle control actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the Engine Control Module (ECM) connector B pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector B.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle control actuator.
  • Disconnect the engine harness ECM connector B.

Action

Check for an open circuit.

  • Measure the resistance between the throttle actuator positive (+) pin in the ECM connector B and the throttle actuator positive (+) pin in the engine harness actuator connector.
  • Measure the resistance between the throttle actuator negative (-) pin in the ECM connector B and the throttle actuator (-) pin in the engine harness actuator connector.

See the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness. Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2752 active?
YES NO

  • First replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

If Fault Code 2752 is still active after replacing ECM, Go to 3D.

 No Repair

Go to 4A

Go to 4A

Guided Step 3D - Check the engine throttle control actuator.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle control actuator clean test.

  • Use Toolkit electronic service tool to conduct the throttle actuator clean test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO
No Repair

A damaged engine throttle control actuator has been detected.

  • Use the following procedure to replace the engine throttle control actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2015


FAULT CODE 2768 - Engine Network Master Slave Communication - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Did the fault codes related to the multiplexing devices exist?
 | STEP 1B. Check for an active fault code. | Fault Code 2768 active?
STEP 2. | Check for Engine Control Module (ECM) Data logging feature setting. |
 | STEP 2A. Check for ECM Data logging feature setting with the Toolkit electronic service tool. | Did the engine ECM Data logging feature enable?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the active fault codes related to the multiplexing devices.

  • Use Toolkit electronic service tool to read the fault codes.

Did the fault codes related to the multiplexing devices exist?
YES | NO
No Repair | No Repair

See active Fault Code Troubleshooting Trees.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2768 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for Engine Control Module (ECM) Data logging feature setting.

Guided Step 2A - Check for ECM Data logging feature setting with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check that the engine ECM Data logging feature enables in Toolkit screen-Monitor-Data logging.

Did the engine ECM Data logging feature enable?
YES NO

Use Toolkit electronic service tool to disable the Data logging feature.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Jun-2015


FAULT CODE 2793 - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 G CMOH6.0 B125 | 4383640
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are the fault codes related to the cooling fan and coolant level active?
STEP 2. | Monitor coolant temperature reading. |
 | STEP 2A. Monitor coolant temperature reading. | Temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 3. | Check the coolant system components. |
 | STEP 3A. Check for faulty coolant thermostat. | Coolant thermostat faulty?
 | STEP 3B. Check for an inactive fault code. | Fault Code 2793 inactive?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for other active fault codes related to the cooling fan and coolant level sensor.

  • Use Toolkit electronic service tool to read the fault codes.

Are the fault codes related to the cooling fan and coolant level active?
YES | NO
No Repair | No Repair

Troubleshooting the active fault codes related to the cooling fan and coolant level sensor.

Go to 2A

Guided Step 2 - Monitor coolant temperature reading.

Guided Step 2A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use Toolkit electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the coolant system components.

Guided Step 3A - Check for faulty coolant thermostat.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant thermostat.

  • Refer to Procedure 008-013 in the Associated Procedures Table.

Coolant thermostat faulty?
YES NO

Replace the engine coolant thermostat.

Refer to Procedure 008-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2793 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 2812 - Electronic Throttle Control Actuator - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2812 active?
STEP 2. | Check the engine throttle control actuator operation. |
 | STEP 2A. Check for active fault codes. | Did the actuator pass the test?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2812 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the engine throttle control actuator operation.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle control actuator test.

  • Use Toolkit electronic service tool to conduct the throttle actuator test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Jul-2015


FAULT CODE 2973 - Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are there active other fault codes about the throttle and Intake Manifold Absolute Pressure and Temperature Sensor?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2973 inactive?
STEP 2. | Verify the Intake Manifold Absolute Pressure and Temperature Sensor with the Engine Intake Air Pressure Sensor and Barometric Pressure Sensor. |
 | STEP 2A. Verify Intake Manifold Absolute Pressure reading. | Intake Manifold Absolute Pressure value is the same as Engine Intake Air Pressure sensor and Barometric Pressure Sensor?
STEP 3. | Check for air leaks in the air intake system. |
 | STEP 3A. Check for air leaks in the air intake system. | Air leaks?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Are there active other fault codes about the throttle and Intake Manifold Absolute Pressure and Temperature Sensor?
YES | NO
No Repair | No Repair

Troubleshooting active Fault Codes.
See appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 2973 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Verify the Intake Manifold Absolute Pressure and Temperature Sensor with the Engine Intake Air Pressure Sensor and Barometric Pressure Sensor.

Guided Step 2A - Verify Intake Manifold Absolute Pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the Intake Manifold Absolute Pressure and Temperature Sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare Intake Manifold Absolute pressure to Engine Intake Air Pressure sensor.

NOTE: Toolkit electronic service tool may display Engine Intake Air Pressure as turbocharger compressor outlet pressure.

Intake Manifold Absolute Pressure value is the same as Engine Intake Air Pressure sensor and Barometric Pressure Sensor?
YES NO
No Repair

A damaged sensor has been detected.

Repair and replace the sensor.

Refer to Procedure 019-099 or Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check for air leaks in the air intake system.

Guided Step 3A - Check for air leaks in the air intake system.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks near all gasket surfaces between the throttle actuator and where the intake meets the block. Check all pipe plugs for leaks or missing components.

  • Start the engine and let it idle.
  • Listen for air leaks while engine is operating.

Air leaks?
YES NO

Locate all damaged gaskets or components and replace accordingly.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jun-2015


FAULT CODE 2994 - Engine Control Module Internal Failure - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Engine Control Module (ECM). |
 | STEP 1A. Check for fault codes. | Fault Code 2994 active?
 | STEP 1B. Check the power supply. | Is there a constant +24 VDC power supply to the ECM?
 | STEP 1C. Inspect the ECM part number. | Was the correct ECM part number used?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the Engine Control Module (ECM).

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Check the ECM.

  • Turn keyswitch OFF and wait 30 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 2994 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the power supply.

Conditions

  • Turn keyswitch ON.

Action

Check the power supply.

  • Inspect the power supply to the ECM.
  • Check the Original Equipment Manufacturer (OEM) connector as a possible source of an intermittent power supply.

Is there a constant +24 VDC power supply to the ECM?
YES NO
No Repair

Intermittent power supply to ECM connectors.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and Refer to Procedure 019-071 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Inspect the ECM part number.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM part number.

Was the correct ECM part number used?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Repair Complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 3159 - Clutch Switch Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3159 inactive?
STEP 2. | Check the clutch switch and circuit. |
 | STEP 2A. Inspect the clutch switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the functionality for clutch switch. | Clutch switch function well?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the Original Equipment Manufacturer (OEM) and engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3159 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3159 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for intermittent or inactive fault code.

Go to 2A

Guided Step 2 - Check the clutch switch and circuit.

Guided Step 2A - Inspect the clutch switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Clutch Switch from the OEM harness.

Action

Inspect the OEM harness and switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the functionality for clutch switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the clutch switch from the OEM harness.

Action

Check the functionality for clutch switch.

Refer to Procedure 019-009 in Section 19.

Clutch switch function well?
YES NO
No Repair

Clutch switch is not working well.

Readjust or replace the clutch switch. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or the engine harness connector A.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the Original Equipment Manufacturer (OEM) and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM A.
  • Disconnect the clutch switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A clutch switch SIGNAL pin and the OEM harness clutch switch connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the clutch switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A clutch switch RETURN pin and the OEM harness clutch switch connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM A, B, and C.
  • Disconnect the clutch switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the clutch switch SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3159 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 3161 - Clutch Switch Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3161 inactive?
STEP 2. | Check the clutch switch and circuit. |
 | STEP 2A. Inspect the clutch switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the functionality for clutch switch. | Clutch switch function well?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the Original Equipment Manufacturer (OEM) and engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3161 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3161 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for intermittent or inactive fault code.

Go to 2A

Guided Step 2 - Check the clutch switch and circuit.

Guided Step 2A - Inspect the clutch switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the clutch switch from the OEM harness.

Action

Inspect the OEM harness and switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the functionality for clutch switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the clutch switch from the OEM harness.

Action

Check the functionality for clutch switch.

Refer to Procedure 019-009 in Section 19.

Clutch switch function well?
YES NO
No Repair

Clutch switch is not working well.

Readjust or replace the clutch switch. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or the engine harness connector A.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the Original Equipment Manufacturer (OEM) and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the clutch switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A clutch switch SIGNAL pin and the OEM harness clutch switch connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the clutch switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A clutch switch RETURN pin and the OEM harness clutch switch connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harnesses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM A, B, and C.
  • Disconnect the clutch switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the clutch switch SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3161 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Aug-2015


FAULT CODE 3357 - Clutch Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3357 inactive?
 | STEP 1B. Check for active fault codes. | Fault Code 3159, 3161, and 3551 active?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3357 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for intermittent or inactive fault code.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3159, 3161, and 3551 active?
YES | NO
No Repair | No Repair

Troubleshooting Fault Code 3159, 3161, and 3551.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 3514 - Engine Throttle Control Actuator - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 177, 2812 active?
 | STEP 1B. Read the fault codes. | Fault Code 3514 active?
STEP 2. | Check the engine throttle control actuator. |
 | STEP 2A. Inspect the engine throttle control actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the engine throttle control actuator. | Between 1.3 to 2.6 ohms?
 | STEP 2C. Check for a short circuit to ground in the engine throttle control actuator. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the Engine Control Module (ECM) connector B pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 3514 active?
 | STEP 3F. Check the engine throttle control actuator. | Did the actuator pass the test?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 177, 2812 active?
YES | NO
No Repair | No Repair

Troubleshooting Fault Code 177, 2812.

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3514 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle control actuator.

Guided Step 2A - Inspect the engine throttle control actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle control actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle control actuator from the engine harness.

Action

Check for a short circuit in the engine throttle control actuator.

  • Measure the actuator resistance on the engine throttle control actuator connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1.3 to 2.6 ohms?
YES NO
No Repair

Replace the defective engine throttle control actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle control actuator from the engine harness.

Action

Check for a short circuit to ground in the engine throttle control actuator connector.

  • Measure the resistance between the throttle actuator positive (+) pin on the engine throttle control actuator connector and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the defective engine throttle control actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the Engine Control Module (ECM) connector B pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector B.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle control actuator connector.
  • Disconnect the engine harness ECM connector B.

Action

Check for a short circuit.

  • Measure the resistance between the throttle actuator positive (+) pin in the ECM connector B and the throttle actuator negative (-) pin in the ECM connector B.

See the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle control actuator connector.
  • Disconnect the engine harness ECM connector B.

Action

Check for a short circuit to ground.

  • Measure the resistance between the engine throttle control actuator positive (+) pin in the ECM connector B and ground.
  • Measure the resistance between the engine throttle control actuator negative (-) pin in the ECM connector B and ground.

See the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine throttle control actuator connector.
  • Disconnect engine harness ECM connectors A, B, and C.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the engine throttle control actuator positive (+) pin in ECM connector B and all other pins in the ECM connector A, B, and C.
  • Measure the resistance between the engine throttle control actuator negative (-) pin in ECM connector B and all other pins in the ECM connector A, B, and C.

See the wiring diagram or circuit diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness. Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3514 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

If Fault Code 3514 is still active after replacing ECM, Go to 3F.

 No Repair

Go to 4A

Go to 4A

Guided Step 3F - Check the engine throttle control actuator.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle control actuator diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle actuator diagnostic test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO
No Repair

A damaged engine throttle control actuator has been detected.

  • Use the following procedure to replace the engine throttle control actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Aug-2015


FAULT CODE 3551 - Transmission Neutral Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3551 inactive?
STEP 2. | Check the transmission neutral switch and circuit. |
 | STEP 2A. Inspect the transmission neutral switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the functionality for transmission neutral switch. | Transmission neutral switch function correctly?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the Original Equipment Manufacturer (OEM) and engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3551 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3551 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for intermittent or inactive fault code.

Go to 2A

Guided Step 2 - Check the transmission neutral switch and circuit.

Guided Step 2A - Inspect the transmission neutral switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission neutral switch from the OEM harness.

Action

Inspect the OEM harness and switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the functionality for transmission neutral switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission neutral switch from the OEM harness.

Action

Check the functionality for transmission neutral switch.

See equipment manufacturer service information.

Transmission neutral switch function correctly?
YES NO
No Repair

Transmission neutral switch is not working correctly.

Repair or replace the transmission neutral switch. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or the engine harness connector A.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the Original Equipment Manufacturer (OEM) and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM A.
  • Disconnect the transmission neutral switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A transmission neutral switch SIGNAL pin and the OEM harness transmission neutral switch connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the transmission neutral switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A transmission neutral switch RETURN pin and the OEM harness transmission neutral switch connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the transmission neutral switch from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the transmission neutral switch SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19 for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table and/or Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3551 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 3841 - Cruise Control Enable Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3841 inactive?
STEP 2. | Check the cruise control enable switch and circuit. |
 | STEP 2A. Inspect the cruise control enable switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the functionality for cruise control enable switch. | Cruise control enable switch function correctly?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 3841 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3841 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the cruise control enable switch and circuit.

Guided Step 2A - Inspect the cruise control enable switch and connector pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Original Equipment Manufacturer (OEM) harness and switch terminal pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness.

Clean the connector and pins.

Repair the damaged harness, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-021 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the functionality for cruise control enable switch.

Conditions

  • Turn keyswitch OFF.

Action

Check the functionality for cruise control enable switch.

Refer to Procedure 019-021 in Section 19.

Cruise control enable switch function correctly?
YES NO
No Repair

Cruise control enable switch is not working correctly.

Repair or replace the cruise control enable switch. Refer to Procedure 019-021 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A and B.

Action

Inspect the engine harness and ECM connector A and B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A and B or the engine harness connector A and B.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the cruise control enable switch from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the cruise control enable switch SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness and OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Enable the cruise control enable switch and read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3841 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 3846 - Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are there the active fault codes associated with engine gas pressure/temperature sensor and oxygen (or exhaust gas) sensor, or intake manifold pressure above normal?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3846 inactive?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Are there the active fault codes associated with engine gas pressure/temperature sensor and oxygen (or exhaust gas) sensor, or intake manifold pressure above normal?

YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inctive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and run the engine at least 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3846 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jun-2015


FAULT CODE 3971 - Engine Turbocharger Wastegate Actuator 1 Position - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Wastegate Control Valve | Refer to Procedure 019-103 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3971 inactive?
STEP 2. | Check the Engine Turbocharger Wastegate Actuator and circuit. |
 | STEP 2A. Inspect the Engine Turbocharger Wastegate Actuator connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open or a short circuit in the Engine Turbocharger Wastegate Actuator. | Between 85.5 to 94.5 ohms ?
 | STEP 2C. Check for a short circuit in the Engine Turbocharger Wastegate Actuator solenoid. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 3971 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3971 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Engine Turbocharger Wastegate Actuator and circuit.

Guided Step 2A - Inspect the Engine Turbocharger Wastegate Actuator connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Turbocharger Wastegate Actuator connector from the engine harness.

Action

Inspect the engine harness and Engine Turbocharger Wastegate Actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open or a short circuit in the Engine Turbocharger Wastegate Actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Turbocharger Wastegate Actuator from the engine harness.

Action

Check for a short circuit in the Engine Turbocharger Wastegate Actuator solenoid.

  • Measure the solenoid resistance on the Engine Turbocharger Wastegate Actuator connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 85.5 to 94.5 ohms ?
YES NO
No Repair

Replace the Engine Turbocharger Wastegate Actuator. Refer to Procedure 019-103 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the Engine Turbocharger Wastegate Actuator solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Turbocharger Wastegate Actuator from the engine harness.

Action

Check for a short circuit to ground in the Engine Turbocharger Wastegate Actuator solenoid.

  • Measure the resistance between the Engine Turbocharger Wastegate Actuator (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Engine Turbocharger Wastegate Actuator.

Refer to Procedure 019-103 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B and C or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Turbocharger Wastegate Actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the Engine Turbocharger Wastegate Actuator POWER SUPPLY pin at the engine harness Engine Turbocharger Wastegate Actuator connector and the Engine Turbocharger Wastegate Actuator POWER SUPPLY pin in the engine harness ECM connector B.
  • Measure the resistance between the Engine Turbocharger Wastegate Actuator SIGNAL pin at the engine harness Engine Turbocharger Wastegate Actuator connector and the Engine Turbocharger Wastegate Actuator SIGNAL pin in the engine harness ECM connector C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Turbocharger Wastegate Actuator from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Engine Turbocharger Wastegate Actuator SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 3971 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Aug-2015


FAULT CODE 4811 - Engine Cylinder 1 (A1) Knock - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
Charge-Air Cooler | Refer to Procedure 010-027 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Compression | Refer to Procedure 014-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6163, 6164 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 4811 active?
STEP 2. | Check the knock sensor connectors and installation. |
 | STEP 2A. Inspect the knock sensor, sensor connector and installation. | Any knock sensor damage?
STEP 3. | Check ignition system. |
 | STEP 3A. Inspect the spark plug. | Cylinder 1 spark plug found to be failed?
 | STEP 3B. Inspect the coil extension. | Cylinder 1 coil extension damaged?
 | STEP 3C. Check the ignition coil. | Was a bad coil found?
STEP 4. | Check the related components. |
 | STEP 4A. Verify oil consumption rate. | Is the oil consumption high?
 | STEP 4B. Verify oxygen sensor operation. | Did the sensor pass the test?
 | STEP 4C. Check the turbocharger wastegate. | Is the turbocharger actuator functioning properly?
 | STEP 4D. Inspect the charge-air cooler for blocks. | Is the charge-air cooler free of blocks or other damage?
 | STEP 4E. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 4F. Check for cylinder damage. | Evidence of damage?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6163, 6164 active?
YES | NO
No Repair | No Repair

See Fault Code 6163, 6164 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use Toolkit electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Interview the driver and make sure fuel grade is correct for the application. See B6.7 G CMOH6.0 B125 Operation and Maintenance Manual, Bulletin 4383641.

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 4811 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor connectors and installation.

Guided Step 2A - Inspect the knock sensor, sensor connector and installation.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face.
  • Damage to the mounting stud or bolt.
  • Poor installation, such as incorrect torque.
  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check ignition system.

Guided Step 3A - Inspect the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug from the engine. Refer to Procedure 013-016 in the Associated Procedures Table.

Action

Inspect the cylinder 1 spark plug.

Cylinder 1 spark plug found to be failed?
YES NO

Replace the spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the coil extension.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 1 coil extension from the spark plug.
  • Disconnect the cylinder 1 coil extension from the coil.

Action

Inspect the coil extension.

  • Inspect the cylinder 1 coil extension for wear, damage and resistance. Refer to Procedure 013-050 in the Associated Procedures Table.

Cylinder 1 coil extension damaged?
YES NO

Replace the damaged coil extension.

Refer to Procedure 013-050 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the ignition coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 1 ignition coil from the engine harness. Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the cylinder 1 ignition coil.

  • Refer to Procedure 013-012 in the Associated Procedures Table.

Was a bad coil found?
YES NO

Replace the bad coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the related components.

Guided Step 4A - Verify oil consumption rate.

Conditions

  • Interview driver.

Action

Check oil consumption against mileage.

  • Check the amount of oil consumption against the mileage.

Is the oil consumption high?
YES NO

Follow the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

 No Repair

Go to Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

Go to 4B

Guided Step 4B - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the Diagnostic Modes UEGO test/Air Calibration using the Toolkit Electronic Service Tool.

  • Use Toolkit electronic service tool to activate UEGO Test Mode test. Follow the directions given by the Toolkit electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the charge-air cooler for blocks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the dirt or debris in or on the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Is the charge-air cooler free of blocks or other damage?
YES NO
No Repair

Clean the charge-air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove cylinder 1 spark plug.

Action

Inspect for cylinder 1 damage.

Refer to Procedure 014-012 in the Associated Procedures Table.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 4812 - Engine Cylinder 2 (B1) Knock - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
Charge-Air Cooler | Refer to Procedure 010-027 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Compression | Refer to Procedure 014-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6163, 6164 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 4812 active?
STEP 2. | Check the knock sensor connectors and installation. |
 | STEP 2A. Inspect the knock sensor, sensor connector and installation. | Any knock sensor damage?
STEP 3. | Check ignition system. |
 | STEP 3A. Inspect the spark plug. | Cylinder 2 spark plug found to be failed?
 | STEP 3B. Inspect the coil extension. | Cylinder 2 coil extension damaged?
 | STEP 3C. Check the ignition coil. | Was a bad coil found?
STEP 4. | Check the related components. |
 | STEP 4A. Verify oil consumption rate. | Is the oil consumption high?
 | STEP 4B. Verify oxygen sensor operation. | Did the sensor pass the test?
 | STEP 4C. Check the turbocharger wastegate. | Is the turbocharger actuator functioning properly?
 | STEP 4D. Inspect the charge-air cooler for blocks. | Is the charge-air cooler free of blocks or other damage?
 | STEP 4E. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 4F. Check for cylinder damage. | Evidence of damage?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6163, 6164 active?
YES | NO
No Repair | No Repair

See Fault Code 6163, 6164 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use Toolkit electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Interview the driver and make sure fuel grade is correct for the application. See B6.7 G CMOH6.0 B125 Operation and Maintenance Manual, Bulletin 4383641.

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 4812 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor connectors and installation.

Guided Step 2A - Inspect the knock sensor, sensor connector and installation.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face.
  • Damage to the mounting stud or bolt.
  • Poor installation, such as incorrect torque.
  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check ignition system.

Guided Step 3A - Inspect the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug from the engine. Refer to Procedure 013-016 in the Associated Procedures Table.

Action

Inspect the cylinder 2 spark plug.

Cylinder 2 spark plug found to be failed?
YES NO

Replace the spark plug.

Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the coil extension.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 2 coil extension from the spark plug.
  • Disconnect the cylinder 2 coil extension from the coil.

Action

Inspect the coil extension.

  • Inspect the cylinder 2 coil extension for wear, damage and resistance. Refer to Procedure 013-050 in the Associated Procedures Table.

Cylinder 2 coil extension damaged?
YES NO

Replace the damaged coil extension. Refer to Procedure 013-050 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the ignition coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 2 ignition coil from the engine harness. Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the cylinder 2 ignition coil.

  • Refer to Procedure 013-012 in the Associated Procedures Table.

Was a bad coil found?
YES NO

Replace the bad coil.

Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the related components.

Guided Step 4A - Verify oil consumption rate.

Conditions

  • Interview driver.

Action

Check oil consumption against mileage.

  • Check the amount of oil consumption against the mileage.

Is the oil consumption high?
YES NO

Follow the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

 No Repair

Go to Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

Go to 4B

Guided Step 4B - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the Diagnostic Modes UEGO test/Air Calibration using the Toolkit Electronic Service Tool.

  • Use Toolkit electronic service tool to activate UEGO Test Mode test. Follow the directions given by the Toolkit electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the charge-air cooler for blocks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the dirt or debris in or on the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Is the charge-air cooler free of blocks or other damage?
YES NO
No Repair

Clean the charge-air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove cylinder 2 spark plug.

Action

Inspect for cylinder 2 damage.

Refer to Procedure 014-012 in the Associated Procedures Table.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 4813 - Engine Cylinder 3 (A2) Knock - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
Charge-Air Cooler | Refer to Procedure 010-027 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Compression | Refer to Procedure 014-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6163, 6164 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 4813 active?
STEP 2. | Check the knock sensor connectors and installation. |
 | STEP 2A. Inspect the knock sensor, sensor connector and installation. | Any knock sensor damage?
STEP 3. | Check ignition system. |
 | STEP 3A. Inspect the spark plug. | Cylinder 3 spark plug found to be failed?
 | STEP 3B. Inspect the coil extension. | Cylinder 3 coil extension damaged?
 | STEP 3C. Check the ignition coil. | Was a bad coil found?
STEP 4. | Check the related components. |
 | STEP 4A. Verify oil consumption rate. | Is the oil consumption high?
 | STEP 4B. Verify oxygen sensor operation. | Did the sensor pass the test?
 | STEP 4C. Check the turbocharger wastegate. | Is the turbocharger actuator functioning properly?
 | STEP 4D. Inspect the charge-air cooler for blocks. | Is the charge-air cooler free of blocks or other damage?
 | STEP 4E. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 4F. Check for cylinder damage. | Evidence of damage?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6163, 6164 active?
YES | NO
No Repair | No Repair

See Fault Code 6163, 6164 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use Toolkit electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Interview the driver and make sure fuel grade is correct for the application. See B6.7 G CMOH6.0 B125 Operation and Maintenance Manual, Bulletin 4383641.

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 4813 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor connectors and installation.

Guided Step 2A - Inspect the knock sensor, sensor connector and installation.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 1 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face.
  • Damage to the mounting stud or bolt.
  • Poor installation, such as incorrect torque.
  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check ignition system.

Guided Step 3A - Inspect the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug from the engine. Refer to Procedure 013-016 in the Associated Procedures Table.

Action

Inspect the cylinder 3 spark plug.

Cylinder 3 spark plug found to be failed?
YES NO

Replace the spark plug.

Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the coil extension.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 3 coil extension from the spark plug.
  • Disconnect the cylinder 3 coil extension from the coil.

Action

Inspect the coil extension.

  • Inspect the cylinder 3 coil extension for wear, damage and resistance. Refer to Procedure 013-050 in the Associated Procedures Table.

Cylinder 3 coil extension damaged?
YES NO

Replace the damaged the coil extension.

Refer to Procedure 013-050 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the ignition coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 3 ignition coil from the engine harness. Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the cylinder 3 ignition coil.

  • Refer to Procedure 013-012 in the Associated Procedures Table.

Was a bad coil found?
YES NO

Replace the bad coil.

Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the related components.

Guided Step 4A - Verify oil consumption rate.

Conditions

  • Interview driver.

Action

Check oil consumption against mileage.

  • Check the amount of oil consumption against the mileage.

Is the oil consumption high?
YES NO

Follow the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

 No Repair

Go to Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

Go to 4B

Guided Step 4B - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the Diagnostic Modes UEGO test/Air Calibration using the Toolkit Electronic Service Tool.

  • Use Toolkit electronic service tool to activate UEGO Test Mode test. Follow the directions given by the Toolkit electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the charge-air cooler for blocks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the dirt or debris in or on the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Is the charge-air cooler free of blocks or other damage?
YES NO
No Repair

Clean the charge-air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove cylinder 3 spark plug.

Action

Inspect for cylinder 3 damage.

Refer to Procedure 014-012 in the Associated Procedures Table.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 4814 - Engine Cylinder 4 (B2) Knock - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
Charge-Air Cooler | Refer to Procedure 010-027 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Compression | Refer to Procedure 014-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6195, 6196 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 4814 active?
STEP 2. | Check the knock sensor connectors and installation. |
 | STEP 2A. Inspect the knock sensor, sensor connector and installation. | Any knock sensor damage?
STEP 3. | Check ignition system. |
 | STEP 3A. Inspect the spark plug. | Cylinder 4 spark plug found to be failed?
 | STEP 3B. Inspect the coil extension. | Cylinder 4 coil extension damaged?
 | STEP 3C. Check the ignition coil. | Was a bad coil found?
STEP 4. | Check the related components. |
 | STEP 4A. Verify oil consumption rate. | Is the oil consumption high?
 | STEP 4B. Verify oxygen sensor operation. | Did the sensor pass the test?
 | STEP 4C. Check the turbocharger wastegate. | Is the turbocharger actuator functioning properly?
 | STEP 4D. Inspect the charge-air cooler for blocks. | Is the charge-air cooler free of blocks or other damage?
 | STEP 4E. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 4F. Check for cylinder damage. | Evidence of damage?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6195, 6196 active?
YES | NO
No Repair | No Repair

See Fault Code 6195, 6196 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use Toolkit electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Interview the driver and make sure fuel grade is correct for the application. See B6.7 G CMOH6.0 B125 Operation and Maintenance Manual, Bulletin 4383641.

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 4814 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor connectors and installation.

Guided Step 2A - Inspect the knock sensor, sensor connector and installation.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 2 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face.
  • Damage to the mounting stud or bolt.
  • Poor installation, such as incorrect torque.
  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check ignition system.

Guided Step 3A - Inspect the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 spark plug from the engine. Refer to Procedure 013-016 in the Associated Procedures Table.

Action

Inspect the cylinder 4 spark plug.

Cylinder 4 spark plug found to be failed?
YES NO

Replace the spark plug.

Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the coil extension.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 4 coil extension from the spark plug.
  • Disconnect the cylinder 4 coil extension from the coil.

Action

Inspect the coil extension.

  • Inspect the cylinder 4 coil extension for wear, damage and resistance.

Refer to Procedure 013-050 in the Associated Procedures Table.

Cylinder 4 coil extension damaged?
YES NO

Replace the damaged coil extension.

Refer to Procedure 013-050 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the ignition coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 4 ignition coil from the engine harness. Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the cylinder 4 ignition coil.

  • Refer to Procedure 013-012 in the Associated Procedures Table.

Was a bad coil found?
YES NO

Replace the bad coil.

Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the related components.

Guided Step 4A - Verify oil consumption rate.

Conditions

  • Interview driver.

Action

Check oil consumption against mileage.

  • Check the amount of oil consumption against the mileage.

Is the oil consumption high?
YES NO

Follow the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

 No Repair

Go to Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

Go to 4B

Guided Step 4B - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the Diagnostic Modes UEGO test/Air Calibration using the Toolkit Electronic Service Tool.

  • Use Toolkit electronic service tool to activate UEGO Test Mode test. Follow the directions given by the Toolkit electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the charge-air cooler for blocks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the dirt or debris in or on the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Is the charge-air cooler free of blocks or other damage?
YES NO
No Repair

Clean the charge-air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove cylinder 4 spark plug.

Action

Inspect for cylinder 4 damage.

Refer to Procedure 014-012 in the Associated Procedures Table.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 4815 - Engine Cylinder 5 (A3) Knock - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
Charge-Air Cooler | Refer to Procedure 010-027 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Compression | Refer to Procedure 014-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6195, 6196 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 4815 active?
STEP 2. | Check the knock sensor connectors and installation. |
 | STEP 2A. Inspect the knock sensor, sensor connector and installation. | Any knock sensor damage?
STEP 3. | Check ignition system. |
 | STEP 3A. Inspect the spark plug. | Cylinder 5 spark plug found to be failed?
 | STEP 3B. Inspect the coil extension. | Cylinder 5 coil extension damaged?
 | STEP 3C. Check the ignition coil. | Was a bad coil found?
STEP 4. | Check the related components. |
 | STEP 4A. Verify oil consumption rate. | Is the oil consumption high?
 | STEP 4B. Verify oxygen sensor operation. | Did the sensor pass the test?
 | STEP 4C. Check the turbocharger wastegate. | Is the turbocharger actuator functioning properly?
 | STEP 4D. Inspect the charge-air cooler for blocks. | Is the charge-air cooler free of blocks or other damage?
 | STEP 4E. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 4F. Check for cylinder damage. | Evidence of damage?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6195, 6196 active?
YES | NO
No Repair | No Repair

See Fault Code 6195, 6196 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use Toolkit electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Interview the driver and make sure fuel grade is correct for the application. See B6.7 G CMOH6.0 B125 Operation and Maintenance Manual, Bulletin 4383641.

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 4815 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor connectors and installation.

Guided Step 2A - Inspect the knock sensor, sensor connector and installation.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 2 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face.
  • Damage to the mounting stud or bolt.
  • Poor installation, such as incorrect torque.
  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check ignition system.

Guided Step 3A - Inspect the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug from the engine. Refer to Procedure 013-016 in the Associated Procedures Table.

Action

Inspect the cylinder 5 spark plug.

Cylinder 5 spark plug found to be failed?
YES NO

Replace the spark plug.

Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the coil extension.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 5 coil extension from the spark plug.
  • Disconnect the cylinder 5 coil extension from the coil.

Action

Inspect the coil extension.

  • Inspect the cylinder 5 coil extension for wear, damage and resistance.

Refer to Procedure 013-050 in the Associated Procedures Table.

Cylinder 5 coil extension damaged?
YES NO

Replace the damaged coil extension.

Refer to Procedure 013-050 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the ignition coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 5 ignition coil from the engine harness. Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the cylinder 5 ignition coil.

  • Refer to Procedure 013-012 in the Associated Procedures Table.

Was a bad coil found?
YES NO

Replace the bad coil.

Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the related components.

Guided Step 4A - Verify oil consumption rate.

Conditions

  • Interview driver.

Action

Check oil consumption against mileage.

  • Check the amount of oil consumption against the mileage.

Is the oil consumption high?
YES NO

Follow the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

 No Repair

Go to Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

Go to 4B

Guided Step 4B - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the Diagnostic Modes UEGO test/Air Calibration using the Toolkit Electronic Service Tool.

  • Use Toolkit electronic service tool to activate UEGO Test Mode test. Follow the directions given by the Toolkit electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the charge-air cooler for blocks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the dirt or debris in or on the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Is the charge-air cooler free of blocks or other damage?
YES NO
No Repair

Clean the charge-air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove cylinder 5 spark plug.

Action

Inspect for cylinder 5 damage.

Refer to Procedure 014-012 in the Associated Procedures Table.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 4816 - Engine Cylinder 6 (B3) Knock - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
Charge-Air Cooler | Refer to Procedure 010-027 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Compression | Refer to Procedure 014-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6195, 6196 active?
 | STEP 1B. Check for existing fault codes other than knock fault codes. | Active fault codes other than knock fault codes?
 | STEP 1C. Check for an active fault code. | Fault Code 4816 active?
STEP 2. | Check the knock sensor connectors and installation. |
 | STEP 2A. Inspect the knock sensor, sensor connector and installation. | Any knock sensor damage?
STEP 3. | Check ignition system. |
 | STEP 3A. Inspect the spark plug. | Cylinder 6 spark plug found to be failed?
 | STEP 3B. Inspect the coil extension. | Cylinder 6 coil extension damaged?
 | STEP 3C. Check the ignition coil. | Was a bad coil found?
STEP 4. | Check the related components. |
 | STEP 4A. Verify oil consumption rate. | Is the oil consumption high?
 | STEP 4B. Verify oxygen sensor operation. | Did the sensor pass the test?
 | STEP 4C. Check the turbocharger wastegate. | Is the turbocharger actuator functioning properly?
 | STEP 4D. Inspect the charge-air cooler for blocks. | Is the charge-air cooler free of blocks or other damage?
 | STEP 4E. Check the overhead adjustment. | Overhead adjustment within specification?
 | STEP 4F. Check for cylinder damage. | Evidence of damage?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6195, 6196 active?
YES | NO
No Repair | No Repair

See Fault Code 6195, 6196 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for existing fault codes other than knock fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Check for existing fault codes other than knock fault codes.
  • Use Toolkit electronic service tool to read the fault codes.

Active fault codes other than knock fault codes?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault code(s).

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Interview the driver and make sure fuel grade is correct for the application. See B6.7 G CMOH6.0 B125 Operation and Maintenance Manual, Bulletin 4383641.

Start the engine and operate the engine in the condition in which the knock fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 4816 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the knock sensor connectors and installation.

Guided Step 2A - Inspect the knock sensor, sensor connector and installation.

Conditions

  • Turn keyswitch OFF.
  • Knock sensor 2 disconnected from the engine harness.

Action

Inspect the knock sensor for the following:

  • Damage to the sensor face.
  • Damage to the mounting stud or bolt.
  • Poor installation, such as incorrect torque.
  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Washers or p-clips can not be mounted with the knock sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any knock sensor damage?
YES NO

An incorrectly mounted or damaged knock sensor has been detected.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Correct the knock sensor mounting.
  • Replace the sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check ignition system.

Guided Step 3A - Inspect the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 spark plug from the engine. Refer to Procedure 013-016 in the Associated Procedures Table.

Action

Inspect the cylinder 6 spark plug.

Cylinder 6 spark plug found to be failed?
YES NO

Replace the spark plug.

Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the coil extension.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 6 coil extension from the spark plug.
  • Disconnect the cylinder 6 coil extension from the coil.

Action

Inspect the coil extension.

  • Inspect the cylinder 6 coil extension for wear, damage and resistance.

Refer to Procedure 013-050 in the Associated Procedures Table.

Cylinder 6 coil extension damaged?
YES NO

Replace the damaged coil extension.

Refer to Procedure 013-050 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the ignition coil.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the cylinder 6 ignition coil from the engine harness. Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the cylinder 6 ignition coil.

  • Refer to Procedure 013-012 in the Associated Procedures Table.

Was a bad coil found?
YES NO

Replace the bad coil.

Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the related components.

Guided Step 4A - Verify oil consumption rate.

Conditions

  • Interview driver.

Action

Check oil consumption against mileage.

  • Check the amount of oil consumption against the mileage.

Is the oil consumption high?
YES NO

Follow the Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

 No Repair

Go to Lubricating Oil Consumption Excessive troubleshooting symptom tree in Section TS.

Go to 4B

Guided Step 4B - Verify oxygen sensor operation.

Conditions

  • Connect all components.
  • Start and idle engine for 3 minutes.
  • Stop engine.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the Diagnostic Modes UEGO test/Air Calibration using the Toolkit Electronic Service Tool.

  • Use Toolkit electronic service tool to activate UEGO Test Mode test. Follow the directions given by the Toolkit electronic service tool.

Did the sensor pass the test?
YES NO
No Repair

Replace the heated oxygen sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the turbocharger wastegate.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger wastegate for proper operation.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Is the turbocharger actuator functioning properly?
YES NO
No Repair

A damaged turbocharger actuator has been detected.

Replace the actuator.

  • Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the charge-air cooler for blocks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the dirt or debris in or on the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Is the charge-air cooler free of blocks or other damage?
YES NO
No Repair

Clean the charge-air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check the overhead adjustment.

Conditions

  • Turn keyswitch OFF.

Action

Check the overhead adjustment:

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead adjustment within specification?
YES NO
No Repair

Adjust the overhead.

  • Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check for cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Remove cylinder 6 spark plug.

Action

Inspect for cylinder 6 damage.

Refer to Procedure 014-012 in the Associated Procedures Table.

Evidence of damage?
YES NO

Replace the damaged components.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 5213 - Engine PTO Governor Enable Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5213 inactive?
STEP 2. | Check the engine PTO governor enable switch and circuit. |
 | STEP 2A. Inspect the engine PTO governor enable switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the functionality for engine PTO governor enable switch. | Engine PTO governor enable switch function correctly?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 5213 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine PTO governor enable switch and circuit.

Guided Step 2A - Inspect the engine PTO governor enable switch and connector pins.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Original Equipment Manufacturer (OEM) harness and switch terminal pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness.

Clean the connector and pins.

Repair the damaged harness, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the functionality for engine PTO governor enable switch.

Conditions

  • Turn keyswitch OFF.

Action

Check the functionality for engine PTO governor enable switch.

Refer to Procedure 019-021 in Section 19.

Engine PTO governor enable switch function correctly?
YES NO
No Repair

Engine PTO governor enable switch is not working correctly.

Repair or replace the engine PTO governor enable switch.

Refer to Procedure 019-021 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A and B.

Action

Inspect the engine harness and ECM connector A and B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A and B or the engine harness connector A and B.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the engine PTO governor enable switch from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine PTO governor enable switch SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness and OEM harness.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Enable the engine PTO governor enable switch and read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5213 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 5249 - Engine Intake Air Pressure - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Throttle Intake Pressure Sensor | Refer to Procedure 019-470 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5249 inactive?
STEP 2. | Check the engine intake air pressure sensor and circuit. |
 | STEP 2A. Inspect the engine intake air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5251 active and Fault Code 5249 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5249 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5249 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for inactive or intermittent fault code.

Go to 2A

Guided Step 2 - Check the engine intake air pressure sensor and circuit.

Guided Step 2A - Inspect the engine intake air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake air pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5251 active and Fault Code 5249 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake air pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine intake air pressure sensor +5 VDC SUPPLY pin to the engine intake air pressure sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake air pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5249 active?
YES NO

A damaged sensor has been detected.

Replace the engine intake air pressure sensor. Refer to Procedure 019-470 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5251 active and Fault Code 5249 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine intake air pressure sensor +5 VDC SUPPLY pin to the engine intake air pressure sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Aug-2015


FAULT CODE 5251 - Engine Intake Air Pressure - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Throttle Intake Pressure Sensor | Refer to Procedure 019-470 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5251 inactive?
STEP 2. | Check the engine intake air pressure sensor and circuit. |
 | STEP 2A. Inspect the engine intake air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 5249 active and Fault Code 5251 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5251 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for inactive fault code.

  • Use Toolkit electronic service tool to read the inactive fault codes.

Fault Code 5251 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for inactive or intemittent fault code.

Go to 2A

Guided Step 2 - Check the engine intake air pressure sensor and circuit.

Guided Step 2A - Inspect the engine intake air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake air pressure sensor from the engine harness.

Action

Inspect the engine harness and engine intake air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake air pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine intake air pressure sensor +5 VDC SUPPLY pin to the engine intake air pressure sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine intake air pressure sensor +5 VDC SUPPLY pin and the engine intake air pressure sensor SIGNAL pin at the engine intake air pressure sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5249 active and Fault Code 5251 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake air pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5251 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-470 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector C, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine intake air pressure sensor +5 VDC SUPPLY pin to the engine intake air pressure sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5251 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Cnspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine intake air pressure sensor +5 VDC SUPPLY pin and the engine intake air pressure sensor SIGNAL pin at the engine control module engine connector C.

See the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5249 active and Fault Code 5251 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5251 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Aug-2015


FAULT CODE 5957 - Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5957 inactive?
STEP 2. | Check the engine coolant system to the fuel system. |
 | STEP 2A. Check the water shut off valve installed in the engine coolant system to the fuel system. | Is there a water shut off valve installed in the coolant system to the fuel system?
 | STEP 2B. Inspect the coolant connections for leakage. | Any leakage and wrong orientation of the connections was found?
 | STEP 2C. Inspect the coolant system components for damage. | Any damage was found?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5957 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant system to the fuel system.

Guided Step 2A - Check the water shut off valve installed in the engine coolant system to the fuel system.

Conditions

  • Turn keyswitch OFF.

Action

Check if there is a water shut off valve installed in the coolant system to the fuel system.

See equipment manufacturer service information.

Is there a water shut off valve installed in the coolant system to the fuel system?
YES NO

Remove the water shut off valve from the coolant system.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the coolant connections for leakage.

Conditions

  • Turn keyswitch OFF.

Action

Check the leakage and orientation of every coolant connection for the fuel system.

For Compressed Natural Gas (CNG) applications, check the coolant connections to the pressure regulator and heat exchanger.

See equipment manufacturer service information.

For Liquid Natural Gas (LNG) applications, check the coolant connections to the vaporization.

See equipment manufacturer service information.

Any leakage and wrong orientation of the connections was found?
YES NO

The connection leakage and/or wrong orientation was found.

Repair and replace the damaged connection.

Reinstall the connection in correct direction.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the coolant system components for damage.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant system components.

Check for kinked, restricted, or blocked coolant lines.

For CNG applications, check the pressure regulator and heat exchanger.

See equipment manufacturer service information.

For LNG applications, check the vaporization.

See equipment manufacturer service information.

Any damage was found?
YES NO

A damaged coolant system component was found.

Repair and replace the damaged component.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Jul-2015


FAULT CODE 5958 - Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5958 inactive?
STEP 2. | Check the engine coolant system to the fuel system. |
 | STEP 2A. Check the water shut off valve installed in the engine coolant system to the fuel system. | Is there a water shut off valve installed in the coolant system to the fuel system?
 | STEP 2B. Inspect the coolant connections for leakage. | Any leakage and wrong orientation of the connections was found?
 | STEP 2C. Inspect the coolant system components for damage. | Any damage was found?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5958 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant system to the fuel system.

Guided Step 2A - Check the water shut off valve installed in the engine coolant system to the fuel system.

Conditions

  • Turn keyswitch OFF.

Action

Check if there is a water shut off valve installed in the coolant system to the fuel system.

See equipment manufacturer service information.

Is there a water shut off valve installed in the coolant system to the fuel system?
YES NO

Remove the water shut off valve from the coolant system.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the coolant connections for leakage.

Conditions

  • Turn keyswitch OFF.

Action

Check the leakage and orientation of every coolant connection for the fuel system.

For Compressed Natural Gas (CNG) applications, check the coolant connections to the pressure regulator and heat exchanger.

See equipment manufacturer service information.

For Liquid Natural Gas (LNG) applications, check the coolant connections to the vaporization.

See equipment manufacturer service information.

Any leakage and wrong orientation of the connections was found?
YES NO

The connection leakage and/or wrong orientation was found.

Repair and replace the damaged connection.

Reinstall the connection in correct direction.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the coolant system components for damage.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant system components.

Check for kinked, restricted, or blocked coolant lines.

For CNG applications, check the pressure regulator and heat exchanger.

See equipment manufacturer service information.

For LNG applications, check the vaporization.

See equipment manufacturer service information.

Any damage was found?
YES NO

A damaged coolant system component was found.

Repair and replace the damaged component.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jun-2015


FAULT CODE 5959 - Engine Fuel Temperature 2 - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5959 inactive?
STEP 2. | Check the engine coolant system to the fuel system. |
 | STEP 2A. Check the water shut off valve installed in the engine coolant system to the fuel system. | Is there a water shut off valve installed in the coolant system to the fuel system?
 | STEP 2B. Inspect the coolant connections for leakage. | Any leakage and wrong orientation of the connections was found?
 | STEP 2C. Inspect the coolant system components for damage. | Any damage was found?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5959 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant system to the fuel system.

Guided Step 2A - Check the water shut off valve installed in the engine coolant system to the fuel system.

Conditions

  • Turn keyswitch OFF.

Action

Check if there is a water shut off valve installed in the coolant system to the fuel system.

See equipment manufacturer service information.

Is there a water shut off valve installed in the coolant system to the fuel system?
YES NO

Remove the water shut off valve from the coolant system.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the coolant connections for leakage.

Conditions

  • Turn keyswitch OFF.

Action

Check the leakage and orientation of every coolant connection for the fuel system.

For Compressed Natural Gas (CNG) applications, check the coolant connections to the pressure regulator and heat exchanger.

See equipment manufacturer service information.

For Liquid Natural Gas (LNG) applications, check the coolant connections to the vaporization.

See equipment manufacturer service information.

Any leakage and wrong orientation of the connections was found?
YES NO

The connection leakage and/or wrong orientation was found.

Repair and replace the damaged connection.

Reinstall the connection in correct direction.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the coolant system components for damage.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant system components.

Check for kinked, restricted, or blocked coolant lines.

For CNG applications, check the pressure regulator and heat exchanger.

See equipment manufacturer service information.

For LNG applications, check the vaporization.

See equipment manufacturer service information.

Any damage was found?
YES NO

A damaged coolant system component was found.

Repair and replace the damaged component.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jun-2015


FAULT CODE 5961 - Engine Fuel Temperature 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 5961 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1754 and/or Fault Code 1755 active?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5961 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 1754 and/or Fault Code 1755 active?
YES NO
No Repair

Replace the engine gas temperature/pressure sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Troubleshooting Fault Code 1754 and/or Fault Code 1755.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Sep-2015


FAULT CODE 5962 - Engine Fuel Temperature 2 - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5962 inactive?
 | STEP 1B. Check for active fault code. | Fault Code 144, 145, 151, 1754, 1755 and 5961 active?
STEP 2. | Monitor coolant temperature reading. |
 | STEP 2A. Monitor coolant temperature reading. | The coolant Temperature sensor reading is above normal?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5962 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 144, 145, 151, 1754, 1755 and 5961 active?
YES | NO
No Repair | No Repair

Troubleshooting Fault Code 144, 145, 151, 1754, 1755 and 5961.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Monitor coolant temperature reading.

Guided Step 2A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use Toolkit electronic service tool to monitor the coolant temperature value.

The coolant Temperature sensor reading is above normal?
YES NO

See the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

 No Repair

Appropriate troubleshooting symptom tree.

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5963 - Engine Fuel Temperature 2 - Data Not Rational - Drifted Low

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5963 inactive?
 | STEP 1B. Check for an inactive fault code. | Fault Code 5961 inactive?
STEP 2. | Check the engine coolant system to the fuel system. |
 | STEP 2A. Check the water shut off valve installed in the engine coolant system to the fuel system. | Is there a water shut off valve installed in the coolant system to the fuel system?
 | STEP 2B. Inspect the coolant connections for leakage. | Any leakage and wrong orientation of the connections was found?
 | STEP 2C. Inspect the coolant system components for damage. | Any damage was found?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5963 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5961 inactive?
YES | NO
No Repair | No Repair

Go to 2A.

Troubleshooting Fault Code 5961.
See fault code 5961 troubleshooting tree.

Guided Step 2 - Check the engine coolant system to the fuel system.

Guided Step 2A - Check the water shut off valve installed in the engine coolant system to the fuel system.

Conditions

  • Turn keyswitch OFF.

Action

Check if there is a water shut off valve installed in the coolant system to the fuel system.

See equipment manufacturer service information.

Is there a water shut off valve installed in the coolant system to the fuel system?
YES NO

Remove the water shut off valve from the coolant system.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the coolant connections for leakage.

Conditions

  • Turn keyswitch OFF.

Action

Check the leakage and orientation of every coolant connection for the fuel system.

For Compressed Natural Gas (CNG) applications, check the coolant connections to the pressure regulator and heat exchanger.

See equipment manufacturer service information.

For Liquid Natural Gas (LNG) applications, check the coolant connections to the vaporization.

See equipment manufacturer service information.

Any leakage and wrong orientation of the connections was found?
YES NO

The connection leakage and/or wrong orientation was found.

Repair and replace the damaged connection.

Reinstall the connection in correct direction.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the coolant system components for damage.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant system components.

Check for kinked, restricted, or blocked coolant lines.

For CNG applications, check the pressure regulator and heat exchanger.

See equipment manufacturer service information.

For LNG applications, check the vaporization.

See equipment manufacturer service information.

Any damage was found?
YES NO

A damaged coolant system component was found.

Repair and replace the damaged component.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 5965 - Battery 2 Voltage - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5965 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5965 active?
STEP 2. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector B pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for an active fault code. | Fault Code 5965 active?
STEP 3. | Check whether the power relay work well. |
 | STEP 3A. Perform the click test for the power relay. | Hear the sound of "click"?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness and Original Equipment Manufacturer (OEM) harness. | Greater than 100k ohms?
 | STEP 3C. Check for an active fault code. | Fault Code 5965 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5965 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Disconnect 4-PIN OEM connector.
  • Connect Toolkit electronic service tool

Action

Turn keyswitch ON and read the fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5965 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector B pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the 4-pin OEM connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the 4-pin connector power relay supply pin in the engine harness and all other pins in the engine harness ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the power relay supply wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Disconnect 4-PIN OEM connector.
  • Connect Toolkit electronic service tool.

Action

Turn keyswitch ON and read the fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5965 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check whether the power relay work well.

Guided Step 3A - Perform the click test for the power relay.

Conditions

  • Turn keyswitch OFF.

Action

Perform the click test for the power relay.

Pull out the power relay from its socket and then insert it back into its socket.

Repeat a few times.

Hear the sound of "click"?
YES NO
No Repair

A damaged power relay has been detected.

Replace the power relay.

See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness and Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Pull out the power relay and coil relay from their socket.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the POWER RELAY DRIVER pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on POWER RELAY DRIVER wire has been detected in the engine harness and/or OEM harness.

Troubleshoot OEM harness and engine harness to determine which contains the pin-to-pin short circuit.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Turn keyswitch ON and read the fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5965 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jul-2015


FAULT CODE 5966 - Engine Oil Rifle Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor accuracy. |
 | STEP 1A. Check the sensor accuracy. | Pressure sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine oil pressure sensor accuracy.

Guided Step 1A - Check the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect a mechanical oil pressure gauge to the engine.
  • Connect Toolkit electronic service tool to the vehicle data link.

Action

Monitor the oil pressure reading.

  • Use Toolkit electronic service tool to monitor the oil pressure value.
  • Compare the pressure reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Pressure sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

Inspect the oil pressure sensor for blockage or damage.

If necessary, repair or replace the sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

See the Lubricating Oil Pressurehigh troubleshooting symptomtree in Section TS.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jul-2015


FAULT CODE 5969 - Accelerator Pedal Position 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 5969 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 5969 active?
STEP 3. | Check the Engine Control Module (ECM) and Original Equipment Manufacturer (OEM) harness and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector A pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM and engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5969 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Fault Code 131 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 VDC SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 5969 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5969 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and Original Equipment Manufacturer (OEM) harness and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM and engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness and engine harness. Refer to Procedure 019-071 in Section 19 and Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in OEM harness or engine harness. Troubleshoot OEM harness and engine harness to determine which contains the pin-to-pin short circuit.

Repair or replace the OEM harness and engine harness. Refer to Procedure 019-071 in Section 19 and Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5969 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 5971 - Accelerator Pedal Position 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 5971 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 5971 is active?
STEP 3. | Check the Engine Control Module (ECM), Original Equipment Manufacturer (OEM), and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector A pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine and OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM and engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 5971 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to Fault Code 132 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 10.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 VDC SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 VDC SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 5971 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5971 is active?
YES NO

A damaged accelerator pedal has been detected. See equipment manufacturer service information for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM), Original Equipment Manufacturer (OEM), and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector A and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness from the ECM connector A.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM and engine harness.

Repair or replace the OEM harness and engine harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM and engine harness.

Repair or replace the OEM harness and engine harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness and engine harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the engine harness ECM connector A and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness or engine harness.

Repair or replace the OEM harness and engine harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5971 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2015


FAULT CODE 5972 - Accelerator Pedal or Lever Idle Validation Switch - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 5972 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the engine harness and Engine Control Module (ECM) connector A pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position sensor resistance. | 1500 to 3000 ohms (released) [250 to 1500 ohms (depressed)]? (Released value must be at least 1000 ohms greater than depressed value.)
 | STEP 2B-1. Inspect the Original Equipment Manufacturer (OEM) harness and accelerator pedal or lever connector pins. |
 | STEP 2B-2. Check the accelerator pedal or lever position sensor resistance. |
 | STEP 2C. Check for a pin-to-pin short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
STEP 3. | Check the accelerator pedal or lever idle validation switch circuit. |
 | STEP 3A. Inspect the engine harness and ECM connector A pins. | Dirty or damaged pins?
 | STEP 3B. Check the accelerator pedal or lever idle validation switch. | Greater than 100k ohms (released) [Less than 125 ohms (depressed)]?
 | STEP 3C. Check the accelerator pedal or lever idle validation switch. | Greater than 100k ohms (released) [Less than 125 ohms (depressed)]?
 | STEP 3D. Disable the fault code. | Fault Code 5972 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.

Action

Check the fault codes.

  • Slowly depress the accelerator pedal or lever to the full throttle position and release it completely three times.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5972 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor circuit.

Guided Step 2A - Inspect the engine harness and Engine Control Module (ECM) connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and the accelerator pedal or lever position sensor pins in ECM connector A for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position +5 VDC SUPPLY pin at the ECM connector A of the engine harness.

See the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms (released) [250 to 1500 ohms (depressed)]? (Released value must be at least 1000 ohms greater than depressed value.)

YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Inspect the Original Equipment Manufacturer (OEM) harness and accelerator pedal or lever connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever connector from OEM harness.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-2

Guided Step 2B-2 - Check the accelerator pedal or lever position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever connector from the OEM harness.

Action

Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position +5 VDC SUPPLY pin at the accelerator pedal or lever connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 ohms (released) [250 to 1500 ohms (depressed)]? (Released value must be at least 1000 ohms greater than depressed value.)

YES NO

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Replace the accelerator pedal or lever assembly. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 2C - Check for a pin-to-pin short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM A, B, and C.
  • Disconnect the accelerator pedal or lever connector from the OEM harness.

Action

Short circuit on one connector pin-to-pin check:

  • Measure the resistance between the accelerator pedal or lever position SIGNAL pin of the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B, and C.

See the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the accelerator pedal or lever idle validation switch circuit.

Guided Step 3A - Inspect the engine harness and ECM connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and the accelerator pedal or lever idle validation switch pins in ECM connector A for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the accelerator pedal or lever idle validation switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Measure the resistance between the accelerator pedal or lever idle validation switch SIGNAL pin and accelerator pedal or lever RETURN pin at the ECM connector A of the engine harness.

See the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms (released) [Less than 125 ohms (depressed)]?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check the accelerator pedal or lever idle validation switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever connector from the OEM harness.

Action

Measure the resistance between the accelerator pedal or lever idle validation switch SIGNAL pin and accelerator pedal or lever RETURN pin at the accelerator pedal or lever connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms (released) [Less than 125 ohms (depressed)]?
YES NO

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-043 in the Associated Procedures Table. Refer to Procedure 019-071 in Section 19.

Replace the accelerator pedal or lever assembly. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 3D - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 5972 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 5974 - Tachograph Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Tachograph Circuit | Refer to Procedure 019-325 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5974 inactive?
STEP 2. | Check the Tachograph circuit. |
 | STEP 2A. Inspect the Tachograph connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open or a short circuit in the Tachograph. | Within the Original Equipment Manufacturer(OEM) Specification?
 | STEP 2C. Check for a short circuit to ground in the Tachograph. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM), engine harness and OEM harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5974 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5974 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Tachograph circuit.

Guided Step 2A - Inspect the Tachograph connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Tachograph connector from the OEM harness.

Action

Inspect the OEM harness and Tachograph connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open or a short circuit in the Tachograph.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Tachograph from the OEM harness.

Action

Check for an open or a short circuit in the Tachograph.

  • Measure the Tachograph resistance on the Tachograph connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Within the Original Equipment Manufacturer (OEM) Specification?
YES NO
No Repair

Replace the Tachograph. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the Tachograph.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Tachograph from the OEM harness.

Action

Check for a short circuit to ground in the Tachograph.

  • Measure the resistance between the Tachograph (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Tachograph. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM), engine harness and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Tachograph from the OEM harness.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between the Tachograph POWER SUPPLY pin at the OEM harness Tachograph connector and the Tachograph POWER SUPPLY pin in keyswitch circuit.
  • Measure the resistance between the Tachograph SIGNAL pin at the OEM harness Tachograph connector and the Tachograph SIGNAL pin in the engine harness ECM connector A.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness andengine harness to determinewhich contains the open circuit.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Tachograph from the OEM harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness and/or OEM harness.

  • Measure the resistance between the Tachograph SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness andengine harness to determinewhich contains the short circuit.

Repair or replace the engine harness and/or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5974 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 5977 - Fan Drive Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5977 inactive?
STEP 2. | Check the Fan Relay circuit. |
 | STEP 2A. Inspect the Fan Relay pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open or a short circuit in the Fan Relay. | Within the Original Equipment Manufacturer (OEM) Specification?
 | STEP 2C. Check for a short circuit to ground in the Fan Relay. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM), engine harness and OEM harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5977 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5977 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Fan Relay circuit.

Guided Step 2A - Inspect the Fan Relay pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the Fan Relay.

Action

Inspect the OEM harness and Fan Relay pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open or a short circuit in the Fan Relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Fan Relay from the OEM harness.

Action

Check for an open or a short circuit in the Fan Relay.

  • Measure the Fan Relay resistance on the Fan Relay.

See the circuit diagram or wiring diagram for Relay pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Within the Original Equipment Manufacturer (OEM) Specification?
YES NO
No Repair

Replace the Fan Relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the Fan Relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Fan Relay from the OEM harness.

Action

Check for a short circuit to ground in the Fan Relay.

  • Measure the resistance between the Fan Relay (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Fan Relay.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM), engine harness and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Fan Relay from the OEM harness.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between the Fan Relay POWER SUPPLY pin at the OEM harness Fan Relay pin and the Fan Relay POWER SUPPLY pin on Keyswitch.
  • Measure the resistance between the Fan Relay SIGNAL pin at the OEM harness Fan Relay pin and the Fan Relay SIGNAL pin in the engine harness ECM connector A.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Fan Relay from the OEM harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness and/or OEM harness.

  • Measure the resistance between the Fan Relay SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5977 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 5978 - Fan 2 Drive Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5978 inactive?
STEP 2. | Check the Fan 2 Relay circuit. |
 | STEP 2A. Inspect the Fan 2 Relay pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open or a short circuit in the Fan 2 Relay. | Within the Original Equipment Manufacturer (OEM) Specification?
 | STEP 2C. Check for a short circuit to ground in the Fan 2 Relay. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM), engine harness and OEM harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5978 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5978 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Fan 2 Relay circuit.

Guided Step 2A - Inspect the Fan 2 Relay pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the Fan 2 Relay.

Action

Inspect the OEM harness and Fan 2 Relay pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open or a short circuit in the Fan 2 Relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Fan Relay 2 from the OEM harness.

Action

Check for a short circuit in the Fan 2 Relay.

  • Measure the Fan 2 Relay resistance on the Fan 2 Relay.

See the circuit diagram or wiring diagram for Relay pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Within the Original Equipment Manufacturer (OEM) Specification?
YES NO
No Repair

Replace the Fan 2 Relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the Fan 2 Relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Fan 2 Relay from the OEM harness.

Action

Check for a short circuit to ground in the Fan 2 Relay.

  • Measure the resistance between the Fan 2 Relay (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Fan 2 Relay. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM), engine harness and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Fan 2 Relay from the OEM harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between the Fan 2 Relay POWER SUPPLY pin at the OEM harness Fan 2 Relay pin and the Fan 2 Relay POWER SUPPLY pin on Keyswitch.
  • Measure the resistance between the Fan 2 Relay SIGNAL pin at the OEM harness Fan 2 Relay pin and the Fan 2 Relay SIGNAL pin in the engine harness ECM connector B.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness and/or OEM harness.

Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Fan 2 Relay from the OEM harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness and/or OEM harness.

  • Measure the resistance between the Fan 2 Relay SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness and/or OEM harness.

Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5978 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Aug-2015


FAULT CODE 5982 - Malfunction Indicator Lamp Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5982 inactive?
STEP 2. | Check the Malfunction Indicator Lamp circuit. |
 | STEP 2A. Inspect the Malfunction Indicator Lamp pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open or a short circuit in the Malfunction Indicator Lamp. | Within the Original Equipment Manufacturer (OEM) Specification?
 | STEP 2C. Check for a short circuit to ground in the Malfunction Indicator Lamp. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM), engine harness and OEM harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5982 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5982 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Malfunction Indicator Lamp circuit.

Guided Step 2A - Inspect the Malfunction Indicator Lamp pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the Malfunction Indicator Lamp.

Action

Inspect the OEM harness and Malfunction Indicator Lamp pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open or a short circuit in the Malfunction Indicator Lamp.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Malfunction Indicator Lamp from the OEM harness.

Action

Check for an open or a short circuit in the Malfunction Indicator Lamp.

  • Measure the Malfunction Indicator Lamp resistance on the Malfunction Indicator Lamp.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Within the Original Equipment Manufacturer (OEM) Specification?
YES NO
No Repair

Replace the Malfunction Indicator Lamp. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the Malfunction Indicator Lamp.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Malfunction Indicator Lamp from the OEM harness.

Action

Check for a short circuit to ground in the Malfunction Indicator Lamp.

  • Measure the resistance between the Malfunction Indicator Lamp (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Malfunction Indicator Lamp. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM), engine harness and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Malfunction Indicator Lamp from the OEM harness.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between the Malfunction Indicator Lamp POWER SUPPLY pin at the OEM harness Malfunction Indicator Lamp pin and the Malfunction Indicator Lamp POWER SUPPLY pin in Keyswitch circuit.
  • Measure the resistance between the Malfunction Indicator Lamp SIGNAL pin at the OEM harness Malfunction Indicator Lamp pin and the Malfunction Indicator Lamp SIGNAL pin in the engine harness ECM connector A.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Malfunction Indicator Lamp from the OEM harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness and/or OEM harness.

  • Measure the resistance between the Malfunction Indicator Lamp SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5982 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 5984 - Maintenance Lamp Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5984 inactive?
STEP 2. | Check the Maintenance Lamp circuit. |
 | STEP 2A. Inspect the Maintenance Lamp pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open or a short circuit in the Maintenance Lamp. | Within the Original Equipment Manufacturer (OEM) Specification?
 | STEP 2C. Check for a short circuit to ground in the Maintenance Lamp. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM), engine harness and OEM harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5984 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5984 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Maintenance Lamp circuit.

Guided Step 2A - Inspect the Maintenance Lamp pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the Maintenance Lamp.

Action

Inspect the OEM harness and Maintenance Lamp pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open or a short circuit in the Maintenance Lamp.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Maintenance Lamp from the OEM harness.

Action

Check for an open or a short circuit in the Maintenance Lamp.

  • Measure the Maintenance Lamp resistance on the Maintenance Lamp.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Within the Original Equipment Manufacturer (OEM) Specification?
YES NO
No Repair

Replace the Maintenance Lamp. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the Maintenance Lamp.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Maintenance Lamp from the OEM harness.

Action

Check for a short circuit to ground in the Maintenance Lamp.

  • Measure the resistance between the Maintenance Lamp (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Maintenance Lamp.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM), engine harness and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Maintenance Lamp from the OEM harness.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between the Maintenance Lamp POWER SUPPLY pin at the OEM harness Maintenance Lamp pin and the Maintenance Lamp POWER SUPPLY pin in Keyswitch circuit.
  • Measure the resistance between the Maintenance Lamp SIGNAL pin at the OEM harness Maintenance Lamp pin and the Maintenance Lamp SIGNAL pin in the engine harness ECM connector A.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Maintenance Lamp from the OEM harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness and/or OEM harness.

  • Measure the resistance between the Maintenance Lamp SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness and/or OEM harness.

Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5984 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 5985 - Red Stop Lamp Driver Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5985 inactive?
STEP 2. | Check the Red Stop Lamp circuit. |
 | STEP 2A. Inspect the Red Stop Lamp pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open or a short circuit in the Red Stop Lamp. | Within the Original Equipment Manufacturer (OEM) Specification?
 | STEP 2C. Check for a short circuit to ground in the Red Stop Lamp. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM), engine harness and OEM harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5985 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5985 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Red Stop Lamp circuit.

Guided Step 2A - Inspect the Red Stop Lamp pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the Red Stop Lamp.

Action

Inspect the OEM harness and Red Stop Lamp pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open or a short circuit in the Red Stop Lamp.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Red Stop Lamp from the OEM harness.

Action

Check for a short circuit in the Red Stop Lamp.

  • Measure the Red Stop Lamp resistance on the Red Stop Lamp.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Within the Original Equipment Manufacturer (OEM) Specification?
YES NO
No Repair

Replace the Red Stop Lamp. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the Red Stop Lamp.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Red Stop Lamp from the OEM harness.

Action

Check for a short circuit to ground in the Red Stop Lamp.

  • Measure the resistance between the Red Stop Lamp (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Red Stop Lamp.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM), engine harness and OEM harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the engine harness and ECM connector A pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector A or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Red Stop Lamp from the OEM harness.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between the Red Stop Lamp POWER SUPPLY pin at the OEM harness Red Stop Lamp pin and the Red Stop Lamp POWER SUPPLY pin in Keyswitch circuit.
  • Measure the resistance between the Red Stop Lamp SIGNAL pin at the OEM harness Red Stop Lamp pin and the Red Stop Lamp SIGNAL pin in the engine harness ECM connector A.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness and/or OEM harness.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Red Stop Lamp from the OEM harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness and/or OEM harness.

  • Measure the resistance between the Red Stop Lamp SIGNAL pin in the engine harness ECM connector A and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness and/or OEM harness.

Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the engine harness and/or OEM harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5985 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Aug-2015


FAULT CODE 5986 - Engine Coolant Temperature - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 G CMOH6.0 B125 | 4383640
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are the Fault Codes related to the cooling fan?
STEP 2. | Monitor coolant temperature reading. |
 | STEP 2A. Monitor coolant temperature reading. | Temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 3. | Check the coolant system components. |
 | STEP 3A. Check for faulty coolant thermostat. | Coolant thermostat faulty?
 | STEP 3B. Check for cooling fan controls. | Does the cooling fan run continuously?
 | STEP 3C. Check for the winterfronts or shutters. | Is cold weather radiator cover or winterfront open？
 | STEP 3D. Check for an inactive fault code. | Fault Code 5986 inactive?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for other active fault codes related to the cooling fan.

  • Use Toolkit electronic service tool to read the fault codes.

Are the Fault Codes related to the cooling fan?
YES | NO
No Repair | No Repair

Troubleshooting the active fault codes related to the cooling fan.

Go to 2A

Guided Step 2 - Monitor coolant temperature reading.

Guided Step 2A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use Toolkit electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the coolant system components.

Guided Step 3A - Check for faulty coolant thermostat.

Conditions

  • Turn keyswitch OFF.

Action

Check the coolant thermostat.

  • Refer to Procedure 008-013 in the Associated Procedures Table.

Coolant thermostat faulty?
YES NO

Replace the Engine Coolant thermostat.

Refer to Procedure 008-013 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for cooling fan controls.

Conditions

  • Turn keyswitch ON.

Action

Check the cooling fan operation.

Does the cooling fan run continuously?
YES NO

There is a circuit issue with the Original Equipment Manufacturer (OEM) electric relay or OEM harness short circuit.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for the winterfronts or shutters.

Conditions

  • Turn keyswitch OFF.

Action

Check for the winterfronts or shutters in cold weather.

Is cold weather radiator cover or winterfront open?
YES NO

Close the cold weather radiator cover or the winterfront.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.
  • Start the engine and run the engine at idle.

Action

Run the engine at least 5 minutes and make sure the coolant temperature is higher than 80℃.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5986 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 5987 - Driver's Demand Engine - Percent Torque - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault codes. | Fault Code 131, 132, 5969, 5971, 5972 or 771 active?
STEP 2. | Check the Brake Switch and circuit. |
 | STEP 2A. Inspect the Brake Switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the functionality for Brake Switch. | Brake Switch function well?
STEP 3. | Check the Accelerator Pedal and circuit. |
 | STEP 3A. Inspect the Accelerator Pedal and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the functionality for Accelerator Pedal. | Accelerator Pedal function well?
STEP 4. | Check the fault codes. |
 | STEP 4A. Check for an inactive fault code. | Fault Code 5987 active?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 131, 132, 5969, 5971, 5972 or 771 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Check the Brake Switch and circuit.

Guided Step 2A - Inspect the Brake Switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Brake Switch from the OEM harness.

Action

Inspect the OEM harness and switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the functionality for Brake Switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Brake Switch from the OEM harness.

Action

Check the functionality for Brake Switch.

See equipment manufacturer service information.

Brake Switch function well?
YES NO
No Repair

Brake Switch is not working well.

Readjust or replace the Brake Switch. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the Accelerator Pedal and circuit.

Guided Step 3A - Inspect the Accelerator Pedal and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Accelerator Pedal from the OEM harness.

Action

Inspect the OEM harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the functionality for Accelerator Pedal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Accelerator Pedal from the OEM harness.

Action

Check the functionality for Accelerator Pedal.

See equipment manufacturer service information.

Accelerator Pedal function well?
YES NO
No Repair

Accelerator Pedal is not working well.

Readjust or replace the Accelerator Pedal. See equipment manufacturer service information.

Go to 4A

Go to 5A

Guided Step 4 - Check the fault codes.

Guided Step 4A - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5987 active?
YES NO

Troubleshooting procedures need to be repeated from the beginning.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Aug-2015


FAULT CODE 5988 - Engine Override Control Mode - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault codes. | Fault Code 771, 6137 or 6138?
STEP 2. | Check the Brake Switch and circuit. |
 | STEP 2A. Inspect the Brake Switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the functionality for Brake Switch. | Brake Switch function well?
STEP 3. | Check the fault codes. |
 | STEP 3A. Check for an inactive fault code. | Fault Code 5988 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions(SID) file and/or wapp file update for this faultcode is available, does the ECM contain thatrevisions or higher?
 | STEP 4B. Disable the fault code. | Greater than 100k ohms?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 771, 6137 or 6138?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Check the Brake Switch and circuit.

Guided Step 2A - Inspect the Brake Switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Brake Switch from the OEM harness.

Action

Inspect the OEM harness and switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the functionality for Brake Switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Brake Switch from the OEM harness.

Action

Check the functionality for Brake Switch.

See equipment manufacturer service information.

Brake Switch function well?
YES NO
No Repair

Brake Switch is not working well.

Readjust or replace the Brake Switch. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the fault codes.

Guided Step 3A - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5988 active?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is an OEM transmission speed controller 1, OEM transmission speed controller 1 setup, or OEM transmission speed controller 1 to data link connection issue.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 5989 - Intake Manifold 1 Pressure - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5995 active?
 | STEP 1B. Check for active fault codes. | Are there active other fault codes about the throttle?
 | STEP 1C. Check for an inactive fault code. | Fault Code 5989 inactive?
STEP 2. | Verify the intake manifold absolute pressure and temperature sensor. |
 | STEP 2A. Verify intake manifold absolute pressure reading. | Intake manifold absolute pressure reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 3. | Check for air leaks in the air intake system. |
 | STEP 3A. Check for air leaks in the air intake system. | Air leaks?
STEP 4. | Check the engine throttle control actuator operation. |
 | STEP 4A. Check the engine throttle control actuator. | Did the actuator pass the test?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5995 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Are there active other fault codes about the throttle?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5989 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Verify the intake manifold absolute pressure and temperature sensor.

Guided Step 2A - Verify intake manifold absolute pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the intake manifold absolute pressure and temperature sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare intake manifold absolute pressure to a mechanical gauge or a known value.

Intake manifold absolute pressure reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?

YES NO
No Repair

A damaged sensor has been detected.

Repair or replace the sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for air leaks in the air intake system.

Guided Step 3A - Check for air leaks in the air intake system.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks near all gasket surfaces between the throttle actuator and where the intake meets the block. Check all pipe plugs for leaks or missing components.

  • Start the engine and let it idle.
  • Listen for air leaks while engine is operating.

Air leaks?
YES NO

Locate all damaged gaskets or components and replace accordingly.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the engine throttle control actuator operation.

Guided Step 4A - Check the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Aug-2015


FAULT CODE 5991 - Intake Manifold 1 Pressure - Data Not Rational - Drifted Low

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are there active other fault codes about the throttle?
 | STEP 1B. Check for an inactive fault code. | Fault Code 5991 inactive?
STEP 2. | Verify intake manifold absolute pressure and barometric air pressure reading. |
 | STEP 2A. Verify intake manifold absolute pressure and barometric air pressure reading. | Intake manifold absolute pressure and barometric air pressure reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 3. | Check the engine throttle control actuator operation. |
 | STEP 3A. Check the engine throttle control actuator. | Did the actuator pass the test?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.
  • Start the engine and run the engine speed from idle up to max speed.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Are there active other fault codes about the throttle?
YES | NO
No Repair | No Repair

Troubleshooting active other fault codes.
See appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.
  • Start the engine.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5991 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Verify intake manifold absolute pressure and barometric air pressure reading.

Guided Step 2A - Verify intake manifold absolute pressure and barometric air pressure reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the intake manifold absolute pressure and barometric air pressure reading.

  • Use Toolkit electronic service tool to monitor the intake manifold absolute pressure and barometric air pressure value while the engine is not running.
  • Compare intake manifold absolute pressure and barometric air pressure reading to a mechanical gauge or a known value.

Intake manifold absolute pressure and barometric air pressure reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?

YES NO
No Repair

A damaged sensor has been detected.

Repair or replace the sensor.

Refer to Procedure 019-099 in the Associated Procedures Table and/or refer to Procedure 019-004 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine throttle control actuator operation.

Guided Step 3A - Check the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Aug-2015


FAULT CODE 5992 - Intake Manifold 1 Pressure - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | B6.7 G CMOH6.0 B125 | 4383640
Gear Cover, Front | Refer to Procedure 001-031 | B6.7 G CMOH6.0 B125 | 4383640
Cylinder Head | Refer to Procedure 002-004 | B6.7 G CMOH6.0 B125 | 4383640
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
Exhaust Restriction | Refer to Procedure 011-009 | B6.7 G CMOH6.0 B125 | 4383640
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are there active other fault codes about the intake manifold absolute pressure and temperature sensor, crankshaft sensor, camshaft sensor, and engine ignition coils?
STEP 2. | Check the ignition coils and spark plugs. |
 | STEP 2A. Inspect the ignition coils and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plugs. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the Coil Extensions. | Coil extensions resistance between 1.1k and 1.7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check the engine exhaust restriction. |
 | STEP 3A. Check the engine exhaust restriction. | Within the specification?
STEP 4. | Check the engine intake valves. |
 | STEP 4A. Check the overhead set. | Overhead is set correctly?
 | STEP 4B. Check the intake valve for leakage. | Any leakage was found at all of the intake valves?
STEP 5. | Check for correct engine static timing. |
 | STEP 5A. Check static timing. | Camshaft and crankshaft gears properly installed?
 | STEP 5B. Inspect the gear train. | Damage found?
STEP 6. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Are there active other fault codes about the intake manifold absolute pressure and temperature sensor, crankshaft sensor, camshaft sensor, and engine ignition coils?

YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the ignition coils and spark plugs.

Guided Step 2A - Inspect the ignition coils and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect coil pack 1 to 6 from the engine harness.

Action

Inspect the engine harness and ignition coil connector pins of the cylinders 1 to 6 for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plugs.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinders 1 to 6 spark plugs.

Action

Inspect the spark plugs for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2C

Guided Step 2C - Check the Coil Extensions.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinders 1 to 6 spark plugs.
  • Remove the cylinders 1 to 6 coil extensions from the coils.

Action

Check the coil extensions resistances.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Coil extensions resistance between 1.1k and 1.7k ohms?
YES NO
No Repair

A damaged coil extensions has been detected.

Replace the coil extensions. Refer to Procedure 013-050 in the Associated Procedures Table.

Go to 2D

Go to 6A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Turn keyswitch ON.

Action

Check the ignition coils of cylinders 1 to 6.

  • Test the cylinder 1 to 6 coils to determine if the plug is receiving voltage.
  • Use the ignition coil test kit, Part Number 4918343, to observe the spark in the observation window.

Refer to Procedure 013-012 in the Associated Procedures Table.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the engine exhaust restriction.

Guided Step 3A - Check the engine exhaust restriction.

Conditions

  • Turn keyswitch OFF.
  • Install a pressure gauge. Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Operate the engine at rated speed and load and read the exhaust restriction.

Refer to Procedure 011-009 in the Associated Procedures Table.

Within the specification?
YES NO
No Repair

A higher exhaust restriction was found.

Repair and replace the damaged component.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine intake valves.

Guided Step 4A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-004 in the Associated Procedures Table.

Action

Inspect the overhead set for all cylinders.

Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead is set correctly?
YES NO
No Repair

Readjust the overhead.

Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 4B

Go to 6A

Guided Step 4B - Check the intake valve for leakage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

Action

Inspect the intake valve for leakage for all cylinders.

Refer to Procedure 002-004 in the Associated Procedures Table.

Any leakage was found at all of the intake valves?
YES NO
No Repair

A damaged intake valve was detected.

Replace the damaged intake valve.

Refer to Procedure 002-004 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 5 - Check for correct engine static timing.

Guided Step 5A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove the gear cover. Refer to Procedure 001-031 in the Associated Procedures Table.
  • Rotate the engine to Top Dead Center (TDC) for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned.
  • Use the following procedure. Refer to Procedure 001-008 in the Associated Procedures Table.

Action

Inspect the engine static timing.

Camshaft and crankshaft gears properly installed?
YES NO
No Repair

Install the camshaft and crankshaft gear correctly.

Go to 5B

Go to 6A

Guided Step 5B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the gear cover.

Refer to Procedure 001-031 in the Associated Procedures Table.

Inspect the gear train for damage that would lead to slippage.

Damage found?
YES NO

  • Repair the damaged components.
  • See the appropriate service manual for repair procedure.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 5993 - Engine Intake Air Pressure - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5993 inactive?
 | STEP 1B. Check for active fault codes. | Are there active other fault codes about the throttle, intake manifold absolute pressure and temperature sensor, and engine intake air pressure sensor?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5993 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Are there active other fault codes about the throttle, intake manifold absolute pressure and temperature sensor, and engine intake air pressure sensor?

YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Aug-2015


FAULT CODE 5994 - Engine Intake Air Pressure - Data Not Rational - Drifted Low

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5994 inactive?
 | STEP 1B. Check for active fault codes. | Are there active other fault codes about the throttle, intake manifold absolute pressure and temperature sensor, and engine intake air pressure sensor?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5994 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Are there active other fault codes about the throttle, intake manifold absolute pressure and temperature sensor, and engine intake air pressure sensor?

YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Aug-2015


FAULT CODE 5995 - Engine Intake Air Pressure - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640
Engine Throttle Intake Pressure Sensor | Refer to Procedure 019-470 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5995 active?
STEP 2. | Check the Intake Manifold Absolute Pressure and Temperature Sensor and Engine Intake Air Pressure sensor. |
 | STEP 2A. Inspect the Intake Manifold Absolute Pressure and Temperature Sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the Engine Intake Air Pressure sensor and connector pins. | Dirty or damaged pins?
STEP 3. | Verify Intake Manifold Absolute Pressure and Temperature Sensor and Engine Intake Air Pressure sensor with Barometric Pressure Sensor. |
 | STEP 3A. Verify Intake Manifold Absolute Pressure and Engine Intake Air Pressure reading. | Toolkit electronic service tool pressure reading within 4 kPa?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine at least 1 minute.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 5995 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19 for an inactive or intermittent fault code.

Guided Step 2 - Check the Intake Manifold Absolute Pressure and Temperature Sensor and Engine Intake Air Pressure sensor.

Guided Step 2A - Inspect the Intake Manifold Absolute Pressure and Temperature Sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Intake Manifold Absolute Pressure and Temperature Sensor from the engine harness.

Action

Inspect the engine harness and Intake Manifold Absolute Pressure and Temperature Sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the Engine Intake Air Pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Intake Air Pressure sensor from the engine harness.

Action

Inspect the engine harness and Engine Intake Air Pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Verify Intake Manifold Absolute Pressure and Temperature Sensor and Engine Intake Air Pressure sensor with Barometric Pressure Sensor.

Guided Step 3A - Verify Intake Manifold Absolute Pressure and Engine Intake Air Pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor and compare Intake Manifold Absolute Pressure and Engine Intake Air Pressure with barometric pressure sensor reading.

  • Use Toolkit electronic service tool to monitor the Intake Manifold Absolute Pressure, Engine Intake Air Pressure and Barometric Air Pressure value while the engine is not running.

Toolkit electronic service tool pressure reading within 4 kPa?
YES NO
No Repair

A damaged sensor has been detected.

Replace the Intake Manifold Absolute Pressure and Temperature Sensor or the Engine Intake Air Pressure sensor.

Refer to Procedure 019-099 in the Associated Procedures Table or Refer to Procedure 019-470 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 5996 - Engine Fuel Valve 2 Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
High Pressure Regulator, NG | Refer to Procedure 005-061 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5996 active?
STEP 2. | Check the Engine Gas Temperature/Pressure Sensor and circuit. |
 | STEP 2A. Inspect the Engine Gas Temperature/Pressure Sensor circuit and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify the Engine Gas Temperature/Pressure Sensor pressure reading. | Fuel pressure within 5 percent?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5996 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Engine Gas Temperature/Pressure Sensor and circuit.

Guided Step 2A - Inspect the Engine Gas Temperature/Pressure Sensor circuit and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine gas temperature/pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Verify the Engine Gas Temperature/Pressure Sensor pressure reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in Toolkit electronic service tool.
  • Engine gas temperature/pressure sensor pressure reading is displayed in Toolkit electronic service tool.

Fuel pressure within 5 percent?
YES NO

An Original Equipment Manufacturer (OEM) fuel delivery issue has been detected.

Troubleshoot the OEM fuel system. See equipment manufacturer service information.

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Sep-2015


FAULT CODE 5997 - Engine Fuel Valve 2 Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve (FSOV), NG | Refer to Procedure 005-044 | B6.7 G CMOH6.0 B125 | 4383640
High Pressure Regulator, NG | Refer to Procedure 005-061 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/ Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5997 active?
STEP 2. | Check the fuel tank pressure or level, check the fuel system connections for leaks. |
 | STEP 2A. Check the fuel tank pressure or level. | Fuel tank pressure or level low?
 | STEP 2B. Check the fuel system connections from fuel tank to fuel metering valve for leaks. | Fuel leaks?
STEP 3. | Check the engine gas temperature/pressure sensor and circuit. |
 | STEP 3A. Inspect the engine gas temperature/pressure sensor circuit and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify the engine gas temperature/pressure sensor pressure reading. | Fuel pressure within 5 percent?
STEP 4. | Check the engine fuel system components. |
 | STEP 4A. Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend. | Any blocks and sharp bend?
 | STEP 4B. Check fuel filter for oil and clogging. | Evidence of oil and the fuel filter clogging?
 | STEP 4C. Inspect the engine low pressure fuel shutoff valve. | Damaged engine low pressure fuel shutoff valve or missing hardware?
 | STEP 4D. Inspect the engine high pressure regulator. | Missing or damaged components?
 | STEP 4E. Check injectors for leaks. | Fuel leaks?
STEP 5. | Check Engine Control Module (ECM) calibration and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5997 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19 for an inactive or intermittent fault code.

Guided Step 2 - Check the fuel tank pressure or level, check the fuel system connections for leaks.

Guided Step 2A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the Original Equipment Manufacturer (OEM) pressure gauge to check the pressure or level of the fuel in the fuel tank.

Fuel tank pressure or level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. See equipment manufacturer service information.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel system connections from fuel tank to fuel metering valve for leaks.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for fuel leaks in the fuel system from fuel tank to fuel metering valve.

  • Check the fuel lines, and fuel connections for leaks.
  • Use a gas detector, Part Number 3823984, or soap solution to check for leaks.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine gas temperature/pressure sensor and circuit.

Guided Step 3A - Inspect the engine gas temperature/pressure sensor circuit and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine gas temperature/pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Verify the engine gas temperature/pressure sensor pressure reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in Toolkit electronic service tool.
  • Engine gas temperature/pressure sensor pressure reading is displayed in Toolkit electronic service tool.

Fuel pressure within 5 percent?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine fuel system components.

Guided Step 4A - Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Any blocks and sharp bend?
YES NO

A blocked or sharp bend fuel line has been detected in the fuel system. Repair or replace the blocked or sharp bend fuel line.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check fuel filter for oil and clogging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the fuel filter and check the fuel filter for oil in and clogging.

Refer to Procedure 006-015 in the Associated Procedures Table.

NOTE: Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil and the fuel filter clogging?
YES NO

Replace the fuel filter.

Refer to Procedure 006-015 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Inspect the engine low pressure fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine low pressure fuel shut off valve. Refer to Procedure 005-044 in the Associated Procedures Table.

Action

Inspect the engine low pressure fuel shutoff valve for restrictions and damage.

Refer to Procedure 005-044 in the Associated Procedures Table.

Damaged engine low pressure fuel shutoff valve or missing hardware?
YES NO

  • Replace the engine fuel shutoff valve. Refer to Procedure 005-044 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Inspect the engine high pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine high pressure regulator. See equipment manufacturer service information for the specific removal and installation requirements.

Action

Inspect the engine high pressure regulator and manifold air pressure bias line.

  • Refer to Procedure 005-061 in the Associated Procedures Table, or see equipment manufacturer service information.

Missing or damaged components?
YES NO

Repair or replace the missing or damaged components.

See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check injectors for leaks.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Check injectors for leaks.

  • Refer to Procedure 005-242 in the Associated Procedures Table.

Fuel leaks?
YES NO

Perform the injector cleaning procedure to clean the injectors. Use Toolkit electronic service tool to perform the injector cleaning process, if fuel still leak after cleaning the injectors, Replace the damage injectors.

Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear the fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 5998 - Engine Fuel Valve 2 Intake Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
High Pressure Regulator, NG | Refer to Procedure 005-061 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5998 active?
STEP 2. | Check the Engine Gas Temperature/Pressure Sensor and circuit. |
 | STEP 2A. Inspect the Engine Gas Temperature/Pressure Sensor circuit and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify the Engine Gas Temperature/Pressure Sensor pressure reading. | Fuel pressure within 5 percent?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5998 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19 for an inactive or intermittent fault code.

Guided Step 2 - Check the Engine Gas Temperature/Pressure Sensor and circuit.

Guided Step 2A - Inspect the Engine Gas Temperature/Pressure Sensor circuit and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine gas temperature/pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for component pin identification.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Verify the Engine Gas Temperature/Pressure Sensor pressure reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in Toolkit electronic service tool.
  • Engine gas temperature/pressure sensor pressure reading is displayed in Toolkit electronic service tool.

Fuel pressure within 5 percent?
YES NO

An Original Equipment Manufacturer (OEM) fuel delivery issue has been detected.

Troubleshoot the OEM fuel system. See equipment manufacturer service information.

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Sep-2015


FAULT CODE 5999 - Engine Fuel Valve 2 Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve (FSOV), NG | Refer to Procedure 005-044 | B6.7 G CMOH6.0 B125 | 4383640
High Pressure Regulator, NG | Refer to Procedure 005-061 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5999 active?
STEP 2. | Check the fuel tank pressure or level, check the fuel system connections for leaks. |
 | STEP 2A. Check the fuel tank pressure or level. | Fuel tank pressure or level low?
 | STEP 2B. Check the fuel system connections from fuel tank to fuel metering valve for leaks. | Fuel leaks?
STEP 3. | Check the Engine Gas Temperature /Pressure Sensor. |
 | STEP 3A. Inspect the Engine Gas Temperature /Pressure Sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify the Engine Gas Temperature/Pressure Sensor pressure reading. | Fuel pressure within 5 percent?
STEP 4. | Check the engine fuel system components. |
 | STEP 4A. Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend. | Any blocks and sharp bend?
 | STEP 4B. Inspect the engine low pressure fuel shutoff valve. | Damaged engine low pressure fuel shutoff valve or missing hardware?
 | STEP 4C. Inspect the engine high pressure regulator. | Missing or damaged components?
 | STEP 4D. Check fuel filter for oil and clogging. | Evidence of oil and the fuel filter clogging?
STEP 5. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 5999 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19 for an inactive or intermittent fault code.

Guided Step 2 - Check the fuel tank pressure or level, check the fuel system connections for leaks.

Guided Step 2A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the Original Equipment Manufacturer (OEM) pressure gauge to check the pressure or level of the fuel in the fuel tank.

Fuel tank pressure or level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. See equipment manufacturer service information.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel system connections from fuel tank to fuel metering valve for leaks.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for fuel leaks in the fuel system from fuel tank to fuel metering valve.

  • Check the fuel lines, and fuel connections for leaks.
  • Use a gas detector, Part Number 3823984, or soap solution to check for leaks.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the Engine Gas Temperature /Pressure Sensor.

Guided Step 3A - Inspect the Engine Gas Temperature /Pressure Sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine gas temperature /pressure sensor.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Verify the Engine Gas Temperature/Pressure Sensor pressure reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in Toolkit electronic service tool.

Engine gas temperature/pressure sensor pressure reading is displayed in Toolkit electronic service tool.

Fuel pressure within 5 percent?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine fuel system components.

Guided Step 4A - Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Any blocks and sharp bend?
YES NO

A blocked or sharp bend fuel line has been detected in the fuel system. Repair or replace the blocked or sharp bend fuel line.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the engine low pressure fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine low pressure fuel shut off valve. Refer to Procedure 005-044 in the Associated Procedures Table.

Action

Inspect the engine low pressure fuel shutoff valve for restrictions and damage.

  • Refer to Procedure 005-044 in the Associated Procedures Table.

Damaged engine low pressure fuel shutoff valve or missing hardware?
YES NO

  • Replace the engine fuel shutoff valve. Refer to Procedure 005-044 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Inspect the engine high pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine high pressure regulator. See equipment manufacturer service information for the specific removal and installation requirements.

Action

Inspect the engine high pressure regulator.

  • Refer to Procedure 005-061 in the Associated Procedures Table, or see equipment manufacturer service information.

Missing or damaged components?
YES NO

Repair or replace the missing or damaged components.

See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check fuel filter for oil and clogging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the fuel filter and check the fuel filter for oil in and clogging.

Refer to Procedure 006-015 in the Associated Procedures Table.

NOTE: Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil and the fuel filter clogging?
YES NO

Replace the fuel filter.

Refer to Procedure 006-015 in the Associated Procedures Table.

An OEM fuel delivery issue has been detected.

Troubleshoot the OEM fuel system. See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 5 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Sep-2015


FAULT CODE 6111 - Engine Fuel Leakage 2 - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Shutoff Valve (FSOV), NG | Refer to Procedure 005-044 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6111 active?
STEP 2. | Check the engine fuel system for leaks. |
 | STEP 2A. Check the fuel system connections from fuel tank to fuel metering valve for leaks. | Fuel leaks?
STEP 3. | Check Engine Control Module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6111 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel system for leaks.

Guided Step 2A - Check the fuel system connections from fuel tank to fuel metering valve for leaks.

Conditions

  • Turn keyswitch ON.

Action

Check for fuel leaks in the fuel system from fuel tank to fuel metering valve.

  • Check the fuel lines and fuel connections for leaks.
  • Use a gas detector, Part Number 3823984, or soap solution to check for leaks.
  • Check the injectors and fuel shutoff valve for leaks.

Refer to Procedure 005-242 in the Associated Procedures Table. Refer to Procedure 005-044 in the Associated Procedures Table.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Turn the key to the OFF position, and repair leaks immediately. Repair or replace the leaking component.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear the fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 6112 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6215, 6217, or 6225 active?
STEP 2. | Check the oxygen (or exhaust gas) sensor and circuit. |
 | STEP 2A. Inspect the oxygen (or exhaust gas) sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6112 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6215, 6217, or 6225 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Check the oxygen (or exhaust gas) sensor and circuit.

Guided Step 2A - Inspect the oxygen (or exhaust gas) sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor connector from the engine harness.

Action

Inspect the engine harness and oxygen (or exhaust gas) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor pumping current SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor pumping current SIGNAL pin in the engine harness ECM connector B.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor pumping current SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6112 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

If the Fault Code 6112 is still active after replacing the oxygen (or exhaust gas) sensor, replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 6113 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 6113 inactive?
STEP 2. | Check the oxygen (or exhaust gas) sensor and circuit. |
 | STEP 2A. Inspect the oxygen (or exhaust gas) sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6113 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6113 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oxygen (or exhaust gas) sensor and circuit.

Guided Step 2A - Inspect the oxygen (or exhaust gas) sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor connector from the engine harness.

Action

Inspect the engine harness and oxygen (or exhaust gas) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6113 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

If the Fault Code 6112 is still active after replacing the oxygen (or exhaust gas) sensor, replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 6114 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6114 inactive?
STEP 2. | Check the oxygen (or exhaust gas) sensor and circuit. |
 | STEP 2A. Inspect the oxygen (or exhaust gas) sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short or open circuit in the oxygen (or exhaust gas) sensor circuit. | Between 30 to 300 ohms?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 6114 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6114 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oxygen (or exhaust gas) sensor and circuit.

Guided Step 2A - Inspect the oxygen (or exhaust gas) sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor connector from the engine harness.

Action

Inspect the engine harness and oxygen (or exhaust gas) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short or open circuit in the oxygen (or exhaust gas) sensor circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.

Action

Check for a short or open circuit in the oxygen (or exhaust gas) sensor trim resistor.

  • Measure the cold resistance between the RETURN pin and engine actual exhaust oxygen SIGNAL pin on the oxygen (or exhaust gas) sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 30 to 300 ohms?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6114 inactive?
YES NO
No Repair

A damaged ECM has been detected.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 6115 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 6112, 6113, 6114, 6118, 6119, 6121, 6215, 6216, 6217, 6218, 6219, or 6225 active?
STEP 2. | Manual calibrate the oxygen (or exhaust gas) sensor. |
 | STEP 2A. Manual calibrate the oxygen (or exhaust gas) sensor. | Fault Code 6115 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Codes 6112, 6113, 6114, 6118, 6119, 6121, 6215, 6216, 6217, 6218, 6219, or 6225 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Manual calibrate the oxygen (or exhaust gas) sensor.

Guided Step 2A - Manual calibrate the oxygen (or exhaust gas) sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the correction factor. If the value is greater than 1.1, perform the manual burn off first. And then perform the manual calibrate to the oxygen (or exhaust gas) sensor.

  • Use Toolkit electronic service tool to perform the manual burn off and manual air calibration to oxygen (or exhaust gas) sensor.
  • Refer to Procedure 019-100 in the Associated Procedures Table.

Fault Code 6115 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Aug-2015


FAULT CODE 6116 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 6112, 6113, 6114, 6115, 6118, 6119, 6121, 6215, 6216, 6217, 6218, 6219, or 6225 active?
STEP 2. | Manual calibrate the oxygen (or exhaust gas) sensor. |
 | STEP 2A. Manual calibrate the oxygen (or exhaust gas) sensor. | Fault Code 6116 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Codes 6112, 6113, 6114, 6115, 6118, 6119, 6121, 6215, 6216, 6217, 6218, 6219, or 6225 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Manual calibrate the oxygen (or exhaust gas) sensor.

Guided Step 2A - Manual calibrate the oxygen (or exhaust gas) sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the manual calibrate to the oxygen (or exhaust gas) sensor.

  • Use Toolkit electronic service tool to perform the manual air calibration to oxygen (or exhaust gas) sensor.
  • Refer to Procedure 019-100 in the Associated Procedures Table.

Fault Code 6116 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Aug-2015


FAULT CODE 6117 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 6112, 6113, 6114, 6115, 6118, 6119, 6121, 6215, 6216, 6217, 6218, 6219, or 6225 active?
STEP 2. | Manual calibrate the oxygen (or exhaust gas) sensor. |
 | STEP 2A. Manual calibrate the oxygen (or exhaust gas) sensor. | Fault Code 6117 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Codes 6112, 6113, 6114, 6115, 6118, 6119, 6121, 6215, 6216, 6217, 6218, 6219, or 6225 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Manual calibrate the oxygen (or exhaust gas) sensor.

Guided Step 2A - Manual calibrate the oxygen (or exhaust gas) sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Read the correction factor. If the value is greater than 1.1, perform the manual burn off first. And then perform the manual calibrate to the oxygen (or exhaust gas) sensor.

  • Use Toolkit electronic service tool to perform the manual burn off and manual air calibration to oxygen (or exhaust gas) sensor.
  • Refer to Procedure 019-100 in the Associated Procedures Table.

Fault Code 6117 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Aug-2015


FAULT CODE 6118 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6118 inactive?
STEP 2. | Check the oxygen (or exhaust gas) sensor and circuit. |
 | STEP 2A. Inspect the oxygen (or exhaust gas) sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to battery (+) in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6218 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6118 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oxygen (or exhaust gas) sensor and circuit.

Guided Step 2A - Inspect the oxygen (or exhaust gas) sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor connector from the engine harness.

Action

Inspect the engine harness and oxygen (or exhaust gas) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B, C, or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor pumping current SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor pumping current SIGNAL pin in the engine harness ECM connector B.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to battery (+) in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin in the engine harness ECM connector B to battery (+) terminal.
  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B to battery (+) terminal.
  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B to battery (+) terminal.
  • Measure the resistance between the oxygen (or exhaust gas) sensor pumping current SIGNAL pin in the engine harness ECM connector B to battery (+) terminal.
  • Measure the resistance between the oxygen (or exhaust gas) sensor heater control SIGNAL pin in the engine harness ECM connector C to battery (+) terminal.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short to battery (+) circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor pumping current SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor heater control SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6218 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

If the Fault Code 6218 is still active after replacing the oxygen (or exhaust gas) sensor, replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Aug-2015


FAULT CODE 6119 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6119 inactive?
STEP 2. | Check the oxygen (or exhaust gas) sensor and circuit. |
 | STEP 2A. Inspect the oxygen (or exhaust gas) sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6219 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6119 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oxygen (or exhaust gas) sensor and circuit.

Guided Step 2A - Inspect the oxygen (or exhaust gas) sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor connector from the engine harness.

Action

Inspect the engine harness and oxygen (or exhaust gas) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B, C, or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor pumping current SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor pumping current SIGNAL pin in the engine harness ECM connector B.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin in the engine harness ECM connector B to ground.
  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B to ground.
  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B to ground.
  • Measure the resistance between the oxygen (or exhaust gas) sensor pumping current SIGNAL pin in the engine harness ECM connector B to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short to ground circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen signal pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor RETURN pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor pumping current SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6219 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

If the Fault Code 6219 is still active after replacing the oxygen (or exhaust gas) sensor, replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Aug-2015


FAULT CODE 6121 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6121 inactive?
STEP 2. | Check the oxygen (or exhaust gas) sensor and circuit. |
 | STEP 2A. Inspect the oxygen (or exhaust gas) sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6121 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6121 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oxygen (or exhaust gas) sensor and circuit.

Guided Step 2A - Inspect the oxygen (or exhaust gas) sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor connector from the engine harness.

Action

Inspect the engine harness and oxygen (or exhaust gas) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B, C, or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen SIGNAL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor engine actual exhaust oxygen SIGNAL pin in the engine harness ECM connector B.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B to ground.
  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen SIGNAL pin in the engine harness ECM connector B to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short to ground circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor trim resistor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.
  • Measure the resistance between the oxygen (or exhaust gas) sensor engine actual exhaust oxygen SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6121 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

If the Fault Code 6121 is still active after replacing the oxygen (or exhaust gas) sensor, replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 6122 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 6122 inactive?
STEP 2. | Manual calibrate the oxygen (or exhaust gas) sensor. |
 | STEP 2A. Manual calibrate the oxygen (or exhaust gas) sensor. | Fault Code 6122 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Manual calibrate the oxygen (or exhaust gas) sensor.

Guided Step 2A - Manual calibrate the oxygen (or exhaust gas) sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the manual burn off first. And then perform the manual calibrate to the oxygen (or exhaust gas) sensor.

  • Use Toolkit electronic service tool to perform the manual burn off and manual air calibration to oxygen (or exhaust gas) sensor.
  • Refer to Procedure 019-100 in the Associated Procedures Table.

Fault Code 6122 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Aug-2015


FAULT CODE 6123 - Oxygen (or Exhaust Gas) Sensor Bank 2 Monitor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 6123 inactive?
STEP 2. | Manual calibrate the oxygen (or exhaust gas) sensor. |
 | STEP 2A. Manual calibrate the oxygen (or exhaust gas) sensor. | Fault Code 6123 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Manual calibrate the oxygen (or exhaust gas) sensor.

Guided Step 2A - Manual calibrate the oxygen (or exhaust gas) sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Perform the manual burn off first. And then perform the manual calibrate to the oxygen (or exhaust gas) sensor.

  • Use Toolkit electronic service tool to perform the manual burn off and manual air calibration to oxygen (or exhaust gas) sensor.
  • Refer to Procedure 019-100 in the Associated Procedures Table.

Fault Code 6123 inactive?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Aug-2015


FAULT CODE 6124 - Engine Timing Sensor - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 6124 active?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 3B. Inspect the Engine Control Module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check for an open circuit in the engine wiring harness. |
 | STEP 3C-2. Check the fault code and verify camshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for sensor supply fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6124 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine camshaft position sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear housing. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

  • Replace the sensor. If mechanical damage was observed, inspect the camshaft gear and related components.
  • Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 VDC SUPPLY pin and the camshaft position sensor RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the Engine Control Module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the ECM and engine harness connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the camshaft position sensor from the engine and measure the air gap at several points in the camshaft's revolution.

Refer to Procedure 019-363 in the Associated Procedures Table.

Is the air gap within specifications?

  • Minimum Air Gap: 0.25 mm [ 0.010 in ]
  • Maximum Air Gap: 1.27 mm [ 0.050 in ]
  • Maximum Target Runout: 0.33 mm [ 0.013 in ]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 6124 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector B and C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 VDC SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector C.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO

A damaged harness has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify camshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6124 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 6125 - Engine Position Sensor - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 6125 active?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 3B. Inspect the Engine Control Module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check for an open circuit in the engine wiring harness. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for sensor supply fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6125 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by crankshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

  • Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 VDC SUPPLY pin and the crankshaft position sensor RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the Engine Control Module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the ECM and engine harness connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector B.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector B and all other pins in the connector A, B, and C.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the crankshaft position sensor from the engine and measure the air gap at several points in the crankshaft's revolution.

Refer to Procedure 019-365 in the Associated Procedures Table.

Is the air gap within specifications?

  • Minimum Air Gap: 0.25 mm [ 0.010 in ]
  • Maximum Air Gap: 1.59 mm [ 0.063 in ]
  • Maximum Target Runout: 0.5 mm [ 0.02 in ]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 6125 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 VDC SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM connector C.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO

A damaged harness has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6125 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 6126 - Engine Timing Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | B6.7 G CMOH6.0 B125 | 4383640
Gear Cover, Front | Refer to Procedure 001-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and camshaft position sensor. |
 | STEP 1A. Inspect the camshaft tone wheel for any damage. | Damage found?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Camshaft and crankshaft gears properly installed?
 | STEP 2B. Inspect the gear train. | Damage found?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the tone wheels and camshaft position sensor.

Guided Step 1A - Inspect the camshaft tone wheel for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the camshaft tone wheels for damage.

Damage found?
YES NO

Replace the tone wheel.

Use the following procedure for camshaft removal and installation on engine.

Refer to Procedure 001-008 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check for correct engine static timing.

Guided Step 2A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove the gear cover. Refer to Procedure 001-031 in the Associated Procedures Table.
  • Rotate the engine to Top Dead Center (TDC) for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned.
  • Use the following procedure. Refer to Procedure 001-008 in the Associated Procedures Table.

Action

Inspect the engine static timing.

Camshaft and crankshaft gears properly installed?
YES NO
No Repair

Install the camshaft and crankshaft gear correctly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the gear cover.

Refer to Procedure 001-031 in the Associated Procedures Table.

Inspect the gear train for damage that would lead to slippage.

Damage found?
YES NO

  • Repair the damaged components.
  • See the appropriate service manual for repair procedure.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2015


FAULT CODE 6127 - Engine Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | B6.7 G CMOH6.0 B125 | 4383640
Gear Cover, Front | Refer to Procedure 001-031 | B6.7 G CMOH6.0 B125 | 4383640
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 G CMOH6.0 B125 | 4383640
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheels and crankshaft position sensor and camshaft position sensor. |
 | STEP 1A. Inspect the crankshaft position sensor and camshaft position sensor. | Damage found?
 | STEP 1B. Inspect the tone wheels for any damage. | Damage found?
STEP 2. | Check for correct engine static timing. |
 | STEP 2A. Check static timing. | Camshaft and crankshaft gears properly installed?
 | STEP 2B. Inspect the gear train. | Damage found?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the tone wheels and crankshaft position sensor and camshaft position sensor.

Guided Step 1A - Inspect the crankshaft position sensor and camshaft position sensor.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft position sensor and camshaft position sensor for damage.

Damage found?
YES NO

Replace the crankshaft position sensor or camshaft position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 1B

Guided Step 1B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for damage.

Damage found?
YES NO

Replace the tone wheel.

Use the following procedure for crankshaft speed indicator ring removal and installation. Refer to Procedure 001-071 in the Associated Procedures Table.

Use the following procedure for camshaft removal and installation on engine.

Refer to Procedure 001-008 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check for correct engine static timing.

Guided Step 2A - Check static timing.

Conditions

  • Turn keyswitch OFF.
  • Remove the gear cover. Refer to Procedure 001-031 in the Associated Procedures Table.
  • Rotate the engine to Top Dead Center (TDC) for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned.
  • Use the following procedure for the engine. Refer to Procedure 001-008 in the Associated Procedures Table.

Action

Inspect the engine static timing.

Camshaft and crankshaft gears properly installed?
YES NO
No Repair

Install the camshaft and crankshaft gear correctly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the gear train.

Conditions

  • Turn keyswitch OFF.

Action

Remove the gear cover.

Refer to Procedure 001-031 in the Associated Procedures Table.

Inspect the gear train for damage that would lead to slippage.

Damage found?
YES NO

  • Repair the damaged components.
  • See the appropriate service manual for repair procedure.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 6128 - Engine Timing Sensor - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft | Refer to Procedure 001-008 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Camshaft Position Sensor | Refer to Procedure 019-363 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheel and camshaft position sensor. |
 | STEP 1A. Inspect the camshaft position sensor. | Damage found and incorrectly installed?
 | STEP 1B. Inspect the camshaft tone wheel for any damage. | Damage found?
STEP 2. | Check the camshaft sensor circuit. |
 | STEP 2A. Inspect the camshaft sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the camshaft sensor circuit at the engine harness Engine Control Module (ECM) connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation and/or wrong signal shielding?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Vehicle test. |
 | STEP 4A. Road test to determine if fault condition exists. | Does Fault Code 6128 become active during engine operation?
 | STEP 4B. Inspect air gap and target wheel. | Is the air gap within specifications?
 | STEP 4C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 6128 status change from inactive to active while manipulating the engine harness?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the tone wheel and camshaft position sensor.

Guided Step 1A - Inspect the camshaft position sensor.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the camshaft position sensor for damage and correct installation.

Damage found and incorrectly installed?
YES NO

Replace the camshaft position sensor or correctly install the sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 1B

Guided Step 1B - Inspect the camshaft tone wheel for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the camshaft tone wheels for damage.

Damage found?
YES NO

Replace the tone wheel.

Use the following procedure for camshaft removal and installation on the engines. Refer to Procedure 001-008 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the camshaft sensor circuit.

Guided Step 2A - Inspect the camshaft sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft sensor from the engine harness.

Action

Closely inspect the engine harness near the camshaft sensor.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Inspect the camshaft sensor circuit at the engine harness Engine Control Module (ECM) connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Closely inspect the engine harness near the ECM connector A, B, and C.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.
  • Verify this sensor have used the shielding line and the shielding line is grounded correctly.

Damaged wire insulation and/or wrong signal shielding?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2E

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the camshaft sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 5A

Guided Step 4 - Vehicle test.

Guided Step 4A - Road test to determine if fault condition exists.

Conditions

  • Connect the camshaft sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

With the engine operating, accelerate the engine several times.

  • Use Toolkit electronic service tool to observe fault codes.

Does Fault Code 6128 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the secondary engine speed sensor (camshaft sensor) from the engine and measure the air gap at several points in the camshaft's revolution.

Refer to Procedure 019-363 in the Associated Procedures Table.

Is the air gap within specifications?

  • Minimum Air Gap: 0.25 mm [ 0.010 in ]
  • Maximum Air Gap: 1.27 mm [ 0.050 in ]
  • Maximum Target Runout: 0.33 mm [ 0.013 in ]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 4C

Go to 5A

Guided Step 4C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Test for an intermittent fault condition.

Use Toolkit electronic service tool to monitor Fault Code 6128 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connectors, manipulate the engine harness manually. Work backward from the ECM connectors toward the engine speed sensor connector.

Does Fault Code 6128 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 6129 - Engine Position Sensor - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the tone wheel and crankshaft position sensor. |
 | STEP 1A. Inspect the crankshaft position sensor. | Damage found and incorrectly installed?
 | STEP 1B. Inspect the crankshaft tone wheel for any damage. | Damage found?
STEP 2. | Check the crankshaft sensor circuit. |
 | STEP 2A. Inspect the crankshaft sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the crankshaft sensor circuit at the engine harness Engine Control Module (ECM) connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation and/or wrong signal shielding?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Vehicle test. |
 | STEP 4A. Road test to determine if fault condition exists. | Does Fault Code 6129 become active during engine operation?
 | STEP 4B. Inspect air gap and target wheel. | Is the air gap within specifications?
 | STEP 4C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 6129 status change from inactive to active while manipulating the engine harness?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the tone wheel and crankshaft position sensor.

Guided Step 1A - Inspect the crankshaft position sensor.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft position sensor for damage and correct installation.

Damage found and incorrectly installed?
YES NO

Replace the crankshaft position sensor or correctly install the sensor.

Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 1B

Guided Step 1B - Inspect the crankshaft tone wheel for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft tone wheels for damage.

Damage found?
YES NO

Replace the tone wheel.

Use the following procedure for crankshaft speed indicator ring removal and installation on the engines. Refer to Procedure 001-071 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the crankshaft sensor circuit.

Guided Step 2A - Inspect the crankshaft sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft sensor from the engine harness.

Action

Closely inspect the engine harness near the crankshaft sensor.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Inspect the crankshaft sensor circuit at the engine harness Engine Control Module (ECM) connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged, allowing intermittent shorts to the engine block or nearby components.
  • Verify this sensor have used the shielding line and the shielding line is grounded correctly.

Damaged wire insulation and/or wrong signal shielding?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2E

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the crankshaft sensor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 5A

Guided Step 4 - Vehicle test.

Guided Step 4A - Road test to determine if fault condition exists.

Conditions

  • Connect the crankshaft sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

With the engine operating, accelerate the engine several times.

  • Use Toolkit electronic service tool to observe fault codes.

Does Fault Code 6129 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the crankshaft sensor from the engine and measure the air gap at several points in the crankshaft's revolution. Refer to Procedure 019-365 in the Associated Procedures Table.

Is the air gap within specifications?

  • Minimum Air Gap: 0.25 mm [ 0.010 in ]
  • Maximum Air Gap: 1.59 mm [ 0.063 in ]
  • Maximum Target Runout: 0.5 mm [ 0.02 in ]
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 4C

Go to 5A

Guided Step 4C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Test for an intermittent fault condition.

Use Toolkit electronic service tool to monitor Fault Code 6129 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connectors, manipulate the engine harness manually. Work backward from the ECM connectors toward the engine speed sensor connector.

Does Fault Code 6129 status change from inactive to active while manipulating the engine harness?
YES NO

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 6131 - Engine Exhaust O2 Sensor Fueling Correction - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | B6.7 G CMOH6.0 B125 | 4383640
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
High Pressure Regulator, NG | Refer to Procedure 005-061 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Any active fault codes?
STEP 2. | Verify the intake manifold absolute pressure and temperature sensor accuracy. |
 | STEP 2A. Verify intake manifold absolute pressure reading. | Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
 | STEP 2B. Monitor intake manifold air temperature reading. | Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 3. | Verify the engine gas temperature/pressure sensor accuracy. |
 | STEP 3A. Verify the engine gas pressure reading. | Fuel pressure within 5 percent?
 | STEP 3B. Verify the engine gas temperature reading. | Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 4. | Calibrate the oxygen (or exhaust gas) sensor. |
 | STEP 4A. Calibrate the oxygen (or exhaust gas) sensor. | Fault Code 6131 inactive?
STEP 5. | Check for air leaks in the air system. |
 | STEP 5A. Check for air leaks in the air intake system. | Air leaks?
 | STEP 5B. Check for air leaks in the exhaust system. | Exhaust leaks?
STEP 6. | Check the engine fuel system. |
 | STEP 6A. Check the fuel tank pressure or level. | Fuel tank pressure or level low?
 | STEP 6B. Check the fuel system connections from fuel tank to fuel metering valve for leaks. | Fuel leaks?
 | STEP 6C. Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend. | Any blocks and sharp bend?
 | STEP 6D. Inspect the engine high pressure regulator. | Missing or damaged components?
 | STEP 6E. Check fuel filter for oil and clogging. | Evidence of oil and the fuel filter clogging?
 | STEP 6F. Check the injectors. | Evidence of injectors malfunctions?
 | STEP 6G. Clean the throttle. | Did the throttle function well?
STEP 7. | Check the engine intake valves. |
 | STEP 7A. Check the overhead set. | Overhead is set correctly?
 | STEP 7B. Check the intake valve for leakage. | Any leakage was found at all of the intake valves?
STEP 8. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Any active fault codes?
YES | NO
No Repair | No Repair

Troubleshooting all active fault codes.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Verify the intake manifold absolute pressure and temperature sensor accuracy.

Guided Step 2A - Verify intake manifold absolute pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the intake manifold absolute pressure and temperature sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare intake manifold absolute pressure to engine intake air pressure sensor.

NOTE: Toolkit electronic service tool may display engine intake air pressure as turbocharger compressor outlet pressure.

Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
YES NO
No Repair

A damaged sensor has been detected.

Repair or replace the sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 2B

Go to 8A

Guided Step 2B - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use Toolkit electronic service tool to monitor the intake temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 3A

Go to 8A

Guided Step 3 - Verify the engine gas temperature/pressure sensor accuracy.

Guided Step 3A - Verify the engine gas pressure reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in Toolkit electronic service tool.

Engine gas temperature/pressure sensor pressure reading is displayed in Toolkit electronic service tool.

Fuel pressure within 5 percent?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 3B

Go to 8A

Guided Step 3B - Verify the engine gas temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the engine gas temperature/pressure sensor temperature reading.

  • Use Toolkit electronic service tool to monitor the engine gas temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 4A

Go to 8A

Guided Step 4 - Calibrate the oxygen (or exhaust gas) sensor.

Guided Step 4A - Calibrate the oxygen (or exhaust gas) sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the oxygen (or exhaust gas) sensor calibration requirement meets.

  • Use Toolkit electronic service tool to perform the manual air calibration to oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Fault Code 6131 inactive?
YES | NO
No Repair | No Repair

Go to 8A

Go to 5A

Guided Step 5 - Check for air leaks in the air system.

Guided Step 5A - Check for air leaks in the air intake system.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks near all gasket surfaces between the throttle actuator and where the intake meets the block. Check all pipe plugs for leaks or missing components.

  • Start the engine and let it idle.
  • Listen for air leaks while engine is operating.

Air leaks?
YES NO

Locate all damaged gaskets or components and replace accordingly.

 No Repair

Go to 8A

Go to 5B

Guided Step 5B - Check for air leaks in the exhaust system.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for exhaust leaks.

  • Check for exhaust leaks at the turbocharger gasket, exhaust manifold gasket leaks, or leak upstream of the oxygen sensor in the exhaust stack.

Exhaust leaks?
YES NO

Repair or replace the leaking components.

 No Repair

Go to 8A

Go to 6A

Guided Step 6 - Check the engine fuel system.

Guided Step 6A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the Original Equipment Manufacturer (OEM) pressure gauge to check the pressure or level of the fuel in the fuel tank.

Fuel tank pressure or level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. See equipment manufacturer service information.

No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check the fuel system connections from fuel tank to fuel metering valve for leaks.

Conditions

  • Turn keyswitch ON.

Action

Check for fuel leaks in the fuel system from fuel tank to fuel metering valve.

  • Check the fuel lines, and fuel connections for leaks.
  • Use a gas detector, Part Number 3823984, or soap solution to check for leaks.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Turn the key to the OFF position, and repair leaks immediately. Repair or replace the leaking component.

No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Any blocks and sharp bend?
YES NO

A blocked or sharp bend fuel line has been detected in the fuel system. Repair or replace the blocked or sharp bend fuel line.

 No Repair

Go to 8A

Go to 6D

Guided Step 6D - Inspect the engine high pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine high pressure regulator. See equipment manufacturer service information for the specific removal and installation requirements.

Action

Inspect the engine high pressure regulator.

  • Refer to Procedure 005-061 in the Associated Procedures Table or see equipment manufacturer service information.

Missing or damaged components?
YES NO

Repair or replace the missing or damaged components.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6E

Guided Step 6E - Check fuel filter for oil and clogging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the fuel filter and check the fuel filter for oil in and clogging.

Refer to Procedure 006-015 in the Associated Procedures Table.

NOTE: Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil and the fuel filter clogging?
YES NO

Replace the fuel filter.

Refer to Procedure 006-015 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6F

Guided Step 6F - Check the injectors.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Use Toolkit electronic service tool to perform injector diagnostic test.

  • Refer to Procedure 005-242 in the Associated Procedures Table.

Evidence of injectors malfunctions?
YES NO

Perform the injector cleaning procedure to clean the injectors. Use Toolkit electronic service tool to perform the injector cleaning process. Perform injector diagnostic test again after cleaning the injectors. If necessary, replace the malfunctioning injectors. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6G

Guided Step 6G - Clean the throttle.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the throttle function well?
YES NO
No Repair

A stuck throttle has been detected.

Clean the throttle plate assembly.

Go to 7A

Go to 8A

Guided Step 7 - Check the engine intake valves.

Guided Step 7A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-004 in the Associated Procedures Table.

Action

Inspect the overhead set for all cylinders.

Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead is set correctly?
YES NO
No Repair

Readjust the overhead.

Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 7B

Go to 8A

Guided Step 7B - Check the intake valve for leakage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

Action

Inspect the intake valve for leakage for all cylinders.

Refer to Procedure 002-004 in the Associated Procedures Table.

Any leakage was found at all of the intake valves?
YES NO

A damaged intake valve was detected.

Replace the damaged intake valve.

Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 8A

Guided Step 8 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Sep-2015


FAULT CODE 6132 - Engine Exhaust O2 Sensor Fueling Correction - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | B6.7 G CMOH6.0 B125 | 4383640
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
High Pressure Regulator, NG | Refer to Procedure 005-061 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Any active fault codes?
STEP 2. | Verify the intake manifold absolute pressure and temperature sensor accuracy. |
 | STEP 2A. Verify intake manifold absolute pressure reading. | Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
 | STEP 2B. Monitor intake manifold air temperature reading. | Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 3. | Verify the engine gas temperature/pressure sensor accuracy. |
 | STEP 3A. Verify the engine gas pressure reading. | Fuel pressure within 5 percent?
 | STEP 3B. Verify the engine gas temperature reading. | Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 4. | Calibrate the oxygen (or exhaust gas) sensor. |
 | STEP 4A. Calibrate the oxygen (or exhaust gas) sensor. | Fault Code 6132 inactive?
STEP 5. | Check for air leaks in the air system. |
 | STEP 5A. Check for air leaks in the air intake system. | Air leaks?
 | STEP 5B. Check for air leaks in the exhaust system. | Exhaust leaks?
STEP 6. | Check the engine fuel system. |
 | STEP 6A. Check the fuel tank pressure or level. | Fuel tank pressure or level low?
 | STEP 6B. Inspect the engine high pressure regulator. | Missing or damaged components?
 | STEP 6C. Check fuel filter for oil and clogging. | Evidence of oil and the fuel filter clogging?
 | STEP 6D. Check injectors for leaks. | Fuel leaks?
 | STEP 6E. Clean the throttle. | Did the throttle function well?
STEP 7. | Check the engine intake valves. |
 | STEP 7A. Check the overhead set. | Overhead is set correctly?
 | STEP 7B. Check the intake valve for leakage. | Any leakage was found at all of the intake valves?
STEP 8. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Any active fault codes?
YES | NO
No Repair | No Repair

Troubleshooting all active fault codes.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Verify the intake manifold absolute pressure and temperature sensor accuracy.

Guided Step 2A - Verify intake manifold absolute pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the intake manifold absolute pressure and temperature sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare intake manifold absolute pressure to engine intake air pressure sensor.

NOTE: Toolkit electronic service tool may display engine intake air pressure as turbocharger compressor outlet pressure.

Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
YES NO
No Repair

A damaged sensor has been detected.

Repair or replace the sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 2B

Go to 8A

Guided Step 2B - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use Toolkit electronic service tool to monitor the intake temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 3A

Go to 8A

Guided Step 3 - Verify the engine gas temperature/pressure sensor accuracy.

Guided Step 3A - Verify the engine gas pressure reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in Toolkit electronic service tool.

Engine gas temperature/pressure sensor pressure reading is displayed in Toolkit electronic service tool.

Fuel pressure within 5 percent?
YES NO
No Repair

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 3B

Go to 8A

Guided Step 3B - Verify the engine gas temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the engine gas temperature/pressure sensor temperature reading.

  • Use Toolkit electronic service tool to monitor the engine gas temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 4A

Go to 8A

Guided Step 4 - Calibrate the oxygen (or exhaust gas) sensor.

Guided Step 4A - Calibrate the oxygen (or exhaust gas) sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the oxygen (or exhaust gas) sensor calibration requirement meets.

  • Use Toolkit electronic service tool to perform the manual air calibration to oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Fault Code 6132 inactive?
YES | NO
No Repair | No Repair

Go to 8A

Go to 5A

Guided Step 5 - Check for air leaks in the air system.

Guided Step 5A - Check for air leaks in the air intake system.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks near all gasket surfaces between the throttle actuator and where the intake meets the block. Check all pipe plugs for leaks or missing components.

  • Start the engine and let it idle.
  • Listen for air leaks while engine is operating.

Air leaks?
YES NO

Locate all damaged gaskets or components and replace accordingly.

 No Repair

Go to 8A

Go to 5B

Guided Step 5B - Check for air leaks in the exhaust system.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for exhaust leaks.

  • Check for exhaust leaks at the turbocharger gasket, exhaust manifold gasket leaks, or leak upstream of the oxygen sensor in the exhaust stack.

Exhaust leaks?
YES NO

Repair or replace the leaking components.

 No Repair

Go to 8A

Go to 6A

Guided Step 6 - Check the engine fuel system.

Guided Step 6A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the Original Equipment Manufacturer (OEM) pressure gauge to check the pressure or level of the fuel in the fuel tank.

Fuel tank pressure or level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. See equipment manufacturer service information.

No Repair

Go to 8A

Go to 6B

Guided Step 6B - Inspect the engine high pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine high pressure regulator. See equipment manufacturer service information for the specific removal and installation requirements.

Action

Inspect the engine high pressure regulator.

  • Refer to Procedure 005-061 in the Associated Procedures Table or see equipment manufacturer service information.

Missing or damaged components?
YES NO

Repair or replace the missing or damaged components.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check fuel filter for oil and clogging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the fuel filter and check the fuel filter for oil in and clogging.

Refer to Procedure 006-015 in the Associated Procedures Table.

NOTE: Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil and the fuel filter clogging?
YES NO

Replace the fuel filter.

Refer to Procedure 006-015 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6D

Guided Step 6D - Check injectors for leaks.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Check injectors for leaks.

  • Refer to Procedure 005-242 in the Associated Procedures Table.

Fuel leaks?
YES NO

Perform the injector cleaning procedure to clean the injectors. Use Toolkit electronic service tool to perform the injector cleaning process. If fuel still leak after cleaning the injectors, replace the damage injectors.

Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6E

Guided Step 6E - Clean the throttle.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the throttle function well?
YES NO
No Repair

A stuck throttle has been detected.

Clean the throttle plate assembly.

Go to 7A

Go to 8A

Guided Step 7 - Check the engine intake valves.

Guided Step 7A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-004 in the Associated Procedures Table.

Action

Inspect the overhead set for all cylinders.

Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead is set correctly?
YES NO
No Repair

Readjust the overhead.

Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 7B

Go to 8A

Guided Step 7B - Check the intake valve for leakage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

Action

Inspect the intake valve for leakage for all cylinders.

Refer to Procedure 002-004 in the Associated Procedures Table.

Any leakage was found at all of the intake valves?
YES NO

A damaged intake valve was detected.

Replace the damaged intake valve.

Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 8A

Guided Step 8 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Sep-2015


FAULT CODE 6133 - Engine Throttle Valve 1 Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6133 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine throttle control actuator operation. |
 | STEP 3A. Check the engine throttle control actuator. | Did the actuator pass the test?
 | STEP 3B. Check for an active fault code. | Fault Code 6133 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6133 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19 for an inactive or intermittent fault code.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and the engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

Repair or replace the harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine throttle control actuator operation.

Guided Step 3A - Check the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO
No Repair

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Turn keyswitch OFF and keep at least 2 seconds before key on.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6133 active?
YES NO

Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2015


FAULT CODE 6134 - Engine Throttle Valve 1 Position - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6134 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine throttle control actuator operation. |
 | STEP 3A. Check the engine throttle control actuator. | Did the actuator pass the test?
 | STEP 3B. Check for an active fault code. | Fault Code 6134 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6134 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19 for an inactive or intermittent fault code.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and the engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

Repair or replace the harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine throttle control actuator operation.

Guided Step 3A - Check the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO
No Repair

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Turn keyswitch OFF and keep at least 2 seconds before key on.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6134 active?
YES NO

Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2015


FAULT CODE 6135 - Engine Throttle Valve 2 Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6135 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine throttle control actuator operation. |
 | STEP 3A. Check the engine throttle control actuator. | Did the actuator pass the test?
 | STEP 3B. Check for an active fault code. | Fault Code 6135 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6135 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and the engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

Repair or replace the harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine throttle control actuator operation.

Guided Step 3A - Check the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO
No Repair

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Turn keyswitch OFF and keep at least 2 seconds before key on.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6135 active?
YES NO

Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2015


FAULT CODE 6136 - Engine Throttle Valve 2 Position - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6136 active?
STEP 2. | Check the engine throttle actuator and circuit. |
 | STEP 2A. Inspect the engine throttle actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine throttle control actuator operation. |
 | STEP 3A. Check the engine throttle control actuator. | Did the actuator pass the test?
 | STEP 3B. Check for an active fault code. | Fault Code 6136 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6136 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine throttle actuator and circuit.

Guided Step 2A - Inspect the engine throttle actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine throttle actuator from the engine harness.

Action

Inspect the engine harness and the engine throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or engine harness connector.

Repair or replace the harness, or replace the actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the engine throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine throttle control actuator operation.

Guided Step 3A - Check the engine throttle control actuator.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the actuator pass the test?
YES NO
No Repair

A stuck throttle actuator has been detected.

Clean the throttle actuator assembly.

Use the following procedure to replace the engine throttle control actuator.

  • Refer to Procedure 005-052 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Turn keyswitch OFF and keep at least 2 seconds before key on.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6136 active?
YES NO

Replace the throttle actuator. Refer to Procedure 005-052 in the Associated Procedures Table.

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Aug-2015


FAULT CODE 6137 - Source Address 3 - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool. |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 6137 active?
STEP 3. | Check the Original Equipment Manufacturer (OEM) electronic transmission controller 1 and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine electronic transmission controller 1 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic transmission controller 1 multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 6137 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6137 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the Original Equipment Manufacturer (OEM) electronic transmission controller 1 and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine electronic transmission controller 1 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM electronic transmission controller 1 multiplexing configuration component enable and OEM electronic transmission controller 1 source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM electronic transmission controller 1 multiplexed component enables and source addresses. This component can be found in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM electronic transmission controller 1 multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is an OEM electronic transmission controller 1, OEM electronic transmission controller 1 setup, or OEM electronic transmission controller 1 to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper OEM electronic transmission controller 1 for multiplexing on the applicable OEM application and make sure the OEM electronic transmission controller 1 source address are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6137 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication troubleshooting symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6138 - Source Address 3 - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6138 active?
STEP 2. | Check the Original Equipment Manufacturer (OEM) electronic transmission controller 1 and Engine Control Module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine electronic transmission controller 1 is enabled for multiplexing over the J1939 data link to ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic transmission controller 1 multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6138 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Original Equipment Manufacturer (OEM) electronic transmission controller 1 and Engine Control Module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine electronic transmission controller 1 is enabled for multiplexing over the J1939 data link to ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM electronic transmission controller 1 multiplexing configuration component enable and OEM electronic transmission controller 1 source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the proper multiplexing configuration.

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM electronic transmission controller 1 multiplexed component enables and source addresses. This component can be found in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM electronic transmission controller 1 multiplexing configuration?
YES NO

There is an OEM issue with the OEM electronic transmission controller 1 or transmission output shaft speed sensor.

Contact the OEM for further repair instructions.

An incorrect setup has been detected in the ECM.

Enable the proper OEM electronic transmission controller 1 for multiplexing on the applicable OEM application and make sure the OEM electronic transmission controller 1 source address are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the Subsystem Identification Descriptions (SID) file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 6139 - Source Address 238 - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool. |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 6139 active?
STEP 3. | Check the Original Equipment Manufacturer (OEM) tachograph 1 and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine tachograph 1 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM tachograph 1 multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 6139 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6139 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the Original Equipment Manufacturer (OEM) tachograph 1 and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine tachograph 1 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM tachograph 1 multiplexing configuration component enable and OEM tachograph 1 source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM tachograph 1 multiplexed component enables and source addresses. This component can be found in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM tachograph 1 multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is an OEM tachograph 1, OEM tachograph 1 setup, or OEM tachograph 1 to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper OEM tachograph 1 for multiplexing on the applicable OEM application and make sure the OEM tachograph 1 source address are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6139 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication troubleshooting symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6141 - Source Address 238 - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6141 active?
STEP 2. | Check the Original Equipment Manufacturer (OEM) tachograph 1 and Engine Control Module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine OEM tachograph 1 is enabled for multiplexing over the J1939 data link to ECM and compare to the ECM configuration. | Does the ECM multiplexing configuration match the OEM tachograph 1 multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6141 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Original Equipment Manufacturer (OEM) tachograph 1 and Engine Control Module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine OEM tachograph 1 is enabled for multiplexing over the J1939 data link to ECM and compare to the ECM configuration..

Conditions

  • Determine proper OEM tachograph 1 multiplexing configuration component enable and OEM tachograph 1 source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the proper multiplexing configuration.

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM tachograph 1 multiplexed component enables and source addresses. This component can be found in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM tachograph 1 multiplexing configuration?
YES NO

There is an OEM issue with the OEM tachograph 1 or tachograph vehicle speed sensor.

Contact the OEM for further repair instructions.

An incorrect setup has been detected in the ECM.

Enable the proper OEM tachograph 1 for multiplexing on the applicable OEM application and make sure the OEM tachograph 1 source address are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the Subsystem Identification Descriptions (SID) file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 6142 - Source Address 11 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool. |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 6142 active?
STEP 3. | Check the Original Equipment Manufacturer (OEM) electronic brake controller 2 and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine electronic brake controller 2 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic brake controller 2 multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 6142 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6142 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the Original Equipment Manufacturer (OEM) electronic brake controller 2 and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine electronic brake controller 2 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM electronic brake controller 2 multiplexing configuration component enable and OEM electronic brake controller 2 source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM electronic brake controller 2 multiplexed component enables and source addresses. This component can be found in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM electronic brake controller 2 multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is an OEM electronic brake controller 2, OEM electronic brake controller 2 setup, or OEM electronic brake controller 2 to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper OEM electronic brake controller 2 for multiplexing on the applicable OEM application and make sure the OEM electronic brake controller 2 source address are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6142 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication troubleshooting symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6143 - Source Address 11 - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6143 active?
STEP 2. | Check the Original Equipment Manufacturer (OEM) electronic brake controller 2 and Engine Control Module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine electronic brake controller 2 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic brake controller 2 multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6143 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Original Equipment Manufacturer (OEM) electronic brake controller 2 and Engine Control Module (ECM) for proper multiplexing configuration.

Guided Step 2A - Determine electronic brake controller 2 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM electronic brake controller 2 multiplexing configuration component enable and OEM electronic brake controller 2 source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM electronic brake controller 2 multiplexed component enables and source addresses. This component can be found in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM electronic brake controller 2 multiplexing configuration?
YES NO

There is an OEM issue with the OEM electronic brake controller 2 or front axle speed sensor.

Contact the OEM for further repair instructions.

An incorrect setup has been detected in the ECM.

Enable the proper OEM electronic brake controller 2 for multiplexing on the applicable OEM application and make sure the OEM electronic brake controller 2 source address are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Jun-2015


FAULT CODE 6144 - Source Address 239 - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool. |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 6144 active?
STEP 3. | Check the Original Equipment Manufacturer (OEM) electronic transmission controller and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine electronic transmission controller 2 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic transmission controller 2 multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 6144 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6144 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the Original Equipment Manufacturer (OEM) electronic transmission controller and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine electronic transmission controller 2 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM electronic transmission controller 2 multiplexing configuration component enable and OEM electronic transmission controller 2 source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM electronic transmission controller 2 multiplexed component enables and source addresses. This component can be found in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM electronic transmission controller 2 multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is an OEM electronic transmission controller 2, OEM electronic transmission controller 2 setup, or OEM electronic transmission controller 2 to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper OEM electronic transmission controller 2 for multiplexing on the applicable OEM application and make sure the OEM electronic transmission controller 2 source address are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness andengine harness to determinewhich contains the open circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness andengine harness to determinewhich contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6145 - J1939 Network #1, Primary Vehicle Network - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool. |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM correct?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Did the fault codes related to the multiplexing devices exist?
STEP 3. | Check for the fault codes by Malfunction Indicator Lamp (MIL) flashing. |
 | STEP 3A. Read the fault codes flash out. | Fault Code 6145 or 6148 active?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for ECM communication with the Toolkit electronic service tool and inactive fault. | Is communication between Toolkit electronic service tool and the ECM correct and Fault Code 6145 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM correct?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Did the fault codes related to the multiplexing devices exist?
YES | NO
No Repair | No Repair

See active Fault Code Troubleshooting Trees.

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check for the fault codes by Malfunction Indicator Lamp (MIL) flashing.

Guided Step 3A - Read the fault codes flash out.

Conditions

  • Turn keyswitch ON.
  • Fully depress and release the pedal three times within 20 seconds prior to engine starting.

Action

Read the fault codes flash out.

Fault Code 6145 or 6148 active?
YES | NO
No Repair | No Repair

Go to 4A

Refer to Procedure 019-362 in Section 19.

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Disconnect the data link adapter from the service data link connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.
  • Repair or replace the Original Equipment Manufacturer (OEM) harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for ECM communication with the Toolkit electronic service tool and inactive fault.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Is communication between Toolkit electronic service tool and the ECM correct and Fault Code 6145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedure Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 6147- Source Address 11 - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool. |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 6147 active?
STEP 3. | Check the Original Equipment Manufacturer (OEM) electronic brake controller 1 and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine electronic brake controller 1 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM electronic brake controller 1 multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 6147 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.
  • Start the engine for at least one minute.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6147 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the Original Equipment Manufacturer (OEM) electronic brake controller 1 and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine electronic brake controller 1 is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM electronic brake controller 1 multiplexing configuration component enable and OEM electronic brake controller 1 source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM electronic brake controller 1 multiplexed component enables and source addresses. This component can be found in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM electronic brake controller 1 multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is an OEM electronic brake controller 1, OEM electronic brake controller 1 setup, or OEM electronic brake controller 1 to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper OEM electronic brake controller 1 for multiplexing on the applicable OEM application and make sure the OEM electronic brake controller 1 source address are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B, and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.
  • Start the engine for at least one minute.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6147 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication troubleshooting symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6148 - J1939 Network #1, Primary Vehicle Network - Special Instructions

Associated Procedures

Associated Procedure
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool. |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM correct?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Did the fault codes related to the multiplexing devices exist?
STEP 3. | Check for the fault codes by Malfunction Indicator Lamp (MIL) flashing. |
 | STEP 3A. Read the fault codes flash out. | Fault Code 6148 active?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for ECM communication with the Toolkit electronic service tool and inactive fault. | Is communication between Toolkit electronic service tool and the ECM correct and Fault Code 6148 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM correct?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Did the fault codes related to the multiplexing devices exist?
YES | NO
No Repair | No Repair

See active Fault Code Troubleshooting Trees.

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check for the fault codes by Malfunction Indicator Lamp (MIL) flashing.

Guided Step 3A - Read the fault codes flash out.

Conditions

  • Turn keyswitch ON.
  • Fully depress and release the pedal three times within 20 seconds prior to engine starting.

Action

Read the fault codes flash out.

Fault Code 6148 active?
YES | NO
No Repair | No Repair

Go to 4A

Refer to Procedure 019-362 in Section 19.

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector .
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the Original Equipment Manufacturer (OEM) harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch ON.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B, and C.

See the the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for ECM communication with the Toolkit electronic service tool and inactive fault.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Is communication between Toolkit electronic service tool and the ECM correct and Fault Code 6148 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM - No Communication troubleshooting symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedure Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6149 - Source Address 11 - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 6149 active?
STEP 3. | Check the Original Equipment Manufacturer (OEM) high resolution wheel speed and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine high resolution wheel speed is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM high resolution wheel multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 6149 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6149 active?
YES NO

No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the Original Equipment Manufacturer (OEM) high resolution wheel speed and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine high resolution wheel speed is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM high resolution wheel multiplexing configuration component enable and OEM high resolution wheel source addresses from the appropriate OEM information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the OEM high resolution wheel multiplexed component enables and source addresses. This component can be found under Controller Area Network (CAN) high resolution wheel in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the OEM high resolution wheel multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is an OEM high resolution wheel, OEM high resolution wheel setup, or OEM high resolution wheel to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper OEM high resolution wheel for multiplexing on the applicable OEM application and make sure the OEM high resolution wheel source address are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step -

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B, and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6149 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6151 - Relative Humidity - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Humidity Sensor | Refer to Procedure 019-356 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 6151 inactive?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6152 active and Fault Code 6151 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 6151 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6151 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6152 active and Fault Code 6151 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the humidity sensor +5 VDC SUPPLY pin to the humidity sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6151 active?
YES NO

A damaged sensor has been detected.

Replace the humidity sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6152 active and Fault Code 6151 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6151 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the humidity sensor +5 VDC SUPPLY pin to the humidity sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6151 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6152 - Relative Humidity - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Humidity Sensor | Refer to Procedure 019-356 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 6152 inactive?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 6151 active and Fault Code 6152 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 6152 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for inactive fault code.

  • Use Toolkit electronic service tool to read the inactive fault codes.

Fault Code 6152 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the humidity sensor +5 VDC SUPPLY pin to the humidity sensor RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the humidity sensor +5 VDC SUPPLY pin and the humidity sensor SIGNAL pin at the humidity sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6151 active and Fault Code 6152 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6152 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector C or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector C, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the humidity sensor +5 VDC SUPPLY pin to the humidity sensor RETURN pin at the ECM engine connector C.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8 VDC and 5.2 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6152 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM engine connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the humidity sensor +5 VDC SUPPLY pin and the humidity sensor SIGNAL pin at the engine control module engine connector C.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6151 active and Fault Code 6152 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6152 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6153 - Relative Humidity - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Humidity Sensor | Refer to Procedure 019-356 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 6153 inactive?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for wet humidity sensor. | Wet humidity sensor?
 | STEP 2C. Check the circuit response. | Fault Code 6153 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for wet humidity sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the humidity sensor from the air inlet connection.

Action

Check for wet humidity sensor and water deposit in the air inlet connection.

See equipment manufacturer service information.

Wet humidity sensor?
YES NO

Clean the humidity sensor, clean the air inlet connection and air filter.

  • See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the circuit response.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Aug-2015


FAULT CODE 6154 - Relative Humidity - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Humidity Sensor | Refer to Procedure 019-356 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 6154 inactive?
 | STEP 1B. Inspect the humidity sensor for correct installation and any damage. | Damage found and installation position wrong?
STEP 2. | Check the humidity sensor and circuit. |
 | STEP 2A. Inspect the humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6152 active?
 | STEP 2C. Check the circuit response. | Fault Code 6151 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Inspect the humidity sensor for correct installation and any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the humidity sensor for correct installation and any damage.

Damage found and installation position wrong?
YES NO

Replace and repair the humidity sensor.

Refer to Procedure 019-356 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the humidity sensor and circuit.

Guided Step 2A - Inspect the humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.

Action

Inspect the engine harness and humidity sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6152 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Place a jumper wire between the humidity sensor humidity SIGNAL pin and the humidity sensor +5 VDC POWER SUPPLY pin at the humidity sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6151 active?
YES NO

Replace the humidity sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C humidity sensor RETURN pin and the engine harness humidity sensor RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C humidity sensor humidity SIGNAL pin and the engine harness humidity sensor humidity SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C humidity sensor +5 VDC POWER SUPPLY pin and the engine harness +5 VDC POWER SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2015


FAULT CODE 6155 - Engine Control Module - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Engine Control Module (ECM). |
 | STEP 1A. Check the ECM. | Fault Code 6155 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 6155. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the Engine Control Module (ECM).

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 6155 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 6155.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 6155.

  • Use Toolkit electronic service tool to read the inactive counts of Fault Code 6155.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jul-2015


FAULT CODE 6156 - Engine Intake Manifold Desired Absolute Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger | Refer to Procedure 010-033 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Actuator Air Line | Refer to Procedure 010-118 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6156 active?
STEP 2. | Check the intake manifold absolute pressure and temperature sensor. |
 | STEP 2A. Inspect the intake manifold absolute pressure and temperature sensor connector pins. | Damaged or dirty pins?
 | STEP 2B. Verify intake manifold absolute pressure. | Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
STEP 3. | Check the components. |
 | STEP 3A. Check the turbocharger actuator air line. | Turbocharger actuator air line leaking or damaged?
 | STEP 3B. Check the wastegate actuator. | Wastegate actuator functioning properly?
 | STEP 3C. Check the turbocharger. | Turbocharger damaged?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 6156 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold absolute pressure and temperature sensor.

Guided Step 2A - Inspect the intake manifold absolute pressure and temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Inspect the intake manifold absolute pressure and temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify intake manifold absolute pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the intake manifold absolute pressure and temperature sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare intake manifold absolute pressure to engine intake air pressure sensor.

NOTE: Toolkit electronic service tool may display engine intake air pressure as turbocharger compressor outlet pressure.

Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
YES NO
No Repair

A damaged sensor has been detected. Replace the sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the components.

Guided Step 3A - Check the turbocharger actuator air line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger actuator air line.

  • Check the turbocharger actuator air line for damage or leaks.

Turbocharger actuator air line leaking or damaged?
YES NO

Replace the turbocharger actuator air line.

  • Refer to Procedure 010-118 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the wastegate actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator.

  • Check the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Wastegate actuator functioning properly?
YES NO
No Repair

A damaged wastegate actuator has been detected.

  • Replace the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger for damage.

  • Check the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Turbocharger damaged?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Aug-2015


FAULT CODE 6157 - Engine Intake Manifold Desired Absolute Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | B6.7 G CMOH6.0 B125 | 4383640
Air Intake Restriction | Refer to Procedure 010-031 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger | Refer to Procedure 010-033 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6157 active?
STEP 2. | Check the components. |
 | STEP 2A. Check for air leaks in the intake system. | Air leaks detected?
 | STEP 2B. Check the exhaust system for leaks before the turbocharger. | Exhaust leaks detected?
 | STEP 2C. Check the wastegate actuator. | Wastegate actuator functioning properly?
 | STEP 2D. Check the wastegate valve body. | Wastegate valve body functioning properly?
 | STEP 2E. Check the air intake restriction. | Is restriction within specification?
 | STEP 2F. Check the turbocharger. | Turbocharger damaged?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 6157 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the components.

Guided Step 2A - Check for air leaks in the intake system.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for air leaks in the intake system.

  • Check for intake air leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Air leaks detected?
YES NO

Repair or replace the leaking components.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the exhaust system for leaks before the turbocharger.

Conditions

  • Turn keyswitch ON.

Action

Start the engine and check for leaks in the exhaust system before the turbocharger.

  • Check for exhaust leaks. Refer to Procedure 010-024 in the Associated Procedures Table.

Exhaust leaks detected?
YES NO

Repair or replace the leaking components.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the wastegate actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator.

  • Check the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Wastegate actuator functioning properly?
YES NO
No Repair

A damaged wastegate actuator has been detected.

  • Replace the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the wastegate valve body.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate valve body.

  • Check the wastegate valve body. Refer to Procedure 010-033 in the Associated Procedures Table.

Wastegate valve body functioning properly?
YES NO
No Repair

A damaged wastegate valve body has been detected.

  • Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the air intake restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake restriction.

  • Check the intake restriction of the engine. Refer to Procedure 010-031 in the Associated Procedures Table.

Is restriction within specification?
YES NO
No Repair

Correct the restriction.

  • Remove the restriction or replace the intake air cleaner element.

Go to 2F

Go to 3A

Guided Step 2F - Check the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger for damage.

  • Check the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Turbocharger damaged?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Aug-2015


FAULT CODE 6158 - Engine Intake Manifold Desired Absolute Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger | Refer to Procedure 010-033 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Wastegate Actuator | Refer to Procedure 010-050 | B6.7 G CMOH6.0 B125 | 4383640
Turbocharger Actuator Air Line | Refer to Procedure 010-118 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6158 active?
STEP 2. | Check the intake manifold absolute pressure and temperature sensor. |
 | STEP 2A. Inspect the intake manifold absolute pressure and temperature sensor connector pins. | Damaged or dirty pins?
 | STEP 2B. Verify intake manifold absolute pressure. | Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
STEP 3. | Check the components. |
 | STEP 3A. Check the turbocharger actuator air line. | Turbocharger actuator air line leaking or damaged?
 | STEP 3B. Check the wastegate actuator. | Wastegate actuator functioning properly?
 | STEP 3C. Check the turbocharger. | Turbocharger damaged?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

Use Toolkit electronic service tool to read the fault codes.

Fault Code 6158 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake manifold absolute pressure and temperature sensor.

Guided Step 2A - Inspect the intake manifold absolute pressure and temperature sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold absolute pressure and temperature sensor from the engine harness.

Action

Inspect the intake manifold absolute pressure and temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged or dirty pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify intake manifold absolute pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the intake manifold absolute pressure and temperature sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare intake manifold absolute pressure to engine intake air pressure sensor.

NOTE: Toolkit electronic service tool may display engine intake air pressure as turbocharger compressor outlet pressure.

Intake manifold absolute pressure value is the same as engine intake air pressure sensor?
YES NO
No Repair

A damaged sensor has been detected. Replace the sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the components.

Guided Step 3A - Check the turbocharger actuator air line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger actuator air line.

  • Check the turbocharger actuator air line for damage or leaks.

Turbocharger actuator air line leaking or damaged?
YES NO

Replace the turbocharger actuator air line.

  • Refer to Procedure 010-118 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the wastegate actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator.

  • Check the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Wastegate actuator functioning properly?
YES NO
No Repair

A damaged wastegate actuator has been detected.

  • Replace the wastegate actuator. Refer to Procedure 010-050 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger for damage.

  • Check the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Turbocharger damaged?
YES NO

Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 6159 - Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6159 active?
STEP 2. | Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor and circuit. |
 | STEP 2A. Inspect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 6161 active and Fault Code 6159 inactive?
 | STEP 2D. Check the fault codes and verify Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor condition. | Fault Code 6159 active?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and engine harness connector A pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the Original Equipment Manufacturer (OEM) harness and engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6159 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6159 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor and circuit.

Guided Step 2A - Inspect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit +5 VOLT SUPPLY pin to the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8-VDC and 5.2-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6161 active and Fault Code 6159 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6159 active?
YES NO

A damaged Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit has been detected.

Replace the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor.

Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM and engine harness connector A pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A and C.

Action

Inspect the engine harness and ECM connector A &C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the Original Equipment Manufacturer (OEM) harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor RETURN pin and the OEM harness Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness and/or engine harness. Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-071 in Section 19 and/or Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit SIGNAL pin in the engine harness ECM connector C and all other pins in the the engine harness ECM connector A, B and C.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness and/or engine harness. Troubleshoot OEM harness and engine harness to determine which contains the pin to pin short circuit.

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-071 in Section 19 and/or Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6159 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Aug-2015


FAULT CODE 6161 - Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6161 active?
STEP 2. | Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor and circuit. |
 | STEP 2A. Inspect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor supply voltage and return circuit. | Between 4.8 VDC and 5.2 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 6159 active and Fault Code 6161 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 6161 is active?
STEP 3. | Check the Engine Control Module (ECM) and harness. |
 | STEP 3A. Inspect the ECM, engine harness connector A and C pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the Original Equipment Manufacturer (OEM) harness and engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness and engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness and engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 6161 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6161 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor and circuit.

Guided Step 2A - Inspect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor +5 volt SUPPLY pin to the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor RETURN pin at the sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.8-VDC and 5.2-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor +5 volt SUPPLY pin and the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor SIGNAL pin at the sensor connector of the OEM harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6159 active and Fault Code 6161 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6161 is active?
YES NO

A damaged Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor has been detected.

Replace the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor.

Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and harness.

Guided Step 3A - Inspect the ECM, engine harness connector A and C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A and C.

Action

Inspect the engine harness and ECM connector A &C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector A ,C and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the Original Equipment Manufacturer (OEM) harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM harness from the ECM connector A.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector A Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor SUPPLY pin and the OEM harness Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor connector SUPPLY pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness and/or engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-071 in Section 19 and/or Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor SIGNAL pin and the OEM harness Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness and/or engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the open circuit.

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-071 in Section 19 and/or Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness and/or engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the pin to pin short circuit.

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-071 in Section 19 and/or Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness and engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor SIGNAL pin in the engine harness ECM connector C and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness and/or engine harness.

Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

Repair or replace the OEM harness and/or engine harness. Refer to Procedure 019-071 in Section 19 and/or Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6161 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Aug-2015


FAULT CODE 6162 - Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6159 and 6161 active?
STEP 2. | Verify the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor reading with the other Pressure Sensor. |
 | STEP 2A. Verify Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure reading. | Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure value is the same as other Pressure sensor?
STEP 3. | Check for the exhaust system for damage. |
 | STEP 3A. Check for an exhaust system leak. | Exhaust leaks?
 | STEP 3B. Check for an inactive fault code. | Fault Code 6162 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6159 and 6161 active?
YES | NO
No Repair | No Repair

Troubleshooting active Fault Codes.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Verify the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure Sensor reading with the other Pressure Sensor.

Guided Step 2A - Verify Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure with Toolkit electronic service tool while the engine is not running:

  • Use Toolkit electronic service tool to compare Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure to other Pressure sensor.

NOTE: Toolkit electronic service tool may display Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure.

Aftertreatment 1 Gas Oxidation Catalyst Differential Pressure value is the same as other Pressure sensor?
YES NO
No Repair

A damaged sensor has been detected.

Repair and replace the sensor.

Refer to Procedure 019-376 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check for the exhaust system for damage.

Guided Step 3A - Check for an exhaust system leak.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for exhaust leaks.

  • Check for exhaust leaks at the turbocharger gasket, exhaust manifold gasket leaks, or leak upstream of the oxygen sensor in the exhaust stack.

Exhaust leaks?
YES NO

Repair or replace the leaking components.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6162 active?
YES NO

Inspect the oxidation catalyst and/or muffler, and replace according to the manufacturer's instructions.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wap file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wap file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jul-2015


FAULT CODE 6163 - Engine Knock Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 6163 inactive?
STEP 2. | Check the Engine Knock sensor and circuit. |
 | STEP 2A. Inspect the Engine Knock sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6164 active and Fault Code 6163 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 6163 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6163 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6163 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Engine Knock sensor and circuit.

Guided Step 2A - Inspect the Engine Knock sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Knock sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Knock sensor 1 from the engine harness.

Action

Check the circuit response.

  • Place a jumper wire between the Engine Knock sensor 1 SIGNAL pin and Engine Knock sensor 1 RETURN at the Engine Knock sensor 1 connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

  • Turn keyswitch ON.
  • Start the engine and let it idle.

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6164 active and Fault Code 6163 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Engine Knock sensor 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

Start the engine and let it idle.

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6163 active?
YES NO

A damaged sensor has been detected.

Replace the Engine Knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or the engine harness connector B.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM B.
  • Disconnect the Engine Knock sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor SIGNAL pin and the engine harness Engine Knock sensor connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM B.
  • Disconnect the Engine Knock sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor RETURN pin and the engine harness Engine Knock sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6163 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jul-2015


FAULT CODE 6164 - Engine Knock Sensor Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 6164 inactive?
STEP 2. | Check the Engine Knock sensor and circuit. |
 | STEP 2A. Inspect the Engine Knock sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6164 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 6164 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6164 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6164 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Engine Knock sensor and circuit.

Guided Step 2A - Inspect the Engine Knock sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Knock sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Knock sensor 1 from the engine harness.
  • Disconnect the Engine Knock sensor 2 from the engine harness.
  • Connect the Engine Knock sensor 2 to the Engine Knock sensor 1 connector of the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

See the circuit diagram or the wiring diagram for connector pin identification.

Start the engine and let it idle.

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6164 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Engine Knock sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and let it idle.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6164 active?
YES NO

A damaged sensor has been detected.

Replace the Engine Knock sensor. Refer to Procedure 019-346 in the Associated Procedures Table

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or the engine harness connector B.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM B.
  • Disconnect the Engine Knock sensor from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor SIGNAL pin and the engine harness Engine Knock sensor connector Return pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Engine Knock sensor from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor SINGNAL pin and all other pins in ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Engine Knock sensor from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor RETURN pin and all other pins in ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6164 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 6167 - Engine Ignition Coil #1 - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6167 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the Coil Extension. | Coil extension resistance between 1.1k and 1.7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6167 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect coil pack number 1 from the engine harness.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover.
  • Electrode deposits or fouling.
  • Missing electrode.
  • Cracked insulator.
  • Electrode misalignment.
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the Coil Extension.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 spark plug.
  • Remove the cylinder 1 coil extension from the coil.

Action

Check the coil extension resistance.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Coil extension resistance between 1.1k and 1.7k ohms?
YES NO
No Repair

A damaged coil extension has been detected.

Replace the coil extension. Refer to Procedure 013-050 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Crank the engine or start the engine and let it idle.

Action

Check the ignition coil of cylinder 1.

  • Test the cylinder 1 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Refer to Procedure 013-012 in the Associated Procedures Table.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 6171 - Engine Ignition Coil #2 - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6171 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the Coil Extension. | Coil extension resistance between 1.1k and 1.7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6171 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect coil pack number 2 from the engine harness.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover
  • Electrode deposits or fouling
  • Missing electrode
  • Cracked insulator
  • Electrode misalignment
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug.

Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the Coil Extension.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 spark plug.
  • Remove the cylinder 2 coil extension from the coil.

Action

Check the coil extension resistance.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Coil extension resistance between 1.1k and 1.7k ohms?
YES NO
No Repair

A damaged coil extension has been detected.

Replace the coil extension. Refer to Procedure 013-050 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Crank the engine or start the engine and let it idle.

Action

Check the ignition coil of cylinder 2.

  • Test the cylinder 2 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Refer to Procedure 013-012 in the Associated Procedures Table.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 6174 - Engine Ignition Coil #3 - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6174 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the Coil Extension. | Coil extension resistance between 1.1k and 1.7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6174 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect coil pack number 3 from the engine harness.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover.
  • Electrode deposits or fouling.
  • Missing electrode.
  • Cracked insulator,
  • Electrode misalignment.
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the Coil Extension.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 spark plug.
  • Remove the cylinder 3 Coil Extension from the coil.

Action

Check the coil extension resistance.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Coil extension resistance between 1.1k and 1.7k ohms?
YES NO
No Repair

A damaged coil extension has been detected.

Replace the coil extension. Refer to Procedure 013-050 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Crank the engine or start the engine and let it idle.

Action

Check the ignition coil of cylinder 3.

  • Test the cylinder 3 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Refer to Procedure 013-012 in the Associated Procedures Table.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Sep-2015


FAULT CODE 6177 - Engine Ignition Coil #4 - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6177 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the Coil Extension. | Coil extension resistance between 1.1k and 1.7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6177 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect coil pack number 4 from the engine harness.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover.
  • Electrode deposits or fouling.
  • Missing electrode.
  • Cracked insulator.
  • Electrode misalignment.
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the Coil Extension.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 spark plug.
  • Remove the cylinder 4 coil extension from the coil

Action

Check the coil extension resistance.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Coil extension resistance between 1.1k and 1.7k ohms?
YES NO
No Repair

A damaged coil extension has been detected.

Replace the coil extension. Refer to Procedure 013-050 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Crank the engine or start the engine and let it idle.

Action

Check the ignition coil of cylinder 4.

  • Test the cylinder 4 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Refer to Procedure 013-012 in the Associated Procedures Table.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jul-2015


FAULT CODE 6181 - Engine Ignition Coil #5 - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6181 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the Coil Extension. | Coil extension resistance between 1.1k and 1.7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6181 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect coil pack number 5 from the engine harness.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover.
  • Electrode deposits or fouling.
  • Missing electrode.
  • Cracked insulator.
  • Electrode misalignment.
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the Coil Extension.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 spark plug.
  • Remove the cylinder 5 coil extension from the coil.

Action

Check the coil extension resistance.

  • Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Coil extension resistance between 1.1k and 1.7k ohms?
YES NO
No Repair

A damaged coil extension has been detected.

Replace the coil extension. Refer to Procedure 013-050 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Crank the engine or start the engine and let it idle.

Action

Check the ignition coil of cylinder 5.

  • Test the cylinder 5 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Refer to Procedure 013-012 in the Associated Procedures Table.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jul-2015


FAULT CODE 6184 - Engine Ignition Coil #6 - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Spark Plugs (Non Shielded) | Refer to Procedure 013-016 | B6.7 G CMOH6.0 B125 | 4383640
Coil Extension | Refer to Procedure 013-050 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6184 active?
STEP 2. | Check the ignition coil and spark plug. |
 | STEP 2A. Inspect the ignition coil and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the spark plug. | Spark plug damaged or excessive gap?
 | STEP 2C. Check the coil extension. | Coil extension resistance between 1.1k and 1.7k ohms?
 | STEP 2D. Check for voltage at the coil. | Steady spark observed?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine in the condition in which the misfire occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6184 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition coil and spark plug.

Guided Step 2A - Inspect the ignition coil and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect coil pack number 6 from the engine harness.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair and replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair and replace the engine harness. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 spark plug.

Action

Inspect the spark plug for the following:

  • Insulation flashover.
  • Electrode deposits or fouling.
  • Missing electrode.
  • Cracked insulator.
  • Electrode misalignment.
  • Correct spark plug gap.

Use the following procedure for information on the spark plugs. Refer to Procedure 013-016 in the Associated Procedures Table.

Spark plug damaged or excessive gap?
YES NO

Replace the damaged spark plug. Refer to Procedure 013-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the coil extension.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 spark plug.
  • Remove the cylinder 6 coil extension from the coil.

Action

Check the coil extension resistance.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Coil extension resistance between 1.1k and 1.7k ohms?
YES NO
No Repair

A damaged coil extension has been detected.

Replace coil extension. Refer to Procedure 013-050 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for voltage at the coil.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure. Refer to Procedure 013-012 in the Associated Procedures Table.
  • Crank the engine or start the engine and let it idle.

Action

Check the ignition coil of cylinder 6.

  • Test the cylinder 6 coil to determine if the plug is receiving voltage.
  • Use the Ignition Coil Test Kit, Part Number 4918343, to observe the spark in the observation window.

Refer to Procedure 013-012 in the Associated Procedures Table.

Steady spark observed?
YES NO
No Repair

A damaged coil has been detected.

Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

Go to 3A

Go to 3B

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 6185 - Engine Ignition Coil #1 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6185 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6185 inactive and Fault Code 6186 active?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 1.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the ignition coil 1 and ignition coil 2.
  • Turn keyswitch ON.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

  • Start the engine and operate the engine for at least one minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6185 inactive and Fault Code 6186 active?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Sep-2015


FAULT CODE 6186 - Engine Ignition Coil #2 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6186 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6185 active and Fault Code 6186 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 2.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the ignition coil 1 and ignition coil 2.
  • Turn keyswitch ON.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

  • Start the engine and operate the engine for at least one minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6185 active and Fault Code 6186 inactive?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Eengine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Jul-2015


FAULT CODE 6187 - Engine Ignition Coil #3 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6187 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6187 inactive and Fault Code 6188 active?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 3.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the ignition coil 3 and ignition coil 4.
  • Turn keyswitch ON.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

  • Start the engine and operate the engine for at least one minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6187 inactive and Fault Code 6188 active?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Eengine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Jul-2015


FAULT CODE 6188 - Engine Ignition Coil #4 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6188 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6187 active and Fault Code 6188 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6188 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 4.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the ignition coil 3 and ignition coil 4.
  • Turn keyswitch ON.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

  • Start the engine and operate the engine for at least one minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6187 active and Fault Code 6188 inactive?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Sep-2015


FAULT CODE 6189 - Engine Ignition Coil #5 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6189 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6189 inactive and Fault Code 6191 active?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6189 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 5.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the ignition coil 5 and ignition coil 6.
  • Turn keyswitch ON.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

  • Start the engine and operate the engine for at least one minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6189 inactive and Fault Code 6191 active?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Sep-2015


FAULT CODE 6191 - Engine Ignition Coil #6 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6191 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and ignition harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6189 active and Fault Code 6191 inactive?
STEP 3. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6191 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and ignition harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 6.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or engine harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the ignition coil 5 and ignition coil 6.
  • Turn keyswitch ON.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

  • Start the engine and operate the engine for at least 1 minute.
  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6189 active and Fault Code 6191 inactive?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Jul-2015


FAULT CODE 6192 - Engine Exhaust O2 Sensor Closed Loop Operation - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | B6.7 G CMOH6.0 B125 | 4383640
Overhead Set | Refer to Procedure 003-004 | B6.7 G CMOH6.0 B125 | 4383640
High Pressure Regulator, NG | Refer to Procedure 005-061 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Metering Valve | Refer to Procedure 005-242 | B6.7 G CMOH6.0 B125 | 4383640
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Intake Manifold Absolute Pressure and Temperature Sensor | Refer to Procedure 019-099 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640
Engine Gas Temperature/Pressure Sensor | Refer to Procedure 019-601 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Any active Fault Codes?
STEP 2. | Verify the Intake Manifold Absolute Pressure and Temperature Sensor accuracy. |
 | STEP 2A. Verify Intake Manifold Absolute Pressure reading. | Intake Manifold Absolute Pressure value is the same as Engine Intake Air Pressure sensor?
 | STEP 2B. Monitor intake manifold air temperature reading. | Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 3. | Verify the Engine Gas Temperature/Pressure Sensor accuracy. |
 | STEP 3A. Verify the Engine Gas Pressure reading. | Fuel pressure within 5 percent?
 | STEP 3B. Verify the Engine Gas temperature reading. | Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 4. | Calibrate the Oxygen (or Exhaust Gas) Sensor. |
 | STEP 4A. Calibrate the Oxygen (or Exhaust Gas) Sensor. | Fault code 6192 inactive?
STEP 5. | Check for air leaks in the air system. |
 | STEP 5A. Check for air leaks in the air intake system. | Air leaks?
 | STEP 5B. Check for air leaks in the exhaust system. | Exhaust leaks?
STEP 6. | Check the engine fuel system. |
 | STEP 6A. Check the fuel tank pressure or level. | Fuel tank pressure or level low?
 | STEP 6B. Check the fuel system connections from fuel tank to fuel control valve for leaks. | Fuel leaks?
 | STEP 6C. Check the fuel lines from fuel tank to fuel control valve for blocks and sharp bend. | Any blocks and sharp bend?
 | STEP 6D. Inspect the engine high pressure regulator. | Missing or damaged components?
 | STEP 6E. Check fuel filter for oil and clogging. | Evidence of oil and the fuel filter clogging?
 | STEP 6F. Check the injectors. | Evidence of injectors malfunctions?
 | STEP 6G. Clean the throttle. | Did the throttle function well?
STEP 7. | Check the engine intake valves. |
 | STEP 7A. Check the overhead set. | Overhead is set correctly?
 | STEP 7B. Check the intake valve for leakage. | Any leakage was found at all of the intake valves?
STEP 8. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Any active Fault Codes?
YES | NO
No Repair | No Repair

Troubleshooting all active Fault Codes.
See appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Verify the Intake Manifold Absolute Pressure and Temperature Sensor accuracy.

Guided Step 2A - Verify Intake Manifold Absolute Pressure reading.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the Intake Manifold Absolute Pressure and Temperature Sensor with Toolkit electronic service tool while the engine is not running.

  • Use Toolkit electronic service tool to compare Intake Manifold Absolute pressure to Engine Intake Air Pressure sensor.

NOTE: Toolkit electronic service tool may display Engine Intake Air Pressure as turbocharger compressor outlet pressure.

Intake Manifold Absolute Pressure value is the same as Engine Intake Air Pressure sensor?
YES NO
No Repair

A damaged sensor has been detected.

Repair and replace the sensor.

Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 2B

Go to 8A

Guided Step 2B - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use Toolkit electronic service tool to monitor the intake temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-099 in the Associated Procedures Table.

Go to 3A

Go to 8A

Guided Step 3 - Verify the Engine Gas Temperature/Pressure Sensor accuracy.

Guided Step 3A - Verify the Engine Gas Pressure reading.

Conditions

  • Turn keyswitch OFF.
  • Connect a mechanical gauge. Refer to Procedure 005-061 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify the fuel pressure.

  • Verify the fuel pressure measurement with a mechanical gauge against the fuel pressure measurement value displayed in Toolkit electronic service tool.

Engine gas temperature/pressure sensor pressure reading is displayed in Toolkit electronic service tool.

Fuel pressure within 5 percent?
YES NO
No Repair

Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 3B

Go to 8A

Guided Step 3B - Verify the Engine Gas temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the engine gas temperature/pressure sensor temperature reading.

  • Use Toolkit electronic service tool to monitor the Engine Gas temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-601 in the Associated Procedures Table.

Go to 4A

Go to 8A

Guided Step 4 - Calibrate the Oxygen (or Exhaust Gas) Sensor.

Guided Step 4A - Calibrate the Oxygen (or Exhaust Gas) Sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the Oxygen (or Exhaust Gas) Sensor calibration requirement meets.

  • Use Toolkit electronic service tool to perform the manual air calibration to Oxygen (or Exhaust Gas) Sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Fault code 6192 inactive?
YES | NO
No Repair | No Repair

Go to 8A

Go to 5A

Guided Step 5 - Check for air leaks in the air system.

Guided Step 5A - Check for air leaks in the air intake system.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks near all gasket surfaces between the throttle actuator and where the intake meets the block. Check all pipe plugs for leaks or missing components.

  • Start the engine and let it idle.
  • Listen for air leaks while engine is operating.

Air leaks?
YES NO

Locate all damaged gaskets or components and replace accordingly.

 No Repair

Go to 8A

Go to 5B

Guided Step 5B - Check for air leaks in the exhaust system.

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

Check for exhaust leaks.

Check for exhaust leaks at the turbocharger gasket, exhaust manifold gasket leaks, or leak upstream of the oxygen sensor in the exhaust stack.

Exhaust leaks?
YES NO

Repair or replace the leaking components.

 No Repair

Go to 8A

Go to 6A

Guided Step 6 - Check the engine fuel system.

Guided Step 6A - Check the fuel tank pressure or level.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel tank pressure or level.

  • Use the Original Equipment Manufacturer (OEM) pressure gauge to check the pressure or level of the fuel in the fuel tank.

Fuel tank pressure or level low?
YES NO

Low fuel tank pressure or level has been detected. Correct the low fuel pressure or level. See equipment manufacturer service information.

No Repair

Go to 8A

Go to 6B

Guided Step 6B - Check the fuel system connections from fuel tank to fuel metering valve for leaks.

Conditions

  • Turn keyswitch ON.

Action

Check for fuel leaks in the fuel system from fuel tank to fuel metering valve.

  • Check the fuel lines, and fuel connections for leaks.
  • Use a gas detector, Part Number 3823984, or a soap solution to check for leaks.

Fuel leaks?
YES NO

A leak has been detected in the fuel system. Turn the key to the OFF position, and repair leaks immediately. Repair or replace the leaking component.

No Repair

Go to 8A

Go to 6C

Guided Step 6C - Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel lines from fuel tank to fuel metering valve for blocks and sharp bend.

Any blocks and sharp bend?
YES NO

A blocked or sharp bend fuel line has been detected in the fuel system. Repair or replace the blocked or sharp bend fuel line.

 No Repair

Go to 8A

Go to 6D

Guided Step 6D - Inspect the engine high pressure regulator.

Conditions

  • Turn keyswitch OFF.
  • Remove the engine high pressure regulator. See equipment manufacturer service information for the specific removal and installation requirements.

Action

Inspect the engine high pressure regulator.

  • Refer to Procedure 005-061 in the Associated Procedures Table or see equipment manufacturer service information.

Missing or damaged components?
YES NO

Repair or replace the missing or damaged components.

See equipment manufacturer service information.

 No Repair

Go to 8A

Go to 6E

Guided Step 6E - Check fuel filter for oil and clogging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the fuel filter and check the fuel filter for oil in and clogging.

Refer to Procedure 006-015 in the Associated Procedures Table.

NOTE: Check the fuel filter for excess oil due to improper maintenance. If there is more than one ounce of oil in the fuel filter, there is a possibility that oil has contaminated the fuel system. The customer will need to check their gas compression station for oil carry over.

Evidence of oil and the fuel filter clogging?
YES NO

Replace the fuel filter.

Refer to Procedure 006-015 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6F

Guided Step 6F - Check the injectors.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Perform injector diagnostic test.

  • Use Toolkit electronic service tool to perform injector diagnostic test. Refer to Procedure 005-242 in the Associated Procedures Table.

Evidence of injectors malfunctions?
YES NO

Perform the injector cleaning procedure to clean the injectors. Use Toolkit electronic service tool to perform the injector cleaning process. Perform injector diagnostic test again after cleaning the injectors. If necessary, replace the malfunctioning injectors. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 6G

Guided Step 6G - Clean the throttle.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.
  • Turn keyswitch ON.

Action

Perform the engine throttle diagnostic test.

  • Use Toolkit electronic service tool to conduct the throttle diagnostic test and confirm the actuator is operational.

Did the throttle function well?
YES NO
No Repair

A stuck throttle has been detected.

Clean the throttle plate assembly.

Go to 7A

Go to 8A

Guided Step 7 - Check the engine intake valves.

Guided Step 7A - heck the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Refer to Procedure 003-004 in the Associated Procedures Table.

Action

Inspect the overhead set for all cylinders.

Refer to Procedure 003-004 in the Associated Procedures Table.

Overhead is set correctly?
YES NO
No Repair

Readjust the overhead.

Refer to Procedure 003-004 in the Associated Procedures Table.

Go to 7B

Go to 8A

Guided Step 7B - Check the intake valve for leakage.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder head. Refer to Procedure 002-004 in the Associated Procedures Table.

Action

Inspect the intake valve for leakage for all cylinders.

Refer to Procedure 002-004 in the Associated Procedures Table.

Any leakage was found at all of the intake valves?
YES NO

A damaged intake valve was detected.

Replace the damaged intake valve.

Refer to Procedure 002-004 in the Associated Procedures Table.

 No Repair

Go to 8A

Go to 8A

Guided Step 8 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Sep-2015


FAULT CODE 6194 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, or 3514 active?
 | STEP 1B. Check for an inactive fault codes. | Fault Code 6194 inactive?
STEP 2. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active Fault Codes 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, or 3514.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 177, 512, 513, 2189, 2519, 2643, 2644, 2752, 2812, or 3514 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for intermittent or inactive fault code.

Go to 1B

Guided Step 1B - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6194 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19 for intermittent or inactive fault code.

Go to 2A

Guided Step 2 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 6195 - Engine Knock 2 Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 6195 inactive?
STEP 2. | Check the Engine Knock sensor 2 and circuit. |
 | STEP 2A. Inspect the Engine Knock sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6196 active and Fault Code 6195 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 6195 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6195 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Engine Knock sensor 2 and circuit.

Guided Step 2A - Inspect the Engine Knock sensor 2 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Knock sensor 2 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Knock sensor 2 from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the Engine Knock sensor 2 SIGNAL pin and Engine Knock sensor 2 RETURN at the Engine Knock sensor 2 connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

  • Start the engine and let it idle

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6196 active and Fault Code 6195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Engine Knock sensor 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and let it idle.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6195 active?
YES NO

A damaged sensor has been detected.

Replace the Engine Knock sensor 2. Refer to Procedure 019-346 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or the engine harness connector B.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM B.
  • Disconnect the Engine Knock sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor 2 SIGNAL pin and the engine harness Engine Knock sensor 2 connector SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM B.
  • Disconnect the Engine Knock sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor 2 RETURN pin and the engine harness Engine Knock sensor 2 connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and let it idle.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6195 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jul-2015


FAULT CODE 6196 - Engine Knock 2 Sensor Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Knock Sensor | Refer to Procedure 019-346 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault codes. | Fault Code 6196 inactive?
STEP 2. | Check the Engine Knock sensor 2 and circuit. |
 | STEP 2A. Inspect the Engine Knock sensor 2 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 6195 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6196 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Engine Knock sensor 2 and circuit.

Guided Step 2A - Inspect the Engine Knock sensor 2 and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Knock sensor 2 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Engine Knock sensor 2 from the engine harness.
  • Disconnect the Engine Knock sensor 1 from the engine harness.
  • Connect the Engine Knock sensor 1 to the Engine Knock sensor 2 connector of the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

See the circuit diagram or the wiring diagram for connector pin identification.

Start the engine and let it idle.

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Engine Knock sensor 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and let it idle.

Check for the appropriate circuit response after30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6196 active?
YES NO

A damaged sensor has been detected.

Replace the Engine Knock sensor 2. Refer to Procedure 019-346 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or the engine harness connector B.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM B.
  • Disconnect the Engine Knock sensor 2 from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor 2 SIGNAL pin and the engine harness Engine Knock sensor 2 connector Return pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Engine Knock sensor 2 from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor 2 SINGNAL pin and all other pins in ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Engine Knock sensor 2 from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the engine harness ECM connector B Engine Knock sensor 2 RETURN pin and all other pins in ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6196 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jul-2015


FAULT CODE 6197 - Engine Ignition Coil #1 - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6197 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6197 inactive and Fault Code 6198 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 1 ohms?
 | STEP 3C. Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness. | Less than 1 ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 1 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6197 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6197 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 1.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the coil packs 1 and 2.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

Start the engine and operate the engine for at least 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6197 inactive and Fault Code 6198 active?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the engine harness from the ignition coil 1.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the primary coil cylinder 1 return pin in the engine harness ECM connector B and the primary coil cylinder 1 return pin in the engine harness coil pack 1 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Dsconnect the engine harness from the ignition coil.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the coil relay and the primary coil cylinder 1 POWER SUPPLY pin in the engine harness coil pack 1 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness or OEM harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the coil relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6197 active?
YES NO

Replace the coil relay.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2015


FAULT CODE 6198 - Engine Ignition Coil #2 - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6198 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6197 active and Fault Code 6198 inactive?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 1 ohms?
 | STEP 3C. Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness. | Less than 1 ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 1 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6198 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6198 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 2.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the coil packs 1 and 2.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

Start the engine and operate the engine for at least 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6197 active and Fault Code 6198 inactive?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the engine harness from the ignition coil 2.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the primary coil cylinder 2 return pin in the engine harness ECM connector B and the primary coil cylinder 2 return pin in the engine harness coil pack 2 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Dsconnect the engine harness from the ignition coil.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the coil relay and the primary coil cylinder 2 POWER SUPPLY pin in the engine harness coil pack 2 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness or OEM harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the coil relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6198 active?
YES NO

Replace the coil relay.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2015


FAULT CODE 6199 - Engine Ignition Coil #3 - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6199 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6199 inactive and Fault Code 6211 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 1 ohms?
 | STEP 3C. Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness. | Less than 1 ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 1 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6199 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6199 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 3.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the coil packs 3 and 4.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

Start the engine and operate the engine for at least 1 minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6199 inactive and Fault Code 6211 active?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the engine harness from the ignition coil 3.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the primary coil cylinder 3 return pin in the engine harness ECM connector B and the primary coil cylinder 3 return pin in the engine harness coil pack 3 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ignition coil 3.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the coil relay and the primary coil cylinder 3 POWER SUPPLY pin in the engine harness coil pack 3 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness or OEM harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the coil relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6199 active?
YES NO

Replace the coil relay.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2015


FAULT CODE 6211 - Engine Ignition Coil #4 - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6211 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6199 active and Fault Code 6211 inactive?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 1 ohms?
 | STEP 3C. Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness. | Less than 1 ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 1 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6211 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6211 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 4.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the coil packs 3 and 4.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6199 active and Fault Code 6211 inactive?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the engine harness from the ignition coil 4.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the primary coil cylinder 4 return pin in the engine harness ECM connector B and the primary coil cylinder 4 return pin in the engine harness coil pack 4 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ignition coil 4.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the coil relay and the primary coil cylinder 4 POWER SUPPLY pin in the engine harness coil pack 4 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness or OEM harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the coil relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6211 active?
YES NO

Replace the coil relay.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes..

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 6212 - Engine Ignition Coil #5 - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6212 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6212 inactive and Fault Code 6213 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 1 ohms?
 | STEP 3C. Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness. | Less than 1 ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 1 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6212 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6212 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 5.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the coil packs 5 and 6.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6212 inactive and Fault Code 6213 active?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the engine harness from the ignition coil 5.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the primary coil cylinder 5 return pin in the engine harness ECM connector B and the primary coil cylinder 5 return pin in the engine harness coil pack 5 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness and OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ignition coil 5.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the coil relay and the primary coil cylinder 5 POWER SUPPLY pin in the engine harness coil pack 5 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness or OEM harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the coil relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6212 active?
YES NO

Replace the coil relay.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check Engine Control Module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 6213 - Engine Ignition Coil #6 - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Ignition Coil (Non Shielded) | Refer to Procedure 013-012 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6213 active?
STEP 2. | Check the ignition system components. |
 | STEP 2A. Inspect the coil pack and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the ignition coil for proper operation. | Fault Code 6212 active and Fault Code 6213 inactive?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 1 ohms?
 | STEP 3C. Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness. | Less than 1 ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 1 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6213 active?
STEP 4. | Check Engine Control Module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6213 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ignition system components.

Guided Step 2A - Inspect the coil pack and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the coil pack 6.

Action

Inspect the engine harness and ignition coil connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ignition coil or ignition harness connectors.

Repair or replace the harness, or replace the ignition coil, whichever has the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ignition coil. Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the ignition coil for proper operation.

Conditions

  • Turn keyswitch OFF.
  • Swap the coil packs 5 and 6.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Refer to Procedure 013-012 in the Associated Procedures Table.

Action

Inspect the coils for damage. Do not swap the plug wires.

Start the engine and operate the engine for at least one minute.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6212 active and Fault Code 6213 inactive?
YES NO

A damaged ignition coil has been detected.

  • Replace the ignition coil.
  • Refer to Procedure 013-012 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

NOTE: Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Repair the harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector B from the ECM.
  • Disconnect the engine harness from the ignition coil 6.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the primary coil cylinder 6 return pin in the engine harness ECM connector B and the primary coil cylinder 6 return pin in the engine harness coil pack 6 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness and Original Equipment Manufacturer (OEM) harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ignition coil 6.

Action

Check for an open circuit in the engine harness and OEM harness.

  • Measure the resistance between POWER SUPPLY in Normal Open contact of the coil relay and the primary coil cylinder 6 POWER SUPPLY pin in the engine harness coil pack 6 connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness or OEM harness.

Repair or replace the engine harness or OEM harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Check for an open circuit in the OEM harness.

  • Measure the resistance between POWER SUPPLY pin on the coil relay and POWER SUPPLY wire on the Battery.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6213 active?
YES NO

Replace the coil relay.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Aug-2015


FAULT CODE 6214 - Hybrid System Fault - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool. |
 | STEP 1A. Check for ECM communication with the Toolkit electronic service tool. | Is communication between Toolkit electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 6214 active?
STEP 3. | Check the Hybrid controller and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine Hybrid controller is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the Hybrid controller multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | Between 50 ohms and 70 ohms?
STEP 5. | Check the harnesses. |
 | STEP 5A. Check the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the J1939 data link harness. | Between 110 ohms and 130 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 6214 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for Engine Control Module (ECM) communication with the Toolkit electronic service tool.

Guided Step 1A - Check for ECM communication with the Toolkit electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Verify Toolkit electronic service tool communication with the ECM.

Is communication between Toolkit electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect Toolkit electronic service tool.

Action

Check for an active fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6214 active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the Hybrid controller and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine Hybrid controller is enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper Hybrid controller multiplexing configuration component enable and Hybrid controller source addresses from the appropriate Hybrid system information.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Use Toolkit electronic service tool, check that the engine ECM multiplexed component enables and source addresses match the Hybrid controller multiplexed component enables and source addresses. This component can be found under Non-Hybrid ISG in Toolkit electronic service tool.

Does the ECM multiplexing configuration match the Hybrid controller multiplexing configuration?
YES NO

A Hybrid system issue has been detected.

Get more Hybrid system information for further repair instructions. It is still possible that there is a Hybrid controller, Hybrid controller setup, or Hybrid controller to data link connection issue.

An incorrect setup has been detected in the ECM.

Enable the proper Hybrid controller for multiplexing on the applicable Hybrid controller application and make sure the Hybrid controller source address are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 ohms and 70 ohms?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5A

Guided Step 5 - Check the harnesses.

Guided Step 5A - Check the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Inspect the ECM data link harness connector A pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the ECM has been detected in the J1939 data link connector or harness.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 110 ohms and 130 ohms?
YES NO
No Repair

An open or short circuit has been detected in the engine harness and/or OEM harness. Troubleshoot OEM harness and engine harness to determine which contains the open or short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the ECM connector A to all other pins in the ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness and/or the engine harness. Troubleshoot OEM harness and engine harness to determine which contains the short circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6214 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 6215 - O2 Sensor Power Relay Driver Control Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6218 or Fault Code 6219 active?
STEP 2. | Check the oxygen (or exhaust gas) sensor and circuit. |
 | STEP 2A. Inspect the oxygen (or exhaust gas) sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the oxygen (or exhaust gas) sensor. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | More than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6215 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6218 or Fault Code 6219 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Check the oxygen (or exhaust gas) sensor and circuit.

Guided Step 2A - Inspect the oxygen (or exhaust gas) sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor connector from the engine harness.

Action

Inspect the engine harness and oxygen (or exhaust gas) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the oxygen (or exhaust gas) sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.

Action

Check for a short circuit to ground in the oxygen (or exhaust gas) sensor.

  • Measure the resistance between the oxygen (or exhaust gas) sensor HEATER CONTROL pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B and C or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector C.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor HEATER CONTROL pin in the engine harness and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor HEATER CONTROL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6215 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 6216 - O2 Sensor Power Relay Driver Control Circuit - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6218 or Fault Code 6219 active?
STEP 2. | Check the oxygen (or exhaust gas) sensor and circuit. |
 | STEP 2A. Inspect the oxygen (or exhaust gas) sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short or open circuit in the oxygen (or exhaust gas) sensor heater circuit. | Between 2.4 to 4.0 ohms?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6216 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6218 or Fault Code 6219 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes.
See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Check the oxygen (or exhaust gas) sensor and circuit.

Guided Step 2A - Inspect the oxygen (or exhaust gas) sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor connector from the engine harness.

Action

Inspect the engine harness and oxygen (or exhaust gas) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short or open circuit in the oxygen (or exhaust gas) sensor heater circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.

Action

Check for a short or open circuit in the oxygen (or exhaust gas) sensor heater.

  • Measure the heater cold resistance on the oxygen (or exhaust gas) sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 2.4 to 4.0 ohms?
YES NO
No Repair

Replace the oxygen (or exhaust gas) sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B and C or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor POWER SUPPLY pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor POWER SUPPLY pin in the engine harness ECM connector B.
  • Measure the resistance between the oxygen (or exhaust gas) sensor HEATER CONTROL pin at the engine harness oxygen (or exhaust gas) sensor connector and the oxygen (or exhaust gas) sensor HEATER CONTROL pin in the engine harness ECM connector C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oxygen (or exhaust gas) sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B, and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the oxygen (or exhaust gas) sensor HEATER CONTROL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B, and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine hanress. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6216 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 6217 - O2 Sensor Power Relay Driver Control Circuit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6215, 6216, 6218 or 6219 active?
STEP 2. | Check the Oxygen (or Exhaust Gas) Sensor and circuit. |
 | STEP 2A. Inspect the Oxygen (or Exhaust Gas) Sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short or open circuit in the Oxygen (or Exhaust Gas) Sensor Heater circuit. | Between 2.4 to 4.0 ohms?
 | STEP 2C. Check for a short circuit to ground in the Oxygen (or Exhaust Gas) Sensor. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the engine harness. | More than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6217 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6215, 6216, 6218 or 6219 active?
YES | NO
No Repair | No Repair

Troubleshooting active fault codes. See active fault code troubleshooting trees.

Go to 2A

Guided Step 2 - Check the Oxygen (or Exhaust Gas) Sensor and circuit.

Guided Step 2A - Inspect the Oxygen (or Exhaust Gas) Sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor connector from the engine harness.

Action

Inspect the engine harness and Oxygen (or Exhaust Gas) Sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short or open circuit in the Oxygen (or Exhaust Gas) Sensor Heater circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.

Action

Check for a short or open circuit in the Oxygen (or Exhaust Gas) Sensor Heater.

  • Measure the Heater cold resistance on the Oxygen (or Exhaust Gas) Sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 2.4 to 4.0 ohms?
YES NO
No Repair

Replace the Oxygen (or Exhaust Gas) Sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the Oxygen (or Exhaust Gas) Sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.

Action

Check for a short circuit to ground in the Oxygen (or Exhaust Gas) Sensor.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor HEATER CONTROL pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Oxygen (or Exhaust Gas) Sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B and C or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor POWER SUPPLY pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor POWER SUPPLY pin in the engine harness ECM connector B.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor HEATER CONTROL pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor HEATER CONTROL pin in the engine harness ECM connector C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor HEATER CONTROL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector C.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor HEATER CONTROL pin in the engine harness ECM connector C and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6217 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 6218 - O2 Sensor Power Relay Driver Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6218 inactive?
STEP 2. | Check the Oxygen (or Exhaust Gas) Sensor and circuit. |
 | STEP 2A. Inspect the Oxygen (or Exhaust Gas) Sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6218 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6218 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Oxygen (or Exhaust Gas) Sensor and circuit.

Guided Step 2A - Inspect the Oxygen (or Exhaust Gas) Sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor connector from the engine harness.

Action

Inspect the engine harness and Oxygen (or Exhaust Gas) Sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor ENGINE ACTUAL EXHAUST OXYGEN Signal pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor ENGINE ACTUAL EXHAUST OXYGEN Signal pin in the engine harness ECM connector B.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor Trim Resistor SIGNAL pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor Trim Resistor SIGNAL pin in the engine harness ECM connector B.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor RETURN pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor RETURN pin in the engine harness ECM connector B.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor Pumping Current SIGNAL pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor Pumping Current SIGNAL pin in the engine harness ECM connector B.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor ENGINE ACTUAL EXHAUST OXYGEN Signal pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor Trim Resistor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor RETURN pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor Pumping Current SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6218 inactive?
YES NO
No Repair

Replace the Oxygen (or Exhaust Gas) Sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

If the Fault Code 6218 is still active after replacing the Oxygen (or Exhaust Gas) Sensor.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 6219 - O2 Sensor Power Relay Driver Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6219 inactive?
STEP 2. | Check the Oxygen (or Exhaust Gas) Sensor and circuit. |
 | STEP 2A. Inspect the Oxygen (or Exhaust Gas) Sensor connector pins. | Dirty or damaged pins?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6219 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6219 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Oxygen (or Exhaust Gas) Sensor and circuit.

Guided Step 2A - Inspect the Oxygen (or Exhaust Gas) Sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor connector from the engine harness.

Action

Inspect the engine harness and Oxygen (or Exhaust Gas) Sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damag
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B.

Action

Inspect the engine harness and ECM connector B pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor ENGINE ACTUAL EXHAUST OXYGEN Signal pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor ENGINE ACTUAL EXHAUST OXYGEN Signal pin in the engine harness ECM connector B.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor Trim Resistor SIGNAL pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor Trim Resistor SIGNAL pin in the engine harness ECM connector B.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor RETURN pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor RETURN pin in the engine harness ECM connector B.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor Pumping Current SIGNAL pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor Pumping Current SIGNAL pin in the engine harness ECM connector B.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor ENGINE ACTUAL EXHAUST OXYGEN Signal pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor Trim Resistor SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor RETURN pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor Pumping Current SIGNAL pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6219 inactive?
YES NO
No Repair

Replace the Oxygen (or Exhaust Gas) Sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

If the Fault Code 6218 is still active after replacing the Oxygen (or Exhaust Gas) Sensor.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 6221 - Turbocharger 1 Compressor Intake Temperature - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Humidity Sensor | Refer to Procedure 019-356 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 6221 inactive?
STEP 2. | Check the Humidity sensor and circuit. |
 | STEP 2A. Inspect the Humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6222 active and Fault Code 6221 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 6221 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector C pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 6222 active and Fault Code 6221 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6221 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6221 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Humidity sensor and circuit.

Guided Step 2A - Inspect the Humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Humidity sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the Humidity sensor TEMPERATURE SIGNAL pin and Humidity sensor RETURN pin at the engine harness Humidity sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

See the circuit diagram or wiring diagram for connector pin identification.

Fault Code 6222 active and Fault Code 6221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6221 active?
YES NO

A damaged sensor has been detected.

Replace the Humidity. Refer to Procedure 019-356 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector C or the engine harness connector C.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the Humidity sensor TEMPERATURE SIGNAL pin and Humidity sensor RETURN pin at the ECM connector C.

See the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6222 active and Fault Code 6221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the Humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C Humidity sensor RETURN pin and the engine harness Humidity sensor connector RETURN pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the Humidity sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector C Humidity sensor TEMPERATURE SIGNAL pin and the engine harness Humidity sensor connector TEMPERATURE SIGNAL pin.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the Humidity sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Aug-2015


FAULT CODE 6222 - Turbocharger 1 Compressor Intake Temperature - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Humidity Sensor | Refer to Procedure 019-356 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 6222 inactive?
STEP 2. | Check the Humidity sensor and circuit. |
 | STEP 2A. Inspect the Humidity sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6221 active and Fault Code 6222 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 6222 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector C pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 6221 active and Fault Code 6222 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 6222 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Humidity sensor and circuit.

Guided Step 2A - Inspect the Humidity sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Humidity sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Humidity sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6221 active and Fault Code 6222 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the Humidity sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6222 active?
YES NO

A damaged sensor has been detected.

Replace the Humidity sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector C pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector C.

Clean the connector C and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6221 active and Fault Code 6222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the Humidity sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.
  • Disconnect the Humidity sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the Humidity sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6222 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jul-2015


FAULT CODE 6223 - Turbocharger 1 Compressor Intake Temperature - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Humidity Sensor | Refer to Procedure 019-356 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 6223 inactive?
 | STEP 1B. Monitor Humidity Sensor temperature reading. | Temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check the Humidity Sensor and circuit. |
 | STEP 2A. Inspect the Humidity Sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 6221 active?
 | STEP 2C. Check the circuit response. | Fault Code 6222 active?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 6223 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for an inactive fault code.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6223 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Monitor Humidity Sensor temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Monitor the Humidity Sensor temperature reading.

  • Use Toolkit electronic service tool to monitor the Humidity Sensor temperature value.
  • Compare the temperature reading with Toolkit electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with Toolkit electronic service tool correlate to a known value or a mechanical gauge?
YES NO
No Repair

Replace the Humidity Sensor. Refer to Procedure 019-019 in the Associated Procedures Table

Go to 2A

Go to 4A

Guided Step 2 - Check the Humidity Sensor and circuit.

Guided Step 2A - Inspect the Humidity Sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Humidity sensor from the engine harness.

Action

Inspect the engine harness and Humidity Sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Humidity Sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6221 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Humidity Sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Place a jumper wire between the Humidity Sensor temperature SIGNAL pin and the Humidity Sensor RETURN pin at the Humidity Sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6222 active?
YES NO

Replace the Humidity Sensor. Refer to Procedure 019-356 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector C.

Action

Inspect the engine harness and ECM connector C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector A, B and C.
  • Disconnect the Humidity sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the Humidity sensor TEMPERATURE SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the TEMPERATURE SIGNAL wire has been detected in the engine harness

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Operate the engine in the condition in which the fault occurred.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6223 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jul-2015


FAULT CODE 6225 - O2 Sensor Power Relay Driver Control Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module | Refer to Procedure 019-031 | B6.7 G CMOH6.0 B125 | 4383640
Engine Control Module Calibration Code | Refer to Procedure 019-032 | B6.7 G CMOH6.0 B125 | 4383640
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 G CMOH6.0 B125 | 4383640
Heated Oxygen Sensor | Refer to Procedure 019-100 | B6.7 G CMOH6.0 B125 | 4383640

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6225 inactive?
STEP 2. | Check the Oxygen (or Exhaust Gas) Sensor and circuit. |
 | STEP 2A. Inspect the Oxygen (or Exhaust Gas) Sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short or open circuit in the Oxygen (or Exhaust Gas) Sensor Heater circuit. | Between 2.4 to 4.0 ohms?
 | STEP 2C. Check for a short circuit in the Oxygen (or Exhaust Gas) Sensor. | More than 100k ohms?
STEP 3. | Check the Engine Control Module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6225 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for active fault codes.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6225 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the Oxygen (or Exhaust Gas) Sensor and circuit.

Guided Step 2A - Inspect the Oxygen (or Exhaust Gas) Sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor connector from the engine harness.

Action

Inspect the engine harness and Oxygen (or Exhaust Gas) Sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short or open circuit in the Oxygen (or Exhaust Gas) Sensor Heater circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.

Action

Check for a short or open circuit in the Oxygen (or Exhaust Gas) Sensor Heater.

  • Measure the Heater cold resistance on the Oxygen (or Exhaust Gas) Sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Between 2.4 to 4.0 ohms?
YES NO
No Repair

Replace the Oxygen (or Exhaust Gas) Sensor. Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit in the Oxygen (or Exhaust Gas) Sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.

Action

Check for a short circuit to ground in the Oxygen (or Exhaust Gas) Sensor.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor (+) pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Replace the Oxygen (or Exhaust Gas) Sensor.

Refer to Procedure 019-100 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the Engine Control Module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Inspect the engine harness and ECM connector B and C pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector B and C or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector B and C.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor POWER SUPPLY pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor POWER SUPPLY pin in the engine harness ECM connector B.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor SIGNAL pin at the engine harness Oxygen (or Exhaust Gas) Sensor connector and the Oxygen (or Exhaust Gas) Sensor SIGNAL pin in the engine harness ECM connector C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Oxygen (or Exhaust Gas) Sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector A, B and C.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor POWER SUPPLY pin in the engine harness ECM connector B and all other pins in the engine harness ECM connector A, B and C.
  • Measure the resistance between the Oxygen (or Exhaust Gas) Sensor SIGNAL pin in the engine harness ECM connector C and all other pins in the engine harness ECM connector A, B and C.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect Toolkit electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use Toolkit electronic service tool to read the fault codes.

Fault Code 6225 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Compare the SID file and wapp file revision numbers in the ECM with the latest files revision.

  • Use Toolkit electronic service tool to find the present ECM SID file revision number and wapp file revision number in the ECM.

If a Subsystem Identification Descriptions (SID) file and/or wapp file update for this fault code is available, does the ECM contain that revisions or higher?

YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Toolkit electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Aug-2015


INDEX
392-fc122.htm

392-t05-122.htm

392-fc123.htm

392-t05-123.htm

392-fc131.htm

392-t05-131.htm

392-fc132.htm

392-t05-132.htm

392-fc135.htm

392-t05-135.htm

392-fc141.htm

392-t05-141.htm

392-fc144.htm

392-t05-144.htm

392-fc145.htm

392-t05-145.htm

392-fc151.htm

392-t05-151.htm

392-fc153.htm

392-t05-153.htm

392-fc154.htm

392-t05-154.htm

392-fc155.htm

392-t05-155.htm

392-fc177.htm

392-t05-177.htm

392-fc187.htm

392-t05-187.htm

392-fc221.htm

392-t05-221.htm

392-fc222.htm

392-t05-222.htm

392-fc227.htm

392-t05-227.htm

392-fc234.htm

392-t05-234.htm

392-fc241.htm

392-t05-241.htm

392-fc242.htm

392-t05-242.htm

392-fc258.htm

392-t05-258.htm

392-fc311.htm

392-t05-311.htm

392-fc312.htm

392-t05-312.htm

392-fc313.htm

392-t05-313.htm

392-fc314.htm

392-t05-314.htm

392-fc315.htm

392-t05-315.htm

392-fc321.htm

392-t05-321.htm

392-fc322.htm

392-t05-322.htm

392-fc334.htm

392-t05-334.htm

392-fc352.htm

392-t05-352.htm

392-fc386.htm

392-t05-386.htm

392-fc415.htm

392-t05-415.htm

392-fc436.htm

392-t05-436.htm

392-fc442.htm

392-t05-442.htm

392-fc495.htm

392-t05-495.htm

392-fc512.htm

392-t05-512.htm

392-fc513.htm

392-t05-513.htm

392-fc587.htm

392-t05-587.htm

392-fc771.htm

392-t05-771.htm

392-fc783.htm

392-t05-783.htm

392-fc1443.htm

392-t05-1443.htm

392-fc1754.htm

392-t05-1754.htm

392-fc1755.htm

392-t05-1755.htm

392-fc1765.htm

392-t05-1765.htm

392-fc1766.htm

392-t05-1766.htm

392-fc1992.htm

392-t05-1992.htm

392-fc2189.htm

392-t05-2189.htm

392-fc2191.htm

392-t05-2191.htm

392-fc2519.htm

392-t05-2519.htm

392-fc2643.htm

392-t05-2643.htm

392-fc2644.htm

392-t05-2644.htm

392-fc2661.htm

392-t05-2661.htm

392-fc2752.htm

392-t05-2752.htm

392-fc2768.htm

392-t05-2768.htm

392-fc2793.htm

392-t05-2793.htm

392-fc2812.htm

392-t05-2812.htm

392-fc2973.htm

392-t05-2973.htm

392-fc2994.htm

392-t05-2994.htm

392-fc3159.htm

392-t05-3159.htm

392-fc3161.htm

392-t05-3161.htm

392-fc3357.htm

392-t05-3357.htm

392-fc3514.htm

392-t05-3514.htm

392-fc3551.htm

392-t05-3551.htm

392-fc3841.htm

392-t05-3841.htm

392-fc3846.htm

392-t05-3846.htm

392-fc3971.htm

392-t05-3971.htm

392-fc4811.htm

392-t05-4811.htm

392-fc4812.htm

392-t05-4812.htm

392-fc4813.htm

392-t05-4813.htm

392-fc4814.htm

392-t05-4814.htm

392-fc4815.htm

392-t05-4815.htm

392-fc4816.htm

392-t05-4816.htm

392-fc5213.htm

392-t05-5213.htm

392-fc5249.htm

392-t05-5249.htm

392-fc5251.htm

392-t05-5251.htm

392-fc5957.htm

392-t05-5957.htm

392-fc5958.htm

392-t05-5958.htm

392-fc5959.htm

392-t05-5959.htm

392-fc5961.htm

392-t05-5961.htm

392-fc5962.htm

392-t05-5962.htm

392-fc5963.htm

392-t05-5963.htm

392-fc5965.htm

392-t05-5965.htm

392-fc5966.htm

392-t05-5966.htm

392-fc5969.htm

392-t05-5969.htm

392-fc5971.htm

392-t05-5971.htm

392-fc5972.htm

392-t05-5972.htm

392-fc5974.htm

392-t05-5974.htm

392-fc5977.htm

392-t05-5977.htm

392-fc5978.htm

392-t05-5978.htm

392-fc5982.htm

392-t05-5982.htm

392-fc5984.htm

392-t05-5984.htm

392-fc5985.htm

392-t05-5985.htm

392-fc5986.htm

392-t05-5986.htm

392-fc5987.htm

392-t05-5987.htm

392-fc5988.htm

392-t05-5988.htm

392-fc5989.htm

392-t05-5989.htm

392-fc5991.htm

392-t05-5991.htm

392-fc5992.htm

392-t05-5992.htm

392-fc5993.htm

392-t05-5993.htm

392-fc5994.htm

392-t05-5994.htm

392-fc5995.htm

392-t05-5995.htm

392-fc5996.htm

392-t05-5996.htm

392-fc5997.htm

392-t05-5997.htm

392-fc5998.htm

392-t05-5998.htm

392-fc5999.htm

392-t05-5999.htm

392-fc6111.htm

392-t05-6111.htm

392-fc6112.htm

392-t05-6112.htm

392-fc6113.htm

392-t05-6113.htm

392-fc6114.htm

392-t05-6114.htm

392-fc6115.htm

392-t05-6115.htm

392-fc6116.htm

392-t05-6116.htm

392-fc6117.htm

392-t05-6117.htm

392-fc6118.htm

392-t05-6118.htm

392-fc6119.htm

392-t05-6119.htm

392-fc6121.htm

392-t05-6121.htm

392-fc6122.htm

392-t05-6122.htm

392-fc6123.htm

392-t05-6123.htm

392-fc6124.htm

392-t05-6124.htm

392-fc6125.htm

392-t05-6125.htm

392-fc6126.htm

392-t05-6126.htm

392-fc6127.htm

392-t05-6127.htm

392-fc6128.htm

392-t05-6128.htm

392-fc6129.htm

392-t05-6129.htm

392-fc6131.htm

392-t05-6131.htm

392-fc6132.htm

392-t05-6132.htm

392-fc6133.htm

392-t05-6133.htm

392-fc6134.htm

392-t05-6134.htm

392-fc6135.htm

392-t05-6135.htm

392-fc6136.htm

392-t05-6136.htm

392-fc6137.htm

392-t05-6137.htm

392-fc6138.htm

392-t05-6138.htm

392-fc6139.htm

392-t05-6139.htm

392-fc6141.htm

392-t05-6141.htm

392-fc6142.htm

392-t05-6142.htm

392-fc6143.htm

392-t05-6143.htm

392-fc6144.htm

392-t05-6144.htm

392-fc6145.htm

392-t05-6145.htm

392-fc6147.htm

392-t05-6147.htm

392-fc6148.htm

392-t05-6148.htm

392-fc6149.htm

392-t05-6149.htm

392-fc6151.htm

392-t05-6151.htm

392-fc6152.htm

392-t05-6152.htm

392-fc6153.htm

392-t05-6153.htm

392-fc6154.htm

392-t05-6154.htm

392-fc6155.htm

392-t05-6155.htm

392-fc6156.htm

392-t05-6156.htm

392-fc6157.htm

392-t05-6157.htm

392-fc6158.htm

392-t05-6158.htm

392-fc6159.htm

392-t05-6159.htm

392-fc6161.htm

392-t05-6161.htm

392-fc6162.htm

392-t05-6162.htm

392-fc6163.htm

392-t05-6163.htm

392-fc6164.htm

392-t05-6164.htm

392-fc6167.htm

392-t05-6167.htm

392-fc6171.htm

392-t05-6171.htm

392-fc6174.htm

392-t05-6174.htm

392-fc6177.htm

392-t05-6177.htm

392-fc6181.htm

392-t05-6181.htm

392-fc6184.htm

392-t05-6184.htm

392-fc6185.htm

392-t05-6185.htm

392-fc6186.htm

392-t05-6186.htm

392-fc6187.htm

392-t05-6187.htm

392-fc6188.htm

392-t05-6188.htm

392-fc6189.htm

392-t05-6189.htm

392-fc6191.htm

392-t05-6191.htm

392-fc6192.htm

392-t05-6192.htm

392-fc6194.htm

392-t05-6194.htm

392-fc6195.htm

392-t05-6195.htm

392-fc6196.htm

392-t05-6196.htm

392-fc6197.htm

392-t05-6197.htm

392-fc6198.htm

392-t05-6198.htm

392-fc6199.htm

392-t05-6199.htm

392-fc6211.htm

392-t05-6211.htm

392-fc6212.htm

392-t05-6212.htm

392-fc6213.htm

392-t05-6213.htm

392-fc6214.htm

392-t05-6214.htm

392-fc6215.htm

392-t05-6215.htm

392-fc6216.htm

392-t05-6216.htm

392-fc6217.htm

392-t05-6217.htm

392-fc6218.htm

392-t05-6218.htm

392-fc6219.htm

392-t05-6219.htm

392-fc6221.htm

392-t05-6221.htm

392-fc6222.htm

392-t05-6222.htm

392-fc6223.htm

392-t05-6223.htm

392-fc6225.htm

392-t05-6225.htm