QSK23 CM2250 K109

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Timing Actuator Driver Circuit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 112

Engine Timing Actuator Driver Circuit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 112 PID: S20 SPN: 635 FMI: 7/7 LAMP: Red SRT: | Engine Timing Actuator Driver Circuit - Mechanical System Not Responding or Out of Adjustment. The timing rail actuator is not closing when commanded. | Possible reduced engine performance.
Engine Timing Actuator Driver Circuit

Circuit Description

The Engine Control Module (ECM) uses the timing rail actuator to control fuel injection timing. The ECM opens the timing rail actuator allowing engine oil to pressurize the timing rail and advance the fuel injection timing. When normal fuel injection timing is desired the ECM closes the timing rail actuator and oil pressure in the timing rail will bleed down. The timing rail actuator is normally closed.

Component Location

The timing rail actuator is located on the electronic control valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the timing rail actuator is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for all injectors.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

Perform a key cycle and use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning timing rail actuator.
Refer to Troubleshooting Fault Code 112.

Last Modified: 15-Jul-2015
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Engine Timing Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 113

Engine Timing Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 113 PID: S20 SPN: 635 FMI: 3/3 LAMP: Amber SRT: | Engine Timing Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the timing rail actuator circuit. | Possible reduced engine performance.
Timing Rail Actuator Circuit

Circuit Description

The Engine Control Module (ECM) uses the timing rail actuator to control fuel injection timing. The ECM opens the timing rail actuator allowing fuel to pressurize the timing rail and advance the fuel injection timing. The timing rail actuator is normally closed.

Component Location

The timing rail actuator is located on the electronic control valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the pulse width modulated (PWM) signal voltage was greater than 0-VDC when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM may not be able to control actuator position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.

Shop Talk

Fault Code 112 or Fault Code 114 can also be logged.

Possible causes of this fault code include.

•Open return or signal circuit in the harness, connectors, or sensor

Short circuit to voltage source in the engine harness.

  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 113.

Last Modified: 15-Jul-2015


Engine Timing Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 114

Engine Timing Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 114 PID: S20 SPN: 635 FMI: 4/4 LAMP: Amber SRT: | Engine Timing Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the timing rail actuator circuit when commanded ON. | Possible reduced engine performance.
Timing Rail Actuator Circuit

Circuit Description

The Engine Control Module (ECM) uses the timing rail actuator to control fuel injection timing. The ECM opens the timing rail actuator allowing fuel to pressurize the timing rail and advance the fuel injection timing. The timing rail actuator is normally closed.

Component Location

The timing rail actuator is located on the electronic control valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs when the timing rail actuator is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the pulse width modulated (PWM) signal voltage was not at system voltage when the PWM signal was turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the harness or actuator.
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 114.

Last Modified: 15-Jul-2015


Injector Timing Rail 1 Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 116

Injector Timing Rail 1 Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 116 PID: P156 SPN: 156 FMI: 3/3 LAMP: Red SRT: | Injector Timing Rail 1 Pressure Sensor Circuit Voltage Above Normal or Shorted to High Source. High signal voltage detected at the timing rail pressure sensor circuit. | The engine will operate in Limp Home mode.
Injector Timing Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the timing rail pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The timing rail pressure sensor provides a signal to the ECM on the timing rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel timing rail.

Component Location

The timing rail pressure sensor is located on the electronic control valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel timing pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the 5 Volt supply wire
  • Open circuit on the signal wire
  • Open circuit on the return wire
  • Malfunctioning sensor

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 116.

Last Modified: 15-Jul-2015


Injector Timing Rail 1 Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 117

Injector Timing Rail 1 Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 117 PID: P156 SPN: 156 FMI: 4/4 LAMP: Red SRT: | Injector Timing Rail 1 Pressure Sensor Circuit Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the timing rail pressure sensor circuit. | The engine will operate in Limp Home mode.
Injector Timing Rail 1 Fuel Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the timing rail pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The timing rail pressure sensor provides a signal to the ECM on the timing rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel timing rail.

Component Location

The timing rail pressure sensor is located on the electronic control valve assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

  • Supply or signal wire is shorted to ground.
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code 117.

Last Modified: 15-Jul-2015


Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

FAULT CODE 121

Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10/10 LAMP: Amber SRT: | Engine Speed/Position Sensor Circuit - Lost One of Two Signals from the Magnetic Pickup Sensor - Abnormal Rate of Change. No engine speed signal detected from either the main or backup speed sensors. | None on performance.
Engine Speed Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • To validate the repair, start the engine and let it idle for 1 minute.

Shop Talk

Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Refer to Troubleshooting Fault Code 121.

Last Modified: 15-Jul-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold pressure sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 122.

Last Modified: 17-Jul-2015


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold pressure sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 123.

Last Modified: 17-Jul-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 135.

Last Modified: 13-Jul-2015


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141.

Last Modified: 13-Jul-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143.

Last Modified: 23-Jul-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144.

Last Modified: 13-Jul-2015


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145.

Last Modified: 13-Jul-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

Refer to Troubleshooting Fault Code 146.

Last Modified: 23-Jul-2015


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151.

Last Modified: 13-Jul-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | None on performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold temperature sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153.

Last Modified: 17-Jul-2015


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | None on performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold temperature sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154.

Last Modified: 17-Jul-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | The engine will shut down or will not start.
Intake Manifold Temperature Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold temperature sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155.

Last Modified: 17-Jul-2015


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 187.

Last Modified: 15-Jul-2015


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code 195.

Last Modified: 15-Jul-2015


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connector, sensor
  • Signal circuit shorted to ground in the harness, sensor or connectors
  • Damaged sensor.
Refer to Troubleshooting Fault Code 196.

Last Modified: 15-Jul-2015


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 197.

Last Modified: 23-Jul-2015


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | None on performance.
Barometric Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors the ambient air pressure using either an ambient air pressure sensor or a combination turbocharger compressor intake pressure/temperature sensor. These sensors respond to pressure changes in the atmosphere, which occur based on the elevation where the engine is currently operating. This pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The ambient air or compressor intake pressure sensor provides a signal to the ECM on the pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple fault codes.

Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 221.

Last Modified: 15-Jul-2015


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | None on performance.
Barometric Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors the ambient air pressure using either an ambient air pressure sensor or a combination turbocharger compressor intake pressure/temperature sensor. These sensors respond to pressure changes in the atmosphere, which occur based on the elevation where the engine is currently operating. This pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The ambient air or compressor intake pressure sensor provides a signal to the ECM on the pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 222.

Last Modified: 15-Jul-2015


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 223

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 223 PID: S85 SPN: 1265 FMI: 4/4 LAMP: Amber SRT: | Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the Centinel oil control valve circuit. | Centinel system will be inoperational.
Centinel Oil Control Valve Circuit

Circuit Description

The engine control module (ECM) uses the Centinel oil control valve to regulate the amount of used oil that is removed from the engine and sent to a waste oil tank. Depending on application setup, the oil control valve can also circulate fresh oil into the engine.

Component Location

The Centinel oil control valve is usually located on the left rear of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Centinel oil control valve signal was not at system voltage when the driver was turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a keycycle, start the engine and perform the Centinel Operational Test using Insite electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground or return.
  • A malfunctioning Centinel oil control valve solenoid.
Refer to Troubleshooting Fault Code 223.

Last Modified: 15-Jul-2015


Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 224

Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 224 PID: S85 SPN: 1265 FMI: 3/3 LAMP: Amber SRT: | Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the Centinel oil control valve circuit. | Centinel system will be inoperational.
Centinel Oil Control Valve Circuit

Circuit Description

The engine control module (ECM) uses the Centinel oil control valve to regulate the amount of used oil that is removed from the engine and sent to a waste oil tank. Depending on application setup, the oil control valve can also circulate fresh oil into the engine.

Component Location

The Centinel oil control valve is usually located on the left rear of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the Centinel oil control valve is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Centinel oil control valve was at system voltage when the driver was OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a keycycle, start the engine and perform the Centinel Operational Test using Insite electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit or shorted to a voltage source.
  • A malfunctioning Centinel oil control valve solenoid.
Refer to Troubleshooting Fault Code 224.

Last Modified: 15-Jul-2015


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | None on performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 15-Jul-2015


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Possible reduced engine performance.
Engine Speed Sensor 1 and 2 Circuits

Circuit Description

The engine speed sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the speed sensor and a return circuit. As the teeth on the crankshaft speed ring move past the speed sensor, a signal is generated on the speed sensor signal circuit. The ECM interprets this signal and converts it to an engine speed.

Component Location

The engine speed sensors are located at the rear of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 234.

Last Modified: 15-Jul-2015


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant is severely low. | Engine will be shut down.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was greater than 3-VDC for more than 30 seconds, indicating severely low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Refer to Troubleshooting Fault Code 235.

Last Modified: 15-Jul-2015


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed sensor.

Component Location

Sensor Supply 3 originates in the engine wiring harness. It provides 5 VDC to the engine speed sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238.

Last Modified: 15-Jul-2015


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed sensor.

Component Location

Sensor Supply 3 originates in the engine wiring harness. It provides 5 VDC to the engine speed sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 13-Jul-2015


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at fuel shutoff valve circuit | The engine will shut down or will not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

The fuel shutoff valve is located in the fuel control block.

Conditions for Running the Diagnostics

This diagnostic runs when the fuel shutoff valve is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the pulse width modulated (PWM) signal voltage was not at system voltage when the PWM signal was turned ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the harness or actuator.
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 254.

Last Modified: 15-Jul-2015


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S17 SPN: 632 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or short to voltage source detected at fuel shutoff valve circuit. | Engine may not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

The fuel shutoff valve is located in the fuel control block.

Conditions for Running the Diagnostics

This diagnostic runs when the fuel shutoff valve is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the pulse width modulated (PWM) signal voltage was greater than 0-VDC when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open circuit in the engine harness, connectors, or actuator.

Short circuit to voltage source in the engine harness.

  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 255.

Last Modified: 15-Jul-2015


Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 257

Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 257 PID: S17 SPN: 632 FMI: 7/7 LAMP: Amber SRT: | Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding or Out of Adjustment. The fuel shutoff valve is stuck open. | None on performance.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

The fuel shutoff valve is located in the fuel control block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the keyswitch was turned OFF but the engine did not shut down or shut down too slowly when the fuel shutoff valve was de-energized.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The ECM will shut down the engine using the fuel rail actuator.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel shutoff valve.
Refer to Troubleshooting Fault Code 257.

Last Modified: 15-Jul-2015


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 261

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: P174 SPN: 174 FMI: 0/16 LAMP: Amber SRT: | Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Fuel temperature above the warning level has been detected. | Engine power derate.
Engine Fuel Property Sensor Circuit

Circuit Description

The fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel entering the high pressure pump. The engine control module (ECM) supplies 5 volts to the fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature exceeded the warning limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Operating the engine in a hot ambient environment with a low fuel tank level
Refer to Troubleshooting Fault Code 261.

Last Modified: 15-Jul-2015


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the engine fuel temperature circuit. | Possible reduced engine performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

Possible causes for this fault code include:

Possible causes for this fault code include:

  • Open circuit in the wiring harness
Refer to Troubleshooting Fault Code 263.

Last Modified: 15-Jul-2015


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine fuel temperature sensor circuit. | Possible reduced engine performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle. If, after the engine idles for 10 minutes, the fault code is still not active, the repair has been validated.

Shop Talk

Possible causes for this fault code include:

  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 265.

Last Modified: 15-Jul-2015


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 266

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 266 PID: P174 SPN: 174 FMI: 0/0 LAMP: Red SRT: | Engine Fuel Temperature - Data Valid but Above Normal Operating Range - Most Severe Level. Fuel temperature above the critical limit has been detected. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel entering the high pressure pump. The engine control module (ECM) supplies 5 volts to the fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature exceeded the critical limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque may be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Operating the engine in a hot ambient environment with a low fuel tank level
Refer to Troubleshooting Fault Code 266.

Last Modified: 15-Jul-2015


Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 279

Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 279 PID: S18 SPN: 633 FMI: 4/4 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal, or Shorted to Low Source. A malfunctioning fuel rail actuator circuit has been detected. | The engine will shut down or will not start.
Fuel Rail Actuator Circuit

Circuit Description

The Engine Control Module (ECM) uses the fuel rail actuator to control fuel rail pressure. The actuator is normally open. The pulse-width modulation (PWM) duty cycle to the fuel rail actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel rail actuator, fuel rail pressure sensor and fuel shutoff valve are located in the fuel control block. The fuel pump is located at the rear of the engine. The fuel pump actuator and fuel delivery pressure sensor are mounted on the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs when the fuel rail actuator is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a malfunction in the fuel rail actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open circuit in the engine harness, connectors, or actuator.

  • A return circuit shorted to ground or voltage source.
  • A malfunctioning fuel rail actuator.
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 279.

Last Modified: 15-Jul-2015


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285.

Last Modified: 13-Jul-2015


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
Multiplexing Configuration

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Component Location

The J1939 data link wiring and location of original equipment manufacturer (OEM) installed J1939 devices varies by OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM ECU source addressed correctly) to receive information from an OEM ECU, but the OEM ECU is transmitting a message that says that component is not available for multiplexing.

Refer to Troubleshooting Fault Code 286.

Last Modified: 15-Jul-2015


Fuel Supply Pump Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 316

Fuel Supply Pump Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 316 PID: S78 SPN: 931 FMI: 3/3 LAMP: Amber SRT: | Fuel Supply Pump Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source. A malfunction has been detected in the fuel pump actuator circuit. | Engine power may increase or decrease.
Fuel Pump Actuator Circuit

Circuit Description

The engine control module (ECM) uses the fuel pump actuator to control fuel delivery pressure. The fuel pump actuator is normally closed. The ECM opens the actuator with a pulse width modulated (PWM) signal allowing delivery fuel to recirculate back to the fuel pump inlet. The PWM duty cycle is continuously changed by the ECM to maintain the correct delivery pressure for all engine conditions.

Component Location

The fuel rail actuator, fuel rail pressure sensor and fuel shutoff valve are located in the fuel control block. The fuel pump is located at the rear of the engine. The fuel pump actuator and fuel delivery pressure sensor are mounted on the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs when the fuel pump actuator is commanded OFF.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected a malfunction in the fuel pump actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the harness or actuator.

Short circuit to voltage source in the engine harness.

  • A malfunctioning fuel pump actuator
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 316.

Last Modified: 15-Jul-2015


Fuel Supply Pump Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 317

Fuel Supply Pump Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 317 PID: S78 SPN: 931 FMI: 4/4 LAMP: Amber SRT: | Fuel Supply Pump Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source. A malfunction has been detected in the fuel pump actuator circuit. | Engine power may increase or decrease.
Fuel Pump Actuator Circuit

Circuit Description

The engine control module (ECM) uses the fuel pump actuator to control fuel delivery pressure. The fuel pump actuator is normally closed. The ECM opens the actuator with a pulse width modulated (PWM) signal allowing delivery fuel to recirculate back to the fuel pump inlet. The PWM duty cycle is continuously changed by the ECM to maintain the correct delivery pressure for all engine conditions.

Component Location

The fuel rail actuator, fuel rail pressure sensor and fuel shutoff valve are located in the fuel control block. The fuel pump is located at the rear of the engine. The fuel pump actuator and fuel delivery pressure sensor are mounted on the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs when the fuel pump actuator is commanded ON.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected a malfunction in the fuel pump actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Open circuit in the engine harness, connectors, or actuator.

  • A short circuit to ground in the harness or actuator.
  • A return circuit shorted to ground or voltage source.
  • A malfunctioning fuel pump actuator
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 317.

Last Modified: 15-Jul-2015


Real Time Clock - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real Time Clock - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real-Time Clock Power Interrupt - Data Erratic, Intermittent, or Incorrect. Real-time clock lost power. | None on performance.
Real Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the Engine Control Module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the real-time clock data was lost due to power loss

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light and/or illuminates the Malfunction Indicator Lamp (MIL) at initial key-on when the diagnostic runs and fails.
  • The real-time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or damaged real-time clock battery, damaged wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

Refer to Troubleshooting Fault Code 319.

Last Modified: 15-Jul-2015


Electronic Calibration Code Incompatibility - Out of Calibration

FAULT CODE 342

Electronic Calibration Code Incompatibility - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: S253 SPN: 630 FMI: 13/13 LAMP: Red SRT: | Electronic Calibration Code Incompatibilty - Out of Calibration. Calibration mismatch detected between modules. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Calibration mismatch or incompatibility detected between ECMs in the system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when INSITE™ electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in INSITE™ electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Corrupted engine calibration
Refer to Troubleshooting Fault Code 342.

Last Modified: 15-Jul-2015


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352.

Last Modified: 15-Jul-2015


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 386.

Last Modified: 15-Jul-2015


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 10 seconds after the red STOP lamp starts flashing.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure sensor
Refer to Troubleshooting Fault Code 415.

Last Modified: 13-Jul-2015


Injector Timing Rail 1 Fuel Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 423

Injector Timing Rail 1 Fuel Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 423 PID: P156 SPN: 156 FMI: 2/2 LAMP: Amber SRT: | Injector Timing Rail 1 Fuel Pressure - Data Erratic, Intermittent, or Incorrect. Timing pressure sensor in-range error detected. Voltage signal indicates that the timing pressure sensor signal can possibly not be accurate. | No action taken by the engine control module (ECM). Possible loss of performance.
Timing Rail Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the timing rail pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The timing rail pressure sensor provides a signal to the ECM on the timing rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel timing rail.

Component Location

The pressure sensor is located on the right, towards the top of the electronic control valve assembly, across from the timing rail actuator.

Conditions for Running the Diagnostics

This diagnostic runs when the timing rail actuator is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for all injectors.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle. If, after the engine idles for 10 minutes, the fault code is still not active, the repair has been validated.

Shop Talk

Reference a specific engine wiring diagram for the output voltage of the pressure sensor.

Refer to Troubleshooting Fault Code 423.

Last Modified: 15-Jul-2015


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | J1939 Data Link - Data Erratic, Intermittent, or Incorrect. Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | None on performance.
SAE J1939 Datalink 1 Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Shorted or open J1939 data link wiring.
Refer to Troubleshooting Fault Code 426.

Last Modified: 15-Jul-2015


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441.

Last Modified: 23-Jul-2015


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442.

Last Modified: 23-Jul-2015


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P157 SPN: 157 FMI: 0/0 LAMP: Red SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operational Range - Most Severe Level. The ECM has detected that fuel pressure in the fuel rail is higher than the normal operating fuel system pressure. | Engine power may increase or decrease.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel rail actuator) or decrease (CLOSE the fuel rail actuator) the fuel supply to the fuel rail.

Component Location

The fuel rail actuator, fuel rail pressure sensor and fuel shutoff valve are located in the fuel control block. The fuel pump is located at the rear of the engine. The fuel pump actuator and fuel delivery pressure sensor are mounted on the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High drain line restriction (high drain line pressure)
  • A malfunctioning fuel rail pressure sensor
  • A malfunctioning fuel rail actuator.
Refer to Troubleshooting Fault Code 449.

Last Modified: 15-Jul-2015


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The fuel rail pressure sensor is located in the fuel control block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the signal wire
  • Open circuit on the 5 Volt supply wire
  • Open circuit on the return wire
  • Malfunctioning sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 451.

Last Modified: 13-Jul-2015


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The fuel rail pressure sensor is located in the fuel control block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel rail pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes for this fault code include:

  • Supply or signal wire is shorted to ground.
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code 452.

Last Modified: 13-Jul-2015


Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 455

Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: S18 SPN: 633 FMI: 3/3 LAMP: Red SRT: | Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source. A malfunctioning fuel rail actuator circuit has been detected. | The engine will shut down or will not start.
Fuel Rail Actuator Circuit

Circuit Description

The Engine Control Module (ECM) uses the fuel rail actuator to control fuel rail pressure. The actuator is normally open. The pulse-width modulation (PWM) duty cycle to the fuel rail actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel rail actuator, fuel rail pressure sensor and fuel shutoff valve are located in the fuel control block. The fuel pump is located at the rear of the engine. The fuel pump actuator and fuel delivery pressure sensor are mounted on the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs when the fuel rail actuator is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a malfunction in the fuel rail actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A signal wire shorted to ground or battery voltage.
  • A return circuit shorted to ground or voltage source.
  • A malfunctioning fuel rail actuator.
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 455.

Last Modified: 15-Jul-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Engine power derate.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler

Undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 488.

Last Modified: 15-Jul-2015


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 515.

Last Modified: 15-Jul-2015


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and a return line, a failed sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 516.

Last Modified: 15-Jul-2015


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: P94 SPN: 94 FMI: 3/3 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel delivery pressure sensor circuit. | Engine power may increase or decrease.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 546.

Last Modified: 15-Jul-2015


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: P94 SPN: 94 FMI: 4/4 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel delivery pressure sensor circuit. | Engine power may increase or decrease.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply wire open or shorted to ground.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 547.

Last Modified: 15-Jul-2015


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel rail actuator) or decrease (CLOSE the fuel rail actuator) the fuel supply to the fuel rail.

Component Location

The fuel rail actuator, fuel rail pressure sensor and fuel shutoff valve are located in the fuel control block. The fuel pump is located at the rear of the engine. The fuel pump actuator and fuel delivery pressure sensor are mounted on the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was below commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High fuel inlet restriction
  • Low fuel gear pump output pressure
  • Air in the fuel
  • A malfunctioning fuel rail pressure sensor
  • A malfunctioning fuel rail actuator.
Refer to Troubleshooting Fault Code 559.

Last Modified: 15-Jul-2015


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning engine speed sensor
  • Damaged tone wheel
  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code 689.

Last Modified: 13-Jul-2015


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Possible reduced engine performance.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 13-Jul-2015


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1411

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1411 PID: S151 SPN: 4182 FMI: 3/3 LAMP: Amber SRT: | Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The frequency adjust potentiometer will go to the default value.
Frequency Adjust Circuit

Circuit Description

The frequency adjust potentiometer circuit provides an analog (0 to 5-VDC) input for commanding a speed offset to the base-rated speed to regulate the frequency. An external parallel/load share controller can supply an analog signal with a potentiometer to this input to modify the generator set operating speed for synchronization or droop operations. The commanded engine speed offset is linearly proportional to the input voltage and nominal voltage of 2.5-VDC commands a speed offset of 0 rpm.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage

Refer to Troubleshooting Fault Code 1411.

Last Modified: 15-Jul-2015


Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1412

Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1412 PID: S151 SPN: 4183 FMI: 3/3 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source. | The droop adjust potentiometer will go to the default value.
Droop Adjust Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage
Refer to Troubleshooting Fault Code 1412.

Last Modified: 15-Jul-2015


Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1418

Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1418 PID: S151 SPN: 4184 FMI: 3/3 LAMP: Amber SRT: | Gain adjust potentiometer signal is shorted high. | The gain adjustment feature will be disabled, and a default value of zero will be used. Possible loss of performance.
Gain Adjust Circuit

Circuit Description

The gain adjust potentiometer is so the operator can adjust the amplification of the difference in the value between the "desired speed" and the "actual speed" of the engine, so that the governor can respond to engine speed fluctuations. The difference between the "desired speed" and the "actual speed" is called the error signal. When the gain is increased, the error signal amplification is increased, more corrective action is taken by the governor, and its response is quicker. When the gain is reduced, the error signal amplification is reduced, less corrective action is taken by the governor, and its response is slower. If the gain is set too high, the governor can over correct the speed error signal, which will lead to engine speed surging or "hunting". The ECM monitors the voltage and expects to see the voltage vary between 0.5 and 4.5-VDC during normal operation. High voltage will activate Fault Code 1418 and can be caused by shorts in the signal wire, an open in the return wire, or a malfunctioning potentiometer.

Component Location

The gain adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Gain adjust circuit is shorted high

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible caused of this fault code include:

  • Signal circuit shorted to sensor supply or battery voltage.
  • Open return circuit in the harness, connectors, or sensor
Refer to Troubleshooting Fault Code 1418.

Last Modified: 15-Jul-2015


Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

FAULT CODE 1427

Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1427 PID: SPN: 4185 FMI: 11/31 LAMP: Amber SRT: | Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists | The overspeed shutdown lamp will not turn on.
Overspeed Shutdown Circuit

Circuit Description

The overspeed shutdown lamp will indicate when the engine has reached overspeed. Fault Code 1992 will trigger the overspeed shutdown lamp.

Component Location

The overspeed shutdown lamp is located on the generator control panel. Refer to the OEM service manual for the overspeed shutdown lamp location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected engine overspeed.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the ECM detects an open lamp circuit, Fault Code 1427 will go active, even in the absence of Fault Code 1992. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1427.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to ground in the harness
  • Open signal circuit or shorted to a voltage source
Refer to Troubleshooting Fault Code 1427.

Last Modified: 15-Jul-2015


Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

FAULT CODE 1428

Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1428 PID: SPN: 4186 FMI: 11/31 LAMP: Amber SRT: | Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists | The low oil pressure (LOP) shutdown lamp will not turn on.
Low Oil Pressure (LOP) Shutdown Circuit

Circuit Description

The low oil pressure (LOP) shutdown lamp will indicate when the engine has reached a low oil pressure most severe condition. Fault Code 415 will trigger the low oil pressure (LOP) shutdown lamp.

Component Location

The low oil pressure (LOP) shutdown lamp is located on the generator control panel. Refer to the OEM service manual for lamp location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low oil pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If the ECM detects an open lamp circuit, Fault Code 1428 will go active, even in the absence of Fault Code 415. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1428.

Possible causes of this fault code include:

  • Open signal circuit or shorted to a voltage source

Signal wire shorted to ground

  • Open return circuit in the harness, connectors, or sensor
Refer to Troubleshooting Fault Code 1428.

Last Modified: 15-Jul-2015


High Engine Temperature (HET) Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

FAULT CODE 1429

High Engine Temperature (HET) Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1429 PID: SPN: 4187 FMI: 11/31 LAMP: Amber SRT: | High Engine Temperature (HET) Shutdown Relay Driver Diagnostic Has Dectected An Error - Condition Exists | The high engine temperature shutdown lamp will not turn on
Engine Control Module

Circuit Description

The high engine temperature shutdown lamp will indicate when the engine has reached a most severe level high coolant or intake manifold temperature. Fault Code 151 or 155 will trigger the high engine temperature shutdown lamp.

Component Location

Refer to the OEM service manual for lamp location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open on the lamp circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open signal circuit or shorted to voltage source.
  • A signal shorted to ground in the harness

Open signal circuit in the OEM harness, connectors, or sensor

Refer to Troubleshooting Fault Code 1429.

Last Modified: 15-Jul-2015


Pre-Low Oil Pressure Warning Relay Driver Diagnostic Has Detected an Error - Condition Exists

FAULT CODE 1431

Pre-Low Oil Pressure Warning Relay Driver Diagnostic Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1431 PID: S151 SPN: 4188 FMI: 11/31 LAMP: Amber SRT: | Pre-Low Oil Pressure Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists | The pre-low oil pressure warning lamp will not turn on.
Pre-Low Oil Pressure Warning Circuit

Circuit Description

The pre-low oil pressure warning lamp will indicate when the engine has reached a moderately severe low oil pressure condition. Fault Code 143 will trigger the pre-low oil pressure warning lamp.

Component Location

The pre-low oil pressure warning lamp is located on the generator control panel. Refer to the OEM service manual for lamp location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low oil pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Fault Code 143 goes active and the pre-low oil pressure warning lamp does not go on if the ECM detects an open lamp circuit, Fault Code 1431 will go active even in the absence of Fault Code 143. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1431.

Refer to Troubleshooting Fault Code 1431.

Last Modified: 15-Jul-2015


Pre-High Engine Temperature Warning Relay Driver Diagnostic Has Detected an Error - Condition Exists

FAULT CODE 1432

Pre-High Engine Temperature Warning Relay Driver Diagnostic Has Detected an Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1432 PID: S151 SPN: 4223 FMI: 11/31 LAMP: Amber SRT: | Pre-High Engine Temperature Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists | The pre-high engine temperature warning lamp will not turn on.
Engine Control Module (ECM)

Circuit Description

The pre-high engine temperature warning lamp will indicate when the engine has reached a moderately severe level high coolant or intake manifold temperature. Fault Code 146 or 488 will trigger the pre-high engine temperature warning lamp.

Component Location

The pre-high engine temperature warning lamp is located on the generator control panel. Refer to the OEM service manual for lamp location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high coolant or intake temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Fault Code 146 or 488 goes active and the pre-high engine temperature warning lamp does not go on if the ECM detects an open lamp circuit, Fault Code 1432 will go active even in the absence of Fault Code 146 or Fault Code 488. The ECM does not have to be trying to turn the lamp on to detect Fault Code 1432.

Possible causes of this fault code include:

  • Open signal circuit or shorted to a voltage source.
  • Signal circuit shorted to ground in the harness
  • Open return circuit in the harness, connectors, or sensor
Refer to Troubleshooting Fault Code 1432.

Last Modified: 15-Jul-2015


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 1597

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1597 PID: S254 SPN: 629 FMI: 12/12 LAMP: Maintenance SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the rear of the engine near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 1597.

Last Modified: 15-Jul-2015


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for the accelerator position sensor 2.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1695.

Last Modified: 15-Jul-2015


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for the accelerator position sensor 2.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1696.

Last Modified: 15-Jul-2015


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: P110 SPN: 110 FMI: 14/14 LAMP: Red SRT: | Engine Coolant Temperature - Special Instructions. Engine coolant temperature signal indicates engine coolant temperature is above the engine protection warning limit. | Engine will be shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located near the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine will only idle or will shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • Malfunctioning coolant temperature sensor

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS

Refer to Troubleshooting Fault Code 1847.

Last Modified: 15-Jul-2015


Engine Oil Change Interval - Condition Exists

FAULT CODE 1891

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1891 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Amber SRT: | Engine Oil Change Interval - Condition Exists. Engine conditions are preventing Centinel operation. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) uses the Centinel oil control valve to regulate the amount of used oil that is removed from the engine and sent to a waste oil tank. Depending on application setup, the oil control valve can also circulate fresh oil into the engine.

Component Location

The Centinel oil control valve is usually located on the left rear of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the Centinel system has been unable to operate for an extended period due to engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a keycycle, start the engine and perform the Centinel Operational Test using Insite electronic service tool.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If fault codes 135, 141, 212, 213, 214, 223, 224, or 421 are active then oil removal/replacement will be disabled. Troubleshoot any occurrences of these fault codes.

If the Centinel/Continuous Oil Replacement System has been disabled for an extended period of time it may be necessary to change the engine oil before the next scheduled oil change.

Refer to Troubleshooting Fault Code 1891.

Last Modified: 13-Jul-2015


Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1978

Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1978 PID: SPN: 3938 FMI: 3/3 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source. | Engine will not synchronize with the grid if connected.
Speed Bias Circuit

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set. Refer to the OEM service manual for component location

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1978.

Last Modified: 15-Jul-2015


Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1979

Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1979 PID: SPN: 3938 FMI: 4/4 LAMP: Amber SRT: | Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will not synchronize with the grid if connected.
Speed Bias Circuit

Circuit Description

The generator speed/load governing bias circuit controls the engine speed in order to match a required grid frequency and phase.

Component Location

The generator speed/load governing bias control is located in the generator set controller on the generator set. Refer to the OEM service manual for component location

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the OEM harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1979.

Last Modified: 15-Jul-2015


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: P190 SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine speed has exceeded a critical limit. | Engine will be shut down.
Engine Crankshaft Speed/Position and Camshaft Speed/Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes for this fault code include:

Gain adjust setting is not set correctly

Erroneous generator speed/load governing bias signal from the generator set

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine

Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 1992.

Last Modified: 15-Jul-2015


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 13-Jul-2015


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 13-Jul-2015


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2261

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2261 PID: P94 SPN: 94 FMI: 0/15 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. High fuel delivery pressure has been detected. | Engine power may increase or decrease.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was higher than normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel pump.
  • A malfunctioning fuel pump actuator
  • Blocked or restricted fuel line.
  • High fuel pump inlet pressure.
Refer to Troubleshooting Fault Code 2261.

Last Modified: 15-Jul-2015


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2262

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2262 PID: P94 SPN: 94 FMI: 1/17 LAMP: Maintenance SRT: | Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level. Low fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was lower than normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A plugged fuel filter
  • A malfunctioning fuel pump actuator
  • A malfunctioning fuel pump.
  • Blocked or restricted fuel line.
Refer to Troubleshooting Fault Code 2262.

Last Modified: 15-Jul-2015


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S18 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Electronic Fuel Injection Control Valve Circuit - Condition Exists. Resistance in the fuel rail actuator circuit is too high or too low. | Engine power may increase or decrease.
Fuel Rail Actuator Circuit

Circuit Description

The Engine Control Module (ECM) uses the fuel rail actuator to control fuel rail pressure. The actuator is normally open. The pulse-width modulation (PWM) duty cycle to the fuel rail actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel rail actuator, fuel rail pressure sensor and fuel shutoff valve are located in the fuel control block. The fuel pump is located at the rear of the engine. The fuel pump actuator and fuel delivery pressure sensor are mounted on the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the resistance of the actuator circuit was out of normal range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High or low resistance in the harness, actuator or connector.
Refer to Troubleshooting Fault Code 2311.

Last Modified: 15-Jul-2015


Timing Actuator Driver Circuit - Condition Exists

FAULT CODE 2312

Timing Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2312 PID: S20 SPN: 635 FMI: 11/31 LAMP: Amber SRT: | Timing Actuator Driver Circuit - Condition Exists. Resistance in the timing rail actuator circuit is too high or too low. | None on performance.
Timing Rail Actuator Circuit

Circuit Description

The Engine Control Module (ECM) uses the timing rail actuator to control fuel injection timing. The ECM opens the timing rail actuator allowing engine oil to pressurize the timing rail and advance the fuel injection timing. When normal fuel injection timing is desired the ECM closes the timing rail actuator and oil pressure in the timing rail will bleed down. The timing rail actuator is normally closed.

Component Location

The timing rail actuator is located in the timing rail control block.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the resistance of the actuator circuit was out of normal range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High or low resistance in the harness, actuator or connector.
Refer to Troubleshooting Fault Code 2312.

Last Modified: 15-Jul-2015


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 11/31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | None on performance.
Engine Control Module (ECM)

Circuit Description

There is at least one unacknowledged severe fault in the system.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM). Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fault that has not set the lamp within a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information-only fault code that will only become active if other critical engine protection fault codes are active. This fault code will remain active until acknowledged using the OEM supplied switch.

Refer to Troubleshooting Fault Code 2661.

Last Modified: 22-Jul-2015


At Least One Unacknowledged Moderately Severe Fault - Condition Exists

FAULT CODE 2662

At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2662 PID: SPN: 629 FMI: 11/31 LAMP: Amber SRT: | At Least One Unacknowledged Moderately Severe Fault - Condition Exists. | None on performance.
Engine Control Module (ECM)

Circuit Description

There is at least one unacknowleged moderately severe fault in the system.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM). Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fault that has not set the lamp within a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This is an information-only fault code that will only become active if other moderate severity fault codes are active. This fault code will remain active until acknowledged using the OEM supplied switch.

Refer to Troubleshooting Fault Code 2662.

Last Modified: 22-Jul-2015


Fuel Supply Pump Actuator Driver Circuit - Condition Exists

FAULT CODE 3684

Fuel Supply Pump Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3684 PID: SPN: 931 FMI: 11/31 LAMP: Amber SRT: | Fuel Supply Pump Actuator Driver Circuit - Condition Exists. Resistance in the fuel pump actuator circuit is too high or too low. | Engine power may increase or decrease.
Fuel Pump Actuator Circuit

Circuit Description

The engine control module (ECM) uses the fuel pump actuator to control fuel delivery pressure. The fuel pump actuator is normally closed. The ECM opens the actuator with a pulse width modulated (PWM) signal allowing delivery fuel to recirculate back to the fuel pump inlet. The PWM duty cycle is continuously changed by the ECM to maintain the correct delivery pressure for all engine conditions.

Component Location

The fuel rail actuator, fuel rail pressure sensor and fuel shutoff valve are located in the fuel control block. The fuel pump is located at the rear of the engine. The fuel pump actuator and fuel delivery pressure sensor are mounted on the fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the resistance of the actuator circuit was out of normal range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High or low resistance in the harness, actuator or connector.
Refer to Troubleshooting Fault Code 3684.

Last Modified: 15-Jul-2015


Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3694

Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3694 PID: S151 SPN: 4184 FMI: 4/4 LAMP: Amber SRT: | Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The gain adjustment feature will be disabled, and a default value of zero will be used. Possible loss of performance.
Gain Adjust Circuit

Circuit Description

The gain adjust potentiometer is used to regulate the governor gains.

Component Location

The gain adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3694.

Last Modified: 15-Jul-2015


Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3695

Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3695 PID: S151 SPN: 4182 FMI: 4/4 LAMP: Amber SRT: | Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The generator output frequency adjust potentiometer will go to the default value.
Frequency Adjust Circuit

Circuit Description

The frequency adjust potentiometer circuit provides an analog (0 to 5-VDC) input for commanding a speed offset to the base-rated speed to regulate the frequency. An external parallel/load share controller can supply an analog signal with a potentiometer to this input to modify the generator set operating speed for synchronization or droop operations. The commanded engine speed offset is linearly proportional to the input voltage and nominal voltage of 2.5-VDC commands a speed offset of 0 rpm.

Component Location

Refer to the OEM Service Manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

If Fault Code 3695 goes active, the generator output frequency adjust potentiometer will not respond.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3695.

Last Modified: 15-Jul-2015


Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3696

Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3696 PID: S151 SPN: 4183 FMI: 4/4 LAMP: Amber SRT: | Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source | The droop adjust potentiometer will go to the default value.
Droop Adjust Circuit

Circuit Description

The droop adjust potentiometer is used to regulate the engine droop.

Component Location

The droop adjust potentiometer is located on the generator control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3696.

Last Modified: 15-Jul-2015


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | IF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | IF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | Signature™ ISX and QSX15 | 3666259
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310840
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 40221704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367219
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | Signature™ ISX and QSX15 | 3666259
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310840
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367219
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Signature™ ISX and QSX15 | 3666259
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Replace the ECM. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete.

Last Modified: 28-Apr-2017


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | Marine QSB6.7 CM2250 | 4310611
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9 CM2350 L101 | 4310787
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX12 CM2350 X102 | 4310646
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX15 CM2350 X101 | 4310641
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B103 | 4332641
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK19 CM2350 K105 | 4326157
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | VTA903 CM2250 V105 | 4332841
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B105 | 4332778
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L102 | 4332796
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9 CM2350 L111 | 4367223
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B106 | 4367376
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2350 G110 | 4367323
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 B128 | 4388601
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2250 L115 | 4388626
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2250 K112 | 4367454
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B130 | 4388668
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L118 | 4388673
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F118 | 4388708
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F119 | 4388703
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B122 | 4388767
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2250 B131 | 4388774
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.3 CM2250 B137 | 5411058
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2250 X115 | 4388739
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B142 | 5411131
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X114B | 5411181
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X116B | 5411186
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L116B | 5411330
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B129B | 5411247
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B147B | 5411252
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B135B | 5411257
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B148B | 5411262
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L119B | 5411267
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B145 | 5411273
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L122 | 5411278
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B144 | 5411382
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L123B | 5411465
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F125 | 5411494
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2350 X118 | 5467247
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | Marine QSB6.7 CM2250 | 4310611
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9 CM2350 L101 | 4310787
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12 CM2350 X102 | 4310646
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2350 X101 | 4310641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2250 SN | 4310736
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B103 | 4332641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK19 CM2350 K105 | 4326157
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK78 CM2250 K104 | 4332682
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | VTA903 CM2250 V105 | 4332841
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B105 | 4332778
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L102 | 4332796
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9 CM2350 L111 | 4367223
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B106 | 4367376
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSG12 CM2350 G110 | 4367323
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2250 K112 | 4367454
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B130 | 4388668
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L118 | 4388673
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F118 | 4388708
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F119 | 4388703
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B122 | 4388767
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 B128 | 4388601
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2250 B131 | 4388774
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB3.3 CM2250 B137 | 5411058
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 X115 | 4388739
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B142 | 5411131
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X114B | 5411181
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X116B | 5411186
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L116B | 5411330
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B129B | 5411247
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B147B | 5411252
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B135B | 5411257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B148B | 5411262
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L119B | 5411267
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B145 | 5411273
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L122 | 5411278
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B144 | 5411382
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L123B | 5411465
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F125 | 5411494
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2350 X118 | 5467247
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High in Section TS, in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2013


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate faultcode troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISV5.0 CM3230 V104 | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for QSK78, QSK23, and ISV5.0 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4327291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for ISV5.0 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except IISV5.0 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISM/QSM11 CM570 | 3666266
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in the appropriate service manual.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for all engines except QSM11 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.
  • Use the following procedure for QSM11 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Do not operate a diesel engine where there are or can be combustible vapors. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to the application, is operating in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. The equipment owner and operator are responsible for safe operation in a hostile environment. Contact a Cummins® Authorized Repair Location for further information.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring down hill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring down hill?
YES NO
No Repair

Check for engine damage.

  • Electronics are ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is operating.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Troubleshoot Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not operating above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or the vessel in a sea trail to determine if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-May-2017


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K117 | 4367449
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 L121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 L121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the equipment manufacturer service information, vehicle electronic control unit (VECU), and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the equipment manufacturer service information, VECU, and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper original equipment manufacturer (OEM) VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the equipment manufacturer service information. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Low engine oil pressure has been detected.

Reference the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the appropriate service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Jan-2016


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-ampere fuse is installed correctly.

  • Inspect the 30-ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turnkeyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the battery system. |
 | STEP 2A. Check the battery connection. | Batteries connected properly for the system voltage required?
 | STEP 2B. Check the alternator. | Alternator charging within equipment manufacturers specifications?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the battery system.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check to make sure batteries are installed correctly.

Batteries connected properly for the system voltage required?
YES NO
No Repair

Install the battery system correctly. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an original equipment manufacturer (OEM) ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within equipment manufacturers specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the equipment manufacturers wiring to the alternator.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-Apr-2017


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 AN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B101 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L101 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358370
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358575
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358580
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | GSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | GSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 AN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B101 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L101 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | GSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | GSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 AN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 EC | 4310575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332687
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K105 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358570
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358580
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 | 4367444
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test leadPart Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 or 515 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 or 515 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 volt SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 IAN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2220 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 GX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 EC | 2883647
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332778
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K104 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K108 | 4332823
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358470
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358475
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358480
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSb4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F116 | 4383664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 516 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 516 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

  • 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]. During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]

During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or battery supply connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the battery supply connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the battery supply connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the battery supply connector and the negative battery connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch wire.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 3E

Go to 4A

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete

Go to 1A

Last Modified: 05-Apr-2017


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical guage?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical guage or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical guage?
YES NO

Use the following troubleshooting symptom tree, Engine Coolant Temperature Above Normal, in Section TS of the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to fin the present ECM code and revison number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found the the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Last Modified: 13-Jul-2015


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5,ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2150 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Check for a short circuit to battery in the OEM harness. | Greater than 100k ohms?
 | STEP 2B. Check for a short circuit to keyswitch power in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Check for a short circuit to battery in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to battery.

  • Measure the resistance and check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM battery SUPPLY (+) pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to keyswitch power in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to keyswitch power.

  • Check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM keyswitch SIGNAL pin in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ and test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Apr-2017


FAULT CODE 2661 - At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive red lamp fault codes?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code? | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive red lamp fault codes?
YES NO

This is an information-only fault code that will only become active if other critical engine protection fault codes are active. This fault code will remain active until acknowledged using the original equipment manufacturer (OEM) supplied switch.

Troubleshoot all other red lamp fault codes.

Once all other red lamp fault codes are inactive, this fault code will remain inactive when acknowledged.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 25-Apr-2014


FAULT CODE 2662 - At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive amber lamp fault codes?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive amber lamp fault codes?
YES NO

This is an information-only fault code that will only become active if other moderate severity fault codes are active. This fault code will remain active until acknowledged using the original equipment manufacturer (OEM) supplied switch.

Troubleshoot all other amber lamp fault codes.

Once all other amber lamp fault codes are inactive, this fault code will remain inactive when acknowledged.

 No Repair

Reference the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Apr-2014


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK19 CM2350 K105 | 4326157
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK50 CM2350 K108 | 4332823
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2350 K121 | 4388645

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 488 inactive?
 | STEP 2B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake manifold Air Temperature Above Specification symptom tree in Section TS.

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Oct-2015


FAULT CODE 1891 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1891. | Fault Code 1891 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1891.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1891.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1891 active?
YES NO

This fault code indicates that the Centinel/Continuous Oil Replacement System has been unable to operate due to engine conditions. If Fault Codes 135, 141, 212, 213, 214, 223, 224, or 421 are active then oil removal/replacement will be disabled. Troubleshoot any occurrences of these fault codes. If the Centinel/Continuous Oil Replacement System has been disabled for an extended period of time, it may be necessary to change the engine oil before the next scheduled oil change.

No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Aug-2014


FAULT CODE 112 - Engine Timing Actuator Driver Circuit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK23 CM2250 K109 | 4367358
Fuel Supply Lines | Refer to Procedure 006-024 | QSK23 CM2250 K109 | 4367358
Injector | Refer to Procedure 006-026 | QSK23 CM2250 K109 | 4367358
Timing Actuator | Refer to Procedure 019-111 | QSK23 CM2250 K109 | 4367358
Additional Service Literature | Refer to Procedure 205-001 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify the complaint. |
 | STEP 1A. Check for other active fault codes. | Other fault codes active?
 | STEP 1B. Interview the operator. | Engine symptoms present?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check for an external power source on the engine harness or generator control system. | External power supply?
STEP 3. | Check the suction-side fuel system flow. |
 | STEP 3A. Check the fuel tank level. | Fuel in tank?
 | STEP 3B. Inspect the fuel system for leaks, broken lines, and loose fittings. | Any leaks, broken lines, or loose fittings?
 | STEP 3C. Check the fuel inlet restriction. | Fuel inlet restriction less than 203 mm-Hg [8 in-Hg]?
 | STEP 3D. Check for air in the fuel. | Air in the fuel?
STEP 4. | Check the pressure-side fuel system flow. |
 | STEP 4A. Check the fuel pump output pressure. | Output pressure within specifications?
 | STEP 4A-1. Check the injector o-rings. |
 | STEP 4A-2. Check for fuel in the oil or coolant. |
 | STEP 4B. Inspect the actuator screen for debris. | Debris in the actuator screen?
 | STEP 4C. Inspect the actuator for corrosion. | Corrosion present?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 112 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify the complaint.

Guided Step 1A - Check for other active fault codes.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Check for other active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Other fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Interview the operator.

Conditions

  • Place the run/stop/auto switch in RUN position.

Action

Interview the operator for the following:

  • Engine symptoms
  • Specific symptoms or shutdown/derates due to Fault Code 112.

Engine symptoms present?
YES NO
No Repair

Clear the fault code.

Inactive faults have been logged. Since the operator is not experiencing a problem, clear the fault.

Go to 2A

Go to 5B

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check for an external power source on the engine harness or generator control system.

Conditions

  • Place run/stop/auto switch in STOP position.

Action

Check for an external power supply (such as a battery charger) on the engine harness or generator control system.

Use the wiring diagram for proper wiring connections.

Use the following procedure for additional service literature for wiring diagram bulletin numbers. Refer to Procedure 205-001 in the Associated Procedures Table.

External power supply?
YES NO

Remove the external power supply from the harness.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the suction-side fuel system flow.

Guided Step 3A - Check the fuel tank level.

Conditions

  • Place run/stop/auto switch in STOP position.

Action

Check the fuel tank level.

Fuel in tank?
YES NO
No Repair

Fill the tank with fuel.

Go to 3B

Go to 5A

Guided Step 3B - Inspect the fuel system for leaks, broken lines, and loose fittings.

Conditions

  • Place run/stop/auto switch in STOP position.

Action

Inspect the fuel system for the following:

  • Leaks
  • Broken lines
  • Loose fittings.

Any leaks, broken lines, or loose fittings?
YES NO

Tighten or replace the leaking fitting or fuel line. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the fuel inlet restriction.

Conditions

  • Place run/stop/auto switch in RUN position.

Action

Measure the inlet restriction.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Fuel inlet restriction less than 203 mm-Hg [8 in-Hg]?
YES NO
No Repair

Locate the cause of the restriction and remove. Check for clogged fuel filters, debris in the fuel tank, clogged fuel tank vents, collapsed or malfunctioning fuel lines, or malfunctioning check valves.

Go to 3D

Go to 5A

Guided Step 3D - Check for air in the fuel.

Conditions

  • Place run/stop/auto switch in RUN position.

Action

Check for air in the fuel.

Refer to Procedure 005-016 in the Associated Procedures Table.

Air in the fuel?
YES NO

Locate the cause of air in the fuel. Check for missing o-ring seals in the inlet fuel fittings or loose or broken fittings and lines.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the pressure-side fuel system flow.

Guided Step 4A - Check the fuel pump output pressure.

Conditions

  • Place run/stop/auto switch in RUN position.

Action

Check the fuel pump output pressure.

Check the fuel pump output pressure. Refer to Procedure 005-016 in the Associated Procedures Table.

Output pressure within specifications?
YES NO

Remove the external power supply from the harness.

 No Repair

Go to 4B

Go to 4A-1

Guided Step 4A-1 - Check the injector o-rings.

Conditions

  • Place run/stop/auto switch in RUN position.

Action

Check the injector o-rings.

Observe the drain output of the front three versus the rear three cylinders.

  • Disconnect the drain lines at the T junction.
  • Place each half into separate, equal size buckets.
  • Operate the engine at rated speed for enough time to determine if output is equal from each half.

Drain output equal from front and rear halves?
YES NO
No Repair

Replace the injector o-rings on the malfunctioning bank. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Check for fuel in the oil or coolant.

Conditions

  • Place run/stop/auto switch in STOP position.

Action

Check for fuel in the oil or coolant.

Fuel in the oil or coolant?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 5A

Guided Step 4B - Inspect the actuator screen for debris.

Conditions

  • Place run/stop/auto switch in STOP position.

Action

Inspect the actuator screen(s) for debris.

  • Remove the timing rail actuator. Refer to Procedure 019-111 in the Associated Procedures Table.

Debris in the actuator screen?
YES NO

Replace the timing rail actuator screen(s). Refer to Procedure 019-111 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Inspect the actuator for corrosion.

Conditions

  • Place run/stop/auto switch in STOP position.

Action

Inspect the actuator(s) for corrosion.

  • Remove the timing rail actuator. Refer to Procedure 019-111 in the Associated Procedures Table.

Corrosion present?
YES NO

Replace the timing actuator(s). Refer to Procedure 019-111 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

Start the engine and run throughout the operating range to verify Fault Code 112 stays inactive.

Fault Code 112 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate fault code troubleshooting tree.

Last Modified: 13-Jul-2015


FAULT CODE 113 - Engine Timing Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Timing Actuator | Refer to Procedure 019-111 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 113 active?
STEP 2. | Check the timing rail actuator. |
 | STEP 2A. Inspect the timing rail actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the timing rail actuator coil resistance. | 7 to 9 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for a return short to the power supply. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 113 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the timing rail actuator.

Guided Step 2A - Inspect the timing rail actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator from the engine harness.

Action

Inspect the timing actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the timing rail actuator coil resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail actuator.

Action

Check the timing rail actuator timing resistance.

  • Measure the resistance from the timing rail actuator SIGNAL pin to the timing rail actuator RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

7 to 9 ohms?
YES NO
No Repair

Replace the timing rail actuator. Refer to Procedure 019-111 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damage harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail actuator SIGNAL pin in the engine harness timing rail actuator connector to the timing rail actuator SIGNAL pin in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail actuator RETURN pin in the engine harness timing rail actuator connector to the timing rail actuator RETURN pin in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the timing rail actuator SIGNAL pin and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a return short to the power supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a return short to the power supply.

  • Measure the resistance from the timing rail actuator RETURN pin and all other pins in the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision history in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 114 - Engine Timing Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Timing Actuator | Refer to Procedure 019-111 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 114 active?
STEP 2. | Check the timing rail actuator. |
 | STEP 2A. Inspect the timing rail actuator and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the coil resistance of the timing rail actuator. | 7.0 to 9.0 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 114 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the timing rail actuator.

Guided Step 2A - Inspect the timing rail actuator and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator from the engine harness

Action

Inspect the timing actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the coil resistance of the timing rail actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the timing rail actuator.

Action

Check the coil resistance of the timing rail actuator.

  • Measure the resistance from the timing rail actuator SIGNAL pin to the timing rail actuator RETURN pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

7.0 to 9.0 ohms?
YES NO
No Repair

Replace the timing rail actuator. Refer to Procedure 019-111 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness and the extension harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure resistance between the timing rail actuator SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the timing rail actuator SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Jul-2015


FAULT CODE 116 - Injector Timing Rail 1 Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Timing Actuator | Refer to Procedure 019-111 | QSK23 CM2250 K109 | 4367358
Fuel Timing Pressure Sensor | Refer to Procedure 019-113 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 116 inactive?
STEP 2. | Check the fuel timing pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel timing pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 117 active and Fault Code 116 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 116 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 116 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel timing pressure sensor and circuit.

Guided Step 2A - Inspect the fuel timing pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel timing pressure sensor from the engine harness.

Action

Inspect the engine harness and timing fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Use the following procedure for the fuel timing pressure sensor. Refer to Procedure 019-113 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel timing pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel timing pressure RETURN pin and the fuel timing pressure SIGNAL pin at the timing fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 117 active and Fault Code 116 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel timing pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel timing pressure 5 volt SUPPLY pin to the fuel timing pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel timing pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 116 active?
YES NO

A damaged sensor has been detected.

Replace the fuel timing pressure sensor. Refer to Procedure 019-113 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the timing fuel pressure RETURN pin and the timing fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 117 active and Fault Code 116 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 116 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the timing fuel pressure 5 volt SUPPLY pin to the timing fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 116 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 117 - Injector Timing Rail 1 Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Timing Pressure Sensor | Refer to Procedure 019-113 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 117 inactive?
STEP 2. | Check the timing fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the timing fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 116 active and Fault Code 117 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 117 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 117 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the timing fuel pressure sensor and circuit.

Guided Step 2A - Inspect the timing fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and timing fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the timing fuel pressure 5 volt SUPPLY pin to the timing fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 116 active and Fault Code 117 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the timing fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 117 active?
YES NO

A damaged sensor has been detected.

Replace the timing fuel pressure sensor. Refer to Procedure 019-113 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the timing fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 117 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 116 active and Fault Code 117 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 117 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 121 - Engine Magnetic Crankshaft Speed/Position Lost One of Two Signals - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Speed Sensor (ESS) | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the engine control module. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine speed sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | No damaged pins?
 | STEP 1B. Inspect the engine speed sensor. | No damaged engine speed sensor?
 | STEP 1C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 1D. Check for an open circuit. | 1k to 2k ohms?
 | STEP 1E. Check for short circuit between coils. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Check for short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 2B. Check for an open circuit. | Less than 2k ohms?
 | STEP 2C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine speed sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

OK NOT OK

No damaged pins?

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-201 in Section 19 or Refer to Procedure 019-205 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 1B

3A

Guided Step 1B - Inspect the engine speed sensor.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.
  • Remove the engine speed sensor.

Action

Inspect engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.
OK NOT OK

No damaged engine speed sensor?

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 1C

Go to 3A

Guided Step 1C - Check for a short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine block ground.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin to the engine block ground.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 1D

Go to 3A

Guided Step 1D - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

1k to 2k ohms?

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 1E

Go to 3A

Guided Step 1E - Check for short circuit between coils.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin to the engine speed sensor 2 SIGNAL pin.
  • Measure the resistance between the engine speed sensor 1 RETURN pin to the engine speed sensor 2 RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Replace the engine speed sensor. Refer to Procedure 019-042 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Check for short circuit to engine block ground.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin on the engine harness to the engine block ground.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin on the engine harness to the engine block ground.
OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor 1 SIGNAL pin to the engine speed sensor 1 RETURN pin on the engine harness.
  • Measure the resistance from the engine speed sensor 2 SIGNAL pin to the engine speed sensor 2 RETURN pin on the engine harness.
OK NOT OK

Less than 2k ohms?

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor 1 SIGNAL pin and all other pins of the engine harness.
  • Measure the resistance between the engine speed sensor 1 RETURN pin and all other pins of the engine harness.
  • Measure the resistance between the engine speed sensor 2 SIGNAL pin and all other pins of the engine harness.
  • Measure the resistance between the engine speed sensor 2 RETURN pin and all other pins of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

OK NOT OK

Greater than 100k ohms?

Repair or replace the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in the IDLE position.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 121 is inactive.
OK NOT OK

Fault Code 121 inactive?

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Place the run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
OK NOT OK

All fault codes cleared?

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Jul-2015


FAULT CODE 187 - Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK23 CM2250 K109 | 4367358
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM) cccccc, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine oil pressure sensor and circuit connected to the sensor number 2 supply and return, if equipped. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine oil pressure sensor and circuit connected to the sensor number 2 supply and return (if equipped).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness, if equipped.

If the engine is not equipped with an oil pressure sensor, skip to step 2F

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 195 - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

See Fault Code 1695

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 196 - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 1696

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Use circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

See the Coolant Loss symptom troubleshooting tree.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 222 active?
STEP 2. | Check the barometric air pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect engine control module ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate faullt code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness.

Action

Inspect the engine harness connector and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN (sensor RETURN 2) pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the barometric air pressure sensor connector of the engine harness.

Usethe circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

A damaged sensor has been detected.

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible..

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the barometric pressure +5 volt SUPPLY (sensor SUPPLY 2) pin and the barometric pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

An open or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 223 - Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Burn Valve Solenoid, Centinel™ Oil | Refer to Procedure 019-173 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 223 active?
STEP 2. | Check engine oil control valve and circuit. |
 | STEP 2A. Inspect the engine oil control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine oil control valve resistance. | Greater than 6 ohms?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 223 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 223 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine oil control valve and circuit.

Guided Step 2A - Inspect the engine oil control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil control valve from the engine harness.

Action

Inspect the engine oil control valve and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine oil control valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil control valve from the engine harness.

Action

Check the engine oil control valve resistance.

  • Measure the resistance of the solenoid and check for low resistance between the engine oil control valve SIGNAL pin and the engine oil control valve RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the engine oil control valve. Refer to Procedure 019-173 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil control valve from the engine harness.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the starter motor relay control SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the engine oil control valve signal wire in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine oil control valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine oil control valve SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the starter motor relay control SIGNAL wire in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and perform the Centinel™ Operational Test using INSITE™ electronic service tool.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 223 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 224 - Engine Oil Burn Valve Solenoid Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4357358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4357358
Burn Valve Solenoid, Centinel™ Oil | Refer to Procedure 019-173 | QSK23 CM2250 K109 | 4357358

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 224 active?
STEP 2. | Check the engine oil control valve circuit. |
 | STEP 2A. Inspect the engine oil control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the engine oil control valve. | Less than 100 ohms?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine oil control valve signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine oil control valve return circuit. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 224 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil control valve circuit.

Guided Step 2A - Inspect the engine oil control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil control valve from the engine harness.

Action

Inspect the engine oil control valve and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine oil control valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the engine oil control valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil control valve from the engine harness.

Action

Check the engine oil control valve resistance.

  • Measure the resistance between the engine oil control valve SIGNAL pin and the engine oil control valve RETURN pin at the engine oil control valve.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

Replace the engine oil control valve solenoid. Refer to Procedure 019-173 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine oil control valve signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine oil control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil control valve SIGNAL pin at the engine oil control valve connector and the engine oil control valve SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine oil control valve SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine oil control valve return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine oil control valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil control valve RETURN pin at the engine oil control valve connector and the engine oil control valve RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine oil control valve RETURN wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine oil control valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil control valve SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the control SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 224 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 2 line.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is avaiable. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is avaiable.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 1A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 254 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Shutoff Valve Solenoid | Refer to Procedure 019-050 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 254 active?
STEP 2. | Check the engine fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the engine fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine fuel shutoff valve. | 24 to 50 ohms?
 | STEP 2C. Check for a short to ground in the engine fuel shutoff valve. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel shutoff valve and circuit.

Guided Step 2A - Inspect the engine fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check engine fuel shutoff valve resistance.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin and the engine fuel shutoff valve RETURN pin at the engine fuel shutoff valve.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

24 to 50 ohms?
YES NO
No Repair

A damaged engine fuel shutoff valve has been detected.

  • Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short to ground in the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine harness.

Action

Check for an engine fuel shutoff valve short to ground.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin and ground at the engine fuel shutoff valve.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A damaged engine fuel shutoff valve has been detected.

  • Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the OEM harness connector.

Clean the connector and pins.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in the OEM harness ECM connector and all other pins in the connector .

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 255 - Engine Fuel Shutoff Valve Driver Circuit - Voltage High or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Shutoff Valve | Refer to Procedure 019-050 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 255 active?
STEP 2. | Check the engine fuel shutoff valve and circuit. |
 | STEP 2A. Inspect the engine fuel shutoff valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine fuel shutoff valve. | 24 to 50 ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel shutoff valve and circuit.

Guided Step 2A - Inspect the engine fuel shutoff valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Inspect the engine harness and engine fuel shutoff valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check engine fuel shutoff valve resistance.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin and the engine fuel shutoff valve RETURN pin at the engine fuel shutoff valve connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

24 to 50 ohms?
YES NO
No Repair

A damaged engine fuel shutoff valve has been detected.

Replace the engine fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM and the OEM harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine fuel shutoff valve SIGNAL pin and the engine harness engine fuel shutoff valve connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open engine fuel shutoff valve signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4B

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine fuel shutoff valve RETURN pin and the engine harness engine fuel shutoff valve connector RETURN pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the engine fuel shutoff valve SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 257 - Engine Fuel Shutoff Valve Driver - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Shutoff Valve | Refer to Procedure 019-050 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for related fault codes. |
 | STEP 1A. Check for active Fault Code 255. | Fault Code 255 active?
STEP 2. | Check for extra wires. |
 | STEP 2A. Check for extra wires attached to the fuel shutoff valve solenoid. | Extra wires detected?
STEP 3. | Check for proper fuel shutoff valve circuit operation. |
 | STEP 3A. Check for proper fuel shutoff valve circuit operation. | Voltage available at the fuel shutoff valve greater than 11-VDC with the keyswitch ON, and less than 0.5-VDC with the keyswitch OFF?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the fuel shutoff valve actuator disc. |
 | STEP 4A. Check the fuel shutoff valve actuator disc. | Debris or damage found on the valve disc, valve seat, or actuator disc?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for related fault codes.

Guided Step 1A - Check for active Fault Code 255.

Conditions

  • All components connected.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 255 active?
YES | NO
No Repair | No Repair

Reference Fault Code 255 troubleshooting tree.

Go to 2A

Guided Step 2 - Check for extra wires.

Guided Step 2A - Check for extra wires attached to the fuel shutoff valve solenoid.

Conditions

  • Turn keyswitch OFF.

Action

Check for extra wires.

  • Check for extra wires attached to the fuel shutoff valve solenoid.

Extra wires detected?
YES NO

Remove the extra wires attached to the fuel shutoff valve solenoid.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check for proper fuel shutoff valve circuit operation.

Guided Step 3A - Check for proper fuel shutoff valve circuit operation.

Conditions

  • Connect all components.

Action

Check the fuel shutoff valve circuit operation.

  • Turn keyswitch ON.
  • Verify the voltage available at the fuel shutoff valve is greater than 22-VDC.
  • Turn keyswitch OFF.
  • Verify the voltage available at the fuel shutoff valve is less than 0.5-VDC.

Voltage available at the fuel shutoff valve greater than 22-VDC with the keyswitch ON, and less than 0.5-VDC with the keyswitch OFF?

YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine fuel shutoff valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel shutoff valve SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit on the engine fuel shutoff valve SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the fuel shutoff valve actuator disc.

Guided Step 4A - Check the fuel shutoff valve actuator disc.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve solenoid, valve disc, valve seat, and actuator disc.

Action

Check the fuel shutoff valve actuator disc.

  • Check the housing, valve disc, valve seat, and actuator disc for dirt, debris, metal parts, bonding separation, corrosion, cracks, or wear.

Debris or damage found on the valve disc, valve seat, or actuator disc?
YES NO

Replace the damaged fuel shutoff valve component. Refer to Procedure 019-050 in the Associated Procedures Table.

Assemble the fuel shutoff valve.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 261 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4332682

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823256 - Metri-Pack 2-way connector test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor accuracy with a thermocouple or similar temperature probe. | Sensor reading correlates with temperature probe or known value?
STEP 2. | Check the ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine fuel temperature sensor accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Place the run/stop/auto switch in the STOP position.
  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Verify the engine fuel temperature sensor accuracy with a thermocouple or similar temperature probe.

  • Compare the engine fuel temperature reading on INSITE™ service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, answer Yes to this step.

Sensor reading correlates with temperature probe or known value?
YES NO

Sensor reading is correct. This fault code could be caused by operation in high temperature environments with low fuel level in the tank.

Replace the engine fuel temperature sensor.

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 1A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 263 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine fuel temperature sensor 1 SIGNAL pin and engine fuel temperature sensor 1 RETURN pin at the engine harness engine fuel temperature sensor 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active and Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO

A damaged sensor has been detected.

Replace the engine fuel temperature sensor 1. Refer to Procedure 019-119 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine fuel temperature 1 SIGNAL pin and engine fuel temperature 1 RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active and Fault Code 263 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor 1 RETURN pin and the engine harness engine fuel temperature sensor 1 connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor 1 SIGNAL pin and the engine harness engine fuel temperature sensor 1 connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 265 active?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 265 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 265 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and engine fuel temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-119 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

A damaged sensor has been detected.

  • Replace the engine fuel temperature sensor 1. Refer to Procedure 019-119 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire in the engine harness.

  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel temperature sensor 1 SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short on the SIGNAL wire has been detected in the engine harness.

Repair or replace the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 266 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Name | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K105 | 4326157
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K108 | 4332823
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K111 | 4358519
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor 1 accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Readings correct?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine fuel temperature sensor 1 accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect INSITE™ electronic service tool.
  • Compare the engine fuel temperature sensor 1 reading on the service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, answer Yes to this step.

Readings will possibly need to be checked while engine is operating at normal temperature conditions 82°C [180°F].

Readings correct?
YES NO
No Repair

Sensor reading incorrect. Replace the fuel supply temperature sensor.

  • Refer to Procedure 019-119 in the Associated Procedures Table.

Refer to Fuel Temperature Above Normal Operating Range symptom tree in Section TS

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 279 - Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fueling Actuator | Refer to Procedure 019-110 | QSK78 CM2250 K104 | 4332682
Fueling Actuator | Refer to Procedure 019-110 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 279 active?
STEP 2. | Check the fuel rail actuator. |
 | STEP 2A. Inspect the fuel rail actuator and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the coil resistance of the fuel rail actuator. | 7.0 to 9.0 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 279 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel rail actuator.

Guided Step 2A - Inspect the fuel rail actuator and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.

Action

Inspect the fuel rail actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Extra wires?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the coil resistance of the fuel rail actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel rail actuator.

Action

Check the coil resistance of the fuel rail actuator.

  • Measure the resistance from the fuel rail actuator SIGNAL pin to the fuel rail actuator RETURN pin.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

7.0 to 9.0 ohms?
YES NO
No Repair

Replace the fuel rail actuator. Refer to Procedure 019-110 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

  • Connect all components.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure resistance between the fuel rail actuator SIGNAL pin and all other pins in the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a return short to the power supply.

  • Measure the resistance from the fuel rail actuator RETURN pin and ground.

Reference the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 316 - Fuel Supply Pump Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Pump Actuator | Refer to Procedure 019-117 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fuel pump actuator. |
 | STEP 1A. Inspect the fuel pump actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the coil resistance of the fuel pump actuator. | 6 to 9 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 2C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fuel pump actuator.

Guided Step 1A - Inspect the fuel pump actuator and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the coil resistance of the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check the coil resistance of the fuel pump actuator.

  • Measure the resistance from the fuel pump actuator SIGNAL pin to the fuel pump actuator RETURN pin.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

6 to 9 ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the fuel pump actuator RETURN pin and ground.
  • Measure the resistance from the fuel pump actuator SIGNAL pin and ground.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure the resistance between the fuel pump actuator RETURN pin and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair Complete

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 317 - Fuel Supply Pump Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Pump Actuator | Refer to Procedure 019-117 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 317 active?
STEP 2. | Check the fuel pump actuator. |
 | STEP 2A. Inspect the fuel pump actuator and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the coil resistance of the fuel pump actuator. | 7 to 9 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 317 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the coil resistance of the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the fuel pump actuator.

Action

Check the coil resistance of the fuel pump actuator.

  • Measure the resistance from the fuel pump actuator SIGNAL pin to the fuel pump actuator RETURN pin.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

7 to 9 ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM.

Action

Inspect the engine harness and the ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure resistance between the fuel pump actuator SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel pump actuator RETURN pin and ground.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 319 - Real Time Clock - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or inactive fault codes?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 319 inactive?
 | STEP 2B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive fault codes?
YES NO

Troubleshoot other fault codes before acknowledging this fault code.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Reset the original equipment manufacturer (OEM)-supplied reset button or switch.
  • Use INSITE™ electronic service tool to reset the fault code.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 319 inactive?
YES NO
No Repair

Contact a Cummins® Authorized Repair Location if the fault code will not reset.

Go to 2B

Go to 2A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.
  • Run the engine for 5 minutes to verify that fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 13-Jul-2015


FAULT CODE 342 - Electronic Calibration Code Incompatibility - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Control Module ROM Boot | Refer to Procedure 019-427 | QSK78 CM2250 K104 | 4332682

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM) and engine harness. |
 | STEP 1A. Inspect all ECM and engine harness connector pins. | Dirty or damaged pins?
STEP 2. | Inspect terminating resistors and circuit. |
 | STEP 2A. Inspect the terminating resistors. | 120 ohms?
 | STEP 2B. Inspect the data link circuit. | 60 ohms?
STEP 3. | Calibrate the ECM. |
 | STEP 3A. Calibrate the ECM. | ECM accepted calibration?
 | STEP 3B. ROM boot the ECM. | ROM boot procedure successful?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 342 inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine control module (ECM) and engine harness.

Guided Step 1A - Inspect all ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all of the engine harness connectors from the ECM connectors.

Action

Inspect all ECM and engine harness connector pins.

Inspect the engine harness and all ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in an ECM engine connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Reference the circuit diagram or wiring diagram for connector identification.

Check all harnesses connected in series. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Inspect the terminating resistors and circuit.

Guided Step 2A - Inspect the terminating resistors.

Conditions

  • Disconnect the terminating resistors.

Action

Measure the resistance across SAE J1939 data link SUPPLY pin and SAE J1939 data link RETURN pin on both terminating resistors.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

120 ohms?
YES NO
No Repair

Replace the terminating resistors.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the data link circuit.

Conditions

  • Disconnect all of the engine harness ECM 60-pin connectors.
  • Connect the terminating resistors.

Action

Measure the resistance across SAE J1939 data link RETURN pin and SAE J1939 data link SUPPLY pin on the 60-pin connectors for all ECMs.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

60 ohms?
YES NO
No Repair

A damaged connection has been detected in an ECM connector or engine harness connector.

Clean the connector and pins.

Replace the damaged section of harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Check all harnesses connected in series. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Calibrate the ECM

Guided Step 3A - Calibrate the ECM.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECM.

  • Use the following procedure and INSITE™ electronic service tool user's manual to calibrate the ECM. Refer to Procedure 019-032 in Section 19.

ECM accepted calibration?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - ROM boot the ECM.

Conditions

  • Turn keyswitch OFF.

Action

ROM boot the ECM.

  • Refer to Procedure 019-427 in the Associated Procedures Table.

ROM boot procedure successful?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4B

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 342 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 2B

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 2B

Last Modified: 13-Jul-2015


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the timing rail pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the fuel pump pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the ambient air pressure sensor and circuit connected to the sensor number 1 supply and return, if equipped. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response |
STEP 3. | Check the engine control module (ECM) and engine harness.. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the timing rail pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail pressure sensor from the engine harness.

Action

Inspect the engine harness and timing rail pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the timing rail pressure sensor.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel pump pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel pump pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fuel pump pressure sensor.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the ambient air pressure sensor and circuit connected to the sensor number 1 supply and return, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.

Action

Inspect the engine harness and ambient air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the ambient air pressure sensor.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedures.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the engine control module (ECM) and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine control module (ECM) and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 1 wire.

Replace the damaged section of the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 423 - Injector Timing Rail 1 Fuel Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Timing Pressure Sensor | Refer to Procedure 019-113 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824774 - Pressure sensor breakout cable, Part Number 3824776 - Pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164752 - Danfoss™ pressure sensor breakout cable, Part Number 3164132 - Deutsch™ socket pin test lead, and Part Number 3164133 - Deutsch™ pin test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the timing rail pressure sensor. |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor supply voltage. | Between 4.75 and 5.25-VDC?
 | STEP 1C. Check the sensor signal voltage. | Between 0.46 and 4.56-VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check for sensor accuracy. |
 | STEP 3A. Compare timing, rail, and ambient air pressure sensor readings. | Timing = rail pressure, Timing = ½ ambient air pressure?
STEP 4. | Check for drain line restriction. |
 | STEP 4A. Check for drain line restriction. | Restriction in drain line?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 423 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the timing rail pressure sensor.

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Place run/stop/auto switch in STOP position.
  • Disconnect the engine harness connector from the timing rail pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair or replace the engine harness or the timing rail pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the damaged pins.

  • Repair the engine harness. Refer to Procedure 019-201, Refer to Procedure 019-202, Refer to Procedure 019-205, or Refer to Procedure 019-219 in Section 19.
  • Replace the timing rail pressure sensor. Refer to Procedure 019-113 in the Associated Procedures Table.

 No Repair

Go to 1B

Go to 6A

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place run/stop/auto switch in RUN position.

Action

Check the timing rail pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Place run/stop/auto switch in RUN position.

Action

Check the timing rail pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 0.46 and 4.56-VDC?
YES NO
No Repair

Replace the timing rail pressure sensor. Refer to Procedure 019-113 in the Associated Procedures Table.

Go to 2A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness connector pins.

Conditions

  • Place run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit.

Conditions

  • Place the run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the extension harness.
  • Disconnect the engine harness from the timing rail pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the timing rail pressure sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness ECM connector to all other pins in the engine harness ECM connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness ECM connector to all other pins in the engine harness ECM connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness ECM connector to all other pins in the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Place run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an open circuit.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness ECM connector to the timing rail pressure SUPPLY pin on the engine harness sensor connector.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness ECM connector to the timing rail pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness ECM connector to the timing rail pressure RETURN pin on the engine harness sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • Place run/stop/auto switch in STOP position.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the timing rail pressure sensor.

Action

Check for an short circuit to engine block ground.

  • Measure the resistance from the timing rail pressure SUPPLY pin on the engine harness ECM connector to engine block ground.
  • Measure the resistance from the timing rail pressure SIGNAL pin on the engine harness ECM connector to engine block ground.
  • Measure the resistance from the timing rail pressure RETURN pin on the engine harness ECM connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for sensor accuracy.

Guided Step 3A - Compare timing, rail, and ambient air pressure sensor readings.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Measure timing, rail, and ambient air pressure sensor readings.

  • Use INSITE™ electronic service tool to measure timing, rail, and ambient air pressure.

Timing = rail pressure

Timing = ½ ambient air pressure
YES NO
No Repair

Repair or replace the fuel timing pressure sensor. Refer to Procedure 019-113 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for drain line restriction.

Guided Step 4A - Check for drain line restriction.

Conditions

  • Place run/stop/auto switch in STOP position.

Action

Check for drain restriction in the drain line.

  • Check for drain line restriction.

Restriction in drain line?
YES NO

Correct restriction in drain line.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Place the idle/rated switch in IDLE position.
  • Place the run/stop/auto switch in RUN position and idle for 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 423 is inactive.

Fault Code 423 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting tree.

Last Modified: 13-Jul-2015


FAULT CODE 426 - J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Electronic Control Module (ECM) | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - ECM Bench Top Calibration Harness and Part Number 4919009 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 data link communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | INSITE™ electronic service tool communicates with the ECM?
 | STEP 1B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check for an open or short circuit in the J1939. | 50 to 70 ohms?
 | STEP 1D. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 1E. Check ECM communication with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with the ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ 4 or later version data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to communicate with the ECM.

  • Start INSITE™ electronic tool and connect to the ECM using INLINE™ 4 or later version (J1939) ECM connection.
  • Use INSITE™ electronic service tool to communicate with the ECM.

INSITE™ electronic service tool communicate with the ECM?
YES NO

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

Refer to the original equipment manufacturer (OEM) service manual for information on troubleshooting and vehicle SAE J1939 data link network.

Go to 1B

Guided Step 1B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM 60 pin original equipment manufacturer (OEM) connector.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connectors and pins.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

  • Repair the harness. Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for all interconnections.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for an open or short circuit in the J1939.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 datal link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1D

Go to 2B

Guided Step 1D - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 datal link (+) wire and the SAE J1939 data link (-) wire on the Cummins® engine ECM OEM connection to all other pins in the OEM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 1E

Go to 2B

Guided Step 1E - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 50-pin connector.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ 4 or later version data link adapter
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool and connect to the ECM using INLINE™ 4 or later version (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM datalink circuit is functioning properly.

Refer to the OEM service manual for information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

Refer to the OEM service manual.

Refer to the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Verify Fault Code 426 is inactive.

Fault Code 426 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 13-Jul-2015


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK23 CM2250 K109 | 4367358
Fuel Control Valve Body Assembly | Refer to Procedure 006-049 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 279, 455, or 2311 active or inactive counts?
 | STEP 1B. Check for active fault codes. | Fault Code 2261 active or inactive counts?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with INSITE™ electronic service tool. | Fuel rail pressure within 14 kPa [2 psi] of gauge or correlate with a known value?
STEP 3. | Check the fuel system flow. |
 | STEP 3A. Check the fuel tank level. | Fuel in tank?
 | STEP 3B. Check the fuel system for leaks, damaged lines, or loose fittings. | Leaks, damaged lines, or loose fittings found?
 | STEP 3C. Check the fuel inlet restriction. | Less than 203 mm-Hg [8 in-Hg]?
 | STEP 3D. Check for air in the fuel. | No air in fuel?
STEP 4. | Check the fuel rail actuator. |
 | STEP 4A. Inspect the fuel rail actuator. | Debris or damage present?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector circuit fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 279, 455, or 2311 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector circuit fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2261 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Install a gauge or digital multimeter pressure sensor at the fuel control block outlet.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Monitor fuel rail pressure with INSITE™ electronic service tool with engine OFF and at idle.
  • Compare the reading in INSITE™ with a gauge or known value.

Fuel rail pressure within 14 kPa [2 psi] of gauge or correlate with a known value?
YES NO
No Repair

Replace the fuel rail pressure sensor.

  • Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the fuel system flow.

Guided Step 3A - Check the fuel tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank level.

.

Fuel in tank?
YES | NO
No Repair | No Repair

Go to 2B

Go to 5A

Guided Step 3B - Check the fuel system for leaks, damaged lines, or loose fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel system.

  • Inspect the fuel system for leaks, broken lines, and loose fittings.

Leaks, damaged lines, or loose fittings found?
YES NO

Repair the leak. Tighten or replace the leaking fitting or fuel line.

 No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel return line from the fuel tank.
  • Remove the fuel return line from the fuel return check valve.

Action

Check the fuel inlet restriction.

  • Refer to Procedure 005-016 in the Associated Procedures Table.

Less than 203 mm-Hg [8 in-Hg]?
YES NO
No Repair

Find the cause of the restriction and remove the restriction. Check for clogged filters, debris in the fuel tank, clogged tank vents, malfunctioning fuel lines, and/or malfunctioning check valves.

Go to 4A

Go to 4A

Guided Step 4 - Check the fuel rail actuator.

Guided Step 4A - Inspect the fuel rail actuator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel rail actuator for debris.

  • Remove the fuel rail actuator from the control block. Refer to Procedure 006-049 in the Associated Procedures Table.
  • Inspect the fuel rail actuator for debris or damage.

Debris or damage present?
YES NO

Replace the fuel rail actuator. Refer to Procedure 006-049 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 455 - Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Control Valve Body Assembly | Refer to Procedure 006-049 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 455 active?
STEP 2. | Check the fuel rail actuator. |
 | STEP 2A. Inspect the fuel rail actuator and the engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the coil resistance of the fuel rail actuator. | 7 ohms to 9 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 455 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel rail actuator.

Guided Step 2A - Inspect the fuel rail actuator and the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.

Action

Inspect the engine harness and the fuel rail actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the coil resistance of the fuel rail actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the the engine harness from the fuel rail actuator.

Action

Check the coil resistance of the fuel rail actuator.

  • Measure the resistance from the fuel rail actuator SIGNAL pin to the fuel rail actuator RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

7 ohms to 9 ohms?
YES NO
No Repair

Replace the fuel rail actuator. Refer to Procedure 006-049 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure resistance between the fuel rail actuator SIGNAL pin and all other pins in the engine harness ECM connector.
  • Measure resistance between the fuel rail actuator RETURN pin and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance from the fuel rail actuator SIGNAL pin and ground.
  • Measure the resistance from the fuel rail actuator RETURN pin and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the fuel rail actuator SIGNAL pin in the engine harness fuel rail actuator connector to the fuel rail actuator SIGNAL pin in the engine harness ECM connector.
  • Measure the resistance from the fuel rail actuator RETURN pin in the engine harness fuel rail actuator connector to the fuel rail actuator RETURN pin in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 515 - Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 515 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 515 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 6 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 516 - Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male WeatherPack™ test lead, Part Number 3823996 - female WeatherPack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 516 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the fuel rail pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 516 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 516 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the fuel rail pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-May-2015


FAULT CODE 546 - Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for inactive fault code. | Fault Code 546 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 547 active and Fault Code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Resistance between 4.75 and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 546 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault codes. | Faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor or harness connector.

Clean the connector and pins.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY (sensor supply 2) pin to the fuel delivery pressure RETURN (sensor return 2) pin at the sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

A damaged fuel delivery pressure sensor has been detected.

  • Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive ?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the fuel delivery pressure SIGNAL wire of the engine harness.

Use the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector pins.

  • Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance between 4.75 and 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open fuel delivery pressure return circuit has been detected in the engine harness.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 547 - Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 547 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Resistance between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 546 active and Fault Code 547 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 547 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 547 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY pin and the fuel delivery pressure SIGNAL pin at the fuel delivery pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO

A damaged fuel delivery pressure sensor has been detected.

  • Replace the damaged sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the engine harness connector port of the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 4.75 and 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted fuel delivery pressure 5 volt supply circuit has been detected in the engine harness.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected at the ECM or engine harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY pin and the fuel delivery pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open fuel delivery pressure signal circuit or pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-May-2015


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Supply Lines | Refer to Procedure 006-024 | QSK23 CM2250 K109 | 4367358
Fuel Control Valve Body Assembly | Refer to Procedure 006-049 | QSK23 CM2250 K109 | 4367358
Fuel Shutoff Valve | Refer to Procedure 019-050 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 254, 255, 279, 455, or 2311 active or inactive counts?
 | STEP 1B. Check for active fault codes. | Fault Code 2261 or 2262 active or inactive counts?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with INSITE™ electronic service tool. | Fuel rail pressure within 14 kPa [2 psi] of gauge or correlate with a known value?
STEP 3. | Inspect the fuel lines. |
 | STEP 3A. Check the fuel lines. | Fuel lines damaged or leaking?
STEP 4. | Check the actuators in the fuel control block. |
 | STEP 4A. Inspect the fuel rail actuator. | Debris or damage present?
 | STEP 4B. Inspect the fuel shut off valve. | Debris or damage present?
STEP 5. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector circuit fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 254, 255, 279, 455, or 2311 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector circuit fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2261 or 2262 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Install a gauge or digital multimeter pressure sensor at the electronic control valve assembly (ECVA) outlet.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy

  • Monitor the fuel rail pressure with INSITE™ electronic service tool with engine OFF and at idle.
  • Compare the reading in INSITE™ electronic service tool with a gauge or known value.

Fuel rail pressure within 14 kPa [2 psi] of gauge or correlate with a known value?
YES NO
No Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Inspect the fuel lines.

Guided Step 3A - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel lines from the outlet of the fuel pump to the fuel return check valve for the following:

  • Damage or kinks
  • Leaks or loose fittings.

Refer to Procedure 006-024 in the Associated Procedures Table.

Any fuel lines damaged or leaking?
YES NO

Tighten any loose fittings.

Replace any damaged fuel lines. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the actuators in the fuel control block.

Guided Step 4A - Inspect the fuel rail actuator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel rail actuator for debris.

  • Remove the fuel rail actuator from the ECVA. Refer to Procedure 006-049 in the Associated Procedures Table.
  • Inspect the fuel rail actuator for debris or damage.

Debris or damage present?
YES NO

Replace the fuel rail actuator. Refer to Procedure 006-049 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the fuel shutoff valve.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel shutoff valve for debris.

  • Remove the fuel shutoff valve from the ECVA. Refer to Procedure 019-050 in the Associated Procedures Table.
  • Inspect the fuel shutoff valve for debris or damage.

Debris or damage present?
YES NO

Replace the fuel shutoff valve. Refer to Procedure 019-050 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration RevisionHistory for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 1411 - Generator Output Frequency Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1411 inactive?
STEP 2. | Check the engine harness and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 1411 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, OEM harness, or the ECM.

Check all harnesses connected in series.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional frequency adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open optional frequency adjust potentiometer return (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the frequency adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or potentiometer has been detected. Refer to the OEM service manual.

A pin-to-pin short circuit on the optional frequency adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1411 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 13-Jul-2015


FAULT CODE 1412 - Droop Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1412 inactive?
STEP 2. | Check the engine harness and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 1412 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the followingh Procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional droop adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open optional droop adjust potentiometer return (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the optional gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or potentiometer has been detected. Refer to the OEM service manual for repair instructions.

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1412 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 13-Jul-2015


FAULT CODE 1418 - Gain Adjust Potentiometer Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number- 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1418 inactive?
STEP 2. | Check the engine harness and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the OEM harness from the engine harness.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, OEM harness, or the ECM.

Check all harnesses connected in series.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector optional gain adjust potentiometer RETURN (sensor return 4) pin and the OEM harness connector optional gain adjust potentiometer RETURN (sensor return 4) pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open optional gain adjust potentiometer return (sensor return 4) circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM connector at the ECM.
  • Disconnect the engine harness from the 31-pin OEM connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output gain adjust potentiometer SIGNAL pin in the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin in the ECM engine harness connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

A damaged generator drive harness or potentiometer has been detected. See equipment manufacturer service information.

A pin-to-pin short circuit on the optional gain adjust potentiometer SIGNAL wire or gain adjust potentiometer 5 volt SUPPLY (sensor supply 4) wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-May-2015


FAULT CODE 1427 - Overspeed Shutdown Relay Driver Diagnostic Has Detected an Error - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1427 inactive?
STEP 2. | Check the engine harness and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1427 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Inspect the engine harness and original equipment manufacturer (OEM) harness connector.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector overspeed shutdown SIGNAL pin and the OEM harness connector overspeed shutdown SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open overspeed shutdown signal circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the overspeed shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin inspection. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO

No repair

A pin-to-pin short circuit on the overspeed shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin short to ground

  • Measure the resistance and check for a short circuit between the overspeed shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin inspection. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or lamp has been detected. See equipment manufacturer service information.

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-May-2015


FAULT CODE 1428 - Low Oil Pressure (LOP) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1428 inactive?
STEP 2. | Check the engine harness and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1428 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector low oil pressure shutdown SIGNAL pin and the OEM harness connector low oil pressure shutdown SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open low oil pressure shutdown SIGNAL circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the low oil pressure shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

No repair

A pin-to-pin short circuit on the low oil pressure shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin short to ground

  • Measure the resistance and check for a short circuit between the low oil pressure shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19..

Greater than 100k ohms?
YES NO

A damaged generator drive harness or lamp has been detected. See equipment manufacturer service information.

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 1429 - High Engine Temperature (HET) Shutdown Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1429 inactive?
STEP 2. | Check the engine harness and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1429 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector HET shutdown SIGNAL pin and the OEM harness connector HET shutdown SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin indentification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open HET shutdown signal circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the HET shutdown SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin indentification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

No repair

A pin-to-pin short circuit on the HET shutdown SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the HET shutdown SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or lamp has been detected. See equipment manufacturer service information.

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 1431 - Pre-Low Oil Pressure Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4332768

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1431 inactive?
STEP 2. | Check the engine harness and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Clear the inactive fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1431 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine harness and OEM harness.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or the ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, the OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector Pre-Low Oil Pressure Warning SIGNAL pin and the OEM harness connector Pre-Low Oil Pressure Warning SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pre-low oil pressure warning signal circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the Pre-Low Oil Pressure Warning SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

No repair

A pin-to-pin short circuit on the pre-low pressure warning SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the pre-low oil pressure warning SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or lamp has been detected. See equipment manufacturer service information.

A pin-to-ground short has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jul-2015


FAULT CODE 1432 - Pre-High Engine Temperature Warning Relay Driver Diagnostic Has Detected An Error - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1427 inactive?
STEP 2. | Inspect the engine harness and original equipment manufacturer (OEM) harness connector. |
 | STEP 2A. Inspect the engine harness and OEM harness connector. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1427 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1432 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Inspect the engine harness and original equipment manufacturer (OEM) harness connector.

Guided Step 2A - Inspect the engine harness and OEM harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the engine control module (ECM).
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Inspect the OEM harness and engine harness to ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine harness connector, OEM harness connector, or ECM connector.

Clean the connector and pins.

Replace the damaged section of the engine harness, OEM harness, or the ECM.

Check all harnesses connected in series.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector pre-high engine temperature warning SIGNAL pin and the OEM harness connector pre-high engine temperature warning SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open pre-high engine temperature warning signal circuit has been detected in the engine harness.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the pre-high engine temperature warning SIGNAL pin in the ECM engine harness connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

No repair

A pin-to-pin short circuit on the pre-high engine temperature warning SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM connector at the ECM.
  • Disconnect the engine harness connector from the OEM harness connector.

Action

Check for a pin to short ground

  • Measure the resistance and check for a short circuit between the pre-high engine temperature warning SIGNAL pin at the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for correct connector pin identification. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or lamp has been detected. See equipment manufacturer service information.

A short circuit to ground has been detected in the engine harness.

Troubleshoot each of the harness sections to determine which contains the short circuit to ground.

Check all harnesses connected in series.

Replace the damaged section of engine harness.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1432 inactive?
YES NO

No repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-May-2015


FAULT CODE 1597 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 1597 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 1597. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1597 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1597 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 1597.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 1597.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 1597.

Less than three counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-May-2015


FAULT CODE 1695 - Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for active or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the speed bias circuit from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 5 pin at the OEM harness ECM connector to all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected on the sensor supply 5 circuit.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 1696 - Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the coolant level sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the speed bias circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the coolant level sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.

Action

Inspect the coolant level sensor, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the coolant level sensor. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the speed bias circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the speed bias circuit from the OEM harness.

Action

Inspect the speed bias circuit, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the speed bias circuit from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Repair or replace the speed bias circuit. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the speed bias circuit from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the OEM harness ECM connector sensor SUPPLY 5 pin and all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the speed bias circuit from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the OEM harness ECM connector sensor SUPPLY 5 pin and the engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 1978 - Generator Speed/Load Governing Bias Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor supply Fault Code 1695 or 1696 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1979 active and Fault Code 1978 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1978 active?
STEP 3. | Check the engine control module (ECM), OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1978 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1978 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 1695 or 1696 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1695 or 1696.

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the OEM connector pins.

Conditions

  • Turn keyswitch ON
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A malfunctioning connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active and Fault Code 1978 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 5) pin and the generator speed/load governing bias RETURN (sensor return 5) pin at the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the engine harness connector to the OEM 31-pin connector.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active?
YES NO

A malfunction on the generator set side has been detected.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port and 60-pin connectors
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias RETURN (sensor return 5) pin and the OEM harness connector generator speed/load governing bias RETURN (sensor return 5) pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias return (sensor return 5) circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the ECM 60-pin connector
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted supply circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1978 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-May-2015


FAULT CODE 1979 - Generator Speed/Load Governing Bias Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 1695 or 1696 active?
STEP 2. | Check the generator speed/load governing bias circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1978 active and Fault Code 1979 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1979 active?
STEP 3. | Check the engine control module (ECM), OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1979 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1979 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to tool read the fault codes.

Sensor supply Fault Code 1695 or 1696 active?
YES | NO
No Repair | No Repair

Fault Code 2186

Go to 2A

Guided Step 2 - Check the generator speed/load governing bias circuit.

Guided Step 2A - Inspect the original equipment manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-208 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector B.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 5) pin and the generator speed/load governing bias RETURN (sensor return 5) pin at the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector B.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the generator speed/load governing bias 5 volt SUPPLY (sensor supply 5) pin and the generator speed/load governing bias SIGNAL pin at the OEM 31-pin B connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1978 active and Fault Code 1979 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 31-pin connector B.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 active?
YES NO

A malfunction on the generator set side has been detected.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM), OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin OEM port connector and 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator speed/load governing bias SIGNAL pin and the OEM 31-pin connector B generator speed/load governing bias SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator speed/load governing bias SIGNAL circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness connector from the OEM 31-pin connector B.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator speed/load governing bias SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the generator speed/load governing bias SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1979 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1979 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-May-2015


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wirning Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays 15 percent above rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine revolutions per minute (rpm). | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Operate the engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine crankshaft speed/position sensor reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Troubleshoot Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

Reference the appropriate circuit or wiring diagram for all engine harness interconnections.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

–

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine to check if the overspeed condition is still present.

–

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1992 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Go to the appropriate troubleshooting steps.

Last Modified: 14-May-2015


FAULT CODE 2261 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Fuel Pump Actuator | Refer to Procedure 019-117 | QSK23 CM2250 K109 | 4367358
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with INSITE™ electronic service tool. | Fuel delivery pressure within 14 kPa [2 psi] of gauge or correlate with a known value?
STEP 2. | Check the fuel inlet pressure. |
 | STEP 2A. Check the fuel inlet pressure. | Fuel inlet pressure always less than 3.45 kPaG [0.5 psig]?
STEP 3. | Check the fuel supply lines. |
 | STEP 3A. Check the fuel supply lines | Any fuel lines damaged or kinked?
STEP 4. | Check the fuel pump actuator. |
 | STEP 4A. Inspect the fuel pump actuator. | Debris or damage present?
STEP 5. | Check the ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Install a gauge or digital multimeter pressure sensor at the fuel pump outlet.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Monitor fuel delivery pressure with INSITE™ electronic service tool with engine OFF and at idle.
  • Compare the INSITE™ electronic service tool reading with a gauge or known value.

Fuel delivery pressure within 14 kPa [2 psi] of gauge or correlate with a known value?
YES NO
No Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2 - Check the fuel inlet pressure.

Guided Step 2A - Check the fuel inlet pressure.

Conditions

  • Turn keyswitch OFF.
  • Install a gauge or digital multimeter pressure sensor at the fuel pump inlet.

Action

Check the fuel inlet pressure.

  • Start and operate the engine at low idle and high idle.

Fuel inlet pressure always less than 3.45 kPaG [0.5 psig]?
YES NO
No Repair

High fuel pump inlet pressure has been detected. Check original equipment manufacturer (OEM) components to determine the cause of the high inlet pressure. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the fuel supply lines.

Guided Step 3A - Check the fuel supply lines.

Conditions

  • Turn the keyswitch OFF.

Action

Examine the fuel lines for damage or kinks.

Any fuel lines damaged or kinked?
YES NO

Replace the fuel line(s).

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the fuel pump actuator.

Guided Step 4A - Inspect the fuel pump actuator.

Conditions

  • Turn the keyswitch OFF.

Action

Inspect the fuel pump actuator for debris.

  • Remove the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.
  • Inspect the fuel pump actuator for debris or damage.

Debris or damage present?
YES NO

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 2262 - Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK23 CM2250 K109 | 4367358
Air In Fuel | Refer to Procedure 006-003 | QSK23 CM2250 K109 | 4367358
Fuel Filter (Spin-On Type) | Refer to Procedure 006-015 | QSK23 CM2250 K109 | 4367358
Fuel Pump Actuator | Refer to Procedure 019-117 | QSK23 CM2250 K109 | 4367358
Fuel Supply Pump Pressure Sensor | Refer to Procedure 019-398 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 316, 317, 659, or 3684 active or inactive counts?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verfiy the sensor accuracy with INSITE™ electronic service tool. | Fuel delivery pressure within 14 kPa [2 psi] of gauge or correlate with a known value?
STEP 3. | Check the engine fuel supply. |
 | STEP 3A. Check for adequte fuel supply. | Equipment/vehicle has an adequate fuel supply?
STEP 4. | Check the fuel lines. |
 | STEP 4A. Check the fuel lines. | Any fuel lines damaged, kinked, or leaking?
STEP 5. | Check for air in the fuel. |
 | STEP 5A. Check for air in the fuel. | Air present in the fuel?
STEP 6. | Check the fuel pump actuator. |
 | STEP 6A. Inspect the fuel pump actuator. | Debris or damage present?
STEP 7. | Check the ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector circuit fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 316, 317, 659, or 3684 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code Troubleshooting Tree.

Go to 2A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verfiy the sensor accuracy with INSITE™ electroinc service tool.

Conditions

  • Install a gauge or digital multimeter pressure sensor at the fuel pump outlet.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Monitor fuel delivery pressure with INSITE™ electronic service tool with engine OFF and at idle.
  • Compare the reading in INSITE™ with a gauge or known value.

Fuel delivery pressure within 14 kPa [2 psi] of gauge or correlate with a known value?
YES NO
No Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-398 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Check the engine fuel supply.

Guided Step 3A - Check for adequte fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank.

Equipment/vehicle has an adequate fuel supply?
YES NO
No Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 4A

Go to 7A

Guided Step 4 - Check the fuel lines.

Guided Step 4A - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel lines for the following:

  • Damage
  • Kinks
  • Leaks or loose fittings.

Refer to Procedure 006-024 in the Associated Procedures Table.

Any fuel lines damaged, kinked, or leaking?
YES NO

Repair the leak. Tighten or replace the leaking or damaged fuel line.

Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check for air in the fuel.

Guided Step 5A - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air present in the fuel?
YES NO

Check the original equipment manufacturer (OEM) fuel lines for loose fittings or damaged lines. See equipment manufacturer service information.

Inspect the fuel lines and fittings and tighten or replace, if necessary.

Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the fuel pump actuator.

Guided Step 6A - Inspect the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pump actuator for debris.

  • Remove the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.
  • Inspect the fuel pump actuator for debris or damage.

Debris or damage present?
YES NO

Replace the fuel pump actuator.

Refer to Procedure 019-117 in the Associated Procedures Table.

Replace the fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check the ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 2311 - Electronic Fuel Injection Control Valve Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fueling Actuator | Refer to Procedure 019-110 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2311 active?
 | STEP 1B. Read the fault codes. | Fault Code 279 or 455 active?
STEP 2. | Check the fuel rail actuator. |
 | STEP 2A. Inspect the fuel rail actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel rail actuator resistance. | Resistance between 7 and 9 ohms?
 | STEP 2C. Check the fuel rail actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 15 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness connection. | Fault Codes 2311, 279, and/or 455 become active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the fuel rail actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2311 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 279 or 455 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the fuel rail actuator.

Guided Step 2A - Inspect the fuel rail actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.

Action

Inspect the fuel rail actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel rail actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.

Action

Check the fuel rail actuator resistance.

  • Measure the resistance between the fuel rail actuator SIGNAL pin and the RETURN pin at the fuel rail actuator connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 7 and 9 ohms?
YES NO
No Repair

Replace the fuel rail actuator. Refer to Procedure 019-110 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel rail actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.

Action

Check the fuel rail actuator resistance.

  • Measure the resistance between the fuel rail actuator SIGNAL pin and the engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel rail actuator. Refer to Procedure 019-110 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and engine control module (ECM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail actuator to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance between the fuel rail actuator SIGNAL pin and the RETURN pin at the ECM engine harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail actuator from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check the engine harness and fuel rail actuator resistance.

  • Measure the resistance between the fuel rail actuator SIGNAL pin at in the engine harness connector at the ECM and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working over to the fuel rail actuator.

Fault Codes 2311, 279, and/or 455 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel rail actuator. Refer to Procedure 019-110 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 2312 - Timing Actuator Drive Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Timing Actuator | Refer to Procedure 019-111 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2312 active?
 | STEP 1A. Read the fault codes. | Fault Code 113 or 114 active?
STEP 2. | Check the timing rail actuator. |
 | STEP 2A. Inspect the timing rail actuator circuit and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the timing rail actuator resistance. | Resistance between 7 and 9 ohms?
 | STEP 2C. Check the timing rail actuator circuit for a short to ground. | Resistance greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Resistance less than 15 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Resistance greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Codes 2312, 113, and/or 114 become active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the timing rail actuator circuit is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2312 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 113 or 114 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the timing rail actuator.

Guided Step 2A - Inspect the timing rail actuator circuit and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator circuit from the engine harness connector.

Action

Inspect the timing rail actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the actuator circuit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the timing rail actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator circuit from the engine harness.

Action

Check the coil resistance of the timing rail actuator(s).

  • Measure the resistance from the timing rail actuator SUPPLY pin to the timing rail actuator RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 7 and 9 ohms?
YES NO
No Repair

Replace the timing rail actuator. Refer to Procedure 019-111 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the timing rail actuator circuit for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator circuit from the engine harness.

Action

Check the timing rail actuator resistance.

  • Measure the resistance between the timing rail actuator circuit SIGNAL pin and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Replace the timing rail actuator. Refer to Procedure 019-111 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and engine control module (ECM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the timing rail actuator circuit to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance between the timing rail actuator circuit SIGNAL pin and RETURN pin at the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 115 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the timing rail actuator circuit from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check the engine harness and timing rail actuator circuit resistance.

  • Measure the resistance between the timing rail actuator circuit SIGNAL pin in the engine harness connector at the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Measure the resistance between the timing rail actuator circuit SIGNAL pin at in the engine harness connector at the ECM connector of the engine harness and engine block ground.

Troubleshoot each harness connected in series to determine which contains the short to ground.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the fuel pump pressurizing assembly 1.

Fault Codes 2312, 113, and/or 114 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the timing rail actuator. Refer to Procedure 019-111 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step ? - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step ?B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2015


FAULT CODE 3684 - Fuel Supply Pump Actuator Driver Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Fuel Pump Actuator | Refer to Procedure 019-117 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3684 active?
 | STEP 1B. Read the fault codes. | Fault Code 316 or 317 active?
STEP 2. | Check the fuel pump actuator. |
 | STEP 2A. Inspect the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump actuator resistance. | Resistance between 7 and 9 ohms?
 | STEP 2C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 15 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness problem. | Fault Codes 316, 317, and/or 3684 become active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the fuel pump actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3684 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 316 or 317 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and RETURN pin at the fuel pump actuator connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 7 and 9 ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and engine control module (ECM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and RETURN pin at the ECM engine harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

Troubleshoot each harness connected in series to determine which contains the high resistance.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness connector at the ECM and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness connection.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or fault.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the fuel pump actuator.

Fault Codes 316, 317, and/or 3684 become active?
YES NO

An intermittent connection has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the intermittent open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-May-2015


FAULT CODE 3694 - Gain Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 187 inactive?
STEP 2. | Check the gain adjust potentiometer circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1418 active and Fault Code 3694 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 3694 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect the ECM, OEM harness, and engine harness connector. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3694 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault codes. | Fault Code 3694 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Reference Fault Code 187

Go to 2A

Guided Step 2 - Check the gain adjust potentiomemter circuit

Guided Step 2A - Inspect the original equipment manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the gain adjust potentiometer 5-volt SUPPLY (sensor supply 4) pin and the gain adjust potentiometer RETURN (sensor return 4) pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the gain adjust potentiometer 5-volt SUPPLY (sensor supply 4) and the gain adjust potentiometer SIGNAL pin at the OEM 31-pin connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1418 active and Fault Code 3694 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 active?
YES NO

An issue has been detected with the generator set controller. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector gain adjust potentiometer SIGNAL pin and the OEM 31-pin connector gain adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open gain adjust potentiometer signal circuit has been detected in the harnesses connected in series.

Troubleshoot each section of the harnesses connected in series to determine which contains the open circuit.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Secion 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or potentiometer is detected. Refer to the OEM service manual for repair instructions.

A pin-to-pin short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the gain adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged generator drive harness or potentiometer has been detected. Refer to the OEM service manual for repair instructions.

A pin-to-ground short circuit on the gain adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3694 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 3694 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-May-2015


FAULT CODE 3695 - Generator Output Frequency Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following tests leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3824774 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 352 active?
STEP 2. | Check the generator output frequency adjust potentiometer. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1411 active and Fault Code 3695 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3695 active?
STEP 3. | Check the ECM, OEM harness, and engine harness. |
 | STEP 3A. Inspect the ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3695 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault codes. | Fault Code 1411 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352

Go to 2A

Guided Step 2 - Check the generator output frequency adjust potentiometer circuit.

Guided Step 2A - Inspect the original equipment manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the generator output frequency adjust potentiometer 5 volt SUPPLY (sensor supply 4) pin and the generator output frequency adjust potentiometer RETURN (sensor return 4) pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the generator output frequency adjust potentiometer 5 volt SUPPLY (sensor supply 4) and the generator output frequency adjust potentiometer SIGNAL pin at the OEM 31-pin connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1411 active and Fault Code 3695 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 active?
YES NO

An issue has been detected with the generator set controller.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector generator output frequency adjust potentiometer SIGNAL pin and the OEM 31-pin connector generator output frequency adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator output frequency adjust potentiometer signal circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the generator output frequency adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the generator output frequency adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3695 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 3695 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-May-2015


FAULT CODE 3696 - Droop Adjust Potentiometer Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 352 active?
STEP 2. | Check the droop adjustment potentiometer circuit. |
 | STEP 2A. Inspect the original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1412 active and Fault Code 3696 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3696 is active?
STEP 3. | Check the engine control module (ECM), OEM harness, and engine harness. |
 | STEP 3A. Inspect ECM, OEM harness, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3696 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 3696 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 352 active?
YES | NO
No Repair | No Repair

Reference Fault Code 352

Go to 2A

Guided Step 2 - Check the droop adjustment potentiometer circuit.

Guided Step 2A - Inspect the original equipment manufacturer (OEM) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the load share equipment or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the OEM 31-pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the droop adjust potentiometer SUPPLY pin and the droop adjust potentiometer RETURN pin at the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general mulitmeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the OEM 31-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the droop adjust potentiometer SUPPLY pin and the droop adjust potentiometer SIGNAL pin at the OEM 31-pin connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1412 active and Fault Code 3696 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the OEM 31-pin connector..
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 is active?
YES NO

An issue has been detected with the gen set controller.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM), OEM harness, and engine harness.

Guided Step 3A - Inspect ECM, OEM harness, and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connectors from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Inspect the OEM harness, engine harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector, OEM harness connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector droop adjust potentiometer SIGNAL pin and the OEM 31-pin connector droop adjust potentiometer SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open generator droop adjust potentiometer signal circuit has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness connector from the OEM 31-pin connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the droop adjust potentiometer SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the droop adjust potentiometer SIGNAL wire has been detected in the harnesses connected in series.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the harnesses.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3696 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 3696 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-May-2015


INDEX
266-fc112.htm

266-t05-112.htm

266-fc113.htm

266-t05-113.htm

266-fc114.htm

266-t05-114.htm

266-fc116.htm

266-t05-116.htm

266-fc117.htm

266-t05-117.htm

266-fc121.htm

266-t05-121.htm

266-fc122.htm

00-t05-122.htm

266-fc123.htm

00-t05-123.htm

266-fc135.htm

00-t05-135.htm

266-fc141.htm

00-t05-141.htm

266-fc143.htm

00-t05-143.htm

266-fc144.htm

00-t05-144.htm

266-fc145.htm

00-t05-145.htm

266-fc146.htm

00-t05-146.htm

266-fc151.htm

00-t05-151.htm

266-fc153.htm

00-t05-153.htm

266-fc154.htm

00-t05-154.htm

266-fc155.htm

00-t05-155.htm

266-fc187.htm

266-t05-187.htm

266-fc195.htm

266-t05-195.htm

266-fc196.htm

266-t05-196.htm

266-fc197.htm

266-t05-197.htm

266-fc221.htm

266-t05-221.htm

266-fc222.htm

266-t05-222.htm

266-fc223.htm

266-t05-223.htm

266-fc224.htm

266-t05-224.htm

266-fc227.htm

266-t05-227.htm

266-fc234.htm

00-t05-234.htm

266-fc235.htm

266-t05-235.htm

266-fc238.htm

00-t05-238.htm

266-fc239.htm

00-t05-239.htm

266-fc254.htm

266-t05-254.htm

266-fc255.htm

266-t05-255.htm

266-fc257.htm

266-t05-257.htm

266-fc261.htm

266-t05-261.htm

266-fc263.htm

266-t05-263.htm

266-fc265.htm

266-t05-265.htm

266-fc266.htm

266-t05-266.htm

266-fc279.htm

266-t05-279.htm

266-fc285.htm

00-t05-285.htm

266-fc286.htm

00-t05-286.htm

266-fc316.htm

266-t05-316.htm

266-fc317.htm

266-t05-317.htm

266-fc319.htm

266-t05-319.htm

266-fc342.htm

266-t05-342.htm

266-fc352.htm

266-t05-352.htm

266-fc386.htm

266-t05-386.htm

266-fc415.htm

00-t05-415.htm

266-fc423.htm

266-t05-423.htm

266-fc426.htm

266-t05-426.htm

266-fc441.htm

00-t05-441.htm

266-fc442.htm

00-t05-442.htm

266-fc449.htm

266-t05-449.htm

266-fc451.htm

00-t05-451.htm

266-fc452.htm

00-t05-452.htm

266-fc455.htm

266-t05-455.htm

266-fc488.htm

214-t05-488.htm

266-fc515.htm

266-t05-515.htm

266-fc516.htm

266-t05-516.htm

266-fc546.htm

266-t05-546.htm

266-fc547.htm

266-t05-547.htm

266-fc559.htm

266-t05-559.htm

266-fc689.htm

00-t05-689.htm

266-fc1117.htm

00-t05-1117.htm

266-fc1411.htm

266-t05-1411.htm

266-fc1412.htm

266-t05-1412.htm

266-fc1418.htm

266-t05-1418.htm

266-fc1427.htm

266-t05-1427.htm

266-fc1428.htm

266-t05-1428.htm

266-fc1429.htm

266-t05-1429.htm

266-fc1431.htm

266-t05-1431.htm

266-fc1432.htm

266-t05-1432.htm

266-fc1597.htm

266-t05-1597.htm

266-fc1695.htm

266-t05-1695.htm

266-fc1696.htm

266-t05-1696.htm

266-fc1847.htm

00-t05-1847.htm

266-fc1891.htm

214-t05-1891.htm

266-fc1978.htm

266-t05-1978.htm

266-fc1979.htm

266-t05-1979.htm

266-fc1992.htm

266-t05-1992.htm

266-fc2185.htm

00-t05-2185.htm

266-fc2186.htm

00-t05-2186.htm

266-fc2261.htm

266-t05-2261.htm

266-fc2262.htm

266-t05-2262.htm

266-fc2311.htm

266-t05-2311.htm

266-fc2312.htm

266-t05-2312.htm

266-fc2661.htm

00-t05-2661.htm

266-fc2662.htm

00-t05-2662.htm

266-fc3684.htm

266-t05-3684.htm

266-fc3694.htm

266-t05-3694.htm

266-fc3695.htm

266-t05-3695.htm

266-fc3696.htm

266-t05-3696.htm